smf: SMF (Social Mobile Framework Interfaces)

  • Main Page
  • Related Pages
  • Modules
  • Namespaces
  • Classes
  • Files

SMF (Social Mobile Framework Interfaces)

version 0.1

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Nalina Hariharan,Satish Kanteti, Rajat Roy

Description: Intro Page

SMF Interfaces and Usage

Generated on Thu Sep 23 15:03:07 2010 for smf by doxygen 1.6.3


smf: Todo List

  • Namespaces
  • Classes
  • Files

Todo List

Member CSmfCredMgrClientSymbian::signMessageL (QString Message, QString Key, QString &Signature, SmfSignatureMethod AlgorithmUsed)
- RSA Signing is falgged-put for time being.

Member SmfCredMgrClient::ChangePluginIDList (QString NewPluginID, bool Flag, QString OldPluginID)
- should return an error code to indicate error while changing the list.

Member SmfCredMgrClient::SignMessage (QString Message, QString Key, QString &Signature, SmfSignatureMethod AlgorithmUsed)
- RSA Signing is falgged-put for time being.
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: Module Index

Modules

Here is a list of all modules:
  • SMF Interfaces and Usage
  • Common Data Classes
  • Client Classes
  • Plugin Classes
  • CredMgr Classes
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: SMF Interfaces and Usage

SMF Interfaces and Usage

Social Mobile Framework is a application level framework which allows Qt Applications use the common web APIs to perform social web activities.

Product name is "SMF"

For details please refer to http://developer.symbian.org/wiki/index.php/Social_Mobile_Framework

SMF Interfaces

Native applications can use SMF, via Client APIs. Service Providers can provide smf plugins, via Plugin APIs. Both would use Common APIs for common data classes Service Providers can optionaliy use Credential Manager APIs

Here is the list of public interfaces ( exported to /epoc32/include ) -

Client Interfaces

  • Client Applications (e.g. Media Player, Contacts, Game) uses these APIs to access SMF. see Client Classes

Plugin Interfaces

  • Service Providers (e.g. Facebook, Flickr, last.fm) implements these APIs to provide service to SMF - see Plugin Classes

Common Interfaces

  • Both plugins and smfclient uses these for representing data - see Common Data Classes

CredMgr Interfaces

  • Credential Manager provides APIs for digital signing, storing and retrieving keys, etc - see CredMgr Classes

Client Usage Example

  • / example / DemoGUI / HomeView.cpp shows how to use the SMF client APIs in applications, e.g. Client can define suitable Models using lists returned by these APIs.
    • how to fetch a list of contacts from a remote server e.g. Facebook, see HomeView::getFriends()
    • how to get a list of posts from a remote server e.g. Facebook, see HomeView::getPosts()
    • how to get a list of images from a remote gallery e.g. Flickr.com, see HomeView::getAlbums()
    • how to list all the activities that has happened recently, see HomeView::getActivities()

Sample Plugin From Service provider

  • This shows how to write a plugin for extending SMF service.
    • how to create request to be sent to a remote server for fetching contacts e.g.Facebook.com, see FBContactFetcherPlugin::friends
    • how to implement the fetching of posts or comment, FBPostProviderPlugin::getPosts()
    • how to parse the response that arrived from Facebook.com for fetching activities, see FBActivityFetcherPlugin::responseAvailable()
    • how to use JSON parsing from SmfPluginUtil, see FBPostProviderPlugin::responseAvailable()

Authentication Application also needs to be provided for these plugins.

Custom API in SMF

  • SMF strives to provide service API for generic "common" social operations. However this doesn't mean that developers have to use other propriatery APIs to access service specific "differentiating" features. Service Providers can provide plugins which support APIs like SmfGalleryPlugin::customRequest(). A separate library would also be provided by service providers to help SMF clients use this custom API

Dependency

  • SMF uses Qt 4.6.2 on Symbian^3 ( Nokia_Symbian3_SDK_v0.8 to be specific )
  • SMF uses QtMobility 1.0 for mainly contacts information, see QtMobility project.
  • SMF uses QJson as utility library, courtesy Flavio Castelli , see http://gitorious.org/qjson/qjson

Notes:

  • SMF defines the social activities with inspiration from http://activitystrea.ms/
  • Other such open standards would soon find their usage in SMF, one such candidate is http://xspf.org/
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: Common Data Classes

Common Data Classes

Classes

class | SmfActivityObject
class | SmfActivityEntry
class | SmfAlbum
class | SmfArtists
class | SmfComment
class | SmfContact
class | SmfEvent
class | SmfGroup
class | SmfLocation
class | SmfLyrics
class | SmfMusicFingerPrint
class | SmfMusicProfile
class | SmfMusicRating
class | SmfPicture
class | SmfPictureAlbum
class | SmfPlaylist
class | SmfPost
class | SmfSubtitle
class | SmfTrackInfo
class | SmfUrl
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: Client Classes

Client Classes

Classes

class | SmfActivityFetcher
class | SmfClient
class | SmfContactFetcher
class | SmfEventsFetcher
class | SmfGallery
class | SmfMusicService
class | SmfPostProvider
class | SmfRelationItem
class | SmfProvider
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: Plugin Classes

Plugin Classes

Classes

class | SmfActivityFetcherPlugin
class | SmfContactFetcherPlugin
class | SmfEventsFetcherPlugin
class | SmfGalleryPlugin
class | SmfLyricsServicePlugin
class | SmfMusicSearchPlugin
class | SmfMusicServicePlugin
class | SmfPlaylistServicePlugin
class | SmfPluginBase
class | SmfPostProviderPlugin
class | SmfProviderBase
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: CredMgr Classes

CredMgr Classes

Classes

class SmfCredMgrClient

Enumerations

enum SmfSignatureMethod {
ESmfNoSigningMethod = 0, ESMFRSAProtocol, ESMFHMACProtocol, ESMFPlainText,
ESMFSHA256Protocol
}

Enumeration Type Documentation

enum SmfSignatureMethod

Enumeration to represent Cryptographic Algorithm useds

Enumerator:
ESmfNoSigningMethod

Enum for no algorithm

ESMFRSAProtocol

Enum for algorithm RSA-SHA1

ESMFHMACProtocol

Enum for algorithm HMAC-SHA1

ESMFPlainText

Enum for Plain Tezt

ESMFSHA256Protocol

Enum for SHA256

Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: Class List

  • Class List
  • Class Hierarchy
  • Class Members

Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
AuthApp |
Ui::AuthAppClass |
CPFIndSettings |
CSessionStruct |
CSmfClientSymbian |
CSmfCredMgrClientSymbian |
CSmfCredMgrDb |
CSmfCredMgrDbUser |
CSmfCredMgrServer |
CSmfCredMgrServerSession |
CSmfFetchAuthTokenSet |
CSmfKeyStoreManager |
CSmfPluginIDListParams |
CSmfPluginIDUpdate |
CSmfRsaKeyParameters |
CSmfSignParameters |
CSmfStoreAuthParams |
CSmfURLListParams |
CustomListWidget |
DataStoreManager |
DisplayWidget |
Ui::DisplayWidgetClass |
DSMContactPckg |
FBActivityFetcherPlugin |
FBActivityProviderBase |
FBContactFetcherPlugin |
FBContactProviderBase |
FBDialog |
FBError |
FBLoginDialog |
FBPostProviderPlugin |
FBProviderBase |
FBRequest |
FBSession |
FBXMLHandler |
FlickrContactFetcherPlugin |
FlickrGalleryPlugin |
FlickrProviderBase |
FriendView |
GridView | Its not in use at this poin
HomeView |
ImageDownload |
yy::json_parser | A Bison parser
JSonScanner |
LastFmMusicSearchPlugin |
LastFmMusicSearchProviderBase |
LastFmMusicServicePlugin |
LastFmMusicServiceProviderBase |
LastFmPlaylistServicePlugin |
LastFmPlaylistServiceProviderBase |
yy::location | Abstract a location
MainWindow |
Ui::MainWindow |
MusicEventPlugin |
MusicLyricsPlugin |
MusicProviderBase |
MyApplication |
MyAppView |
QJson::Parser | Main class used to convert JSON data to QVariant objects
QJson::ParserPrivate |
QJson::ParserRunnable | Convenience class for converting JSON data to QVariant objects using a dedicated thread
Person |
yy::position | Abstract a position
PostTestUi |
Ui::PostTestUiClass |
QJson::ParserRunnable::Private |
QJson::SerializerRunnable::Private |
progressbar |
Ui::progressbarClass |
QJson::QObjectHelper | Class used to convert QObject into QVariant and vivce-versa. During these operations only the class attributes defined as properties will be considered
QJson::QObjectHelper::QObjectHelperPrivate |
RSmfClientSymbianSession |
RSmfCredMgrClientSession |
SamplePlugin |
SampleProviderBase |
ScreenSize |
QJson::Serializer | Main class used to convert QVariant objects to JSON data
QJson::Serializer::SerializerPrivate |
QJson::SerializerRunnable | Convenience class for converting JSON data to QVariant objects using a dedicated thread
yy::slice< T, S > | Present a slice of the top of a stack
SmfActivityEntry |
SmfActivityEntryPrivate |
SmfActivityFetcher |
SmfActivityFetcherPlugin |
SmfActivityFetcherPrivate |
SmfActivityObject |
SmfActivityObjectPrivate |
SmfAlbum |
SmfAlbumPrivate |
SmfArtists |
SmfArtistsPrivate |
SmfClient |
SmfClientApp |
Ui::SmfClientApp |
SmfClientAuthID |
SmfClientPrivate |
SmfClientQt |
SmfComment |
SmfCommentPrivate |
SmfContact |
SmfContactFetcher |
SmfContactFetcherPlugin |
SmfContactFetcherPrivate |
SmfContactPrivate |
SmfCredMgrClient |
SmfEvent |
SmfEventPrivate |
SmfEventsFetcher |
SmfEventsFetcherPlugin |
SmfEventsFetcherPrivate |
SmfGallery |
SmfGalleryPlugin |
SmfGalleryPrivate |
SmfGroup |
SmfGroupPrivate |
SmfLocation |
SmfLocationPrivate |
SmfLyrics |
SmfLyricsPrivate |
SmfLyricsService |
SmfLyricsServicePlugin |
SmfLyricsServicePrivate |
SmfMusicFingerPrint |
SmfMusicFingerPrintPrivate |
SmfMusicProfile |
SmfMusicProfilePrivate |
SmfMusicRating |
SmfMusicRatingPrivate |
SmfMusicSearch |
SmfMusicSearchPlugin |
SmfMusicSearchPrivate |
SmfMusicService |
SmfMusicServicePlugin |
SmfMusicServicePrivate |
smfObserver |
SmfPicture |
SmfPictureAlbum |
SmfPictureAlbumPrivate |
SmfPicturePrivate |
SmfPlaylist |
SmfPlaylistPrivate |
SmfPlaylistService |
SmfPlaylistServicePlugin |
SmfPlaylistServicePrivate |
SmfPluginBase |
SmfPluginDataUsage |
SmfPluginManager |
SmfPluginManagerUtil |
SmfPluginRequestData |
SmfPluginUtil |
SmfPost |
SmfPostPrivate |
SmfPostProvider |
SmfPostProviderPlugin |
SmfPostProviderPrivate |
SmfProvider |
SmfProviderBase |
SmfRelationItem |
SmfRelationMgr |
SmfRelationMgrPrivate |
SmfResultPage |
SmfServer |
SmfServerQt |
SmfServerQtSession |
SmfServerSymbian |
SmfServerSymbianSession |
SMFSettings |
SmfSettingsHandler |
SmfSettingsRepositoryQt |
SMFSocialNetworkingSite | This class represents a social networking site
SMFSocialProfile | This class represents a user's public profile on a social networking site
SmfSubtitle |
SmfSubtitlePrivate |
SmfTrackInfo |
SmfTrackInfoPrivate |
SmfTransportManager |
SmfTransportManagerUtil |
SmfUrl |
SmfUrlPrivate |
SMFUserProfile | This class represents a user's profile
SmfWaitingPluginInfoStruc |
yy::stack< T, S > |
TestParser |
TestQObjectHelper |
TestScreen |
TestSerializer |
yy::json_parser::token | Tokens
ToolBar |
TSmfAuthToken |
Ui_AuthAppClass |
Ui_DisplayWidgetClass |
Ui_MainWindow |
Ui_PostTestUiClass |
Ui_progressbarClass |
Ui_SmfClientApp |
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: AuthApp Class Reference

AuthApp Class Reference

#include <AuthApp.h>

List of all members.

Public Member Functions

AuthApp (QWidget *parent=0)
AuthApp (QWidget *parent=0)

Protected Member Functions

void | changeEvent (QEvent *e)
void | changeEvent (QEvent *e)

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "{License}" which accompanies this distribution, and is available at the URL "{LicenseUrl}".

Initial Contributors: Narasimhulu Kavadapu, Sasken Communication Technologies Ltd - Initial contribution

Contributors:

Description: UI Class of Authentication Application

Constructor & Destructor Documentation

AuthApp::AuthApp ( QWidget * parent = 0 )

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "{License}" which accompanies this distribution, and is available at the URL "{LicenseUrl}".

Initial Contributors: Narasimhulu Kavadapu, Sasken Communication Technologies Ltd - Initial contribution

Contributors:

Description: UI Class of Authentication Application

The documentation for this class was generated from the following files:
  • example/AuthApp/AuthApp.h
  • example/FlickrAuthApp/AuthApp.h
  • example/AuthApp/AuthApp.cpp
  • example/FlickrAuthApp/AuthApp.cpp
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Member List

AuthApp Member List

This is the complete list of members for AuthApp, including all inherited members.
AuthApp(QWidget *parent=0) | AuthApp |
AuthApp(QWidget *parent=0) (defined in AuthApp) | AuthApp |
changeEvent(QEvent *e) (defined in AuthApp) | AuthApp | [protected]
changeEvent(QEvent *e) (defined in AuthApp) | AuthApp | [protected]
~AuthApp() (defined in AuthApp) | AuthApp |
~AuthApp() (defined in AuthApp) | AuthApp |
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Ui::AuthAppClass Class Reference

Ui::AuthAppClass

Ui::AuthAppClass Class Reference

Inherits Ui_AuthAppClass, and Ui_AuthAppClass.

List of all members.

The documentation for this class was generated from the following file:
  • example/AuthApp/ui_AuthApp.h
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: Member List

Ui::AuthAppClass Member List

This is the complete list of members for Ui::AuthAppClass, including all inherited members.
buttonForget (defined in Ui_AuthAppClass) | Ui_AuthAppClass |
centralWidget (defined in Ui_AuthAppClass) | Ui_AuthAppClass |
pushButton (defined in Ui_AuthAppClass) | Ui_AuthAppClass |
retranslateUi(QMainWindow *AuthAppClass) (defined in Ui_AuthAppClass) | Ui_AuthAppClass | [inline]
retranslateUi(QMainWindow *AuthAppClass) (defined in Ui_AuthAppClass) | Ui_AuthAppClass | [inline]
setupUi(QMainWindow *AuthAppClass) (defined in Ui_AuthAppClass) | Ui_AuthAppClass | [inline]
setupUi(QMainWindow *AuthAppClass) (defined in Ui_AuthAppClass) | Ui_AuthAppClass | [inline]
verticalLayout (defined in Ui_AuthAppClass) | Ui_AuthAppClass |
verticalSpacer (defined in Ui_AuthAppClass) | Ui_AuthAppClass |
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: CPFIndSettings Class Reference

CPFIndSettings Class Reference

#include <PlatfromIndependentSettings.h>

List of all members.

Public Member Functions

~CPFIndSettings ()
CPFIndSettings ()
void | SetPluginDetails (QString &aPluginName, QString &aPluginStatus)
void | SetAuthExpirationValue (QString &aVal)
void | SetMaxDataTransferLimit (QString &aVal)
void | SetRoamingStatusforDataTransfer (QString &aStatus)
void | SetUploadFileType (QString &aFileType)
QStringList | GetPluginDetails () const
QString | GetAuthExpirationValue () const
QString | GetMaxDataTransferLimit () const
QString | GetRoamingStatusforDataTransfer () const
QString | GetUploadFileType () const

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "{License}" which accompanies this distribution, and is available at the URL "{LicenseUrl}".

Initial Contributors: Narasimhulu Kavadapu, Sasken Communication Technologies Ltd - Initial contribution

Contributors:

Description: Platform Independent Settings Class

An instance Platform Independent Settings class to set/get setting values to/from symbian repository.

Constructor & Destructor Documentation

CPFIndSettings::~CPFIndSettings ( )

~CPFIndSettings

Destroy the object and release all memory objects

CPFIndSettings::CPFIndSettings ( )

CPFIndSettings

Construct the Settings Object

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "{License}" which accompanies this distribution, and is available at the URL "{LicenseUrl}".

Initial Contributors: Narasimhulu Kavadapu, Sasken Communication Technologies Ltd - Initial contribution

Contributors:

Description: Platform Independent Settings Class

The documentation for this class was generated from the following files:
  • smf/smfsettingsui/PlatfromIndependentSettings.h
  • smf/smfsettingsui/PlatfromIndependentSettings.cpp
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Member List

CPFIndSettings Member List

This is the complete list of members for CPFIndSettings, including all inherited members.
CPFIndSettings() | CPFIndSettings
GetAuthExpirationValue() const (defined in CPFIndSettings) | CPFIndSettings
GetMaxDataTransferLimit() const (defined in CPFIndSettings) | CPFIndSettings
GetPluginDetails() const (defined in CPFIndSettings) | CPFIndSettings
GetRoamingStatusforDataTransfer() const (defined in CPFIndSettings) | CPFIndSettings
GetUploadFileType() const (defined in CPFIndSettings) | CPFIndSettings
SetAuthExpirationValue(QString &aVal) (defined in CPFIndSettings) | CPFIndSettings
SetMaxDataTransferLimit(QString &aVal) (defined in CPFIndSettings) | CPFIndSettings
SetPluginDetails(QString &aPluginName, QString &aPluginStatus) (defined in CPFIndSettings) | CPFIndSettings
SetRoamingStatusforDataTransfer(QString &aStatus) (defined in CPFIndSettings) | CPFIndSettings
SetUploadFileType(QString &aFileType) (defined in CPFIndSettings) | CPFIndSettings
~CPFIndSettings() | CPFIndSettings
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: CSessionStruct Struct Reference

CSessionStruct Struct Reference

#include <smfserversymbian_p.h>

List of all members.

Public Attributes

SmfServerSymbianSession * | iSession
RMessage2 | iMsg

Detailed Description

Stores session and request information. For now storing RMessage2 is reduntant as we are allowing only one outstanding request per session

The documentation for this struct was generated from the following file:
  • smf/smfservermodule/smfserver/server/smfserversymbian_p.h
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Member List

CSessionStruct Member List

This is the complete list of members for CSessionStruct, including all inherited members.
iMsg (defined in CSessionStruct) | CSessionStruct
iSession (defined in CSessionStruct) | CSessionStruct
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: CSmfClientSymbian Class Reference

CSmfClientSymbian Class Reference

#include <smfclientsymbian.h>

List of all members.

Public Member Functions

virtual | ~CSmfClientSymbian ()
QByteArray | sendRequest (QString aInterfaceName, SmfRequestTypeID requestType, TInt aMaxAllocation, QByteArray &aSerializedData)
QByteArray | sendSyncRequest (QString aInterfaceName, SmfRequestTypeID requestType, TInt maxSize, QByteArray &aSerializedData)
QByteArray | sendDSMSyncRequest (SmfRequestTypeID requestType, QByteArray &aSerializedData, SmfError &aErr, TInt maxSize=10)
TInt | sendRequest (QByteArray &aSerializedData, QString aInterfaceName, SmfRequestTypeID requestType, TInt aMaxAllocation)
void | CancelRequest ()

Static Public Member Functions

static CSmfClientSymbian * | NewL (smfObserver *aObserver=NULL)
static CSmfClientSymbian * | NewLC (smfObserver *aObserver)

Protected Member Functions

void | RunL ()
void | DoCancel ()
TInt | RunError (TInt aError)

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Describes the classes that implement the symbian client part of Smf server. Private client implementation for Symbian. Private client implementation for Symbian.

Constructor & Destructor Documentation

CSmfClientSymbian::~CSmfClientSymbian ( ) [virtual]

Destructor. Destroys the object and release all memory objects.

Member Function Documentation

void CSmfClientSymbian::CancelRequest ( )

CancelRequest. Cancels an outstanding request.

void CSmfClientSymbian::DoCancel ( ) [protected]

From CActive, DoCancel. Cancels any outstanding operation.

CSmfClientSymbian * CSmfClientSymbian::NewL ( smfObserver * aObserver = NULL ) [static]

Two phase contruction - NewL

Parameters:
aObserver For callback
CSmfClientSymbian * CSmfClientSymbian::NewLC ( smfObserver * aObserver ) [static]

Two phase contruction - NewLC

Parameters:
aObserver For callback
TInt CSmfClientSymbian::RunError ( TInt aError ) [protected]

From CActive, RunError.

void CSmfClientSymbian::RunL ( ) [protected]

From CActive, RunL. Callback function. Invoked to handle responses from the server.

QByteArray CSmfClientSymbian::sendDSMSyncRequest | ( | SmfRequestTypeID | requestType,
 |  | QByteArray & | aSerializedData,
 |  | SmfError & | aErr,
 |  | TInt | maxSize = 10
 | ) |  |

For sending request specific to DSM. These are used by SmfRelationMngr API

Parameters:
requestType | Opcode
aSerializedData | Data to be passed to DSM through server, interpretation depends on Relation manager and DSM Size to be allocated in the client side
Returns:
Data received from server, interpretation depends on SmfRelationMngr and DSM
TInt CSmfClientSymbian::sendRequest | ( | QByteArray & | aSerializedData,
 |  | QString | aInterfaceName,
 |  | SmfRequestTypeID | requestType,
 |  | TInt | aMaxAllocation
 | ) |  |

Calls SendReceive (Asynchronous) of the RSessionBase object.

Parameters:
aSerializedData | serialized by the caller.
aInterfaceName | Interface name
requestType | Opcode
aMaxAllocation | Max data size that is allocated in the client side for receiving this data
xtraInfo | XtraInfo when required by server other than smfProvider
QByteArray CSmfClientSymbian::sendRequest | ( | QString | aInterfaceName,
 |  | SmfRequestTypeID | requestType,
 |  | TInt | aMaxAllocation,
 |  | QByteArray & | aSerializedData
 | ) |  |

This overloaded API is for Synchronous calls to plugin APIs

Parameters:
aSerializedData | serialized by the caller.
aInterfaceName | Interface name
requestType | Opcode
aMaxAllocation | Max data size that is allocated in the client side for receiving this data
Returns:
QByteArray
QByteArray CSmfClientSymbian::sendSyncRequest | ( | QString | aInterfaceName,
 |  | SmfRequestTypeID | requestType,
 |  | TInt | maxSize,
 |  | QByteArray & | aSerializedData
 | ) |  |

This API is for Synchronous calls to server

Parameters:
aInterfaceName | Interface name
requestType | Opcode
maxSize | Max data size that is allocated in the client side for receiving this data
aSerializedData | serialized by the caller.
Returns:
QByteArray
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfclientsymbian.h
  • smf/smfservermodule/smfclient/smfclientsymbian.cpp
Generated on Thu Sep 23 15:03:21 2010 for smf by doxygen 1.6.3


smf: Member List

CSmfClientSymbian Member List

This is the complete list of members for CSmfClientSymbian, including all inherited members.
CancelRequest() | CSmfClientSymbian |
DoCancel() | CSmfClientSymbian | [protected]
NewL(smfObserver *aObserver=NULL) | CSmfClientSymbian | [static]
NewLC(smfObserver *aObserver) | CSmfClientSymbian | [static]
RunError(TInt aError) | CSmfClientSymbian | [protected]
RunL() | CSmfClientSymbian | [protected]
sendDSMSyncRequest(SmfRequestTypeID requestType, QByteArray &aSerializedData, SmfError &aErr, TInt maxSize=10) | CSmfClientSymbian |
sendRequest(QString aInterfaceName, SmfRequestTypeID requestType, TInt aMaxAllocation, QByteArray &aSerializedData) | CSmfClientSymbian |
sendRequest(QByteArray &aSerializedData, QString aInterfaceName, SmfRequestTypeID requestType, TInt aMaxAllocation) | CSmfClientSymbian |
sendSyncRequest(QString aInterfaceName, SmfRequestTypeID requestType, TInt maxSize, QByteArray &aSerializedData) | CSmfClientSymbian |
~CSmfClientSymbian() | CSmfClientSymbian | [virtual]
Generated on Thu Sep 23 15:03:21 2010 for smf by doxygen 1.6.3


smf: CSmfCredMgrClientSymbian Class Reference

CSmfCredMgrClientSymbian Class Reference

#include <smfcredmgrclient_p.h>

List of all members.

Public Member Functions

~CSmfCredMgrClientSymbian ()
QString | storeAuthDataL (SmfAuthParams Set, QDateTime Validity, QList< QUrl > URLList, QStringList PluginList, QString AuthAppAID, bool Flag)
TBool | isPluginAuthenticatedL (QString PluginID)
void | authenticatedPluginListL (QString RegistrationToken, QStringList &List)
void | URLListL (QString PluginID, QList< QUrl > &List)
QString | generateNONCE (const qint64 Length)
void | changePluginIDListL (const QString NewPluginID, const bool Flag, const QString OldPluginID)
TBool | AuthDataSetL (QString RegToken, QDateTime Validity, SmfAuthParams &AuthTokenSet)
QString | storeRSAKeysL (const QString KeyLabel, const QString keydata, const QDateTime Validity)
SMFCredMgrErrorCode | signMessageL (QString Message, QString Key, QString &Signature, SmfSignatureMethod AlgorithmUsed)
void | deleteRSAKey (QString KeyLabel)

Static Public Member Functions

static CSmfCredMgrClientSymbian * | NewL (SmfCredMgrClient *aPublicImpl)
static CSmfCredMgrClientSymbian * | NewLC (SmfCredMgrClient *aPublicImpl)

Protected Member Functions

void | RunL ()
void | DoCancel ()

Detailed Description

The private implementation class for the APIs exported by Credential Manager. Its a symbian implementation.

Constructor & Destructor Documentation

CSmfCredMgrClientSymbian::~CSmfCredMgrClientSymbian ( )

Destructor

Member Function Documentation

TBool CSmfCredMgrClientSymbian::AuthDataSetL | ( | QString | RegToken,
 |  | QDateTime | Validity,
 |  | SmfAuthParams & | AuthTokenSet
 | ) |  |

Method to get the Auth Token set, eg:OAuth_RequestToken; OAuth_AccessToken

Parameters:
RegToken | Registration Token previously obtained from SMF
Validity | time by which the Auth set will expire, its to check if reg token is still valid
AuthTokenSet | the Auth Token Set for the plugin
Returns:
boolean value if the reg token is still valid
void CSmfCredMgrClientSymbian::authenticatedPluginListL | ( | QString | RegistrationToken,
 |  | QStringList & | List
 | ) |  |

Method to get the list of authenticated plugins

Parameters:
RegistrationToken | The token that validates a list of such plugins.
List | The list of authenticated plugins to be retrieved
void CSmfCredMgrClientSymbian::changePluginIDListL | ( | const QString | NewPluginID,
 |  | const bool | Flag,
 |  | const QString | OldPluginID
 | ) |  |

Method to update the list of authenticated plugins-add, remove, update to plugins Called by changePluginIDList() of SmfCredMgrClient.

Parameters:
NewPluginID | ID of the new plugin
Flag | boolean to indicate plugin is enabled or disabled
OldPluginID | ID of the old plugin to be replaced
void CSmfCredMgrClientSymbian::deleteRSAKey ( QString KeyLabel )

API To delete the RSA Key from the Key Store

Parameters:
KeyLabel The Label of key pair. This is the value returned while StoreRSAKeys().
void CSmfCredMgrClientSymbian::DoCancel ( ) [protected]

From CActive, DoCancel. Cancels any outstanding operation.

QString CSmfCredMgrClientSymbian::generateNONCE ( const qint64 Length )

Method to generate NONCE token

Parameters:
Length Lenth of the NONCE tobe generated
Returns:
The generated NONCE
TBool CSmfCredMgrClientSymbian::isPluginAuthenticatedL ( QString PluginID )

Method to check the authentication of a Plugin

Parameters:
PluginID Id of the Plugin to be checked.
Returns:
True if authenticated or False if not
CSmfCredMgrClientSymbian * CSmfCredMgrClientSymbian::NewL ( SmfCredMgrClient * aPublicImpl ) [static]

new methods

Parameters:
aPublicImpl The Qt client object
void CSmfCredMgrClientSymbian::RunL ( ) [protected]

From CActive, RunL. Callback function. Invoked to handle responses from the server.

SMFCredMgrErrorCode CSmfCredMgrClientSymbian::signMessageL | ( | QString | Message,
 |  | QString | Key,
 |  | QString & | Signature,
 |  | SmfSignatureMethod | AlgorithmUsed
 | ) |  |

API to Sign the message

Parameters:
Message | The message to be signed
Key | If Signature method is RSA-SHA1 then it must be equal to the value returned while storeRSAKeys(), if signature method is HMAC-SHA1 key must the value to sign the message with
Signature | The signed message is an output argument
AlgorithmUsed | The algorithm used for signing return Smf defined errorcode
Todo:
  • RSA Signing is falgged-put for time being.
QString CSmfCredMgrClientSymbian::storeAuthDataL | ( | SmfAuthParams | Set,
 |  | QDateTime | Validity,
 |  | QList< QUrl > | URLList,
 |  | QStringList | PluginList,
 |  | QString | AuthAppAID,
 |  | bool | Flag
 | ) |  |

Method to store all data related to an auth app i.e URL list for Plugins, List of Plugins.etc. Called by storeAuthData() of SmfCredMgrClient.

Parameters:
Set | The auth Key set
Validity | time by which the Auth set will expire
URLList | The URL list to be set
PluginList | The plugin list to be set
AuthAppAID | The Authentication Application Id
Flag | flag to enable or disable the plugin
Returns:
The registration token that completes authentication
QString CSmfCredMgrClientSymbian::storeRSAKeysL | ( | const QString | KeyLabel,
 |  | const QString | keydata,
 |  | const QDateTime | Validity
 | ) |  |

Method to store RSA Keys

Parameters:
KeyLabel | First key of the key pair
keydata | Other key of the key pair
Validity | time by which the key set will expire
Returns:
The Label of key pair
void CSmfCredMgrClientSymbian::URLListL | ( | QString | PluginID,
 |  | QList< QUrl > & | List
 | ) |  |

Method to get list of URLs which plugin can access

Parameters:
PluginID | The ID of the Plugin whose corresponding list of URLs to be retrieved
List | The URL list to be retrieved
The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclient_p.h
  • smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclient_p.cpp
Generated on Thu Sep 23 15:03:21 2010 for smf by doxygen 1.6.3


smf: Member List

CSmfCredMgrClientSymbian Member List

This is the complete list of members for CSmfCredMgrClientSymbian, including all inherited members.
AuthDataSetL(QString RegToken, QDateTime Validity, SmfAuthParams &AuthTokenSet) | CSmfCredMgrClientSymbian |
authenticatedPluginListL(QString RegistrationToken, QStringList &List) | CSmfCredMgrClientSymbian |
changePluginIDListL(const QString NewPluginID, const bool Flag, const QString OldPluginID) | CSmfCredMgrClientSymbian |
deleteRSAKey(QString KeyLabel) | CSmfCredMgrClientSymbian |
DoCancel() | CSmfCredMgrClientSymbian | [protected]
generateNONCE(const qint64 Length) | CSmfCredMgrClientSymbian |
isPluginAuthenticatedL(QString PluginID) | CSmfCredMgrClientSymbian |
NewL(SmfCredMgrClient *aPublicImpl) | CSmfCredMgrClientSymbian | [static]
NewLC(SmfCredMgrClient *aPublicImpl) (defined in CSmfCredMgrClientSymbian) | CSmfCredMgrClientSymbian | [static]
RunL() | CSmfCredMgrClientSymbian | [protected]
signMessageL(QString Message, QString Key, QString &Signature, SmfSignatureMethod AlgorithmUsed) | CSmfCredMgrClientSymbian |
storeAuthDataL(SmfAuthParams Set, QDateTime Validity, QList< QUrl > URLList, QStringList PluginList, QString AuthAppAID, bool Flag) | CSmfCredMgrClientSymbian |
storeRSAKeysL(const QString KeyLabel, const QString keydata, const QDateTime Validity) | CSmfCredMgrClientSymbian |
URLListL(QString PluginID, QList< QUrl > &List) | CSmfCredMgrClientSymbian |
~CSmfCredMgrClientSymbian() | CSmfCredMgrClientSymbian |
Generated on Thu Sep 23 15:03:21 2010 for smf by doxygen 1.6.3


smf: CSmfCredMgrDb Class Reference

CSmfCredMgrDb Class Reference

#include <smfcredmgrdb.h>

List of all members.

Public Member Functions

~CSmfCredMgrDb ()

Static Public Member Functions

static CSmfCredMgrDb * | NewL ()
static CSmfCredMgrDb * | NewLC ()

Detailed Description

The creator class of the server database. Derives from CBase

Constructor & Destructor Documentation

CSmfCredMgrDb::~CSmfCredMgrDb ( )

Destructor

Member Function Documentation

CSmfCredMgrDb * CSmfCredMgrDb::NewL ( ) [static]

NewL Method

Returns:
The constructed CSmfCredMgrDb instance

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Pritam Roy Biswas, Nalina Hariharan, Sasken Communication Technologies Ltd

Description: This header defines the database-table and the creation of database that will be used by the Credential Manager Server to store all the credentials related to an Authentication Application NewL Method

Returns:
The constructed CSmfCredMgrDb instance
CSmfCredMgrDb * CSmfCredMgrDb::NewLC ( ) [static]

NewLC Method

Returns:
The constructed CSmfCredMgrDb instance
The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrdb.h
  • smf/smfcredentialmgr/smfcredmgrserver/src/smfcredmgrdb.cpp
Generated on Thu Sep 23 15:03:21 2010 for smf by doxygen 1.6.3


smf: Member List

CSmfCredMgrDb Member List

This is the complete list of members for CSmfCredMgrDb, including all inherited members.
NewL() | CSmfCredMgrDb | [static]
NewLC() | CSmfCredMgrDb | [static]
~CSmfCredMgrDb() | CSmfCredMgrDb |
Generated on Thu Sep 23 15:03:21 2010 for smf by doxygen 1.6.3


smf: CSmfCredMgrDbUser Class Reference

CSmfCredMgrDbUser Class Reference

#include <smfcredmgrdbuser.h>

List of all members.

Public Member Functions

~CSmfCredMgrDbUser ()
TInt | PluginIDTableInsert (const TDesC &aPluginID, const TDesC &aAuthAppId, TBool aEnableFlag)
TInt | URLTableInsert (const TDesC &aAuthAppId, const TDesC &aURL)
TInt | RegTokenValidityTableInsert (const TDesC &aRegToken, const TDesC &aAuthAppId, const TUint aValidity)
TInt | AuthParamsTableInsert (const TDesC &aAuthAppId, const TDesC &aKey, const TDesC &aSecret)
void | fetchPluginListL (const TDesC &aRegToken, RPointerArray< HBufC > &aArray)
void | readAuthTokensL (const TDesC &aAuthAppId, RArray< TSmfAuthToken > &aArray)
void | readUrlL (const TDesC &aAuthAppId, RPointerArray< HBufC > &aArray)
void | readValidity (const TDesC &aAuthAppId, TInt64 &aValidity)
void | readRegistrationTokenL (const TDesC &aAuthAppId, TDesC &aRegToken)
void | readAuthAppIdInRegTokenTable (const TDesC &aRegToken, TDes &aAuthAppId)
void | readAuthAppIdInPluginIdTable (const TDesC &aPluginID, TDes &aAuthAppId)
void | readFlagInPluginIdTable (const TDesC &aPluginID, TInt &aFlag)
TInt | updatePlugin (const TDesC &aPluginID, const TBool &aFlag, const TDesC &aOldPluginID)
void | readPluginIdL (const TDesC &aAuthAppId, RPointerArray< HBufC > &aArray)

Static Public Member Functions

static CSmfCredMgrDbUser * | NewL (CSmfCredMgrServerSession *aSession)
static CSmfCredMgrDbUser * | NewLC (CSmfCredMgrServerSession *aSession)

Detailed Description

The class to use the server database i.e insert table in Db, query from Db.

Constructor & Destructor Documentation

CSmfCredMgrDbUser::~CSmfCredMgrDbUser ( )

Destructor

Member Function Documentation

TInt CSmfCredMgrDbUser::AuthParamsTableInsert | ( | const TDesC & | aAuthAppId,
 |  | const TDesC & | aKey,
 |  | const TDesC & | aSecret
 | ) |  |

Method to insert AuthParamsTable

Parameters:
aAuthAppId | The ID of the Authentication app
aKey | The Key
aSecret | The Secret
Returns:
Returns KErrNone if success. Refer ESqlDbError and system-wide error codes for detailed error description.
void CSmfCredMgrDbUser::fetchPluginListL | ( | const TDesC & | aRegToken,
 |  | RPointerArray< HBufC > & | aArray
 | ) |  |

Method to fetch all the plugins associated with the registration token

Parameters:
aRegToken | The Registration token of the authentication app
aArray | [out] The array to be updated with plugin ids
CSmfCredMgrDbUser * CSmfCredMgrDbUser::NewL ( CSmfCredMgrServerSession * aSession ) [static]

NewL function

Parameters:
aSession the session object using this class
Returns:
The constructed CSmfCredMgrDbUser instance

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Pritam Roy Biswas, Nalina Hariharan, Sasken Communication Technologies Ltd

Description: This file contains routines to handle the data-base operations like insertion, query etc. on Credential Manager Server Database NewL function

Parameters:
aSession the session object using this class
Returns:
The constructed CSmfCredMgrDbUser instance
CSmfCredMgrDbUser * CSmfCredMgrDbUser::NewLC ( CSmfCredMgrServerSession * aSession ) [static]

NewLC function. This method adds the return value to the Cleanup Stack if constructed

Parameters:
aSession the session object using this class
Returns:
The constructed CSmfCredMgrDbUser instance
TInt CSmfCredMgrDbUser::PluginIDTableInsert | ( | const TDesC & | aPluginId,
 |  | const TDesC & | aAuthAppId,
 |  | TBool | aEnableFlag
 | ) |  |

Method to insert PluginIDTable

Parameters:
aPluginID | The ID of the plugin
aAuthAppId | The ID of the Authentication app associated with the plugin
aEnableFlag | A flag to indicate if the plugin is enabled, i.e, aEnableFlag = 0 for a disabled plugin
Returns:
Returns KErrNone if success. Refer ESqlDbError and system-wide error codes for detailed error description.
void CSmfCredMgrDbUser::readAuthAppIdInPluginIdTable | ( | const TDesC & | aPluginID,
 |  | TDes & | aAuthAppId
 | ) |  |

Method to fetch Authentication app ID from PluginIDTable giving the plugin ID

Parameters:
aPluginID | the ID of the plugin
aAuthAppId | [out] ID of the Authentication app
void CSmfCredMgrDbUser::readAuthAppIdInRegTokenTable | ( | const TDesC & | aRegToken,
 |  | TDes & | aAuthAppId
 | ) |  |

Method to fetch Authentication app ID from RegTokenValidityTable giving the reg token

Parameters:
aRegToken | The Registration token of the authentication app
aAuthAppId | [out] The ID of the Authentication app
void CSmfCredMgrDbUser::readAuthTokensL | ( | const TDesC & | aAuthAppId,
 |  | RArray< TSmfAuthToken > & | aArray
 | ) |  |

Method to Key-Secret pairs of the Authentication app

Parameters:
aAuthAppId | The ID of the Authentication app
aArray | [out] The array containing the key-secret pair
void CSmfCredMgrDbUser::readFlagInPluginIdTable | ( | const TDesC & | aPluginID,
 |  | TInt & | aFlag
 | ) |  |

Method to read the IsEnabled flag from plugin Id table

Parameters:
aPluginID | The ID of the plugin
aFlag | [out] The flag that indicates the plugin id is enables or disabled
void CSmfCredMgrDbUser::readPluginIdL | ( | const TDesC & | aAuthAppId,
 |  | RPointerArray< HBufC > & | aArray
 | ) |  |

Method to fetch the list of plugin ids associated with Authentication App id, it is called internally by fetchPluginList().

Parameters:
aAuthAppId | ID of the Authentication app
aArray | [out] The array to be updated with plugin ids
void CSmfCredMgrDbUser::readRegistrationTokenL | ( | const TDesC & | aAuthAppId,
 |  | TDesC & | aRegToken
 | ) |  |

Method to fetch Registration token of the Authentication app from RegTokenValidityTable

Parameters:
aAuthAppId | The ID of the Authentication app
aRegToken | [out] The Registration token of the authentication app
void CSmfCredMgrDbUser::readUrlL | ( | const TDesC & | aAuthAppId,
 |  | RPointerArray< HBufC > & | aArray
 | ) |  |

Method to fetch all the URLs associated with the Authentication app

Parameters:
aAuthAppId | The ID of the Authentication app
aArray | [out] The array to be updated with URLs
void CSmfCredMgrDbUser::readValidity | ( | const TDesC & | aAuthAppId,
 |  | TInt64 & | aValidity
 | ) |  |

Method to fetch Validity of the Authentication app

Parameters:
aAuthAppId | The ID of the Authentication app
aValidity | [out] The time by which the Auth set will expire
TInt CSmfCredMgrDbUser::RegTokenValidityTableInsert | ( | const TDesC & | aRegToken,
 |  | const TDesC & | aAuthAppId,
 |  | const TUint | aValidity
 | ) |  |

Method to insert RegTokenValidityTable

Parameters:
aRegToken | The Registration token for the authentication app
aAuthAppId | The ID of the Authentication app
aValidity | The time by which the set will expire
Returns:
Returns KErrNone if success. Refer ESqlDbError and system-wide error codes for detailed error description.
TInt CSmfCredMgrDbUser::updatePlugin | ( | const TDesC & | aPluginID,
 |  | const TBool & | aFlag,
 |  | const TDesC & | aOldPluginID
 | ) |  |

Method to change a plugin id in plugin Id table

Parameters:
aNewPluginID | The ID of the new plugin
aFlag | The flag that indicates the plugin id is enables or disabled
aOldPluginID | The ID of the plugin to be replaced
Returns:
Returns KErrNone if success. Refer ESqlDbError and system-wide error codes for detailed error description.
TInt CSmfCredMgrDbUser::URLTableInsert | ( | const TDesC & | aAuthAppId,
 |  | const TDesC & | aURL
 | ) |  |

Method to insert URLTable

Parameters:
aAuthAppId | The ID of the Authentication app associated with the URLs
aURL | The URL to be stored
Returns:
Returns KErrNone if success. Refer ESqlDbError and system-wide error codes for detailed error description.
The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrdbuser.h
  • smf/smfcredentialmgr/smfcredmgrserver/src/smfcredmgrdbuser.cpp
Generated on Thu Sep 23 15:03:21 2010 for smf by doxygen 1.6.3


smf: Member List

CSmfCredMgrDbUser Member List

This is the complete list of members for CSmfCredMgrDbUser, including all inherited members.
AuthParamsTableInsert(const TDesC &aAuthAppId, const TDesC &aKey, const TDesC &aSecret) | CSmfCredMgrDbUser |
fetchPluginListL(const TDesC &aRegToken, RPointerArray< HBufC > &aArray) | CSmfCredMgrDbUser |
NewL(CSmfCredMgrServerSession *aSession) | CSmfCredMgrDbUser | [static]
NewLC(CSmfCredMgrServerSession *aSession) | CSmfCredMgrDbUser | [static]
PluginIDTableInsert(const TDesC &aPluginID, const TDesC &aAuthAppId, TBool aEnableFlag) | CSmfCredMgrDbUser |
readAuthAppIdInPluginIdTable(const TDesC &aPluginID, TDes &aAuthAppId) | CSmfCredMgrDbUser |
readAuthAppIdInRegTokenTable(const TDesC &aRegToken, TDes &aAuthAppId) | CSmfCredMgrDbUser |
readAuthTokensL(const TDesC &aAuthAppId, RArray< TSmfAuthToken > &aArray) | CSmfCredMgrDbUser |
readFlagInPluginIdTable(const TDesC &aPluginID, TInt &aFlag) | CSmfCredMgrDbUser |
readPluginIdL(const TDesC &aAuthAppId, RPointerArray< HBufC > &aArray) | CSmfCredMgrDbUser |
readRegistrationTokenL(const TDesC &aAuthAppId, TDesC &aRegToken) | CSmfCredMgrDbUser |
readUrlL(const TDesC &aAuthAppId, RPointerArray< HBufC > &aArray) | CSmfCredMgrDbUser |
readValidity(const TDesC &aAuthAppId, TInt64 &aValidity) | CSmfCredMgrDbUser |
RegTokenValidityTableInsert(const TDesC &aRegToken, const TDesC &aAuthAppId, const TUint aValidity) | CSmfCredMgrDbUser |
updatePlugin(const TDesC &aPluginID, const TBool &aFlag, const TDesC &aOldPluginID) | CSmfCredMgrDbUser |
URLTableInsert(const TDesC &aAuthAppId, const TDesC &aURL) | CSmfCredMgrDbUser |
~CSmfCredMgrDbUser() | CSmfCredMgrDbUser |
Generated on Thu Sep 23 15:03:21 2010 for smf by doxygen 1.6.3


smf: CSmfCredMgrServer Class Reference

CSmfCredMgrServer Class Reference

#include <smfcredmgrserver.h>

List of all members.

Public Member Functions

~CSmfCredMgrServer ()
CSession2 * | NewSessionL (const TVersion &aVersion, const RMessage2 &aMessage) const

Static Public Member Functions

static CSmfCredMgrServer * | NewL ()
static CSmfCredMgrServer * | NewLC ()

Detailed Description

Class for Credential Manager Server. Derives from CPolicyServer.

Constructor & Destructor Documentation

CSmfCredMgrServer::~CSmfCredMgrServer ( )

Destructor

CSmfCredMgrServer::~CSmfCredMgrServer() Destructor.

Member Function Documentation

CSmfCredMgrServer * CSmfCredMgrServer::NewL ( ) [static]

NewL Method

Returns:
The constructed CSmfCredMgrServer instance

CSmfCredMgrServer::NewL() Two-phased constructor.

Returns:
The constructed CSmfCredMgrServer instance
CSmfCredMgrServer * CSmfCredMgrServer::NewLC ( ) [static]

NewLC Method

Returns:
The constructed CSmfCredMgrServer instance

CSmfCredMgrServer::NewLC() Two-phased constructor.

Returns:
The constructed CSmfCredMgrServer instance
CSession2 * CSmfCredMgrServer::NewSessionL | ( | const TVersion & | aVersion,
 |  | const RMessage2 & | aMessage |
 | ) |  |  | const

Creates a server-side session object.The session represents a communication link between a client and a server, and its creation is initiated by the client through a call to one of the RSessionBase::CreateSession() variants.

CSmfCredMgrServer::NewSessionL Creates a new session with the server.

The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrserver.h
  • smf/smfcredentialmgr/smfcredmgrserver/src/smfcredmgrserver.cpp
Generated on Thu Sep 23 15:03:21 2010 for smf by doxygen 1.6.3


smf: Member List

CSmfCredMgrServer Member List

This is the complete list of members for CSmfCredMgrServer, including all inherited members.
NewL() | CSmfCredMgrServer | [static]
NewLC() | CSmfCredMgrServer | [static]
NewSessionL(const TVersion &aVersion, const RMessage2 &aMessage) const | CSmfCredMgrServer |
~CSmfCredMgrServer() | CSmfCredMgrServer |
Generated on Thu Sep 23 15:03:21 2010 for smf by doxygen 1.6.3


smf: CSmfCredMgrServerSession Class Reference

CSmfCredMgrServerSession Class Reference

#include <smfcredmgrserversession.h>

List of all members.

Public Member Functions

~CSmfCredMgrServerSession ()
virtual void | ServiceL (const RMessage2 &aMessage)

Static Public Member Functions

static CSmfCredMgrServerSession * | NewL (CSmfCredMgrServer &aServer)
static CSmfCredMgrServerSession * | NewLC (CSmfCredMgrServer &aServer)

Detailed Description

Class to establish a client session at server side. Derives from CSession2

Constructor & Destructor Documentation

CSmfCredMgrServerSession::~CSmfCredMgrServerSession ( )

Destructor

Member Function Documentation

CSmfCredMgrServerSession * CSmfCredMgrServerSession::NewL ( CSmfCredMgrServer & aServer ) [static]

NewL Method

Parameters:
aServer the server object
Returns:
The constructed CSmfCredMgrServerSession instance

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Pritam Roy Biswas, Sasken Communication Technologies Ltd

Description: Header file for Credential Manager Server Session. NewL Method

Parameters:
aServer the server object
Returns:
The constructed CSmfCredMgrServerSession instance
CSmfCredMgrServerSession * CSmfCredMgrServerSession::NewLC ( CSmfCredMgrServer & aServer ) [static]

NewLC Method

Parameters:
aServer the server object
Returns:
The constructed CSmfCredMgrServerSession instance
void CSmfCredMgrServerSession::ServiceL ( const RMessage2 & aMessage ) [virtual]

Handles the servicing of a client request that has been passed to the server

Parameters:
aMessage The message containing the details of the client request
The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrserversession.h
  • smf/smfcredentialmgr/smfcredmgrserver/src/smfcredmgrserversession.cpp
Generated on Thu Sep 23 15:03:21 2010 for smf by doxygen 1.6.3


smf: Member List

CSmfCredMgrServerSession Member List

This is the complete list of members for CSmfCredMgrServerSession, including all inherited members.
NewL(CSmfCredMgrServer &aServer) | CSmfCredMgrServerSession | [static]
NewLC(CSmfCredMgrServer &aServer) | CSmfCredMgrServerSession | [static]
ServiceL(const RMessage2 &aMessage) | CSmfCredMgrServerSession | [virtual]
~CSmfCredMgrServerSession() | CSmfCredMgrServerSession |
Generated on Thu Sep 23 15:03:21 2010 for smf by doxygen 1.6.3


smf: CSmfFetchAuthTokenSet Class Reference

CSmfFetchAuthTokenSet Class Reference

#include <smfcredmgrclientdatastruct.h>

List of all members.

Public Member Functions

~CSmfFetchAuthTokenSet ()
void | ExternalizeL (RWriteStream &aStream)
void | InternalizeL (const RBuf8 &aSource)

Public Attributes

HBufC * | iRegistrationToken
TUint32 | iValidity
RArray< TSmfAuthToken > | iAuthTokenArray

Detailed Description

This class provide details and to serialize for the API fetching Authentication Parameters

Constructor & Destructor Documentation

CSmfFetchAuthTokenSet::~CSmfFetchAuthTokenSet ( ) [inline]

Destructor

Member Function Documentation

void CSmfFetchAuthTokenSet::ExternalizeL ( RWriteStream & aStream )

Method to externalize the member variables

Parameters:
aStream The Write Stream to be filled.
void CSmfFetchAuthTokenSet::InternalizeL ( const RBuf8 & aSource )

Method to internalize the member variables

Parameters:
aSource The Source Stream to read from

Member Data Documentation

RArray<TSmfAuthToken> CSmfFetchAuthTokenSet::iAuthTokenArray

Array in symbian to hold the key-value pair

HBufC* CSmfFetchAuthTokenSet::iRegistrationToken

Buffer to hold registration token

TUint32 CSmfFetchAuthTokenSet::iValidity

Time by which the Auth set will expire

The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrclientdatastruct.h
  • smf/smfcredentialmgr/smfcredmgrcommon/src/smfcredmgrclientdatastruct.cpp
Generated on Thu Sep 23 15:03:21 2010 for smf by doxygen 1.6.3


smf: Member List

CSmfFetchAuthTokenSet Member List

This is the complete list of members for CSmfFetchAuthTokenSet, including all inherited members.
ExternalizeL(RWriteStream &aStream) | CSmfFetchAuthTokenSet |
iAuthTokenArray | CSmfFetchAuthTokenSet |
InternalizeL(const RBuf8 &aSource) | CSmfFetchAuthTokenSet |
iRegistrationToken | CSmfFetchAuthTokenSet |
iValidity | CSmfFetchAuthTokenSet |
~CSmfFetchAuthTokenSet() | CSmfFetchAuthTokenSet | [inline]
Generated on Thu Sep 23 15:03:21 2010 for smf by doxygen 1.6.3


smf: CSmfKeyStoreManager Class Reference

CSmfKeyStoreManager Class Reference

List of all members.

Public Member Functions

~CSmfKeyStoreManager ()
void | HandleMessageL (const RMessage2 &aMessage)

Static Public Member Functions

static CSmfKeyStoreManager * | NewL ()
static CSmfKeyStoreManager * | NewLC ()

Constructor & Destructor Documentation

CSmfKeyStoreManager::~CSmfKeyStoreManager ( )

Destructor

Member Function Documentation

void CSmfKeyStoreManager::HandleMessageL ( const RMessage2 & aMessage )

HandleMessageL

Parameters:
aMessage
CSmfKeyStoreManager * CSmfKeyStoreManager::NewL ( ) [static]

NewL Method

Returns:
The constructed CSmfKeyStoreManager instance

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Lasse Laasonen, Sasken Communication Technologies Ltd - Initial contribution

Description: This source contains routines handling RSA signing using Unified Key Store NewL Method

Returns:
The constructed CSmfKeyStoreManager instance
CSmfKeyStoreManager * CSmfKeyStoreManager::NewLC ( ) [static]

NewLC Method

Returns:
The constructed CSmfKeyStoreManager instance
The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrserver/inc/smfkeystoremanager.h
  • smf/smfcredentialmgr/smfcredmgrserver/src/smfkeystoremanager.cpp
Generated on Thu Sep 23 15:03:22 2010 for smf by doxygen 1.6.3


smf: Member List

CSmfKeyStoreManager Member List

This is the complete list of members for CSmfKeyStoreManager, including all inherited members.
HandleMessageL(const RMessage2 &aMessage) | CSmfKeyStoreManager |
NewL() | CSmfKeyStoreManager | [static]
NewLC() | CSmfKeyStoreManager | [static]
~CSmfKeyStoreManager() | CSmfKeyStoreManager |
Generated on Thu Sep 23 15:03:22 2010 for smf by doxygen 1.6.3


smf: CSmfPluginIDListParams Class Reference

CSmfPluginIDListParams Class Reference

#include <smfcredmgrclientdatastruct.h>

List of all members.

Public Member Functions

~CSmfPluginIDListParams ()
void | ExternalizeL (RWriteStream &aStream)
void | InternalizeL (const RBuf8 &aSource)

Public Attributes

RPointerArray< HBufC > | iPluginList
HBufC * | iRegistrationToken

Detailed Description

This class provide details and to serialize data to the API retreiving Authenticated PluginID List

Constructor & Destructor Documentation

CSmfPluginIDListParams::~CSmfPluginIDListParams ( ) [inline]

Destructor

Member Function Documentation

void CSmfPluginIDListParams::ExternalizeL ( RWriteStream & aStream )

Method to externalize the member variables

Parameters:
aStream The Write Stream to be filled.
void CSmfPluginIDListParams::InternalizeL ( const RBuf8 & aSource )

Method to internalize the member variables

Parameters:
aSource The source stream to read from

Member Data Documentation

RPointerArray<HBufC> CSmfPluginIDListParams::iPluginList

Array in symbian to hold plugin list

HBufC* CSmfPluginIDListParams::iRegistrationToken

Buffer to hold registration token for which the list of plugins will be queried

The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrclientdatastruct.h
  • smf/smfcredentialmgr/smfcredmgrcommon/src/smfcredmgrclientdatastruct.cpp
Generated on Thu Sep 23 15:03:22 2010 for smf by doxygen 1.6.3


smf: Member List

CSmfPluginIDListParams Member List

This is the complete list of members for CSmfPluginIDListParams, including all inherited members.
ExternalizeL(RWriteStream &aStream) | CSmfPluginIDListParams |
InternalizeL(const RBuf8 &aSource) | CSmfPluginIDListParams |
iPluginList | CSmfPluginIDListParams |
iRegistrationToken | CSmfPluginIDListParams |
~CSmfPluginIDListParams() | CSmfPluginIDListParams | [inline]
Generated on Thu Sep 23 15:03:22 2010 for smf by doxygen 1.6.3


smf: CSmfPluginIDUpdate Class Reference

CSmfPluginIDUpdate Class Reference

#include <smfcredmgrclientdatastruct.h>

List of all members.

Public Member Functions

void | ExternalizeL (RWriteStream &aStream)
void | InternalizeL (const RBuf8 &aSource)

Public Attributes

HBufC * | iNewPluginID
HBufC * | iOldPluginID
TBool | pluginIDEnabled

Detailed Description

Class to provide details of data to the API changing/updating Authenticated plugin list

Member Function Documentation

void CSmfPluginIDUpdate::ExternalizeL ( RWriteStream & aStream )

Method to externalize the member variables

Parameters:
aStream The Write Stream to be filled.
void CSmfPluginIDUpdate::InternalizeL ( const RBuf8 & aSource )

Method to internalize the member variables

Parameters:
aSource The source stream to read from

Member Data Documentation

HBufC* CSmfPluginIDUpdate::iNewPluginID

Id of new plugin

HBufC* CSmfPluginIDUpdate::iOldPluginID

Id of the old plugin to be replaced

TBool CSmfPluginIDUpdate::pluginIDEnabled

flag to indicate an enabled pluginID

The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrclientdatastruct.h
  • smf/smfcredentialmgr/smfcredmgrcommon/src/smfcredmgrclientdatastruct.cpp
Generated on Thu Sep 23 15:03:22 2010 for smf by doxygen 1.6.3


smf: Member List

CSmfPluginIDUpdate Member List

This is the complete list of members for CSmfPluginIDUpdate, including all inherited members.
ExternalizeL(RWriteStream &aStream) | CSmfPluginIDUpdate |
iNewPluginID | CSmfPluginIDUpdate |
InternalizeL(const RBuf8 &aSource) | CSmfPluginIDUpdate |
iOldPluginID | CSmfPluginIDUpdate |
pluginIDEnabled | CSmfPluginIDUpdate |
~CSmfPluginIDUpdate() (defined in CSmfPluginIDUpdate) | CSmfPluginIDUpdate | [inline]
Generated on Thu Sep 23 15:03:22 2010 for smf by doxygen 1.6.3


smf: CSmfRsaKeyParameters Class Reference

CSmfRsaKeyParameters Class Reference

#include <smfcredmgrclientdatastruct.h>

List of all members.

Public Member Functions

~CSmfRsaKeyParameters ()
void | ExternalizeL (RWriteStream &aStream) const
const TDesC & | KeyName () const
const TDesC8 & | KeyData () const
const TTime & | StartDate () const
const TTime & | EndDate () const

Static Public Member Functions

static CSmfRsaKeyParameters * | NewL (const TDesC &aKeyName, const TTime &startDate, const TTime &endDate, const TDesC8 &aKeyData)
static CSmfRsaKeyParameters * | NewL (const TDesC8 &aData)

Detailed Description

Class to provide RSA key details

Constructor & Destructor Documentation

CSmfRsaKeyParameters::~CSmfRsaKeyParameters ( )

Destructor

Member Function Documentation

const TTime & CSmfRsaKeyParameters::EndDate ( ) const

Method to get the end date

Returns:
The end date
void CSmfRsaKeyParameters::ExternalizeL ( RWriteStream & aStream ) const

Method to externalize the member variables

Parameters:
aStream The Write Stream to be filled.
const TDesC8 & CSmfRsaKeyParameters::KeyData ( ) const

Method to get the key data

Returns:
The key data
const TDesC & CSmfRsaKeyParameters::KeyName ( ) const

Method to get the key name

Returns:
The key name
CSmfRsaKeyParameters * CSmfRsaKeyParameters::NewL ( const TDesC8 & aData ) [static]

Overloaded NewL method

Parameters:
aData
Returns:
The constructed CSmfRsaKeyParameters instance
CSmfRsaKeyParameters * CSmfRsaKeyParameters::NewL | ( | const TDesC & | aKeyName,
 |  | const TTime & | startDate,
 |  | const TTime & | endDate,
 |  | const TDesC8 & | aKeyData |
 | ) |  |  | [static]

NewL method

Parameters:
aKeyName
startDate
endDate
aKeydata
Returns:
The constructed CSmfRsaKeyParameters instance
const TTime & CSmfRsaKeyParameters::StartDate ( ) const

Method to get the start date

Returns:
The start date
The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrclientdatastruct.h
  • smf/smfcredentialmgr/smfcredmgrcommon/src/smfcredmgrclientdatastruct.cpp
Generated on Thu Sep 23 15:03:22 2010 for smf by doxygen 1.6.3


smf: Member List

CSmfRsaKeyParameters Member List

This is the complete list of members for CSmfRsaKeyParameters, including all inherited members.
EndDate() const | CSmfRsaKeyParameters |
ExternalizeL(RWriteStream &aStream) const | CSmfRsaKeyParameters |
KeyData() const | CSmfRsaKeyParameters |
KeyName() const | CSmfRsaKeyParameters |
NewL(const TDesC &aKeyName, const TTime &startDate, const TTime &endDate, const TDesC8 &aKeyData) | CSmfRsaKeyParameters | [static]
NewL(const TDesC8 &aData) | CSmfRsaKeyParameters | [static]
StartDate() const | CSmfRsaKeyParameters |
~CSmfRsaKeyParameters() | CSmfRsaKeyParameters |
Generated on Thu Sep 23 15:03:22 2010 for smf by doxygen 1.6.3


smf: CSmfSignParameters Class Reference

CSmfSignParameters Class Reference

#include <smfcredmgrclientdatastruct.h>

List of all members.

Public Member Functions

~CSmfSignParameters ()
void | ExternalizeL (RWriteStream &aStream) const
const TDesC8 & | Key () const
const TDesC8 & | Message () const

Static Public Member Functions

static CSmfSignParameters * | NewL (const TDesC8 &aMessage, const TDesC8 &aKey)
static CSmfSignParameters * | NewL (const TDesC8 &aData)

Detailed Description

Class to provide data to Signing API.

Constructor & Destructor Documentation

CSmfSignParameters::~CSmfSignParameters ( )

Destructor

Member Function Documentation

void CSmfSignParameters::ExternalizeL ( RWriteStream & aStream ) const

Method to externalize the member variables

Parameters:
aStream The Write Stream to be filled.
const TDesC8 & CSmfSignParameters::Key ( ) const

Method to get the Key for the signature

Returns:
The Key for the signature
const TDesC8 & CSmfSignParameters::Message ( ) const

Method to get the message

Returns:
The message
CSmfSignParameters * CSmfSignParameters::NewL ( const TDesC8 & aData ) [static]

Overloaded NewL method

Parameters:
aMessage The message to be signed
Returns:
The constructed CSmfSignParameters instance
CSmfSignParameters * CSmfSignParameters::NewL | ( | const TDesC8 & | aMessage,
 |  | const TDesC8 & | aKey |
 | ) |  |  | [static]

NewL method

Parameters:
aMessage | The message to be signed
aKey | The key
Returns:
The constructed CSmfSignParameters instance
The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrclientdatastruct.h
  • smf/smfcredentialmgr/smfcredmgrcommon/src/smfcredmgrclientdatastruct.cpp
Generated on Thu Sep 23 15:03:22 2010 for smf by doxygen 1.6.3


smf: Member List

CSmfSignParameters Member List

This is the complete list of members for CSmfSignParameters, including all inherited members.
ExternalizeL(RWriteStream &aStream) const | CSmfSignParameters |
Key() const | CSmfSignParameters |
Message() const | CSmfSignParameters |
NewL(const TDesC8 &aMessage, const TDesC8 &aKey) | CSmfSignParameters | [static]
NewL(const TDesC8 &aData) | CSmfSignParameters | [static]
~CSmfSignParameters() | CSmfSignParameters |
Generated on Thu Sep 23 15:03:22 2010 for smf by doxygen 1.6.3


smf: CSmfStoreAuthParams Class Reference

CSmfStoreAuthParams Class Reference

#include <smfcredmgrclientdatastruct.h>

List of all members.

Public Member Functions

~CSmfStoreAuthParams ()
void | ExternalizeL (RWriteStream &aStream)
void | InternalizeL (const RBuf8 &aSource)

Public Attributes

RArray< TSmfAuthToken > | iAuthTokenArray
RPointerArray< HBufC > | iPluginIDList
RPointerArray< HBufC > | iURLList
HBufC * | iRegistrationToken
HBufC * | iAuthAppID
TBool | pluginIDEnabled
TUint32 | iValidity

Detailed Description

Class to provide details of data to API storing Parameters during Authentication process

Constructor & Destructor Documentation

CSmfStoreAuthParams::~CSmfStoreAuthParams ( ) [inline]

destructor

Member Function Documentation

void CSmfStoreAuthParams::ExternalizeL ( RWriteStream & aStream )

Method to externalize the member variables

Parameters:
aStream The Write Stream to be filled.
void CSmfStoreAuthParams::InternalizeL ( const RBuf8 & aSource )

Method to internalize the member variables

Parameters:
aSource The source stream to read from

Member Data Documentation

HBufC* CSmfStoreAuthParams::iAuthAppID

Buffer to hold the authentication application ID

RArray<TSmfAuthToken> CSmfStoreAuthParams::iAuthTokenArray

Array to hold TSmfAuthToken elements

RPointerArray<HBufC> CSmfStoreAuthParams::iPluginIDList

Array to hold list of plugins

HBufC* CSmfStoreAuthParams::iRegistrationToken

Buffer to hold the registration token

RPointerArray<HBufC> CSmfStoreAuthParams::iURLList

Array to hold URL list

TUint32 CSmfStoreAuthParams::iValidity

Time by which the Auth set will expire

TBool CSmfStoreAuthParams::pluginIDEnabled

Flag to indicate an enabled pluginID

The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrclientdatastruct.h
  • smf/smfcredentialmgr/smfcredmgrcommon/src/smfcredmgrclientdatastruct.cpp
Generated on Thu Sep 23 15:03:22 2010 for smf by doxygen 1.6.3


smf: Member List

CSmfStoreAuthParams Member List

This is the complete list of members for CSmfStoreAuthParams, including all inherited members.
ExternalizeL(RWriteStream &aStream) | CSmfStoreAuthParams |
iAuthAppID | CSmfStoreAuthParams |
iAuthTokenArray | CSmfStoreAuthParams |
InternalizeL(const RBuf8 &aSource) | CSmfStoreAuthParams |
iPluginIDList | CSmfStoreAuthParams |
iRegistrationToken | CSmfStoreAuthParams |
iURLList | CSmfStoreAuthParams |
iValidity | CSmfStoreAuthParams |
pluginIDEnabled | CSmfStoreAuthParams |
~CSmfStoreAuthParams() | CSmfStoreAuthParams | [inline]
Generated on Thu Sep 23 15:03:22 2010 for smf by doxygen 1.6.3


smf: CSmfURLListParams Class Reference

CSmfURLListParams Class Reference

#include <smfcredmgrclientdatastruct.h>

List of all members.

Public Member Functions

~CSmfURLListParams ()
void | ExternalizeL (RWriteStream &aStream)
void | InternalizeL (const TDesC8 &aSource)

Public Attributes

RPointerArray< HBufC > | iURLList
HBufC * | iPluginID

Detailed Description

This class provide details and to serialize of data to the API retreiving URL List

Constructor & Destructor Documentation

CSmfURLListParams::~CSmfURLListParams ( ) [inline]

Destructor

Member Function Documentation

void CSmfURLListParams::ExternalizeL ( RWriteStream & aStream )

Method to externalize the member variables

Parameters:
aStream The Write Stream to be filled.
void CSmfURLListParams::InternalizeL ( const TDesC8 & aSource )

Method to internalize the member variables

Parameters:
aSource The source stream to read from

Member Data Documentation

HBufC* CSmfURLListParams::iPluginID

Buffer to hold the plugin id for which urls will be queried

RPointerArray<HBufC> CSmfURLListParams::iURLList

Array in symbian to hold url list

The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrclientdatastruct.h
  • smf/smfcredentialmgr/smfcredmgrcommon/src/smfcredmgrclientdatastruct.cpp
Generated on Thu Sep 23 15:03:22 2010 for smf by doxygen 1.6.3


smf: Member List

CSmfURLListParams Member List

This is the complete list of members for CSmfURLListParams, including all inherited members.
ExternalizeL(RWriteStream &aStream) | CSmfURLListParams |
InternalizeL(const TDesC8 &aSource) | CSmfURLListParams |
iPluginID | CSmfURLListParams |
iURLList | CSmfURLListParams |
~CSmfURLListParams() | CSmfURLListParams | [inline]
Generated on Thu Sep 23 15:03:22 2010 for smf by doxygen 1.6.3


smf: CustomListWidget Class Reference

CustomListWidget Class Reference

List of all members.

Public Member Functions

QWidget * | CreateListwidget (SmfContactList *friendsList)
QWidget * | CreateListwidget (SmfPostList *postsList)
QWidget * | CreateListwidget (SmfActivityEntryList *activityList)
void | AddListItem (QString aIconPath, QString aFirstLine, QString aSecondLine)
void | AddListItem (QMainWindow *mainWindow, QStringList aIconPath, QStringList iconName)
The documentation for this class was generated from the following files:
  • example/DemoGUI/CustomListWidget.h
  • example/DemoGUI/CustomListWidget.cpp
Generated on Thu Sep 23 15:03:23 2010 for smf by doxygen 1.6.3


smf: Member List

CustomListWidget Member List

This is the complete list of members for CustomListWidget, including all inherited members.
AddListItem(QString aIconPath, QString aFirstLine, QString aSecondLine) (defined in CustomListWidget) | CustomListWidget
AddListItem(QMainWindow *mainWindow, QStringList aIconPath, QStringList iconName) (defined in CustomListWidget) | CustomListWidget
CreateListwidget(SmfContactList *friendsList) (defined in CustomListWidget) | CustomListWidget
CreateListwidget(SmfPostList *postsList) (defined in CustomListWidget) | CustomListWidget
CreateListwidget(SmfActivityEntryList *activityList) (defined in CustomListWidget) | CustomListWidget
CustomListWidget() (defined in CustomListWidget) | CustomListWidget
~CustomListWidget() (defined in CustomListWidget) | CustomListWidget
Generated on Thu Sep 23 15:03:23 2010 for smf by doxygen 1.6.3


smf: DataStoreManager Class Reference

DataStoreManager Class Reference

List of all members.

Public Slots

SmfRelationId | create (SmfProvider *aProvider=NULL, SmfContact *aContact=NULL)
SmfError | associate (SmfRelationId aRelation, const SmfContact *aContact, SmfProvider *aProvider)
SmfError | remove (SmfRelationId aRelation, const SmfContact *aConact)
SmfRelationItem * | searchById (const SmfRelationId aRelation)
SmfRelationId | searchByContact (SmfContact aContact)
QList< SmfRelationItem > | getAll (SmfRelationId aRelation)
SmfRelationItem * | getContact (SmfRelationId aRelation, quint32 aIndex)
SmfError | deleteRelation (SmfRelationId aRelation)
QList< SmfRelationId > | getAllRelations ()
uint | count (SmfRelationId aRelation)
DSMContactPckg * | get (SmfRelationId aRelation, quint32 aIndex)

Public Member Functions

~DataStoreManager ()
Destructor for DataStoreManager class.
DataStoreManagerState | getState () const
Get the current state of the DataStoreManager object.
QString | getErrorText () const
Get the last error message from the DataStoreManager object.

Static Public Member Functions

static DataStoreManager * | getDataStoreManager ()
To get a handle on the datastore instantiation.

Constructor & Destructor Documentation

DataStoreManager::~DataStoreManager ( )

Destructor for DataStoreManager class.

Note:
Should this be public?

Member Function Documentation

SmfError DataStoreManager::associate | ( | SmfRelationId | aRelation,
 |  | const SmfContact * | aContact,
 |  | SmfProvider * | aProvider |
 | ) |  |  | [slot]

assign contact to a relation

uint DataStoreManager::count ( SmfRelationId aRelation ) [slot]

returns number of contacts in a relation

SmfError DataStoreManager::deleteRelation ( SmfRelationId aRelation ) [slot]

delete a particular relation

DSMContactPckg * DataStoreManager::get | ( | SmfRelationId | aRelation,
 |  | quint32 | aIndex |
 | ) |  |  | [slot]

get DSMContactPckg

contacts and their provider

QList< SmfRelationItem > DataStoreManager::getAll ( SmfRelationId aRelation ) [slot]

list of contacts and their provider

QList< SmfRelationId > DataStoreManager::getAllRelations ( ) [slot]

list of all relations

SmfRelationItem * DataStoreManager::getContact | ( | SmfRelationId | aRelation,
 |  | quint32 | aIndex |
 | ) |  |  | [slot]

contacts and their provider

DataStoreManager * DataStoreManager::getDataStoreManager ( ) [static]

To get a handle on the datastore instantiation.

This function returns a pointer to the existing DataStoreManager instantiation(object). If no object exists, a new one is created.

Returns:
Pointer to the current instantiation of DataStoreManager.
QString DataStoreManager::getErrorText ( ) const

Get the last error message from the DataStoreManager object.

Returns:
The last error message string of the DSM object.
DataStoreManagerState DataStoreManager::getState ( ) const

Get the current state of the DataStoreManager object.

Returns:
The state of the DSM object.
SmfError DataStoreManager::remove | ( | SmfRelationId | aRelation,
 |  | const SmfContact * | aContact |
 | ) |  |  | [slot]

remove contact from a relation

SmfRelationId DataStoreManager::searchByContact ( SmfContact aContact ) [slot]

returns relation Id for a given contacts if exists, NULL otherwise

SmfRelationItem * DataStoreManager::searchById ( const SmfRelationId aRelation ) [slot]

returns first relation item in the relation when exists, NULL otherwise

The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfserver/datastoremgr/dsm.h
  • smf/smfservermodule/smfserver/datastoremgr/dsm.cpp
Generated on Thu Sep 23 15:03:23 2010 for smf by doxygen 1.6.3


smf: Member List

DataStoreManager Member List

This is the complete list of members for DataStoreManager, including all inherited members.
associate(SmfRelationId aRelation, const SmfContact *aContact, SmfProvider *aProvider) | DataStoreManager | [slot]
count(SmfRelationId aRelation) | DataStoreManager | [slot]
create(SmfProvider *aProvider=NULL, SmfContact *aContact=NULL) (defined in DataStoreManager) | DataStoreManager | [slot]
deleteRelation(SmfRelationId aRelation) | DataStoreManager | [slot]
get(SmfRelationId aRelation, quint32 aIndex) | DataStoreManager | [slot]
getAll(SmfRelationId aRelation) | DataStoreManager | [slot]
getAllRelations() | DataStoreManager | [slot]
getContact(SmfRelationId aRelation, quint32 aIndex) | DataStoreManager | [slot]
getDataStoreManager() | DataStoreManager | [static]
getErrorText() const | DataStoreManager |
getState() const | DataStoreManager |
remove(SmfRelationId aRelation, const SmfContact *aConact) | DataStoreManager | [slot]
searchByContact(SmfContact aContact) | DataStoreManager | [slot]
searchById(const SmfRelationId aRelation) | DataStoreManager | [slot]
~DataStoreManager() | DataStoreManager |
Generated on Thu Sep 23 15:03:23 2010 for smf by doxygen 1.6.3


smf: DisplayWidget Class Reference

DisplayWidget Class Reference

#include <displaywidget.h>

List of all members.

Public Slots

void | showFriends (SmfContactList *frnds, SmfError, SmfResultPage)
void | showPosts (SmfPostList *postlist, SmfError error, SmfResultPage resultPage)
void | interfaceSelected ()
void | serviceProviderSelected ()
void | serviceSelected ()

Public Member Functions

DisplayWidget (QWidget *parent=0)
void | writeLog (QString log) const

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Constructor & Destructor Documentation

DisplayWidget::DisplayWidget ( QWidget * parent = 0 )

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

The documentation for this class was generated from the following files:
  • example/smfclientapp/displaywidget.h
  • example/smfclientapp/displaywidget.cpp
Generated on Thu Sep 23 15:03:23 2010 for smf by doxygen 1.6.3


smf: Member List

DisplayWidget Member List

This is the complete list of members for DisplayWidget, including all inherited members.
DisplayWidget(QWidget *parent=0) | DisplayWidget |
interfaceSelected() (defined in DisplayWidget) | DisplayWidget | [slot]
serviceProviderSelected() (defined in DisplayWidget) | DisplayWidget | [slot]
serviceSelected() (defined in DisplayWidget) | DisplayWidget | [slot]
showFriends(SmfContactList *frnds, SmfError, SmfResultPage) (defined in DisplayWidget) | DisplayWidget | [slot]
showPosts(SmfPostList *postlist, SmfError error, SmfResultPage resultPage) (defined in DisplayWidget) | DisplayWidget | [slot]
writeLog(QString log) const (defined in DisplayWidget) | DisplayWidget |
~DisplayWidget() (defined in DisplayWidget) | DisplayWidget |
Generated on Thu Sep 23 15:03:23 2010 for smf by doxygen 1.6.3


smf: Ui::DisplayWidgetClass Class Reference

Ui::DisplayWidgetClass

Ui::DisplayWidgetClass Class Reference

Inherits Ui_DisplayWidgetClass.

List of all members.

The documentation for this class was generated from the following file:
  • example/smfclientapp/ui_displaywidget.h
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: Member List

Ui::DisplayWidgetClass Member List

This is the complete list of members for Ui::DisplayWidgetClass, including all inherited members.
comboBox__SP (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
comboBox_intf (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
comboBox_service (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
label (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
label_2 (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
label_3 (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
listWidget (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
pushButton_intf (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
pushButton_service (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
pushButton_SP (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
retranslateUi(QWidget *DisplayWidgetClass) (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass | [inline]
setupUi(QWidget *DisplayWidgetClass) (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass | [inline]
verticalLayout (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
verticalLayoutWidget (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
verticalScrollBar_list (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: DSMContactPckg Struct Reference

DSMContactPckg Struct Reference

List of all members.

Public Attributes

QString | userId
QString | contactUrl
QString | localId
QString | managerUri
QString | snsName
QString | snsDesc
QString | snsUrl
QString | presenceState
QString | presenceText
QString | statusText
Int64 | timeStamp
int | contactIndex
int | relationId
The documentation for this struct was generated from the following file:
  • smf/smfservermodule/smfserver/datastoremgr/dsm.h
Generated on Thu Sep 23 15:03:23 2010 for smf by doxygen 1.6.3


smf: Member List

DSMContactPckg Member List

This is the complete list of members for DSMContactPckg, including all inherited members.
contactIndex (defined in DSMContactPckg) | DSMContactPckg
contactUrl (defined in DSMContactPckg) | DSMContactPckg
localId (defined in DSMContactPckg) | DSMContactPckg
managerUri (defined in DSMContactPckg) | DSMContactPckg
presenceState (defined in DSMContactPckg) | DSMContactPckg
presenceText (defined in DSMContactPckg) | DSMContactPckg
relationId (defined in DSMContactPckg) | DSMContactPckg
snsDesc (defined in DSMContactPckg) | DSMContactPckg
snsName (defined in DSMContactPckg) | DSMContactPckg
snsUrl (defined in DSMContactPckg) | DSMContactPckg
statusText (defined in DSMContactPckg) | DSMContactPckg
timeStamp (defined in DSMContactPckg) | DSMContactPckg
userId (defined in DSMContactPckg) | DSMContactPckg
Generated on Thu Sep 23 15:03:23 2010 for smf by doxygen 1.6.3


smf: FBActivityFetcherPlugin Class Reference

FBActivityFetcherPlugin Class Reference

#include <fbactivityfetcherplugin.h>

Inherits SmfActivityFetcherPlugin.

List of all members.

Public Member Functions

virtual | ~FBActivityFetcherPlugin ()
SmfPluginError | selfActivities (SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | friendsActivities (SmfPluginRequestData &aRequest, const SmfContact &aContact, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | filtered (SmfPluginRequestData &aRequest, QList< SmfActivityObjectType > &aFilters, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)
void | initialize ()
SmfProviderBase * getProviderInfo ()
SmfPluginError | responseAvailable (const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)

Detailed Description

The Plugin class that fetches activities from the logged in user's facebook account

Constructor & Destructor Documentation

FBActivityFetcherPlugin::~FBActivityFetcherPlugin ( ) [virtual]

Destructor

Member Function Documentation

SmfPluginError FBActivityFetcherPlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [virtual]

Customised method for SmfActivityFetcherPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | The operation type (should be known between the client interface and the plugin)
aData | The data required to form the request (The type of data should be known between client and the plugin)
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfActivityFetcherPlugin.

SmfPluginError FBActivityFetcherPlugin::filtered | ( | SmfPluginRequestData & | aRequest,
 |  | QList< SmfActivityObjectType > & | aFilters,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get list of self activities filtered by activity type, e.g. only photo updates in own wall

Parameters:
aRequest | [out] The request data plugin generated (to be sent to network)
aFilters | [in] The list of activity types to be included in result
aPageNum[in] | The page to be extracted
aItemsPerPage[in] | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfActivityFetcherPlugin.

SmfPluginError FBActivityFetcherPlugin::friendsActivities | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfContact & | aContact,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get the list of activities for other, e.g. shown in a friends wall

Parameters:
aRequest | [out] The request data plugin generated (to be sent to network)
aContact | [in] The contact containing the URI, name or id of the user
aPageNum[in] | The page to be extracted
aItemsPerPage[in] | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfActivityFetcherPlugin.

SmfProviderBase * FBActivityFetcherPlugin::getProviderInfo ( ) [virtual]

Method to get the provider information

Returns:
Instance of SmfProviderBase

Implements SmfPluginBase.

void FBActivityFetcherPlugin::initialize ( ) [virtual]

The first method to be called in the plugin that implements this interface. If this method is not called, plugin may not behave as expected.

Implements SmfPluginBase.

SmfPluginError FBActivityFetcherPlugin::responseAvailable | ( | const SmfRequestTypeID | aOperation,
 |  | const SmfTransportResult & | aTransportResult,
 |  | QByteArray * | aResponse,
 |  | QVariant * | aResult,
 |  | SmfPluginRetType & | aRetType,
 |  | SmfResultPage & | aPageResult |
 | ) |  |  | [virtual]

Method to get the result for a network request.

Parameters:
aOperation | The type of operation to be requested
aTransportResult | The result of transport operation
aResponse | The QByteArray instance containing the network response. The plugins should delete this instance once they have read the data from it.
aResult | [out] An output parameter to the plugin manager.If the return value is SmfSendRequestAgain, QVariant will be of type SmfPluginRequestData. For SmfActivityFetcherPlugin: If last operation was selfActivities() or friendsActivities() or filtered(), aResult will be of type QList<SmfActivityEntry>.
aRetType | [out] SmfPluginRetType
aPageResult | [out] The SmfResultPage structure variable

Implements SmfPluginBase.

SmfPluginError FBActivityFetcherPlugin::selfActivities | ( | SmfPluginRequestData & | aRequest,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get the list of self activities, e.g. shown in own wall

Parameters:
aRequest | [out] The request data that plugin generates (to be sent to network)
aPageNum[in] | The page to be extracted
aItemsPerPage[in] | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfActivityFetcherPlugin.

The documentation for this class was generated from the following files:
  • example/fbactivityfetcherplugin/fbactivityfetcherplugin.h
  • example/fbactivityfetcherplugin/fbactivityfetcherplugin.cpp
Generated on Thu Sep 23 15:03:24 2010 for smf by doxygen 1.6.3


smf: Member List

FBActivityFetcherPlugin Member List

This is the complete list of members for FBActivityFetcherPlugin, including all inherited members.
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData) | FBActivityFetcherPlugin | [virtual]
filtered(SmfPluginRequestData &aRequest, QList< SmfActivityObjectType > &aFilters, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FBActivityFetcherPlugin | [virtual]
friendsActivities(SmfPluginRequestData &aRequest, const SmfContact &aContact, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FBActivityFetcherPlugin | [virtual]
getProviderInfo() | FBActivityFetcherPlugin | [virtual]
initialize() | FBActivityFetcherPlugin | [virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult) | FBActivityFetcherPlugin | [virtual]
selfActivities(SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FBActivityFetcherPlugin | [virtual]
~FBActivityFetcherPlugin() | FBActivityFetcherPlugin | [virtual]
~SmfActivityFetcherPlugin() | SmfActivityFetcherPlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:24 2010 for smf by doxygen 1.6.3


smf: FBActivityProviderBase Class Reference

FBActivityProviderBase Class Reference

#include <fbactivityfetcherplugin.h>

Inherits SmfProviderBase.

List of all members.

Public Member Functions

virtual | ~FBActivityProviderBase ()
QString | serviceName () const
QImage | serviceIcon () const
QString | description () const
QUrl | serviceUrl () const
QUrl | applicationUrl () const
QImage | applicationIcon () const
QList< QString > | supportedInterfaces () const
QStringList | supportedLanguages () const
QString | pluginId () const
QString | authenticationApp (QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const
QString | smfRegistrationId () const

Friends

class | FBActivityFetcherPlugin

Detailed Description

The Plugin class that implements SmfProviderBase for this facebook plugin

Constructor & Destructor Documentation

FBActivityProviderBase::~FBActivityProviderBase ( ) [virtual]

Destructor

Member Function Documentation

QImage FBActivityProviderBase::applicationIcon ( ) const [virtual]

Method to get the Icon of the application

Returns:
The Icon of the application

Implements SmfProviderBase.

QUrl FBActivityProviderBase::applicationUrl ( ) const [virtual]

Method to get the URL of the Application providing this service

Returns:
The URL of the Application providing this service

Implements SmfProviderBase.

QString FBActivityProviderBase::authenticationApp | ( | QString & | aProgram,
 |  | QStringList & | aArguments,
 |  | QIODevice::OpenModeFlag | aMode = QIODevice::ReadWrite |
 | ) |  |  | const [virtual]

Method to get the ID of the authentication application for this service

Parameters:
aProgram | The authentication application name
aArguments | List of arguments required for authentication app
aMode | Strting mode for authentication application
Returns:
The ID of the authentication application

Implements SmfProviderBase.

QString FBActivityProviderBase::description ( ) const [virtual]

Method to get the Readable service description

Returns:
The Readable service description

Implements SmfProviderBase.

QString FBActivityProviderBase::pluginId ( ) const [virtual]

Method to get the Plugin specific ID

Returns:
The Plugin specific ID

Implements SmfProviderBase.

QImage FBActivityProviderBase::serviceIcon ( ) const [virtual]

Method to get the Logo of the service

Returns:
The Logo of the service

Implements SmfProviderBase.

QString FBActivityProviderBase::serviceName ( ) const [virtual]

Method to get the Localisable name of the service.

Returns:
The Localisable name of the service.

Implements SmfProviderBase.

QUrl FBActivityProviderBase::serviceUrl ( ) const [virtual]

Method to get the Website of the service

Returns:
The Website of the service

Implements SmfProviderBase.

QString FBActivityProviderBase::smfRegistrationId ( ) const [virtual]

Method to get the unique registration ID provided by the Smf for authorised plugins

Returns:
The unique registration ID/token provided by the Smf for authorised plugins

Implements SmfProviderBase.

QList< QString > FBActivityProviderBase::supportedInterfaces ( ) const [virtual]

Method to get the list of interfaces that this provider support

Returns:
List of supported Interafces

Implements SmfProviderBase.

QStringList FBActivityProviderBase::supportedLanguages ( ) const [virtual]

Method to get the list of languages supported by this service provider

Returns:
a QStringList of languages supported by this service provider in 2 letter ISO 639-1 format.

Implements SmfProviderBase.

The documentation for this class was generated from the following files:
  • example/fbactivityfetcherplugin/fbactivityfetcherplugin.h
  • example/fbactivityfetcherplugin/fbactivityfetcherplugin.cpp
Generated on Thu Sep 23 15:03:24 2010 for smf by doxygen 1.6.3


smf: Member List

FBActivityProviderBase Member List

This is the complete list of members for FBActivityProviderBase, including all inherited members.
applicationIcon() const | FBActivityProviderBase | [virtual]
applicationUrl() const | FBActivityProviderBase | [virtual]
authenticationApp(QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const | FBActivityProviderBase | [virtual]
description() const | FBActivityProviderBase | [virtual]
FBActivityFetcherPlugin (defined in FBActivityProviderBase) | FBActivityProviderBase | [friend]
pluginId() const | FBActivityProviderBase | [virtual]
serviceIcon() const | FBActivityProviderBase | [virtual]
serviceName() const | FBActivityProviderBase | [virtual]
serviceUrl() const | FBActivityProviderBase | [virtual]
smfRegistrationId() const | FBActivityProviderBase | [virtual]
supportedInterfaces() const | FBActivityProviderBase | [virtual]
supportedLanguages() const | FBActivityProviderBase | [virtual]
~FBActivityProviderBase() | FBActivityProviderBase | [virtual]
~SmfProviderBase() | SmfProviderBase | [inline, virtual]
Generated on Thu Sep 23 15:03:24 2010 for smf by doxygen 1.6.3


smf: FBContactFetcherPlugin Class Reference

FBContactFetcherPlugin Class Reference

#include <fbcontactfetcherplugin.h>

Inherits SmfContactFetcherPlugin.

List of all members.

Public Member Functions

virtual | ~FBContactFetcherPlugin ()
SmfPluginError | friends (SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | followers (SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | search (SmfPluginRequestData &aRequest, const SmfContact &aContact, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | searchNear (SmfPluginRequestData &aRequest, const SmfLocation &aLocation, const SmfLocationSearchBoundary &aProximity, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | groups (SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | searchInGroup (SmfPluginRequestData &aRequest, const SmfGroup &aGroup, SmfContact *aContact=NULL, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)
void | initialize ()
SmfProviderBase * getProviderInfo ()
SmfPluginError | responseAvailable (const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)

Detailed Description

The Plugin class that fetches contacts from the logged in user's facebook account

Constructor & Destructor Documentation

FBContactFetcherPlugin::~FBContactFetcherPlugin ( ) [virtual]

Destructor

Member Function Documentation

SmfPluginError FBContactFetcherPlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [virtual]

Customised method for SmfContactFetcherPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | The operation type (should be known between the client interface and the plugin)
aData | The data required to form the request (The type of data should be known between client and the plugin)
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfContactFetcherPlugin.

SmfPluginError FBContactFetcherPlugin::followers | ( | SmfPluginRequestData & | aRequest,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get the list of followers

Parameters:
aRequest | [out] The request data to be sent to network
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfContactFetcherPlugin.

SmfPluginError FBContactFetcherPlugin::friends | ( | SmfPluginRequestData & | aRequest,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get the list of friends

Parameters:
aRequest | [out] The request data to be sent to network
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfContactFetcherPlugin.

SmfProviderBase * FBContactFetcherPlugin::getProviderInfo ( ) [virtual]

Method to get the provider information

Returns:
Instance of SmfProviderBase

Implements SmfPluginBase.

SmfPluginError FBContactFetcherPlugin::groups | ( | SmfPluginRequestData & | aRequest,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get the list of groups

Parameters:
aRequest | [out] The request data to be sent to network
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfContactFetcherPlugin.

void FBContactFetcherPlugin::initialize ( ) [virtual]

The first method to be called in the plugin that implements this interface. If this method is not called, plugin may not behave as expected.

Implements SmfPluginBase.

SmfPluginError FBContactFetcherPlugin::responseAvailable | ( | const SmfRequestTypeID | aOperation,
 |  | const SmfTransportResult & | aTransportResult,
 |  | QByteArray * | aResponse,
 |  | QVariant * | aResult,
 |  | SmfPluginRetType & | aRetType,
 |  | SmfResultPage & | aPageResult |
 | ) |  |  | [virtual]

Method to get the result for a network request.

Parameters:
aOperation | The type of operation to be requested
aTransportResult | The result of transport operation
aResponse | The QByteArray instance containing the network response. The plugins should delete this instance once they have read the data from it.
aResult | [out] An output parameter to the plugin manager.If the return value is SmfSendRequestAgain, QVariant will be of type SmfPluginRequestData. For SmfGalleryPlugin: If last operation was pictures(), aResult will be of type QList<SmfPicture>. If last operation was description(), aResult will be of type QString. If last operation was upload() or postComment(), aResult will be of type bool.
aRetType | [out] SmfPluginRetType
aPageResult | [out] The SmfResultPage structure variable

Implements SmfPluginBase.

SmfPluginError FBContactFetcherPlugin::search | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfContact & | aContact,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to search for a contact

Parameters:
aRequest | [out] The request data to be sent to network
aContact | contact to be searched
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfContactFetcherPlugin.

SmfPluginError FBContactFetcherPlugin::searchInGroup | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfGroup & | aGroup,
 |  | SmfContact * | aContact = NULL,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to search for a contact in a group

Parameters:
aRequest | [out] The request data to be sent to network
aGroup | the group in which to search
aContact | The contact to be searched, default (NULL) is the self contact.
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfContactFetcherPlugin.

SmfPluginError FBContactFetcherPlugin::searchNear | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfLocation & | aLocation,
 |  | const SmfLocationSearchBoundary & | aProximity,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to search for contacts (friends) who are near the user. Proximity defines accuracy level

Parameters:
aRequest | [out] The request data to be sent to network
aLocation | The location search criteria
aProximity | location search boundary
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfContactFetcherPlugin.

The documentation for this class was generated from the following files:
  • example/fbcontactfetcherplugin/fbcontactfetcherplugin.h
  • example/fbcontactfetcherplugin/fbcontactfetcherplugin.cpp
Generated on Thu Sep 23 15:03:24 2010 for smf by doxygen 1.6.3


smf: Member List

FBContactFetcherPlugin Member List

This is the complete list of members for FBContactFetcherPlugin, including all inherited members.
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData) | FBContactFetcherPlugin | [virtual]
followers(SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FBContactFetcherPlugin | [virtual]
friends(SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FBContactFetcherPlugin | [virtual]
getProviderInfo() | FBContactFetcherPlugin | [virtual]
groups(SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FBContactFetcherPlugin | [virtual]
initialize() | FBContactFetcherPlugin | [virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult) | FBContactFetcherPlugin | [virtual]
search(SmfPluginRequestData &aRequest, const SmfContact &aContact, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FBContactFetcherPlugin | [virtual]
searchInGroup(SmfPluginRequestData &aRequest, const SmfGroup &aGroup, SmfContact *aContact=NULL, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FBContactFetcherPlugin | [virtual]
searchNear(SmfPluginRequestData &aRequest, const SmfLocation &aLocation, const SmfLocationSearchBoundary &aProximity, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FBContactFetcherPlugin | [virtual]
~FBContactFetcherPlugin() | FBContactFetcherPlugin | [virtual]
~SmfContactFetcherPlugin() | SmfContactFetcherPlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:24 2010 for smf by doxygen 1.6.3


smf: FBContactProviderBase Class Reference

FBContactProviderBase Class Reference

#include <fbcontactfetcherplugin.h>

Inherits SmfProviderBase.

List of all members.

Public Member Functions

virtual | ~FBContactProviderBase ()
QString | serviceName () const
QImage | serviceIcon () const
QString | description () const
QUrl | serviceUrl () const
QUrl | applicationUrl () const
QImage | applicationIcon () const
QList< QString > | supportedInterfaces () const
QStringList | supportedLanguages () const
QString | pluginId () const
QString | authenticationApp (QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const
QString | smfRegistrationId () const

Friends

class | FBContactFetcherPlugin

Detailed Description

The Plugin class that implements SmfProviderBase for this facebook plugin

Constructor & Destructor Documentation

FBContactProviderBase::~FBContactProviderBase ( ) [virtual]

Destructor

Member Function Documentation

QImage FBContactProviderBase::applicationIcon ( ) const [virtual]

Method to get the Icon of the application

Returns:
The Icon of the application

Implements SmfProviderBase.

QUrl FBContactProviderBase::applicationUrl ( ) const [virtual]

Method to get the URL of the Application providing this service

Returns:
The URL of the Application providing this service

Implements SmfProviderBase.

QString FBContactProviderBase::authenticationApp | ( | QString & | aProgram,
 |  | QStringList & | aArguments,
 |  | QIODevice::OpenModeFlag | aMode = QIODevice::ReadWrite |
 | ) |  |  | const [virtual]

Method to get the ID of the authentication application for this service

Parameters:
aProgram | The authentication application name
aArguments | List of arguments required for authentication app
aMode | Strting mode for authentication application
Returns:
The ID of the authentication application

Implements SmfProviderBase.

QString FBContactProviderBase::description ( ) const [virtual]

Method to get the Readable service description

Returns:
The Readable service description

Implements SmfProviderBase.

QString FBContactProviderBase::pluginId ( ) const [virtual]

Method to get the Plugin specific ID

Returns:
The Plugin specific ID

Implements SmfProviderBase.

QImage FBContactProviderBase::serviceIcon ( ) const [virtual]

Method to get the Logo of the service

Returns:
The Logo of the service

Implements SmfProviderBase.

QString FBContactProviderBase::serviceName ( ) const [virtual]

Method to get the Localisable name of the service.

Returns:
The Localisable name of the service.

Implements SmfProviderBase.

QUrl FBContactProviderBase::serviceUrl ( ) const [virtual]

Method to get the Website of the service

Returns:
The Website of the service

Implements SmfProviderBase.

QString FBContactProviderBase::smfRegistrationId ( ) const [virtual]

Method to get the unique registration ID provided by the Smf for authorised plugins

Returns:
The unique registration ID/token provided by the Smf for authorised plugins

Implements SmfProviderBase.

QList< QString > FBContactProviderBase::supportedInterfaces ( ) const [virtual]

Method to get the list of interfaces that this provider support

Returns:
List of supported Interafces

Implements SmfProviderBase.

QStringList FBContactProviderBase::supportedLanguages ( ) const [virtual]

Method to get the list of languages supported by this service provider

Returns:
a QStringList of languages supported by this service provider in 2 letter ISO 639-1 format.

Implements SmfProviderBase.

The documentation for this class was generated from the following files:
  • example/fbcontactfetcherplugin/fbcontactfetcherplugin.h
  • example/fbcontactfetcherplugin/fbcontactfetcherplugin.cpp
Generated on Thu Sep 23 15:03:24 2010 for smf by doxygen 1.6.3


smf: Member List

FBContactProviderBase Member List

This is the complete list of members for FBContactProviderBase, including all inherited members.
applicationIcon() const | FBContactProviderBase | [virtual]
applicationUrl() const | FBContactProviderBase | [virtual]
authenticationApp(QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const | FBContactProviderBase | [virtual]
description() const | FBContactProviderBase | [virtual]
FBContactFetcherPlugin (defined in FBContactProviderBase) | FBContactProviderBase | [friend]
pluginId() const | FBContactProviderBase | [virtual]
serviceIcon() const | FBContactProviderBase | [virtual]
serviceName() const | FBContactProviderBase | [virtual]
serviceUrl() const | FBContactProviderBase | [virtual]
smfRegistrationId() const | FBContactProviderBase | [virtual]
supportedInterfaces() const | FBContactProviderBase | [virtual]
supportedLanguages() const | FBContactProviderBase | [virtual]
~FBContactProviderBase() | FBContactProviderBase | [virtual]
~SmfProviderBase() | SmfProviderBase | [inline, virtual]
Generated on Thu Sep 23 15:03:24 2010 for smf by doxygen 1.6.3


smf: FBDialog Class Reference

FBDialog Class Reference

#include <baseDialog.h>

Inherited by FBLoginDialog, and FBLoginDialog.

List of all members.

Signals

void | dialogDidSucceed ()
void | dialogDidCancel ()
void | dialogDidFailWithError (const FBError &error)
void | dialogDidSucceed ()
void | dialogDidCancel ()
void | dialogDidFailWithError (const FBError &error)

Public Member Functions

void | proxysettings ()
FBDialog (FBSession *aSession)
void | show ()
virtual void | load ()
void | loadURL (const QString &aUrl, QNetworkAccessManager::Operation aMethod, const QHash< QString, QString > &aGetParams, const QHash< QString, QString > &aPostParams)
void | dismiss (bool aAnimated)
void | dismissWithSuccess (bool aSuccess, bool aAnimated)
void | dismissWithError (const FBError &aError, bool aAnimated)
virtual void | dialogWillAppear ()
virtual void | dialogWillDisappear ()
virtual void | dialogDidSucceed (const QUrl &aUrl)
QString | title () const
void | setTitle (const QString &aTitle)
virtual void | GetSessionKey (const QUrl &aUrl)
virtual void | FetchKeyFromUrl (const QUrl &aUrl)
void | proxysettings ()
FBDialog (FBSession *aSession)
void | show ()
virtual void | load ()
void | loadURL (const QString &aUrl, QNetworkAccessManager::Operation aMethod, const QHash< QString, QString > &aGetParams, const QHash< QString, QString > &aPostParams)
void | dismiss (bool aAnimated)
void | dismissWithSuccess (bool aSuccess, bool aAnimated)
void | dismissWithError (const FBError &aError)
virtual void | dialogWillAppear ()
virtual void | dialogWillDisappear ()
virtual void | dialogDidSucceed (const QUrl &aUrl)
QString | title () const
void | setTitle (const QString &aTitle)
virtual void | GetSessionKey (const QUrl &aUrl)
virtual void | connectToGetFullToken ()

Protected Attributes

FBSession * iSession
QWebView * | iWebView
QString | iLoadingUrl
bool | iIgnorePageLoadCompleteEvent
QProgressBar * | progressbar
QVBoxLayout * | layout

Detailed Description

The base Dialoggg

Constructor & Destructor Documentation

FBDialog::FBDialog ( FBSession * aSession )

Creates the view but does not display it.

FBDialog::FBDialog ( FBSession * aSession )

Creates the view but does not display it.

Member Function Documentation

void FBDialog::dialogDidCancel ( ) [signal]

Called when the dialog is cancelled and is about to be dismissed.

void FBDialog::dialogDidCancel ( ) [signal]

Called when the dialog is cancelled and is about to be dismissed.

void FBDialog::dialogDidFailWithError ( const FBError & error ) [signal]

Called when dialog failed to load due to an error.

void FBDialog::dialogDidFailWithError ( const FBError & error ) [signal]

Called when dialog failed to load due to an error.

virtual void FBDialog::dialogDidSucceed ( const QUrl & aUrl ) [virtual]

Subclasses should override to process data returned from the server in a 'fbconnect' url.

Implementations must call dismissWithSuccess:YES at some point to hide the dialog.

void FBDialog::dialogDidSucceed ( ) [signal]

Called when the dialog succeeds and is about to be dismissed.

void FBDialog::dialogDidSucceed ( const QUrl & aUrl ) [virtual]

Subclasses should override to process data returned from the server in a 'fbconnect' url.

Implementations must call dismissWithSuccess:YES at some point to hide the dialog.

void FBDialog::dialogDidSucceed ( ) [signal]

Called when the dialog succeeds and is about to be dismissed.

virtual void FBDialog::dialogWillAppear ( ) [virtual]

Subclasses may override to perform actions just prior to showing the dialog.

void FBDialog::dialogWillAppear ( ) [virtual]

Subclasses may override to perform actions just prior to showing the dialog.

virtual void FBDialog::dialogWillDisappear ( ) [virtual]

Subclasses may override to perform actions just after the dialog is hidden.

Reimplemented in FBLoginDialog.

void FBDialog::dialogWillDisappear ( ) [virtual]

Subclasses may override to perform actions just after the dialog is hidden.

Reimplemented in FBLoginDialog.

void FBDialog::dismissWithError ( const FBError & aError )

Hides the view and notifies delegates of an error.

void FBDialog::dismissWithError | ( | const FBError & | aError,
 |  | bool | aAnimated
 | ) |  |

Hides the view and notifies delegates of an error.

void FBDialog::dismissWithSuccess | ( | bool | aSuccess,
 |  | bool | aAnimated
 | ) |  |

Hides the view and notifies delegates of success or cancellation.

void FBDialog::dismissWithSuccess | ( | bool | aSuccess,
 |  | bool | aAnimated
 | ) |  |

Hides the view and notifies delegates of success or cancellation.

virtual void FBDialog::load ( ) [virtual]

Displays the first page of the dialog.

Do not ever call this directly. It is intended to be overriden by subclasses.

Reimplemented in FBLoginDialog, and FBLoginDialog.

void FBDialog::load ( ) [virtual]

Displays the first page of the dialog.

Do not ever call this directly. It is intended to be overriden by subclasses.

Reimplemented in FBLoginDialog, and FBLoginDialog.

void FBDialog::loadURL | ( | const QString & | aUrl,
 |  | QNetworkAccessManager::Operation | aMethod,
 |  | const QHash< QString, QString > & | aGetParams,
 |  | const QHash< QString, QString > & | aPostParams
 | ) |  |

Displays a URL in the dialog.

void FBDialog::loadURL | ( | const QString & | aUrl,
 |  | QNetworkAccessManager::Operation | aMethod,
 |  | const QHash< QString, QString > & | aGetParams,
 |  | const QHash< QString, QString > & | aPostParams
 | ) |  |

Displays a URL in the dialog.

void FBDialog::show ( )

Displays the view with an animation.

The view will be added to the top of the current key window.

void FBDialog::show ( )

Displays the view with an animation.

The view will be added to the top of the current key window.

Member Data Documentation

FBSession * FBDialog::iSession [protected]

The session for which the login is taking place.

The documentation for this class was generated from the following files:
  • example/AuthApp/inc/baseDialog.h
  • example/FlickrAuthApp/inc/baseDialog.h
  • example/AuthApp/src/baseDialog.cpp
  • example/FlickrAuthApp/src/baseDialog.cpp
Generated on Thu Sep 23 15:03:24 2010 for smf by doxygen 1.6.3


smf: Member List

FBDialog Member List

This is the complete list of members for FBDialog, including all inherited members.
connectToGetFullToken() (defined in FBDialog) | FBDialog | [virtual]
dialogDidCancel() | FBDialog | [signal]
dialogDidCancel() | FBDialog | [signal]
dialogDidFailWithError(const FBError &error) | FBDialog | [signal]
dialogDidFailWithError(const FBError &error) | FBDialog | [signal]
dialogDidSucceed() | FBDialog | [signal]
dialogDidSucceed(const QUrl &aUrl) | FBDialog | [virtual]
dialogDidSucceed() | FBDialog | [signal]
dialogDidSucceed(const QUrl &aUrl) | FBDialog | [virtual]
dialogWillAppear() | FBDialog | [virtual]
dialogWillAppear() | FBDialog | [virtual]
dialogWillDisappear() | FBDialog | [virtual]
dialogWillDisappear() | FBDialog | [virtual]
dismiss(bool aAnimated) (defined in FBDialog) | FBDialog |
dismiss(bool aAnimated) (defined in FBDialog) | FBDialog |
dismissWithError(const FBError &aError, bool aAnimated) | FBDialog |
dismissWithError(const FBError &aError) | FBDialog |
dismissWithSuccess(bool aSuccess, bool aAnimated) | FBDialog |
dismissWithSuccess(bool aSuccess, bool aAnimated) | FBDialog |
FBDialog(FBSession *aSession) | FBDialog |
FBDialog() (defined in FBDialog) | FBDialog |
FBDialog(FBSession *aSession) | FBDialog |
FBDialog() (defined in FBDialog) | FBDialog |
FetchKeyFromUrl(const QUrl &aUrl) (defined in FBDialog) | FBDialog | [virtual]
GetSessionKey(const QUrl &aUrl) (defined in FBDialog) | FBDialog | [virtual]
GetSessionKey(const QUrl &aUrl) (defined in FBDialog) | FBDialog | [virtual]
iIgnorePageLoadCompleteEvent (defined in FBDialog) | FBDialog | [protected]
iLoadingUrl (defined in FBDialog) | FBDialog | [protected]
iSession | FBDialog | [protected]
iWebView (defined in FBDialog) | FBDialog | [protected]
layout (defined in FBDialog) | FBDialog | [protected]
load() | FBDialog | [virtual]
load() | FBDialog | [virtual]
loadURL(const QString &aUrl, QNetworkAccessManager::Operation aMethod, const QHash< QString, QString > &aGetParams, const QHash< QString, QString > &aPostParams) | FBDialog |
loadURL(const QString &aUrl, QNetworkAccessManager::Operation aMethod, const QHash< QString, QString > &aGetParams, const QHash< QString, QString > &aPostParams) | FBDialog |
progressbar (defined in FBDialog) | FBDialog | [protected]
proxysettings() (defined in FBDialog) | FBDialog |
proxysettings() (defined in FBDialog) | FBDialog |
setTitle(const QString &aTitle) (defined in FBDialog) | FBDialog |
setTitle(const QString &aTitle) (defined in FBDialog) | FBDialog |
show() | FBDialog |
show() | FBDialog |
title() const (defined in FBDialog) | FBDialog |
title() const (defined in FBDialog) | FBDialog |
Generated on Thu Sep 23 15:03:25 2010 for smf by doxygen 1.6.3


smf: FBError Class Reference

FBError Class Reference

List of all members.

Public Member Functions

FBError (quint8 aErrorCode)
quint8 | code () const
void | setCode (quint8 aErrorCode)
QString | description () const
void | setDescription (const QString &aErrorDescription)
FBError (quint8 aErrorCode)
quint8 | code () const
void | setCode (quint8 aErrorCode)
QString | description () const
void | setDescription (const QString &aErrorDescription)
The documentation for this class was generated from the following files:
  • example/AuthApp/inc/errorCodes.h
  • example/FlickrAuthApp/inc/errorCodes.h
Generated on Thu Sep 23 15:03:25 2010 for smf by doxygen 1.6.3


smf: Member List

FBError Member List

This is the complete list of members for FBError, including all inherited members.
code() const (defined in FBError) | FBError | [inline]
code() const (defined in FBError) | FBError | [inline]
description() const (defined in FBError) | FBError | [inline]
description() const (defined in FBError) | FBError | [inline]
FBError(quint8 aErrorCode) (defined in FBError) | FBError | [inline]
FBError() (defined in FBError) | FBError | [inline]
FBError(quint8 aErrorCode) (defined in FBError) | FBError | [inline]
FBError() (defined in FBError) | FBError | [inline]
setCode(quint8 aErrorCode) (defined in FBError) | FBError | [inline]
setCode(quint8 aErrorCode) (defined in FBError) | FBError | [inline]
setDescription(const QString &aErrorDescription) (defined in FBError) | FBError | [inline]
setDescription(const QString &aErrorDescription) (defined in FBError) | FBError | [inline]
Generated on Thu Sep 23 15:03:25 2010 for smf by doxygen 1.6.3


smf: FBLoginDialog Class Reference

FBLoginDialog Class Reference

Inherits FBDialog, and FBDialog.

List of all members.

Public Member Functions

FBLoginDialog (FBSession *aSession)
void | load ()
FBLoginDialog (FBSession *aSession)
void | connecttoGetFrob ()
void | load ()

Protected Member Functions

virtual void | dialogWillDisappear ()
void | GetSessionKey (const QUrl &aUrl)
void | FetchKeyFromUrl (const QUrl &aUrl)

Member Function Documentation

void FBLoginDialog::dialogWillDisappear ( ) [protected, virtual]

Subclasses may override to perform actions just after the dialog is hidden.

Reimplemented from FBDialog.

void FBLoginDialog::load ( ) [virtual]

Displays the first page of the dialog.

Do not ever call this directly. It is intended to be overriden by subclasses.

Reimplemented from FBDialog.

void FBLoginDialog::load ( ) [virtual]

Displays the first page of the dialog.

Do not ever call this directly. It is intended to be overriden by subclasses.

Reimplemented from FBDialog.

The documentation for this class was generated from the following files:
  • example/AuthApp/inc/loginDialog.h
  • example/FlickrAuthApp/inc/loginDialog.h
  • example/AuthApp/src/loginDialog.cpp
  • example/FlickrAuthApp/src/loginDialog.cpp
Generated on Thu Sep 23 15:03:25 2010 for smf by doxygen 1.6.3


smf: Member List

FBLoginDialog Member List

This is the complete list of members for FBLoginDialog, including all inherited members.
connecttoGetFrob() (defined in FBLoginDialog) | FBLoginDialog |
dialogDidCancel() | FBDialog | [signal]
dialogDidCancel() | FBDialog | [signal]
dialogDidFailWithError(const FBError &error) | FBDialog | [signal]
dialogDidFailWithError(const FBError &error) | FBDialog | [signal]
dialogDidSucceed() | FBDialog | [signal]
dialogDidSucceed(const QUrl &aUrl) | FBDialog | [virtual]
dialogDidSucceed() | FBDialog | [signal]
dialogDidSucceed(const QUrl &aUrl) | FBDialog | [virtual]
dialogWillAppear() | FBDialog | [virtual]
dialogWillAppear() | FBDialog | [virtual]
dialogWillDisappear() | FBLoginDialog | [protected, virtual]
dismiss(bool aAnimated) (defined in FBDialog) | FBDialog |
dismiss(bool aAnimated) (defined in FBDialog) | FBDialog |
dismissWithError(const FBError &aError, bool aAnimated) | FBDialog |
dismissWithError(const FBError &aError) | FBDialog |
dismissWithSuccess(bool aSuccess, bool aAnimated) | FBDialog |
dismissWithSuccess(bool aSuccess, bool aAnimated) | FBDialog |
FBDialog(FBSession *aSession) | FBDialog |
FBDialog() (defined in FBDialog) | FBDialog |
FBDialog(FBSession *aSession) | FBDialog |
FBDialog() (defined in FBDialog) | FBDialog |
FBLoginDialog(FBSession *aSession) (defined in FBLoginDialog) | FBLoginDialog |
FBLoginDialog() (defined in FBLoginDialog) | FBLoginDialog |
FBLoginDialog(FBSession *aSession) (defined in FBLoginDialog) | FBLoginDialog |
FBLoginDialog() (defined in FBLoginDialog) | FBLoginDialog |
FetchKeyFromUrl(const QUrl &aUrl) (defined in FBLoginDialog) | FBLoginDialog | [protected, virtual]
GetSessionKey(const QUrl &aUrl) (defined in FBLoginDialog) | FBLoginDialog | [protected, virtual]
iIgnorePageLoadCompleteEvent (defined in FBDialog) | FBDialog | [protected]
iLoadingUrl (defined in FBDialog) | FBDialog | [protected]
iSession | FBDialog | [protected]
iWebView (defined in FBDialog) | FBDialog | [protected]
layout (defined in FBDialog) | FBDialog | [protected]
load() | FBLoginDialog | [virtual]
load() | FBLoginDialog | [virtual]
loadURL(const QString &aUrl, QNetworkAccessManager::Operation aMethod, const QHash< QString, QString > &aGetParams, const QHash< QString, QString > &aPostParams) | FBDialog |
loadURL(const QString &aUrl, QNetworkAccessManager::Operation aMethod, const QHash< QString, QString > &aGetParams, const QHash< QString, QString > &aPostParams) | FBDialog |
progressbar (defined in FBDialog) | FBDialog | [protected]
proxysettings() (defined in FBDialog) | FBDialog |
proxysettings() (defined in FBDialog) | FBDialog |
setTitle(const QString &aTitle) (defined in FBDialog) | FBDialog |
setTitle(const QString &aTitle) (defined in FBDialog) | FBDialog |
show() | FBDialog |
show() | FBDialog |
title() const (defined in FBDialog) | FBDialog |
title() const (defined in FBDialog) | FBDialog |
Generated on Thu Sep 23 15:03:25 2010 for smf by doxygen 1.6.3


smf: FBPostProviderPlugin Class Reference

FBPostProviderPlugin Class Reference

#include <fbpostproviderplugin.h>

Inherits SmfPostProviderPlugin.

List of all members.

Public Member Functions

virtual | ~FBPostProviderPlugin ()
qint32 | maxCharsInPost () const
qint32 | maxItems () const
QVector< QTextFormat > | supportedFormats () const
bool | supportsAppearence () const
SmfPluginError | retrieve (SmfPluginRequestData &aRequest, const SmfContact *aUser=0, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | post (SmfPluginRequestData &aRequest, const SmfPost &aPostData, const SmfLocation &aLocation)
SmfPluginError | updatePost (SmfPluginRequestData &aRequest, const SmfPost &aPostData)
SmfPluginError | postDirected (SmfPluginRequestData &aRequest, const SmfPost &aPostData, const SmfContact &aContact, const SmfLocation *aLocation=NULL)
SmfPluginError | commentOnAPost (SmfPluginRequestData &aRequest, const SmfPost &aTarget, const SmfPost &aComment, const SmfLocation *aLocation=NULL)
SmfPluginError | postAppearence (SmfPluginRequestData &aRequest, const SmfPresenceInfo &aAppearence, const QString &aStatus)
SmfPluginError | sharePost (SmfPluginRequestData &aRequest, const SmfPost &aPostData, const SmfContact &aContact, const bool &aEdited)
SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)
void | initialize ()
SmfProviderBase * getProviderInfo ()
SmfPluginError | responseAvailable (const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)

Detailed Description

The Plugin that manages post operations on the logged in user's facebook account

Constructor & Destructor Documentation

FBPostProviderPlugin::~FBPostProviderPlugin ( ) [virtual]

Destructor

Member Function Documentation

SmfPluginError FBPostProviderPlugin::commentOnAPost | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPost & | aTarget,
 |  | const SmfPost & | aComment,
 |  | const SmfLocation * | aLocation = NULL |
 | ) |  |  | [virtual]

Method to post a comment on a post.

Parameters:
aRequest | [out] The request data to be sent to network
aTarget | Post on which comment has to be posted
aComment | comment to be posted
aLocation | location data

Implements SmfPostProviderPlugin.

SmfPluginError FBPostProviderPlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [virtual]

Customised method for SmfPostProviderPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | The operation type (should be known between the client interface and the plugin)
aData | The data required to form the request (The type of data should be known between client and the plugin)
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfPostProviderPlugin.

SmfProviderBase * FBPostProviderPlugin::getProviderInfo ( ) [virtual]

Method to get the provider information

Returns:
Instance of SmfProviderBase

Implements SmfPluginBase.

void FBPostProviderPlugin::initialize ( ) [virtual]

The first method to be called in the plugin that implements this interface. If this method is not called, plugin may not behave as expected.

Implements SmfPluginBase.

qint32 FBPostProviderPlugin::maxCharsInPost ( ) const [virtual]

Method that returns maximum no of chars (unicode) that service provider can post without truncation. Negative value means no limit

Returns:
Max characters that can be posted without truncation

Implements SmfPostProviderPlugin.

qint32 FBPostProviderPlugin::maxItems ( ) const [virtual]

Method that returns maximum no of items that can be returned in a single query to getPosts. Negative value means feature not supported.

Returns:
Max items that can be returned in a single query

Implements SmfPostProviderPlugin.

SmfPluginError FBPostProviderPlugin::post | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPost & | aPostData,
 |  | const SmfLocation & | aLocation |
 | ) |  |  | [virtual]

Method to update a post to own area.

Parameters:
aRequest | [out] The request data to be sent to network
aPostData | The post data to be posted
aLocation | The location
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfPostProviderPlugin.

SmfPluginError FBPostProviderPlugin::postAppearence | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPresenceInfo & | aAppearence,
 |  | const QString & | aStatus |
 | ) |  |  | [virtual]

Method to update the presence information of the user

Parameters:
aRequest | [out] The request data to be sent to network
aAppearence | The appearence information
aStatus | The status string
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfPostProviderPlugin.

SmfPluginError FBPostProviderPlugin::postDirected | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPost & | aPostData,
 |  | const SmfContact & | aContact,
 |  | const SmfLocation * | aLocation = NULL |
 | ) |  |  | [virtual]

Method to update a post to a particular contact

Parameters:
aRequest | [out] The request data to be sent to network
aPostData | The post data to be posted
aContact | The contact where the data has to be posted
aLocation | The location
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfPostProviderPlugin.

SmfPluginError FBPostProviderPlugin::responseAvailable | ( | const SmfRequestTypeID | aOperation,
 |  | const SmfTransportResult & | aTransportResult,
 |  | QByteArray * | aResponse,
 |  | QVariant * | aResult,
 |  | SmfPluginRetType & | aRetType,
 |  | SmfResultPage & | aPageResult |
 | ) |  |  | [virtual]

Method to get the result for a network request.

Parameters:
aOperation | The type of operation to be requested
aTransportResult | The result of transport operation
aResponse | The QByteArray instance containing the network response. The plugins should delete this instance once they have read the data from it.
aResult | [out] An output parameter to the plugin manager.If the return value is SmfSendRequestAgain, QVariant will be of type SmfPluginRequestData. For SmfPostProviderPlugin: If last operation was retrieve(), aResult will be of type QList<SmfPost>. If last operation was post() or updatePost() or postDirected() or commentOnAPost() or postAppearence() or sharePost(), aResult will be of type bool
aRetType | [out] SmfPluginRetType
aPageResult | [out] The SmfResultPage structure variable

Implements SmfPluginBase.

SmfPluginError FBPostProviderPlugin::retrieve | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfContact * | aUser = 0,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get the latest posts

Parameters:
aRequest | [out] The request data to be sent to network
aUser | The user's contact in this SP, omit for self contact
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfPostProviderPlugin.

SmfPluginError FBPostProviderPlugin::sharePost | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPost & | aPostData,
 |  | const SmfContact & | aContact,
 |  | const bool & | aEdited |
 | ) |  |  | [virtual]

Share /a contact's post to user's friends and followers (e.g. retweet in twitter, share on facebook)

Parameters:
aRequest | [out] The request data to be sent to network
aPostData | data to be posted
aContact | contact to which the post belonged
aEdited | whether user changed items within the post
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Share a contact's post to user's friends and followers (e.g. retweet in twitter, share on facebook)

Parameters:
aRequest | [out] The request data to be sent to network
aPostData | data to be posted
aContact | contact to which the post belonged
aEdited | whether user changed items within the post
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfPostProviderPlugin.

QVector< QTextFormat > FBPostProviderPlugin::supportedFormats ( ) const [virtual]

<Method that returns all the formatting of posts that this service provider supports. May return 0 items to mean only QString is supported.

Returns:
Supported formats of posts

Implements SmfPostProviderPlugin.

bool FBPostProviderPlugin::supportsAppearence ( ) const [virtual]

Method that returns whether this SP supports Appearence

Returns:
Returns true if Appearance is supported, else false.
See also:
SmfAppearenceInfo

Implements SmfPostProviderPlugin.

SmfPluginError FBPostProviderPlugin::updatePost | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPost & | aPostData |
 | ) |  |  | [virtual]

Method to update the last post to own area with new data

Parameters:
aRequest | [out] The request data to be sent to network
aPostData | The edited/new data to be posted
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfPostProviderPlugin.

The documentation for this class was generated from the following files:
  • example/fbpostproviderplugin/fbpostproviderplugin.h
  • example/fbpostproviderplugin/fbpostproviderplugin.cpp
Generated on Thu Sep 23 15:03:25 2010 for smf by doxygen 1.6.3


smf: Member List

FBPostProviderPlugin Member List

This is the complete list of members for FBPostProviderPlugin, including all inherited members.
commentOnAPost(SmfPluginRequestData &aRequest, const SmfPost &aTarget, const SmfPost &aComment, const SmfLocation *aLocation=NULL) | FBPostProviderPlugin | [virtual]
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData) | FBPostProviderPlugin | [virtual]
getProviderInfo() | FBPostProviderPlugin | [virtual]
initialize() | FBPostProviderPlugin | [virtual]
maxCharsInPost() const | FBPostProviderPlugin | [virtual]
maxItems() const | FBPostProviderPlugin | [virtual]
post(SmfPluginRequestData &aRequest, const SmfPost &aPostData, const SmfLocation &aLocation) | FBPostProviderPlugin | [virtual]
postAppearence(SmfPluginRequestData &aRequest, const SmfPresenceInfo &aAppearence, const QString &aStatus) | FBPostProviderPlugin | [virtual]
postDirected(SmfPluginRequestData &aRequest, const SmfPost &aPostData, const SmfContact &aContact, const SmfLocation *aLocation=NULL) | FBPostProviderPlugin | [virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult) | FBPostProviderPlugin | [virtual]
retrieve(SmfPluginRequestData &aRequest, const SmfContact *aUser=0, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FBPostProviderPlugin | [virtual]
sharePost(SmfPluginRequestData &aRequest, const SmfPost &aPostData, const SmfContact &aContact, const bool &aEdited) | FBPostProviderPlugin | [virtual]
supportedFormats() const | FBPostProviderPlugin | [virtual]
supportsAppearence() const | FBPostProviderPlugin | [virtual]
updatePost(SmfPluginRequestData &aRequest, const SmfPost &aPostData) | FBPostProviderPlugin | [virtual]
~FBPostProviderPlugin() | FBPostProviderPlugin | [virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
~SmfPostProviderPlugin() | SmfPostProviderPlugin | [inline, virtual]
Generated on Thu Sep 23 15:03:25 2010 for smf by doxygen 1.6.3


smf: FBProviderBase Class Reference

FBProviderBase Class Reference

#include <fbpostproviderplugin.h>

Inherits SmfProviderBase.

List of all members.

Public Member Functions

virtual | ~FBProviderBase ()
QString | serviceName () const
QImage | serviceIcon () const
QString | description () const
QUrl | serviceUrl () const
QUrl | applicationUrl () const
QImage | applicationIcon () const
QList< QString > | supportedInterfaces () const
QStringList | supportedLanguages () const
QString | pluginId () const
QString | authenticationApp (QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const
QString | smfRegistrationId () const

Friends

class | FBPostProviderPlugin

Detailed Description

The Plugin class that implements SmfProviderBase for this facebook plugin

Constructor & Destructor Documentation

FBProviderBase::~FBProviderBase ( ) [virtual]

Destructor

Member Function Documentation

QImage FBProviderBase::applicationIcon ( ) const [virtual]

Method to get the Icon of the application

Returns:
The Icon of the application

Implements SmfProviderBase.

QUrl FBProviderBase::applicationUrl ( ) const [virtual]

Method to get the URL of the Application providing this service

Returns:
The URL of the Application providing this service

Implements SmfProviderBase.

QString FBProviderBase::authenticationApp | ( | QString & | aProgram,
 |  | QStringList & | aArguments,
 |  | QIODevice::OpenModeFlag | aMode = QIODevice::ReadWrite |
 | ) |  |  | const [virtual]

Method to get the ID of the authentication application for this service

Parameters:
aProgram | The authentication application name
aArguments | List of arguments required for authentication app
aMode | Strting mode for authentication application
Returns:
The ID of the authentication application

Implements SmfProviderBase.

QString FBProviderBase::description ( ) const [virtual]

Method to get the Readable service description

Returns:
The Readable service description

Implements SmfProviderBase.

QString FBProviderBase::pluginId ( ) const [virtual]

Method to get the Plugin specific ID

Returns:
The Plugin specific ID

Implements SmfProviderBase.

QImage FBProviderBase::serviceIcon ( ) const [virtual]

Method to get the Logo of the service

Returns:
The Logo of the service

Implements SmfProviderBase.

QString FBProviderBase::serviceName ( ) const [virtual]

Method to get the Localisable name of the service.

Returns:
The Localisable name of the service.

Implements SmfProviderBase.

QUrl FBProviderBase::serviceUrl ( ) const [virtual]

Method to get the Website of the service

Returns:
The Website of the service

Implements SmfProviderBase.

QString FBProviderBase::smfRegistrationId ( ) const [virtual]

Method to get the unique registration ID provided by the Smf for authorised plugins

Returns:
The unique registration ID/token provided by the Smf for authorised plugins

Implements SmfProviderBase.

QList< QString > FBProviderBase::supportedInterfaces ( ) const [virtual]

Method to get the list of interfaces that this provider support

Returns:
List of supported Interafces

Implements SmfProviderBase.

QStringList FBProviderBase::supportedLanguages ( ) const [virtual]

Method to get the list of languages supported by this service provider

Returns:
a QStringList of languages supported by this service provider in 2 letter ISO 639-1 format.

Implements SmfProviderBase.

The documentation for this class was generated from the following files:
  • example/fbpostproviderplugin/fbpostproviderplugin.h
  • example/fbpostproviderplugin/fbpostproviderplugin.cpp
Generated on Thu Sep 23 15:03:25 2010 for smf by doxygen 1.6.3


smf: Member List

FBProviderBase Member List

This is the complete list of members for FBProviderBase, including all inherited members.
applicationIcon() const | FBProviderBase | [virtual]
applicationUrl() const | FBProviderBase | [virtual]
authenticationApp(QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const | FBProviderBase | [virtual]
description() const | FBProviderBase | [virtual]
FBPostProviderPlugin (defined in FBProviderBase) | FBProviderBase | [friend]
pluginId() const | FBProviderBase | [virtual]
serviceIcon() const | FBProviderBase | [virtual]
serviceName() const | FBProviderBase | [virtual]
serviceUrl() const | FBProviderBase | [virtual]
smfRegistrationId() const | FBProviderBase | [virtual]
supportedInterfaces() const | FBProviderBase | [virtual]
supportedLanguages() const | FBProviderBase | [virtual]
~FBProviderBase() | FBProviderBase | [virtual]
~SmfProviderBase() | SmfProviderBase | [inline, virtual]
Generated on Thu Sep 23 15:03:26 2010 for smf by doxygen 1.6.3


smf: FBRequest Class Reference

FBRequest Class Reference

List of all members.

Signals

void | requestLoading ()
void | requestFailedWithNetworkError (QNetworkReply::NetworkError code)
void | requestFailedWithFacebookError (const FBError &aError)
void | requestDidLoad (const QVariant &aResult)
void | requestWasCancelled ()
void | requestLoading ()
void | requestFailedWithNetworkError (QNetworkReply::NetworkError code)
void | requestFailedWithFlickrError (const FBError &aError)
void | requestDidLoad (const QVariant &aResult)

Public Member Functions

FBRequest (FBSession *aSession)
void | call (const QString &aMethod, const Dictionary &aParams)
void | callWithDataParams (const QString &aMethod, const Dictionary &aParams, const QByteArray &aDataParam, bool aDataParamPicture)
void | post (const QString &aUrl, const Dictionary &aParams)
void | cancel ()
const QDateTime & | timeStamp () const
void | connect ()
FBRequest (FBSession *aSession)
void | call (const QString &aMethod, const Dictionary &aParams)
void | callforToken ()
void | callWithDataParams (const QString &aMethod, const Dictionary &aParams, const QByteArray &aDataParam, bool aDataParamPicture)
void | post (const QString &aUrl, const Dictionary &aParams)
void | cancel ()
const QDateTime & | timeStamp () const
void | connect ()
QString | generateSig (Dictionary Params)
void | proxysettings ()

Static Public Member Functions

static FBRequest * | request ()
static FBRequest * | requestWithSession (FBSession *aSession)
static FBRequest * | request ()
static FBRequest * | requestWithSession (FBSession *aSession)

Constructor & Destructor Documentation

FBRequest::FBRequest ( FBSession * aSession )

Creates a new request paired to a session.

FBRequest::FBRequest ( FBSession * aSession )

Creates a new request paired to a session.

Member Function Documentation

void FBRequest::call | ( | const QString & | aMethod,
 |  | const Dictionary & | aParams
 | ) |  |

Calls a method on the server asynchronously.

The delegate will be called for each stage of the loading process.

void FBRequest::call | ( | const QString & | aMethod,
 |  | const Dictionary & | aParams
 | ) |  |

Calls a method on the server asynchronously.

The delegate will be called for each stage of the loading process.

void FBRequest::callWithDataParams | ( | const QString & | aMethod,
 |  | const Dictionary & | aParams,
 |  | const QByteArray & | aDataParam,
 |  | bool | aDataParamPicture
 | ) |  |

Calls a method on the server asynchronously, with a file upload component.

The delegate will be called for each stage of the loading process.

void FBRequest::callWithDataParams | ( | const QString & | aMethod,
 |  | const Dictionary & | aParams,
 |  | const QByteArray & | aDataParam,
 |  | bool | aDataParamPicture
 | ) |  |

Calls a method on the server asynchronously, with a file upload component.

The delegate will be called for each stage of the loading process.

void FBRequest::cancel ( )

Stops an active request before the response has returned.

void FBRequest::cancel ( )

Stops an active request before the response has returned.

void FBRequest::post | ( | const QString & | aUrl,
 |  | const Dictionary & | aParams
 | ) |  |

Calls a URL on the server asynchronously.

The delegate will be called for each stage of the loading process.

void FBRequest::post | ( | const QString & | aUrl,
 |  | const Dictionary & | aParams
 | ) |  |

Calls a URL on the server asynchronously.

The delegate will be called for each stage of the loading process.

static FBRequest* FBRequest::request ( ) [static]

Creates a new API request for the global session.

FBRequest * FBRequest::request ( ) [static]

Creates a new API request for the global session.

void FBRequest::requestDidLoad ( const QVariant & aResult ) [signal]

Called when a request returns and its response has been parsed into an object.

The resulting object may be a dictionary, an array, a string, or a number, depending on thee format of the API response.

void FBRequest::requestDidLoad ( const QVariant & aResult ) [signal]

Called when a request returns and its response has been parsed into an object.

The resulting object may be a dictionary, an array, a string, or a number, depending on thee format of the API response.

void FBRequest::requestFailedWithNetworkError ( QNetworkReply::NetworkError code ) [signal]

Called when an error prevents the request from completing successfully.

void FBRequest::requestFailedWithNetworkError ( QNetworkReply::NetworkError code ) [signal]

Called when the server responds and begins to send back data. Called when an error prevents the request from completing successfully.

void FBRequest::requestLoading ( ) [signal]

Called just before the request is sent to the server.

void FBRequest::requestLoading ( ) [signal]

Called just before the request is sent to the server.

void FBRequest::requestWasCancelled ( ) [signal]

Called when the request was cancelled.

static FBRequest* FBRequest::requestWithSession ( FBSession * aSession ) [static]

Creates a new API request for a particular session.

FBRequest * FBRequest::requestWithSession ( FBSession * aSession ) [static]

Creates a new API request for a particular session.

const QDateTime& FBRequest::timeStamp ( ) const

returns the time stamp of when the request was sent to the server

const QDateTime & FBRequest::timeStamp ( ) const

returns the time stamp of when the request was sent to the server

The documentation for this class was generated from the following files:
  • example/AuthApp/inc/requestSP.h
  • example/FlickrAuthApp/inc/requestSP.h
  • example/AuthApp/src/requestSP.cpp
  • example/FlickrAuthApp/src/requestSP.cpp
Generated on Thu Sep 23 15:03:26 2010 for smf by doxygen 1.6.3


smf: Member List

FBRequest Member List

This is the complete list of members for FBRequest, including all inherited members.
call(const QString &aMethod, const Dictionary &aParams) | FBRequest |
call(const QString &aMethod, const Dictionary &aParams) | FBRequest |
callforToken() (defined in FBRequest) | FBRequest |
callWithDataParams(const QString &aMethod, const Dictionary &aParams, const QByteArray &aDataParam, bool aDataParamPicture) | FBRequest |
callWithDataParams(const QString &aMethod, const Dictionary &aParams, const QByteArray &aDataParam, bool aDataParamPicture) | FBRequest |
cancel() | FBRequest |
cancel() | FBRequest |
connect() (defined in FBRequest) | FBRequest |
connect() (defined in FBRequest) | FBRequest |
FBRequest(FBSession *aSession) | FBRequest |
FBRequest(FBSession *aSession) | FBRequest |
generateSig(Dictionary Params) (defined in FBRequest) | FBRequest |
post(const QString &aUrl, const Dictionary &aParams) | FBRequest |
post(const QString &aUrl, const Dictionary &aParams) | FBRequest |
proxysettings() (defined in FBRequest) | FBRequest |
request() | FBRequest | [static]
request() | FBRequest | [static]
requestDidLoad(const QVariant &aResult) | FBRequest | [signal]
requestDidLoad(const QVariant &aResult) | FBRequest | [signal]
requestFailedWithFacebookError(const FBError &aError) (defined in FBRequest) | FBRequest | [signal]
requestFailedWithFlickrError(const FBError &aError) (defined in FBRequest) | FBRequest | [signal]
requestFailedWithNetworkError(QNetworkReply::NetworkError code) | FBRequest | [signal]
requestFailedWithNetworkError(QNetworkReply::NetworkError code) | FBRequest | [signal]
requestLoading() | FBRequest | [signal]
requestLoading() | FBRequest | [signal]
requestWasCancelled() | FBRequest | [signal]
requestWithSession(FBSession *aSession) | FBRequest | [static]
requestWithSession(FBSession *aSession) | FBRequest | [static]
timeStamp() const | FBRequest |
timeStamp() const | FBRequest |
Generated on Thu Sep 23 15:03:26 2010 for smf by doxygen 1.6.3


smf: FBSession Class Reference

FBSession Class Reference

#include <sessionSP.h>

List of all members.

Signals

void | sessionDidLogin (QString SessionKey)
void | sessionDidNotLogin ()
void | sessionWillLogout ()
void | sessionDidLogout ()
void | sessionDidLogin (QString SessionKey)
void | sessionDidNotLogin ()
void | sessionWillLogout ()
void | sessionDidLogout ()

Public Member Functions

FBSession (const QString &aKey, const QString &aSecret, const QString &aSessionProxy)
~FBSession ()
void | beginSession (const QString &aSessionKey, const QString &aSessionSecret, const QDateTime &aExpires)
bool | resume ()
void | cancelLogin ()
void | logout ()
void | send (FBRequest *aRequest)
const QString & | apiURL () const
const QString & | apiSecureURL () const
bool | isConnected () const
const QString & | apiSecret () const
const QString & | getSessionProxy () const
const QString & | apiKey () const
const QString & | sessionSecret () const
const QString & | sessionKey () const
FBSession (const QString &aKey, const QString &aSecret, const QString &aSessionProxy)
~FBSession ()
void | SaveFrobKey (const QString &aFrob)
void | Savetoken (const QString &token)
bool | resume ()
void | logout ()
void | send (FBRequest *aRequest)
const QString & | apiURL () const
const QString & | apiSecret () const
const QString & | apiKey () const
const QString & | frobKey () const

Static Public Member Functions

static FBSession * | session ()
static void | setSession (FBSession *aSession)
static FBSession * | sessionForApplication (const QString &aKey, const QString &aSecret, const QString &aSessionProxy)
static FBSession * | session ()
static void | setSession (FBSession *aSession)
static FBSession * | sessionForApplication (const QString &aKey, const QString &aSecret, const QString &aSessionProxy)

Detailed Description

An FBSession represents a single user's authenticated session for a Facebook application.

To create a session, you must use the session key of your application (which can be found on the Facebook developer website). You may then use the login dialog to ask the user to enter their email address and password. If successful, you will get back a session key which can be used to make requests to the Facebook API.

Session keys are cached and stored on the disk of the device so that you do not need to ask the user to login every time they launch the app. To restore the last active session, call the resume method after instantiating your session.

Constructor & Destructor Documentation

FBSession::FBSession | ( | const QString & | aKey,
 |  | const QString & | aSecret,
 |  | const QString & | aSessionProxy
 | ) |  |

Constructs a session for an application.

Parameters:
secret | the application secret (optional)
getSessionProxy | a url to that proxies auth.getSession (optional)
FBSession::~FBSession ( )

Destructor

FBSession::FBSession | ( | const QString & | aKey,
 |  | const QString & | aSecret,
 |  | const QString & | aSessionProxy
 | ) |  |

Constructs a session for an application.

Parameters:
secret | the application secret (optional)
getSessionProxy | a url to that proxies auth.getSession (optional)
FBSession::~FBSession ( )

Destructor

Member Function Documentation

const QString& FBSession::apiKey ( ) const [inline]
Returns:
api key for this session
const QString& FBSession::apiKey ( ) const [inline]
Returns:
api key for this session
const QString& FBSession::apiSecret ( ) const [inline]
Returns:
const QString& the api secret
const QString& FBSession::apiSecret ( ) const [inline]
Returns:
const QString& the api secret
const QString & FBSession::apiSecureURL ( ) const
Returns:
const QString& https:// URL to the secure facebook REST server
const QString& FBSession::apiURL ( ) const
Returns:
const QString& http:// URL to the facebook REST server
const QString & FBSession::apiURL ( ) const
Returns:
const QString& http:// URL to the facebook REST server
void FBSession::beginSession | ( | const QString & | aSessionKey,
 |  | const QString & | aSessionSecret,
 |  | const QDateTime & | aExpires
 | ) |  |

Begins a session for a user with a given key and secret.

void FBSession::cancelLogin ( )

Cancels a login (no-op if the login is already complete).

const QString& FBSession::frobKey ( ) const [inline]
Returns:
the Frob key
const QString& FBSession::getSessionProxy ( ) const [inline]
Returns:
const QString& the GET? session proxy
bool FBSession::isConnected ( ) const

Determines if the session is active and connected.

Returns:
bool true if connected
void FBSession::logout ( )

Ends the current session and deletes the uid, session key, and secret from disk.

void FBSession::logout ( )

Ends the current session and deletes the uid, session key, and secret from disk.

bool FBSession::resume ( )

Resumes a previous session whose uid, session key, and secret are cached on disk.

bool FBSession::resume ( )

Resumes a previous session whose uid, session key, and secret are cached on disk.

void FBSession::SaveFrobKey ( const QString & aFrob )

Saves Frob Key

void FBSession::Savetoken ( const QString & token )

Saves Token

void FBSession::send ( FBRequest * aRequest )

Sends a fully configured request to the server for execution.

void FBSession::send ( FBRequest * aRequest )

Sends a fully configured request to the server for execution.

static FBSession* FBSession::session ( ) [static]

The globally shared session instance.

FBSession * FBSession::session ( ) [static]

The globally shared session instance.

void FBSession::sessionDidLogin ( QString SessionKey ) [signal]

Called when session logged in sucessfully

Parameters:
SessionKey is the fb assigned session key
void FBSession::sessionDidLogin ( QString SessionKey ) [signal]

Called when session logged in sucessfully

Parameters:
SessionKey is the fb assigned session key
void FBSession::sessionDidLogout ( ) [signal]

Called when a session has logged out.

void FBSession::sessionDidLogout ( ) [signal]

Called when a session has logged out.

void FBSession::sessionDidNotLogin ( ) [signal]

Called when a user closes the login dialog without logging in.

void FBSession::sessionDidNotLogin ( ) [signal]

Called when a user closes the login dialog without logging in.

static FBSession* FBSession::sessionForApplication | ( | const QString & | aKey,
 |  | const QString & | aSecret,
 |  | const QString & | aSessionProxy |
 | ) |  |  | [static]

Constructs a session and stores it as the globally shared session instance.

Parameters:
aSessionProxy a url to that proxies auth.getSession
FBSession * FBSession::sessionForApplication | ( | const QString & | aKey,
 |  | const QString & | aSecret,
 |  | const QString & | aSessionProxy |
 | ) |  |  | [static]

Constructs a session and stores it as the globally shared session instance.

Parameters:
aSessionProxy a url to that proxies auth.getSession
const QString& FBSession::sessionKey ( ) const [inline]
Returns:
the session key
const QString& FBSession::sessionSecret ( ) const [inline]
Returns:
the session secret
void FBSession::sessionWillLogout ( ) [signal]

Called when a session is about to log out.

Parameters:
aUid is the fb assigned session id
void FBSession::sessionWillLogout ( ) [signal]

Called when a session is about to log out.

Parameters:
aUid is the fb assigned session id
static void FBSession::setSession ( FBSession * aSession ) [static]

Sets the globally shared session instance.

This session is not retained, so you are still responsible for retaining it yourself. The first session that is created is automatically stored here.

void FBSession::setSession ( FBSession * aSession ) [static]

Sets the globally shared session instance.

This session is not retained, so you are still responsible for retaining it yourself. The first session that is created is automatically stored here.

The documentation for this class was generated from the following files:
  • example/AuthApp/inc/sessionSP.h
  • example/FlickrAuthApp/inc/sessionSP.h
  • example/AuthApp/src/sessionSP.cpp
  • example/FlickrAuthApp/src/sessionSP.cpp
Generated on Thu Sep 23 15:03:26 2010 for smf by doxygen 1.6.3


smf: Member List

FBSession Member List

This is the complete list of members for FBSession, including all inherited members.
apiKey() const | FBSession | [inline]
apiKey() const | FBSession | [inline]
apiSecret() const | FBSession | [inline]
apiSecret() const | FBSession | [inline]
apiSecureURL() const | FBSession |
apiURL() const | FBSession |
apiURL() const | FBSession |
beginSession(const QString &aSessionKey, const QString &aSessionSecret, const QDateTime &aExpires) | FBSession |
cancelLogin() | FBSession |
FBSession(const QString &aKey, const QString &aSecret, const QString &aSessionProxy) | FBSession |
FBSession(const QString &aKey, const QString &aSecret, const QString &aSessionProxy) | FBSession |
frobKey() const | FBSession | [inline]
getSessionProxy() const | FBSession | [inline]
isConnected() const | FBSession |
logout() | FBSession |
logout() | FBSession |
resume() | FBSession |
resume() | FBSession |
SaveFrobKey(const QString &aFrob) | FBSession |
Savetoken(const QString &token) | FBSession |
send(FBRequest *aRequest) | FBSession |
send(FBRequest *aRequest) | FBSession |
session() | FBSession | [static]
session() | FBSession | [static]
sessionDidLogin(QString SessionKey) | FBSession | [signal]
sessionDidLogin(QString SessionKey) | FBSession | [signal]
sessionDidLogout() | FBSession | [signal]
sessionDidLogout() | FBSession | [signal]
sessionDidNotLogin() | FBSession | [signal]
sessionDidNotLogin() | FBSession | [signal]
sessionForApplication(const QString &aKey, const QString &aSecret, const QString &aSessionProxy) | FBSession | [static]
sessionForApplication(const QString &aKey, const QString &aSecret, const QString &aSessionProxy) | FBSession | [static]
sessionKey() const | FBSession | [inline]
sessionSecret() const | FBSession | [inline]
sessionWillLogout() | FBSession | [signal]
sessionWillLogout() | FBSession | [signal]
setSession(FBSession *aSession) | FBSession | [static]
setSession(FBSession *aSession) | FBSession | [static]
~FBSession() | FBSession |
~FBSession() | FBSession |
Generated on Thu Sep 23 15:03:26 2010 for smf by doxygen 1.6.3


smf: FBXMLHandler Class Reference

FBXMLHandler Class Reference

List of all members.

Public Member Functions

FBXMLHandler ()
const QString & | rootName () const
QVariant | rootObject () const
bool | parseError () const
const QString & | rootName () const
QVariant | rootObject () const
bool | parseError () const

Constructor & Destructor Documentation

FBXMLHandler::FBXMLHandler ( )

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "{License}" which accompanies this distribution, and is available at the URL "{LicenseUrl}".

Initial Contributors: Narasimhulu Kavadapu, Sasken Communication Technologies Ltd - Initial contribution

Contributors:

Description: XML Parser class

The documentation for this class was generated from the following files:
  • example/AuthApp/inc/xmlParser.h
  • example/FlickrAuthApp/inc/xmlParser.h
  • example/AuthApp/src/xmlParser.cpp
  • example/FlickrAuthApp/src/xmlParser.cpp
Generated on Thu Sep 23 15:03:26 2010 for smf by doxygen 1.6.3


smf: Member List

FBXMLHandler Member List

This is the complete list of members for FBXMLHandler, including all inherited members.
FBXMLHandler() | FBXMLHandler |
FBXMLHandler() (defined in FBXMLHandler) | FBXMLHandler |
parseError() const (defined in FBXMLHandler) | FBXMLHandler | [inline]
parseError() const (defined in FBXMLHandler) | FBXMLHandler | [inline]
rootName() const (defined in FBXMLHandler) | FBXMLHandler | [inline]
rootName() const (defined in FBXMLHandler) | FBXMLHandler | [inline]
rootObject() const (defined in FBXMLHandler) | FBXMLHandler | [inline]
rootObject() const (defined in FBXMLHandler) | FBXMLHandler | [inline]
~FBXMLHandler() (defined in FBXMLHandler) | FBXMLHandler |
~FBXMLHandler() (defined in FBXMLHandler) | FBXMLHandler |
Generated on Thu Sep 23 15:03:26 2010 for smf by doxygen 1.6.3


smf: FlickrContactFetcherPlugin Class Reference

FlickrContactFetcherPlugin Class Reference

#include <flickrcontactfetcherplugin.h>

Inherits SmfContactFetcherPlugin.

List of all members.

Public Member Functions

virtual | ~FlickrContactFetcherPlugin ()
SmfPluginError | friends (SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | followers (SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | search (SmfPluginRequestData &aRequest, const SmfContact &aContact, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | searchNear (SmfPluginRequestData &aRequest, const SmfLocation &aLocation, const SmfLocationSearchBoundary &aProximity, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | groups (SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | searchInGroup (SmfPluginRequestData &aRequest, const SmfGroup &aGroup, SmfContact *aContact=NULL, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)
void | initialize ()
SmfProviderBase * getProviderInfo ()
SmfPluginError | responseAvailable (const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)

Detailed Description

The Plugin that fetches contacts from the logged in user's flickr account

Constructor & Destructor Documentation

FlickrContactFetcherPlugin::~FlickrContactFetcherPlugin ( ) [virtual]

Destructor

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Nalina Hariharan

Description: The Plugin that fetches contacts from the logged in user's flickr account Destructor

Member Function Documentation

SmfPluginError FlickrContactFetcherPlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [virtual]

Customised method for SmfContactFetcherPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | The operation type (should be known between the client interface and the plugin)
aData | The data required to form the request (The type of data should be known between client and the plugin)
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfContactFetcherPlugin.

SmfPluginError FlickrContactFetcherPlugin::followers | ( | SmfPluginRequestData & | aRequest,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get the list of followers

Parameters:
aRequest | [out] The request data to be sent to network
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfContactFetcherPlugin.

SmfPluginError FlickrContactFetcherPlugin::friends | ( | SmfPluginRequestData & | aRequest,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get the list of friends

Parameters:
aRequest | [out] The request data to be sent to network
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfContactFetcherPlugin.

SmfProviderBase * FlickrContactFetcherPlugin::getProviderInfo ( ) [virtual]

Method to get the provider information

Returns:
Instance of SmfProviderBase

Implements SmfPluginBase.

SmfPluginError FlickrContactFetcherPlugin::groups | ( | SmfPluginRequestData & | aRequest,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get the list of groups

Parameters:
aRequest | [out] The request data to be sent to network
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfContactFetcherPlugin.

void FlickrContactFetcherPlugin::initialize ( ) [virtual]

The first method to be called in the plugin that implements this interface. If this method is not called, plugin may not behave as expected.

Implements SmfPluginBase.

SmfPluginError FlickrContactFetcherPlugin::responseAvailable | ( | const SmfRequestTypeID | aOperation,
 |  | const SmfTransportResult & | aTransportResult,
 |  | QByteArray * | aResponse,
 |  | QVariant * | aResult,
 |  | SmfPluginRetType & | aRetType,
 |  | SmfResultPage & | aPageResult |
 | ) |  |  | [virtual]

Method to get the result for a network request.

Parameters:
aOperation | The type of operation to be requested
aTransportResult | The result of transport operation
aResponse | The QByteArray instance containing the network response. The plugins should delete this instance once they have read the data from it.
aResult | [out] An output parameter to the plugin manager.If the return value is SmfSendRequestAgain, QVariant will be of type SmfPluginRequestData. For SmfGalleryPlugin: If last operation was pictures(), aResult will be of type QList<SmfPicture>. If last operation was description(), aResult will be of type QString. If last operation was upload() or postComment(), aResult will be of type bool.
aRetType | [out] SmfPluginRetType
aPageResult | [out] The SmfResultPage structure variable

Implements SmfPluginBase.

SmfPluginError FlickrContactFetcherPlugin::search | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfContact & | aContact,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to search for a contact

Parameters:
aRequest | [out] The request data to be sent to network
aContact | contact to be searched
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfContactFetcherPlugin.

SmfPluginError FlickrContactFetcherPlugin::searchInGroup | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfGroup & | aGroup,
 |  | SmfContact * | aContact = NULL,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to search for a contact in a group

Parameters:
aRequest | [out] The request data to be sent to network
aGroup | the group in which to search
aContact | The contact to be searched, default (NULL) is the self contact.
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfContactFetcherPlugin.

SmfPluginError FlickrContactFetcherPlugin::searchNear | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfLocation & | aLocation,
 |  | const SmfLocationSearchBoundary & | aProximity,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to search for contacts (friends) who are near the user. Proximity defines accuracy level

Parameters:
aRequest | [out] The request data to be sent to network
aLocation | The location search criteria
aProximity | location search boundary
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfContactFetcherPlugin.

The documentation for this class was generated from the following files:
  • example/flickrcontactfetcherplugin/flickrcontactfetcherplugin.h
  • example/flickrcontactfetcherplugin/flickrcontactfetcherplugin.cpp
Generated on Thu Sep 23 15:03:26 2010 for smf by doxygen 1.6.3


smf: Member List

FlickrContactFetcherPlugin Member List

This is the complete list of members for FlickrContactFetcherPlugin, including all inherited members.
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData) | FlickrContactFetcherPlugin | [virtual]
followers(SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FlickrContactFetcherPlugin | [virtual]
friends(SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FlickrContactFetcherPlugin | [virtual]
getProviderInfo() | FlickrContactFetcherPlugin | [virtual]
groups(SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FlickrContactFetcherPlugin | [virtual]
initialize() | FlickrContactFetcherPlugin | [virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult) | FlickrContactFetcherPlugin | [virtual]
search(SmfPluginRequestData &aRequest, const SmfContact &aContact, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FlickrContactFetcherPlugin | [virtual]
searchInGroup(SmfPluginRequestData &aRequest, const SmfGroup &aGroup, SmfContact *aContact=NULL, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FlickrContactFetcherPlugin | [virtual]
searchNear(SmfPluginRequestData &aRequest, const SmfLocation &aLocation, const SmfLocationSearchBoundary &aProximity, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FlickrContactFetcherPlugin | [virtual]
~FlickrContactFetcherPlugin() | FlickrContactFetcherPlugin | [virtual]
~SmfContactFetcherPlugin() | SmfContactFetcherPlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:26 2010 for smf by doxygen 1.6.3


smf: FlickrGalleryPlugin Class Reference

FlickrGalleryPlugin Class Reference

#include <flickrgalleryplugin.h>

Inherits SmfGalleryPlugin.

List of all members.

Public Member Functions

virtual | ~FlickrGalleryPlugin ()
SmfPluginError | albums (SmfPluginRequestData &aRequest, const QStringList &aNames, const SmfContact *aUser, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | pictures (SmfPluginRequestData &aRequest, const SmfPictureAlbumList &aAlbums, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | description (SmfPluginRequestData &aRequest, const SmfPicture &aImage)
SmfPluginError | upload (SmfPluginRequestData &aRequest, const SmfPicture &aImage, const SmfPictureAlbum *aAlbum=NULL)
SmfPluginError | upload (SmfPluginRequestData &aRequest, const QList< SmfPicture > &aImages, const SmfPictureAlbum *aAlbum=NULL)
SmfPluginError | postComment (SmfPluginRequestData &aRequest, const SmfPicture &aImage, const SmfComment &aComment)
SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)
void | initialize ()
SmfProviderBase * getProviderInfo ()
SmfPluginError | responseAvailable (const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)
QByteArray | constructField (const QString &aName, const QString &aContent, const QByteArray &aBoundary, const QString &aFilename=QString())

Detailed Description

The Plugin that fetches gallery related items from the logged in user's flickr account

Constructor & Destructor Documentation

FlickrGalleryPlugin::~FlickrGalleryPlugin ( ) [virtual]

Destructor

Member Function Documentation

SmfPluginError FlickrGalleryPlugin::albums | ( | SmfPluginRequestData & | aRequest,
 |  | const QStringList & | aNames,
 |  | const SmfContact * | aUser,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get a list of albums

Parameters:
aRequest | [out] The request data to be sent to network
aNames | The subject or any keywords to be used to filter albums with that name
aUser | The user whose albums are requested
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfGalleryPlugin.

QByteArray FlickrGalleryPlugin::constructField | ( | const QString & | aName,
 |  | const QString & | aContent,
 |  | const QByteArray & | aBoundary,
 |  | const QString & | aFilename = QString()
 | ) |  |

Method to construct individual fields for photo upload

Parameters:
aName | The name argument
aContent | The content of this field
aBoundary | The boundary string (need to be unique in the payload data)
aFilename | The filename if for photo field
Returns:
The field data constructed by this method
SmfPluginError FlickrGalleryPlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [virtual]

Customised method for SMFGalleryPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | The operation type (should be known between the client interface and the plugin)
aData | The data required to form the request (The type of data should be known between client and the plugin)
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Customised method for SmfContactFetcherPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | The operation type (should be known between the client interface and the plugin)
aData | The data required to form the request (The type of data should be known between client and the plugin)
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfGalleryPlugin.

SmfPluginError FlickrGalleryPlugin::description | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPicture & | aImage |
 | ) |  |  | [virtual]

Method to get a description

Parameters:
aRequest | [out] The request data to be sent to network
aImage | The image abot which the description is required
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfGalleryPlugin.

SmfProviderBase * FlickrGalleryPlugin::getProviderInfo ( ) [virtual]

Method to get the provider information

Returns:
Instance of SmfProviderBase

Implements SmfPluginBase.

void FlickrGalleryPlugin::initialize ( ) [virtual]

The first method to be called in the plugin that implements this interface. If this method is not called, plugin may not behave as expected.

Implements SmfPluginBase.

SmfPluginError FlickrGalleryPlugin::pictures | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPictureAlbumList & | aAlbums,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get a list of pictures

Parameters:
aRequest | [out] The request data to be sent to network
aAlbums | The album(s) whose pictures are being requested
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfGalleryPlugin.

SmfPluginError FlickrGalleryPlugin::postComment | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPicture & | aImage,
 |  | const SmfComment & | aComment |
 | ) |  |  | [virtual]

Method to post comment on a picture is available

Parameters:
aRequest | [out] The request data to be sent to network
aImage | The image on which comment is to be posted
aComment | The comment to be posted
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfGalleryPlugin.

SmfPluginError FlickrGalleryPlugin::responseAvailable | ( | const SmfRequestTypeID | aOperation,
 |  | const SmfTransportResult & | aTransportResult,
 |  | QByteArray * | aResponse,
 |  | QVariant * | aResult,
 |  | SmfPluginRetType & | aRetType,
 |  | SmfResultPage & | aPageResult |
 | ) |  |  | [virtual]

Method to get the result for a network request.

Parameters:
aOperation | The type of operation to be requested
aTransportResult | The result of transport operation
aResponse | The QByteArray instance containing the network response. The plugins should delete this instance once they have read the data from it.
aResult | [out] An output parameter to the plugin manager.If the return value is SmfSendRequestAgain, QVariant will be of type SmfPluginRequestData. For SmfGalleryPlugin: If last operation was albums, aResult will be of type QList<SmfPictureAlbum>. If the last operation was pictures(), aResult will be of type QList<SmfPicture>. If last operation was description(), aResult will be of type QString. If last operation was upload() or postComment(), aResult will be of type bool.
aRetType | [out] SmfPluginRetType
aPageResult | [out] The SmfResultPage structure variable

Implements SmfPluginBase.

SmfPluginError FlickrGalleryPlugin::upload | ( | SmfPluginRequestData & | aRequest,
 |  | const QList< SmfPicture > & | aImages,
 |  | const SmfPictureAlbum * | aAlbum = NULL |
 | ) |  |  | [virtual]

Method to upload a list of pictures

Parameters:
aRequest | [out] The request data to be sent to network
aImages | The list of images to be uploaded
aAlbum | the optional destination album name
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Method to upload a list of pictures

Parameters:
aRequest | [out] The request data to be sent to network
aImages | The list of images to be uploaded
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfGalleryPlugin.

SmfPluginError FlickrGalleryPlugin::upload | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPicture & | aImage,
 |  | const SmfPictureAlbum * | aAlbum = NULL |
 | ) |  |  | [virtual]

Method to upload a picture

Parameters:
aRequest | [out] The request data to be sent to network
aImage | The image to be uploaded
aAlbum | the optional destination album name
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfGalleryPlugin.

The documentation for this class was generated from the following files:
  • example/flickrgalleryplugin/flickrgalleryplugin.h
  • example/flickrgalleryplugin/flickrgalleryplugin.cpp
Generated on Thu Sep 23 15:03:26 2010 for smf by doxygen 1.6.3


smf: Member List

FlickrGalleryPlugin Member List

This is the complete list of members for FlickrGalleryPlugin, including all inherited members.
albums(SmfPluginRequestData &aRequest, const QStringList &aNames, const SmfContact *aUser, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FlickrGalleryPlugin | [virtual]
constructField(const QString &aName, const QString &aContent, const QByteArray &aBoundary, const QString &aFilename=QString()) | FlickrGalleryPlugin |
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData) | FlickrGalleryPlugin | [virtual]
description(SmfPluginRequestData &aRequest, const SmfPicture &aImage) | FlickrGalleryPlugin | [virtual]
getProviderInfo() | FlickrGalleryPlugin | [virtual]
initialize() | FlickrGalleryPlugin | [virtual]
pictures(SmfPluginRequestData &aRequest, const SmfPictureAlbumList &aAlbums, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | FlickrGalleryPlugin | [virtual]
postComment(SmfPluginRequestData &aRequest, const SmfPicture &aImage, const SmfComment &aComment) | FlickrGalleryPlugin | [virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult) | FlickrGalleryPlugin | [virtual]
upload(SmfPluginRequestData &aRequest, const SmfPicture &aImage, const SmfPictureAlbum *aAlbum=NULL) | FlickrGalleryPlugin | [virtual]
upload(SmfPluginRequestData &aRequest, const QList< SmfPicture > &aImages, const SmfPictureAlbum *aAlbum=NULL) | FlickrGalleryPlugin | [virtual]
~FlickrGalleryPlugin() | FlickrGalleryPlugin | [virtual]
~SmfGalleryPlugin() | SmfGalleryPlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:26 2010 for smf by doxygen 1.6.3


smf: FlickrProviderBase Class Reference

FlickrProviderBase Class Reference

#include <flickrcontactfetcherplugin.h>

Inherits SmfProviderBase, and SmfProviderBase.

List of all members.

Public Member Functions

virtual | ~FlickrProviderBase ()
QString | serviceName () const
QImage | serviceIcon () const
QString | description () const
QUrl | serviceUrl () const
QUrl | applicationUrl () const
QImage | applicationIcon () const
QList< QString > | supportedInterfaces () const
QStringList | supportedLanguages () const
QString | pluginId () const
QString | authenticationApp (QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const
QString | smfRegistrationId () const
QString | serviceName () const
QImage | serviceIcon () const
QString | description () const
QUrl | serviceUrl () const
QUrl | applicationUrl () const
QImage | applicationIcon () const
QList< QString > | supportedInterfaces () const
QStringList | supportedLanguages () const
QString | pluginId () const
QString | authenticationApp (QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const
QString | smfRegistrationId () const

Friends

class | FlickrContactFetcherPlugin
class | FlickrGalleryPlugin

Detailed Description

The Plugin class that implements SmfProviderBase for this flickr plugin

Constructor & Destructor Documentation

FlickrProviderBase::~FlickrProviderBase ( ) [virtual]

Destructor

Member Function Documentation

QImage FlickrProviderBase::applicationIcon ( ) const [virtual]

Method to get the Icon of the application

Returns:
The Icon of the application

Implements SmfProviderBase.

QImage FlickrProviderBase::applicationIcon ( ) const [virtual]

Method to get the Icon of the application

Returns:
The Icon of the application

Implements SmfProviderBase.

QUrl FlickrProviderBase::applicationUrl ( ) const [virtual]

Method to get the URL of the Application providing this service

Returns:
The URL of the Application providing this service

Implements SmfProviderBase.

QUrl FlickrProviderBase::applicationUrl ( ) const [virtual]

Method to get the URL of the Application providing this service

Returns:
The URL of the Application providing this service

Implements SmfProviderBase.

QString FlickrProviderBase::authenticationApp | ( | QString & | aProgram,
 |  | QStringList & | aArguments,
 |  | QIODevice::OpenModeFlag | aMode = QIODevice::ReadWrite |
 | ) |  |  | const [virtual]

Method to get the ID of the authentication application for this service

Parameters:
aProgram | The authentication application name
aArguments | List of arguments required for authentication app
aMode | Strting mode for authentication application
Returns:
The ID of the authentication application

Implements SmfProviderBase.

QString FlickrProviderBase::authenticationApp | ( | QString & | aProgram,
 |  | QStringList & | aArguments,
 |  | QIODevice::OpenModeFlag | aMode = QIODevice::ReadWrite |
 | ) |  |  | const [virtual]

Method to get the ID of the authentication application for this service

Parameters:
aProgram | The authentication application name
aArguments | List of arguments required for authentication app
aMode | Strting mode for authentication application
Returns:
The ID of the authentication application

Implements SmfProviderBase.

QString FlickrProviderBase::description ( ) const [virtual]

Method to get the Readable service description

Returns:
The Readable service description

Implements SmfProviderBase.

QString FlickrProviderBase::description ( ) const [virtual]

Method to get the Readable service description

Returns:
The Readable service description

Implements SmfProviderBase.

QString FlickrProviderBase::pluginId ( ) const [virtual]

Method to get the Plugin specific ID

Returns:
The Plugin specific ID

Implements SmfProviderBase.

QString FlickrProviderBase::pluginId ( ) const [virtual]

Method to get the Plugin specific ID

Returns:
The Plugin specific ID

Implements SmfProviderBase.

QImage FlickrProviderBase::serviceIcon ( ) const [virtual]

Method to get the Logo of the service

Returns:
The Logo of the service

Implements SmfProviderBase.

QImage FlickrProviderBase::serviceIcon ( ) const [virtual]

Method to get the Logo of the service

Returns:
The Logo of the service

Implements SmfProviderBase.

QString FlickrProviderBase::serviceName ( ) const [virtual]

Method to get the Localisable name of the service.

Returns:
The Localisable name of the service.

Implements SmfProviderBase.

QString FlickrProviderBase::serviceName ( ) const [virtual]

Method to get the Localisable name of the service.

Returns:
The Localisable name of the service.

Implements SmfProviderBase.

QUrl FlickrProviderBase::serviceUrl ( ) const [virtual]

Method to get the Website of the service

Returns:
The Website of the service

Implements SmfProviderBase.

QUrl FlickrProviderBase::serviceUrl ( ) const [virtual]

Method to get the Website of the service

Returns:
The Website of the service

Implements SmfProviderBase.

QString FlickrProviderBase::smfRegistrationId ( ) const [virtual]

Method to get the unique registration ID provided by the Smf for authorised plugins

Returns:
The unique registration ID/token provided by the Smf for authorised plugins

Implements SmfProviderBase.

QString FlickrProviderBase::smfRegistrationId ( ) const [virtual]

Method to get the unique registration ID provided by the Smf for authorised plugins

Returns:
The unique registration ID/token provided by the Smf for authorised plugins

Implements SmfProviderBase.

QList<QString> FlickrProviderBase::supportedInterfaces ( ) const [virtual]

Method to get the list of interfaces that this provider support

Returns:
List of supported Interafces

Implements SmfProviderBase.

QList< QString > FlickrProviderBase::supportedInterfaces ( ) const [virtual]

Method to get the list of interfaces that this provider support

Returns:
List of supported Interafces

Implements SmfProviderBase.

QStringList FlickrProviderBase::supportedLanguages ( ) const [virtual]

Method to get the list of languages supported by this service provider

Returns:
a QStringList of languages supported by this service provider in 2 letter ISO 639-1 format.

Implements SmfProviderBase.

QStringList FlickrProviderBase::supportedLanguages ( ) const [virtual]

Method to get the list of languages supported by this service provider

Returns:
a QStringList of languages supported by this service provider in 2 letter ISO 639-1 format.

Implements SmfProviderBase.

The documentation for this class was generated from the following files:
  • example/flickrcontactfetcherplugin/flickrcontactfetcherplugin.h
  • example/flickrgalleryplugin/flickrgalleryplugin.h
  • example/flickrcontactfetcherplugin/flickrcontactfetcherplugin.cpp
  • example/flickrgalleryplugin/flickrgalleryplugin.cpp
Generated on Thu Sep 23 15:03:26 2010 for smf by doxygen 1.6.3


smf: Member List

FlickrProviderBase Member List

This is the complete list of members for FlickrProviderBase, including all inherited members.
applicationIcon() const | FlickrProviderBase | [virtual]
applicationIcon() const | FlickrProviderBase | [virtual]
applicationUrl() const | FlickrProviderBase | [virtual]
applicationUrl() const | FlickrProviderBase | [virtual]
authenticationApp(QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const | FlickrProviderBase | [virtual]
authenticationApp(QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const | FlickrProviderBase | [virtual]
description() const | FlickrProviderBase | [virtual]
description() const | FlickrProviderBase | [virtual]
FlickrContactFetcherPlugin (defined in FlickrProviderBase) | FlickrProviderBase | [friend]
FlickrGalleryPlugin (defined in FlickrProviderBase) | FlickrProviderBase | [friend]
pluginId() const | FlickrProviderBase | [virtual]
pluginId() const | FlickrProviderBase | [virtual]
serviceIcon() const | FlickrProviderBase | [virtual]
serviceIcon() const | FlickrProviderBase | [virtual]
serviceName() const | FlickrProviderBase | [virtual]
serviceName() const | FlickrProviderBase | [virtual]
serviceUrl() const | FlickrProviderBase | [virtual]
serviceUrl() const | FlickrProviderBase | [virtual]
smfRegistrationId() const | FlickrProviderBase | [virtual]
smfRegistrationId() const | FlickrProviderBase | [virtual]
supportedInterfaces() const | FlickrProviderBase | [virtual]
supportedInterfaces() const | FlickrProviderBase | [virtual]
supportedLanguages() const | FlickrProviderBase | [virtual]
supportedLanguages() const | FlickrProviderBase | [virtual]
~FlickrProviderBase() | FlickrProviderBase | [virtual]
~FlickrProviderBase() (defined in FlickrProviderBase) | FlickrProviderBase | [virtual]
~SmfProviderBase() | SmfProviderBase | [inline, virtual]
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: FriendView Class Reference

FriendView Class Reference

List of all members.

Public Member Functions

FriendView (QString aHeadName)
void SetupUI ()
The documentation for this class was generated from the following files:
  • example/DemoGUI/FriendView.h
  • example/DemoGUI/FriendView.cpp
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: Member List

FriendView Member List

This is the complete list of members for FriendView, including all inherited members.
FriendView(QString aHeadName) (defined in FriendView) | FriendView
SetupUI() (defined in FriendView) | FriendView
~FriendView() (defined in FriendView) | FriendView
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: GridView Class Reference

GridView Class Reference

Its not in use at this poin. More...

#include <GridView.h>

List of all members.

Public Member Functions

void CreateGridView (QStringList aIconPath, QStringList names)

Detailed Description

Its not in use at this poin.

The documentation for this class was generated from the following files:
  • example/DemoGUI/GridView.h
  • example/DemoGUI/GridView.cpp
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: Member List

GridView Member List

This is the complete list of members for GridView, including all inherited members.
CreateGridView(QStringList aIconPath, QStringList names) (defined in GridView) | GridView
GridView() (defined in GridView) | GridView
~GridView() (defined in GridView) | GridView
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: HomeView Class Reference

HomeView Class Reference

List of all members.

Public Member Functions

HomeView (QString aHeadName)
void | SetupUI (QMainWindow *Mainwindow)
void | populateFriendsWidget ()
void | populatePostsWidget ()
void | populateActivitiesWidget ()
void | populatePhotosGridView ()
The documentation for this class was generated from the following files:
  • example/DemoGUI/HomeView.h
  • example/DemoGUI/HomeView.cpp
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: Member List

HomeView Member List

This is the complete list of members for HomeView, including all inherited members.
HomeView(QString aHeadName) (defined in HomeView) | HomeView
populateActivitiesWidget() (defined in HomeView) | HomeView
populateFriendsWidget() (defined in HomeView) | HomeView
populatePhotosGridView() (defined in HomeView) | HomeView
populatePostsWidget() (defined in HomeView) | HomeView
SetupUI(QMainWindow *Mainwindow) (defined in HomeView) | HomeView
~HomeView() (defined in HomeView) | HomeView
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: ImageDownload Class Reference

ImageDownload Class Reference

List of all members.

Public Slots

void | networkReplyFinished (QNetworkReply *aNetworkReply)

Public Member Functions

ImageDownload (QObject *parent=0)
void | downloadImage (HomeView *homeView, QString name, QUrl url, const SmfItemIdentifier &identifier)
The documentation for this class was generated from the following files:
  • example/DemoGUI/ImageDownload.h
  • example/DemoGUI/ImageDownload.cpp
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: Member List

ImageDownload Member List

This is the complete list of members for ImageDownload, including all inherited members.
downloadImage(HomeView *homeView, QString name, QUrl url, const SmfItemIdentifier &identifier) (defined in ImageDownload) | ImageDownload |
ImageDownload(QObject *parent=0) (defined in ImageDownload) | ImageDownload |
networkReplyFinished(QNetworkReply *aNetworkReply) (defined in ImageDownload) | ImageDownload | [slot]
~ImageDownload() (defined in ImageDownload) | ImageDownload |
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: yy::json_parser Class Reference

yy::json_parser

yy::json_parser Class Reference

A Bison parser. More...

#include <json_parser.hh>

List of all members.

Classes

struct | token
Tokens. More...

Public Types

typedef int | semantic_type
Symbol semantic values.
typedef location | location_type
Symbol locations.
typedef token::yytokentype | token_type
Token type.
typedef int | debug_level_type
Type for debugging levels.

Public Member Functions

json_parser (QJson::ParserPrivate *driver_yyarg)
Build a parser object.
virtual int | parse ()
std::ostream & | debug_stream () const
The current debugging stream.
void | set_debug_stream (std::ostream &)
Set the current debugging stream.
debug_level_type | debug_level () const
The current debugging level.
void | set_debug_level (debug_level_type l)
Set the current debugging level.

Detailed Description

A Bison parser.

Member Function Documentation

int yy::json_parser::parse ( ) [virtual]

Parse.

Returns:
0 iff parsing succeeded.

Look-ahead and look-ahead in internal form.

Semantic value of the look-ahead.

Location of the look-ahead.

The locations where the error started and ended.

$$.

$.

The documentation for this class was generated from the following files:
  • smf/smfservermodule/util/qjson/src/json_parser.hh
  • smf/smfservermodule/util/qjson/src/json_parser.cc
Generated on Thu Sep 23 15:03:54 2010 for smf by doxygen 1.6.3


smf: Member List

yy::json_parser Member List

This is the complete list of members for yy::json_parser, including all inherited members.
debug_level() const | yy::json_parser |
debug_level_type typedef | yy::json_parser |
debug_stream() const | yy::json_parser |
json_parser(QJson::ParserPrivate *driver_yyarg) | yy::json_parser |
location_type typedef | yy::json_parser |
parse() | yy::json_parser | [virtual]
semantic_type typedef | yy::json_parser |
set_debug_level(debug_level_type l) | yy::json_parser |
set_debug_stream(std::ostream &) | yy::json_parser |
token_type typedef | yy::json_parser |
~json_parser() (defined in yy::json_parser) | yy::json_parser | [virtual]
Generated on Thu Sep 23 15:03:54 2010 for smf by doxygen 1.6.3


smf: JSonScanner Class Reference

JSonScanner Class Reference

List of all members.

Public Member Functions

JSonScanner (QIODevice *io)
int | yylex (YYSTYPE *yylval, yy::location *yylloc)

Protected Attributes

bool | m_quotmarkClosed
unsigned int | m_quotmarkCount
QIODevice * | m_io
The documentation for this class was generated from the following files:
  • smf/smfservermodule/util/qjson/src/json_scanner.h
  • smf/smfservermodule/util/qjson/src/json_scanner.cpp
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: Member List

JSonScanner Member List

This is the complete list of members for JSonScanner, including all inherited members.
JSonScanner(QIODevice *io) (defined in JSonScanner) | JSonScanner | [explicit]
m_io (defined in JSonScanner) | JSonScanner | [protected]
m_quotmarkClosed (defined in JSonScanner) | JSonScanner | [protected]
m_quotmarkCount (defined in JSonScanner) | JSonScanner | [protected]
yylex(YYSTYPE *yylval, yy::location *yylloc) (defined in JSonScanner) | JSonScanner |
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: LastFmMusicSearchPlugin Class Reference

LastFmMusicSearchPlugin Class Reference

#include <lastfmmusicsearchplugin.h>

Inherits SmfMusicSearchPlugin.

List of all members.

Public Member Functions

virtual | ~LastFmMusicSearchPlugin ()
SmfPluginError | recommendations (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | tracksSimilar (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | tracksOfAlbum (SmfPluginRequestData &aRequest, const SmfAlbum &aAlbum, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | tracksOfArtist (SmfPluginRequestData &aRequest, const SmfArtists &aArtist, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | trackInfo (SmfPluginRequestData &aRequest, const SmfMusicFingerPrint &aSignature, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | stores (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)
void | initialize ()
SmfProviderBase * getProviderInfo ()
SmfPluginError | responseAvailable (const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)

Detailed Description

The Plugin does music serach related functionalities from last.fm site

Constructor & Destructor Documentation

LastFmMusicSearchPlugin::~LastFmMusicSearchPlugin ( ) [virtual]

Destructor

Member Function Documentation

SmfPluginError LastFmMusicSearchPlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [virtual]

Customised method for SmfMusicSearchPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | The operation type (should be known between the client interface and the plugin)
aData | The data required to form the request (The type of data should be known between client and the plugin)
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfMusicSearchPlugin.

SmfProviderBase * LastFmMusicSearchPlugin::getProviderInfo ( ) [virtual]

Method to get the provider information

Returns:
Instance of SmfProviderBase

Implements SmfPluginBase.

void LastFmMusicSearchPlugin::initialize ( ) [virtual]

The first method to be called in the plugin that implements this interface. If this method is not called, plugin may not behave as expected.

Implements SmfPluginBase.

SmfPluginError LastFmMusicSearchPlugin::recommendations | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get recommended tracks

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | The track for which similar recommendations need to be fetched.
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfMusicSearchPlugin.

SmfPluginError LastFmMusicSearchPlugin::responseAvailable | ( | const SmfRequestTypeID | aOperation,
 |  | const SmfTransportResult & | aTransportResult,
 |  | QByteArray * | aResponse,
 |  | QVariant * | aResult,
 |  | SmfPluginRetType & | aRetType,
 |  | SmfResultPage & | aPageResult |
 | ) |  |  | [virtual]

Method to get the result for a network request.

Parameters:
aOperation | The type of operation to be requested
aTransportResult | The result of transport operation
aResponse | The QByteArray instance containing the network response. The plugins should delete this instance once they have read the data from it.
aResult | [out] An output parameter to the plugin manager.If the return value is SmfSendRequestAgain, QVariant will be of type SmfPluginRequestData. For SmfMusicSearchPlugin: If last operation was recommendations(), tracksSimilar() or tracksOfAlbum() or tracksOfArtist() or trackInfo(), aResult will be of type QList<SmfTrackInfo>. If last operation was stores(), aResult will be of type QList<SmfProvider>.
aRetType | [out] SmfPluginRetType
aPageResult | [out] The SmfResultPage structure variable

Implements SmfPluginBase.

SmfPluginError LastFmMusicSearchPlugin::stores | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to search information about where to buy this song from

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | The track for which stores need to be searched
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfMusicSearchPlugin.

SmfPluginError LastFmMusicSearchPlugin::trackInfo | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfMusicFingerPrint & | aSignature,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get tracks having a similar finger print

Parameters:
aRequest | [out] The request data to be sent to network
aSignature | The finger print to be searched for need to be fetched.
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfMusicSearchPlugin.

SmfPluginError LastFmMusicSearchPlugin::tracksOfAlbum | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfAlbum & | aAlbum,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to search for tracks of a given album

Parameters:
aRequest | [out] The request data to be sent to network
aAlbum | The album whose tracks need to be fetched.
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfMusicSearchPlugin.

SmfPluginError LastFmMusicSearchPlugin::tracksOfArtist | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfArtists & | aArtist,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to search for tracks of the given artist(s)

Parameters:
aRequest | [out] The request data to be sent to network
aArtist | The artist(s) whose tracks need to be fetched.
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfMusicSearchPlugin.

SmfPluginError LastFmMusicSearchPlugin::tracksSimilar | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to search for tracks similar to a given track

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | The track for which similar tracks need to be fetched.
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfMusicSearchPlugin.

The documentation for this class was generated from the following files:
  • example/lastfmmusicsearchplugin/lastfmmusicsearchplugin.h
  • example/lastfmmusicsearchplugin/lastfmmusicsearchplugin.cpp
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: Member List

LastFmMusicSearchPlugin Member List

This is the complete list of members for LastFmMusicSearchPlugin, including all inherited members.
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData) | LastFmMusicSearchPlugin | [virtual]
getProviderInfo() | LastFmMusicSearchPlugin | [virtual]
initialize() | LastFmMusicSearchPlugin | [virtual]
recommendations(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | LastFmMusicSearchPlugin | [virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult) | LastFmMusicSearchPlugin | [virtual]
stores(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | LastFmMusicSearchPlugin | [virtual]
trackInfo(SmfPluginRequestData &aRequest, const SmfMusicFingerPrint &aSignature, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | LastFmMusicSearchPlugin | [virtual]
tracksOfAlbum(SmfPluginRequestData &aRequest, const SmfAlbum &aAlbum, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | LastFmMusicSearchPlugin | [virtual]
tracksOfArtist(SmfPluginRequestData &aRequest, const SmfArtists &aArtist, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | LastFmMusicSearchPlugin | [virtual]
tracksSimilar(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | LastFmMusicSearchPlugin | [virtual]
~LastFmMusicSearchPlugin() | LastFmMusicSearchPlugin | [virtual]
~SmfMusicSearchPlugin() | SmfMusicSearchPlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: LastFmMusicSearchProviderBase Class Reference

LastFmMusicSearchProviderBase Class Reference

#include <lastfmmusicsearchplugin.h>

Inherits SmfProviderBase.

List of all members.

Public Member Functions

virtual | ~LastFmMusicSearchProviderBase ()
QString | serviceName () const
QImage | serviceIcon () const
QString | description () const
QUrl | serviceUrl () const
QUrl | applicationUrl () const
QImage | applicationIcon () const
QList< QString > | supportedInterfaces () const
QStringList | supportedLanguages () const
QString | pluginId () const
QString | authenticationApp (QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const
QString | smfRegistrationId () const

Friends

class | LastFmMusicSearchPlugin

Detailed Description

The Plugin class that implements SmfProviderBase for this last.fm plugin

Constructor & Destructor Documentation

LastFmMusicSearchProviderBase::~LastFmMusicSearchProviderBase ( ) [virtual]

Destructor

Member Function Documentation

QImage LastFmMusicSearchProviderBase::applicationIcon ( ) const [virtual]

Method to get the Icon of the application

Returns:
The Icon of the application

Implements SmfProviderBase.

QUrl LastFmMusicSearchProviderBase::applicationUrl ( ) const [virtual]

Method to get the URL of the Application providing this service

Returns:
The URL of the Application providing this service

Implements SmfProviderBase.

QString LastFmMusicSearchProviderBase::authenticationApp | ( | QString & | aProgram,
 |  | QStringList & | aArguments,
 |  | QIODevice::OpenModeFlag | aMode = QIODevice::ReadWrite |
 | ) |  |  | const [virtual]

Method to get the ID of the authentication application for this service

Parameters:
aProgram | The authentication application name
aArguments | List of arguments required for authentication app
aMode | Strting mode for authentication application
Returns:
The ID of the authentication application

Implements SmfProviderBase.

QString LastFmMusicSearchProviderBase::description ( ) const [virtual]

Method to get the Readable service description

Returns:
The Readable service description

Implements SmfProviderBase.

QString LastFmMusicSearchProviderBase::pluginId ( ) const [virtual]

Method to get the Plugin specific ID

Returns:
The Plugin specific ID

Implements SmfProviderBase.

QImage LastFmMusicSearchProviderBase::serviceIcon ( ) const [virtual]

Method to get the Logo of the service

Returns:
The Logo of the service

Implements SmfProviderBase.

QString LastFmMusicSearchProviderBase::serviceName ( ) const [virtual]

Method to get the Localisable name of the service.

Returns:
The Localisable name of the service.

Implements SmfProviderBase.

QUrl LastFmMusicSearchProviderBase::serviceUrl ( ) const [virtual]

Method to get the Website of the service

Returns:
The Website of the service

Implements SmfProviderBase.

QString LastFmMusicSearchProviderBase::smfRegistrationId ( ) const [virtual]

Method to get the unique registration ID provided by the Smf for authorised plugins

Returns:
The unique registration ID/token provided by the Smf for authorised plugins

Implements SmfProviderBase.

QList< QString > LastFmMusicSearchProviderBase::supportedInterfaces ( ) const [virtual]

Method to get the list of interfaces that this provider support

Returns:
List of supported Interafces

Implements SmfProviderBase.

QStringList LastFmMusicSearchProviderBase::supportedLanguages ( ) const [virtual]

Method to get the list of languages supported by this service provider

Returns:
a QStringList of languages supported by this service provider in 2 letter ISO 639-1 format.

Implements SmfProviderBase.

The documentation for this class was generated from the following files:
  • example/lastfmmusicsearchplugin/lastfmmusicsearchplugin.h
  • example/lastfmmusicsearchplugin/lastfmmusicsearchplugin.cpp
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: Member List

LastFmMusicSearchProviderBase Member List

This is the complete list of members for LastFmMusicSearchProviderBase, including all inherited members.
applicationIcon() const | LastFmMusicSearchProviderBase | [virtual]
applicationUrl() const | LastFmMusicSearchProviderBase | [virtual]
authenticationApp(QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const | LastFmMusicSearchProviderBase | [virtual]
description() const | LastFmMusicSearchProviderBase | [virtual]
LastFmMusicSearchPlugin (defined in LastFmMusicSearchProviderBase) | LastFmMusicSearchProviderBase | [friend]
pluginId() const | LastFmMusicSearchProviderBase | [virtual]
serviceIcon() const | LastFmMusicSearchProviderBase | [virtual]
serviceName() const | LastFmMusicSearchProviderBase | [virtual]
serviceUrl() const | LastFmMusicSearchProviderBase | [virtual]
smfRegistrationId() const | LastFmMusicSearchProviderBase | [virtual]
supportedInterfaces() const | LastFmMusicSearchProviderBase | [virtual]
supportedLanguages() const | LastFmMusicSearchProviderBase | [virtual]
~LastFmMusicSearchProviderBase() | LastFmMusicSearchProviderBase | [virtual]
~SmfProviderBase() | SmfProviderBase | [inline, virtual]
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: LastFmMusicServicePlugin Class Reference

LastFmMusicServicePlugin Class Reference

#include <lastfmmusicserviceplugin.h>

Inherits SmfMusicServicePlugin.

List of all members.

Public Member Functions

virtual | ~LastFmMusicServicePlugin ()
SmfPluginError | userMusicInfo (SmfPluginRequestData &aRequest)
SmfPluginError | searchArtist (SmfPluginRequestData &aRequest, const SmfArtists &aArtist, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | searchAlbum (SmfPluginRequestData &aRequest, const SmfAlbum &aAlbum, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | searchEvents (SmfPluginRequestData &aRequest, const SmfEvent &aEvent, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | searchVenue (SmfPluginRequestData &aRequest, const SmfLocation &aVenue, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | searchUser (SmfPluginRequestData &aRequest, const SmfLocation &aPlace, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | postCurrentPlaying (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack)
SmfPluginError | postRating (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const SmfMusicRating &aRating)
SmfPluginError | postComments (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const SmfComment &aComment)
SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)
void | initialize ()
SmfProviderBase * getProviderInfo ()
SmfPluginError | responseAvailable (const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)

Detailed Description

The Plugin does music services related functionalities from last.fm site

Constructor & Destructor Documentation

LastFmMusicServicePlugin::~LastFmMusicServicePlugin ( ) [virtual]

Destructor

Member Function Documentation

SmfPluginError LastFmMusicServicePlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [virtual]

Customised method for SmfMusicServicePlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | [in] The operation type (should be known between the client interface and the plugin)
aData | [in] The data required to form the request (The type of data should be known between client and the plugin)
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implements SmfMusicServicePlugin.

SmfProviderBase * LastFmMusicServicePlugin::getProviderInfo ( ) [virtual]

Method to get the provider information

Returns:
Instance of SmfProviderBase

Implements SmfPluginBase.

void LastFmMusicServicePlugin::initialize ( ) [virtual]

The first method to be called in the plugin that implements this interface. If this method is not called, plugin may not behave as expected.

Implements SmfPluginBase.

SmfPluginError LastFmMusicServicePlugin::postComments | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack,
 |  | const SmfComment & | aComment |
 | ) |  |  | [virtual]

Method to post comment on a track

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | [in] The track on which comment should be posted
aComment | [in] The comment content
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implements SmfMusicServicePlugin.

SmfPluginError LastFmMusicServicePlugin::postCurrentPlaying | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack |
 | ) |  |  | [virtual]

Method to post the currently playing track

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | [in] The current playing track, that should be posted
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implements SmfMusicServicePlugin.

SmfPluginError LastFmMusicServicePlugin::postRating | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack,
 |  | const SmfMusicRating & | aRating |
 | ) |  |  | [virtual]

Method to post the rating on a track

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | [in] The track on which rating should be posted
aRating | [in] The rating values
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implements SmfMusicServicePlugin.

SmfPluginError LastFmMusicServicePlugin::responseAvailable | ( | const SmfRequestTypeID | aOperation,
 |  | const SmfTransportResult & | aTransportResult,
 |  | QByteArray * | aResponse,
 |  | QVariant * | aResult,
 |  | SmfPluginRetType & | aRetType,
 |  | SmfResultPage & | aPageResult |
 | ) |  |  | [virtual]

Method to get the result for a network request.

Parameters:
aOperation | The type of operation to be requested
aTransportResult | The result of transport operation
aResponse | The QByteArray instance containing the network response. The plugins should delete this instance once they have read the data from it.
aResult | [out] An output parameter to the plugin manager.If the return value is SmfSendRequestAgain, QVariant will be of type SmfPluginRequestData. For SmfMusicServicePlugin: If last operation was userMusicInfo(), aResult will be of type SmfMusicProfile. If last operation was searchArtist(), aResult will be of type QList<SmfArtists>. If last operation was searchAlbum(), aResult will be of type QList<SmfAlbum>. If last operation was searchEvents(), aResult will be of type QList<SmfEvent>. If last operation was searchVenue(), aResult will be of type QList<Smfocation>. If last operation was searchUser(), aResult will be of type QList<SmfMusicProfile>. If last operation was postCurrentPlaying() or postRating() or postComments(), aResult will be of type bool.
aRetType | [out] SmfPluginRetType
aPageResult | [out] The SmfResultPage structure variable

Implements SmfPluginBase.

SmfPluginError LastFmMusicServicePlugin::searchAlbum | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfAlbum & | aAlbum,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to search information about album. All information in SmfAlbum is not required, however more available the better

Parameters:
aRequest | [out] The request data to be sent to network
aAlbum | [in] The album which is the search criteria
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implements SmfMusicServicePlugin.

SmfPluginError LastFmMusicServicePlugin::searchArtist | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfArtists & | aArtist,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to search information about artists. All information in SmfArtists is not required, however more available the better

Parameters:
aRequest | [out] The request data to be sent to network
aArtist | The artist which is the search criteria
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implements SmfMusicServicePlugin.

SmfPluginError LastFmMusicServicePlugin::searchEvents | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfEvent & | aEvent,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to search information about events. All information in SmfEvent is not required, however more available the better

Parameters:
aRequest | [out] The request data to be sent to network
aEvent | [in] The event which is the search criteria
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implements SmfMusicServicePlugin.

SmfPluginError LastFmMusicServicePlugin::searchUser | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfLocation & | aPlace,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to search information about other service users for a particular place

Parameters:
aRequest | [out] The request data to be sent to network
aPlace | [in] The place which is the search criteria
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implements SmfMusicServicePlugin.

SmfPluginError LastFmMusicServicePlugin::searchVenue | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfLocation & | aVenue,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to search information about venue. All information in SmfLocation is not required, however more available the better

Parameters:
aRequest | [out] The request data to be sent to network
aVenue | [in] The venue which is the search criteria
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implements SmfMusicServicePlugin.

SmfPluginError LastFmMusicServicePlugin::userMusicInfo ( SmfPluginRequestData & aRequest ) [virtual]

Method to get self profile information

Parameters:
aRequest [out] The request data to be sent to network
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implements SmfMusicServicePlugin.

The documentation for this class was generated from the following files:
  • example/lastfmmusicserviceplugin/lastfmmusicserviceplugin.h
  • example/lastfmmusicserviceplugin/lastfmmusicserviceplugin.cpp
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: Member List

LastFmMusicServicePlugin Member List

This is the complete list of members for LastFmMusicServicePlugin, including all inherited members.
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData) | LastFmMusicServicePlugin | [virtual]
getProviderInfo() | LastFmMusicServicePlugin | [virtual]
initialize() | LastFmMusicServicePlugin | [virtual]
postComments(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const SmfComment &aComment) | LastFmMusicServicePlugin | [virtual]
postCurrentPlaying(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack) | LastFmMusicServicePlugin | [virtual]
postRating(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const SmfMusicRating &aRating) | LastFmMusicServicePlugin | [virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult) | LastFmMusicServicePlugin | [virtual]
searchAlbum(SmfPluginRequestData &aRequest, const SmfAlbum &aAlbum, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | LastFmMusicServicePlugin | [virtual]
searchArtist(SmfPluginRequestData &aRequest, const SmfArtists &aArtist, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | LastFmMusicServicePlugin | [virtual]
searchEvents(SmfPluginRequestData &aRequest, const SmfEvent &aEvent, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | LastFmMusicServicePlugin | [virtual]
searchUser(SmfPluginRequestData &aRequest, const SmfLocation &aPlace, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | LastFmMusicServicePlugin | [virtual]
searchVenue(SmfPluginRequestData &aRequest, const SmfLocation &aVenue, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | LastFmMusicServicePlugin | [virtual]
userMusicInfo(SmfPluginRequestData &aRequest) | LastFmMusicServicePlugin | [virtual]
~LastFmMusicServicePlugin() | LastFmMusicServicePlugin | [virtual]
~SmfMusicServicePlugin() | SmfMusicServicePlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: LastFmMusicServiceProviderBase Class Reference

LastFmMusicServiceProviderBase Class Reference

#include <lastfmmusicserviceplugin.h>

Inherits SmfProviderBase.

List of all members.

Public Member Functions

virtual | ~LastFmMusicServiceProviderBase ()
QString | serviceName () const
QImage | serviceIcon () const
QString | description () const
QUrl | serviceUrl () const
QUrl | applicationUrl () const
QImage | applicationIcon () const
QList< QString > | supportedInterfaces () const
QStringList | supportedLanguages () const
QString | pluginId () const
QString | authenticationApp (QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const
QString | smfRegistrationId () const

Friends

class | LastFmMusicServicePlugin

Detailed Description

The Plugin class that implements SmfProviderBase for this last.fm plugin

Constructor & Destructor Documentation

LastFmMusicServiceProviderBase::~LastFmMusicServiceProviderBase ( ) [virtual]

Destructor

Member Function Documentation

QImage LastFmMusicServiceProviderBase::applicationIcon ( ) const [virtual]

Method to get the Icon of the application

Returns:
The Icon of the application

Implements SmfProviderBase.

QUrl LastFmMusicServiceProviderBase::applicationUrl ( ) const [virtual]

Method to get the URL of the Application providing this service

Returns:
The URL of the Application providing this service

Implements SmfProviderBase.

QString LastFmMusicServiceProviderBase::authenticationApp | ( | QString & | aProgram,
 |  | QStringList & | aArguments,
 |  | QIODevice::OpenModeFlag | aMode = QIODevice::ReadWrite |
 | ) |  |  | const [virtual]

Method to get the ID of the authentication application for this service

Parameters:
aProgram | The authentication application name
aArguments | List of arguments required for authentication app
aMode | Strting mode for authentication application
Returns:
The ID of the authentication application

Implements SmfProviderBase.

QString LastFmMusicServiceProviderBase::description ( ) const [virtual]

Method to get the Readable service description

Returns:
The Readable service description

Implements SmfProviderBase.

QString LastFmMusicServiceProviderBase::pluginId ( ) const [virtual]

Method to get the Plugin specific ID

Returns:
The Plugin specific ID

Implements SmfProviderBase.

QImage LastFmMusicServiceProviderBase::serviceIcon ( ) const [virtual]

Method to get the Logo of the service

Returns:
The Logo of the service

Implements SmfProviderBase.

QString LastFmMusicServiceProviderBase::serviceName ( ) const [virtual]

Method to get the Localisable name of the service.

Returns:
The Localisable name of the service.

Implements SmfProviderBase.

QUrl LastFmMusicServiceProviderBase::serviceUrl ( ) const [virtual]

Method to get the Website of the service

Returns:
The Website of the service

Implements SmfProviderBase.

QString LastFmMusicServiceProviderBase::smfRegistrationId ( ) const [virtual]

Method to get the unique registration ID provided by the Smf for authorised plugins

Returns:
The unique registration ID/token provided by the Smf for authorised plugins

Implements SmfProviderBase.

QList< QString > LastFmMusicServiceProviderBase::supportedInterfaces ( ) const [virtual]

Method to get the list of interfaces that this provider support

Returns:
List of supported Interafces

Implements SmfProviderBase.

QStringList LastFmMusicServiceProviderBase::supportedLanguages ( ) const [virtual]

Method to get the list of languages supported by this service provider

Returns:
a QStringList of languages supported by this service provider in 2 letter ISO 639-1 format.

Implements SmfProviderBase.

The documentation for this class was generated from the following files:
  • example/lastfmmusicserviceplugin/lastfmmusicserviceplugin.h
  • example/lastfmmusicserviceplugin/lastfmmusicserviceplugin.cpp
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: Member List

LastFmMusicServiceProviderBase Member List

This is the complete list of members for LastFmMusicServiceProviderBase, including all inherited members.
applicationIcon() const | LastFmMusicServiceProviderBase | [virtual]
applicationUrl() const | LastFmMusicServiceProviderBase | [virtual]
authenticationApp(QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const | LastFmMusicServiceProviderBase | [virtual]
description() const | LastFmMusicServiceProviderBase | [virtual]
LastFmMusicServicePlugin (defined in LastFmMusicServiceProviderBase) | LastFmMusicServiceProviderBase | [friend]
pluginId() const | LastFmMusicServiceProviderBase | [virtual]
serviceIcon() const | LastFmMusicServiceProviderBase | [virtual]
serviceName() const | LastFmMusicServiceProviderBase | [virtual]
serviceUrl() const | LastFmMusicServiceProviderBase | [virtual]
smfRegistrationId() const | LastFmMusicServiceProviderBase | [virtual]
supportedInterfaces() const | LastFmMusicServiceProviderBase | [virtual]
supportedLanguages() const | LastFmMusicServiceProviderBase | [virtual]
~LastFmMusicServiceProviderBase() | LastFmMusicServiceProviderBase | [virtual]
~SmfProviderBase() | SmfProviderBase | [inline, virtual]
Generated on Thu Sep 23 15:03:27 2010 for smf by doxygen 1.6.3


smf: LastFmPlaylistServicePlugin Class Reference

LastFmPlaylistServicePlugin Class Reference

Inherits SmfPlaylistServicePlugin.

List of all members.

Public Member Functions

virtual | ~LastFmPlaylistServicePlugin ()
SmfPluginError | playlists (SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | playlistsOf (SmfPluginRequestData &aRequest, const SmfContact &aUser, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | addToPlaylist (SmfPluginRequestData &aRequest, const SmfPlaylist &aPlaylist, const QList< SmfTrackInfo > &aTracks)
SmfPluginError | postCurrentPlayingPlaylist (SmfPluginRequestData &aRequest, const SmfPlaylist &aPlaylist)
SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)
void | initialize ()
SmfProviderBase * getProviderInfo ()
SmfPluginError | responseAvailable (const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)

Constructor & Destructor Documentation

LastFmPlaylistServicePlugin::~LastFmPlaylistServicePlugin ( ) [virtual]

Destructor

Member Function Documentation

SmfPluginError LastFmPlaylistServicePlugin::addToPlaylist | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPlaylist & | aPlaylist,
 |  | const QList< SmfTrackInfo > & | aTracks |
 | ) |  |  | [virtual]

Method to add tracks to a playlist

Parameters:
aRequest | [out] The request data to be sent to network
aPlaylist | [in] The playlist where tracks should be added
aTracks | [in] The tracks to be added to the playlist
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implements SmfPlaylistServicePlugin.

SmfPluginError LastFmPlaylistServicePlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [virtual]

Customised method for SmfPlaylistServicePlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | [in] The operation type (should be known between the client interface and the plugin)
aData | [in] The data required to form the request (The type of data should be known between client and the plugin)
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implements SmfPlaylistServicePlugin.

SmfProviderBase * LastFmPlaylistServicePlugin::getProviderInfo ( ) [virtual]

Method to get the provider information

Returns:
Instance of SmfProviderBase

Implements SmfPluginBase.

void LastFmPlaylistServicePlugin::initialize ( ) [virtual]

The first method to be called in the plugin that implements this interface. If this method is not called, plugin may not behave as expected.

Implements SmfPluginBase.

SmfPluginError LastFmPlaylistServicePlugin::playlists | ( | SmfPluginRequestData & | aRequest,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get the playlist

Parameters:
aRequest | [out] The request data to be sent to network
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implements SmfPlaylistServicePlugin.

SmfPluginError LastFmPlaylistServicePlugin::playlistsOf | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfContact & | aUser,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get the playlist of a particular user

Parameters:
aRequest | [out] The request data to be sent to network
aUser | [in] The user whose playlists need to be fetched
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implements SmfPlaylistServicePlugin.

SmfPluginError LastFmPlaylistServicePlugin::postCurrentPlayingPlaylist | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPlaylist & | aPlaylist |
 | ) |  |  | [virtual]

Method to post the current playing playlist

Parameters:
aRequest | [out] The request data to be sent to network
aPlaylist | [in] The current playing playlist which should be posted
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implements SmfPlaylistServicePlugin.

SmfPluginError LastFmPlaylistServicePlugin::responseAvailable | ( | const SmfRequestTypeID | aOperation,
 |  | const SmfTransportResult & | aTransportResult,
 |  | QByteArray * | aResponse,
 |  | QVariant * | aResult,
 |  | SmfPluginRetType & | aRetType,
 |  | SmfResultPage & | aPageResult |
 | ) |  |  | [virtual]

Method to get the result for a network request.

Parameters:
aOperation | The type of operation to be requested
aTransportResult | The result of transport operation
aResponse | The QByteArray instance containing the network response. The plugins should delete this instance once they have read the data from it.
aResult | [out] An output parameter to the plugin manager.If the return value is SmfSendRequestAgain, QVariant will be of type SmfPluginRequestData. For SmfMusicServicePlugin: If last operation was userMusicInfo(), aResult will be of type SmfMusicProfile. If last operation was searchArtist(), aResult will be of type QList<SmfArtists>. If last operation was searchAlbum(), aResult will be of type QList<SmfAlbum>. If last operation was searchEvents(), aResult will be of type QList<SmfEvent>. If last operation was searchVenue(), aResult will be of type QList<Smfocation>. If last operation was searchUser(), aResult will be of type QList<SmfMusicProfile>. If last operation was postCurrentPlaying() or postRating() or postComments(), aResult will be of type bool.
aRetType | [out] SmfPluginRetType
aPageResult | [out] The SmfResultPage structure variable

Implements SmfPluginBase.

The documentation for this class was generated from the following files:
  • example/lastfmplaylistserviceplugin/lastfmplaylistserviceplugin.h
  • example/lastfmplaylistserviceplugin/lastfmplaylistserviceplugin.cpp
Generated on Thu Sep 23 15:03:28 2010 for smf by doxygen 1.6.3


smf: Member List

LastFmPlaylistServicePlugin Member List

This is the complete list of members for LastFmPlaylistServicePlugin, including all inherited members.
addToPlaylist(SmfPluginRequestData &aRequest, const SmfPlaylist &aPlaylist, const QList< SmfTrackInfo > &aTracks) | LastFmPlaylistServicePlugin | [virtual]
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData) | LastFmPlaylistServicePlugin | [virtual]
getProviderInfo() | LastFmPlaylistServicePlugin | [virtual]
initialize() | LastFmPlaylistServicePlugin | [virtual]
playlists(SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | LastFmPlaylistServicePlugin | [virtual]
playlistsOf(SmfPluginRequestData &aRequest, const SmfContact &aUser, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | LastFmPlaylistServicePlugin | [virtual]
postCurrentPlayingPlaylist(SmfPluginRequestData &aRequest, const SmfPlaylist &aPlaylist) | LastFmPlaylistServicePlugin | [virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult) | LastFmPlaylistServicePlugin | [virtual]
~LastFmPlaylistServicePlugin() | LastFmPlaylistServicePlugin | [virtual]
~SmfPlaylistServicePlugin() | SmfPlaylistServicePlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:28 2010 for smf by doxygen 1.6.3


smf: LastFmPlaylistServiceProviderBase Class Reference

LastFmPlaylistServiceProviderBase Class Reference

#include <lastfmplaylistserviceplugin.h>

Inherits SmfProviderBase.

List of all members.

Public Member Functions

virtual | ~LastFmPlaylistServiceProviderBase ()
QString | serviceName () const
QImage | serviceIcon () const
QString | description () const
QUrl | serviceUrl () const
QUrl | applicationUrl () const
QImage | applicationIcon () const
QList< QString > | supportedInterfaces () const
QStringList | supportedLanguages () const
QString | pluginId () const
QString | authenticationApp (QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const
QString | smfRegistrationId () const

Friends

class | LastFmPlaylistServicePlugin

Detailed Description

The Plugin class that implements SmfProviderBase for this last.fm plugin

Constructor & Destructor Documentation

LastFmPlaylistServiceProviderBase::~LastFmPlaylistServiceProviderBase ( ) [virtual]

Destructor

Member Function Documentation

QImage LastFmPlaylistServiceProviderBase::applicationIcon ( ) const [virtual]

Method to get the Icon of the application

Returns:
The Icon of the application

Implements SmfProviderBase.

QUrl LastFmPlaylistServiceProviderBase::applicationUrl ( ) const [virtual]

Method to get the URL of the Application providing this service

Returns:
The URL of the Application providing this service

Implements SmfProviderBase.

QString LastFmPlaylistServiceProviderBase::authenticationApp | ( | QString & | aProgram,
 |  | QStringList & | aArguments,
 |  | QIODevice::OpenModeFlag | aMode = QIODevice::ReadWrite |
 | ) |  |  | const [virtual]

Method to get the ID of the authentication application for this service

Parameters:
aProgram | The authentication application name
aArguments | List of arguments required for authentication app
aMode | Strting mode for authentication application
Returns:
The ID of the authentication application

Implements SmfProviderBase.

QString LastFmPlaylistServiceProviderBase::description ( ) const [virtual]

Method to get the Readable service description

Returns:
The Readable service description

Implements SmfProviderBase.

QString LastFmPlaylistServiceProviderBase::pluginId ( ) const [virtual]

Method to get the Plugin specific ID

Returns:
The Plugin specific ID

Implements SmfProviderBase.

QImage LastFmPlaylistServiceProviderBase::serviceIcon ( ) const [virtual]

Method to get the Logo of the service

Returns:
The Logo of the service

Implements SmfProviderBase.

QString LastFmPlaylistServiceProviderBase::serviceName ( ) const [virtual]

Method to get the Localisable name of the service.

Returns:
The Localisable name of the service.

Implements SmfProviderBase.

QUrl LastFmPlaylistServiceProviderBase::serviceUrl ( ) const [virtual]

Method to get the Website of the service

Returns:
The Website of the service

Implements SmfProviderBase.

QString LastFmPlaylistServiceProviderBase::smfRegistrationId ( ) const [virtual]

Method to get the unique registration ID provided by the Smf for authorised plugins

Returns:
The unique registration ID/token provided by the Smf for authorised plugins

Implements SmfProviderBase.

QList< QString > LastFmPlaylistServiceProviderBase::supportedInterfaces ( ) const [virtual]

Method to get the list of interfaces that this provider support

Returns:
List of supported Interafces

Implements SmfProviderBase.

QStringList LastFmPlaylistServiceProviderBase::supportedLanguages ( ) const [virtual]

Method to get the list of languages supported by this service provider

Returns:
a QStringList of languages supported by this service provider in 2 letter ISO 639-1 format.

Implements SmfProviderBase.

The documentation for this class was generated from the following files:
  • example/lastfmplaylistserviceplugin/lastfmplaylistserviceplugin.h
  • example/lastfmplaylistserviceplugin/lastfmplaylistserviceplugin.cpp
Generated on Thu Sep 23 15:03:28 2010 for smf by doxygen 1.6.3


smf: Member List

LastFmPlaylistServiceProviderBase Member List

This is the complete list of members for LastFmPlaylistServiceProviderBase, including all inherited members.
applicationIcon() const | LastFmPlaylistServiceProviderBase | [virtual]
applicationUrl() const | LastFmPlaylistServiceProviderBase | [virtual]
authenticationApp(QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const | LastFmPlaylistServiceProviderBase | [virtual]
description() const | LastFmPlaylistServiceProviderBase | [virtual]
LastFmPlaylistServicePlugin (defined in LastFmPlaylistServiceProviderBase) | LastFmPlaylistServiceProviderBase | [friend]
pluginId() const | LastFmPlaylistServiceProviderBase | [virtual]
serviceIcon() const | LastFmPlaylistServiceProviderBase | [virtual]
serviceName() const | LastFmPlaylistServiceProviderBase | [virtual]
serviceUrl() const | LastFmPlaylistServiceProviderBase | [virtual]
smfRegistrationId() const | LastFmPlaylistServiceProviderBase | [virtual]
supportedInterfaces() const | LastFmPlaylistServiceProviderBase | [virtual]
supportedLanguages() const | LastFmPlaylistServiceProviderBase | [virtual]
~LastFmPlaylistServiceProviderBase() | LastFmPlaylistServiceProviderBase | [virtual]
~SmfProviderBase() | SmfProviderBase | [inline, virtual]
Generated on Thu Sep 23 15:03:28 2010 for smf by doxygen 1.6.3


smf: yy::location Class Reference

yy::location

yy::location Class Reference

Abstract a location. More...

#include <location.hh>

List of all members.

Public Member Functions

location ()
Construct a location.
void | initialize (std::string *fn)
Initialization.
Line and Column related manipulators

void | step ()
Reset initial location to final location.
void | columns (unsigned int count=1)
Extend the current location to the COUNT next columns.
void | lines (unsigned int count=1)
Extend the current location to the COUNT next lines.

Public Attributes

position begin
Beginning of the located region.
position end
End of the located region.

Detailed Description

Abstract a location.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/util/qjson/src/location.hh
Generated on Thu Sep 23 15:03:54 2010 for smf by doxygen 1.6.3


smf: Member List

yy::location Member List

This is the complete list of members for yy::location, including all inherited members.
begin | yy::location |
columns(unsigned int count=1) | yy::location | [inline]
end | yy::location |
initialize(std::string *fn) | yy::location | [inline]
lines(unsigned int count=1) | yy::location | [inline]
location() | yy::location | [inline]
step() | yy::location | [inline]
Generated on Thu Sep 23 15:03:54 2010 for smf by doxygen 1.6.3


smf: MainWindow Class Reference

MainWindow Class Reference

List of all members.

Public Member Functions

MainWindow (QWidget *parent=0)

Protected Member Functions

void changeEvent (QEvent *e)
The documentation for this class was generated from the following files:
  • example/DemoGUI/mainwindow.h
  • example/DemoGUI/mainwindow.cpp
Generated on Thu Sep 23 15:03:28 2010 for smf by doxygen 1.6.3


smf: Member List

MainWindow Member List

This is the complete list of members for MainWindow, including all inherited members.
changeEvent(QEvent *e) (defined in MainWindow) | MainWindow | [protected]
MainWindow(QWidget *parent=0) (defined in MainWindow) | MainWindow |
~MainWindow() (defined in MainWindow) | MainWindow |
Generated on Thu Sep 23 15:03:28 2010 for smf by doxygen 1.6.3


smf: Ui::MainWindow Class Reference

Ui::MainWindow

Ui::MainWindow Class Reference

Inherits Ui_MainWindow.

List of all members.

The documentation for this class was generated from the following file:
  • example/DemoGUI/ui_mainwindow.h
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: Member List

Ui::MainWindow Member List

This is the complete list of members for Ui::MainWindow, including all inherited members.
centralWidget (defined in Ui_MainWindow) | Ui_MainWindow |
mainToolBar (defined in Ui_MainWindow) | Ui_MainWindow |
menuBar (defined in Ui_MainWindow) | Ui_MainWindow |
retranslateUi(QMainWindow *MainWindow) (defined in Ui_MainWindow) | Ui_MainWindow | [inline]
setupUi(QMainWindow *MainWindow) (defined in Ui_MainWindow) | Ui_MainWindow | [inline]
statusBar (defined in Ui_MainWindow) | Ui_MainWindow |
textEdit (defined in Ui_MainWindow) | Ui_MainWindow |
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: MusicEventPlugin Class Reference

MusicEventPlugin Class Reference

Inherits SmfEventsFetcherPlugin.

List of all members.

Public Member Functions

virtual | ~MusicEventPlugin ()
void | fetchKeys (QString &aApiKey, QString &aApiSecret, QString &aSessionKey, QString &aSessionSecret)
SmfPluginError | venues (SmfPluginRequestData &aRequest, const SmfLocation &aLocation, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | events (SmfPluginRequestData &aRequest, const SmfLocation &aVenue, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | postEvents (SmfPluginRequestData &aRequest, const QList< SmfEvent > &aEventList)
SmfPluginError | attendees (SmfPluginRequestData &aRequest, const SmfEvent &aEvent, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)
void | initialize ()
SmfProviderBase * getProviderInfo ()
SmfPluginError | responseAvailable (const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)
void | writeLog (QString log) const

Constructor & Destructor Documentation

MusicEventPlugin::~MusicEventPlugin ( ) [virtual]

Destructor

Member Function Documentation

SmfPluginError MusicEventPlugin::attendees | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfEvent & | aEvent,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Customised method for SmfMusicEventsPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | The operation type (should be known between the client interface and the plugin)
aData | The data required to form the request (The type of data should be known between client and the plugin)
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfEventsFetcherPlugin.

SmfPluginError MusicEventPlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [virtual]

Customised method for SmfMusicEventsPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | The operation type (should be known between the client interface and the plugin)
aData | The data required to form the request (The type of data should be known between client and the plugin)
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfEventsFetcherPlugin.

SmfPluginError MusicEventPlugin::events | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfLocation & | aVenue,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get the events based on venues

Parameters:
aRequest | [out] The request data to be sent to network
aVenue | Venue of the event
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfEventsFetcherPlugin.

void MusicEventPlugin::fetchKeys | ( | QString & | aApiKey,
 |  | QString & | aApiSecret,
 |  | QString & | aSessionKey,
 |  | QString & | aSessionSecret
 | ) |  |

Method to get the events based on location

Parameters:
aRequest | [out] The request data to be sent to network
aLocation | Location of the event
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone Method to get the venues based on location
Parameters:
aRequest | [out] The request data to be sent to network
aLocation | Location of the venue
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Method to interpret the key sets obtained from credential manager

Parameters:
aApiKey | [out] The api key
aApiSecret | [out] The api secret
aSessionKey | [out] The session key
aSessionSecret | [out] The session secret
aAppId | [out] The application ID
SmfProviderBase * MusicEventPlugin::getProviderInfo ( ) [virtual]

Method to get the provider information

Returns:
Instance of SmfProviderBase

Implements SmfPluginBase.

void MusicEventPlugin::initialize ( ) [virtual]

The first method to be called in the plugin that implements this interface. If this method is not called, plugin may not behave as expected. Plugins are expected to save the aUtil handle and use and when required.

Parameters:
aUtil The instance of SmfPluginUtil

Implements SmfPluginBase.

SmfPluginError MusicEventPlugin::postEvents | ( | SmfPluginRequestData & | aRequest,
 |  | const QList< SmfEvent > & | aEventList |
 | ) |  |  | [virtual]

Method to post events

Parameters:
aRequest | [out] The request data to be sent to network
aEventList | The list of events to be posted
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfEventsFetcherPlugin.

SmfPluginError MusicEventPlugin::responseAvailable | ( | const SmfRequestTypeID | aOperation,
 |  | const SmfTransportResult & | aTransportResult,
 |  | QByteArray * | aResponse,
 |  | QVariant * | aResult,
 |  | SmfPluginRetType & | aRetType,
 |  | SmfResultPage & | aPageResult |
 | ) |  |  | [virtual]

Method to get the result for a network request.

Parameters:
aTransportResult | The result of transport operation
aReply | The QNetworkReply instance for the request
aResult | [out] An output parameter to the plugin manager.If the return value is SmfSendRequestAgain, QVariant will be of type SmfPluginRequestData. For SmfGalleryPlugin: If last operation was pictures(), aResult will be of type QList<SmfPicture>. If last operation was description(), aResult will be of type QString. If last operation was upload() or postComment(), aResult will be of type bool.
aRetType | [out] SmfPluginRetType
aPageResult | [out] The SmfResultPage structure variable

Method to get the result for a network request.

Parameters:
aOperation | The type of operation to be requested
aTransportResult | The result of transport operation
aResponse | The QByteArray instance containing the network response. The plugins should delete this instance once they have read the data from it.
aResult | [out] An output parameter to the plugin manager.If the return value is SmfSendRequestAgain, QVariant will be of type SmfPluginRequestData. For SmfGalleryPlugin: If last operation was pictures(), aResult will be of type QList<SmfPicture>. If last operation was description(), aResult will be of type QString. If last operation was upload() or postComment(), aResult will be of type bool.
aRetType | [out] SmfPluginRetType
aPageResult | [out] The SmfResultPage structure variable

Implements SmfPluginBase.

SmfPluginError MusicEventPlugin::venues | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfLocation & | aLocation,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get the events based on location

Parameters:
aRequest | [out] The request data to be sent to network
aLocation | Location of the event
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone Method to get the venues based on location
Parameters:
aRequest | [out] The request data to be sent to network
aLocation | Location of the venue
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfEventsFetcherPlugin.

void MusicEventPlugin::writeLog ( QString log ) const

Method called by plugins for logging

Parameters:
log string to be logged
The documentation for this class was generated from the following files:
  • example/lastfmmusiceventplugin/lastfmmusiceventplugin.h
  • example/lastfmmusiceventplugin/lastfmmusiceventplugin.cpp
Generated on Thu Sep 23 15:03:28 2010 for smf by doxygen 1.6.3


smf: Member List

MusicEventPlugin Member List

This is the complete list of members for MusicEventPlugin, including all inherited members.
attendees(SmfPluginRequestData &aRequest, const SmfEvent &aEvent, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | MusicEventPlugin | [virtual]
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData) | MusicEventPlugin | [virtual]
events(SmfPluginRequestData &aRequest, const SmfLocation &aVenue, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | MusicEventPlugin | [virtual]
fetchKeys(QString &aApiKey, QString &aApiSecret, QString &aSessionKey, QString &aSessionSecret) | MusicEventPlugin |
getProviderInfo() | MusicEventPlugin | [virtual]
initialize() | MusicEventPlugin | [virtual]
postEvents(SmfPluginRequestData &aRequest, const QList< SmfEvent > &aEventList) | MusicEventPlugin | [virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult) | MusicEventPlugin | [virtual]
venues(SmfPluginRequestData &aRequest, const SmfLocation &aLocation, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | MusicEventPlugin | [virtual]
writeLog(QString log) const | MusicEventPlugin |
~MusicEventPlugin() | MusicEventPlugin | [virtual]
~SmfEventsFetcherPlugin() | SmfEventsFetcherPlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:28 2010 for smf by doxygen 1.6.3


smf: MusicLyricsPlugin Class Reference

MusicLyricsPlugin Class Reference

Inherits SmfLyricsServicePlugin.

List of all members.

Public Member Functions

virtual | ~MusicLyricsPlugin ()
SmfPluginError | lyrics (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | subtitles (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const SmfSubtitleSearchFilter &aFilter=SubtitleAll, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)
void | initialize ()
SmfProviderBase * getProviderInfo ()
SmfPluginError | responseAvailable (const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)
void | writeLog (QString log) const

Constructor & Destructor Documentation

MusicLyricsPlugin::~MusicLyricsPlugin ( ) [virtual]

Destructor

Member Function Documentation

SmfPluginError MusicLyricsPlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [virtual]

Customised method for SmfMusicEventsPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | The operation type (should be known between the client interface and the plugin)
aData | The data required to form the request (The type of data should be known between client and the plugin)
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfLyricsServicePlugin.

SmfProviderBase * MusicLyricsPlugin::getProviderInfo ( ) [virtual]

Method to get the provider information

Returns:
Instance of SmfProviderBase

Implements SmfPluginBase.

void MusicLyricsPlugin::initialize ( ) [virtual]

The first method to be called in the plugin that implements this interface. If this method is not called, plugin may not behave as expected. Plugins are expected to save the aUtil handle and use and when required.

Parameters:
aUtil The instance of SmfPluginUtil

Implements SmfPluginBase.

SmfPluginError MusicLyricsPlugin::lyrics | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get the lyrics

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | The track whose lyrics need to be fetched
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfLyricsServicePlugin.

SmfPluginError MusicLyricsPlugin::responseAvailable | ( | const SmfRequestTypeID | aOperation,
 |  | const SmfTransportResult & | aTransportResult,
 |  | QByteArray * | aResponse,
 |  | QVariant * | aResult,
 |  | SmfPluginRetType & | aRetType,
 |  | SmfResultPage & | aPageResult |
 | ) |  |  | [virtual]

Method to get the result for a network request.

Parameters:
aTransportResult | The result of transport operation
aReply | The QNetworkReply instance for the request
aResult | [out] An output parameter to the plugin manager.If the return value is SmfSendRequestAgain, QVariant will be of type SmfPluginRequestData. For SmfGalleryPlugin: If last operation was pictures(), aResult will be of type QList<SmfPicture>. If last operation was description(), aResult will be of type QString. If last operation was upload() or postComment(), aResult will be of type bool.
aRetType | [out] SmfPluginRetType
aPageResult | [out] The SmfResultPage structure variable

Method to get the result for a network request.

Parameters:
aOperation | The type of operation to be requested
aTransportResult | The result of transport operation
aResponse | The QByteArray instance containing the network response. The plugins should delete this instance once they have read the data from it.
aResult | [out] An output parameter to the plugin manager.If the return value is SmfSendRequestAgain, QVariant will be of type SmfPluginRequestData. For SmfLyricsServicePlugin: If last operation was lyrics(), aResult will be of type QList<SmfLyrics>. If last operation was subtitles(), aResult will be of type QList<SmfSubtitle>.

Implements SmfPluginBase.

SmfPluginError MusicLyricsPlugin::subtitles | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack,
 |  | const SmfSubtitleSearchFilter & | aFilter = SubtitleAll,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [virtual]

Method to get the subtitle

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | The track whose subtitle need to be fetched
aFilter | The subtitle search filter if any
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfLyricsServicePlugin.

void MusicLyricsPlugin::writeLog ( QString log ) const

Method called by plugins for logging

Parameters:
log string to be logged
The documentation for this class was generated from the following files:
  • example/MusicLyricsPlugin/MusicLyricsPlugin.h
  • example/MusicLyricsPlugin/MusicLyricsPlugin.cpp
Generated on Thu Sep 23 15:03:28 2010 for smf by doxygen 1.6.3


smf: Member List

MusicLyricsPlugin Member List

This is the complete list of members for MusicLyricsPlugin, including all inherited members.
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData) | MusicLyricsPlugin | [virtual]
getProviderInfo() | MusicLyricsPlugin | [virtual]
initialize() | MusicLyricsPlugin | [virtual]
lyrics(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | MusicLyricsPlugin | [virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aResponse, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult) | MusicLyricsPlugin | [virtual]
subtitles(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const SmfSubtitleSearchFilter &aFilter=SubtitleAll, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | MusicLyricsPlugin | [virtual]
writeLog(QString log) const | MusicLyricsPlugin |
~MusicLyricsPlugin() | MusicLyricsPlugin | [virtual]
~SmfLyricsServicePlugin() | SmfLyricsServicePlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:28 2010 for smf by doxygen 1.6.3


smf: MusicProviderBase Class Reference

MusicProviderBase Class Reference

Inherits SmfProviderBase, and SmfProviderBase.

List of all members.

Public Member Functions

virtual | ~MusicProviderBase ()
QString | serviceName () const
QImage | serviceIcon () const
QString | description () const
QUrl | serviceUrl () const
QUrl | applicationUrl () const
QImage | applicationIcon () const
QList< QString > | supportedInterfaces () const
QStringList | supportedLanguages () const
QString | pluginId () const
QString | authenticationApp (QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const
QString | smfRegistrationId () const
QString | serviceName () const
QImage | serviceIcon () const
QString | description () const
QUrl | serviceUrl () const
QUrl | applicationUrl () const
QImage | applicationIcon () const
QList< QString > | supportedInterfaces () const
QStringList | supportedLanguages () const
QString | pluginId () const
QString | authenticationApp (QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const
QString | smfRegistrationId () const

Friends

class | MusicEventPlugin
class | MusicLyricsPlugin

Constructor & Destructor Documentation

MusicProviderBase::~MusicProviderBase ( ) [virtual]

Destructor

Member Function Documentation

QImage MusicProviderBase::applicationIcon ( ) const [virtual]

Method to get the Icon of the application

Returns:
The Icon of the application

Implements SmfProviderBase.

QImage MusicProviderBase::applicationIcon ( ) const [virtual]

Method to get the Icon of the application

Returns:
The Icon of the application

Implements SmfProviderBase.

QUrl MusicProviderBase::applicationUrl ( ) const [virtual]

Method to get the URL of the Application providing this service

Returns:
The URL of the Application providing this service

Implements SmfProviderBase.

QUrl MusicProviderBase::applicationUrl ( ) const [virtual]

Method to get the URL of the Application providing this service

Returns:
The URL of the Application providing this service

Implements SmfProviderBase.

QString MusicProviderBase::authenticationApp | ( | QString & | aProgram,
 |  | QStringList & | aArguments,
 |  | QIODevice::OpenModeFlag | aMode = QIODevice::ReadWrite |
 | ) |  |  | const [virtual]

Method to get the ID of the authentication application for this service

Parameters:
aProgram | The authentication application name
aArguments | List of arguments required for authentication app
aMode | Strting mode for authentication application
Returns:
The ID of the authentication application

Implements SmfProviderBase.

QString MusicProviderBase::authenticationApp | ( | QString & | aProgram,
 |  | QStringList & | aArguments,
 |  | QIODevice::OpenModeFlag | aMode = QIODevice::ReadWrite |
 | ) |  |  | const [virtual]

Method to get the ID of the authentication application for this service

Parameters:
aProgram | The authentication application name
aArguments | List of arguments required for authentication app
aMode | Strting mode for authentication application
Returns:
The ID of the authentication application

Implements SmfProviderBase.

QString MusicProviderBase::description ( ) const [virtual]

Method to get the Readable service description

Returns:
The Readable service description

Implements SmfProviderBase.

QString MusicProviderBase::description ( ) const [virtual]

Method to get the Readable service description

Returns:
The Readable service description

Implements SmfProviderBase.

QString MusicProviderBase::pluginId ( ) const [virtual]

Method to get the Plugin specific ID

Returns:
The Plugin specific ID

Implements SmfProviderBase.

QString MusicProviderBase::pluginId ( ) const [virtual]

Method to get the Plugin specific ID

Returns:
The Plugin specific ID

Implements SmfProviderBase.

QImage MusicProviderBase::serviceIcon ( ) const [virtual]

Method to get the Logo of the service

Returns:
The Logo of the service

Implements SmfProviderBase.

QImage MusicProviderBase::serviceIcon ( ) const [virtual]

Method to get the Logo of the service

Returns:
The Logo of the service

Implements SmfProviderBase.

QString MusicProviderBase::serviceName ( ) const [virtual]

Method to get the Localisable name of the service.

Returns:
The Localisable name of the service.

Implements SmfProviderBase.

QString MusicProviderBase::serviceName ( ) const [virtual]

Method to get the Localisable name of the service.

Returns:
The Localisable name of the service.

Implements SmfProviderBase.

QUrl MusicProviderBase::serviceUrl ( ) const [virtual]

Method to get the Website of the service

Returns:
The Website of the service

Implements SmfProviderBase.

QUrl MusicProviderBase::serviceUrl ( ) const [virtual]

Method to get the Website of the service

Returns:
The Website of the service

Implements SmfProviderBase.

QString MusicProviderBase::smfRegistrationId ( ) const [virtual]

Method to get the unique registration ID provided by the Smf for authorised plugins

Returns:
The unique registration ID/token provided by the Smf for authorised plugins

Implements SmfProviderBase.

QString MusicProviderBase::smfRegistrationId ( ) const [virtual]

Method to get the unique registration ID provided by the Smf for authorised plugins

Returns:
The unique registration ID/token provided by the Smf for authorised plugins

Implements SmfProviderBase.

QList<QString> MusicProviderBase::supportedInterfaces ( ) const [virtual]

Method to get the list of interfaces that this provider support

Returns:
List of supported Interafces

Implements SmfProviderBase.

QList< QString > MusicProviderBase::supportedInterfaces ( ) const [virtual]

Method to get the list of interfaces that this provider support

Returns:
List of supported Interafces

Implements SmfProviderBase.

QStringList MusicProviderBase::supportedLanguages ( ) const [virtual]

Method to get the list of languages supported by this service provider

Returns:
a QStringList of languages supported by this service provider in 2 letter ISO 639-1 format.

Implements SmfProviderBase.

QStringList MusicProviderBase::supportedLanguages ( ) const [virtual]

Method to get the list of languages supported by this service provider

Returns:
a QStringList of languages supported by this service provider in 2 letter ISO 639-1 format.

Implements SmfProviderBase.

The documentation for this class was generated from the following files:
  • example/lastfmmusiceventplugin/lastfmmusiceventplugin.h
  • example/MusicLyricsPlugin/MusicLyricsPlugin.h
  • example/lastfmmusiceventplugin/lastfmmusiceventplugin.cpp
  • example/MusicLyricsPlugin/MusicLyricsPlugin.cpp
Generated on Thu Sep 23 15:03:29 2010 for smf by doxygen 1.6.3


smf: Member List

MusicProviderBase Member List

This is the complete list of members for MusicProviderBase, including all inherited members.
applicationIcon() const | MusicProviderBase | [virtual]
applicationIcon() const | MusicProviderBase | [virtual]
applicationUrl() const | MusicProviderBase | [virtual]
applicationUrl() const | MusicProviderBase | [virtual]
authenticationApp(QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const | MusicProviderBase | [virtual]
authenticationApp(QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const | MusicProviderBase | [virtual]
description() const | MusicProviderBase | [virtual]
description() const | MusicProviderBase | [virtual]
MusicEventPlugin (defined in MusicProviderBase) | MusicProviderBase | [friend]
MusicLyricsPlugin (defined in MusicProviderBase) | MusicProviderBase | [friend]
pluginId() const | MusicProviderBase | [virtual]
pluginId() const | MusicProviderBase | [virtual]
serviceIcon() const | MusicProviderBase | [virtual]
serviceIcon() const | MusicProviderBase | [virtual]
serviceName() const | MusicProviderBase | [virtual]
serviceName() const | MusicProviderBase | [virtual]
serviceUrl() const | MusicProviderBase | [virtual]
serviceUrl() const | MusicProviderBase | [virtual]
smfRegistrationId() const | MusicProviderBase | [virtual]
smfRegistrationId() const | MusicProviderBase | [virtual]
supportedInterfaces() const | MusicProviderBase | [virtual]
supportedInterfaces() const | MusicProviderBase | [virtual]
supportedLanguages() const | MusicProviderBase | [virtual]
supportedLanguages() const | MusicProviderBase | [virtual]
~MusicProviderBase() | MusicProviderBase | [virtual]
~MusicProviderBase() (defined in MusicProviderBase) | MusicProviderBase | [virtual]
~SmfProviderBase() | SmfProviderBase | [inline, virtual]
Generated on Thu Sep 23 15:03:29 2010 for smf by doxygen 1.6.3


smf: MyApplication Class Reference

MyApplication Class Reference

List of all members.

Public Slots

void | displayGallery ()
void | showPicsSlot (SmfPictureList *pics, QString err)
void | uploadPicture (QImage *picture, QList< SmfGallery > galleries)
void | uploaded (bool success)
void | displayFriends ()
void | showlist (SmfContactList *friendsList)
void | postUpdate ()
void | showPosts (SmfPostList *posts, QString err)
void | getMusic (SmfTrackInfo currTrack)
void | showTrackSearch (SmfTrackInfoList *songs)
void | showStore (SmfProviderList *stores)
void | updateCurrentPlaying (QList< SmfMusicSearch > musicServices, SmfTrackInfo currTrack)
void | displayLyrics (SmfTrackInfo currTrack)
void | showLyrics (SmfLyricsList *list)
void | getActivities ()
void | showActivities (SmfActivityEntryList *entries)

Member Function Documentation

void MyApplication::displayFriends ( ) [slot]

3. This is an example of displaying the friends profile image in a view from one or more service provider. Note that this service can be provided by any kind of service provider, e.g. last.fm music service where users maintain profiles and friends.

void MyApplication::displayGallery ( ) [slot]

1. Display a gallery on the screen for some remote service. assume m_view is some gallery view object in the application.

Asynchrnous request to fetch the pictures. The picturesAvailable() signal is emitted with SmfPictureList once the pictures have arrived.

void MyApplication::getMusic ( SmfTrackInfo currTrack ) [slot]

5. This is an example of getting song recommendations from a social netowrking sites

void MyApplication::postUpdate ( ) [slot]

4. This is an example of posting and reading user updates to social netowrking sites

void MyApplication::uploaded ( bool success ) [slot]

Slot to catch the uploading finished event

void MyApplication::uploadPicture | ( | QImage * | picture,
 |  | QList< SmfGallery > | galleries |
 | ) |  |  | [slot]

2. Upload a picture captured by the user to some selection of galeries.

When uploading is finished we can check the success of the uploading

The documentation for this class was generated from the following file:
  • example/example_usage.cpp
Generated on Thu Sep 23 15:03:29 2010 for smf by doxygen 1.6.3


smf: Member List

MyApplication Member List

This is the complete list of members for MyApplication, including all inherited members.
displayFriends() | MyApplication | [slot]
displayGallery() | MyApplication | [slot]
displayLyrics(SmfTrackInfo currTrack) (defined in MyApplication) | MyApplication | [slot]
getActivities() (defined in MyApplication) | MyApplication | [slot]
getMusic(SmfTrackInfo currTrack) | MyApplication | [slot]
postUpdate() | MyApplication | [slot]
showActivities(SmfActivityEntryList *entries) (defined in MyApplication) | MyApplication | [slot]
showlist(SmfContactList *friendsList) (defined in MyApplication) | MyApplication | [slot]
showLyrics(SmfLyricsList *list) (defined in MyApplication) | MyApplication | [slot]
showPicsSlot(SmfPictureList *pics, QString err) (defined in MyApplication) | MyApplication | [slot]
showPosts(SmfPostList *posts, QString err) (defined in MyApplication) | MyApplication | [slot]
showStore(SmfProviderList *stores) (defined in MyApplication) | MyApplication | [slot]
showTrackSearch(SmfTrackInfoList *songs) (defined in MyApplication) | MyApplication | [slot]
updateCurrentPlaying(QList< SmfMusicSearch > musicServices, SmfTrackInfo currTrack) (defined in MyApplication) | MyApplication | [slot]
uploaded(bool success) | MyApplication | [slot]
uploadPicture(QImage *picture, QList< SmfGallery > galleries) | MyApplication | [slot]
Generated on Thu Sep 23 15:03:29 2010 for smf by doxygen 1.6.3


smf: MyAppView Class Reference

MyAppView Class Reference

List of all members.

Public Member Functions

void | add (QImage pic)
void | add (SmfTrackInfo trackInfo)
void | add (QContact qc)
void | setPicture (QImage image)
void | setTitle (QString cap)
void | setIcon (QImage image)
void | setDescription (QString desc)
void | setProvider (SmfProvider p)
void | setLyricsData (SmfLyrics l)
The documentation for this class was generated from the following file:
  • example/example_usage.cpp
Generated on Thu Sep 23 15:03:29 2010 for smf by doxygen 1.6.3


smf: Member List

MyAppView Member List

This is the complete list of members for MyAppView, including all inherited members.
add(QImage pic) (defined in MyAppView) | MyAppView
add(SmfTrackInfo trackInfo) (defined in MyAppView) | MyAppView
add(QContact qc) (defined in MyAppView) | MyAppView
setDescription(QString desc) (defined in MyAppView) | MyAppView
setIcon(QImage image) (defined in MyAppView) | MyAppView
setLyricsData(SmfLyrics l) (defined in MyAppView) | MyAppView
setPicture(QImage image) (defined in MyAppView) | MyAppView
setProvider(SmfProvider p) (defined in MyAppView) | MyAppView
setTitle(QString cap) (defined in MyAppView) | MyAppView
Generated on Thu Sep 23 15:03:29 2010 for smf by doxygen 1.6.3


smf: QJson::Parser Class Reference

QJson::Parser

QJson::Parser Class Reference

Main class used to convert JSON data to QVariant objects. More...

#include <parser.h>

List of all members.

Public Member Functions

QVariant | parse (QIODevice *io, bool *ok=0)
QVariant | parse (const QByteArray &jsonData, bool *ok=0)
QString | errorString () const
int | errorLine () const

Detailed Description

Main class used to convert JSON data to QVariant objects.

Member Function Documentation

int Parser::errorLine ( ) const

This method returns line number where the error occurred

Returns:
the line number where the error occurred
See also:
errorString
QString Parser::errorString ( ) const

This method returns the error message

Returns:
a QString object containing the error message of the last parse operation
See also:
errorLine
QVariant Parser::parse | ( | const QByteArray & | jsonData,
 |  | bool * | ok = 0
 | ) |  |

This is a method provided for convenience.

Parameters:
jsonData | data containing the JSON object representation
ok | if a conversion error occurs, *ok is set to false; otherwise *ok is set to true.
Returns:
a QVariant object generated from the JSON string
See also:
errorString
errorLine
QVariant Parser::parse | ( | QIODevice * | io,
 |  | bool * | ok = 0
 | ) |  |

Read JSON string from the I/O Device and converts it to a QVariant object

Parameters:
io | Input output device
ok | if a conversion error occurs, *ok is set to false; otherwise *ok is set to true.
Returns:
a QVariant object generated from the JSON string
The documentation for this class was generated from the following files:
  • smf/smfservermodule/util/qjson/src/parser.h
  • smf/smfservermodule/util/qjson/src/parser.cpp
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: Member List

QJson::Parser Member List

This is the complete list of members for QJson::Parser, including all inherited members.
errorLine() const | QJson::Parser
errorString() const | QJson::Parser
parse(QIODevice *io, bool *ok=0) | QJson::Parser
parse(const QByteArray &jsonData, bool *ok=0) | QJson::Parser
Parser() (defined in QJson::Parser) | QJson::Parser
~Parser() (defined in QJson::Parser) | QJson::Parser
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: QJson::ParserPrivate Class Reference

QJson::ParserPrivate

QJson::ParserPrivate Class Reference

List of all members.

Public Member Functions

void | setError (QString errorMsg, int line)

Public Attributes

JSonScanner * | m_scanner
bool | m_negate
bool | m_error
int | m_errorLine
QString | m_errorMsg
QVariant | m_result
The documentation for this class was generated from the following files:
  • smf/smfservermodule/util/qjson/src/parser_p.h
  • smf/smfservermodule/util/qjson/src/parser.cpp
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: Member List

QJson::ParserPrivate Member List

This is the complete list of members for QJson::ParserPrivate, including all inherited members.
m_error (defined in QJson::ParserPrivate) | QJson::ParserPrivate
m_errorLine (defined in QJson::ParserPrivate) | QJson::ParserPrivate
m_errorMsg (defined in QJson::ParserPrivate) | QJson::ParserPrivate
m_negate (defined in QJson::ParserPrivate) | QJson::ParserPrivate
m_result (defined in QJson::ParserPrivate) | QJson::ParserPrivate
m_scanner (defined in QJson::ParserPrivate) | QJson::ParserPrivate
ParserPrivate() (defined in QJson::ParserPrivate) | QJson::ParserPrivate
setError(QString errorMsg, int line) (defined in QJson::ParserPrivate) | QJson::ParserPrivate
~ParserPrivate() (defined in QJson::ParserPrivate) | QJson::ParserPrivate
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: QJson::ParserRunnable Class Reference

QJson::ParserRunnable

QJson::ParserRunnable Class Reference

Convenience class for converting JSON data to QVariant objects using a dedicated thread. More...

#include <parserrunnable.h>

List of all members.

Classes

class | Private

Signals

void | parsingFinished (const QVariant &json, bool ok, const QString &error_msg)

Public Member Functions

ParserRunnable (QObject *parent=0)
void | setData (const QByteArray &data)
void | run ()

Detailed Description

Convenience class for converting JSON data to QVariant objects using a dedicated thread.

Constructor & Destructor Documentation

ParserRunnable::ParserRunnable ( QObject * parent = 0 ) [explicit]

This signal is emitted when the conversion process has been completed

Parameters:
data | contains the JSON data that has to be converted
parent | parent of the object

Member Function Documentation

void QJson::ParserRunnable::parsingFinished | ( | const QVariant & | json,
 |  | bool | ok,
 |  | const QString & | error_msg |
 | ) |  |  | [signal]

This signal is emitted when the parsing process has been completed

Parameters:
json | contains the result of the parsing
ok | if a parsing error occurs ok is set to false, otherwise it's set to true.
error_msg | contains a string explaining the failure reason
The documentation for this class was generated from the following files:
  • smf/smfservermodule/util/qjson/src/parserrunnable.h
  • smf/smfservermodule/util/qjson/src/parserrunnable.cpp
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: Member List

QJson::ParserRunnable Member List

This is the complete list of members for QJson::ParserRunnable, including all inherited members.
ParserRunnable(QObject *parent=0) | QJson::ParserRunnable | [explicit]
parsingFinished(const QVariant &json, bool ok, const QString &error_msg) | QJson::ParserRunnable | [signal]
run() (defined in QJson::ParserRunnable) | QJson::ParserRunnable |
setData(const QByteArray &data) (defined in QJson::ParserRunnable) | QJson::ParserRunnable |
~ParserRunnable() (defined in QJson::ParserRunnable) | QJson::ParserRunnable |
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: Person Class Reference

Person Class Reference

List of all members.

Public Types

enum | Gender { Male, Female }

Public Member Functions

Person (QObject *parent=0)
QString | name () const
void | setName (const QString &name)
int | phoneNumber () const
void | setPhoneNumber (const int phoneNumber)
void | setGender (Gender gender)
Gender | gender () const
QDate | dob () const
void | setDob (const QDate &dob)

Properties

QString | name
int | phoneNumber
Gender | gender
QDate | dob
The documentation for this class was generated from the following files:
  • smf/smfservermodule/util/qjson/tests/person.h
  • smf/smfservermodule/util/qjson/tests/person.cpp
Generated on Thu Sep 23 15:03:29 2010 for smf by doxygen 1.6.3


smf: Member List

Person Member List

This is the complete list of members for Person, including all inherited members.
dob (defined in Person) | Person
dob() const (defined in Person) | Person
Female enum value (defined in Person) | Person
Gender enum name (defined in Person) | Person
gender (defined in Person) | Person
gender() const (defined in Person) | Person
Male enum value (defined in Person) | Person
name (defined in Person) | Person
name() const (defined in Person) | Person
Person(QObject *parent=0) (defined in Person) | Person
phoneNumber (defined in Person) | Person
phoneNumber() const (defined in Person) | Person
setDob(const QDate &dob) (defined in Person) | Person
setGender(Gender gender) (defined in Person) | Person
setName(const QString &name) (defined in Person) | Person
setPhoneNumber(const int phoneNumber) (defined in Person) | Person
~Person() (defined in Person) | Person
Generated on Thu Sep 23 15:03:29 2010 for smf by doxygen 1.6.3


smf: yy::position Class Reference

yy::position

yy::position Class Reference

Abstract a position. More...

#include <position.hh>

List of all members.

Public Member Functions

position ()
Construct a position.
void | initialize (std::string *fn)
Initialization.
Line and Column related manipulators

void | lines (int count=1)
(line related) Advance to the COUNT next lines.
void | columns (int count=1)
(column related) Advance to the COUNT next columns.

Public Attributes

std::string * | filename
File name to which this position refers.
unsigned int | line
Current line number.
unsigned int | column
Current column number.

Detailed Description

Abstract a position.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/util/qjson/src/position.hh
Generated on Thu Sep 23 15:03:54 2010 for smf by doxygen 1.6.3


smf: Member List

yy::position Member List

This is the complete list of members for yy::position, including all inherited members.
column | yy::position |
columns(int count=1) | yy::position | [inline]
filename | yy::position |
initialize(std::string *fn) | yy::position | [inline]
line | yy::position |
lines(int count=1) | yy::position | [inline]
position() | yy::position | [inline]
Generated on Thu Sep 23 15:03:54 2010 for smf by doxygen 1.6.3


smf: PostTestUi Class Reference

PostTestUi Class Reference

List of all members.

Public Member Functions

PostTestUi (QWidget *parent=0)
The documentation for this class was generated from the following files:
  • example/smfclientapp/posttestui.h
  • example/smfclientapp/posttestui.cpp
Generated on Thu Sep 23 15:03:30 2010 for smf by doxygen 1.6.3


smf: Member List

PostTestUi Member List

This is the complete list of members for PostTestUi, including all inherited members.
PostTestUi(QWidget *parent=0) (defined in PostTestUi) | PostTestUi
~PostTestUi() (defined in PostTestUi) | PostTestUi
Generated on Thu Sep 23 15:03:30 2010 for smf by doxygen 1.6.3


smf: Ui::PostTestUiClass Class Reference

Ui::PostTestUiClass

Ui::PostTestUiClass Class Reference

Inherits Ui_PostTestUiClass.

List of all members.

The documentation for this class was generated from the following file:
  • example/smfclientapp/ui_posttestui.h
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: Member List

Ui::PostTestUiClass Member List

This is the complete list of members for Ui::PostTestUiClass, including all inherited members.
comboBox (defined in Ui_PostTestUiClass) | Ui_PostTestUiClass |
gridLayout (defined in Ui_PostTestUiClass) | Ui_PostTestUiClass |
listWidget (defined in Ui_PostTestUiClass) | Ui_PostTestUiClass |
retranslateUi(QWidget *PostTestUiClass) (defined in Ui_PostTestUiClass) | Ui_PostTestUiClass | [inline]
setupUi(QWidget *PostTestUiClass) (defined in Ui_PostTestUiClass) | Ui_PostTestUiClass | [inline]
verticalLayout (defined in Ui_PostTestUiClass) | Ui_PostTestUiClass |
verticalLayoutWidget (defined in Ui_PostTestUiClass) | Ui_PostTestUiClass |
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: QJson::ParserRunnable::Private Class Reference

QJson::ParserRunnable::Private

QJson::ParserRunnable::Private Class Reference

List of all members.

Public Attributes

QByteArray m_data
The documentation for this class was generated from the following file:
  • smf/smfservermodule/util/qjson/src/parserrunnable.cpp
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: Member List

QJson::ParserRunnable::Private Member List

This is the complete list of members for QJson::ParserRunnable::Private, including all inherited members.
m_data (defined in QJson::ParserRunnable::Private) QJson::ParserRunnable::Private
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: QJson::SerializerRunnable::Private Class Reference

QJson::SerializerRunnable::Private

QJson::SerializerRunnable::Private Class Reference

List of all members.

Public Attributes

QVariant json
The documentation for this class was generated from the following file:
  • smf/smfservermodule/util/qjson/src/serializerrunnable.cpp
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: Member List

QJson::SerializerRunnable::Private Member List

This is the complete list of members for QJson::SerializerRunnable::Private, including all inherited members.
json (defined in QJson::SerializerRunnable::Private) QJson::SerializerRunnable::Private
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: progressbar Class Reference

progressbar Class Reference

List of all members.

Public Member Functions

progressbar (QWidget *parent=0)
progressbar (QWidget *parent=0)
The documentation for this class was generated from the following files:
  • example/AuthApp/progressbar.h
  • example/FlickrAuthApp/progressbar.h
  • example/AuthApp/progressbar.cpp
  • example/FlickrAuthApp/progressbar.cpp
Generated on Thu Sep 23 15:03:30 2010 for smf by doxygen 1.6.3


smf: Member List

progressbar Member List

This is the complete list of members for progressbar, including all inherited members.
progressbar(QWidget *parent=0) (defined in progressbar) | progressbar
progressbar(QWidget *parent=0) (defined in progressbar) | progressbar
~progressbar() (defined in progressbar) | progressbar
~progressbar() (defined in progressbar) | progressbar
Generated on Thu Sep 23 15:03:30 2010 for smf by doxygen 1.6.3


smf: Ui::progressbarClass Class Reference

Ui::progressbarClass

Ui::progressbarClass Class Reference

Inherits Ui_progressbarClass, and Ui_progressbarClass.

List of all members.

The documentation for this class was generated from the following file:
  • example/AuthApp/ui_progressbar.h
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: Member List

Ui::progressbarClass Member List

This is the complete list of members for Ui::progressbarClass, including all inherited members.
label (defined in Ui_progressbarClass) | Ui_progressbarClass |
progressBar (defined in Ui_progressbarClass) | Ui_progressbarClass |
retranslateUi(QWidget *progressbarClass) (defined in Ui_progressbarClass) | Ui_progressbarClass | [inline]
retranslateUi(QWidget *progressbarClass) (defined in Ui_progressbarClass) | Ui_progressbarClass | [inline]
setupUi(QWidget *progressbarClass) (defined in Ui_progressbarClass) | Ui_progressbarClass | [inline]
setupUi(QWidget *progressbarClass) (defined in Ui_progressbarClass) | Ui_progressbarClass | [inline]
verticalLayout (defined in Ui_progressbarClass) | Ui_progressbarClass |
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: QJson::QObjectHelper Class Reference

QJson::QObjectHelper

QJson::QObjectHelper Class Reference

Class used to convert QObject into QVariant and vivce-versa. During these operations only the class attributes defined as properties will be considered. More...

#include <qobjecthelper.h>

List of all members.

Classes

class | QObjectHelperPrivate

Static Public Member Functions

static QVariantMap | qobject2qvariant (const QObject *object, const QStringList &ignoredProperties=QStringList(QString(QLatin1String("objectName"))))
static void | qvariant2qobject (const QVariantMap &variant, QObject *object)

Detailed Description

Class used to convert QObject into QVariant and vivce-versa. During these operations only the class attributes defined as properties will be considered.

Suppose the declaration of the Person class looks like this:

 class Person : public QObject
    {
      Q_OBJECT

      Q_PROPERTY(QString name READ name WRITE setName)
      Q_PROPERTY(int phoneNumber READ phoneNumber WRITE setPhoneNumber)
      Q_PROPERTY(Gender gender READ gender WRITE setGender)
      Q_PROPERTY(QDate dob READ dob WRITE setDob)
      Q_ENUMS(Gender)

     public:
        Person(QObject* parent = 0);
        ~Person();

        QString name() const;
        void setName(const QString& name);

        int phoneNumber() const;
        void setPhoneNumber(const int  phoneNumber);

        enum Gender {Male, Female};
        void setGender(Gender gender);
        Gender gender() const;

        QDate dob() const;
        void setDob(const QDate& dob);

      private:
        QString m_name;
        int m_phoneNumber;
        Gender m_gender;
        QDate m_dob;
    };

The following code will serialize an instance of Person to JSON :

    Person person;
    person.setName("Flavio");
    person.setPhoneNumber(123456);
    person.setGender(Person::Male);
    person.setDob(QDate(1982, 7, 12));

    QVariantMap variant = QObjectHelper::qobject2qvariant(&person);
    Serializer serializer;
    qDebug() << serializer.serialize( variant);

The generated output will be:

    { "dob" : "1982-07-12", "gender" : 0, "name" : "Flavio", "phoneNumber" : 123456 }

It's also possible to initialize a QObject using the values stored inside of a QVariantMap.

Suppose you have the following JSON data stored into a QString:

    { "dob" : "1982-07-12", "gender" : 0, "name" : "Flavio", "phoneNumber" : 123456 }

The following code will initialize an already allocated instance of Person using the JSON values:

    Parser parser;
    QVariant variant = parser.parse(json);

    Person person;
    QObjectHelper::qvariant2qobject(variant.toMap(), &person);
See also:
Parser
Serializer

Member Function Documentation

QVariantMap QObjectHelper::qobject2qvariant | ( | const QObject * | object,
 |  | const QStringList & | ignoredProperties = QStringList(QString(QLatin1String("objectName"))) |
 | ) |  |  | [static]

This method converts a QObject instance into a QVariantMap.

Parameters:
object | The QObject instance to be converted.
ignoredProperties | Properties that won't be converted.
void QObjectHelper::qvariant2qobject | ( | const QVariantMap & | variant,
 |  | QObject * | object |
 | ) |  |  | [static]

This method converts a QVariantMap instance into a QObject

Parameters:
object The QObject instance to be converted.
The documentation for this class was generated from the following files:
  • smf/smfservermodule/util/qjson/src/qobjecthelper.h
  • smf/smfservermodule/util/qjson/src/qobjecthelper.cpp
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: Member List

QJson::QObjectHelper Member List

This is the complete list of members for QJson::QObjectHelper, including all inherited members.
qobject2qvariant(const QObject *object, const QStringList &ignoredProperties=QStringList(QString(QLatin1String("objectName")))) | QJson::QObjectHelper | [static]
QObjectHelper() (defined in QJson::QObjectHelper) | QJson::QObjectHelper |
qvariant2qobject(const QVariantMap &variant, QObject *object) | QJson::QObjectHelper | [static]
~QObjectHelper() (defined in QJson::QObjectHelper) | QJson::QObjectHelper |
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: QJson::QObjectHelper::QObjectHelperPrivate Class Reference

QJson::QObjectHelper::QObjectHelperPrivate

QJson::QObjectHelper::QObjectHelperPrivate Class Reference

The documentation for this class was generated from the following file:
  • smf/smfservermodule/util/qjson/src/qobjecthelper.cpp
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: RSmfClientSymbianSession Class Reference

RSmfClientSymbianSession Class Reference

#include <smfclientsymbiansession.h>

List of all members.

Public Member Functions

RSmfClientSymbianSession ()
TInt | connectToServer ()
TVersion | Version () const
void | Close ()
bool | isConnected ()
TInt | sendRequest (SmfRequestTypeID requestType)
TPtr8 | sendSyncRequest (QByteArray &aSerializedData, QString aInterfaceName, SmfRequestTypeID aRequestType, TInt maxSize)
TPtr8 | sendDSMSyncRequest (SmfRequestTypeID aRequestType, QByteArray &aSerializedData, SmfError &aErr, TInt maxSize=0)
TPtr8 | sendSyncRequest (QString aInterfaceName, SmfRequestTypeID aRequestType, TInt maxSize, QByteArray &aSerializedData)
void | sendAsyncRequest (QByteArray &aSerializedData, QString aInterfaceName, SmfRequestTypeID aRequestType, TRequestStatus &aStatus, TInt aMaxAllocation)
TPtr8 | getData ()
TInt | getLastRequest ()

Public Attributes

bool | connected
TPtr8 | iDataPtr8
TPtr | iDataPtr16

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan Corresponds to client session in Symbian

Constructor & Destructor Documentation

RSmfClientSymbianSession::RSmfClientSymbianSession ( )

Constructs

Member Function Documentation

TInt RSmfClientSymbianSession::connectToServer ( )

Creates the server process if not already running and creates session

Returns:
Error code while creating server process/ creating session
TPtr8 RSmfClientSymbianSession::getData ( ) [inline]

Returns data,used to return back the data received from server

void RSmfClientSymbianSession::sendAsyncRequest | ( | QByteArray & | aSerializedData,
 |  | QString | aInterfaceName,
 |  | SmfRequestTypeID | aRequestType,
 |  | TRequestStatus & | aStatus,
 |  | TInt | aMaxAllocation
 | ) |  |

Sends async request to the Smf server

Parameters:
aSerializedData | Serialized data to be sent to the server. Consists of provider Info(SmfProvider*)+ Other common class data (when applicable)-serialized
aInterfaceName | Name of the interface
aStatus | TRequestStatus
maxSize | Size of the data to be allocated. This info is sent to the server

sendAsyncRequest() Calls SendReceive() after converting into symbian descriptors

The message body consists of.- slot 0 = SmfProvider + argument flag + argument + etc slot 1 = Interface name serialized slot 2 = Data pointer to be filled by server slot 3 = not used now

TPtr8 RSmfClientSymbianSession::sendDSMSyncRequest | ( | SmfRequestTypeID | aRequestType,
 |  | QByteArray & | aSerializedData,
 |  | SmfError & | aErr,
 |  | TInt | maxSize = 0
 | ) |  |

Sends DSM related sync request to the Smf server

Sends sync DSM request to the Smf server

Slot 0:- Data to be passed to DSM Slot 1:- Data returned from DSM Slot 2:- Error

TInt RSmfClientSymbianSession::sendRequest ( SmfRequestTypeID requestType )

Calls SendReceive with requestType opcode and packaged data depending on requestType

TPtr8 RSmfClientSymbianSession::sendSyncRequest | ( | QString | aInterfaceName,
 |  | SmfRequestTypeID | aRequestType,
 |  | TInt | maxSize,
 |  | QByteArray & | aSerializedData
 | ) |  |

Sends synchronous requests to the Smf server

The message body consists of.- slot 0 = SmfProvider + argument flag + argument + etc slot 1 = Interface name serialized slot 2 = Data pointer to be filled by server slot 3 = not used now

TPtr8 RSmfClientSymbianSession::sendSyncRequest | ( | QByteArray & | aSerializedData,
 |  | QString | aInterfaceName,
 |  | SmfRequestTypeID | aRequestType,
 |  | TInt | maxSize
 | ) |  |

Sends sync request to the Smf server - overloaded

The message body consists of.- 1. Serialized data to server SmfProvider+page information+extra information 2. Interface name as string ("org.symbian.smf.client.gallery") 3. Data pointer to be filled by serialized data(QList<smfProvider>) 4. Xtra information if any

TVersion RSmfClientSymbianSession::Version ( ) const [inline]

Version

The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfclientsymbiansession.h
  • smf/smfservermodule/smfclient/smfclientsymbian.cpp
Generated on Thu Sep 23 15:03:30 2010 for smf by doxygen 1.6.3


smf: Member List

RSmfClientSymbianSession Member List

This is the complete list of members for RSmfClientSymbianSession, including all inherited members.
Close() (defined in RSmfClientSymbianSession) | RSmfClientSymbianSession | [inline]
connected (defined in RSmfClientSymbianSession) | RSmfClientSymbianSession |
connectToServer() | RSmfClientSymbianSession |
getData() | RSmfClientSymbianSession | [inline]
getLastRequest() (defined in RSmfClientSymbianSession) | RSmfClientSymbianSession | [inline]
iDataPtr16 (defined in RSmfClientSymbianSession) | RSmfClientSymbianSession |
iDataPtr8 (defined in RSmfClientSymbianSession) | RSmfClientSymbianSession |
isConnected() (defined in RSmfClientSymbianSession) | RSmfClientSymbianSession |
RSmfClientSymbianSession() | RSmfClientSymbianSession |
sendAsyncRequest(QByteArray &aSerializedData, QString aInterfaceName, SmfRequestTypeID aRequestType, TRequestStatus &aStatus, TInt aMaxAllocation) | RSmfClientSymbianSession |
sendDSMSyncRequest(SmfRequestTypeID aRequestType, QByteArray &aSerializedData, SmfError &aErr, TInt maxSize=0) | RSmfClientSymbianSession |
sendRequest(SmfRequestTypeID requestType) | RSmfClientSymbianSession |
sendSyncRequest(QByteArray &aSerializedData, QString aInterfaceName, SmfRequestTypeID aRequestType, TInt maxSize) | RSmfClientSymbianSession |
sendSyncRequest(QString aInterfaceName, SmfRequestTypeID aRequestType, TInt maxSize, QByteArray &aSerializedData) | RSmfClientSymbianSession |
Version() const | RSmfClientSymbianSession | [inline]
Generated on Thu Sep 23 15:03:30 2010 for smf by doxygen 1.6.3


smf: RSmfCredMgrClientSession Class Reference

RSmfCredMgrClientSession Class Reference

#include <smfcredmgrclientsession.h>

List of all members.

Public Member Functions

RSmfCredMgrClientSession ()
TInt | connectToServer ()
TVersion | Version () const
void | Close ()
void | RequestAsyncService (TCredentialServerRequestID aRequestType, TRequestStatus &aStatus)
void | RequestService (TCredentialServerRequestID aRequestType, const TIpcArgs &aArgs)

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Pritam Roy Biswas, Sasken Communication Technologies Ltd - Initial contribution

Description: Client-side handle to a session with a server. Derives from RSessionBase to create a communicating channel with the server. Class for client side handle and to create a channel with the server. Derives from RSessionBase.

Constructor & Destructor Documentation

RSmfCredMgrClientSession::RSmfCredMgrClientSession ( )

Constructor

Member Function Documentation

void RSmfCredMgrClientSession::Close ( )

Close the session

TInt RSmfCredMgrClientSession::connectToServer ( )

Connection to server to be made using CreateSession()

void RSmfCredMgrClientSession::RequestAsyncService | ( | TCredentialServerRequestID | aRequestType,
 |  | TRequestStatus & | aStatus
 | ) |  |

Calls SendReceive with requestType opcode and packaged data depending on requestType

void RSmfCredMgrClientSession::RequestService | ( | TCredentialServerRequestID | aRequestType,
 |  | const TIpcArgs & | aArgs
 | ) |  |

Issue request to server using SendReceive()

TVersion RSmfCredMgrClientSession::Version ( ) const

Method to retrieve the Version of the Server

The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclientsession.h
  • smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclientsession.cpp
Generated on Thu Sep 23 15:03:30 2010 for smf by doxygen 1.6.3


smf: Member List

RSmfCredMgrClientSession Member List

This is the complete list of members for RSmfCredMgrClientSession, including all inherited members.
Close() | RSmfCredMgrClientSession
connectToServer() | RSmfCredMgrClientSession
RequestAsyncService(TCredentialServerRequestID aRequestType, TRequestStatus &aStatus) | RSmfCredMgrClientSession
RequestService(TCredentialServerRequestID aRequestType, const TIpcArgs &aArgs) | RSmfCredMgrClientSession
RSmfCredMgrClientSession() | RSmfCredMgrClientSession
Version() const | RSmfCredMgrClientSession
Generated on Thu Sep 23 15:03:30 2010 for smf by doxygen 1.6.3


smf: SamplePlugin Class Reference

SamplePlugin Class Reference

Inherits SmfGalleryPlugin.

List of all members.

Public Member Functions

SamplePlugin (SmfPluginUtil *aUtil)
~SamplePlugin ()
SmfPluginError | pictures (SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)
SmfPluginError | description (SmfPluginRequestData &aRequest, const SmfPicture &aImage)
SmfPluginError | upload (SmfPluginRequestData &aRequest, const SmfPicture &aImage)
SmfPluginError | upload (SmfPluginRequestData &aRequest, const QList< SmfPicture > &aImages)
SmfPluginError | postComment (SmfPluginRequestData &aRequest, const SmfPicture &aImage, const SmfComment &aComment)
SmfProviderBase * getProviderInfo ()
SmfPluginError | responseAvailable (const SmfTransportResult &aTransportResult, QNetworkReply *aReply, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)

Constructor & Destructor Documentation

SamplePlugin::SamplePlugin ( SmfPluginUtil * aUtil )

Constructor with default argument

Parameters:
aUtil The SmfPluginUtil instance. The plugins can call the method getAuthKeys() of this class, with its pluginID to get the OAuth keys, keys are returned only if this plugin is authorised by Smf franework
SamplePlugin::~SamplePlugin ( )

Destructor

Member Function Documentation

SmfPluginError SamplePlugin::description | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPicture & | aImage |
 | ) |  |  | [virtual]

Method to get a description

Parameters:
aRequest | [out] The request data to be sent to network
aImage | The image abot which the description is required
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfGalleryPlugin.

SmfProviderBase * SamplePlugin::getProviderInfo ( ) [virtual]

Method to get the provider information

Returns:
Instance of SmfProviderBase

Implements SmfPluginBase.

SmfPluginError SamplePlugin::pictures | ( | SmfPluginRequestData & | aRequest,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Method to get a list of pictures

Parameters:
aRequest | [out] The request data to be sent to network
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone
SmfPluginError SamplePlugin::postComment | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPicture & | aImage,
 |  | const SmfComment & | aComment |
 | ) |  |  | [virtual]

Method to post comment on a picture is available

Parameters:
aRequest | [out] The request data to be sent to network
aImage | The image on which comment is to be posted
aComment | The comment to be posted
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone

Implements SmfGalleryPlugin.

SmfPluginError SamplePlugin::responseAvailable | ( | const SmfTransportResult & | aTransportResult,
 |  | QNetworkReply * | aReply,
 |  | QVariant * | aResult,
 |  | SmfPluginRetType & | aRetType,
 |  | SmfResultPage & | aPageResult
 | ) |  |

Method to get the result for a network request.

Parameters:
aTransportResult | The result of transport operation
aReply | The QNetworkReply instance for the request
aResult | [out] An output parameter to the plugin manager.If the return value is SmfSendRequestAgain, QVariant will be of type SmfPluginRequestData. For SmfGalleryPlugin: If last operation was pictures(), aResult will be of type QList<SmfPicture>. If last operation was description(), aResult will be of type QString. If last operation was upload() or postComment(), aResult will be of type bool.
aRetType | [out] SmfPluginRetType
aPageResult | [out] The SmfResultPage structure variable

see http://qjson.sourceforge.net/usage.html for more details

SmfPluginError SamplePlugin::upload | ( | SmfPluginRequestData & | aRequest,
 |  | const QList< SmfPicture > & | aImages
 | ) |  |

Method to upload a list of pictures

Parameters:
aRequest | [out] The request data to be sent to network
aImages | The list of images to be uploaded
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone
SmfPluginError SamplePlugin::upload | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPicture & | aImage
 | ) |  |

Method to upload a picture

Parameters:
aRequest | [out] The request data to be sent to network
aImage | The image to be uploaded
Returns:
SmfPluginError Plugin error if any, else SmfPluginErrNone
The documentation for this class was generated from the following files:
  • example/sampleplugin.h
  • example/sampleplugin.cpp
Generated on Thu Sep 23 15:03:30 2010 for smf by doxygen 1.6.3


smf: Member List

SamplePlugin Member List

This is the complete list of members for SamplePlugin, including all inherited members.
albums(SmfPluginRequestData &aRequest, const QStringList &aNames, const SmfContact *aUser, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfGalleryPlugin | [pure virtual]
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0 | SmfGalleryPlugin | [pure virtual]
description(SmfPluginRequestData &aRequest, const SmfPicture &aImage) | SamplePlugin | [virtual]
getProviderInfo() | SamplePlugin | [virtual]
initialize()=0 | SmfPluginBase | [pure virtual]
pictures(SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE) | SamplePlugin |
SmfGalleryPlugin::pictures(SmfPluginRequestData &aRequest, const SmfPictureAlbumList &aAlbums, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfGalleryPlugin | [pure virtual]
postComment(SmfPluginRequestData &aRequest, const SmfPicture &aImage, const SmfComment &aComment) | SamplePlugin | [virtual]
responseAvailable(const SmfTransportResult &aTransportResult, QNetworkReply *aReply, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult) | SamplePlugin |
SmfGalleryPlugin::responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aReply, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)=0 | SmfPluginBase | [pure virtual]
SamplePlugin(SmfPluginUtil *aUtil) | SamplePlugin |
upload(SmfPluginRequestData &aRequest, const SmfPicture &aImage) | SamplePlugin |
upload(SmfPluginRequestData &aRequest, const QList< SmfPicture > &aImages) | SamplePlugin |
SmfGalleryPlugin::upload(SmfPluginRequestData &aRequest, const SmfPicture &aImage, const SmfPictureAlbum *aAlbum=NULL)=0 | SmfGalleryPlugin | [pure virtual]
SmfGalleryPlugin::upload(SmfPluginRequestData &aRequest, const QList< SmfPicture > &aImages, const SmfPictureAlbum *aAlbum=NULL)=0 | SmfGalleryPlugin | [pure virtual]
~SamplePlugin() | SamplePlugin |
~SmfGalleryPlugin() | SmfGalleryPlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:31 2010 for smf by doxygen 1.6.3


smf: SampleProviderBase Class Reference

SampleProviderBase Class Reference

Inherits SmfProviderBase.

List of all members.

Public Member Functions

SampleProviderBase (QObject *aParent=0)
SampleProviderBase (const SampleProviderBase &aOther)
~SampleProviderBase ()
QString | serviceName () const
QImage | serviceIcon () const
QString | description () const
QUrl | serviceUrl () const
QUrl | applicationUrl () const
QImage | applicationIcon () const
QString | pluginId () const
QString | authenticationApp (QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const
QString | smfRegistrationId () const
SmfPluginDataUsage | getDataUsage () const

Friends

class | SamplePlugin

Constructor & Destructor Documentation

SampleProviderBase::SampleProviderBase ( QObject * aParent = 0 )

Constructor with default argument

Parameters:
aParent The parent object
SampleProviderBase::SampleProviderBase ( const SampleProviderBase & aOther )

Copy Constructor

Parameters:
aOther The reference object
SampleProviderBase::~SampleProviderBase ( )

Destructor

Member Function Documentation

QImage SampleProviderBase::applicationIcon ( ) const [virtual]

Method to get the Icon of the application

Returns:
The Icon of the application

Implements SmfProviderBase.

QUrl SampleProviderBase::applicationUrl ( ) const [virtual]

Method to get the URL of the Application providing this service

Returns:
The URL of the Application providing this service

Implements SmfProviderBase.

QString SampleProviderBase::authenticationApp | ( | QString & | aProgram,
 |  | QStringList & | aArguments,
 |  | QIODevice::OpenModeFlag | aMode = QIODevice::ReadWrite |
 | ) |  |  | const [virtual]

Method to get the ID of the authentication application for this service

Parameters:
aProgram | The authentication application name
aArguments | List of arguments required for authentication app
aMode | Strting mode for authentication application
Returns:
The ID of the authentication application

Implements SmfProviderBase.

QString SampleProviderBase::description ( ) const [virtual]

Method to get the Readable service description

Returns:
The Readable service description

Implements SmfProviderBase.

SmfPluginDataUsage SampleProviderBase::getDataUsage ( ) const

Method to get the data usage of each plugin

Returns:
The data usage structure
QString SampleProviderBase::pluginId ( ) const [virtual]

Method to get the Plugin specific ID

Returns:
The Plugin specific ID

Implements SmfProviderBase.

QImage SampleProviderBase::serviceIcon ( ) const [virtual]

Method to get the Logo of the service

Returns:
The Logo of the service

Implements SmfProviderBase.

QString SampleProviderBase::serviceName ( ) const [virtual]

Method to get the Localisable name of the service.

Returns:
The Localisable name of the service.

Implements SmfProviderBase.

QUrl SampleProviderBase::serviceUrl ( ) const [virtual]

Method to get the Website of the service

Returns:
The Website of the service

Implements SmfProviderBase.

QString SampleProviderBase::smfRegistrationId ( ) const [virtual]

Method to get the unique registration ID provided by the Smf for authorised plugins

Returns:
The unique registration ID/token provided by the Smf for authorised plugins

Implements SmfProviderBase.

The documentation for this class was generated from the following files:
  • example/sampleplugin.h
  • example/sampleplugin.cpp
Generated on Thu Sep 23 15:03:31 2010 for smf by doxygen 1.6.3


smf: Member List

SampleProviderBase Member List

This is the complete list of members for SampleProviderBase, including all inherited members.
applicationIcon() const | SampleProviderBase | [virtual]
applicationUrl() const | SampleProviderBase | [virtual]
authenticationApp(QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const | SampleProviderBase | [virtual]
description() const | SampleProviderBase | [virtual]
getDataUsage() const | SampleProviderBase |
pluginId() const | SampleProviderBase | [virtual]
SamplePlugin (defined in SampleProviderBase) | SampleProviderBase | [friend]
SampleProviderBase(QObject *aParent=0) | SampleProviderBase |
SampleProviderBase(const SampleProviderBase &aOther) | SampleProviderBase |
serviceIcon() const | SampleProviderBase | [virtual]
serviceName() const | SampleProviderBase | [virtual]
serviceUrl() const | SampleProviderBase | [virtual]
smfRegistrationId() const | SampleProviderBase | [virtual]
supportedInterfaces() const =0 | SmfProviderBase | [pure virtual]
supportedLanguages() const =0 | SmfProviderBase | [pure virtual]
~SampleProviderBase() | SampleProviderBase |
~SmfProviderBase() | SmfProviderBase | [inline, virtual]
Generated on Thu Sep 23 15:03:31 2010 for smf by doxygen 1.6.3


smf: ScreenSize Class Reference

ScreenSize Class Reference

List of all members.

Static Public Member Functions

static QRect GetScreenRect ()
The documentation for this class was generated from the following file:
  • example/DemoGUI/ScreenSize.h
Generated on Thu Sep 23 15:03:31 2010 for smf by doxygen 1.6.3


smf: Member List

ScreenSize Member List

This is the complete list of members for ScreenSize, including all inherited members.
GetScreenRect() (defined in ScreenSize) ScreenSize [inline, static]
Generated on Thu Sep 23 15:03:31 2010 for smf by doxygen 1.6.3


smf: QJson::Serializer Class Reference

QJson::Serializer

QJson::Serializer Class Reference

Main class used to convert QVariant objects to JSON data. More...

#include <serializer.h>

List of all members.

Classes

class | SerializerPrivate

Public Member Functions

void | serialize (const QVariant &variant, QIODevice *out, bool *ok=0)
QByteArray | serialize (const QVariant &variant)

Detailed Description

Main class used to convert QVariant objects to JSON data.

QVariant objects are converted to a string containing the JSON data. If QVariant object is empty or not valid a null json object is returned.

Member Function Documentation

QByteArray Serializer::serialize ( const QVariant & variant )

This is a method provided for convenience. It turns the passed in in-memory representation of the JSON document into a textual one, which is returned. If the returned string is empty, the document was empty. If it was null, there was a parsing error.

Parameters:
variant The JSON document in its in-memory representation as generated by the parser.
void Serializer::serialize | ( | const QVariant & | variant,
 |  | QIODevice * | out,
 |  | bool * | ok = 0
 | ) |  |

This method generates a textual JSON representation and outputs it to the passed in I/O Device.

Parameters:
variant | The JSON document in its in-memory representation as generated by the parser.
out | Input output device
ok | if a conversion error occurs, *ok is set to false; otherwise *ok is set to true
The documentation for this class was generated from the following files:
  • smf/smfservermodule/util/qjson/src/serializer.h
  • smf/smfservermodule/util/qjson/src/serializer.cpp
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: Member List

QJson::Serializer Member List

This is the complete list of members for QJson::Serializer, including all inherited members.
serialize(const QVariant &variant, QIODevice *out, bool *ok=0) | QJson::Serializer
serialize(const QVariant &variant) | QJson::Serializer
Serializer() (defined in QJson::Serializer) | QJson::Serializer
~Serializer() (defined in QJson::Serializer) | QJson::Serializer
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: QJson::Serializer::SerializerPrivate Class Reference

QJson::Serializer::SerializerPrivate

QJson::Serializer::SerializerPrivate Class Reference

The documentation for this class was generated from the following file:
  • smf/smfservermodule/util/qjson/src/serializer.cpp
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: QJson::SerializerRunnable Class Reference

QJson::SerializerRunnable

QJson::SerializerRunnable Class Reference

Convenience class for converting JSON data to QVariant objects using a dedicated thread. More...

#include <serializerrunnable.h>

List of all members.

Classes

class | Private

Signals

void | parsingFinished (const QByteArray &serialized, bool ok, const QString &error_msg)

Public Member Functions

SerializerRunnable (QObject *parent=0)
void | setJsonObject (const QVariant &json)
void | run ()

Detailed Description

Convenience class for converting JSON data to QVariant objects using a dedicated thread.

Constructor & Destructor Documentation

SerializerRunnable::SerializerRunnable ( QObject * parent = 0 ) [explicit]

This signal is emitted when the conversion process has been completed

Parameters:
data | contains the JSON data that has to be converted
parent | parent of the object

Member Function Documentation

void QJson::SerializerRunnable::parsingFinished | ( | const QByteArray & | serialized,
 |  | bool | ok,
 |  | const QString & | error_msg |
 | ) |  |  | [signal]

This signal is emitted when the serialization process has been completed

Parameters:
serialized | contains the result of the serialization
ok | if a serialization error occurs ok is set to false, otherwise it's set to true.
error_msg | contains a string explaining the failure reason
void SerializerRunnable::setJsonObject ( const QVariant & json )

Sets the json object to serialize.

Parameters:
json QVariant containing the json representation to be serialized
The documentation for this class was generated from the following files:
  • smf/smfservermodule/util/qjson/src/serializerrunnable.h
  • smf/smfservermodule/util/qjson/src/serializerrunnable.cpp
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: Member List

QJson::SerializerRunnable Member List

This is the complete list of members for QJson::SerializerRunnable, including all inherited members.
parsingFinished(const QByteArray &serialized, bool ok, const QString &error_msg) | QJson::SerializerRunnable | [signal]
run() (defined in QJson::SerializerRunnable) | QJson::SerializerRunnable |
SerializerRunnable(QObject *parent=0) | QJson::SerializerRunnable | [explicit]
setJsonObject(const QVariant &json) | QJson::SerializerRunnable |
~SerializerRunnable() (defined in QJson::SerializerRunnable) | QJson::SerializerRunnable |
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: yy::slice< T, S > Class Template Reference

yy::slice

yy::slice< T, S > Class Template Reference

Present a slice of the top of a stack. More...

#include <stack.hh>

List of all members.

Public Member Functions

slice (const S &stack, unsigned int range)
const T & operator[] (unsigned int i) const

Detailed Description

template<class T, class S = stack<T>>
class yy::slice< T, S >

Present a slice of the top of a stack.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/util/qjson/src/stack.hh
Generated on Thu Sep 23 15:03:54 2010 for smf by doxygen 1.6.3


smf: Member List

yy::slice< T, S > Member List

This is the complete list of members for yy::slice< T, S >, including all inherited members.
operator[](unsigned int i) const (defined in yy::slice< T, S >) | yy::slice< T, S > | [inline]
slice(const S &stack, unsigned int range) (defined in yy::slice< T, S >) | yy::slice< T, S > | [inline]
Generated on Thu Sep 23 15:03:54 2010 for smf by doxygen 1.6.3


smf: SmfActivityEntry Class Reference

SmfActivityEntry Class Reference
[Common Data Classes]

#include <smfactions.h>

List of all members.

Public Member Functions

SmfActivityEntry (const SmfActivityEntry &aOther)
QString | id () const
SmfPost | title () const
SmfPost | details () const
SmfContact | author () const
SmfActivityVerb | actionName () const
QList< SmfActivityObject > | activities () const
SmfActivityObject | targetObj () const
bool | setId (const QString &aId)
bool | setTitle (const SmfPost &aTitle)
bool | setDetails (const SmfPost &aDetails)
bool | setAuthor (const SmfContact &aContact)
void | setActionName (SmfActivityVerb aVerb)
bool | setActivities (QList< SmfActivityObject > &aList)
bool | setTargetObj (const SmfActivityObject &aTarget)

Friends

QDataStream & | operator>> (QDataStream &aOut, SmfActivityEntry &aData)
QDataStream & | operator<< (QDataStream &aIn, const SmfActivityEntry &aData)

Detailed Description

The object class represents an entry in the list of activities

Member Function Documentation

SmfActivityVerb SmfActivityEntry::actionName ( ) const
Returns:
Returns the verb of the activity ,e.g. Robin "marked" Joseph as a friend
QList< SmfActivityObject > SmfActivityEntry::activities ( ) const

There can be multiple objects in a single activity entry, though this may be rare - only for few verbs.

Returns:
list of activity objects (mostly one object)
SmfContact SmfActivityEntry::author ( ) const
Returns:
Returns the author of the activity - the name and the uri field are most commonly used Other information fields might be empty
SmfPost SmfActivityEntry::details ( ) const
Returns:
Returns detail descriptiopn of this entry in the activity list. might be absent if title is sufficient
QString SmfActivityEntry::id ( ) const
Returns:
Returns service specific id of the of entry
void SmfActivityEntry::setActionName ( SmfActivityVerb aVerb )

Sets the verb of the activity ,e.g. Robin "marked" Joseph as a friend

Parameters:
aVerb The action name to be set
bool SmfActivityEntry::setActivities ( QList< SmfActivityObject > & aList )

Sets single or multiple objects in a single activity entry, though multiple may be rare - only for few verbs.

Parameters:
list of activity objects (mostly one object)
bool SmfActivityEntry::setAuthor ( const SmfContact & aContact )

Sets the author of the activity - the name and the uri field are most commonly used Oher information fields might be empty

Parameters:
aContact The author to be set
bool SmfActivityEntry::setDetails ( const SmfPost & aDetails )

Sets detail description of this entry in the activity list. might be absent if title is sufficient

Parameters:
aDetails The details to be set
bool SmfActivityEntry::setId ( const QString & aId )

Sets service specific id of the of entry

Parameters:
aId The id to be set
bool SmfActivityEntry::setTargetObj ( const SmfActivityObject & aTarget )

Returns information about the target of the activity, for verbs that support a target. For example, a target is a photo album to which photos were added

Parameters:
aTarget The activity object to be set
bool SmfActivityEntry::setTitle ( const SmfPost & aTitle )

Sets the title of the entry - mostly be a string

Parameters:
aTitle The title to be set
SmfActivityObject SmfActivityEntry::targetObj ( ) const
Returns:
Returns information about the target of the activity, for verbs that support a target. For example, a target is a photo album to which photos were added
SmfPost SmfActivityEntry::title ( ) const
Returns:
Returns the title of the entry - mostly be a string

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aIn,
 |  | const SmfActivityEntry & | aData |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfActivityEntry object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aObj | The SmfActivityEntry object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aOut,
 |  | SmfActivityEntry & | aData |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfActivityEntry object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aObj | The SmfActivityEntry object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfactions.h
  • smf/smfservermodule/smfcommon/smfactions.cpp
Generated on Thu Sep 23 15:03:31 2010 for smf by doxygen 1.6.3


smf: Member List

SmfActivityEntry Member List

This is the complete list of members for SmfActivityEntry, including all inherited members.
actionName() const | SmfActivityEntry |
activities() const | SmfActivityEntry |
author() const | SmfActivityEntry |
details() const | SmfActivityEntry |
id() const | SmfActivityEntry |
operator<<(QDataStream &aIn, const SmfActivityEntry &aData) | SmfActivityEntry | [friend]
operator>>(QDataStream &aOut, SmfActivityEntry &aData) | SmfActivityEntry | [friend]
setActionName(SmfActivityVerb aVerb) | SmfActivityEntry |
setActivities(QList< SmfActivityObject > &aList) | SmfActivityEntry |
setAuthor(const SmfContact &aContact) | SmfActivityEntry |
setDetails(const SmfPost &aDetails) | SmfActivityEntry |
setId(const QString &aId) | SmfActivityEntry |
setTargetObj(const SmfActivityObject &aTarget) | SmfActivityEntry |
setTitle(const SmfPost &aTitle) | SmfActivityEntry |
SmfActivityEntry() (defined in SmfActivityEntry) | SmfActivityEntry |
SmfActivityEntry(const SmfActivityEntry &aOther) (defined in SmfActivityEntry) | SmfActivityEntry |
targetObj() const | SmfActivityEntry |
title() const | SmfActivityEntry |
~SmfActivityEntry() (defined in SmfActivityEntry) | SmfActivityEntry |
Generated on Thu Sep 23 15:03:31 2010 for smf by doxygen 1.6.3


smf: SmfActivityEntryPrivate Class Reference

SmfActivityEntryPrivate Class Reference

List of all members.

Public Member Functions

SmfActivityEntryPrivate (const SmfActivityEntryPrivate &aOther)

Public Attributes

QString | m_id
SmfPost | m_title
SmfPost | m_details
SmfContact | m_author
SmfActivityVerb | m_actionName
QList< SmfActivityObject > | m_activities
SmfActivityObject | m_targetObj

Member Data Documentation

QString SmfActivityEntryPrivate::m_id

Data members

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfactions.h
Generated on Thu Sep 23 15:03:31 2010 for smf by doxygen 1.6.3


smf: Member List

SmfActivityEntryPrivate Member List

This is the complete list of members for SmfActivityEntryPrivate, including all inherited members.
m_actionName (defined in SmfActivityEntryPrivate) | SmfActivityEntryPrivate |
m_activities (defined in SmfActivityEntryPrivate) | SmfActivityEntryPrivate |
m_author (defined in SmfActivityEntryPrivate) | SmfActivityEntryPrivate |
m_details (defined in SmfActivityEntryPrivate) | SmfActivityEntryPrivate |
m_id | SmfActivityEntryPrivate |
m_targetObj (defined in SmfActivityEntryPrivate) | SmfActivityEntryPrivate |
m_title (defined in SmfActivityEntryPrivate) | SmfActivityEntryPrivate |
SmfActivityEntryPrivate() (defined in SmfActivityEntryPrivate) | SmfActivityEntryPrivate | [inline]
SmfActivityEntryPrivate(const SmfActivityEntryPrivate &aOther) (defined in SmfActivityEntryPrivate) | SmfActivityEntryPrivate | [inline]
~SmfActivityEntryPrivate() (defined in SmfActivityEntryPrivate) | SmfActivityEntryPrivate | [inline]
Generated on Thu Sep 23 15:03:31 2010 for smf by doxygen 1.6.3


smf: SmfActivityFetcher Class Reference

SmfActivityFetcher Class Reference
[Client Classes]

#include <smfactivityfetcher.h>

List of all members.

Public Slots

SmfError | selfActivities (int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | friendsActivities (const SmfContact &aFriend, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | filtered (QList< SmfActivityObjectType > filters, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()

Signals

void | resultsAvailable (SmfActivityEntryList *entries, SmfError error, SmfResultPage resultPage)
void | customDataAvailable (const int &operationId, QByteArray *customData)

Public Member Functions

SmfActivityFetcher (SmfProvider *baseprovider=0)
~SmfActivityFetcher ()

Friends

class | SmfActivityFetcherPrivate

Detailed Description

Basic activity service ("org.symbian.smf.client.activity.fetcher")

Constructor & Destructor Documentation

SmfActivityFetcher::SmfActivityFetcher ( SmfProvider * baseprovider = 0 )

Constructs SmfActivity.

Parameters:
baseProvider The base provider info

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Represents activity in terms similar to standard activity stream http://activitystrea.ms/

SmfActivityFetcher::~SmfActivityFetcher ( )

Destructor

Member Function Documentation

SmfError SmfActivityFetcher::cancelRequest ( ) [slot]

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
void SmfActivityFetcher::customDataAvailable | ( | const int & | operationId,
 |  | QByteArray * | customData |
 | ) |  |  | [signal]

Signals availability of the result of the customRequest

SmfError SmfActivityFetcher::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData |
 | ) |  |  | [slot]

Request for a custom operation. The signal customDataAvailable() is emitted when the result is available.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfError. SmfNoError if success, else appropriate error code Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
SmfError SmfActivityFetcher::filtered | ( | QList< SmfActivityObjectType > | filters,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [slot]

returns only those activities (self) which are from

  • filters
    Returns:
    SmfError. SmfNoError if success, else appropriate error code
SmfError SmfActivityFetcher::friendsActivities | ( | const SmfContact & | aFriend,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [slot]

Emits signal resultsAvailable() when list of activities for other contact is available

Returns:
SmfError. SmfNoError if success, else appropriate error code
void SmfActivityFetcher::resultsAvailable | ( | SmfActivityEntryList * | entries,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Signals availability of the result of the previous query

SmfError SmfActivityFetcher::selfActivities | ( | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [slot]

Emits signal resultsAvailable() when list of activities for the user is available

Returns:
SmfError. SmfNoError if success, else appropriate error code
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfactivityfetcher.h
  • smf/smfservermodule/smfclient/smfactivityfetcher.cpp
Generated on Thu Sep 23 15:03:31 2010 for smf by doxygen 1.6.3


smf: Member List

SmfActivityFetcher Member List

This is the complete list of members for SmfActivityFetcher, including all inherited members.
cancelRequest() | SmfActivityFetcher | [slot]
customDataAvailable(const int &operationId, QByteArray *customData) | SmfActivityFetcher | [signal]
customRequest(const int &operationId, QByteArray *customData) | SmfActivityFetcher | [slot]
filtered(QList< SmfActivityObjectType > filters, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfActivityFetcher | [slot]
friendsActivities(const SmfContact &aFriend, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfActivityFetcher | [slot]
resultsAvailable(SmfActivityEntryList *entries, SmfError error, SmfResultPage resultPage) | SmfActivityFetcher | [signal]
selfActivities(int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfActivityFetcher | [slot]
SmfActivityFetcher(SmfProvider *baseprovider=0) | SmfActivityFetcher |
SmfActivityFetcherPrivate (defined in SmfActivityFetcher) | SmfActivityFetcher | [friend]
~SmfActivityFetcher() | SmfActivityFetcher |
Generated on Thu Sep 23 15:03:31 2010 for smf by doxygen 1.6.3


smf: SmfActivityFetcherPlugin Class Reference

SmfActivityFetcherPlugin Class Reference
[Plugin Classes]

#include <smfactivityfetcherplugin.h>

Inherits SmfPluginBase.

Inherited by FBActivityFetcherPlugin.

List of all members.

Public Member Functions

virtual | ~SmfActivityFetcherPlugin ()
virtual SmfPluginError | selfActivities (SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | friendsActivities (SmfPluginRequestData &aRequest, const SmfContact &aContact, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | filtered (SmfPluginRequestData &aRequest, QList< SmfActivityObjectType > &aFilters, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0

Detailed Description

Interface specification for fetching social activity list for a user. This class provides basic functionality to allow applications to obtain list of activities like "marked as favourite", "commented on a picture" etc in a social networking service.

All of the functionality described here should be implemented by a service specific plug-in.

Constructor & Destructor Documentation

virtual SmfActivityFetcherPlugin::~SmfActivityFetcherPlugin ( ) [inline, virtual]

Destructor

Member Function Documentation

virtual SmfPluginError SmfActivityFetcherPlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [pure virtual]

Customised method for SmfActivityFetcherPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | [in] The operation type (should be known between the client interface and the plugin)
aData | [in] The data required to form the request (The type of data should be known between client and the plugin)
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBActivityFetcherPlugin.

virtual SmfPluginError SmfActivityFetcherPlugin::filtered | ( | SmfPluginRequestData & | aRequest,
 |  | QList< SmfActivityObjectType > & | aFilters,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get list of self activities filtered by activity type, e.g. only photo updates in own wall

Parameters:
aRequest | [out] The request data plugin generated (to be sent to network)
aFilters | [in] The list of activity types to be included in result
aPageNum | [in] The page to be extracted
aItemsPerPage[in] | Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBActivityFetcherPlugin.

virtual SmfPluginError SmfActivityFetcherPlugin::friendsActivities | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfContact & | aContact,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get the list of activities for other, e.g. shown in a friends wall

Parameters:
aRequest | [out] The request data plugin generated (to be sent to network)
aContact | [in] The contact containing the URI, name or id of the user
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBActivityFetcherPlugin.

virtual SmfPluginError SmfActivityFetcherPlugin::selfActivities | ( | SmfPluginRequestData & | aRequest,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get the list of self activities, e.g. shown in own wall

Parameters:
aRequest | [out] The request data that plugin generates (to be sent to network)
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBActivityFetcherPlugin.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfserver/smfplugins/smfactivityfetcherplugin.h
Generated on Thu Sep 23 15:03:31 2010 for smf by doxygen 1.6.3


smf: Member List

SmfActivityFetcherPlugin Member List

This is the complete list of members for SmfActivityFetcherPlugin, including all inherited members.
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0 | SmfActivityFetcherPlugin | [pure virtual]
filtered(SmfPluginRequestData &aRequest, QList< SmfActivityObjectType > &aFilters, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfActivityFetcherPlugin | [pure virtual]
friendsActivities(SmfPluginRequestData &aRequest, const SmfContact &aContact, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfActivityFetcherPlugin | [pure virtual]
getProviderInfo()=0 | SmfPluginBase | [pure virtual]
initialize()=0 | SmfPluginBase | [pure virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aReply, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)=0 | SmfPluginBase | [pure virtual]
selfActivities(SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfActivityFetcherPlugin | [pure virtual]
~SmfActivityFetcherPlugin() | SmfActivityFetcherPlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:31 2010 for smf by doxygen 1.6.3


smf: SmfActivityFetcherPrivate Class Reference

SmfActivityFetcherPrivate Class Reference

Inherits smfObserver.

List of all members.

Public Member Functions

SmfActivityFetcherPrivate (SmfActivityFetcher *activityFetcher)
~SmfActivityFetcherPrivate ()
SmfError | selfActivities (int pageNum, int perPage)
SmfError | friendsActivities (const SmfContact &aFriend, int pageNum, int perPage)
SmfError | filtered (QList< SmfActivityObjectType > filters, int pageNum, int perPage)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()
void | resultsAvailable (QByteArray result, SmfRequestTypeID opcode, SmfError error)

Friends

class | SmfClientQt

Constructor & Destructor Documentation

SmfActivityFetcherPrivate::SmfActivityFetcherPrivate ( SmfActivityFetcher * activityFetcher )

Constructs SmfActivityFetcherPrivate.

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private Implementation of SmfActivityFetcher

SmfActivityFetcherPrivate::~SmfActivityFetcherPrivate ( )

Destructor

Member Function Documentation

SmfError SmfActivityFetcherPrivate::cancelRequest ( )

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
SmfError SmfActivityFetcherPrivate::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData
 | ) |  |

Request for a custom operation. The signal customDataAvailable() is emitted when the result is available.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfError. SmfNoError if success, else appropriate error code Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
SmfError SmfActivityFetcherPrivate::filtered | ( | QList< SmfActivityObjectType > | filters,
 |  | int | pageNum,
 |  | int | perPage
 | ) |  |

returns only those activities (self) which are from

  • filters
    Returns:
    SmfError. SmfNoError if success, else appropriate error code
SmfError SmfActivityFetcherPrivate::friendsActivities | ( | const SmfContact & | aFriend,
 |  | int | pageNum,
 |  | int | perPage
 | ) |  |

Emits signal resultsAvailable() when list of activities for other contact is available

Returns:
SmfError. SmfNoError if success, else appropriate error code
void SmfActivityFetcherPrivate::resultsAvailable | ( | QByteArray | result,
 |  | SmfRequestTypeID | opcode,
 |  | SmfError | error |
 | ) |  |  | [virtual]

To notify availibility of asynchronous requests.

Parameters:
result | Requested result, before using must check error param.
opcode | Requested opcode, for which the result has arrived.
error | Error

Implements smfObserver.

SmfError SmfActivityFetcherPrivate::selfActivities | ( | int | pageNum,
 |  | int | perPage
 | ) |  |

Emits signal resultsAvailable() when list of activities for the user is available

Returns:
SmfError. SmfNoError if success, else appropriate error code
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfactivityfetcher_p.h
  • smf/smfservermodule/smfclient/smfactivityfetcher_p.cpp
Generated on Thu Sep 23 15:03:32 2010 for smf by doxygen 1.6.3


smf: Member List

SmfActivityFetcherPrivate Member List

This is the complete list of members for SmfActivityFetcherPrivate, including all inherited members.
cancelRequest() | SmfActivityFetcherPrivate |
customRequest(const int &operationId, QByteArray *customData) | SmfActivityFetcherPrivate |
filtered(QList< SmfActivityObjectType > filters, int pageNum, int perPage) | SmfActivityFetcherPrivate |
friendsActivities(const SmfContact &aFriend, int pageNum, int perPage) | SmfActivityFetcherPrivate |
resultsAvailable(QByteArray result, SmfRequestTypeID opcode, SmfError error) | SmfActivityFetcherPrivate | [virtual]
selfActivities(int pageNum, int perPage) | SmfActivityFetcherPrivate |
SmfActivityFetcherPrivate(SmfActivityFetcher *activityFetcher) | SmfActivityFetcherPrivate |
SmfClientQt (defined in SmfActivityFetcherPrivate) | SmfActivityFetcherPrivate | [friend]
~SmfActivityFetcherPrivate() | SmfActivityFetcherPrivate |
Generated on Thu Sep 23 15:03:32 2010 for smf by doxygen 1.6.3


smf: SmfActivityObject Class Reference

SmfActivityObject Class Reference
[Common Data Classes]

#include <smfactions.h>

List of all members.

Public Member Functions

SmfActivityObject ()
SmfActivityObject (const SmfActivityObject &aOther)
SmfActivityObject & | operator= (const SmfActivityObject &aOther)
~SmfActivityObject ()
QString | id () const
QImage | thumbnail () const
QString | caption () const
SmfActivityObjectType | type () const
QVariant | objData () const
QString | link () const
QDateTime | time () const
QString | content () const
void | setId (const QString &aId)
void | setThumbnail (const QImage &aIcon)
void | setCaption (const QString &aCap)
void | setType (const SmfActivityObjectType &aObjType)
void | setObjData (const QVariant &aData)
void | setLink (const QString &aLink)
void | setTime (const QDateTime &aTime)
void | setContent (const QString &aText)

Friends

QDataStream & | operator>> (QDataStream &aOut, SmfActivityObject &aData)
QDataStream & | operator<< (QDataStream &aIn, const SmfActivityObject &aData)

Detailed Description

The object class represents an object in an activity (e.g.a picture or a music track on which somebody commented)

Constructor & Destructor Documentation

SmfActivityObject::SmfActivityObject ( )

Constructor

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Represents activities in terms similar to standard activity stream http://activitystrea.ms/ Constructor

SmfActivityObject::SmfActivityObject ( const SmfActivityObject & aOther )

Copy Constructor

Copy Constructor

Parameters:
aOther The reference object
SmfActivityObject::~SmfActivityObject ( )

Destructor

Member Function Documentation

QString SmfActivityObject::caption ( ) const
Returns:
Captions for this object
QString SmfActivityObject::content ( ) const
Returns:
Description of the content of this object
QString SmfActivityObject::id ( ) const
Returns:
returns service specific Id of this object in the entry
QString SmfActivityObject::link ( ) const
Returns:
url of this object, e.g. url of the image on which somebody commented
QVariant SmfActivityObject::objData ( ) const
Returns:
returns data of the object - see type() for casting
SmfActivityObject & SmfActivityObject::operator= ( const SmfActivityObject & aOther )

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
void SmfActivityObject::setCaption ( const QString & aCap )

Sets caption for this object

Parameters:
aCaption The caption to be set
void SmfActivityObject::setContent ( const QString & aText )

Sets the description of the content of this object

Parameters:
aText The content to be set
void SmfActivityObject::setId ( const QString & aId )

Sets service specific id for this object

Parameters:
aId The id to be set
void SmfActivityObject::setLink ( const QString & aLink )

Sets the url for the object

Parameters:
aLink The Link to be set
void SmfActivityObject::setObjData ( const QVariant & aData )

Sets object data e,g, SmfImage, SmfComment, SmfMusic, SmfEvent etc setType() with suitable type should have been called before

Parameters:
aData The object data to be set
void SmfActivityObject::setThumbnail ( const QImage & aIcon )

Sets thumbnail for this object , not mandatory

Parameters:
aIcon The thumbnail image
void SmfActivityObject::setTime ( const QDateTime & aTime )

Sets the time of creation/last modification of the object

Parameters:
aTime The time to be set
void SmfActivityObject::setType ( const SmfActivityObjectType & aObjType )

Sets type of this object - ObjData should be set next accordingly

Parameters:
aObjType The activity type to be set
QImage SmfActivityObject::thumbnail ( ) const
Returns:
returns thumbnail if availabel for this object in the entry
QDateTime SmfActivityObject::time ( ) const
Returns:
Time of creation of this object
SmfActivityObjectType SmfActivityObject::type ( ) const
Returns:
retruns the type of this object

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aIn,
 |  | const SmfActivityObject & | aData |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfActivityObject object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aObj | The SmfActivityObject object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aOut,
 |  | SmfActivityObject & | aData |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfActivityObject object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aObj | The SmfActivityObject object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfactions.h
  • smf/smfservermodule/smfcommon/smfactions.cpp
Generated on Thu Sep 23 15:03:32 2010 for smf by doxygen 1.6.3


smf: Member List

SmfActivityObject Member List

This is the complete list of members for SmfActivityObject, including all inherited members.
caption() const | SmfActivityObject |
content() const | SmfActivityObject |
id() const | SmfActivityObject |
link() const | SmfActivityObject |
objData() const | SmfActivityObject |
operator<<(QDataStream &aIn, const SmfActivityObject &aData) | SmfActivityObject | [friend]
operator=(const SmfActivityObject &aOther) | SmfActivityObject |
operator>>(QDataStream &aOut, SmfActivityObject &aData) | SmfActivityObject | [friend]
setCaption(const QString &aCap) | SmfActivityObject |
setContent(const QString &aText) | SmfActivityObject |
setId(const QString &aId) | SmfActivityObject |
setLink(const QString &aLink) | SmfActivityObject |
setObjData(const QVariant &aData) | SmfActivityObject |
setThumbnail(const QImage &aIcon) | SmfActivityObject |
setTime(const QDateTime &aTime) | SmfActivityObject |
setType(const SmfActivityObjectType &aObjType) | SmfActivityObject |
SmfActivityObject() | SmfActivityObject |
SmfActivityObject(const SmfActivityObject &aOther) | SmfActivityObject |
thumbnail() const | SmfActivityObject |
time() const | SmfActivityObject |
type() const | SmfActivityObject |
~SmfActivityObject() | SmfActivityObject |
Generated on Thu Sep 23 15:03:32 2010 for smf by doxygen 1.6.3


smf: SmfActivityObjectPrivate Class Reference

SmfActivityObjectPrivate Class Reference

#include <smfactions_p.h>

List of all members.

Public Member Functions

SmfActivityObjectPrivate (const SmfActivityObjectPrivate &aOther)

Public Attributes

QString | m_id
QImage | m_thumbnail
QString | m_caption
SmfActivityObjectType | m_type
QVariant | m_objData
QString | m_link
QDateTime | m_time
QString | m_content

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Contains private implementation of the smfactions

Member Data Documentation

QString SmfActivityObjectPrivate::m_id

Data members

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfactions_p.h
Generated on Thu Sep 23 15:03:32 2010 for smf by doxygen 1.6.3


smf: Member List

SmfActivityObjectPrivate Member List

This is the complete list of members for SmfActivityObjectPrivate, including all inherited members.
m_caption (defined in SmfActivityObjectPrivate) | SmfActivityObjectPrivate |
m_content (defined in SmfActivityObjectPrivate) | SmfActivityObjectPrivate |
m_id | SmfActivityObjectPrivate |
m_link (defined in SmfActivityObjectPrivate) | SmfActivityObjectPrivate |
m_objData (defined in SmfActivityObjectPrivate) | SmfActivityObjectPrivate |
m_thumbnail (defined in SmfActivityObjectPrivate) | SmfActivityObjectPrivate |
m_time (defined in SmfActivityObjectPrivate) | SmfActivityObjectPrivate |
m_type (defined in SmfActivityObjectPrivate) | SmfActivityObjectPrivate |
SmfActivityObjectPrivate() (defined in SmfActivityObjectPrivate) | SmfActivityObjectPrivate | [inline]
SmfActivityObjectPrivate(const SmfActivityObjectPrivate &aOther) (defined in SmfActivityObjectPrivate) | SmfActivityObjectPrivate | [inline]
~SmfActivityObjectPrivate() (defined in SmfActivityObjectPrivate) | SmfActivityObjectPrivate | [inline]
Generated on Thu Sep 23 15:03:32 2010 for smf by doxygen 1.6.3


smf: SmfAlbum Class Reference

SmfAlbum Class Reference
[Common Data Classes]

#include <smfalbum.h>

List of all members.

Public Member Functions

SmfAlbum ()
SmfAlbum (const SmfAlbum &aOther)
SmfAlbum & | operator= (const SmfAlbum &aOther)
~SmfAlbum ()
QString | name () const
QUrl | imageUrl () const
SmfArtists | artists () const
SmfLocation | location () const
int | itemsCount () const
SmfAlbumMediaType | type () const
QString | id () const
QString | secondaryId () const
void | setName (const QString &aName)
void | setImageUrl (const QUrl &aUrl)
void | setArtists (const SmfArtists &aArtists)
void | setLocation (const SmfLocation &aLoc)
void | setItemsCount (const int aCount)
void | setType (SmfAlbumMediaType aType)
void | setId (const QString &aId)
void | setSecondaryId (const QString &aSecondaryID)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfAlbum &aAlbum)
QDataStream & | operator>> (QDataStream &aDataStream, SmfAlbum &aAlbum)

Detailed Description

The SmfAlbum class represents a music album

Constructor & Destructor Documentation

SmfAlbum::SmfAlbum ( )

Constructor with default argument

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The SmfAlbum class represents an album Constructor with default argument

SmfAlbum::SmfAlbum ( const SmfAlbum & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfAlbum::~SmfAlbum ( )

Destructor

Member Function Documentation

SmfArtists SmfAlbum::artists ( ) const

Method to get the artist names

Returns:
The list of artists in the album
QString SmfAlbum::id ( ) const

Method to get the id of the album, id is unique to service provider

Returns:
The ID value

Method to get the id of the album

Returns:
The ID value
QUrl SmfAlbum::imageUrl ( ) const

Method to get the album's image url if any

Returns:
The album's image url if any
int SmfAlbum::itemsCount ( ) const

Method to get the number of items in this album

Returns:
The number of items in this album
SmfLocation SmfAlbum::location ( ) const

Method to get the location of this album

Returns:
The location of this album
QString SmfAlbum::name ( ) const

Method to get the album name

Returns:
The album name
SmfAlbum & SmfAlbum::operator= ( const SmfAlbum & aOther )

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
QString SmfAlbum::secondaryId ( ) const

Method to get the secondary id of the album, e.g. musicbrainz id of the album for a music album

Returns:
The ID value
void SmfAlbum::setArtists ( const SmfArtists & aArtists )

Method to set the artist names

Parameters:
aArtists The list of artists in the album
void SmfAlbum::setId ( const QString & aId )

Method to set the id of the album

Parameters:
aId The ID value
void SmfAlbum::setImageUrl ( const QUrl & aUrl )

Method to set the album's image url

Parameters:
aUrl The album's image url
void SmfAlbum::setItemsCount ( const int aCount )

Method to set the number of items in this album

Parameters:
aCount the number of items in this album
void SmfAlbum::setLocation ( const SmfLocation & aLoc )

Method to set the location of this album

Parameters:
aLoc The location of the album
void SmfAlbum::setName ( const QString & aName )

Method to set the album name

Parameters:
aName The album name
void SmfAlbum::setSecondaryId ( const QString & aSecondaryID )

Method to set the secondary id of the album, e.g. musicbrainz id of the album for a music album

Parameters:
aSecondaryID the secondaryID of this album
void SmfAlbum::setType ( SmfAlbumMediaType aType )

Method to set the type of this album

Parameters:
aType the type of this album
SmfAlbumMediaType SmfAlbum::type ( ) const

Method to get the type of this album

Returns:
The type of this album

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfAlbum & | aAlbum |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfAlbum object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aAlbum | The SmfAlbum object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfAlbum & | aAlbum |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfAlbum object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aAlbum | The SmfAlbum object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfalbum.h
  • smf/smfservermodule/smfcommon/smfalbum.cpp
Generated on Thu Sep 23 15:03:32 2010 for smf by doxygen 1.6.3


smf: Member List

SmfAlbum Member List

This is the complete list of members for SmfAlbum, including all inherited members.
artists() const | SmfAlbum |
id() const | SmfAlbum |
imageUrl() const | SmfAlbum |
itemsCount() const | SmfAlbum |
location() const | SmfAlbum |
name() const | SmfAlbum |
operator<<(QDataStream &aDataStream, const SmfAlbum &aAlbum) | SmfAlbum | [friend]
operator=(const SmfAlbum &aOther) | SmfAlbum |
operator>>(QDataStream &aDataStream, SmfAlbum &aAlbum) | SmfAlbum | [friend]
secondaryId() const | SmfAlbum |
setArtists(const SmfArtists &aArtists) | SmfAlbum |
setId(const QString &aId) | SmfAlbum |
setImageUrl(const QUrl &aUrl) | SmfAlbum |
setItemsCount(const int aCount) | SmfAlbum |
setLocation(const SmfLocation &aLoc) | SmfAlbum |
setName(const QString &aName) | SmfAlbum |
setSecondaryId(const QString &aSecondaryID) | SmfAlbum |
setType(SmfAlbumMediaType aType) | SmfAlbum |
SmfAlbum() | SmfAlbum |
SmfAlbum(const SmfAlbum &aOther) | SmfAlbum |
type() const | SmfAlbum |
~SmfAlbum() | SmfAlbum |
Generated on Thu Sep 23 15:03:32 2010 for smf by doxygen 1.6.3


smf: SmfAlbumPrivate Class Reference

SmfAlbumPrivate Class Reference

#include <smfalbum_p.h>

List of all members.

Public Member Functions

SmfAlbumPrivate ()
SmfAlbumPrivate (const SmfAlbumPrivate &aOther)
~SmfAlbumPrivate ()

Public Attributes

QString | m_name
QUrl | m_imageUrl
SmfArtists | m_artists
SmfLocation | m_location
int | m_itemCount
SmfAlbumMediaType | m_type
QString | m_albumId
QString | m_secondaryId

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfAlbum class

Constructor & Destructor Documentation

SmfAlbumPrivate::SmfAlbumPrivate ( ) [inline]

Constructor

SmfAlbumPrivate::SmfAlbumPrivate ( const SmfAlbumPrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfAlbumPrivate::~SmfAlbumPrivate ( ) [inline]

Destructor

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfalbum_p.h
Generated on Thu Sep 23 15:03:32 2010 for smf by doxygen 1.6.3


smf: Member List

SmfAlbumPrivate Member List

This is the complete list of members for SmfAlbumPrivate, including all inherited members.
m_albumId (defined in SmfAlbumPrivate) | SmfAlbumPrivate |
m_artists (defined in SmfAlbumPrivate) | SmfAlbumPrivate |
m_imageUrl (defined in SmfAlbumPrivate) | SmfAlbumPrivate |
m_itemCount (defined in SmfAlbumPrivate) | SmfAlbumPrivate |
m_location (defined in SmfAlbumPrivate) | SmfAlbumPrivate |
m_name (defined in SmfAlbumPrivate) | SmfAlbumPrivate |
m_secondaryId (defined in SmfAlbumPrivate) | SmfAlbumPrivate |
m_type (defined in SmfAlbumPrivate) | SmfAlbumPrivate |
SmfAlbumPrivate() | SmfAlbumPrivate | [inline]
SmfAlbumPrivate(const SmfAlbumPrivate &aOther) | SmfAlbumPrivate | [inline]
~SmfAlbumPrivate() | SmfAlbumPrivate | [inline]
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: SmfArtists Class Reference

SmfArtists Class Reference
[Common Data Classes]

#include <smfartists.h>

List of all members.

Public Member Functions

SmfArtists ()
SmfArtists (const SmfArtists &aOther)
SmfArtists & | operator= (const SmfArtists &aOther)
~SmfArtists ()
QStringList | names () const
QImage | image () const
QUrl | url () const
QStringList | tags () const
QString | id () const
void | setNames (const QStringList &aList)
void | setImage (const QImage &aImage)
void | setUrl (const QUrl &aUrl)
void | setTags (const QStringList &aTags)
void | setId (const QString &aId)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfArtists &aArtists)
QDataStream & | operator>> (QDataStream &aDataStream, SmfArtists &aArtists)

Detailed Description

The SmfArtists class represents the artists in a track or an album

Constructor & Destructor Documentation

SmfArtists::SmfArtists ( )

Constructor with default argument

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The SmfArtists class represents the artists in a track or an album Constructor with default argument

SmfArtists::SmfArtists ( const SmfArtists & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfArtists::~SmfArtists ( )

Destructor

Member Function Documentation

QString SmfArtists::id ( ) const

Service specific Id for this artist(s), e.g. could be musicbrainz id for this artist

Returns:
service specific id of the artists, NULL if not supported
QImage SmfArtists::image ( ) const

Method to get the image of the artists

Returns:
The image of the artists if available, always small size is fetched

Method to get the image of the artists

Returns:
The image of te artists
QStringList SmfArtists::names ( ) const

Method to get the artists names

Returns:
The list of artists
SmfArtists & SmfArtists::operator= ( const SmfArtists & aOther )

Overloaded = operator

Parameters:
aOther The reference object

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
void SmfArtists::setId ( const QString & aId )

Method to set the service specific ID of the artists

Parameters:
aId The id of the artists
void SmfArtists::setImage ( const QImage & aImage )

Method to set the image of the artists

Parameters:
aImage The image of the artists
void SmfArtists::setNames ( const QStringList & aList )

Method to set the artists names

Parameters:
aList The list of artists names
void SmfArtists::setTags ( const QStringList & aTags )

Method to set tags of the artists

Parameters:
aTags tags for the artists
void SmfArtists::setUrl ( const QUrl & aUrl )

Method to set the url of the artists

Parameters:
aUrl The url of the artists
QStringList SmfArtists::tags ( ) const

Method to get the tags applied for artist(s)

Returns:
list of tags, NULL if not supported
QUrl SmfArtists::url ( ) const

Method to get the url of the artists

Returns:
The url of the artists, NULL if not present

Method to get the url of the artists

Returns:
The url of the artists

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfArtists & | aArtists |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfArtists object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aArtists | The SmfArtists object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfArtists & | aArtists |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfArtists object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aArtists | The SmfArtists object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfartists.h
  • smf/smfservermodule/smfcommon/smfartists.cpp
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: Member List

SmfArtists Member List

This is the complete list of members for SmfArtists, including all inherited members.
id() const | SmfArtists |
image() const | SmfArtists |
names() const | SmfArtists |
operator<<(QDataStream &aDataStream, const SmfArtists &aArtists) | SmfArtists | [friend]
operator=(const SmfArtists &aOther) | SmfArtists |
operator>>(QDataStream &aDataStream, SmfArtists &aArtists) | SmfArtists | [friend]
setId(const QString &aId) | SmfArtists |
setImage(const QImage &aImage) | SmfArtists |
setNames(const QStringList &aList) | SmfArtists |
setTags(const QStringList &aTags) | SmfArtists |
setUrl(const QUrl &aUrl) | SmfArtists |
SmfArtists() | SmfArtists |
SmfArtists(const SmfArtists &aOther) | SmfArtists |
tags() const | SmfArtists |
url() const | SmfArtists |
~SmfArtists() | SmfArtists |
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: SmfArtistsPrivate Class Reference

SmfArtistsPrivate Class Reference

#include <smfartists_p.h>

List of all members.

Public Member Functions

SmfArtistsPrivate ()
SmfArtistsPrivate (const SmfArtistsPrivate &aOther)
~SmfArtistsPrivate ()

Public Attributes

QStringList | m_names
QImage | m_image
QUrl | m_url
QStringList | m_tags
QString | m_id

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfArtists class

Constructor & Destructor Documentation

SmfArtistsPrivate::SmfArtistsPrivate ( ) [inline]

Constructor

SmfArtistsPrivate::SmfArtistsPrivate ( const SmfArtistsPrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfArtistsPrivate::~SmfArtistsPrivate ( ) [inline]

Destructor

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfartists_p.h
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: Member List

SmfArtistsPrivate Member List

This is the complete list of members for SmfArtistsPrivate, including all inherited members.
m_id (defined in SmfArtistsPrivate) | SmfArtistsPrivate |
m_image (defined in SmfArtistsPrivate) | SmfArtistsPrivate |
m_names (defined in SmfArtistsPrivate) | SmfArtistsPrivate |
m_tags (defined in SmfArtistsPrivate) | SmfArtistsPrivate |
m_url (defined in SmfArtistsPrivate) | SmfArtistsPrivate |
SmfArtistsPrivate() | SmfArtistsPrivate | [inline]
SmfArtistsPrivate(const SmfArtistsPrivate &aOther) | SmfArtistsPrivate | [inline]
~SmfArtistsPrivate() | SmfArtistsPrivate | [inline]
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: SmfClient Class Reference

SmfClient Class Reference
[Client Classes]

#include <smfclient.h>

List of all members.

Public Member Functions

SmfClient ()
~SmfClient ()
QList< SmfProvider > * | GetServices (const QString &serviceName)
QString | errorString (const SmfError &aErrorCode) const

Detailed Description

Interface for a base service provider. Other service provider classes contains implementation of this base class so that each has access to service provider information. All of the functionality described here should be implemented by a service specific plug-in object.

Constructor & Destructor Documentation

SmfClient::SmfClient ( )

Constructs SmfClient

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The SmfClient class provides a set of APIs to get list of service provider who implement the given interface. Calling GetServices of the instance of this class is mandatory before using any other interface.

SmfClient::~SmfClient ( )

Destructor

Member Function Documentation

QString SmfClient::errorString ( const SmfError & aErrorCode ) const

This method returns the error message for the mentioned argument error code

Parameters:
aErrorCode The SmfError code for which the error string is required
Returns:
a QString object containing the required error message
QList< SmfProvider > * SmfClient::GetServices ( const QString & serviceName )

Method to get the list of services for a given service (interface name)

Parameters:
serviceName The name of the service
Returns:
Service provider's list (ownership of memory is transferred to the calling party)
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfclient.h
  • smf/smfservermodule/smfclient/smfclient.cpp
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: Member List

SmfClient Member List

This is the complete list of members for SmfClient, including all inherited members.
errorString(const SmfError &aErrorCode) const | SmfClient
GetServices(const QString &serviceName) | SmfClient
SmfClient() | SmfClient
~SmfClient() | SmfClient
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: SmfClientApp Class Reference

SmfClientApp Class Reference

List of all members.

Public Member Functions

SmfClientApp (QWidget *parent=0)
The documentation for this class was generated from the following files:
  • example/smfclientapp/smfclientapp.h
  • example/smfclientapp/smfclientapp.cpp
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: Member List

SmfClientApp Member List

This is the complete list of members for SmfClientApp, including all inherited members.
SmfClientApp(QWidget *parent=0) (defined in SmfClientApp) | SmfClientApp
~SmfClientApp() (defined in SmfClientApp) | SmfClientApp
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: Ui::SmfClientApp Class Reference

Ui::SmfClientApp

Ui::SmfClientApp Class Reference

Inherits Ui_SmfClientApp.

List of all members.

The documentation for this class was generated from the following file:
  • example/smfclientapp/ui_smfclientapp.h
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: Member List

Ui::SmfClientApp Member List

This is the complete list of members for Ui::SmfClientApp, including all inherited members.
comboBox (defined in Ui_SmfClientApp) | Ui_SmfClientApp |
label (defined in Ui_SmfClientApp) | Ui_SmfClientApp |
listWidget (defined in Ui_SmfClientApp) | Ui_SmfClientApp |
pushButton (defined in Ui_SmfClientApp) | Ui_SmfClientApp |
pushButton_2 (defined in Ui_SmfClientApp) | Ui_SmfClientApp |
retranslateUi(QWidget *SmfClientApp) (defined in Ui_SmfClientApp) | Ui_SmfClientApp | [inline]
setupUi(QWidget *SmfClientApp) (defined in Ui_SmfClientApp) | Ui_SmfClientApp | [inline]
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: SmfClientAuthID Struct Reference

SmfClientAuthID Struct Reference

List of all members.

Public Attributes

QString | pid
SmfServerQtSession * | session
The documentation for this struct was generated from the following file:
  • smf/smfservermodule/smfcommon/smfglobal.h
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: Member List

SmfClientAuthID Member List

This is the complete list of members for SmfClientAuthID, including all inherited members.
pid (defined in SmfClientAuthID) | SmfClientAuthID
session (defined in SmfClientAuthID) | SmfClientAuthID
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: SmfClientPrivate Class Reference

SmfClientPrivate Class Reference

#include <smfclient_p.h>

Inherits smfObserver.

List of all members.

Public Member Functions

SmfClientPrivate (SmfClient *client=0)
~SmfClientPrivate ()
QList< SmfProvider > * | GetServices (const QString serviceName)
void | resultsAvailable (QByteArray result, SmfRequestTypeID opcode, SmfError error)

Friends

class | SmfClientQt

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Private Qt wrapper Private Qt wrapper Provided to accomodate diff facilities in diff platforms. Uses Symbian client-server for Symbian QDbus for linux QLocalserver for rest of the platforms Note:- only symbian client-server impl is provided at the moment

Constructor & Destructor Documentation

SmfClientPrivate::SmfClientPrivate ( SmfClient * client = 0 )

Constructs SmfClientPrivate

Parameters:
client SmfClient instance, so that it can directly emit SmfClient's signal

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Private Qt wrapper

SmfClientPrivate::~SmfClientPrivate ( ) [inline]

Destructor

Member Function Documentation

QList< SmfProvider > * SmfClientPrivate::GetServices ( const QString serviceName )

Corresponds to SmfClient::GetServices(const QString )

void SmfClientPrivate::resultsAvailable | ( | QByteArray | result,
 |  | SmfRequestTypeID | opcode,
 |  | SmfError | error |
 | ) |  |  | [virtual]

From smfobserver. This callback is invoked when requested result is available from other components of Smf (specially from plugin manager).

Parameters:
result | Parsed and serialized result.
opcode | Request code.
error | Error

Implements smfObserver.

The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfclient_p.h
  • smf/smfservermodule/smfclient/smfclient_p.cpp
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: Member List

SmfClientPrivate Member List

This is the complete list of members for SmfClientPrivate, including all inherited members.
GetServices(const QString serviceName) | SmfClientPrivate |
resultsAvailable(QByteArray result, SmfRequestTypeID opcode, SmfError error) | SmfClientPrivate | [virtual]
SmfClientPrivate(SmfClient *client=0) | SmfClientPrivate |
SmfClientQt (defined in SmfClientPrivate) | SmfClientPrivate | [friend]
~SmfClientPrivate() | SmfClientPrivate | [inline]
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: SmfClientQt Class Reference

SmfClientQt Class Reference

#include <smfclientqt.h>

List of all members.

Public Member Functions

SmfClientQt (QObject *parent=0)
int | sendRequest (QByteArray &aSerializedData, QString aInterfaceName, SmfRequestTypeID requestType)
QByteArray | sendRequest (QString aInterfaceName, SmfRequestTypeID requestType)
int | sendDummyRequest (QByteArray *provider, QString aInterfaceName, SmfRequestTypeID requestType)
void | CancelRequest ()

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Constructor & Destructor Documentation

SmfClientQt::SmfClientQt ( QObject * parent = 0 ) [explicit]

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Member Function Documentation

void SmfClientQt::CancelRequest ( )

CancelRequest. Cancels an outstanding request.

int SmfClientQt::sendDummyRequest | ( | QByteArray * | provider,
 |  | QString | aInterfaceName,
 |  | SmfRequestTypeID | requestType
 | ) |  |

For testing purpose only

QByteArray SmfClientQt::sendRequest | ( | QString | interfaceName,
 |  | SmfRequestTypeID | requestType
 | ) |  |

This overloaded API is for ESmfGetServices, where data should be fetched synchronously

int SmfClientQt::sendRequest | ( | QByteArray & | serializedData,
 |  | QString | interfaceName,
 |  | SmfRequestTypeID | requestType
 | ) |  |

Send a request to the server.

Parameters:
aSerializedData | serialized by the caller.
aInterfaceName | Interface name
requestType | Opcode
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfclientqt.h
  • smf/smfservermodule/smfclient/smfclientqt.cpp
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: Member List

SmfClientQt Member List

This is the complete list of members for SmfClientQt, including all inherited members.
CancelRequest() | SmfClientQt |
sendDummyRequest(QByteArray *provider, QString aInterfaceName, SmfRequestTypeID requestType) | SmfClientQt |
sendRequest(QByteArray &aSerializedData, QString aInterfaceName, SmfRequestTypeID requestType) | SmfClientQt |
sendRequest(QString aInterfaceName, SmfRequestTypeID requestType) | SmfClientQt |
SmfClientQt(QObject *parent=0) | SmfClientQt | [explicit]
~SmfClientQt() (defined in SmfClientQt) | SmfClientQt |
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: SmfComment Class Reference

SmfComment Class Reference
[Common Data Classes]

#include <smfcomment.h>

List of all members.

Public Member Functions

SmfComment ()
SmfComment (const SmfComment &aOther)
SmfComment & | operator= (const SmfComment &aOther)
~SmfComment ()
QString | text () const
QDateTime | timeStamp () const
QString | id () const
void | setText (const QString &aText)
void | setTimeStamp (const QDateTime &aDateTime)
void | setId (const QString &aId)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfComment &aComment)
QDataStream & | operator>> (QDataStream &aDataStream, SmfComment &aComment)

Detailed Description

The comment class represents a comment (on a picture or a music track etc)

Constructor & Destructor Documentation

SmfComment::SmfComment ( )

Constructor with default argument

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The comment class represents a comment (on a picture or a music track etc) Constructor with default argument

SmfComment::SmfComment ( const SmfComment & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfComment::~SmfComment ( )

Destructor

Member Function Documentation

QString SmfComment::id ( ) const

Method to get the id of the comment

Returns:
The ID value
SmfComment & SmfComment::operator= ( const SmfComment & aOther )

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The current object reference
void SmfComment::setId ( const QString & aId )

Method to set the id of the comment

Parameters:
aId The ID value to be set
void SmfComment::setText ( const QString & aText )

Method to set the comment text

Parameters:
aText The comment text to be set
void SmfComment::setTimeStamp ( const QDateTime & aDateTime )

Method to set the time stamp

Parameters:
aDateTime The comment time stamp value to be set
QString SmfComment::text ( ) const

Method to get the comment text

Returns:
The comment text
QDateTime SmfComment::timeStamp ( ) const

Method to get the comment time stamp

Returns:
The comment time stamp value

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfComment & | aComment |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfComment object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aComment | The SmfComment object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfComment & | aComment |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfComment object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aComment | The SmfComment object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfcomment.h
  • smf/smfservermodule/smfcommon/smfcomment.cpp
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: Member List

SmfComment Member List

This is the complete list of members for SmfComment, including all inherited members.
id() const | SmfComment |
operator<<(QDataStream &aDataStream, const SmfComment &aComment) | SmfComment | [friend]
operator=(const SmfComment &aOther) | SmfComment |
operator>>(QDataStream &aDataStream, SmfComment &aComment) | SmfComment | [friend]
setId(const QString &aId) | SmfComment |
setText(const QString &aText) | SmfComment |
setTimeStamp(const QDateTime &aDateTime) | SmfComment |
SmfComment() | SmfComment |
SmfComment(const SmfComment &aOther) | SmfComment |
text() const | SmfComment |
timeStamp() const | SmfComment |
~SmfComment() | SmfComment |
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: SmfCommentPrivate Class Reference

SmfCommentPrivate Class Reference

#include <smfcomment_p.h>

List of all members.

Public Member Functions

SmfCommentPrivate ()
SmfCommentPrivate (const SmfCommentPrivate &aOther)
~SmfCommentPrivate ()

Public Attributes

QString | m_text
QDateTime | m_timeStamp
QString | m_commentId

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfComment class

Constructor & Destructor Documentation

SmfCommentPrivate::SmfCommentPrivate ( ) [inline]

Constructor

SmfCommentPrivate::SmfCommentPrivate ( const SmfCommentPrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfCommentPrivate::~SmfCommentPrivate ( ) [inline]

Destructor

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfcomment_p.h
Generated on Thu Sep 23 15:03:33 2010 for smf by doxygen 1.6.3


smf: Member List

SmfCommentPrivate Member List

This is the complete list of members for SmfCommentPrivate, including all inherited members.
m_commentId (defined in SmfCommentPrivate) | SmfCommentPrivate |
m_text (defined in SmfCommentPrivate) | SmfCommentPrivate |
m_timeStamp (defined in SmfCommentPrivate) | SmfCommentPrivate |
SmfCommentPrivate() | SmfCommentPrivate | [inline]
SmfCommentPrivate(const SmfCommentPrivate &aOther) | SmfCommentPrivate | [inline]
~SmfCommentPrivate() | SmfCommentPrivate | [inline]
Generated on Thu Sep 23 15:03:34 2010 for smf by doxygen 1.6.3


smf: SmfContact Class Reference

SmfContact Class Reference
[Common Data Classes]

#include <smfcontact.h>

Inherited by SmfRelationItem.

List of all members.

Public Slots

QStringList | subTypes () const
void | convert (QContact &aContact) const
QVariant | value (const QString &aSubType) const
void | setValue (const QString &aSubType, QVariant &value)

Public Member Functions

SmfContact (QObject *aParent=0)
SmfContact (const SmfContact &aOther)
SmfContact & | operator= (const SmfContact &aOther)
~SmfContact ()

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfContact &aContact)
QDataStream & | operator>> (QDataStream &aDataStream, SmfContact &aContact)

Detailed Description

The contact class represents a social contact

Note: This class has dependencies on QtMobility project

Constructor & Destructor Documentation

SmfContact::SmfContact ( QObject * aParent = 0 )

Constructor with default argument

Parameters:
aParent The parent object

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The contact class represents a social contact Note: This class has dependencies on QtMobility project Constructor with default argument

Parameters:
aParent The parent object
SmfContact::SmfContact ( const SmfContact & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfContact::~SmfContact ( )

Destructor

Member Function Documentation

void SmfContact::convert ( QContact & aContact ) const [slot]

Method to convert an SmfContact to a QContact Changes made to the returned QContact will not be reflected in its parent SmfContact object

Parameters:
aContact QContact corresponding to SmfContact
SmfContact & SmfContact::operator= ( const SmfContact & aOther )

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
void SmfContact::setValue | ( | const QString & | aSubType,
 |  | QVariant & | value |
 | ) |  |  | [slot]

Method to set value for a subtype

Parameters:
aSubType | The subtype string
value | Thhe value to be set for the subtype
QStringList SmfContact::subTypes ( ) const [slot]

Method to get the available sub fields for contacts. The following are the available sub types of a contact QtMobility::QContactAddress Address; QtMobility::QContactAnniversary Anniversary; QtMobility::QContactAvatar Avatar; QtMobility::QContactBirthday Birthday; QtMobility::QContactId ContactId; QtMobility::QContactEmailAddress EmailAddress; QtMobility::QContactGender Gender; QtMobility::QContactGeoLocation Geolocation; QtMobility::QContactGuid Guid; QtMobility::QContactName Name; QtMobility::QContactNickname Nickname; QtMobility::QContactNote Note; QtMobility::QContactOnlineAccount OnlineAccount; QtMobility::QContactOrganization Organization; QtMobility::QContactPhoneNumber PhoneNumber; QtMobility::QContactPresence Presence; QtMobility::QContactThumbnail Thumbnail; QtMobility::QContactTimestamp Timestamp; QtMobility::QContactType Type; QtMobility::QContactUrl Url;

Returns:
The Available sub fields for this contact
QVariant SmfContact::value ( const QString & aSubType ) const [slot]

Method to get the value of a sub field for this contact

Parameters:
aSubType The sub field type
Returns:
The value of the sub field subType
See also:
subTypes()

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfContact & | aContact |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfContact object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aContact | The SmfContact object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfContact & | aContact |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfContact object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aContact | The SmfContact object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfcontact.h
  • smf/smfservermodule/smfcommon/smfcontact.cpp
Generated on Thu Sep 23 15:03:34 2010 for smf by doxygen 1.6.3


smf: Member List

SmfContact Member List

This is the complete list of members for SmfContact, including all inherited members.
convert(QContact &aContact) const | SmfContact | [slot]
operator<<(QDataStream &aDataStream, const SmfContact &aContact) | SmfContact | [friend]
operator=(const SmfContact &aOther) | SmfContact |
operator>>(QDataStream &aDataStream, SmfContact &aContact) | SmfContact | [friend]
setValue(const QString &aSubType, QVariant &value) | SmfContact | [slot]
SmfContact(QObject *aParent=0) | SmfContact |
SmfContact(const SmfContact &aOther) | SmfContact |
subTypes() const | SmfContact | [slot]
value(const QString &aSubType) const | SmfContact | [slot]
~SmfContact() | SmfContact |
Generated on Thu Sep 23 15:03:34 2010 for smf by doxygen 1.6.3


smf: SmfContactFetcher Class Reference

SmfContactFetcher Class Reference
[Client Classes]

#include <smfcontactfetcher.h>

List of all members.

Signals

void | friendsListAvailable (SmfContactList *list, SmfError error, SmfResultPage resultPage)
void | followersListAvailable (SmfContactList *list, SmfError error, SmfResultPage resultPage)
void | searchContactFinished (SmfContactList *list, SmfError error, SmfResultPage resultPage)
void | searchNearFinished (SmfContactList *list, SmfError error, SmfResultPage resultPage)
void | groupListAvailable (SmfGroupList *list, SmfError error, SmfResultPage resultPage)
void | searchInGroupFinished (SmfContactList *list, SmfError error, SmfResultPage resultPage)
void | customDataAvailable (int operationId, QByteArray *customData)

Public Member Functions

SmfContactFetcher (SmfProvider *baseProvider)
SmfContactFetcher (SmfProvider *baseProvider, SmfContact *contact)
~SmfContactFetcher ()
SmfError | friends (int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | followers (int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | search (SmfContact *contact, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | searchNear (SmfLocation *location, SmfLocationSearchBoundary proximity, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | groups (int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | searchInGroup (SmfGroup group, SmfContact *contact=NULL, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()

Friends

class | SmfContactFetcherPrivate

Detailed Description

Interface to search for contacts/connections from a service provider. This class provides basic functionality to allow applications to obtain list of contacts or friends in a social networking service. Note that to get the base provider info like service name, icon, description etc use getProvider(). See also: SmfProvider::serviceName(), SmfProvider::serviceIcon(), SmfProvider::description()

All of the functionality described here should be implemented by a service specific plug-in object. Interface name:- org.symbian.smf.client.contact.fetcher

Constructor & Destructor Documentation

SmfContactFetcher::SmfContactFetcher ( SmfProvider * baseProvider )

Constructs the SmfContactFetcher.

Parameters:
parent base provider info Seeing as this is a plug-in implementation, these will realistically be generated by SMF factory of some kind

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The SmfContactFetcher class is for fetching SmfContact related info

SmfContactFetcher::SmfContactFetcher | ( | SmfProvider * | baseProvider,
 |  | SmfContact * | contact
 | ) |  |

Constructs the SmfContactFetcher.

Parameters:
parent | base provider info
contact | Used for searching friends of the given contact Seeing as this is a plug-in implementation, these will realistically be generated by SMF factory of some kind
SmfContactFetcher::~SmfContactFetcher ( )

Destructor

:- Request to unload the plugin

Member Function Documentation

SmfError SmfContactFetcher::cancelRequest ( )

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
void SmfContactFetcher::customDataAvailable | ( | int | operationId,
 |  | QByteArray * | customData |
 | ) |  |  | [signal]

Emitted when custom data is available

Parameters:
operationId | Requested operation id
customData | Custom data received, interpretation is not the responsibility of Smf. Ownership of memory is transferred.
SmfError SmfContactFetcher::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData
 | ) |  |

Request for a custom operation. The signal customDataAvailable() is emitted when the result is available.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfError. SmfNoError if success, else appropriate error code Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
SmfError SmfContactFetcher::followers | ( | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Get the list of followers asynchronously. The followersListAvailable() signal is emitted with SmfContactList once data is arrived. Please note that some service may not support followers/fans - FALSE is returned if not supported. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
void SmfContactFetcher::followersListAvailable | ( | SmfContactList * | list,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

This signal is emitted when a request to get followers is completed Note if number of followers is large, then it can download the list page by page. In that case this signal is emitted multiple times.

Parameters:
list | list of followers. Ownership of memory is transferred.
error | error value
resultPage | Page number info
See also:
followers()
SmfError SmfContactFetcher::friends | ( | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Get the friend listing asynchronously. The friendsListAvailable() signal is emitted with SmfContactList once data is arrived. When the list is big, user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
void SmfContactFetcher::friendsListAvailable | ( | SmfContactList * | list,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

This signal is emitted when a request to get friends is completed. Note if number of friends is large, then it can download the list page by page. In that case this signal is emitted multiple times.

Parameters:
list | list of friends. Ownership of memory is transferred.
error | error value
resultPage | Page number info
See also:
friends()
void SmfContactFetcher::groupListAvailable | ( | SmfGroupList * | list,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

This signal is emitted when a request to get groups is completed Note if number of groups is large, then it can download the list page by page. In that case this signal is emitted multiple times.

Parameters:
list | list of groups. Ownership of memory is transferred.
error | error value
resultPage | Page number info
See also:
groups()
SmfError SmfContactFetcher::groups | ( | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Get the list of groups. The groupListAvailable() signal is emitted with SmfGroupList once data is arrived. False might be returned if this service doesn't support any mode of grouping (very rare). When the list is big, user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfContactFetcher::search | ( | SmfContact * | contact,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for a contact The searchContactFinished() signal is emitted with SmfContactList once data is arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
contact | The contact to be searched. The serach criteria must be set as one of its fields.
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
void SmfContactFetcher::searchContactFinished | ( | SmfContactList * | list,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

This signal is emitted when search for a contact is finished. Note if number of contacts in the search is large, then it can download the list page by page. In that case this signal is emitted multiple times.

Parameters:
list | List of filtered contacts. Ownership of memory is transferred.
resultPage | Page number info
See also:
search()
SmfError SmfContactFetcher::searchInGroup | ( | SmfGroup | group,
 |  | SmfContact * | contact = NULL,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for Smf Contacts in an Smf group. The signal searchInGroupFinished() is emitted with SmfContactList once data is arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
group | The group to be searched in The contact to be searched, default (NULL) is the self contact.
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
void SmfContactFetcher::searchInGroupFinished | ( | SmfContactList * | list,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Emitted when search for a contact in a group is finished Note if number of contacts in the search is large, then it can download the list page by page In that case this signal is emitted multiple times.

Parameters:
list | list of filtered contacts. Ownership of memory is transferred.
resultPage | Page number info
See also:
searchInGroup()
SmfError SmfContactFetcher::searchNear | ( | SmfLocation * | location,
 |  | SmfLocationSearchBoundary | proximity,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for a contacts (friends) who are near the user. The signal searchNearFinished() is emitted with SmfContactList once data is arrived. Proximity defines accuracy level. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
location | The location information
proximity | The search boundary criteria
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
void SmfContactFetcher::searchNearFinished | ( | SmfContactList * | list,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Emitted when search for contacts who are near a geographic location, is finished. Note if number of contacts in the search is large, then it can download the list page by page In that case this signal is emitted multiple times.

Parameters:
list | List of filtered contacts. Ownership of memory is transferred.
resultPage | Page number info
See also:
search()
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfcontactfetcher.h
  • smf/smfservermodule/smfclient/smfcontactfetcher.cpp
Generated on Thu Sep 23 15:03:34 2010 for smf by doxygen 1.6.3


smf: Member List

SmfContactFetcher Member List

This is the complete list of members for SmfContactFetcher, including all inherited members.
cancelRequest() | SmfContactFetcher |
customDataAvailable(int operationId, QByteArray *customData) | SmfContactFetcher | [signal]
customRequest(const int &operationId, QByteArray *customData) | SmfContactFetcher |
followers(int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfContactFetcher |
followersListAvailable(SmfContactList *list, SmfError error, SmfResultPage resultPage) | SmfContactFetcher | [signal]
friends(int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfContactFetcher |
friendsListAvailable(SmfContactList *list, SmfError error, SmfResultPage resultPage) | SmfContactFetcher | [signal]
groupListAvailable(SmfGroupList *list, SmfError error, SmfResultPage resultPage) | SmfContactFetcher | [signal]
groups(int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfContactFetcher |
search(SmfContact *contact, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfContactFetcher |
searchContactFinished(SmfContactList *list, SmfError error, SmfResultPage resultPage) | SmfContactFetcher | [signal]
searchInGroup(SmfGroup group, SmfContact *contact=NULL, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfContactFetcher |
searchInGroupFinished(SmfContactList *list, SmfError error, SmfResultPage resultPage) | SmfContactFetcher | [signal]
searchNear(SmfLocation *location, SmfLocationSearchBoundary proximity, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfContactFetcher |
searchNearFinished(SmfContactList *list, SmfError error, SmfResultPage resultPage) | SmfContactFetcher | [signal]
SmfContactFetcher(SmfProvider *baseProvider) | SmfContactFetcher |
SmfContactFetcher(SmfProvider *baseProvider, SmfContact *contact) | SmfContactFetcher |
SmfContactFetcherPrivate (defined in SmfContactFetcher) | SmfContactFetcher | [friend]
~SmfContactFetcher() | SmfContactFetcher |
Generated on Thu Sep 23 15:03:34 2010 for smf by doxygen 1.6.3


smf: SmfContactFetcherPlugin Class Reference

SmfContactFetcherPlugin Class Reference
[Plugin Classes]

#include <smfcontactfetcherplugin.h>

Inherits SmfPluginBase.

Inherited by FBContactFetcherPlugin, and FlickrContactFetcherPlugin.

List of all members.

Public Member Functions

virtual | ~SmfContactFetcherPlugin ()
virtual SmfPluginError | friends (SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | followers (SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | search (SmfPluginRequestData &aRequest, const SmfContact &aContact, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | searchNear (SmfPluginRequestData &aRequest, const SmfLocation &aLocation, const SmfLocationSearchBoundary &aProximity, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | groups (SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | searchInGroup (SmfPluginRequestData &aRequest, const SmfGroup &aGroup, SmfContact *aContact=NULL, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Interface specification for fetching contacts

Interface specification for fetching contacts. This class provides basic functionality to allow applications to obtain list of friends, followers, groups of a user in a social networking service.

All of the functionality described here should be implemented by a service specific plug-in.

Constructor & Destructor Documentation

virtual SmfContactFetcherPlugin::~SmfContactFetcherPlugin ( ) [inline, virtual]

Destructor

Member Function Documentation

virtual SmfPluginError SmfContactFetcherPlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [pure virtual]

Customised method for SmfContactFetcherPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | [in] The operation type (should be known between the client interface and the plugin)
aData | [in] The data required to form the request (The type of data should be known between client and the plugin)
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBContactFetcherPlugin, and FlickrContactFetcherPlugin.

virtual SmfPluginError SmfContactFetcherPlugin::followers | ( | SmfPluginRequestData & | aRequest,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get the list of followers

Parameters:
aRequest | [out] The request data to be sent to network
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBContactFetcherPlugin, and FlickrContactFetcherPlugin.

virtual SmfPluginError SmfContactFetcherPlugin::friends | ( | SmfPluginRequestData & | aRequest,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get the list of friends

Parameters:
aRequest | [out] The request data to be sent to network
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBContactFetcherPlugin, and FlickrContactFetcherPlugin.

virtual SmfPluginError SmfContactFetcherPlugin::groups | ( | SmfPluginRequestData & | aRequest,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get the list of groups

Parameters:
aRequest | [out] The request data to be sent to network
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBContactFetcherPlugin, and FlickrContactFetcherPlugin.

virtual SmfPluginError SmfContactFetcherPlugin::search | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfContact & | aContact,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to search for a contact (name or service ID should be provided)

Parameters:
aRequest | [out] The request data to be sent to network
aContact | [in] contact to be searched
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBContactFetcherPlugin, and FlickrContactFetcherPlugin.

virtual SmfPluginError SmfContactFetcherPlugin::searchInGroup | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfGroup & | aGroup,
 |  | SmfContact * | aContact = NULL,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to search for a contact in a group

Parameters:
aRequest | [out] The request data to be sent to network
aGroup | [in] the group in which to search
aContact | [in] The contact to be searched, default (NULL) is the self contact.
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBContactFetcherPlugin, and FlickrContactFetcherPlugin.

virtual SmfPluginError SmfContactFetcherPlugin::searchNear | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfLocation & | aLocation,
 |  | const SmfLocationSearchBoundary & | aProximity,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to search for contacts (friends) who are near the user. Proximity defines accuracy level

Parameters:
aRequest | [out] The request data to be sent to network
aLocation | [in] The location search criteria
aProximity | [in] location search boundary
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBContactFetcherPlugin, and FlickrContactFetcherPlugin.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfserver/smfplugins/smfcontactfetcherplugin.h
Generated on Thu Sep 23 15:03:34 2010 for smf by doxygen 1.6.3


smf: Member List

SmfContactFetcherPlugin Member List

This is the complete list of members for SmfContactFetcherPlugin, including all inherited members.
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0 | SmfContactFetcherPlugin | [pure virtual]
followers(SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfContactFetcherPlugin | [pure virtual]
friends(SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfContactFetcherPlugin | [pure virtual]
getProviderInfo()=0 | SmfPluginBase | [pure virtual]
groups(SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfContactFetcherPlugin | [pure virtual]
initialize()=0 | SmfPluginBase | [pure virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aReply, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)=0 | SmfPluginBase | [pure virtual]
search(SmfPluginRequestData &aRequest, const SmfContact &aContact, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfContactFetcherPlugin | [pure virtual]
searchInGroup(SmfPluginRequestData &aRequest, const SmfGroup &aGroup, SmfContact *aContact=NULL, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfContactFetcherPlugin | [pure virtual]
searchNear(SmfPluginRequestData &aRequest, const SmfLocation &aLocation, const SmfLocationSearchBoundary &aProximity, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfContactFetcherPlugin | [pure virtual]
~SmfContactFetcherPlugin() | SmfContactFetcherPlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:34 2010 for smf by doxygen 1.6.3


smf: SmfContactFetcherPrivate Class Reference

SmfContactFetcherPrivate Class Reference

#include <smfcontactfetcher_p.h>

Inherits smfObserver.

List of all members.

Public Member Functions

SmfContactFetcherPrivate (SmfContactFetcher *contactFetcher=0)
~SmfContactFetcherPrivate ()
SmfError | friends (int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | followers (int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | search (SmfContact *contact, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | searchNear (SmfLocation *location, SmfLocationSearchBoundary proximity, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | groups (int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | searchInGroup (SmfGroup group, SmfContact *contact=NULL, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()
void | resultsAvailable (QByteArray result, SmfRequestTypeID opcode, SmfError error)

Friends

class | SmfClientQt

Detailed Description

Private Qt wrapper Provided to accomodate diff facilities in diff platforms. Uses Symbian client-server for Symbian QDbus for linux QLocalserver for rest of the platforms Note:- only symbian client-server impl is provided at the moment

Constructor & Destructor Documentation

SmfContactFetcherPrivate::SmfContactFetcherPrivate ( SmfContactFetcher * contactFetcher = 0 )

Constructor

Parameters:
contactFetcher The SmfContactFetcher instance

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private Qt wrapper for SmfContactFetcher Constructor

Parameters:
contactFetcher The SmfContactFetcher instance
SmfContactFetcherPrivate::~SmfContactFetcherPrivate ( )

Destructor

Member Function Documentation

SmfError SmfContactFetcherPrivate::cancelRequest ( )

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
SmfError SmfContactFetcherPrivate::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData
 | ) |  |

Request for a custom operation. The signal customDataAvailable() is emitted when the result is available.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfError. SmfNoError if success, else appropriate error code Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
SmfError SmfContactFetcherPrivate::followers | ( | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Get the list of followers asynchronously. The followersListAvailable() signal is emitted with SmfContactList once data is arrived. Please note that some service may not support followers/fans - FALSE is returned if not supported. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfContactFetcherPrivate::friends | ( | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Get the friend listing asynchronously. The friendsListAvailable() signal is emitted with SmfContactList once data is arrived. When the list is big, user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfContactFetcherPrivate::groups | ( | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Get the list of groups. The groupListAvailable() signal is emitted with SmfGroupList once data is arrived. False might be returned if this service doesn't support any mode of grouping (very rare). When the list is big, user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
void SmfContactFetcherPrivate::resultsAvailable | ( | QByteArray | result,
 |  | SmfRequestTypeID | opcode,
 |  | SmfError | error |
 | ) |  |  | [virtual]

To notify availibility of asynchronous requests.

Parameters:
result | Requested result, before using must check error param.
opcode | Requested opcode, for which the result has arrived.
error | Error

:-After consulting with PM owner decide page serialization

:-After consulting with PM owner decide page serialization

:-After consulting with PM owner decide page serialization

Implements smfObserver.

SmfError SmfContactFetcherPrivate::search | ( | SmfContact * | contact,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for a contact The searchContactFinished() signal is emitted with SmfContactList once data is arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
contact | The contact to be searched. The serach criteria must be set as one of its fields.
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfContactFetcherPrivate::searchInGroup | ( | SmfGroup | group,
 |  | SmfContact * | contact = NULL,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for Smf Contacts in an Smf group. The signal searchInGroupFinished() is emitted with SmfContactList once data is arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
group | The group to be searched in The contact to be searched, default (NULL) is the self contact.
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfContactFetcherPrivate::searchNear | ( | SmfLocation * | location,
 |  | SmfLocationSearchBoundary | proximity,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for a contacts (friends) who are near the user. The signal searchNearFinished() is emitted with SmfContactList once data is arrived. Proximity defines accuracy level. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
location | The location information
proximity | The search boundary criteria
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfcontactfetcher_p.h
  • smf/smfservermodule/smfclient/smfcontactfetcher_p.cpp
Generated on Thu Sep 23 15:03:35 2010 for smf by doxygen 1.6.3


smf: Member List

SmfContactFetcherPrivate Member List

This is the complete list of members for SmfContactFetcherPrivate, including all inherited members.
cancelRequest() | SmfContactFetcherPrivate |
customRequest(const int &operationId, QByteArray *customData) | SmfContactFetcherPrivate |
followers(int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfContactFetcherPrivate |
friends(int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfContactFetcherPrivate |
groups(int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfContactFetcherPrivate |
resultsAvailable(QByteArray result, SmfRequestTypeID opcode, SmfError error) | SmfContactFetcherPrivate | [virtual]
search(SmfContact *contact, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfContactFetcherPrivate |
searchInGroup(SmfGroup group, SmfContact *contact=NULL, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfContactFetcherPrivate |
searchNear(SmfLocation *location, SmfLocationSearchBoundary proximity, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfContactFetcherPrivate |
SmfClientQt (defined in SmfContactFetcherPrivate) | SmfContactFetcherPrivate | [friend]
SmfContactFetcherPrivate(SmfContactFetcher *contactFetcher=0) | SmfContactFetcherPrivate |
~SmfContactFetcherPrivate() | SmfContactFetcherPrivate |
Generated on Thu Sep 23 15:03:35 2010 for smf by doxygen 1.6.3


smf: SmfContactPrivate Class Reference

SmfContactPrivate Class Reference

List of all members.

Public Member Functions

SmfContactPrivate ()
SmfContactPrivate (const SmfContactPrivate &aOther)
~SmfContactPrivate ()

Public Attributes

QVariantMap m_details

Constructor & Destructor Documentation

SmfContactPrivate::SmfContactPrivate ( ) [inline]

Constructor

SmfContactPrivate::SmfContactPrivate ( const SmfContactPrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfContactPrivate::~SmfContactPrivate ( ) [inline]

Destructor

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfcontact_p.h
Generated on Thu Sep 23 15:03:35 2010 for smf by doxygen 1.6.3


smf: Member List

SmfContactPrivate Member List

This is the complete list of members for SmfContactPrivate, including all inherited members.
m_details (defined in SmfContactPrivate) | SmfContactPrivate |
SmfContactPrivate() | SmfContactPrivate | [inline]
SmfContactPrivate(const SmfContactPrivate &aOther) | SmfContactPrivate | [inline]
~SmfContactPrivate() | SmfContactPrivate | [inline]
Generated on Thu Sep 23 15:03:35 2010 for smf by doxygen 1.6.3


smf: SmfCredMgrClient Class Reference

SmfCredMgrClient Class Reference
[CredMgr Classes]

#include <smfcredmgrclient.h>

List of all members.

Public Member Functions

SmfCredMgrClient (QObject *parent=0)
~SmfCredMgrClient ()
bool | CheckPluginAuthentication (QString PluginID) const
bool | AuthDataSet (QString RegToken, QDateTime Validity, SmfAuthParams &AuthDataSet) const
QList< QUrl > | URLList (QString PluginID) const
QStringList | AuthenticatedPluginList (QString RegistrationToken) const
QString | GenerateNONCE (const qint64 Length)
void | ChangePluginIDList (QString NewPluginID, bool Flag, QString OldPluginID)
QString | StoreAuthData (SmfAuthParams Set, QDateTime Validity, QList< QUrl > URLList, QStringList PluginList, QString AuthAppId, bool Flag)
QString | StoreRSAKeys (const QString KeyLabel, const QString Keydata, const QDateTime Validity)
SMFCredMgrErrorCode | SignMessage (QString Message, QString Key, QString &Signature, SmfSignatureMethod AlgorithmUsed)
void | DeleteRSAKey (QString KeyLabel)

Detailed Description

Qt wrapper class for for exporting APIs of Credential Manager server

Constructor & Destructor Documentation

SmfCredMgrClient::SmfCredMgrClient ( QObject * Parent = 0 )

Constructor

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Pritam Roy Biswas, Sasken Communication Technologies Ltd - Initial contribution

Description: This is the public implementation Class(Qt wrapper) for symbian client for Credential Manager server

SmfCredMgrClient::~SmfCredMgrClient ( )

Destructor

Member Function Documentation

bool SmfCredMgrClient::AuthDataSet | ( | QString | RegToken,
 |  | QDateTime | Validity,
 |  | SmfAuthParams & | AuthDataSet |
 | ) |  |  | const

API to get the Auth Data set, eg:OAuth_RequestToken; OAuth_AccessToken

Parameters:
RegToken | Registration Token obtained from SMF while storing this Auth Data set
Validity | Time by which the Auth set will expire
AuthDataSet | The Auth Token Set for the plugin, this Api would fill this parameter so the caller of The API must create space for SmfAuthParams
Returns:
boolean Value if the reg token is still valid
QStringList SmfCredMgrClient::AuthenticatedPluginList ( QString RegistrationToken ) const

API to get the list of authenticated plugins

Parameters:
RegistrationToken The token that validates a list of such plugins.
Returns:
The list of authenticated plugins
void SmfCredMgrClient::ChangePluginIDList | ( | QString | NewPluginID,
 |  | bool | Flag,
 |  | QString | OldPluginID
 | ) |  |

API to update the list of authenticated plugins-add, remove, update to plugins

Parameters:
NewPluginID | ID of the new plugin
Flag | flag to enable or disable the plugin
OldPluginID | ID of the old plugin to be replaced
Todo:
  • should return an error code to indicate error while changing the list.
bool SmfCredMgrClient::CheckPluginAuthentication ( QString PluginID ) const

API to check plugin authentication

Parameters:
PluginID The ID of the Plugin to be checked
Returns:
The boolean value-TRUE if authenticated, FALSE if not
void SmfCredMgrClient::DeleteRSAKey ( QString KeyLabel )

API To delete the RSA Key from the Key Store

Parameters:
KeyLabel The Label of key pair. This is the value returned while StoreRSAKeys().
QString SmfCredMgrClient::GenerateNONCE ( const qint64 Length )

API to generate NONCE token

Parameters:
Length Lenth of the NONCE tobe generated
Returns:
The generated NONCE. This is never zero, the minimum length is 12.
SMFCredMgrErrorCode SmfCredMgrClient::SignMessage | ( | QString | Message,
 |  | QString | Key,
 |  | QString & | Signature,
 |  | SmfSignatureMethod | AlgorithmUsed
 | ) |  |

API to Sign the message

Parameters:
Message | The message to be signed
Key | If Signature method is RSA-SHA1 then it must be equal to the value returned while storeRSAKeys(), if signature method is HMAC-SHA1 key must the value to sign the message with
Signature | The signed message is an output argument
AlgorithmUsed | The algorithm used for signing return Smf defined errorcode
Todo:
  • RSA Signing is falgged-put for time being.
QString SmfCredMgrClient::StoreAuthData | ( | SmfAuthParams | Set,
 |  | QDateTime | Validity,
 |  | QList< QUrl > | URLList,
 |  | QStringList | PluginList,
 |  | QString | AuthAppId,
 |  | bool | Flag
 | ) |  |

API to store all data related to an auth app i.e URL list for Plugins, List of Plugins.etc.

Parameters:
Set | The auth Key set
Validity | time by which the Auth set will expire
URLList | The URL list to be set
PluginList | The plugin list to be set
AuthAppId | The Authentication Application Id
Flag | flag to enable or disable the plugins
Returns:
The registration token that completes authentication, its a NULL string if the API fails due to any wrong argument
QString SmfCredMgrClient::StoreRSAKeys | ( | const QString | KeyLabel,
 |  | const QString | Keydata,
 |  | const QDateTime | Validity
 | ) |  |

API to store RSA Keys

Parameters:
KeyLabel | First key of the key pair
Keydata | Other key of the key pair
Validity | time by which the key set will expire
Returns:
The Label of key pair
QList< QUrl > SmfCredMgrClient::URLList ( QString PluginID ) const

API to get list of URLs which plugin can access

Parameters:
PluginID The ID of the Plugin whose corresponding list of URLs to be retrieved
Returns:
The URL list
The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclient.h
  • smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclient.cpp
Generated on Thu Sep 23 15:03:35 2010 for smf by doxygen 1.6.3


smf: Member List

SmfCredMgrClient Member List

This is the complete list of members for SmfCredMgrClient, including all inherited members.
AuthDataSet(QString RegToken, QDateTime Validity, SmfAuthParams &AuthDataSet) const | SmfCredMgrClient
AuthenticatedPluginList(QString RegistrationToken) const | SmfCredMgrClient
ChangePluginIDList(QString NewPluginID, bool Flag, QString OldPluginID) | SmfCredMgrClient
CheckPluginAuthentication(QString PluginID) const | SmfCredMgrClient
DeleteRSAKey(QString KeyLabel) | SmfCredMgrClient
GenerateNONCE(const qint64 Length) | SmfCredMgrClient
SignMessage(QString Message, QString Key, QString &Signature, SmfSignatureMethod AlgorithmUsed) | SmfCredMgrClient
SmfCredMgrClient(QObject *parent=0) | SmfCredMgrClient
StoreAuthData(SmfAuthParams Set, QDateTime Validity, QList< QUrl > URLList, QStringList PluginList, QString AuthAppId, bool Flag) | SmfCredMgrClient
StoreRSAKeys(const QString KeyLabel, const QString Keydata, const QDateTime Validity) | SmfCredMgrClient
URLList(QString PluginID) const | SmfCredMgrClient
~SmfCredMgrClient() | SmfCredMgrClient
Generated on Thu Sep 23 15:03:35 2010 for smf by doxygen 1.6.3


smf: SmfEvent Class Reference

SmfEvent Class Reference
[Common Data Classes]

#include <smfevent.h>

List of all members.

Public Member Functions

SmfEvent ()
SmfEvent (const SmfEvent &aOther)
SmfEvent & | operator= (const SmfEvent &aOther)
~SmfEvent ()
QString | title () const
QDateTime | eventDateTime () const
QTime | duration () const
SmfArtists | artists () const
SmfLocation | venue () const
QUrl | ticketUrl () const
QString | id () const
void | setTitle (const QString &aName)
void | setEventDateTime (const QDateTime &aDateTime)
void | setDuration (const QTime &aDuration)
void | setArtists (const SmfArtists &aArtists)
void | setVenue (const SmfLocation &aVenue)
void | setTicketUrl (const QUrl &aUrl)
void | setId (const QString &aId)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfEvent &aEvent)
QDataStream & | operator>> (QDataStream &aDataStream, SmfEvent &aEvent)

Detailed Description

The event class represents an event

Constructor & Destructor Documentation

SmfEvent::SmfEvent ( )

Constructor with default argument

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The SmfEvent class represents an event Constructor with default argument

SmfEvent::SmfEvent ( const SmfEvent & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfEvent::~SmfEvent ( )

Destructor

Member Function Documentation

SmfArtists SmfEvent::artists ( ) const

Method to get the artist names

Returns:
The list of artists in the event
QTime SmfEvent::duration ( ) const

Method to get the event duration

Returns:
The duration of the event
QDateTime SmfEvent::eventDateTime ( ) const

Method to get the event date and time

Returns:
The date and time of the event
QString SmfEvent::id ( ) const

Method to get the id of the event

Returns:
The ID value
SmfEvent & SmfEvent::operator= ( const SmfEvent & aOther )

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The current object reference

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
void SmfEvent::setArtists ( const SmfArtists & aArtists )

Method to set the artist

Parameters:
aArtists The new artists in the event
void SmfEvent::setDuration ( const QTime & aDuration )

Method to set the event duration

Parameters:
aDuration The new duration of the event
void SmfEvent::setEventDateTime ( const QDateTime & aDateTime )

Method to set the event date and time

Parameters:
aDateTime The new date and time of the event
void SmfEvent::setId ( const QString & aId )

Method to set the id of the event

Parameters:
aId The ID value
void SmfEvent::setTicketUrl ( const QUrl & aUrl )

Method to set the URL for getting tickets for the event

Parameters:
aUrl The new Url for getting ticket for the event
void SmfEvent::setTitle ( const QString & aName )

Method to set the event name

Parameters:
aName The new event name
void SmfEvent::setVenue ( const SmfLocation & aVenue )

Method to set the venue name

Parameters:
aVenue The new venue of the event
QUrl SmfEvent::ticketUrl ( ) const

Method to get the URL for getting tickets for the event

Returns:
The Url for getting ticket for the event
QString SmfEvent::title ( ) const

Method to get the event name

Returns:
The event name
SmfLocation SmfEvent::venue ( ) const

Method to get the venue of the event

Returns:
The venue of the event

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfEvent & | aEvent |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfEvent object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aEvent | The SmfEvent object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfEvent & | aEvent |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfEvent object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aEvent | The SmfEvent object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfevent.h
  • smf/smfservermodule/smfcommon/smfevent.cpp
Generated on Thu Sep 23 15:03:35 2010 for smf by doxygen 1.6.3


smf: Member List

SmfEvent Member List

This is the complete list of members for SmfEvent, including all inherited members.
artists() const | SmfEvent |
duration() const | SmfEvent |
eventDateTime() const | SmfEvent |
id() const | SmfEvent |
operator<<(QDataStream &aDataStream, const SmfEvent &aEvent) | SmfEvent | [friend]
operator=(const SmfEvent &aOther) | SmfEvent |
operator>>(QDataStream &aDataStream, SmfEvent &aEvent) | SmfEvent | [friend]
setArtists(const SmfArtists &aArtists) | SmfEvent |
setDuration(const QTime &aDuration) | SmfEvent |
setEventDateTime(const QDateTime &aDateTime) | SmfEvent |
setId(const QString &aId) | SmfEvent |
setTicketUrl(const QUrl &aUrl) | SmfEvent |
setTitle(const QString &aName) | SmfEvent |
setVenue(const SmfLocation &aVenue) | SmfEvent |
SmfEvent() | SmfEvent |
SmfEvent(const SmfEvent &aOther) | SmfEvent |
ticketUrl() const | SmfEvent |
title() const | SmfEvent |
venue() const | SmfEvent |
~SmfEvent() | SmfEvent |
Generated on Thu Sep 23 15:03:35 2010 for smf by doxygen 1.6.3


smf: SmfEventPrivate Class Reference

SmfEventPrivate Class Reference

#include <smfevent_p.h>

List of all members.

Public Member Functions

SmfEventPrivate ()
SmfEventPrivate (const SmfEventPrivate &aOther)
~SmfEventPrivate ()

Public Attributes

QString | m_name
QDateTime | m_dateTime
QTime | m_duration
SmfArtists | m_artists
SmfLocation | m_venue
QUrl | m_url
QString | m_eventId

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfEvent class

Constructor & Destructor Documentation

SmfEventPrivate::SmfEventPrivate ( ) [inline]

Constructor

SmfEventPrivate::SmfEventPrivate ( const SmfEventPrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfEventPrivate::~SmfEventPrivate ( ) [inline]

Destructor

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfevent_p.h
Generated on Thu Sep 23 15:03:35 2010 for smf by doxygen 1.6.3


smf: Member List

SmfEventPrivate Member List

This is the complete list of members for SmfEventPrivate, including all inherited members.
m_artists (defined in SmfEventPrivate) | SmfEventPrivate |
m_dateTime (defined in SmfEventPrivate) | SmfEventPrivate |
m_duration (defined in SmfEventPrivate) | SmfEventPrivate |
m_eventId (defined in SmfEventPrivate) | SmfEventPrivate |
m_name (defined in SmfEventPrivate) | SmfEventPrivate |
m_url (defined in SmfEventPrivate) | SmfEventPrivate |
m_venue (defined in SmfEventPrivate) | SmfEventPrivate |
SmfEventPrivate() | SmfEventPrivate | [inline]
SmfEventPrivate(const SmfEventPrivate &aOther) | SmfEventPrivate | [inline]
~SmfEventPrivate() | SmfEventPrivate | [inline]
Generated on Thu Sep 23 15:03:35 2010 for smf by doxygen 1.6.3


smf: SmfEventsFetcher Class Reference

SmfEventsFetcher Class Reference
[Client Classes]

#include <smfeventsfetcher.h>

List of all members.

Public Slots

SmfError | postEvents (SmfEventList events)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()

Signals

void | eventsAvailable (SmfEventList *list, SmfError error, SmfResultPage resultPage)
void | venuesAvailable (SmfLocationList *list, SmfError error, SmfResultPage resultPage)
void | attendeesAvailable (SmfContactList *list, SmfError error, SmfResultPage resultPage)
void | eventsUpdated (SmfError success)
void | customDataAvailable (const int &operationId, QByteArray *customData)

Public Member Functions

SmfEventsFetcher (SmfProvider *baseProvider=0)
~SmfEventsFetcher ()
SmfError | events (SmfLocation venue, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | venues (SmfLocation location, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | attendees (SmfEvent event, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)

Friends

class | SmfEventsFetcherPrivate

Detailed Description

provides service ("org.symbian.smf.client.events.fetcher")

Constructor & Destructor Documentation

SmfEventsFetcher::SmfEventsFetcher ( SmfProvider * baseProvider = 0 )

Constructs SmfEventsFetcher with base provider info Seeing as this is a plug-in implementation, these will realistically be generated by SMF factory of some kind

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Nalina Hariharan

Description: Events related services

SmfEventsFetcher::~SmfEventsFetcher ( )

Destructor

Member Function Documentation

SmfError SmfEventsFetcher::attendees | ( | SmfEvent | event,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Gets a list of attendees to the event attendeesAvailable() signal is emitted with SmfContacts for the users attending this event

Parameters:
event
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
void SmfEventsFetcher::attendeesAvailable | ( | SmfContactList * | list,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Notification on arrival of attendees lists Note if number of list is large, then it can download the list page by page.

Parameters:
list | List of attendees
error | SmfNoError if success, else appropriate error value
resultPage | Page number info
SmfError SmfEventsFetcher::cancelRequest ( ) [slot]

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
void SmfEventsFetcher::customDataAvailable | ( | const int & | operationId,
 |  | QByteArray * | customData |
 | ) |  |  | [signal]

Signals availability of the result of the customRequest

Parameters:
operationId | The ID to be shared between clients and the plugin
customData | data
SmfError SmfEventsFetcher::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData |
 | ) |  |  | [slot]

Request for a custom operation. The signal customDataAvailable() is emitted when the result is available.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfNoError if success, else appropriate error value Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
SmfError SmfEventsFetcher::events | ( | SmfLocation | venue,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Gets list of events in a particular venue asynchronously. eventsAvailable() signal is emitted with SmfEventsList once its arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
void SmfEventsFetcher::eventsAvailable | ( | SmfEventList * | list,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Notification on arrival of event lists Note if number of list is large, then it can download the list page by page.

Parameters:
list | List of events
error | SmfNoError if success, else appropriate error value
resultPage | Page number info
void SmfEventsFetcher::eventsUpdated ( SmfError success ) [signal]

Notification of the success of request to post an event

Parameters:
error SmfNoError if success, else appropriate error value
SmfError SmfEventsFetcher::postEvents ( SmfEventList events ) [slot]

Updates events. Might not be supported by all service provider. eventsUpdated() signal can be checked for success value.

Parameters:
SmfEventsList List of events to be posted
Returns:
SmfNoError if success, else appropriate error value
SmfError SmfEventsFetcher::venues | ( | SmfLocation | location,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Gets list of venues of a particular location asynchronously. venuesAvailable() signal is emitted with SmfLocationList once its arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
void SmfEventsFetcher::venuesAvailable | ( | SmfLocationList * | list,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Notification on arrival of venues lists Note if number of list is large, then it can download the list page by page.

Parameters:
list | List of venues
error | SmfNoError if success, else appropriate error value
resultPage | Page number info
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfeventsfetcher.h
  • smf/smfservermodule/smfclient/smfeventsfetcher.cpp
Generated on Thu Sep 23 15:03:35 2010 for smf by doxygen 1.6.3


smf: Member List

SmfEventsFetcher Member List

This is the complete list of members for SmfEventsFetcher, including all inherited members.
attendees(SmfEvent event, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfEventsFetcher |
attendeesAvailable(SmfContactList *list, SmfError error, SmfResultPage resultPage) | SmfEventsFetcher | [signal]
cancelRequest() | SmfEventsFetcher | [slot]
customDataAvailable(const int &operationId, QByteArray *customData) | SmfEventsFetcher | [signal]
customRequest(const int &operationId, QByteArray *customData) | SmfEventsFetcher | [slot]
events(SmfLocation venue, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfEventsFetcher |
eventsAvailable(SmfEventList *list, SmfError error, SmfResultPage resultPage) | SmfEventsFetcher | [signal]
eventsUpdated(SmfError success) | SmfEventsFetcher | [signal]
postEvents(SmfEventList events) | SmfEventsFetcher | [slot]
SmfEventsFetcher(SmfProvider *baseProvider=0) | SmfEventsFetcher |
SmfEventsFetcherPrivate (defined in SmfEventsFetcher) | SmfEventsFetcher | [friend]
venues(SmfLocation location, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfEventsFetcher |
venuesAvailable(SmfLocationList *list, SmfError error, SmfResultPage resultPage) | SmfEventsFetcher | [signal]
~SmfEventsFetcher() | SmfEventsFetcher |
Generated on Thu Sep 23 15:03:35 2010 for smf by doxygen 1.6.3


smf: SmfEventsFetcherPlugin Class Reference

SmfEventsFetcherPlugin Class Reference
[Plugin Classes]

#include <smfeventsfetcherplugin.h>

Inherits SmfPluginBase.

Inherited by MusicEventPlugin.

List of all members.

Public Member Functions

virtual | ~SmfEventsFetcherPlugin ()
virtual SmfPluginError | events (SmfPluginRequestData &aRequest, const SmfLocation &aLocation, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | venues (SmfPluginRequestData &aRequest, const SmfLocation &aLocation, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | attendees (SmfPluginRequestData &aRequest, const SmfEvent &aEvent, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | postEvents (SmfPluginRequestData &aRequest, const QList< SmfEvent > &aEventList)=0
virtual SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0

Detailed Description

Interface specification for events

All of the functionality described here should be implemented by a service specific plug-in.

Note: This class has dependencies on QtMobility project

Constructor & Destructor Documentation

virtual SmfEventsFetcherPlugin::~SmfEventsFetcherPlugin ( ) [inline, virtual]

Destructor

Member Function Documentation

virtual SmfPluginError SmfEventsFetcherPlugin::attendees | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfEvent & | aEvent,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get the list of attendees for an event

Parameters:
aRequest | [out] The request data to be sent to network
aEvent | [in] The event for which attendees should be fetched
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in MusicEventPlugin.

virtual SmfPluginError SmfEventsFetcherPlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [pure virtual]

Customised method for SmfEventsFetcherPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | [in] The operation type (should be known between the client interface and the plugin)
aData | [in] The data required to form the request (The type of data should be known between client and the plugin)
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in MusicEventPlugin.

virtual SmfPluginError SmfEventsFetcherPlugin::events | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfLocation & | aLocation,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get the events on the specified location

Parameters:
aRequest | [out] The request data to be sent to network
aLocation | [in] Location of the event
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in MusicEventPlugin.

virtual SmfPluginError SmfEventsFetcherPlugin::postEvents | ( | SmfPluginRequestData & | aRequest,
 |  | const QList< SmfEvent > & | aEventList |
 | ) |  |  | [pure virtual]

Method to post event(s)

Parameters:
aRequest | [out] The request data to be sent to network
aEventList | [in] The list of events to be posted
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in MusicEventPlugin.

virtual SmfPluginError SmfEventsFetcherPlugin::venues | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfLocation & | aLocation,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get the venues on the specified location

Parameters:
aRequest | [out] The request data to be sent to network
aLocation | [in] Location of the venue
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in MusicEventPlugin.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfserver/smfplugins/smfeventsfetcherplugin.h
Generated on Thu Sep 23 15:03:36 2010 for smf by doxygen 1.6.3


smf: Member List

SmfEventsFetcherPlugin Member List

This is the complete list of members for SmfEventsFetcherPlugin, including all inherited members.
attendees(SmfPluginRequestData &aRequest, const SmfEvent &aEvent, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfEventsFetcherPlugin | [pure virtual]
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0 | SmfEventsFetcherPlugin | [pure virtual]
events(SmfPluginRequestData &aRequest, const SmfLocation &aLocation, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfEventsFetcherPlugin | [pure virtual]
getProviderInfo()=0 | SmfPluginBase | [pure virtual]
initialize()=0 | SmfPluginBase | [pure virtual]
postEvents(SmfPluginRequestData &aRequest, const QList< SmfEvent > &aEventList)=0 | SmfEventsFetcherPlugin | [pure virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aReply, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)=0 | SmfPluginBase | [pure virtual]
venues(SmfPluginRequestData &aRequest, const SmfLocation &aLocation, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfEventsFetcherPlugin | [pure virtual]
~SmfEventsFetcherPlugin() | SmfEventsFetcherPlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:36 2010 for smf by doxygen 1.6.3


smf: SmfEventsFetcherPrivate Class Reference

SmfEventsFetcherPrivate Class Reference

Inherits smfObserver.

List of all members.

Public Member Functions

SmfEventsFetcherPrivate (SmfEventsFetcher *aEventFetcher)
~SmfEventsFetcherPrivate ()
SmfError | events (SmfLocation venue, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | venues (SmfLocation location, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | attendees (SmfEvent event, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | postEvents (SmfEventList events)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()
void | resultsAvailable (QByteArray result, SmfRequestTypeID opcode, SmfError error)

Friends

class | SmfClientQt

Constructor & Destructor Documentation

SmfEventsFetcherPrivate::SmfEventsFetcherPrivate ( SmfEventsFetcher * aEventFetcher )

Constructs SmfEventsFetcher with base provider info

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Nalina Hariharan

Description: Private implementation of events related services

SmfEventsFetcherPrivate::~SmfEventsFetcherPrivate ( )

Destructor

Member Function Documentation

SmfError SmfEventsFetcherPrivate::attendees | ( | SmfEvent | event,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Gets a list of attendees to the event attendeesAvailable() signal is emitted with SmfContacts for the users attending this event

Parameters:
event
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
SmfError SmfEventsFetcherPrivate::cancelRequest ( )

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
SmfError SmfEventsFetcherPrivate::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData
 | ) |  |

Request for a custom operation. The signal customDataAvailable() is emitted when the result is available.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfNoError if success, else appropriate error value Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
SmfError SmfEventsFetcherPrivate::events | ( | SmfLocation | venue,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Gets list of events in a particular venue asynchronously. eventsAvailable() signal is emitted with SmfEventsList once its arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
SmfError SmfEventsFetcherPrivate::postEvents ( SmfEventList events )

Updates events. Might not be supported by all service provider. eventsUpdated() signal can be checked for success value.

Parameters:
SmfEventsList List of events to be posted
Returns:
SmfNoError if success, else appropriate error value
void SmfEventsFetcherPrivate::resultsAvailable | ( | QByteArray | result,
 |  | SmfRequestTypeID | opcode,
 |  | SmfError | error |
 | ) |  |  | [virtual]

To notify availibility of asynchronous requests.

Parameters:
result | Requested result, before using must check error param.
opcode | Requested opcode, for which the result has arrived.
error | Error

Implements smfObserver.

SmfError SmfEventsFetcherPrivate::venues | ( | SmfLocation | location,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Gets list of venues of a particular location asynchronously. venuesAvailable() signal is emitted with SmfLocationList once its arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfeventsfetcher_p.h
  • smf/smfservermodule/smfclient/smfeventsfetcher_p.cpp
Generated on Thu Sep 23 15:03:36 2010 for smf by doxygen 1.6.3


smf: Member List

SmfEventsFetcherPrivate Member List

This is the complete list of members for SmfEventsFetcherPrivate, including all inherited members.
attendees(SmfEvent event, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfEventsFetcherPrivate |
cancelRequest() | SmfEventsFetcherPrivate |
customRequest(const int &operationId, QByteArray *customData) | SmfEventsFetcherPrivate |
events(SmfLocation venue, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfEventsFetcherPrivate |
postEvents(SmfEventList events) | SmfEventsFetcherPrivate |
resultsAvailable(QByteArray result, SmfRequestTypeID opcode, SmfError error) | SmfEventsFetcherPrivate | [virtual]
SmfClientQt (defined in SmfEventsFetcherPrivate) | SmfEventsFetcherPrivate | [friend]
SmfEventsFetcherPrivate(SmfEventsFetcher *aEventFetcher) | SmfEventsFetcherPrivate |
venues(SmfLocation location, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfEventsFetcherPrivate |
~SmfEventsFetcherPrivate() | SmfEventsFetcherPrivate |
Generated on Thu Sep 23 15:03:37 2010 for smf by doxygen 1.6.3


smf: SmfGallery Class Reference

SmfGallery Class Reference
[Client Classes]

#include <smfgallery.h>

List of all members.

Public Slots

SmfError | albums (QStringList names, SmfContact *user, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | pictures (SmfPictureAlbumList &albums, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | description (SmfPicture &picture)
SmfError | upload (SmfPicture *image, SmfPictureAlbum *album=NULL)
SmfError | upload (SmfPictureList *images, SmfPictureAlbum *album=NULL)
SmfError | postComment (SmfPicture image, SmfComment comment)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()

Signals

void | albumsAvailable (SmfPictureAlbumList *albums, SmfError error, SmfResultPage resultPage)
void | picturesAvailable (SmfPictureList *pics, SmfError error, SmfResultPage resultPage)
void | descriptionAvailable (QString desc, SmfError error)
void | uploadFinished (QList< SmfError > error)
void | customDataAvailable (int operationId, QByteArray *customData)

Public Member Functions

SmfGallery (SmfProvider *baseprovider)
~SmfGallery ()

Friends

class | SmfGalleryPrivate

Detailed Description

Interface to a remote gallery service. This class provides some basic gallery functionality to allow applications to interact with a picture gallery in a social network.

Note that branding information for the particular service implementation is available from getProvider() API. See also: SmfProvider::serviceName(), SmfProvider::serviceIcon()

All of the functionality described here should be implemented by a service specific plug-in object. Interface name for SmfGallery org.symbian.smf.client.gallery

Constructor & Destructor Documentation

SmfGallery::SmfGallery ( SmfProvider * baseprovider )

Constructs SmfGallery.

Parameters:
baseProvider The base provider info

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The SmfGallery class

SmfGallery::~SmfGallery ( )

Destructor

Member Function Documentation

SmfError SmfGallery::albums | ( | QStringList | names,
 |  | SmfContact * | user,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [slot]

Get the album listing asynchronously. The albumsAvailable() signal is emitted with SmfPictureAlbumList once the albums have arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
names | the subject or any keywords to be used to filter albums with that name
user | the user whose albums are requested
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
void SmfGallery::albumsAvailable | ( | SmfPictureAlbumList * | albums,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Notification on arrival of list of SmfPictureAlbum as a result of call to albums().

Parameters:
pics | Picture list
error | Error string
resultPage | Page number info
SmfError SmfGallery::cancelRequest ( ) [slot]

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
void SmfGallery::customDataAvailable | ( | int | operationId,
 |  | QByteArray * | customData |
 | ) |  |  | [signal]

Emitted when custom data is available

Parameters:
operationId | Requested operation id
customData | Custom data received, interpretation is not the responsibility of Smf
SmfError SmfGallery::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData |
 | ) |  |  | [slot]

Request for a custom operation.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfError. SmfNoError if success, else appropriate error code Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
SmfError SmfGallery::description ( SmfPicture & picture ) [slot]

Returns a user title/caption for the picture

Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfGallery::pictures | ( | SmfPictureAlbumList & | albums,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [slot]

Get the picture listing asynchronously. The picturesAvailable() signal is emitted with SmfPictureList once the pictures have arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
albums | album(s) whose pictures are being requested
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
void SmfGallery::picturesAvailable | ( | SmfPictureList * | pics,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Notification on arrival of list of SmfPicture as a result of request. Note if number of friends is large, then it can download the list page by page. In that case this signal is emitted multiple times. through pictures().

Parameters:
pics | Picture list
error | Error string
resultPage | Page number info
SmfError SmfGallery::postComment | ( | SmfPicture | image,
 |  | SmfComment | comment |
 | ) |  |  | [slot]

Posts a comment for an image. uploadFinished() signal is emitted with success of the post once comment is posted.

Parameters:
image | Image to comment on
comment | Comment to post
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfGallery::upload | ( | SmfPictureList * | images,
 |  | SmfPictureAlbum * | album = NULL |
 | ) |  |  | [slot]

Upload an list image.Implemented as slot to connect to UI controls more easily uploadFinished() signal is emitted with the success value of the upload

Parameters:
images | the list image to be uploaded
album | the optional destination album name
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfGallery::upload | ( | SmfPicture * | image,
 |  | SmfPictureAlbum * | album = NULL |
 | ) |  |  | [slot]

Upload an image.Implemented as slot to connect to UI controls more easily uploadFinished() signal is emitted with the success value of the upload

Parameters:
image | the image to be uploaded
album | the optional destination album name
Returns:
SmfError. SmfNoError if success, else appropriate error code
void SmfGallery::uploadFinished ( QList< SmfError > error ) [signal]

Notification of the success of the uploading of image/comment

Parameters:
error The upload success result of each individual pictures
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfgallery.h
  • smf/smfservermodule/smfclient/smfgallery.cpp
Generated on Thu Sep 23 15:03:37 2010 for smf by doxygen 1.6.3


smf: Member List

SmfGallery Member List

This is the complete list of members for SmfGallery, including all inherited members.
albums(QStringList names, SmfContact *user, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfGallery | [slot]
albumsAvailable(SmfPictureAlbumList *albums, SmfError error, SmfResultPage resultPage) | SmfGallery | [signal]
cancelRequest() | SmfGallery | [slot]
customDataAvailable(int operationId, QByteArray *customData) | SmfGallery | [signal]
customRequest(const int &operationId, QByteArray *customData) | SmfGallery | [slot]
description(SmfPicture &picture) | SmfGallery | [slot]
descriptionAvailable(QString desc, SmfError error) (defined in SmfGallery) | SmfGallery | [signal]
pictures(SmfPictureAlbumList &albums, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfGallery | [slot]
picturesAvailable(SmfPictureList *pics, SmfError error, SmfResultPage resultPage) | SmfGallery | [signal]
postComment(SmfPicture image, SmfComment comment) | SmfGallery | [slot]
SmfGallery(SmfProvider *baseprovider) | SmfGallery |
SmfGalleryPrivate (defined in SmfGallery) | SmfGallery | [friend]
upload(SmfPicture *image, SmfPictureAlbum *album=NULL) | SmfGallery | [slot]
upload(SmfPictureList *images, SmfPictureAlbum *album=NULL) | SmfGallery | [slot]
uploadFinished(QList< SmfError > error) | SmfGallery | [signal]
~SmfGallery() | SmfGallery |
Generated on Thu Sep 23 15:03:37 2010 for smf by doxygen 1.6.3


smf: SmfGalleryPlugin Class Reference

SmfGalleryPlugin Class Reference
[Plugin Classes]

#include <smfgalleryplugin.h>

Inherits SmfPluginBase.

Inherited by FlickrGalleryPlugin, and SamplePlugin.

List of all members.

Public Member Functions

virtual | ~SmfGalleryPlugin ()
virtual SmfPluginError | albums (SmfPluginRequestData &aRequest, const QStringList &aNames, const SmfContact *aUser, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | pictures (SmfPluginRequestData &aRequest, const SmfPictureAlbumList &aAlbums, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | description (SmfPluginRequestData &aRequest, const SmfPicture &aImage)=0
virtual SmfPluginError | upload (SmfPluginRequestData &aRequest, const SmfPicture &aImage, const SmfPictureAlbum *aAlbum=NULL)=0
virtual SmfPluginError | upload (SmfPluginRequestData &aRequest, const QList< SmfPicture > &aImages, const SmfPictureAlbum *aAlbum=NULL)=0
virtual SmfPluginError | postComment (SmfPluginRequestData &aRequest, const SmfPicture &aImage, const SmfComment &aComment)=0
virtual SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Interface specification for plugins that implement gallery related services

Interface specification for plugins that implement gallery related services like getting pictures, their description, uploading, posting comments on pictures etc

All of the functionality described here should be implemented by a service specific plug-in.

A sample call flow between SmfPluginMgr and SmfGalleryPlugin is shown here

Constructor & Destructor Documentation

virtual SmfGalleryPlugin::~SmfGalleryPlugin ( ) [inline, virtual]

Destructor

Member Function Documentation

virtual SmfPluginError SmfGalleryPlugin::albums | ( | SmfPluginRequestData & | aRequest,
 |  | const QStringList & | aNames,
 |  | const SmfContact * | aUser,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get a list of albums

Parameters:
aRequest | [out] The request data to be sent to network
aNames | [in] The subject or any keywords to be used to filter albums with that name
aUser | [in] The user whose albums are requested
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FlickrGalleryPlugin.

virtual SmfPluginError SmfGalleryPlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [pure virtual]

Customised method for SmfGalleryPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | [in] The operation type (should be known between the client interface and the plugin)
aData | [in] The data required to form the request (The type of data should be known between client and the plugin)
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FlickrGalleryPlugin.

virtual SmfPluginError SmfGalleryPlugin::description | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPicture & | aImage |
 | ) |  |  | [pure virtual]

Method to get a description

Parameters:
aRequest | [out] The request data to be sent to network
aImage | [in] The image about which the description is required
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FlickrGalleryPlugin, and SamplePlugin.

virtual SmfPluginError SmfGalleryPlugin::pictures | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPictureAlbumList & | aAlbums,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get a list of pictures

Parameters:
aRequest | [out] The request data to be sent to network
aAlbums | [in] The album(s) whose pictures are being requested
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FlickrGalleryPlugin.

virtual SmfPluginError SmfGalleryPlugin::postComment | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPicture & | aImage,
 |  | const SmfComment & | aComment |
 | ) |  |  | [pure virtual]

Method to post comment on a picture is available

Parameters:
aRequest | [out] The request data to be sent to network
aImage | [in] The image on which comment is to be posted (its id should be present)
aComment | [in] The comment to be posted
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FlickrGalleryPlugin, and SamplePlugin.

virtual SmfPluginError SmfGalleryPlugin::upload | ( | SmfPluginRequestData & | aRequest,
 |  | const QList< SmfPicture > & | aImages,
 |  | const SmfPictureAlbum * | aAlbum = NULL |
 | ) |  |  | [pure virtual]

Method to upload a list of pictures

Parameters:
aRequest | [out] The request data to be sent to network
aImages | [in] The list of images to be uploaded
aAlbum | [in] the optional destination album name
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FlickrGalleryPlugin.

virtual SmfPluginError SmfGalleryPlugin::upload | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPicture & | aImage,
 |  | const SmfPictureAlbum * | aAlbum = NULL |
 | ) |  |  | [pure virtual]

Method to upload a picture

Parameters:
aRequest | [out] The request data to be sent to network
aImage | [in] The image to be uploaded
aAlbum | [in] the optional destination album name
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FlickrGalleryPlugin.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfserver/smfplugins/smfgalleryplugin.h
Generated on Thu Sep 23 15:03:38 2010 for smf by doxygen 1.6.3


smf: Member List

SmfGalleryPlugin Member List

This is the complete list of members for SmfGalleryPlugin, including all inherited members.
albums(SmfPluginRequestData &aRequest, const QStringList &aNames, const SmfContact *aUser, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfGalleryPlugin | [pure virtual]
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0 | SmfGalleryPlugin | [pure virtual]
description(SmfPluginRequestData &aRequest, const SmfPicture &aImage)=0 | SmfGalleryPlugin | [pure virtual]
getProviderInfo()=0 | SmfPluginBase | [pure virtual]
initialize()=0 | SmfPluginBase | [pure virtual]
pictures(SmfPluginRequestData &aRequest, const SmfPictureAlbumList &aAlbums, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfGalleryPlugin | [pure virtual]
postComment(SmfPluginRequestData &aRequest, const SmfPicture &aImage, const SmfComment &aComment)=0 | SmfGalleryPlugin | [pure virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aReply, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)=0 | SmfPluginBase | [pure virtual]
upload(SmfPluginRequestData &aRequest, const SmfPicture &aImage, const SmfPictureAlbum *aAlbum=NULL)=0 | SmfGalleryPlugin | [pure virtual]
upload(SmfPluginRequestData &aRequest, const QList< SmfPicture > &aImages, const SmfPictureAlbum *aAlbum=NULL)=0 | SmfGalleryPlugin | [pure virtual]
~SmfGalleryPlugin() | SmfGalleryPlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:38 2010 for smf by doxygen 1.6.3


smf: SmfGalleryPrivate Class Reference

SmfGalleryPrivate Class Reference

#include <smfgallery_p.h>

Inherits smfObserver.

List of all members.

Public Member Functions

SmfGalleryPrivate (SmfGallery *gallery=0)
~SmfGalleryPrivate ()
SmfError | albums (QStringList names, SmfContact *user, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | pictures (SmfPictureAlbumList &albums, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | description (SmfPicture &picture)
SmfError | upload (SmfPicture *image, SmfPictureAlbum *album=NULL)
SmfError | upload (SmfPictureList *images, SmfPictureAlbum *album=NULL)
SmfError | postComment (SmfPicture image, SmfComment comment)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()
void | resultsAvailable (QByteArray result, SmfRequestTypeID opcode, SmfError error)

Friends

class | SmfClientQt

Detailed Description

Private Qt wrapper Provided to accomodate diff facilities in diff platforms. Uses Symbian client-server for Symbian QDbus for linux QLocalserver for rest of the platforms Note:- only symbian client-server impl is provided at the moment

Constructor & Destructor Documentation

SmfGalleryPrivate::SmfGalleryPrivate ( SmfGallery * gallery = 0 )

Constructor

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private implementation for SmfGallery class

SmfGalleryPrivate::~SmfGalleryPrivate ( )

Destructor

Member Function Documentation

SmfError SmfGalleryPrivate::albums | ( | QStringList | names,
 |  | SmfContact * | user,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Get the album listing asynchronously. The albumsAvailable() signal is emitted with SmfPictureAlbumList once the albums have arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
names | the subject or any keywords to be used to filter albums with that name
user | the user whose albums are requested
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfGalleryPrivate::cancelRequest ( )

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
SmfError SmfGalleryPrivate::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData
 | ) |  |

Request for a custom operation.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfError. SmfNoError if success, else appropriate error code Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
SmfError SmfGalleryPrivate::description ( SmfPicture & picture )

Returns a user title/caption for the picture

Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfGalleryPrivate::pictures | ( | SmfPictureAlbumList & | albums,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Get the picture listing asynchronously. The picturesAvailable() signal is emitted with SmfPictureList once the pictures have arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
albums | album(s) whose pictures are being requested
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfGalleryPrivate::postComment | ( | SmfPicture | image,
 |  | SmfComment | comment
 | ) |  |

Posts a comment for an image. uploadFinished() signal is emitted with success of the post once comment is posted.

Parameters:
image | Image to comment on
comment | Comment to post
Returns:
SmfError. SmfNoError if success, else appropriate error code
void SmfGalleryPrivate::resultsAvailable | ( | QByteArray | result,
 |  | SmfRequestTypeID | opcode,
 |  | SmfError | error |
 | ) |  |  | [virtual]

To notify availibility of asynchronous requests.

Parameters:
result | Requested result, before using must check error param.
opcode | Requested opcode, for which the result has arrived.
error | Error

Implements smfObserver.

SmfError SmfGalleryPrivate::upload | ( | SmfPictureList * | images,
 |  | SmfPictureAlbum * | album = NULL
 | ) |  |

Upload an list image.Implemented as slot to connect to UI controls more easily uploadFinished() signal is emitted with the success value of the upload

Parameters:
images | the list image to be uploaded
album | the optional destination album name
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfGalleryPrivate::upload | ( | SmfPicture * | image,
 |  | SmfPictureAlbum * | album = NULL
 | ) |  |

Upload an image.Implemented as slot to connect to UI controls more easily uploadFinished() signal is emitted with the success value of the upload

Parameters:
image | the image to be uploaded
album | the optional destination album name
Returns:
SmfError. SmfNoError if success, else appropriate error code
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfgallery_p.h
  • smf/smfservermodule/smfclient/smfgallery_p.cpp
Generated on Thu Sep 23 15:03:38 2010 for smf by doxygen 1.6.3


smf: Member List

SmfGalleryPrivate Member List

This is the complete list of members for SmfGalleryPrivate, including all inherited members.
albums(QStringList names, SmfContact *user, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfGalleryPrivate |
cancelRequest() | SmfGalleryPrivate |
customRequest(const int &operationId, QByteArray *customData) | SmfGalleryPrivate |
description(SmfPicture &picture) | SmfGalleryPrivate |
pictures(SmfPictureAlbumList &albums, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfGalleryPrivate |
postComment(SmfPicture image, SmfComment comment) | SmfGalleryPrivate |
resultsAvailable(QByteArray result, SmfRequestTypeID opcode, SmfError error) | SmfGalleryPrivate | [virtual]
SmfClientQt (defined in SmfGalleryPrivate) | SmfGalleryPrivate | [friend]
SmfGalleryPrivate(SmfGallery *gallery=0) | SmfGalleryPrivate |
upload(SmfPicture *image, SmfPictureAlbum *album=NULL) | SmfGalleryPrivate |
upload(SmfPictureList *images, SmfPictureAlbum *album=NULL) | SmfGalleryPrivate |
~SmfGalleryPrivate() | SmfGalleryPrivate |
Generated on Thu Sep 23 15:03:38 2010 for smf by doxygen 1.6.3


smf: SmfGroup Class Reference

SmfGroup Class Reference
[Common Data Classes]

#include <smfgroup.h>

List of all members.

Public Slots

QList< SmfContact > | members () const
void | setMembers (QList< SmfContact > *mems)
QString | name () const
void | setName (QString &name)
QString | id () const
void | setId (QString &id)

Public Member Functions

SmfGroup (QList< SmfContact > *list=0)
SmfGroup (const SmfGroup &aOther)
SmfGroup & | operator= (const SmfGroup &aOther)
~SmfGroup ()

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfGroup &aGroup)
QDataStream & | operator>> (QDataStream &aDataStream, SmfGroup &aGroup)

Detailed Description

The group class represents an instance of a group as per SN site terminolgy

Constructor & Destructor Documentation

SmfGroup::SmfGroup ( QList< SmfContact > * list = 0 )

Constructor with default argument

Parameters:
list The list of members in the group

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The group class represents an instance of a group as per SN site terminolgy Constructor with default argument

Parameters:
list The list of members in the group
SmfGroup::SmfGroup ( const SmfGroup & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfGroup::~SmfGroup ( )

Destructor

Member Function Documentation

QString SmfGroup::id ( ) const [slot]

Method to get the id of the group

Returns:
The ID value
QList< SmfContact > SmfGroup::members ( ) const [slot]

Method to get the list of members in the group

Returns:
The list of members in the group
QString SmfGroup::name ( ) const [slot]

Method to get the name of the group

Returns:
The name of the group
SmfGroup & SmfGroup::operator= ( const SmfGroup & aOther )

Overloaded = operator

Parameters:
aOther The reference object

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
void SmfGroup::setId ( QString & id ) [slot]

Method to set id

void SmfGroup::setMembers ( QList< SmfContact > * mems ) [slot]

Method to set members

void SmfGroup::setName ( QString & name ) [slot]

Method to set name

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfGroup & | aGroup |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfGroup object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aGroup | The SmfGroup object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfGroup & | aGroup |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfGroup object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aGroup | The SmfGroup object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfgroup.h
  • smf/smfservermodule/smfcommon/smfgroup.cpp
Generated on Thu Sep 23 15:03:38 2010 for smf by doxygen 1.6.3


smf: Member List

SmfGroup Member List

This is the complete list of members for SmfGroup, including all inherited members.
id() const | SmfGroup | [slot]
members() const | SmfGroup | [slot]
name() const | SmfGroup | [slot]
operator<<(QDataStream &aDataStream, const SmfGroup &aGroup) | SmfGroup | [friend]
operator=(const SmfGroup &aOther) | SmfGroup |
operator>>(QDataStream &aDataStream, SmfGroup &aGroup) | SmfGroup | [friend]
setId(QString &id) | SmfGroup | [slot]
setMembers(QList< SmfContact > *mems) | SmfGroup | [slot]
setName(QString &name) | SmfGroup | [slot]
SmfGroup(QList< SmfContact > *list=0) | SmfGroup |
SmfGroup(const SmfGroup &aOther) | SmfGroup |
~SmfGroup() | SmfGroup |
Generated on Thu Sep 23 15:03:38 2010 for smf by doxygen 1.6.3


smf: SmfGroupPrivate Class Reference

SmfGroupPrivate Class Reference

#include <smfgroup_p.h>

List of all members.

Public Member Functions

SmfGroupPrivate ()
SmfGroupPrivate (const SmfGroupPrivate &aOther)
~SmfGroupPrivate ()

Public Attributes

QList< SmfContact > * | m_members
QString | m_groupName
QString | m_groupId

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfGroup class

Constructor & Destructor Documentation

SmfGroupPrivate::SmfGroupPrivate ( ) [inline]

Constructor

SmfGroupPrivate::SmfGroupPrivate ( const SmfGroupPrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfGroupPrivate::~SmfGroupPrivate ( ) [inline]

Destructor

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfgroup_p.h
Generated on Thu Sep 23 15:03:38 2010 for smf by doxygen 1.6.3


smf: Member List

SmfGroupPrivate Member List

This is the complete list of members for SmfGroupPrivate, including all inherited members.
m_groupId (defined in SmfGroupPrivate) | SmfGroupPrivate |
m_groupName (defined in SmfGroupPrivate) | SmfGroupPrivate |
m_members (defined in SmfGroupPrivate) | SmfGroupPrivate |
SmfGroupPrivate() | SmfGroupPrivate | [inline]
SmfGroupPrivate(const SmfGroupPrivate &aOther) | SmfGroupPrivate | [inline]
~SmfGroupPrivate() | SmfGroupPrivate | [inline]
Generated on Thu Sep 23 15:03:38 2010 for smf by doxygen 1.6.3


smf: SmfLocation Class Reference

SmfLocation Class Reference
[Common Data Classes]

#include <smflocation.h>

List of all members.

Public Member Functions

SmfLocation ()
SmfLocation (const SmfLocation &aOther)
SmfLocation & | operator= (const SmfLocation &aOther)
~SmfLocation ()
QString | name () const
QString | city () const
QString | street () const
QString | zipCode () const
QString | country () const
QGeoPositionInfo | geoPositionInfo () const
QUrl | url () const
QString | id () const
void | setName (const QString &aPlace)
void | setCity (const QString &aCity)
void | setStreet (const QString &aStreet)
void | setZipCode (const QString &aZipCode)
void | setCountry (const QString &aCountry)
void | setGeoPositionInfo (const QGeoPositionInfo &aGeoPosInfo)
void | setUrl (const QUrl &aUrl)
void | setId (const QString &aId)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfLocation &aPlace)
QDataStream & | operator>> (QDataStream &aDataStream, SmfLocation &aPlace)

Detailed Description

The SmfLocation class represents a location and its related information.

Note: This class has dependencies on QtMobility project

Constructor & Destructor Documentation

SmfLocation::SmfLocation ( )

Constructor with default argument

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The SmfLocation class represents a location and its related information Note: This class has dependencies on QtMobility project Constructor with default argument

SmfLocation::SmfLocation ( const SmfLocation & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfLocation::~SmfLocation ( )

Destructor

Member Function Documentation

QString SmfLocation::city ( ) const

Method to get the city of place

Returns:
The city of the place
QString SmfLocation::country ( ) const

Method to get the country of place

Returns:
The country of place
QGeoPositionInfo SmfLocation::geoPositionInfo ( ) const

Method to get the Geo Position information (like information gathered on a global position, direction and velocity at a particular point in time) of the place.

Returns:
The Geo Position information of place
QString SmfLocation::id ( ) const

Method to get the id of the place

Returns:
The ID value
QString SmfLocation::name ( ) const

Method to get the place name

Returns:
The place name
SmfLocation & SmfLocation::operator= ( const SmfLocation & aOther )

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The current object reference

Overloaded = operator

Parameters:
aOther The reference object
void SmfLocation::setCity ( const QString & aCity )

Method to set the city of place

Parameters:
aCity The new city of the place
void SmfLocation::setCountry ( const QString & aCountry )

Method to set the country of place

Parameters:
aCountry The new country of place
void SmfLocation::setGeoPositionInfo ( const QGeoPositionInfo & aGeoPosInfo )

Method to set the Geo Postion information (like information gathered on a global position, direction and velocity at a particular point in time) of the place.

Parameters:
aGeoPosInfo The new Geo Position information of place
void SmfLocation::setId ( const QString & aId )

Method to set the id of the place

Returns:
The ID value
void SmfLocation::setName ( const QString & aPlace )

Method to set the place name

Parameters:
aPlace The new place name
void SmfLocation::setStreet ( const QString & aStreet )

Method to set the street information of place

Parameters:
aStreet The new street information of the place
void SmfLocation::setUrl ( const QUrl & aUrl )

Method to set the url indicating the place

Parameters:
aUrl The new url indicating the place
void SmfLocation::setZipCode ( const QString & aZipCode )

Method to set the zip code of place

Parameters:
aZipCode The new zip code of place
QString SmfLocation::street ( ) const

Method to get the street information of place

Returns:
The street information of the place
QUrl SmfLocation::url ( ) const

Method to get the url indicating the place

Returns:
The url indicating the place
QString SmfLocation::zipCode ( ) const

Method to get the zip code of place

Returns:
The zip code of place

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfLocation & | aPlace |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfLocation object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aPlace | The SmfLocation object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfLocation & | aPlace |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfLocation object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aPlace | The SmfLocation object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smflocation.h
  • smf/smfservermodule/smfcommon/smflocation.cpp
Generated on Thu Sep 23 15:03:39 2010 for smf by doxygen 1.6.3


smf: Member List

SmfLocation Member List

This is the complete list of members for SmfLocation, including all inherited members.
city() const | SmfLocation |
country() const | SmfLocation |
geoPositionInfo() const | SmfLocation |
id() const | SmfLocation |
name() const | SmfLocation |
operator<<(QDataStream &aDataStream, const SmfLocation &aPlace) | SmfLocation | [friend]
operator=(const SmfLocation &aOther) | SmfLocation |
operator>>(QDataStream &aDataStream, SmfLocation &aPlace) | SmfLocation | [friend]
setCity(const QString &aCity) | SmfLocation |
setCountry(const QString &aCountry) | SmfLocation |
setGeoPositionInfo(const QGeoPositionInfo &aGeoPosInfo) | SmfLocation |
setId(const QString &aId) | SmfLocation |
setName(const QString &aPlace) | SmfLocation |
setStreet(const QString &aStreet) | SmfLocation |
setUrl(const QUrl &aUrl) | SmfLocation |
setZipCode(const QString &aZipCode) | SmfLocation |
SmfLocation() | SmfLocation |
SmfLocation(const SmfLocation &aOther) | SmfLocation |
street() const | SmfLocation |
url() const | SmfLocation |
zipCode() const | SmfLocation |
~SmfLocation() | SmfLocation |
Generated on Thu Sep 23 15:03:39 2010 for smf by doxygen 1.6.3


smf: SmfLocationPrivate Class Reference

SmfLocationPrivate Class Reference

List of all members.

Public Member Functions

SmfLocationPrivate ()
SmfLocationPrivate (const SmfLocationPrivate &aOther)
~SmfLocationPrivate ()

Public Attributes

QString | m_name
QString | m_city
QString | m_street
QString | m_zipcode
QString | m_country
QGeoPositionInfo | m_geo
QUrl | m_url
QString | m_placeId

Constructor & Destructor Documentation

SmfLocationPrivate::SmfLocationPrivate ( ) [inline]

Constructor

SmfLocationPrivate::SmfLocationPrivate ( const SmfLocationPrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfLocationPrivate::~SmfLocationPrivate ( ) [inline]

Destructor

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smflocation_p.h
Generated on Thu Sep 23 15:03:39 2010 for smf by doxygen 1.6.3


smf: Member List

SmfLocationPrivate Member List

This is the complete list of members for SmfLocationPrivate, including all inherited members.
m_city (defined in SmfLocationPrivate) | SmfLocationPrivate |
m_country (defined in SmfLocationPrivate) | SmfLocationPrivate |
m_geo (defined in SmfLocationPrivate) | SmfLocationPrivate |
m_name (defined in SmfLocationPrivate) | SmfLocationPrivate |
m_placeId (defined in SmfLocationPrivate) | SmfLocationPrivate |
m_street (defined in SmfLocationPrivate) | SmfLocationPrivate |
m_url (defined in SmfLocationPrivate) | SmfLocationPrivate |
m_zipcode (defined in SmfLocationPrivate) | SmfLocationPrivate |
SmfLocationPrivate() | SmfLocationPrivate | [inline]
SmfLocationPrivate(const SmfLocationPrivate &aOther) | SmfLocationPrivate | [inline]
~SmfLocationPrivate() | SmfLocationPrivate | [inline]
Generated on Thu Sep 23 15:03:39 2010 for smf by doxygen 1.6.3


smf: SmfLyrics Class Reference

SmfLyrics Class Reference
[Common Data Classes]

#include <smflyrics.h>

List of all members.

Public Member Functions

SmfLyrics ()
SmfLyrics (const SmfLyrics &aOther)
SmfLyrics & | operator= (const SmfLyrics &aOther)
~SmfLyrics ()
QByteArray | lyrics () const
QString | language () const
QDateTime | releaseYear () const
QString | id () const
void | setLyrics (const QByteArray &aLyrics)
void | setLanguage (const QString &aLang)
void | setReleaseYear (const QDateTime &aRelYear)
void | setId (const QString &aId)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfLyrics &aLyrics)
QDataStream & | operator>> (QDataStream &aDataStream, SmfLyrics &aLyrics)

Detailed Description

The lyrics class represents an instance of a music track's lyrics

Constructor & Destructor Documentation

SmfLyrics::SmfLyrics ( )

Constructor with default argument

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The SmfLyrics class represents an instance of a music track's lyrics Constructor with default argument

SmfLyrics::SmfLyrics ( const SmfLyrics & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfLyrics::~SmfLyrics ( )

Destructor

Member Function Documentation

QString SmfLyrics::id ( ) const

Method to get the id of the lyrics

Returns:
The ID value
QString SmfLyrics::language ( ) const

Method to get the language

Returns:
The language
QByteArray SmfLyrics::lyrics ( ) const

Method to get the lyrics

Returns:
The lyrics data
SmfLyrics & SmfLyrics::operator= ( const SmfLyrics & aOther )

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The current object reference

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
QDateTime SmfLyrics::releaseYear ( ) const

Method to get the release year

Returns:
The release year
void SmfLyrics::setId ( const QString & aId )

Method to set the id of the lyrics

Parameters:
aId The ID value
void SmfLyrics::setLanguage ( const QString & aLang )

Method to set the language

Parameters:
aLang The language
void SmfLyrics::setLyrics ( const QByteArray & aLyrics )

Method to set the lyrics

Parameters:
aLyrics The lyrics data
void SmfLyrics::setReleaseYear ( const QDateTime & aRelYear )

Method to set the release year

Parameters:
aRelYear The release year

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfLyrics & | aLyrics |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfLyrics object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aLyrics | The SmfLyrics object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfLyrics & | aLyrics |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfLyrics object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aLyrics | The SmfLyrics object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smflyrics.h
  • smf/smfservermodule/smfcommon/smflyrics.cpp
Generated on Thu Sep 23 15:03:39 2010 for smf by doxygen 1.6.3


smf: Member List

SmfLyrics Member List

This is the complete list of members for SmfLyrics, including all inherited members.
id() const | SmfLyrics |
language() const | SmfLyrics |
lyrics() const | SmfLyrics |
operator<<(QDataStream &aDataStream, const SmfLyrics &aLyrics) | SmfLyrics | [friend]
operator=(const SmfLyrics &aOther) | SmfLyrics |
operator>>(QDataStream &aDataStream, SmfLyrics &aLyrics) | SmfLyrics | [friend]
releaseYear() const | SmfLyrics |
setId(const QString &aId) | SmfLyrics |
setLanguage(const QString &aLang) | SmfLyrics |
setLyrics(const QByteArray &aLyrics) | SmfLyrics |
setReleaseYear(const QDateTime &aRelYear) | SmfLyrics |
SmfLyrics() | SmfLyrics |
SmfLyrics(const SmfLyrics &aOther) | SmfLyrics |
~SmfLyrics() | SmfLyrics |
Generated on Thu Sep 23 15:03:39 2010 for smf by doxygen 1.6.3


smf: SmfLyricsPrivate Class Reference

SmfLyricsPrivate Class Reference

#include <smflyrics_p.h>

List of all members.

Public Member Functions

SmfLyricsPrivate ()
SmfLyricsPrivate (const SmfLyricsPrivate &aOther)
~SmfLyricsPrivate ()

Public Attributes

QByteArray | m_lyrics
QString | m_language
QDateTime | m_releaseYr
QString | m_lyricsId

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfLyrics class

Constructor & Destructor Documentation

SmfLyricsPrivate::SmfLyricsPrivate ( ) [inline]

Constructor

SmfLyricsPrivate::SmfLyricsPrivate ( const SmfLyricsPrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfLyricsPrivate::~SmfLyricsPrivate ( ) [inline]

Destructor

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smflyrics_p.h
Generated on Thu Sep 23 15:03:39 2010 for smf by doxygen 1.6.3


smf: Member List

SmfLyricsPrivate Member List

This is the complete list of members for SmfLyricsPrivate, including all inherited members.
m_language (defined in SmfLyricsPrivate) | SmfLyricsPrivate |
m_lyrics (defined in SmfLyricsPrivate) | SmfLyricsPrivate |
m_lyricsId (defined in SmfLyricsPrivate) | SmfLyricsPrivate |
m_releaseYr (defined in SmfLyricsPrivate) | SmfLyricsPrivate |
SmfLyricsPrivate() | SmfLyricsPrivate | [inline]
SmfLyricsPrivate(const SmfLyricsPrivate &aOther) | SmfLyricsPrivate | [inline]
~SmfLyricsPrivate() | SmfLyricsPrivate | [inline]
Generated on Thu Sep 23 15:03:39 2010 for smf by doxygen 1.6.3


smf: SmfLyricsService Class Reference

SmfLyricsService Class Reference

#include <smfmusic.h>

List of all members.

Signals

void | lyricsAvailable (SmfLyricsList *list, SmfError error, SmfResultPage resultPage)
void | subtitleAvailable (SmfSubtitleList *list, SmfError error, SmfResultPage resultPage)
void | customDataAvailable (const int &operationId, QByteArray *customData)

Public Member Functions

SmfLyricsService (SmfProvider *baseProvider=0)
~SmfLyricsService ()
SmfError | lyrics (SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | subtitles (SmfTrackInfo track, SmfSubtitleSearchFilter filter, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()

Friends

class | SmfLyricsServicePrivate

Detailed Description

provides service ("org.symbian.smf.client.music.lyrics")

Constructor & Destructor Documentation

SmfLyricsService::SmfLyricsService ( SmfProvider * baseProvider = 0 )

Constructs SmfLyricsService with base provider info.

SmfLyricsService::~SmfLyricsService ( )

Destructor

Member Function Documentation

SmfError SmfLyricsService::cancelRequest ( )

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
void SmfLyricsService::customDataAvailable | ( | const int & | operationId,
 |  | QByteArray * | customData |
 | ) |  |  | [signal]

Signals availability of the result of the customRequest

Parameters:
operationId | The ID to be shared between clients and the plugin
customData | data
SmfError SmfLyricsService::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData
 | ) |  |

Request for a custom operation. The signal customDataAvailable() is emitted when the result is available.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfNoError if success, else appropriate error value Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
SmfError SmfLyricsService::lyrics | ( | SmfTrackInfo | track,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Get the lyrics lists asynchrnously, it fetches texts without time info. lyricsAvailable() notification comes SmfLyricsList with when the data is available

Parameters:
track | Track for which lyrics needs to be fetched.
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
void SmfLyricsService::lyricsAvailable | ( | SmfLyricsList * | list,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Notification on arrival of lyrics Note if the list is large, then it can download the list page by page.

Parameters:
list | List of lyrics
error | SmfNoError if success, else appropriate error value
resultPage | Page number info
void SmfLyricsService::subtitleAvailable | ( | SmfSubtitleList * | list,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Notification on arrival of subtitle based on filter. Note if the list is large, then it can download the list page by page.

Parameters:
list | List of subtitles
error | SmfNoError if success, else appropriate error value
resultPage | Page number info
SmfError SmfLyricsService::subtitles | ( | SmfTrackInfo | track,
 |  | SmfSubtitleSearchFilter | filter,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Get the lyrics lists asynchrnously, it fetches texts with time info. Subtitle search filter can be applied subtitleAvailable() notification comes SmfSubtitleList with when the data is available

Parameters:
track | Track for which subtitle needs to be fetched.
filter | Subtitle search filter
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfmusic.h
  • smf/smfservermodule/smfclient/smfmusic.cpp
Generated on Thu Sep 23 15:03:39 2010 for smf by doxygen 1.6.3


smf: Member List

SmfLyricsService Member List

This is the complete list of members for SmfLyricsService, including all inherited members.
cancelRequest() | SmfLyricsService |
customDataAvailable(const int &operationId, QByteArray *customData) | SmfLyricsService | [signal]
customRequest(const int &operationId, QByteArray *customData) | SmfLyricsService |
lyrics(SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfLyricsService |
lyricsAvailable(SmfLyricsList *list, SmfError error, SmfResultPage resultPage) | SmfLyricsService | [signal]
SmfLyricsService(SmfProvider *baseProvider=0) | SmfLyricsService |
SmfLyricsServicePrivate (defined in SmfLyricsService) | SmfLyricsService | [friend]
subtitleAvailable(SmfSubtitleList *list, SmfError error, SmfResultPage resultPage) | SmfLyricsService | [signal]
subtitles(SmfTrackInfo track, SmfSubtitleSearchFilter filter, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfLyricsService |
~SmfLyricsService() | SmfLyricsService |
Generated on Thu Sep 23 15:03:39 2010 for smf by doxygen 1.6.3


smf: SmfLyricsServicePlugin Class Reference

SmfLyricsServicePlugin Class Reference
[Plugin Classes]

#include <smflyricsserviceplugin.h>

Inherits SmfPluginBase.

Inherited by MusicLyricsPlugin.

List of all members.

Public Member Functions

virtual | ~SmfLyricsServicePlugin ()
virtual SmfPluginError | lyrics (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | subtitles (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const SmfSubtitleSearchFilter &aFilter=SubtitleAll, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Interface specification for music track lyrics

Interface specification for music track lyrics

All of the functionality described here should be implemented by a service specific plug-in.

Constructor & Destructor Documentation

virtual SmfLyricsServicePlugin::~SmfLyricsServicePlugin ( ) [inline, virtual]

Destructor

Member Function Documentation

virtual SmfPluginError SmfLyricsServicePlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [pure virtual]

Customised method for SmfLyricsServicePlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | [in] The operation type (should be known between the client interface and the plugin)
aData | [in] The data required to form the request (The type of data should be known between client and the plugin)
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in MusicLyricsPlugin.

virtual SmfPluginError SmfLyricsServicePlugin::lyrics | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get the lyrics

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | [in] The track whose lyrics need to be fetched
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in MusicLyricsPlugin.

virtual SmfPluginError SmfLyricsServicePlugin::subtitles | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack,
 |  | const SmfSubtitleSearchFilter & | aFilter = SubtitleAll,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get the subtitle

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | [in] The track whose subtitle need to be fetched
aFilter | [in] The subtitle search filter if any
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in MusicLyricsPlugin.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfserver/smfplugins/smflyricsserviceplugin.h
Generated on Thu Sep 23 15:03:40 2010 for smf by doxygen 1.6.3


smf: Member List

SmfLyricsServicePlugin Member List

This is the complete list of members for SmfLyricsServicePlugin, including all inherited members.
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0 | SmfLyricsServicePlugin | [pure virtual]
getProviderInfo()=0 | SmfPluginBase | [pure virtual]
initialize()=0 | SmfPluginBase | [pure virtual]
lyrics(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfLyricsServicePlugin | [pure virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aReply, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)=0 | SmfPluginBase | [pure virtual]
subtitles(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const SmfSubtitleSearchFilter &aFilter=SubtitleAll, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfLyricsServicePlugin | [pure virtual]
~SmfLyricsServicePlugin() | SmfLyricsServicePlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:40 2010 for smf by doxygen 1.6.3


smf: SmfLyricsServicePrivate Class Reference

SmfLyricsServicePrivate Class Reference

#include <smfmusic_p.h>

Inherits smfObserver.

List of all members.

Public Member Functions

SmfLyricsServicePrivate (SmfLyricsService *aLyricsSrvc)
~SmfLyricsServicePrivate ()
SmfError | lyrics (SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | subtitles (SmfTrackInfo track, SmfSubtitleSearchFilter filter, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()
void | resultsAvailable (QByteArray result, SmfRequestTypeID opcode, SmfError error)

Friends

class | SmfClientQt

Detailed Description

provides service ("org.symbian.smf.client.music.lyrics")

Constructor & Destructor Documentation

SmfLyricsServicePrivate::SmfLyricsServicePrivate ( SmfLyricsService * aLyricsSrvc )

Constructs SmfLyricsService with base provider info.

SmfLyricsServicePrivate::~SmfLyricsServicePrivate ( )

Destructor

Member Function Documentation

SmfError SmfLyricsServicePrivate::cancelRequest ( )

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
SmfError SmfLyricsServicePrivate::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData
 | ) |  |

Request for a custom operation. The signal customDataAvailable() is emitted when the result is available.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfNoError if success, else appropriate error value Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
SmfError SmfLyricsServicePrivate::lyrics | ( | SmfTrackInfo | track,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Get the lyrics lists asynchrnously, it fetches texts without time info. lyricsAvailable() notification comes SmfLyricsList with when the data is available

Parameters:
track | Track for which lyrics needs to be fetched.
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
void SmfLyricsServicePrivate::resultsAvailable | ( | QByteArray | result,
 |  | SmfRequestTypeID | opcode,
 |  | SmfError | error |
 | ) |  |  | [virtual]

To notify availibility of asynchronous requests.

Parameters:
result | Requested result, before using must check error param.
opcode | Requested opcode, for which the result has arrived.
error | Error

Implements smfObserver.

SmfError SmfLyricsServicePrivate::subtitles | ( | SmfTrackInfo | track,
 |  | SmfSubtitleSearchFilter | filter,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Get the lyrics lists asynchrnously, it fetches texts with time info. Subtitle search filter can be applied subtitleAvailable() notification comes SmfSubtitleList with when the data is available

Parameters:
track | Track for which subtitle needs to be fetched.
filter | Subtitle search filter
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfmusic_p.h
  • smf/smfservermodule/smfclient/smfmusic_p.cpp
Generated on Thu Sep 23 15:03:40 2010 for smf by doxygen 1.6.3


smf: Member List

SmfLyricsServicePrivate Member List

This is the complete list of members for SmfLyricsServicePrivate, including all inherited members.
cancelRequest() | SmfLyricsServicePrivate |
customRequest(const int &operationId, QByteArray *customData) | SmfLyricsServicePrivate |
lyrics(SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfLyricsServicePrivate |
resultsAvailable(QByteArray result, SmfRequestTypeID opcode, SmfError error) | SmfLyricsServicePrivate | [virtual]
SmfClientQt (defined in SmfLyricsServicePrivate) | SmfLyricsServicePrivate | [friend]
SmfLyricsServicePrivate(SmfLyricsService *aLyricsSrvc) | SmfLyricsServicePrivate |
subtitles(SmfTrackInfo track, SmfSubtitleSearchFilter filter, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfLyricsServicePrivate |
~SmfLyricsServicePrivate() | SmfLyricsServicePrivate |
Generated on Thu Sep 23 15:03:40 2010 for smf by doxygen 1.6.3


smf: SmfMusicFingerPrint Class Reference

SmfMusicFingerPrint Class Reference
[Common Data Classes]

#include <smfmusicfingerprint.h>

List of all members.

Public Member Functions

SmfMusicFingerPrint ()
SmfMusicFingerPrint (const SmfMusicFingerPrint &aOther)
SmfMusicFingerPrint & | operator= (const SmfMusicFingerPrint &aOther)
~SmfMusicFingerPrint ()
QByteArray | musicFingerPrint () const
QString | id () const
void | setMusicFingerPrint (const QByteArray &aFp)
void | setId (const QString &aId)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfMusicFingerPrint &aMFP)
QDataStream & | operator>> (QDataStream &aDataStream, SmfMusicFingerPrint &aMFP)

Detailed Description

The musicfingerprint class represents a music finger print used in searches

Constructor & Destructor Documentation

SmfMusicFingerPrint::SmfMusicFingerPrint ( )

Constructor with default argument

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The SmfMusicFingerPrint class represents a music finger print used in searches Constructor with default argument

SmfMusicFingerPrint::SmfMusicFingerPrint ( const SmfMusicFingerPrint & aOther )

Constructor with default argument

Parameters:
aParent The parent object
SmfMusicFingerPrint::~SmfMusicFingerPrint ( )

Destructor

Member Function Documentation

QString SmfMusicFingerPrint::id ( ) const

Method to get the service specific id of this fingerprint data

Returns:
The ID value
QByteArray SmfMusicFingerPrint::musicFingerPrint ( ) const

Method to get the music finger print data

Returns:
The music finger print data

GEt the music finger print data

Returns:
The music finger print data
SmfMusicFingerPrint & SmfMusicFingerPrint::operator= ( const SmfMusicFingerPrint & aOther )

Overloaded = operator

Parameters:
aOther The reference object

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
void SmfMusicFingerPrint::setId ( const QString & aId )

Method to set the service specific id of this fingerprint data

Parameters:
aId The ID value
void SmfMusicFingerPrint::setMusicFingerPrint ( const QByteArray & aFp )

Method to set the music finger print data

Parameters:
aFp The music finger print data

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfMusicFingerPrint & | aMFP |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfMusicFingerPrint object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aMFP | The SmfMusicFingerPrint object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfMusicFingerPrint & | aMFP |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfMusicFingerPrint object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aMFP | The SmfMusicFingerPrint object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfmusicfingerprint.h
  • smf/smfservermodule/smfcommon/smfmusicfingerprint.cpp
Generated on Thu Sep 23 15:03:40 2010 for smf by doxygen 1.6.3


smf: Member List

SmfMusicFingerPrint Member List

This is the complete list of members for SmfMusicFingerPrint, including all inherited members.
id() const | SmfMusicFingerPrint |
musicFingerPrint() const | SmfMusicFingerPrint |
operator<<(QDataStream &aDataStream, const SmfMusicFingerPrint &aMFP) | SmfMusicFingerPrint | [friend]
operator=(const SmfMusicFingerPrint &aOther) | SmfMusicFingerPrint |
operator>>(QDataStream &aDataStream, SmfMusicFingerPrint &aMFP) | SmfMusicFingerPrint | [friend]
setId(const QString &aId) | SmfMusicFingerPrint |
setMusicFingerPrint(const QByteArray &aFp) | SmfMusicFingerPrint |
SmfMusicFingerPrint() | SmfMusicFingerPrint |
SmfMusicFingerPrint(const SmfMusicFingerPrint &aOther) | SmfMusicFingerPrint |
~SmfMusicFingerPrint() | SmfMusicFingerPrint |
Generated on Thu Sep 23 15:03:40 2010 for smf by doxygen 1.6.3


smf: SmfMusicFingerPrintPrivate Class Reference

SmfMusicFingerPrintPrivate Class Reference

#include <smfmusicfingerprint_p.h>

List of all members.

Public Member Functions

SmfMusicFingerPrintPrivate ()
SmfMusicFingerPrintPrivate (const SmfMusicFingerPrintPrivate &aOther)
~SmfMusicFingerPrintPrivate ()

Public Attributes

QByteArray | m_fingerPrintData
QString | m_id

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfMusicFingerPrint class

Constructor & Destructor Documentation

SmfMusicFingerPrintPrivate::SmfMusicFingerPrintPrivate ( ) [inline]

Constructor

SmfMusicFingerPrintPrivate::SmfMusicFingerPrintPrivate ( const SmfMusicFingerPrintPrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfMusicFingerPrintPrivate::~SmfMusicFingerPrintPrivate ( ) [inline]

Destructor

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfmusicfingerprint_p.h
Generated on Thu Sep 23 15:03:40 2010 for smf by doxygen 1.6.3


smf: Member List

SmfMusicFingerPrintPrivate Member List

This is the complete list of members for SmfMusicFingerPrintPrivate, including all inherited members.
m_fingerPrintData (defined in SmfMusicFingerPrintPrivate) | SmfMusicFingerPrintPrivate |
m_id (defined in SmfMusicFingerPrintPrivate) | SmfMusicFingerPrintPrivate |
SmfMusicFingerPrintPrivate() | SmfMusicFingerPrintPrivate | [inline]
SmfMusicFingerPrintPrivate(const SmfMusicFingerPrintPrivate &aOther) | SmfMusicFingerPrintPrivate | [inline]
~SmfMusicFingerPrintPrivate() | SmfMusicFingerPrintPrivate | [inline]
Generated on Thu Sep 23 15:03:40 2010 for smf by doxygen 1.6.3


smf: SmfMusicProfile Class Reference

SmfMusicProfile Class Reference
[Common Data Classes]

#include <smfmusicprofile.h>

List of all members.

Public Member Functions

SmfMusicProfile ()
SmfMusicProfile (const SmfMusicProfile &aOther)
SmfMusicProfile & | operator= (const SmfMusicProfile &aOther)
~SmfMusicProfile ()
QList< SmfTrackInfo > | recentTracks () const
QList< SmfTrackInfo > | favorites () const
QList< SmfEvent > | userEvents () const
QString | id () const
void | setRecentTracks (const QList< SmfTrackInfo > &aUsage)
void | setFavorites (const QList< SmfTrackInfo > &aInterest)
void | setUserEvents (const QList< SmfEvent > &aList)
void | setId (const QString &aId)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfMusicProfile &aProfile)
QDataStream & | operator>> (QDataStream &aDataStream, SmfMusicProfile &aProfile)

Detailed Description

The music profile class represents a user's profile in music site

Constructor & Destructor Documentation

SmfMusicProfile::SmfMusicProfile ( )

Constructor with default argument

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The music profile class represents a user's profile in music site Constructor with default argument

SmfMusicProfile::SmfMusicProfile ( const SmfMusicProfile & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfMusicProfile::~SmfMusicProfile ( )

Destructor

Member Function Documentation

QList< SmfTrackInfo > SmfMusicProfile::favorites ( ) const

Method to get the user's favorite tracks e.g. could be user.getLovedTracks for last.fm

Returns:
The users favorite track list
QString SmfMusicProfile::id ( ) const

Method to get the service specific id of this user

Returns:
The ID value

Method to get the id of the music profile

Returns:
The ID value
SmfMusicProfile & SmfMusicProfile::operator= ( const SmfMusicProfile & aOther )

Overloaded = operator

Parameters:
aOther The reference object

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
QList< SmfTrackInfo > SmfMusicProfile::recentTracks ( ) const

Method to get the user's most recently heard tracks

Returns:
The users most recently heard tracks
void SmfMusicProfile::setFavorites ( const QList< SmfTrackInfo > & aInterest )

Method to set the user's favorite tracks

Parameters:
aInterest The users new favorite track list
void SmfMusicProfile::setId ( const QString & aId )

Method to set the id of the music profile

Parameters:
aId The ID value
void SmfMusicProfile::setRecentTracks ( const QList< SmfTrackInfo > & aUsage )

Method to set the user's recent tracks

Parameters:
aUsage The users new track list
void SmfMusicProfile::setUserEvents ( const QList< SmfEvent > & aList )

Method to set the user events as list of SmfEvents

Parameters:
aList The list of events
QList< SmfEvent > SmfMusicProfile::userEvents ( ) const

Method to get a list of upcoming events that this user is attending

Returns:
The list of upcoming events

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfMusicProfile & | aProfile |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfMusicProfile object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aProfile | The SmfMusicProfile object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfMusicProfile & | aProfile |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfMusicProfile object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aProfile | The SmfMusicProfile object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfmusicprofile.h
  • smf/smfservermodule/smfcommon/smfmusicprofile.cpp
Generated on Thu Sep 23 15:03:40 2010 for smf by doxygen 1.6.3


smf: Member List

SmfMusicProfile Member List

This is the complete list of members for SmfMusicProfile, including all inherited members.
favorites() const | SmfMusicProfile |
id() const | SmfMusicProfile |
operator<<(QDataStream &aDataStream, const SmfMusicProfile &aProfile) | SmfMusicProfile | [friend]
operator=(const SmfMusicProfile &aOther) | SmfMusicProfile |
operator>>(QDataStream &aDataStream, SmfMusicProfile &aProfile) | SmfMusicProfile | [friend]
recentTracks() const | SmfMusicProfile |
setFavorites(const QList< SmfTrackInfo > &aInterest) | SmfMusicProfile |
setId(const QString &aId) | SmfMusicProfile |
setRecentTracks(const QList< SmfTrackInfo > &aUsage) | SmfMusicProfile |
setUserEvents(const QList< SmfEvent > &aList) | SmfMusicProfile |
SmfMusicProfile() | SmfMusicProfile |
SmfMusicProfile(const SmfMusicProfile &aOther) | SmfMusicProfile |
userEvents() const | SmfMusicProfile |
~SmfMusicProfile() | SmfMusicProfile |
Generated on Thu Sep 23 15:03:40 2010 for smf by doxygen 1.6.3


smf: SmfMusicProfilePrivate Class Reference

SmfMusicProfilePrivate Class Reference

#include <smfmusicprofile_p.h>

List of all members.

Public Member Functions

SmfMusicProfilePrivate ()
SmfMusicProfilePrivate (const SmfMusicProfilePrivate &aOther)
~SmfMusicProfilePrivate ()

Public Attributes

QList< SmfTrackInfo > | m_recent
QList< SmfTrackInfo > | m_favorites
QList< SmfEvent > | m_events
QString | m_profileId

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfMusicProfile class

Constructor & Destructor Documentation

SmfMusicProfilePrivate::SmfMusicProfilePrivate ( ) [inline]

Constructor

SmfMusicProfilePrivate::SmfMusicProfilePrivate ( const SmfMusicProfilePrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfMusicProfilePrivate::~SmfMusicProfilePrivate ( ) [inline]

Destructor

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfmusicprofile_p.h
Generated on Thu Sep 23 15:03:41 2010 for smf by doxygen 1.6.3


smf: Member List

SmfMusicProfilePrivate Member List

This is the complete list of members for SmfMusicProfilePrivate, including all inherited members.
m_events (defined in SmfMusicProfilePrivate) | SmfMusicProfilePrivate |
m_favorites (defined in SmfMusicProfilePrivate) | SmfMusicProfilePrivate |
m_profileId (defined in SmfMusicProfilePrivate) | SmfMusicProfilePrivate |
m_recent (defined in SmfMusicProfilePrivate) | SmfMusicProfilePrivate |
SmfMusicProfilePrivate() | SmfMusicProfilePrivate | [inline]
SmfMusicProfilePrivate(const SmfMusicProfilePrivate &aOther) | SmfMusicProfilePrivate | [inline]
~SmfMusicProfilePrivate() | SmfMusicProfilePrivate | [inline]
Generated on Thu Sep 23 15:03:41 2010 for smf by doxygen 1.6.3


smf: SmfMusicRating Class Reference

SmfMusicRating Class Reference
[Common Data Classes]

#include <smfmusicrating.h>

List of all members.

Public Member Functions

SmfMusicRating (SmfTrackInfo *aParent=0)
SmfMusicRating (const SmfMusicRating &aOther)
SmfMusicRating & | operator= (const SmfMusicRating &aOther)
~SmfMusicRating ()
int | rating () const
int | maxRating () const
int | minRating () const
void | setRating (const int &aRating)
void | setMaxRating (const int &aMax)
void | setMinRating (const int &aMin)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfMusicRating &aMusicRating)
QDataStream & | operator>> (QDataStream &aDataStream, SmfMusicRating &aMusicRating)

Detailed Description

The music rating class represents an instance of rating about a music track

Constructor & Destructor Documentation

SmfMusicRating::SmfMusicRating ( SmfTrackInfo * aParent = 0 )

Constructor with default argument

Parameters:
aParent The SmfTrackInfo instance

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The music rating class represents an instance of rating about a music track Constructor with default argument

Parameters:
aParent The SmfTrackInfo instance
SmfMusicRating::SmfMusicRating ( const SmfMusicRating & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfMusicRating::~SmfMusicRating ( )

Destructor

Member Function Documentation

int SmfMusicRating::maxRating ( ) const

Method to get the max rating

Returns:
The max rating value
int SmfMusicRating::minRating ( ) const

Method to get the min rating

Returns:
The min rating value
SmfMusicRating & SmfMusicRating::operator= ( const SmfMusicRating & aOther )

Overloaded = operator

Parameters:
aOther The reference object
int SmfMusicRating::rating ( ) const

Method to get the rating

Returns:
The rating value
void SmfMusicRating::setMaxRating ( const int & aMax )

Method to set the max rating

Parameters:
aMax The max rating value
void SmfMusicRating::setMinRating ( const int & aMin )

Method to set the min rating

Parameters:
aMin The min rating value
void SmfMusicRating::setRating ( const int & aRating )

Method to set the rating

Parameters:
aRating The rating value

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfMusicRating & | aMusicRating |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfMusicRating object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aMusicRating | The SmfMusicRating object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfMusicRating & | aMusicRating |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfMusicRating object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aMusicRating | The SmfMusicRating object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfmusicrating.h
  • smf/smfservermodule/smfcommon/smfmusicrating.cpp
Generated on Thu Sep 23 15:03:41 2010 for smf by doxygen 1.6.3


smf: Member List

SmfMusicRating Member List

This is the complete list of members for SmfMusicRating, including all inherited members.
maxRating() const | SmfMusicRating |
minRating() const | SmfMusicRating |
operator<<(QDataStream &aDataStream, const SmfMusicRating &aMusicRating) | SmfMusicRating | [friend]
operator=(const SmfMusicRating &aOther) | SmfMusicRating |
operator>>(QDataStream &aDataStream, SmfMusicRating &aMusicRating) | SmfMusicRating | [friend]
rating() const | SmfMusicRating |
setMaxRating(const int &aMax) | SmfMusicRating |
setMinRating(const int &aMin) | SmfMusicRating |
setRating(const int &aRating) | SmfMusicRating |
SmfMusicRating(SmfTrackInfo *aParent=0) | SmfMusicRating |
SmfMusicRating(const SmfMusicRating &aOther) | SmfMusicRating |
~SmfMusicRating() | SmfMusicRating |
Generated on Thu Sep 23 15:03:41 2010 for smf by doxygen 1.6.3


smf: SmfMusicRatingPrivate Class Reference

SmfMusicRatingPrivate Class Reference

#include <smfmusicrating_p.h>

List of all members.

Public Member Functions

SmfMusicRatingPrivate ()
SmfMusicRatingPrivate (const SmfMusicRatingPrivate &aOther)
~SmfMusicRatingPrivate ()

Public Attributes

qint32 | m_rating
qint32 | m_max
qint32 | m_min

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfMusicRating class

Constructor & Destructor Documentation

SmfMusicRatingPrivate::SmfMusicRatingPrivate ( ) [inline]

Constructor

SmfMusicRatingPrivate::SmfMusicRatingPrivate ( const SmfMusicRatingPrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfMusicRatingPrivate::~SmfMusicRatingPrivate ( ) [inline]

Destructor

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfmusicrating_p.h
Generated on Thu Sep 23 15:03:41 2010 for smf by doxygen 1.6.3


smf: Member List

SmfMusicRatingPrivate Member List

This is the complete list of members for SmfMusicRatingPrivate, including all inherited members.
m_max (defined in SmfMusicRatingPrivate) | SmfMusicRatingPrivate |
m_min (defined in SmfMusicRatingPrivate) | SmfMusicRatingPrivate |
m_rating (defined in SmfMusicRatingPrivate) | SmfMusicRatingPrivate |
SmfMusicRatingPrivate() | SmfMusicRatingPrivate | [inline]
SmfMusicRatingPrivate(const SmfMusicRatingPrivate &aOther) | SmfMusicRatingPrivate | [inline]
~SmfMusicRatingPrivate() | SmfMusicRatingPrivate | [inline]
Generated on Thu Sep 23 15:03:41 2010 for smf by doxygen 1.6.3


smf: SmfMusicSearch Class Reference

SmfMusicSearch Class Reference

#include <smfmusic.h>

List of all members.

Signals

void | trackSearchAvailable (SmfTrackInfoList *result, SmfError error, SmfResultPage resultPage)
void | storeSearchAvailable (SmfProviderList *result, SmfError error, SmfResultPage resultPage)
void | customDataAvailable (const int &operationId, QByteArray *customData)

Public Member Functions

SmfMusicSearch (SmfProvider *baseProvider=0)
~SmfMusicSearch ()
SmfError | recommendations (SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | tracksSimilar (SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | tracksOfAlbum (SmfAlbum album, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | tracksOfArtist (SmfArtists artists, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | trackInfo (SmfMusicFingerPrint signature, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | stores (SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()

Friends

class | SmfMusicSearchPrivate

Detailed Description

Provides service ("org.symbian.smf.client.music.search") for music search

Constructor & Destructor Documentation

SmfMusicSearch::SmfMusicSearch ( SmfProvider * baseProvider = 0 )

Constructs SmfMusicSearch with base provider as arguement.

SmfMusicSearch::~SmfMusicSearch ( )

Destructor

Member Function Documentation

SmfError SmfMusicSearch::cancelRequest ( )

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
void SmfMusicSearch::customDataAvailable | ( | const int & | operationId,
 |  | QByteArray * | customData |
 | ) |  |  | [signal]

Signals availability of the result of the customRequest

Parameters:
operationId | The ID to be shared between clients and the plugin
customData | data
SmfError SmfMusicSearch::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData
 | ) |  |

Request for a custom operation. The signal customDataAvailable() is emitted when the result is available.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfNoError if success, else appropriate error value Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
SmfError SmfMusicSearch::recommendations | ( | SmfTrackInfo | track,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for music recommendations similar to a particulartrack asynchronously. The signal trackSearchAvailable() is emitted with SmfTrackInfoList once its arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
track | The track for which similar recommendations need to be fetched.
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
SmfError SmfMusicSearch::stores | ( | SmfTrackInfo | track,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Search information about where to buy this song from asynchronously. The signal storeSearchAvailable() is emitted with SmfProviderList once its arrived.

Parameters:
track | The search criteria for stores
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
void SmfMusicSearch::storeSearchAvailable | ( | SmfProviderList * | result,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Emitted when the search result for a store is available. Note if number of tacks in the search is large, then it can download the list page by page.

Parameters:
result | List of stores
error | SmfNoError if success, else appropriate error value
resultPage | Page number info
SmfError SmfMusicSearch::trackInfo | ( | SmfMusicFingerPrint | signature,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for a track having similar finger print asynchronously. The signal trackSearchAvailable() is emitted with SmfTrackInfoList once its arrived.

Parameters:
signature | The search criteria,signature to be searched for
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
void SmfMusicSearch::trackSearchAvailable | ( | SmfTrackInfoList * | result,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Emitted when the search results for tracks (for album, artist, etc) are available. Note if number of tacks in the search is large, then it can download the list page by page.

Parameters:
result | list of tracks
error | SmfNoError if success, else appropriate error value
resultPage | Page number info
SmfError SmfMusicSearch::tracksOfAlbum | ( | SmfAlbum | album,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for tracks for a given album asynchronously. The signal trackSearchAvailable() is emitted with SmfTrackInfoList once its arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
album | The album containing the id
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
SmfError SmfMusicSearch::tracksOfArtist | ( | SmfArtists | artists,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for tracks for a given artist(s) asynchronously. The signal trackSearchAvailable() is emitted with SmfTrackInfoList once its arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
artists | The artists list
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
SmfError SmfMusicSearch::tracksSimilar | ( | SmfTrackInfo | track,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for tracks similar to a given track asynchronously. The signal trackSearchAvailable() is emitted with SmfTrackInfoList once its arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
track | The search criteria, similar tracks are searched
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfmusic.h
  • smf/smfservermodule/smfclient/smfmusic.cpp
Generated on Thu Sep 23 15:03:41 2010 for smf by doxygen 1.6.3


smf: Member List

SmfMusicSearch Member List

This is the complete list of members for SmfMusicSearch, including all inherited members.
cancelRequest() | SmfMusicSearch |
customDataAvailable(const int &operationId, QByteArray *customData) | SmfMusicSearch | [signal]
customRequest(const int &operationId, QByteArray *customData) | SmfMusicSearch |
recommendations(SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicSearch |
SmfMusicSearch(SmfProvider *baseProvider=0) | SmfMusicSearch |
SmfMusicSearchPrivate (defined in SmfMusicSearch) | SmfMusicSearch | [friend]
stores(SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicSearch |
storeSearchAvailable(SmfProviderList *result, SmfError error, SmfResultPage resultPage) | SmfMusicSearch | [signal]
trackInfo(SmfMusicFingerPrint signature, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicSearch |
trackSearchAvailable(SmfTrackInfoList *result, SmfError error, SmfResultPage resultPage) | SmfMusicSearch | [signal]
tracksOfAlbum(SmfAlbum album, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicSearch |
tracksOfArtist(SmfArtists artists, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicSearch |
tracksSimilar(SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicSearch |
~SmfMusicSearch() | SmfMusicSearch |
Generated on Thu Sep 23 15:03:41 2010 for smf by doxygen 1.6.3


smf: SmfMusicSearchPlugin Class Reference

SmfMusicSearchPlugin Class Reference
[Plugin Classes]

#include <smfmusicsearchplugin.h>

Inherits SmfPluginBase.

Inherited by LastFmMusicSearchPlugin.

List of all members.

Public Member Functions

virtual | ~SmfMusicSearchPlugin ()
virtual SmfPluginError | recommendations (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | tracksSimilar (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | tracksOfAlbum (SmfPluginRequestData &aRequest, const SmfAlbum &aAlbum, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | tracksOfArtist (SmfPluginRequestData &aRequest, const SmfArtists &aArtist, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | trackInfo (SmfPluginRequestData &aRequest, const SmfMusicFingerPrint &aSignature, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | stores (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Interface specification for music search services

Interface specification for music search services. This class provides basic functionality to allow applications to search for tracks, get recommented tracks etc

All of the functionality described here should be implemented by a service specific plug-in.

Constructor & Destructor Documentation

virtual SmfMusicSearchPlugin::~SmfMusicSearchPlugin ( ) [inline, virtual]

Destructor

Member Function Documentation

virtual SmfPluginError SmfMusicSearchPlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [pure virtual]

Customised method for SmfMusicSearchPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | [in] The operation type (should be known between the client interface and the plugin)
aData | [in] The data required to form the request (The type of data should be known between client and the plugin)
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicSearchPlugin.

virtual SmfPluginError SmfMusicSearchPlugin::recommendations | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get recommended tracks

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | [in] The track for which similar recommendations need to be fetched.
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicSearchPlugin.

virtual SmfPluginError SmfMusicSearchPlugin::stores | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to search information about where to buy this song from

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | [in] The track for which stores need to be searched
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicSearchPlugin.

virtual SmfPluginError SmfMusicSearchPlugin::trackInfo | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfMusicFingerPrint & | aSignature,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get tracks having a similar finger print

Parameters:
aRequest | [out] The request data to be sent to network
aSignature | [in] The finger print to be searched for need to be fetched.
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicSearchPlugin.

virtual SmfPluginError SmfMusicSearchPlugin::tracksOfAlbum | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfAlbum & | aAlbum,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to search for tracks of a given album

Parameters:
aRequest | [out] The request data to be sent to network
aAlbum | [in] The album whose tracks need to be fetched.
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicSearchPlugin.

virtual SmfPluginError SmfMusicSearchPlugin::tracksOfArtist | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfArtists & | aArtist,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to search for tracks of the given artist(s)

Parameters:
aRequest | [out] The request data to be sent to network
aArtist | [in] The artist(s) whose tracks need to be fetched.
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicSearchPlugin.

virtual SmfPluginError SmfMusicSearchPlugin::tracksSimilar | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to search for tracks similar to a given track

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | [in] The track for which similar tracks need to be fetched.
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicSearchPlugin.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfserver/smfplugins/smfmusicsearchplugin.h
Generated on Thu Sep 23 15:03:41 2010 for smf by doxygen 1.6.3


smf: Member List

SmfMusicSearchPlugin Member List

This is the complete list of members for SmfMusicSearchPlugin, including all inherited members.
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0 | SmfMusicSearchPlugin | [pure virtual]
getProviderInfo()=0 | SmfPluginBase | [pure virtual]
initialize()=0 | SmfPluginBase | [pure virtual]
recommendations(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfMusicSearchPlugin | [pure virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aReply, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)=0 | SmfPluginBase | [pure virtual]
stores(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfMusicSearchPlugin | [pure virtual]
trackInfo(SmfPluginRequestData &aRequest, const SmfMusicFingerPrint &aSignature, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfMusicSearchPlugin | [pure virtual]
tracksOfAlbum(SmfPluginRequestData &aRequest, const SmfAlbum &aAlbum, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfMusicSearchPlugin | [pure virtual]
tracksOfArtist(SmfPluginRequestData &aRequest, const SmfArtists &aArtist, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfMusicSearchPlugin | [pure virtual]
tracksSimilar(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfMusicSearchPlugin | [pure virtual]
~SmfMusicSearchPlugin() | SmfMusicSearchPlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:42 2010 for smf by doxygen 1.6.3


smf: SmfMusicSearchPrivate Class Reference

SmfMusicSearchPrivate Class Reference

Inherits smfObserver.

List of all members.

Public Member Functions

SmfMusicSearchPrivate (SmfMusicSearch *aMusicSearch)
~SmfMusicSearchPrivate ()
SmfError | recommendations (SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | tracksSimilar (SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | tracksOfAlbum (SmfAlbum album, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | tracksOfArtist (SmfArtists artists, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | trackInfo (SmfMusicFingerPrint signature, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | stores (SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()
void | resultsAvailable (QByteArray result, SmfRequestTypeID opcode, SmfError error)

Friends

class | SmfClientQt

Constructor & Destructor Documentation

SmfMusicSearchPrivate::SmfMusicSearchPrivate ( SmfMusicSearch * aMusicSearch )

Constructor

SmfMusicSearchPrivate::~SmfMusicSearchPrivate ( )

Constructor

Member Function Documentation

SmfError SmfMusicSearchPrivate::cancelRequest ( )

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
SmfError SmfMusicSearchPrivate::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData
 | ) |  |

Request for a custom operation. The signal customDataAvailable() is emitted when the result is available.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfNoError if success, else appropriate error value Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data

:-revisit all the maxalloc

SmfError SmfMusicSearchPrivate::recommendations | ( | SmfTrackInfo | track,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for music recommendations similar to a particulartrack asynchronously. The signal trackSearchAvailable() is emitted with SmfTrackInfoList once its arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
track | The track for which similar recommendations need to be fetched.
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
void SmfMusicSearchPrivate::resultsAvailable | ( | QByteArray | result,
 |  | SmfRequestTypeID | opcode,
 |  | SmfError | error |
 | ) |  |  | [virtual]

To notify availibility of asynchronous requests.

Parameters:
result | Requested result, before using must check error param.
opcode | Requested opcode, for which the result has arrived.
error | Error

Implements smfObserver.

SmfError SmfMusicSearchPrivate::stores | ( | SmfTrackInfo | track,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Search information about where to buy this song from asynchronously. The signal storeSearchAvailable() is emitted with SmfProviderList once its arrived.

Parameters:
track | The search criteria for stores
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value

:-revisit all the maxalloc

SmfError SmfMusicSearchPrivate::trackInfo | ( | SmfMusicFingerPrint | signature,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for a track having similar finger print asynchronously. The signal trackSearchAvailable() is emitted with SmfTrackInfoList once its arrived.

Parameters:
signature | The search criteria,signature to be searched for
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
SmfError SmfMusicSearchPrivate::tracksOfAlbum | ( | SmfAlbum | album,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for tracks for a given album asynchronously. The signal trackSearchAvailable() is emitted with SmfTrackInfoList once its arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
album | The album containing the id
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
SmfError SmfMusicSearchPrivate::tracksOfArtist | ( | SmfArtists | artists,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for tracks for a given artist(s) asynchronously. The signal trackSearchAvailable() is emitted with SmfTrackInfoList once its arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
artists | The artists list
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
SmfError SmfMusicSearchPrivate::tracksSimilar | ( | SmfTrackInfo | track,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Searches for tracks similar to a given track asynchronously. The signal trackSearchAvailable() is emitted with SmfTrackInfoList once its arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
track | The search criteria, similar tracks are searched
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfmusic_p.h
  • smf/smfservermodule/smfclient/smfmusic_p.cpp
Generated on Thu Sep 23 15:03:42 2010 for smf by doxygen 1.6.3


smf: Member List

SmfMusicSearchPrivate Member List

This is the complete list of members for SmfMusicSearchPrivate, including all inherited members.
cancelRequest() | SmfMusicSearchPrivate |
customRequest(const int &operationId, QByteArray *customData) | SmfMusicSearchPrivate |
recommendations(SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicSearchPrivate |
resultsAvailable(QByteArray result, SmfRequestTypeID opcode, SmfError error) | SmfMusicSearchPrivate | [virtual]
SmfClientQt (defined in SmfMusicSearchPrivate) | SmfMusicSearchPrivate | [friend]
SmfMusicSearchPrivate(SmfMusicSearch *aMusicSearch) | SmfMusicSearchPrivate |
stores(SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicSearchPrivate |
trackInfo(SmfMusicFingerPrint signature, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicSearchPrivate |
tracksOfAlbum(SmfAlbum album, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicSearchPrivate |
tracksOfArtist(SmfArtists artists, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicSearchPrivate |
tracksSimilar(SmfTrackInfo track, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicSearchPrivate |
~SmfMusicSearchPrivate() | SmfMusicSearchPrivate |
Generated on Thu Sep 23 15:03:42 2010 for smf by doxygen 1.6.3


smf: SmfMusicService Class Reference

SmfMusicService Class Reference
[Client Classes]

#include <smfmusic.h>

List of all members.

Public Slots

SmfError | userMusicInfo ()
SmfError | searchArtist (SmfArtists artist, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | searchAlbum (SmfAlbum album, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | searchEvents (SmfEvent event, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | searchVenue (SmfLocation location, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | searchUser (SmfLocation venue, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | postCurrentPlaying (SmfTrackInfo track)
SmfError | postRating (SmfTrackInfo track, SmfMusicRating rate)
SmfError | postComments (SmfTrackInfo track, SmfComment comment)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()

Signals

void | userMusicInfoAvailable (SmfMusicProfile *profile, SmfError error)
void | searchUserInfoAvailable (SmfMusicProfileList *profileList, SmfError error, SmfResultPage resultPage)
void | searchArtistInfoAvailable (QList< SmfArtists > *artists, SmfError error, SmfResultPage resultPage)
void | searchAlbumInfoAvailable (QList< SmfAlbum > *albumList, SmfError error, SmfResultPage resultPage)
void | searchEventsInfoAvailable (SmfEventList *eventList, SmfError error, SmfResultPage resultPage)
void | searchVenueInfoAvailable (SmfLocationList *venueList, SmfError error, SmfResultPage resultPage)
void | customDataAvailable (const int &operationId, QByteArray *customData)
void | postfinished (SmfError error)

Public Member Functions

SmfMusicService (SmfProvider *baseProvider=0)
~SmfMusicService ()

Friends

class | SmfMusicServicePrivate

Detailed Description

Basic music service ("org.symbian.smf.client.music.service") This is the music profile information of a user in this service. Also provides searching on music meta information like albums artists etc. For searching for actual music/tracks use ("org.symbian.smf.client.music.search") interface from this service provider For usual contact information (like address, nickname, friends etc) please use ("org.symbian.smf.client.contact.fetcher") interface from this service provider

Constructor & Destructor Documentation

SmfMusicService::SmfMusicService ( SmfProvider * baseProvider = 0 )

Constructs SmfMusicService.

Parameters:
baseProvider The base provider info

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Music related services

SmfMusicService::~SmfMusicService ( )

Destructor

Member Function Documentation

SmfError SmfMusicService::cancelRequest ( ) [slot]

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
void SmfMusicService::customDataAvailable | ( | const int & | operationId,
 |  | QByteArray * | customData |
 | ) |  |  | [signal]

Signals availability of the result of the customRequest

Parameters:
operationId | The ID to be shared between clients and the plugin
customData | data
SmfError SmfMusicService::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData |
 | ) |  |  | [slot]

Request for a custom operation. The signal customDataAvailable() is emitted when the result is available.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfError. SmfNoError if success, else appropriate error code Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
SmfError SmfMusicService::postComments | ( | SmfTrackInfo | track,
 |  | SmfComment | comment |
 | ) |  |  | [slot]

Comment on a track via this API Success can be checked by checking the signal postFinished()

Parameters:
track | Track on which comment should be posted
comment | The comemnt to be posted
Returns:
SmfError, SmfNoError if success, else appropriate error value
SmfError SmfMusicService::postCurrentPlaying ( SmfTrackInfo track ) [slot]

Posts currently playing track. Success can be checked by checking the signal postFinished()

Parameters:
track Track to post
Returns:
SmfError, SmfNoError if success, else appropriate error value
void SmfMusicService::postfinished ( SmfError error ) [signal]

Signals availability of the result of the posting a track or a comment or a rating

Parameters:
error SmfNoError if success, else appropriate error value
SmfError SmfMusicService::postRating | ( | SmfTrackInfo | track,
 |  | SmfMusicRating | rate |
 | ) |  |  | [slot]

Rate a music via this API Success can be checked by checking the signal postFinished()

Parameters:
track | Track on which rating should be posted
rate | Rating value
Returns:
SmfError, SmfNoError if success, else appropriate error value
SmfError SmfMusicService::searchAlbum | ( | SmfAlbum | album,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [slot]

Asynchronously searches information about albums in this service. All information in SmfAlbum is not required, however more available the better searchAlbumInfoAvailable() signal is emitted when the info is arrived.

Parameters:
album | The search criteria
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError, SmfNoError if success, else appropriate error value
void SmfMusicService::searchAlbumInfoAvailable | ( | QList< SmfAlbum > * | albumList,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Notification on arrival of search info

Parameters:
albumList | List of albums
error | SmfNoError if success, else appropriate error value
SmfError SmfMusicService::searchArtist | ( | SmfArtists | artist,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [slot]

Asynchronously searches information about artists in this service. All information in SmfArtists is not required, however more available the better searchArtistInfoAvailable() signal is emitted when the info is arrived.

Parameters:
artist | The search criteria
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError, SmfNoError if success, else appropriate error value
void SmfMusicService::searchArtistInfoAvailable | ( | QList< SmfArtists > * | artists,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Notification on arrival of search info

Parameters:
artists | List of artists
error | SmfNoError if success, else appropriate error value
SmfError SmfMusicService::searchEvents | ( | SmfEvent | event,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [slot]

Asynchronously searches information about events in this service. All information in SmfEvents is not required, however more available the better searchEventsInfoAvailable() signal is emitted when the info is arrived.

Parameters:
event | The search criteria
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError, SmfNoError if success, else appropriate error value
void SmfMusicService::searchEventsInfoAvailable | ( | SmfEventList * | eventList,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Notification on arrival of search info

Parameters:
eventList | List of events
error | SmfNoError if success, else appropriate error value
SmfError SmfMusicService::searchUser | ( | SmfLocation | venue,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [slot]

Asynchronously searches information about other service users for a particular venue searchUserInfoAvailable() signal is emitted with SmfMusicProfileList when the info is arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
location | The search criteria
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError, SmfNoError if success, else appropriate error value
void SmfMusicService::searchUserInfoAvailable | ( | SmfMusicProfileList * | profileList,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Notification on arrival of search info

Parameters:
profileList | List of music profiles
error | SmfNoError if success, else appropriate error value
SmfError SmfMusicService::searchVenue | ( | SmfLocation | location,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [slot]

Asynchronously searches information about venue in this service. All information in SmfVenue is not required, however more available the better searchVenueInfoAvailable() signal is emitted when the info is arrived.

Parameters:
location | The search criteria
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError, SmfNoError if success, else appropriate error value
void SmfMusicService::searchVenueInfoAvailable | ( | SmfLocationList * | venueList,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Notification on arrival of search info

Parameters:
venueList | List of venues
error | SmfNoError if success, else appropriate error value
SmfError SmfMusicService::userMusicInfo ( ) [slot]

Gets self profile information (e.g. music likings, feavorites etc) asynchronously. userMusicInfoAvailable() signal is emitted with SmfMusicProfile when the info is arrived

Returns:
SmfError. SmfNoError if success, else appropriate error code
void SmfMusicService::userMusicInfoAvailable | ( | SmfMusicProfile * | profile,
 |  | SmfError | error |
 | ) |  |  | [signal]

Notification on arrival of the self profile as result of userinfo().

Parameters:
profile | The self profile
error | SmfNoError if success, else appropriate error value
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfmusic.h
  • smf/smfservermodule/smfclient/smfmusic.cpp
Generated on Thu Sep 23 15:03:42 2010 for smf by doxygen 1.6.3


smf: Member List

SmfMusicService Member List

This is the complete list of members for SmfMusicService, including all inherited members.
cancelRequest() | SmfMusicService | [slot]
customDataAvailable(const int &operationId, QByteArray *customData) | SmfMusicService | [signal]
customRequest(const int &operationId, QByteArray *customData) | SmfMusicService | [slot]
postComments(SmfTrackInfo track, SmfComment comment) | SmfMusicService | [slot]
postCurrentPlaying(SmfTrackInfo track) | SmfMusicService | [slot]
postfinished(SmfError error) | SmfMusicService | [signal]
postRating(SmfTrackInfo track, SmfMusicRating rate) | SmfMusicService | [slot]
searchAlbum(SmfAlbum album, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicService | [slot]
searchAlbumInfoAvailable(QList< SmfAlbum > *albumList, SmfError error, SmfResultPage resultPage) | SmfMusicService | [signal]
searchArtist(SmfArtists artist, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicService | [slot]
searchArtistInfoAvailable(QList< SmfArtists > *artists, SmfError error, SmfResultPage resultPage) | SmfMusicService | [signal]
searchEvents(SmfEvent event, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicService | [slot]
searchEventsInfoAvailable(SmfEventList *eventList, SmfError error, SmfResultPage resultPage) | SmfMusicService | [signal]
searchUser(SmfLocation venue, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicService | [slot]
searchUserInfoAvailable(SmfMusicProfileList *profileList, SmfError error, SmfResultPage resultPage) | SmfMusicService | [signal]
searchVenue(SmfLocation location, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicService | [slot]
searchVenueInfoAvailable(SmfLocationList *venueList, SmfError error, SmfResultPage resultPage) | SmfMusicService | [signal]
SmfMusicService(SmfProvider *baseProvider=0) | SmfMusicService |
SmfMusicServicePrivate (defined in SmfMusicService) | SmfMusicService | [friend]
userMusicInfo() | SmfMusicService | [slot]
userMusicInfoAvailable(SmfMusicProfile *profile, SmfError error) | SmfMusicService | [signal]
~SmfMusicService() | SmfMusicService |
Generated on Thu Sep 23 15:03:42 2010 for smf by doxygen 1.6.3


smf: SmfMusicServicePlugin Class Reference

SmfMusicServicePlugin Class Reference
[Plugin Classes]

#include <smfmusicserviceplugin.h>

Inherits SmfPluginBase.

Inherited by LastFmMusicServicePlugin.

List of all members.

Public Member Functions

virtual | ~SmfMusicServicePlugin ()
virtual SmfPluginError | userMusicInfo (SmfPluginRequestData &aRequest)=0
virtual SmfPluginError | searchArtist (SmfPluginRequestData &aRequest, const SmfArtists &aArtist, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | searchAlbum (SmfPluginRequestData &aRequest, const SmfAlbum &aAlbum, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | searchEvents (SmfPluginRequestData &aRequest, const SmfEvent &aEvent, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | searchVenue (SmfPluginRequestData &aRequest, const SmfLocation &aVenue, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | searchUser (SmfPluginRequestData &aRequest, const SmfLocation &aPlace, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | postCurrentPlaying (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack)=0
virtual SmfPluginError | postRating (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const SmfMusicRating &aRating)=0
virtual SmfPluginError | postComments (SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const SmfComment &aComment)=0
virtual SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Interface specification for music services

Interface specification for music services. This class provides basic functionality to allow application to search for a user or check for user information etc.

All of the functionality described here should be implemented by a service specific plug-in.

Constructor & Destructor Documentation

virtual SmfMusicServicePlugin::~SmfMusicServicePlugin ( ) [inline, virtual]

Destructor

Member Function Documentation

virtual SmfPluginError SmfMusicServicePlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [pure virtual]

Customised method for SmfMusicServicePlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | [in] The operation type (should be known between the client interface and the plugin)
aData | [in] The data required to form the request (The type of data should be known between client and the plugin)
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicServicePlugin.

virtual SmfPluginError SmfMusicServicePlugin::postComments | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack,
 |  | const SmfComment & | aComment |
 | ) |  |  | [pure virtual]

Method to post comment on a track

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | [in] The track on which comment should be posted
aComment | [in] The comment content
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicServicePlugin.

virtual SmfPluginError SmfMusicServicePlugin::postCurrentPlaying | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack |
 | ) |  |  | [pure virtual]

Method to post the currently playing track

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | [in] The current playing track, that should be posted
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicServicePlugin.

virtual SmfPluginError SmfMusicServicePlugin::postRating | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfTrackInfo & | aTrack,
 |  | const SmfMusicRating & | aRating |
 | ) |  |  | [pure virtual]

Method to post the rating on a track

Parameters:
aRequest | [out] The request data to be sent to network
aTrack | [in] The track on which rating should be posted
aRating | [in] The rating values
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicServicePlugin.

virtual SmfPluginError SmfMusicServicePlugin::searchAlbum | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfAlbum & | aAlbum,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to search information about album. All information in SmfAlbum is not required, however more available the better

Parameters:
aRequest | [out] The request data to be sent to network
aAlbum | [in] The album which is the search criteria
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicServicePlugin.

virtual SmfPluginError SmfMusicServicePlugin::searchArtist | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfArtists & | aArtist,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to search information about artists. All information in SmfArtists is not required, however more available the better

Parameters:
aRequest | [out] The request data to be sent to network
aArtist | The artist which is the search criteria
aPageNum | The page to be extracted
aItemsPerPage | Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicServicePlugin.

virtual SmfPluginError SmfMusicServicePlugin::searchEvents | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfEvent & | aEvent,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to search information about events. All information in SmfEvent is not required, however more available the better

Parameters:
aRequest | [out] The request data to be sent to network
aEvent | [in] The event which is the search criteria
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicServicePlugin.

virtual SmfPluginError SmfMusicServicePlugin::searchUser | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfLocation & | aPlace,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to search information about other service users for a particular place

Parameters:
aRequest | [out] The request data to be sent to network
aPlace | [in] The place which is the search criteria
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicServicePlugin.

virtual SmfPluginError SmfMusicServicePlugin::searchVenue | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfLocation & | aVenue,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to search information about venue. All information in SmfLocation is not required, however more available the better

Parameters:
aRequest | [out] The request data to be sent to network
aVenue | [in] The venue which is the search criteria
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicServicePlugin.

virtual SmfPluginError SmfMusicServicePlugin::userMusicInfo ( SmfPluginRequestData & aRequest ) [pure virtual]

Method to get self profile information

Parameters:
aRequest [out] The request data to be sent to network
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmMusicServicePlugin.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfserver/smfplugins/smfmusicserviceplugin.h
Generated on Thu Sep 23 15:03:42 2010 for smf by doxygen 1.6.3


smf: Member List

SmfMusicServicePlugin Member List

This is the complete list of members for SmfMusicServicePlugin, including all inherited members.
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0 | SmfMusicServicePlugin | [pure virtual]
getProviderInfo()=0 | SmfPluginBase | [pure virtual]
initialize()=0 | SmfPluginBase | [pure virtual]
postComments(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const SmfComment &aComment)=0 | SmfMusicServicePlugin | [pure virtual]
postCurrentPlaying(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack)=0 | SmfMusicServicePlugin | [pure virtual]
postRating(SmfPluginRequestData &aRequest, const SmfTrackInfo &aTrack, const SmfMusicRating &aRating)=0 | SmfMusicServicePlugin | [pure virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aReply, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)=0 | SmfPluginBase | [pure virtual]
searchAlbum(SmfPluginRequestData &aRequest, const SmfAlbum &aAlbum, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfMusicServicePlugin | [pure virtual]
searchArtist(SmfPluginRequestData &aRequest, const SmfArtists &aArtist, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfMusicServicePlugin | [pure virtual]
searchEvents(SmfPluginRequestData &aRequest, const SmfEvent &aEvent, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfMusicServicePlugin | [pure virtual]
searchUser(SmfPluginRequestData &aRequest, const SmfLocation &aPlace, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfMusicServicePlugin | [pure virtual]
searchVenue(SmfPluginRequestData &aRequest, const SmfLocation &aVenue, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfMusicServicePlugin | [pure virtual]
userMusicInfo(SmfPluginRequestData &aRequest)=0 | SmfMusicServicePlugin | [pure virtual]
~SmfMusicServicePlugin() | SmfMusicServicePlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:42 2010 for smf by doxygen 1.6.3


smf: SmfMusicServicePrivate Class Reference

SmfMusicServicePrivate Class Reference

Inherits smfObserver.

List of all members.

Public Member Functions

SmfMusicServicePrivate (SmfMusicService *aMusicService)
~SmfMusicServicePrivate ()
SmfError | userMusicInfo ()
SmfError | searchArtist (SmfArtists artist, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | searchAlbum (SmfAlbum album, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | searchEvents (SmfEvent event, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | searchVenue (SmfLocation location, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | searchUser (SmfLocation venue, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | postCurrentPlaying (SmfTrackInfo track)
SmfError | postRating (SmfTrackInfo track, SmfMusicRating rate)
SmfError | postComments (SmfTrackInfo track, SmfComment comment)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()
void | resultsAvailable (QByteArray result, SmfRequestTypeID opcode, SmfError error)

Friends

class | SmfClientQt

Constructor & Destructor Documentation

SmfMusicServicePrivate::SmfMusicServicePrivate ( SmfMusicService * aMusicService )

Constructor

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private implementation of music related services

SmfMusicServicePrivate::~SmfMusicServicePrivate ( )

Destructor

Member Function Documentation

SmfError SmfMusicServicePrivate::cancelRequest ( )

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
SmfError SmfMusicServicePrivate::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData
 | ) |  |

Request for a custom operation. The signal customDataAvailable() is emitted when the result is available.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfError. SmfNoError if success, else appropriate error code Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
SmfError SmfMusicServicePrivate::postComments | ( | SmfTrackInfo | track,
 |  | SmfComment | comment
 | ) |  |

Comment on a track via this API Success can be checked by checking the signal postFinished()

Parameters:
track | Track on which comment should be posted
comment | The comemnt to be posted
Returns:
SmfError, SmfNoError if success, else appropriate error value
SmfError SmfMusicServicePrivate::postCurrentPlaying ( SmfTrackInfo track )

Posts currently playing track. Success can be checked by checking the signal postFinished()

Parameters:
track Track to post
Returns:
SmfError, SmfNoError if success, else appropriate error value
SmfError SmfMusicServicePrivate::postRating | ( | SmfTrackInfo | track,
 |  | SmfMusicRating | rate
 | ) |  |

Rate a music via this API Success can be checked by checking the signal postFinished()

Parameters:
track | Track on which rating should be posted
rate | Rating value
Returns:
SmfError, SmfNoError if success, else appropriate error value
void SmfMusicServicePrivate::resultsAvailable | ( | QByteArray | result,
 |  | SmfRequestTypeID | opcode,
 |  | SmfError | error |
 | ) |  |  | [virtual]

To notify availibility of asynchronous requests.

Parameters:
result | Requested result, before using must check error param.
opcode | Requested opcode, for which the result has arrived.
error | Error

Implements smfObserver.

SmfError SmfMusicServicePrivate::searchAlbum | ( | SmfAlbum | album,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Asynchronously searches information about albums in this service. All information in SmfAlbum is not required, however more available the better searchAlbumInfoAvailable() signal is emitted when the info is arrived.

Parameters:
album | The search criteria
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError, SmfNoError if success, else appropriate error value
SmfError SmfMusicServicePrivate::searchArtist | ( | SmfArtists | artist,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Asynchronously searches information about artisits in this service. All information in SmfArtists is not required, however more available the better searchArtistInfoAvailable() signal is emitted when the info is arrived.

Parameters:
artist | The search criteria
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError, SmfNoError if success, else appropriate error value
SmfError SmfMusicServicePrivate::searchEvents | ( | SmfEvent | event,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Asynchronously searches information about events in this service. All information in SmfEvents is not required, however more available the better searchEventsInfoAvailable() signal is emitted when the info is arrived.

Parameters:
event | The search criteria
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError, SmfNoError if success, else appropriate error value
SmfError SmfMusicServicePrivate::searchUser | ( | SmfLocation | venue,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Asynchronously searches information about other service users for a particular venue searchUserInfoAvailable() signal is emitted with SmfMusicProfileList when the info is arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
location | The search criteria
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError, SmfNoError if success, else appropriate error value
SmfError SmfMusicServicePrivate::searchVenue | ( | SmfLocation | location,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Asynchronously searches information about venue in this service. All information in SmfVenue is not required, however more available the better searchVenueInfoAvailable() signal is emitted when the info is arrived.

Parameters:
location | The search criteria
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError, SmfNoError if success, else appropriate error value
SmfError SmfMusicServicePrivate::userMusicInfo ( )

Gets self profile information (e.g. music likings, feavorites etc) asynchronously. userMusicInfoAvailable() signal is emitted with SmfMusicProfile when the info is arrived

Returns:
SmfError. SmfNoError if success, else appropriate error code
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfmusic_p.h
  • smf/smfservermodule/smfclient/smfmusic_p.cpp
Generated on Thu Sep 23 15:03:43 2010 for smf by doxygen 1.6.3


smf: Member List

SmfMusicServicePrivate Member List

This is the complete list of members for SmfMusicServicePrivate, including all inherited members.
cancelRequest() | SmfMusicServicePrivate |
customRequest(const int &operationId, QByteArray *customData) | SmfMusicServicePrivate |
postComments(SmfTrackInfo track, SmfComment comment) | SmfMusicServicePrivate |
postCurrentPlaying(SmfTrackInfo track) | SmfMusicServicePrivate |
postRating(SmfTrackInfo track, SmfMusicRating rate) | SmfMusicServicePrivate |
resultsAvailable(QByteArray result, SmfRequestTypeID opcode, SmfError error) | SmfMusicServicePrivate | [virtual]
searchAlbum(SmfAlbum album, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicServicePrivate |
searchArtist(SmfArtists artist, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicServicePrivate |
searchEvents(SmfEvent event, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicServicePrivate |
searchUser(SmfLocation venue, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicServicePrivate |
searchVenue(SmfLocation location, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfMusicServicePrivate |
SmfClientQt (defined in SmfMusicServicePrivate) | SmfMusicServicePrivate | [friend]
SmfMusicServicePrivate(SmfMusicService *aMusicService) | SmfMusicServicePrivate |
userMusicInfo() | SmfMusicServicePrivate |
~SmfMusicServicePrivate() | SmfMusicServicePrivate |
Generated on Thu Sep 23 15:03:43 2010 for smf by doxygen 1.6.3


smf: smfObserver Class Reference

smfObserver Class Reference

#include <smfobserver.h>

Inherited by SmfActivityFetcherPrivate, SmfClientPrivate, SmfContactFetcherPrivate, SmfEventsFetcherPrivate, SmfGalleryPrivate, SmfLyricsServicePrivate, SmfMusicSearchPrivate, SmfMusicServicePrivate, SmfPlaylistServicePrivate, and SmfPostProviderPrivate.

List of all members.

Public Member Functions

virtual void resultsAvailable (QByteArray result, SmfRequestTypeID opcode, SmfError error)=0

Detailed Description

Observer class to notify availability of asynchronous requests

Member Function Documentation

virtual void smfObserver::resultsAvailable | ( | QByteArray | result,
 |  | SmfRequestTypeID | opcode,
 |  | SmfError | error |
 | ) |  |  | [pure virtual]

To notify availibility of asynchronous requests.

Parameters:
result | Requested result, before using must check error param.
opcode | Requested opcode, for which the result has arrived.
error | Error

Implemented in SmfActivityFetcherPrivate, SmfClientPrivate, SmfContactFetcherPrivate, SmfEventsFetcherPrivate, SmfGalleryPrivate, SmfMusicServicePrivate, SmfMusicSearchPrivate, SmfPlaylistServicePrivate, SmfLyricsServicePrivate, and SmfPostProviderPrivate.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfobserver.h
Generated on Thu Sep 23 15:03:43 2010 for smf by doxygen 1.6.3


smf: Member List

smfObserver Member List

This is the complete list of members for smfObserver, including all inherited members.
resultsAvailable(QByteArray result, SmfRequestTypeID opcode, SmfError error)=0 smfObserver [pure virtual]
Generated on Thu Sep 23 15:03:43 2010 for smf by doxygen 1.6.3


smf: SmfPicture Class Reference

SmfPicture Class Reference
[Common Data Classes]

#include <smfpicture.h>

List of all members.

Public Member Functions

SmfPicture ()
SmfPicture (const SmfPicture &aOther)
SmfPicture (const QImage &aImage)
SmfPicture & | operator= (const SmfPicture &aOther)
~SmfPicture ()
QString | owner () const
QString | title () const
QString | description () const
SmfPictureVisibility | visibility () const
QDateTime | postedDate () const
QList< SmfComment > | comments () const
QStringList | tags () const
QUrl | url () const
QImage | picture () const
QString | id () const
bool | downloadFlag ()
void | setOwner (const QString &aOwner)
void | setTitle (const QString &aTitle)
void | setDescription (const QString &aDescription)
void | setVisibility (const SmfPictureVisibility &aVisibility)
void | setPostedDate (const QDateTime &aDate)
void | addComment (const SmfComment &aComment)
void | addTags (const QStringList &aTags)
void | setUrl (const QUrl &aUrl)
void | setPicture (const QImage &aData)
void | setId (const QString &aId)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfPicture &aPic)
QDataStream & | operator>> (QDataStream &aDataStream, SmfPicture &aPic)

Detailed Description

The picture class represents an instance of a picture

Constructor & Destructor Documentation

SmfPicture::SmfPicture ( )

Constructor with default argument.

Parameters:
aDownloaded This flag is to know whether the content is downloaded in the device(if true). If false it signifies that SmfPicture contains a link/url to the location of the content

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The picture class represents an instance of a picture Constructor with default argument

SmfPicture::SmfPicture ( const SmfPicture & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfPicture::SmfPicture ( const QImage & aImage )

CConstructs SmfPicture from QImage

Parameters:
aImage The QImage

CConstructs SmfPicture from QImage

Parameters:
aOther The QImage
SmfPicture::~SmfPicture ( )

Destructor

Member Function Documentation

void SmfPicture::addComment ( const SmfComment & aComment )

Method to add comment on the picture

Parameters:
aComment The comment for the picture
void SmfPicture::addTags ( const QStringList & aTags )

Method to add tags for the picture

Parameters:
aTag The tag for the picture
QList< SmfComment > SmfPicture::comments ( ) const

Method to get the comments for the picture

Returns:
The comments for the picture
QString SmfPicture::description ( ) const

Method to get a picture description

Returns:
The description of the picture
bool SmfPicture::downloadFlag ( )

Gets download flag. This flag is to know whether the content is downloaded in the device(if true). If false it signifies that SmfPicture contains a link/url to the location of the content

QString SmfPicture::id ( ) const

Method to get the id of the picture

Returns:
The ID value
SmfPicture & SmfPicture::operator= ( const SmfPicture & aOther )

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The current object reference

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
QString SmfPicture::owner ( ) const

Method to get a picture owner

Returns:
The owner of the picture
QImage SmfPicture::picture ( ) const

Method to get the picture data as QImage

Returns:
The picture as QImage
QDateTime SmfPicture::postedDate ( ) const

Method to get the date of posting the picture

Returns:
The posted date of the picture
void SmfPicture::setDescription ( const QString & aDescription )

Method to set a picture description

Parameters:
aDescription The description of the picture
void SmfPicture::setId ( const QString & aId )

Method to set the id of the picture

Parameters:
aId The ID value
void SmfPicture::setOwner ( const QString & aOwner )

Method to set a picture owner

Parameters:
aOwner The owner of the picture
void SmfPicture::setPicture ( const QImage & aData )

Method to set the picture data as QImage

Parameters:
aData The picture as QImage
void SmfPicture::setPostedDate ( const QDateTime & aDate )

Method to set the date of posting the picture

Parameters:
aDate The post date of the picture
void SmfPicture::setTitle ( const QString & aTitle )

Method to set a picture title

Parameters:
aTitle The title of the picture
void SmfPicture::setUrl ( const QUrl & aUrl )

Method to set the url of the picture

Parameters:
aUrl The url of the picture
void SmfPicture::setVisibility ( const SmfPictureVisibility & aVisibility )

Method to set a visibility of a picture for public

Parameters:
aVisibility aVisibility The visibility mode of this picture for others
QStringList SmfPicture::tags ( ) const

Method to get the tags for the picture

Returns:
The tags for the picture
QString SmfPicture::title ( ) const

Method to get a picture title

Returns:
The title of the picture
QUrl SmfPicture::url ( ) const

Method to get the url of the picture

Returns:
The url of the picture
SmfPictureVisibility SmfPicture::visibility ( ) const

Method to get a visibility of a picture for public

Returns:
The visibility mode of this picture for others

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfPicture & | aPic |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfPicture object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aPic | The SmfPicture object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfPicture & | aPic |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfPicture object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aPic | The SmfPicture object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfpicture.h
  • smf/smfservermodule/smfcommon/smfpicture.cpp
Generated on Thu Sep 23 15:03:43 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPicture Member List

This is the complete list of members for SmfPicture, including all inherited members.
addComment(const SmfComment &aComment) | SmfPicture |
addTags(const QStringList &aTags) | SmfPicture |
comments() const | SmfPicture |
description() const | SmfPicture |
downloadFlag() | SmfPicture |
id() const | SmfPicture |
operator<<(QDataStream &aDataStream, const SmfPicture &aPic) | SmfPicture | [friend]
operator=(const SmfPicture &aOther) | SmfPicture |
operator>>(QDataStream &aDataStream, SmfPicture &aPic) | SmfPicture | [friend]
owner() const | SmfPicture |
picture() const | SmfPicture |
postedDate() const | SmfPicture |
setDescription(const QString &aDescription) | SmfPicture |
setId(const QString &aId) | SmfPicture |
setOwner(const QString &aOwner) | SmfPicture |
setPicture(const QImage &aData) | SmfPicture |
setPostedDate(const QDateTime &aDate) | SmfPicture |
setTitle(const QString &aTitle) | SmfPicture |
setUrl(const QUrl &aUrl) | SmfPicture |
setVisibility(const SmfPictureVisibility &aVisibility) | SmfPicture |
SmfPicture() | SmfPicture |
SmfPicture(const SmfPicture &aOther) | SmfPicture |
SmfPicture(const QImage &aImage) | SmfPicture |
tags() const | SmfPicture |
title() const | SmfPicture |
url() const | SmfPicture |
visibility() const | SmfPicture |
~SmfPicture() | SmfPicture |
Generated on Thu Sep 23 15:03:43 2010 for smf by doxygen 1.6.3


smf: SmfPictureAlbum Class Reference

SmfPictureAlbum Class Reference
[Common Data Classes]

#include <smfpicturealbum.h>

List of all members.

Public Member Functions

SmfPictureAlbum ()
SmfPictureAlbum (const SmfPictureAlbum &aOther)
SmfPictureAlbum & | operator= (const SmfPictureAlbum &aOther)
~SmfPictureAlbum ()
QString | title () const
QString | description () const
SmfPictureVisibility | visibility () const
QDateTime | postedDate () const
QList< SmfComment > | comments () const
QStringList | keywords () const
QUrl | url () const
QImage | thumbnail () const
qint32 | pictureCount () const
QString | id () const
void | setTitle (const QString &aTitle)
void | setDescription (const QString &aDescription)
void | setVisibility (const SmfPictureVisibility &aVisibility)
void | setPostedDate (const QDateTime &aDate)
void | addComment (const SmfComment &aComment)
void | addKeywords (const QStringList &aWords)
void | setUrl (const QUrl &aUrl)
void | setThumbnail (const QImage &aImage)
void | setPictureCount (const qint32 aCount)
void | setId (const QString &aId)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfPictureAlbum &aAlbm)
QDataStream & | operator>> (QDataStream &aDataStream, SmfPictureAlbum &aAlbm)

Detailed Description

album class represents an online picture album (collection)

Constructor & Destructor Documentation

SmfPictureAlbum::SmfPictureAlbum ( )

Constructor with default argument

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The album to contain a set pf pictures Constructor with default argument

SmfPictureAlbum::SmfPictureAlbum ( const SmfPictureAlbum & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfPictureAlbum::~SmfPictureAlbum ( )

Destructor

Member Function Documentation

void SmfPictureAlbum::addComment ( const SmfComment & aComment )

Method to add comment on the album

Parameters:
aComment The comment for the album
void SmfPictureAlbum::addKeywords ( const QStringList & aKeywords )

Method to add keywords for the album

Parameters:
aTag The tag for the album

Method to add tags for the album

Parameters:
aTag The tag for the album
QList< SmfComment > SmfPictureAlbum::comments ( ) const

Method to get the comments for the album

Returns:
The comments for the album
QString SmfPictureAlbum::description ( ) const

Method to get a album description

Returns:
The description of the album
QString SmfPictureAlbum::id ( ) const

Method to get the id of the album

Returns:
The ID value
QStringList SmfPictureAlbum::keywords ( ) const

Method to get the keywords for the album

Returns:
The keywords for the album

Method to get the tags for the album

Returns:
The tags for the album
SmfPictureAlbum & SmfPictureAlbum::operator= ( const SmfPictureAlbum & aOther )

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The current object reference

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
qint32 SmfPictureAlbum::pictureCount ( ) const

Method to get the number of pictures in this album

Returns:
number of pictures in this album

Method to get the album data as QImage

Returns:
The album as QImage
QDateTime SmfPictureAlbum::postedDate ( ) const

Method to get the date of posting the album

Returns:
The posted date of the album
void SmfPictureAlbum::setDescription ( const QString & aDescription )

Method to set a album description

Parameters:
aDescription The description of the album
void SmfPictureAlbum::setId ( const QString & aId )

Method to set the id of the album

Parameters:
aId The ID value
void SmfPictureAlbum::setPictureCount ( const qint32 aCount )

Method to get the number of pictures in this album

Returns:
number of pictures in this album
void SmfPictureAlbum::setPostedDate ( const QDateTime & aDate )

Method to set the date of posting the album

Parameters:
aDate The post date of the album
void SmfPictureAlbum::setThumbnail ( const QImage & aData )

Method to set the thumbnail for this album as QImage

Returns:
The picture as QImage

Method to set the album data as QImage

Parameters:
aData The album as QImage
void SmfPictureAlbum::setTitle ( const QString & aTitle )

Method to set a album title

Parameters:
aTitle The title of the album
void SmfPictureAlbum::setUrl ( const QUrl & aUrl )

Method to set the url of the album

Parameters:
aUrl The url of the album
void SmfPictureAlbum::setVisibility ( const SmfPictureVisibility & aVisibility )

Method to set a visibility of a album for public

Parameters:
aVisibility aVisibility The visibility mode of this album for others
QImage SmfPictureAlbum::thumbnail ( ) const

Method to get the thumbnail for this album as QImage

Returns:
The picture as QImage
QString SmfPictureAlbum::title ( ) const

Method to get a album title

Returns:
The title of the album
QUrl SmfPictureAlbum::url ( ) const

Method to get the url of the album

Returns:
The url of the album
SmfPictureVisibility SmfPictureAlbum::visibility ( ) const

Method to get a visibility of a album for public

Returns:
The visibility mode of this album for others

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfPictureAlbum & | aAlbm |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfPictureAlbum object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aPic | The SmfPictureAlbum object to be externalized
Returns:
reference to the written stream

Method for Externalization. Writes the SmfPictureAlbum object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aAlbm | The SmfPictureAlbum object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfPictureAlbum & | aAlbm |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfPictureAlbum object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aPic | The SmfPictureAlbum object to be internalized
Returns:
reference to the stream

Method for Internalization. Reads a SmfPictureAlbum object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aAlbm | The SmfPictureAlbum object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfpicturealbum.h
  • smf/smfservermodule/smfcommon/smfpicturealbum.cpp
Generated on Thu Sep 23 15:03:43 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPictureAlbum Member List

This is the complete list of members for SmfPictureAlbum, including all inherited members.
addComment(const SmfComment &aComment) | SmfPictureAlbum |
addKeywords(const QStringList &aWords) | SmfPictureAlbum |
comments() const | SmfPictureAlbum |
description() const | SmfPictureAlbum |
id() const | SmfPictureAlbum |
keywords() const | SmfPictureAlbum |
operator<<(QDataStream &aDataStream, const SmfPictureAlbum &aAlbm) | SmfPictureAlbum | [friend]
operator=(const SmfPictureAlbum &aOther) | SmfPictureAlbum |
operator>>(QDataStream &aDataStream, SmfPictureAlbum &aAlbm) | SmfPictureAlbum | [friend]
pictureCount() const | SmfPictureAlbum |
postedDate() const | SmfPictureAlbum |
setDescription(const QString &aDescription) | SmfPictureAlbum |
setId(const QString &aId) | SmfPictureAlbum |
setPictureCount(const qint32 aCount) | SmfPictureAlbum |
setPostedDate(const QDateTime &aDate) | SmfPictureAlbum |
setThumbnail(const QImage &aImage) | SmfPictureAlbum |
setTitle(const QString &aTitle) | SmfPictureAlbum |
setUrl(const QUrl &aUrl) | SmfPictureAlbum |
setVisibility(const SmfPictureVisibility &aVisibility) | SmfPictureAlbum |
SmfPictureAlbum() | SmfPictureAlbum |
SmfPictureAlbum(const SmfPictureAlbum &aOther) | SmfPictureAlbum |
thumbnail() const | SmfPictureAlbum |
title() const | SmfPictureAlbum |
url() const | SmfPictureAlbum |
visibility() const | SmfPictureAlbum |
~SmfPictureAlbum() | SmfPictureAlbum |
Generated on Thu Sep 23 15:03:43 2010 for smf by doxygen 1.6.3


smf: SmfPictureAlbumPrivate Class Reference

SmfPictureAlbumPrivate Class Reference

#include <smfpicturealbum_p.h>

List of all members.

Public Member Functions

SmfPictureAlbumPrivate ()
SmfPictureAlbumPrivate (const SmfPictureAlbumPrivate &aOther)
~SmfPictureAlbumPrivate ()

Public Attributes

QString | m_title
QString | m_description
SmfPictureVisibility | m_albumVisibility
QDateTime | m_postedOn
QList< SmfComment > | m_comments
QStringList | m_keywords
QUrl | m_url
QImage | m_thumbnail
quint32 | m_picCount
QString | m_albumId

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfPictureAlbum class

Constructor & Destructor Documentation

SmfPictureAlbumPrivate::SmfPictureAlbumPrivate ( ) [inline]

Constructor

SmfPictureAlbumPrivate::SmfPictureAlbumPrivate ( const SmfPictureAlbumPrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfPictureAlbumPrivate::~SmfPictureAlbumPrivate ( ) [inline]

Destructor

Member Data Documentation

QString SmfPictureAlbumPrivate::m_title

Member variables

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfpicturealbum_p.h
Generated on Thu Sep 23 15:03:43 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPictureAlbumPrivate Member List

This is the complete list of members for SmfPictureAlbumPrivate, including all inherited members.
m_albumId (defined in SmfPictureAlbumPrivate) | SmfPictureAlbumPrivate |
m_albumVisibility (defined in SmfPictureAlbumPrivate) | SmfPictureAlbumPrivate |
m_comments (defined in SmfPictureAlbumPrivate) | SmfPictureAlbumPrivate |
m_description (defined in SmfPictureAlbumPrivate) | SmfPictureAlbumPrivate |
m_keywords (defined in SmfPictureAlbumPrivate) | SmfPictureAlbumPrivate |
m_picCount (defined in SmfPictureAlbumPrivate) | SmfPictureAlbumPrivate |
m_postedOn (defined in SmfPictureAlbumPrivate) | SmfPictureAlbumPrivate |
m_thumbnail (defined in SmfPictureAlbumPrivate) | SmfPictureAlbumPrivate |
m_title | SmfPictureAlbumPrivate |
m_url (defined in SmfPictureAlbumPrivate) | SmfPictureAlbumPrivate |
SmfPictureAlbumPrivate() | SmfPictureAlbumPrivate | [inline]
SmfPictureAlbumPrivate(const SmfPictureAlbumPrivate &aOther) | SmfPictureAlbumPrivate | [inline]
~SmfPictureAlbumPrivate() | SmfPictureAlbumPrivate | [inline]
Generated on Thu Sep 23 15:03:43 2010 for smf by doxygen 1.6.3


smf: SmfPicturePrivate Class Reference

SmfPicturePrivate Class Reference

#include <smfpicture_p.h>

List of all members.

Public Member Functions

SmfPicturePrivate ()
SmfPicturePrivate (const QImage &aImage)
SmfPicturePrivate (const SmfPicturePrivate &aOther)
~SmfPicturePrivate ()

Public Attributes

QString | m_photoId
QString | m_owner
QString | m_title
QString | m_description
SmfPictureVisibility | m_picVisibility
QDateTime | m_postedOn
QList< SmfComment > | m_comments
QStringList | m_tags
QUrl | m_url
QImage | m_picture
bool | isDownloaded

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfPicture class

Constructor & Destructor Documentation

SmfPicturePrivate::SmfPicturePrivate ( ) [inline]

Constructor

SmfPicturePrivate::SmfPicturePrivate ( const QImage & aImage ) [inline]

Constructor

SmfPicturePrivate::SmfPicturePrivate ( const SmfPicturePrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfPicturePrivate::~SmfPicturePrivate ( ) [inline]

Destructor

Member Data Documentation

bool SmfPicturePrivate::isDownloaded

Flag whether the content is actually available in device - if this is false then only the url/link to the media is available in the class - clients can use the link to download the content/visit the site.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfpicture_p.h
Generated on Thu Sep 23 15:03:43 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPicturePrivate Member List

This is the complete list of members for SmfPicturePrivate, including all inherited members.
isDownloaded | SmfPicturePrivate |
m_comments (defined in SmfPicturePrivate) | SmfPicturePrivate |
m_description (defined in SmfPicturePrivate) | SmfPicturePrivate |
m_owner (defined in SmfPicturePrivate) | SmfPicturePrivate |
m_photoId (defined in SmfPicturePrivate) | SmfPicturePrivate |
m_picture (defined in SmfPicturePrivate) | SmfPicturePrivate |
m_picVisibility (defined in SmfPicturePrivate) | SmfPicturePrivate |
m_postedOn (defined in SmfPicturePrivate) | SmfPicturePrivate |
m_tags (defined in SmfPicturePrivate) | SmfPicturePrivate |
m_title (defined in SmfPicturePrivate) | SmfPicturePrivate |
m_url (defined in SmfPicturePrivate) | SmfPicturePrivate |
SmfPicturePrivate() | SmfPicturePrivate | [inline]
SmfPicturePrivate(const QImage &aImage) | SmfPicturePrivate | [inline]
SmfPicturePrivate(const SmfPicturePrivate &aOther) | SmfPicturePrivate | [inline]
~SmfPicturePrivate() | SmfPicturePrivate | [inline]
Generated on Thu Sep 23 15:03:43 2010 for smf by doxygen 1.6.3


smf: SmfPlaylist Class Reference

SmfPlaylist Class Reference
[Common Data Classes]

#include <smfplaylist.h>

List of all members.

Public Member Functions

SmfPlaylist ()
SmfPlaylist (const SmfPlaylist &aOther)
SmfPlaylist & | operator= (const SmfPlaylist &aOther)
~SmfPlaylist ()
QString | version () const
QString | playListTitle () const
QString | author () const
QList< SmfComment > | comments () const
QUrl | info () const
QUrl | location () const
QString | id () const
QUrl | image () const
QDateTime | creationDate () const
QUrl | license () const
QList< QUrl > | attribution () const
QVariantMap | metadata () const
QVariantMap | extension () const
QList< SmfTrackInfo > | trackList () const
void | setVersion (const QString &aVersion)
void | setPlayListTitle (const QString &aTitle)
void | setAuthor (const QString &aAuthor)
void | setComments (const QList< SmfComment > &aComments)
void | setInfo (const QUrl &aInfoUrl)
void | setLocation (const QUrl &aLocation)
void | setId (const QString &aId)
void | setImage (const QUrl &aImage)
void | setCreationDate (const QDateTime &aDate)
void | setLicense (const QUrl &aLicense)
void | setAttribution (const QList< QUrl > &aAttribution)
void | setMetadata (const QVariantMap &aMetaData)
void | setExtension (const QVariantMap &aExtension)
void | setTrackList (const QList< SmfTrackInfo > &aList)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfPlaylist &aPlaylist)
QDataStream & | operator>> (QDataStream &aDataStream, SmfPlaylist &aPlaylist)

Detailed Description

The playlist class represents an instance of a playlist. SmfPlaylist class is in accordance with the XML Shareable Playlist Format (XSPF) as mentioned in http://xspf.org/xspf-v1.html

Constructor & Destructor Documentation

SmfPlaylist::SmfPlaylist ( )

Constructor with default argument

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The playlist class represents an instance of a playlist. SmfPlaylist class is in accordance with the XML Shareable Playlist Format (XSPF) as mentioned in http://xspf.org/xspf-v1.html Constructor with default argument

SmfPlaylist::SmfPlaylist ( const SmfPlaylist & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfPlaylist::~SmfPlaylist ( )

Destructor

Member Function Documentation

QList< QUrl > SmfPlaylist::attribution ( ) const

Method to get the ordered list of URIs. The purpose is to satisfy licenses allowing modification but requiring attribution

Returns:
The list of license Urls
QString SmfPlaylist::author ( ) const

Method to get the author of the playlist

Returns:
The author of the playlist
QList< SmfComment > SmfPlaylist::comments ( ) const

Method to get the comments on the playlist

Returns:
The comments on the playlist
QDateTime SmfPlaylist::creationDate ( ) const

Method to get the creation date of the playlist

Returns:
The date and time of creation of the playlist
QVariantMap SmfPlaylist::extension ( ) const

Method to get the extension element that allows non-XSPF XML to be included in XSPF documents

Returns:
The extension elements as a QVarintMap
QString SmfPlaylist::id ( ) const

Method to get the id of the playlist

Returns:
The ID value
QUrl SmfPlaylist::image ( ) const

Method to get the URI of an image to display in the absence of an image for playlist's tracks

Returns:
The deafult image Url
QUrl SmfPlaylist::info ( ) const

Method to get the URI of a web page to find out more about this playlist

Returns:
The info Url
QUrl SmfPlaylist::license ( ) const

Method to get the URI of a resource that describes the license under which this playlist was released

Returns:
The license Url
QUrl SmfPlaylist::location ( ) const

Method to get the Source URI for this playlist

Returns:
The Source URI for this playlist
QVariantMap SmfPlaylist::metadata ( ) const

Method to get the meta element that allows metadata fields to be added to XSPF

Returns:
The meta elements as a QVarintMap
SmfPlaylist & SmfPlaylist::operator= ( const SmfPlaylist & aOther )

Overloaded = operator

Parameters:
aOther The reference object

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
QString SmfPlaylist::playListTitle ( ) const

Method to get the playlist title

Returns:
The title of the playlist
void SmfPlaylist::setAttribution ( const QList< QUrl > & aAttribution )

Method to set the ordered list of URIs. The purpose is to satisfy licenses allowing modification but requiring attribution

Parameters:
aAttribution The list of license Urls
void SmfPlaylist::setAuthor ( const QString & aAuthor )

Method to set the author of the playlist

Parameters:
aAuthor The author of the playlist
void SmfPlaylist::setComments ( const QList< SmfComment > & aComments )

Method to set the comments on the playlist

Parameters:
aComments The comments on the playlist
void SmfPlaylist::setCreationDate ( const QDateTime & aDate )

Method to set the creation date of the playlist

Parameters:
aDate The date and time of creation of the playlist
void SmfPlaylist::setExtension ( const QVariantMap & aExtension )

Method to set the extension element that allows non-XSPF XML to be included in XSPF documents

Parameters:
aExtension The extension elements as a QVarintMap
void SmfPlaylist::setId ( const QString & aId )

Method to set the id of the playlist

Parameters:
aId The ID value
void SmfPlaylist::setImage ( const QUrl & aImage )

Method to set the URI of an image to display in the absence of an image for playlist's tracks

Parameters:
aImage The default image Url
void SmfPlaylist::setInfo ( const QUrl & aInfoUrl )

Method to set the URI of a web page to find out more about this playlist

Parameters:
aInfoUrl The info Url
void SmfPlaylist::setLicense ( const QUrl & aLicense )

Method to set the URI of a resource that describes the license under which this playlist was released

Parameters:
aLicense The license Url
void SmfPlaylist::setLocation ( const QUrl & aLocation )

Method to set the Source URI for this playlist

Parameters:
aLocation The Source URI for this playlist
void SmfPlaylist::setMetadata ( const QVariantMap & aMetaData )

Method to set the meta element that allows metadata fields to be added to XSPF

Parameters:
aMetaData The meta elements as a QVarintMap
void SmfPlaylist::setPlayListTitle ( const QString & aTitle )

Method to set the playlist title

Parameters:
aTitle The title of the playlist
void SmfPlaylist::setTrackList ( const QList< SmfTrackInfo > & aList )

Method to set the list of tracks in the playlist

Parameters:
aList The new list of tracks in the playlist
void SmfPlaylist::setVersion ( const QString & aVersion )

Method to set the version of the playlist

Parameters:
aVersion The version of the playlist
QList< SmfTrackInfo > SmfPlaylist::trackList ( ) const

Method to get the list of tracks in the playlist

Returns:
The list of tracks in the playlist
QString SmfPlaylist::version ( ) const

Method to get the version of the playlist

Returns:
The version of the playlist

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfPlaylist & | aPlaylist |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfPlaylist object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aPlaylist | The SmfPlaylist object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfPlaylist & | aPlaylist |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfPlaylist object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aPlaylist | The SmfPlaylist object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfplaylist.h
  • smf/smfservermodule/smfcommon/smfplaylist.cpp
Generated on Thu Sep 23 15:03:44 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPlaylist Member List

This is the complete list of members for SmfPlaylist, including all inherited members.
attribution() const | SmfPlaylist |
author() const | SmfPlaylist |
comments() const | SmfPlaylist |
creationDate() const | SmfPlaylist |
extension() const | SmfPlaylist |
id() const | SmfPlaylist |
image() const | SmfPlaylist |
info() const | SmfPlaylist |
license() const | SmfPlaylist |
location() const | SmfPlaylist |
metadata() const | SmfPlaylist |
operator<<(QDataStream &aDataStream, const SmfPlaylist &aPlaylist) | SmfPlaylist | [friend]
operator=(const SmfPlaylist &aOther) | SmfPlaylist |
operator>>(QDataStream &aDataStream, SmfPlaylist &aPlaylist) | SmfPlaylist | [friend]
playListTitle() const | SmfPlaylist |
setAttribution(const QList< QUrl > &aAttribution) | SmfPlaylist |
setAuthor(const QString &aAuthor) | SmfPlaylist |
setComments(const QList< SmfComment > &aComments) | SmfPlaylist |
setCreationDate(const QDateTime &aDate) | SmfPlaylist |
setExtension(const QVariantMap &aExtension) | SmfPlaylist |
setId(const QString &aId) | SmfPlaylist |
setImage(const QUrl &aImage) | SmfPlaylist |
setInfo(const QUrl &aInfoUrl) | SmfPlaylist |
setLicense(const QUrl &aLicense) | SmfPlaylist |
setLocation(const QUrl &aLocation) | SmfPlaylist |
setMetadata(const QVariantMap &aMetaData) | SmfPlaylist |
setPlayListTitle(const QString &aTitle) | SmfPlaylist |
setTrackList(const QList< SmfTrackInfo > &aList) | SmfPlaylist |
setVersion(const QString &aVersion) | SmfPlaylist |
SmfPlaylist() | SmfPlaylist |
SmfPlaylist(const SmfPlaylist &aOther) | SmfPlaylist |
trackList() const | SmfPlaylist |
version() const | SmfPlaylist |
~SmfPlaylist() | SmfPlaylist |
Generated on Thu Sep 23 15:03:44 2010 for smf by doxygen 1.6.3


smf: SmfPlaylistPrivate Class Reference

SmfPlaylistPrivate Class Reference

#include <smfplaylist_p.h>

List of all members.

Public Member Functions

SmfPlaylistPrivate ()
SmfPlaylistPrivate (const SmfPlaylistPrivate &aOther)
~SmfPlaylistPrivate ()

Public Attributes

QString | m_version
QString | m_title
QString | m_author
QList< SmfComment > | m_comments
QUrl | m_info
QUrl | m_location
QString | m_playlistId
QUrl | m_image
QDateTime | m_creationDate
QUrl | m_license
QList< QUrl > | m_attribution
QVariantMap | m_metadata
QVariantMap | m_extension
QList< SmfTrackInfo > | m_trackList

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfPlaylist class

Constructor & Destructor Documentation

SmfPlaylistPrivate::SmfPlaylistPrivate ( ) [inline]

Constructor

SmfPlaylistPrivate::SmfPlaylistPrivate ( const SmfPlaylistPrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfPlaylistPrivate::~SmfPlaylistPrivate ( ) [inline]

Destructor

Member Data Documentation

QString SmfPlaylistPrivate::m_version

Data members

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfplaylist_p.h
Generated on Thu Sep 23 15:03:44 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPlaylistPrivate Member List

This is the complete list of members for SmfPlaylistPrivate, including all inherited members.
m_attribution (defined in SmfPlaylistPrivate) | SmfPlaylistPrivate |
m_author (defined in SmfPlaylistPrivate) | SmfPlaylistPrivate |
m_comments (defined in SmfPlaylistPrivate) | SmfPlaylistPrivate |
m_creationDate (defined in SmfPlaylistPrivate) | SmfPlaylistPrivate |
m_extension (defined in SmfPlaylistPrivate) | SmfPlaylistPrivate |
m_image (defined in SmfPlaylistPrivate) | SmfPlaylistPrivate |
m_info (defined in SmfPlaylistPrivate) | SmfPlaylistPrivate |
m_license (defined in SmfPlaylistPrivate) | SmfPlaylistPrivate |
m_location (defined in SmfPlaylistPrivate) | SmfPlaylistPrivate |
m_metadata (defined in SmfPlaylistPrivate) | SmfPlaylistPrivate |
m_playlistId (defined in SmfPlaylistPrivate) | SmfPlaylistPrivate |
m_title (defined in SmfPlaylistPrivate) | SmfPlaylistPrivate |
m_trackList (defined in SmfPlaylistPrivate) | SmfPlaylistPrivate |
m_version | SmfPlaylistPrivate |
SmfPlaylistPrivate() | SmfPlaylistPrivate | [inline]
SmfPlaylistPrivate(const SmfPlaylistPrivate &aOther) | SmfPlaylistPrivate | [inline]
~SmfPlaylistPrivate() | SmfPlaylistPrivate | [inline]
Generated on Thu Sep 23 15:03:44 2010 for smf by doxygen 1.6.3


smf: SmfPlaylistService Class Reference

SmfPlaylistService Class Reference

#include <smfmusic.h>

List of all members.

Public Slots

SmfError | addToPlaylist (SmfPlaylist plst, SmfTrackInfoList *tracks)
SmfError | postCurrentPlayingPlaylist (SmfPlaylist plst)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()

Signals

void | playlistsListAvailable (SmfPlaylistList *plst, SmfError error, SmfResultPage resultPage)
void | playlistUpdated (SmfError error)
void | customDataAvailable (const int &operationId, QByteArray *customData)

Public Member Functions

SmfPlaylistService (SmfProvider *baseProvider=0)
~SmfPlaylistService ()
SmfError | playlists (int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | playlistsOf (SmfContact *user, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)

Friends

class | SmfPlaylistServicePrivate

Detailed Description

Provides service ("org.symbian.smf.client.music.playlist")

Interface to a remote playlist service. This class provides some basic functionality to allow applications to interact with playlists in some music related service provider (e.g. last.fm).

Note that branding information for the particular service implementation is available from getProvider() API. See also: SmfProvider::serviceName(), SmfProvider::serviceIcon()

All of the functionality described here should be implemented by a service specific plug-in object.

Constructor & Destructor Documentation

SmfPlaylistService::SmfPlaylistService ( SmfProvider * baseProvider = 0 )

Constructs SmfPlaylistService with base provider info Seeing as this is a plug-in implementation, these will realistically be generated by SMF factory of some kind

SmfPlaylistService::~SmfPlaylistService ( )

Destructor

Member Function Documentation

SmfError SmfPlaylistService::addToPlaylist | ( | SmfPlaylist | plst,
 |  | SmfTrackInfoList * | tracks |
 | ) |  |  | [slot]

Upload currently playing track to a playlist. Signal playlistUpdated() can be checked for success value

Parameters:
plst | The playlist to be added in
tracks | The list of tracks to uploaded
Returns:
SmfNoError if success, else appropriate error value
SmfError SmfPlaylistService::cancelRequest ( ) [slot]

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
void SmfPlaylistService::customDataAvailable | ( | const int & | operationId,
 |  | QByteArray * | customData |
 | ) |  |  | [signal]

Signals availability of the result of the customRequest

Parameters:
operationId | The ID to be shared between clients and the plugin
customData | data
SmfError SmfPlaylistService::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData |
 | ) |  |  | [slot]

Request for a custom operation. The signal customDataAvailable() is emitted when the result is available.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfNoError if success, else appropriate error value Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
SmfError SmfPlaylistService::playlists | ( | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Gets the list playlists for the logged-in user asynchronously. The signal playlistsListAvailable() signal is emitted with SmfPlaylistList once its arrived . When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
void SmfPlaylistService::playlistsListAvailable | ( | SmfPlaylistList * | plst,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Notification of availability of list of playlists requested. Note if number of list is large, then it can download the list page by page.

Parameters:
plst | List of playlists
error,SmfNoError | if success, else appropriate error value
resultPage | Page number info
SmfError SmfPlaylistService::playlistsOf | ( | SmfContact * | user,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Gets the list playlists for the given user asynchronously. The signal playlistsListAvailable() signal is emitted with SmfPlaylistList once its arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
user | User for which to get the playlists
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
void SmfPlaylistService::playlistUpdated ( SmfError error ) [signal]

Signals remote updation of playlist with success value

Parameters:
error,SmfNoError if success, else appropriate error value
SmfError SmfPlaylistService::postCurrentPlayingPlaylist ( SmfPlaylist plst ) [slot]

Upload currently playing playlist . Signal playlistUpdated() can be checked for success value

Parameters:
plst The playlist to be uploaded
Returns:
SmfNoError if success, else appropriate error value
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfmusic.h
  • smf/smfservermodule/smfclient/smfmusic.cpp
Generated on Thu Sep 23 15:03:44 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPlaylistService Member List

This is the complete list of members for SmfPlaylistService, including all inherited members.
addToPlaylist(SmfPlaylist plst, SmfTrackInfoList *tracks) | SmfPlaylistService | [slot]
cancelRequest() | SmfPlaylistService | [slot]
customDataAvailable(const int &operationId, QByteArray *customData) | SmfPlaylistService | [signal]
customRequest(const int &operationId, QByteArray *customData) | SmfPlaylistService | [slot]
playlists(int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfPlaylistService |
playlistsListAvailable(SmfPlaylistList *plst, SmfError error, SmfResultPage resultPage) | SmfPlaylistService | [signal]
playlistsOf(SmfContact *user, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfPlaylistService |
playlistUpdated(SmfError error) | SmfPlaylistService | [signal]
postCurrentPlayingPlaylist(SmfPlaylist plst) | SmfPlaylistService | [slot]
SmfPlaylistService(SmfProvider *baseProvider=0) | SmfPlaylistService |
SmfPlaylistServicePrivate (defined in SmfPlaylistService) | SmfPlaylistService | [friend]
~SmfPlaylistService() | SmfPlaylistService |
Generated on Thu Sep 23 15:03:44 2010 for smf by doxygen 1.6.3


smf: SmfPlaylistServicePlugin Class Reference

SmfPlaylistServicePlugin Class Reference
[Plugin Classes]

#include <smfplaylistserviceplugin.h>

Inherits SmfPluginBase.

Inherited by LastFmPlaylistServicePlugin.

List of all members.

Public Member Functions

virtual | ~SmfPlaylistServicePlugin ()
virtual SmfPluginError | playlists (SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | playlistsOf (SmfPluginRequestData &aRequest, const SmfContact &aUser, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | addToPlaylist (SmfPluginRequestData &aRequest, const SmfPlaylist &aPlaylist, const QList< SmfTrackInfo > &aTracks)=0
virtual SmfPluginError | postCurrentPlayingPlaylist (SmfPluginRequestData &aRequest, const SmfPlaylist &aPlaylist)=0
virtual SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Interface specification for playlists service

Interface specification for playlists service. This class provides basic functionality to allow applications to get playlists of a user, add some track to an existing playlist, post the current playing playlists etc.

All of the functionality described here should be implemented by a service specific plug-in.

Constructor & Destructor Documentation

virtual SmfPlaylistServicePlugin::~SmfPlaylistServicePlugin ( ) [inline, virtual]

Destructor

Member Function Documentation

virtual SmfPluginError SmfPlaylistServicePlugin::addToPlaylist | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPlaylist & | aPlaylist,
 |  | const QList< SmfTrackInfo > & | aTracks |
 | ) |  |  | [pure virtual]

Method to add tracks to a playlist

Parameters:
aRequest | [out] The request data to be sent to network
aPlaylist | [in] The playlist where tracks should be added
aTracks | [in] The tracks to be added to the playlist
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmPlaylistServicePlugin.

virtual SmfPluginError SmfPlaylistServicePlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [pure virtual]

Customised method for SmfPlaylistServicePlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | [in] The operation type (should be known between the client interface and the plugin)
aData | [in] The data required to form the request (The type of data should be known between client and the plugin)
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmPlaylistServicePlugin.

virtual SmfPluginError SmfPlaylistServicePlugin::playlists | ( | SmfPluginRequestData & | aRequest,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get the playlist

Parameters:
aRequest | [out] The request data to be sent to network
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmPlaylistServicePlugin.

virtual SmfPluginError SmfPlaylistServicePlugin::playlistsOf | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfContact & | aUser,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get the playlist of a particular user

Parameters:
aRequest | [out] The request data to be sent to network
aUser | [in] The user whose playlists need to be fetched
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmPlaylistServicePlugin.

virtual SmfPluginError SmfPlaylistServicePlugin::postCurrentPlayingPlaylist | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPlaylist & | aPlaylist |
 | ) |  |  | [pure virtual]

Method to post the current playing playlist

Parameters:
aRequest | [out] The request data to be sent to network
aPlaylist | [in] The current playing playlist which should be posted
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in LastFmPlaylistServicePlugin.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfserver/smfplugins/smfplaylistserviceplugin.h
Generated on Thu Sep 23 15:03:44 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPlaylistServicePlugin Member List

This is the complete list of members for SmfPlaylistServicePlugin, including all inherited members.
addToPlaylist(SmfPluginRequestData &aRequest, const SmfPlaylist &aPlaylist, const QList< SmfTrackInfo > &aTracks)=0 | SmfPlaylistServicePlugin | [pure virtual]
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0 | SmfPlaylistServicePlugin | [pure virtual]
getProviderInfo()=0 | SmfPluginBase | [pure virtual]
initialize()=0 | SmfPluginBase | [pure virtual]
playlists(SmfPluginRequestData &aRequest, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfPlaylistServicePlugin | [pure virtual]
playlistsOf(SmfPluginRequestData &aRequest, const SmfContact &aUser, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfPlaylistServicePlugin | [pure virtual]
postCurrentPlayingPlaylist(SmfPluginRequestData &aRequest, const SmfPlaylist &aPlaylist)=0 | SmfPlaylistServicePlugin | [pure virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aReply, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)=0 | SmfPluginBase | [pure virtual]
~SmfPlaylistServicePlugin() | SmfPlaylistServicePlugin | [inline, virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:44 2010 for smf by doxygen 1.6.3


smf: SmfPlaylistServicePrivate Class Reference

SmfPlaylistServicePrivate Class Reference

Inherits smfObserver.

List of all members.

Public Member Functions

SmfPlaylistServicePrivate (SmfPlaylistService *aPlayLstSrvc)
~SmfPlaylistServicePrivate ()
SmfError | playlists (int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | playlistsOf (SmfContact *user, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | addToPlaylist (SmfPlaylist plst, SmfTrackInfoList *tracks)
SmfError | postCurrentPlayingPlaylist (SmfPlaylist plst)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()
void | resultsAvailable (QByteArray result, SmfRequestTypeID opcode, SmfError error)

Friends

class | SmfClientQt

Constructor & Destructor Documentation

SmfPlaylistServicePrivate::SmfPlaylistServicePrivate ( SmfPlaylistService * aPlayLstSrvc )

Constructs SmfPlaylistService with base provider info

SmfPlaylistServicePrivate::~SmfPlaylistServicePrivate ( )

Destructor

Member Function Documentation

SmfError SmfPlaylistServicePrivate::addToPlaylist | ( | SmfPlaylist | plst,
 |  | SmfTrackInfoList * | tracks
 | ) |  |

Upload currently playing track to a playlist. Signal playlistUpdated() can be checked for success value

Parameters:
plst | The playlist to be added in
tracks | The list of tracks to uploaded
Returns:
SmfNoError if success, else appropriate error value
SmfError SmfPlaylistServicePrivate::cancelRequest ( )

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
SmfError SmfPlaylistServicePrivate::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData
 | ) |  |

Request for a custom operation. The signal customDataAvailable() is emitted when the result is available.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfNoError if success, else appropriate error value Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
SmfError SmfPlaylistServicePrivate::playlists | ( | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Gets the list playlists for the logged-in user asynchronously. The signal playlistsListAvailable() signal is emitted with SmfPlaylistList once its arrived . When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
SmfError SmfPlaylistServicePrivate::playlistsOf | ( | SmfContact * | user,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Gets the list playlists for the given user asynchronously. The signal playlistsListAvailable() signal is emitted with SmfPlaylistList once its arrived. When the list is big user can specify the page number and per page item data. If not supplied by the user default values are used.

Parameters:
user | User for which to get the playlists
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfNoError if success, else appropriate error value
SmfError SmfPlaylistServicePrivate::postCurrentPlayingPlaylist ( SmfPlaylist plst )

Upload currently playing playlist . Signal playlistUpdated() can be checked for success value

Parameters:
plst The playlist to be uploaded
Returns:
SmfNoError if success, else appropriate error value
void SmfPlaylistServicePrivate::resultsAvailable | ( | QByteArray | result,
 |  | SmfRequestTypeID | opcode,
 |  | SmfError | error |
 | ) |  |  | [virtual]

To notify availibility of asynchronous requests.

Parameters:
result | Requested result, before using must check error param.
opcode | Requested opcode, for which the result has arrived.
error | Error

Implements smfObserver.

The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfmusic_p.h
  • smf/smfservermodule/smfclient/smfmusic_p.cpp
Generated on Thu Sep 23 15:03:44 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPlaylistServicePrivate Member List

This is the complete list of members for SmfPlaylistServicePrivate, including all inherited members.
addToPlaylist(SmfPlaylist plst, SmfTrackInfoList *tracks) | SmfPlaylistServicePrivate |
cancelRequest() | SmfPlaylistServicePrivate |
customRequest(const int &operationId, QByteArray *customData) | SmfPlaylistServicePrivate |
playlists(int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfPlaylistServicePrivate |
playlistsOf(SmfContact *user, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfPlaylistServicePrivate |
postCurrentPlayingPlaylist(SmfPlaylist plst) | SmfPlaylistServicePrivate |
resultsAvailable(QByteArray result, SmfRequestTypeID opcode, SmfError error) | SmfPlaylistServicePrivate | [virtual]
SmfClientQt (defined in SmfPlaylistServicePrivate) | SmfPlaylistServicePrivate | [friend]
SmfPlaylistServicePrivate(SmfPlaylistService *aPlayLstSrvc) | SmfPlaylistServicePrivate |
~SmfPlaylistServicePrivate() | SmfPlaylistServicePrivate |
Generated on Thu Sep 23 15:03:44 2010 for smf by doxygen 1.6.3


smf: SmfPluginBase Class Reference

SmfPluginBase Class Reference
[Plugin Classes]

#include <smfpluginbase.h>

Inherited by SmfActivityFetcherPlugin, SmfContactFetcherPlugin, SmfEventsFetcherPlugin, SmfGalleryPlugin, SmfLyricsServicePlugin, SmfMusicSearchPlugin, SmfMusicServicePlugin, SmfPlaylistServicePlugin, and SmfPostProviderPlugin.

List of all members.

Public Member Functions

virtual | ~SmfPluginBase ()
virtual void | initialize ()=0
virtual SmfProviderBase * | getProviderInfo ()=0
virtual SmfPluginError | responseAvailable (const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aReply, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)=0

Detailed Description

The SmfPluginBase class is the base class for all plugins

Constructor & Destructor Documentation

virtual SmfPluginBase::~SmfPluginBase ( ) [inline, virtual]

Destructor

Member Function Documentation

virtual SmfProviderBase* SmfPluginBase::getProviderInfo ( ) [pure virtual]

Method to get the provider information

Returns:
Instance of SmfProviderBase

Implemented in FBActivityFetcherPlugin, FBContactFetcherPlugin, FBPostProviderPlugin, FlickrContactFetcherPlugin, FlickrGalleryPlugin, MusicEventPlugin, LastFmMusicSearchPlugin, LastFmMusicServicePlugin, LastFmPlaylistServicePlugin, MusicLyricsPlugin, and SamplePlugin.

virtual void SmfPluginBase::initialize ( ) [pure virtual]

The first method to be called in the plugin that implements this interface. If this method is not called, plugin may not behave as expected.

Implemented in FBActivityFetcherPlugin, FBContactFetcherPlugin, FBPostProviderPlugin, FlickrContactFetcherPlugin, FlickrGalleryPlugin, MusicEventPlugin, LastFmMusicSearchPlugin, LastFmMusicServicePlugin, LastFmPlaylistServicePlugin, and MusicLyricsPlugin.

virtual SmfPluginError SmfPluginBase::responseAvailable | ( | const SmfRequestTypeID | aOperation,
 |  | const SmfTransportResult & | aTransportResult,
 |  | QByteArray * | aReply,
 |  | QVariant * | aResult,
 |  | SmfPluginRetType & | aRetType,
 |  | SmfResultPage & | aPageResult |
 | ) |  |  | [pure virtual]

Method to get the result for a network request.

Parameters:
aOperation | [in] The type of operation to be requested
aTransportResult | [in] The result of transport operation
aReply | [in] The QByteArray instance containing the network response. The plugins should delete this instance once they have read the data from it.
aResult | [out] An output parameter to the plugin manager.If the return value is SmfSendRequestAgain, QVariant will be of type SmfPluginRequestData.

For SmfActivityFetcherPlugin: If the last operation was selfActivities(), friendsActivities() or filtered(), aResult will be of type QList<SmfActivityEntry>

For SmfContactFetcherPlugin: If last operation was friends() or followers() or search() or searchInGroup() or searchNear(), aResult will be of type QList<SmfContact>. If last operation was groups(), aResult will be of type QList<SmfGroup>

For SmfEventsFetcherPlugin: If the last operation was events(), aResult will be of type QList<SmfEvent>. If the last operation was venues(), aResult will be of type QList<SmfLocation>. If the last operation was attendees(), aResult will be of type QList<SmfContact>. If the last operation was postEvents(), aResult will be of type bool.

For SmfGalleryPlugin: If last operation was albums, aResult will be of type QList<SmfPictureAlbum>. If the last operation was pictures(), aResult will be of type QList<SmfPicture>. If last operation was description(), aResult will be of type QString. If last operation was upload() or postComment(), aResult will be of type bool.

For SmfLyricsServicePlugin: If last operation was lyrics(), aResult will be of type QList<SmfLyrics>. If last operation was subtitles(), aResult will be of type QList<SmfSubtitle>.

For SmfMusicSearchPlugin: If last operation was recommendations() or tracksSimilar() or tracksOfAlbum() or tracksOfArtist() or trackInfo(), aResult will be of type QList<SmfTrackInfo>. If last operation was stores(), aResult will be of type QList<SmfProvider>.

For SmfMusicServicePlugin: If last operation was userMusicInfo(), aResult will be of type SmfMusicProfile. If last operation was searchArtist(), aResult will be of type QList<SmfArtists>. If last operation was searchAlbum(), aResult will be of type QList<SmfAlbum>. If last operation was searchEvents(), aResult will be of type QList<SmfEvent>. If last operation was searchVenue(), aResult will be of type QList<Smfocation>. If last operation was searchUser(), aResult will be of type QList<SmfMusicProfile>. If last operation was postCurrentPlaying() or postRating() or postComments(), aResult will be of type bool.

For SmfPlaylistServicePlugin: If last operation was playlists() or playlistsOf(), aResult will be of type QList<SmfPlaylist>. If last operation was addToPlaylist() or postCurrentPlayingPlaylist(), aResult will be of type bool.

For SmfPostProviderPlugin: If last operation was retrieve(), aResult will be of type QList<SmfPost>. If last operation was post() or updatePost() or postDirected() or commentOnAPost() or postAppearence() or sharePost(), aResult will be of type bool

Parameters:
aRetType | [out] Appropriate value of the enum SmfPluginRetType
aPageResult | [out] The SmfResultPage structure variable
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBActivityFetcherPlugin, FBContactFetcherPlugin, FBPostProviderPlugin, FlickrContactFetcherPlugin, FlickrGalleryPlugin, MusicEventPlugin, LastFmMusicSearchPlugin, LastFmMusicServicePlugin, LastFmPlaylistServicePlugin, and MusicLyricsPlugin.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfserver/smfplugins/smfpluginbase.h
Generated on Thu Sep 23 15:03:44 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPluginBase Member List

This is the complete list of members for SmfPluginBase, including all inherited members.
getProviderInfo()=0 | SmfPluginBase | [pure virtual]
initialize()=0 | SmfPluginBase | [pure virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aReply, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)=0 | SmfPluginBase | [pure virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
Generated on Thu Sep 23 15:03:44 2010 for smf by doxygen 1.6.3


smf: SmfPluginDataUsage Struct Reference

SmfPluginDataUsage Struct Reference

#include <smfserverglobal.h>

List of all members.

Public Attributes

QString | iAppName
QString | iInterfaceName
QString | iServiceProviderName
uint | iBytesSent
uint | iBytesReceived

Detailed Description

The structure used to track the data usage of each plugins

Member Data Documentation

QString SmfPluginDataUsage::iAppName

Application that called the plugin

uint SmfPluginDataUsage::iBytesReceived

number of bytes received for this plugin

uint SmfPluginDataUsage::iBytesSent

number of bytes sent for this plugin

QString SmfPluginDataUsage::iInterfaceName

Interface implemented by the plugin

QString SmfPluginDataUsage::iServiceProviderName

The service provider

The documentation for this struct was generated from the following file:
  • smf/smfservermodule/smfserver/smfserverglobal.h
Generated on Thu Sep 23 15:03:45 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPluginDataUsage Member List

This is the complete list of members for SmfPluginDataUsage, including all inherited members.
iAppName | SmfPluginDataUsage
iBytesReceived | SmfPluginDataUsage
iBytesSent | SmfPluginDataUsage
iInterfaceName | SmfPluginDataUsage
iServiceProviderName | SmfPluginDataUsage
Generated on Thu Sep 23 15:03:45 2010 for smf by doxygen 1.6.3


smf: SmfPluginManager Class Reference

SmfPluginManager Class Reference

#include <smfpluginmanager.h>

List of all members.

Public Member Functions

SmfServer * server ()
~SmfPluginManager ()
SmfError | createRequest (const quint32 &aSessionID, const QString &aPluginID, const SmfRequestTypeID &aOperation, QByteArray &aInputData)
SmfError | createSyncRequest (const QString &aPluginID, const SmfRequestTypeID &aOperation, QByteArray &aInputData, QByteArray &aOutputData)
void | responseAvailable (const SmfTransportResult &aTransportResult, QNetworkReply *aReply, QByteArray *aResponse)
bool | cancelRequest (const quint32 &aSessionID)
void | getPlugins (const QString &aInterface, QMap< QString, SmfProvider > &aMap)
void | getPluginId (const QString &aInterface, const SmfProvider &aProv, QString &aPluginId)

Static Public Member Functions

static SmfPluginManager * | getInstance (SmfServer *aServer=NULL)

Detailed Description

The Plugin Manager class manages the loading and unloading of plug-ins

Constructor & Destructor Documentation

SmfPluginManager::~SmfPluginManager ( )

Destructor

Member Function Documentation

bool SmfPluginManager::cancelRequest ( const quint32 & aSessionID )

Method to cancel the service request

Parameters:
aSessionID The session to be cancelled. If the plugin is not loaded currently, this method just returns true.
Returns:
Returns true if the plugin operation could be cancelled else returns false.
SmfError SmfPluginManager::createRequest | ( | const quint32 & | aSessionID,
 |  | const QString & | aPluginID,
 |  | const SmfRequestTypeID & | aOperation,
 |  | QByteArray & | aInputData
 | ) |  |

Method called by Smf server to create a web query. Plugin Manager calls the appropriate web query creation method using the aOperation and aInputData parameters. Once the web request is ready, it calls the appropriate methods exposed by the Transport Manager to send the network request.

Parameters:
aSessionID | The session ID provided by Smf Server
aPluginID | The plugin ID that need to perform this operation
aOperation | The type of operation to be performed
aInputData | The data required to create the web query
Returns:
SmfError The result of the operation. It can be :- SmfPluginNoError (if the request is sent successfully) or SmfPluginLoadError (if plugin could not be loaded) or SmfPluginNotAuthorised (if the plugin is not authorised) or SmfPluginUnknownPluginService (if the requested service is not known or unsupported) or SmfPluginRequestCreationFailed (if request creation has failed) or SmfPluginSOPCheckFailed (if plugins request doesnot comply to the Same Origin Policy) or SmfPluginRequestSendingFailed (if request could not be sent) or SmfPluginUnknownHttpService (if the plugin requested any unknown http method other than get, post, put, head or delete)
SmfError SmfPluginManager::createSyncRequest | ( | const QString & | aPluginID,
 |  | const SmfRequestTypeID & | aOperation,
 |  | QByteArray & | aInputData,
 |  | QByteArray & | aOutputData
 | ) |  |

Method called by Smf server to create a synchronous plugin request.

Parameters:
aPluginID | The plugin ID that need to perform this operation
aOperation | The type of operation to be performed
aInputData | The data required by the plugins
aOutputData | [out] The output data to be filled by the plugins
Returns:
SmfError The result of the operation. It can be :- SmfPluginNoError (if the request is success) or SmfPluginLoadError (if plugin could not be loaded) or SmfPluginNotAuthorised (if the plugin is not authorised) or SmfPluginUnknownPluginService (if the requested service is not known or unsupported)
SmfPluginManager * SmfPluginManager::getInstance ( SmfServer * aServer = NULL ) [static]

Method to get the instance of SmfPluginManager class

Parameters:
aServer The Smf server instance
Returns:
The instance of SmfPluginManager class
void SmfPluginManager::getPluginId | ( | const QString & | aInterface,
 |  | const SmfProvider & | aProv,
 |  | QString & | aPluginId
 | ) |  |

Method to get the pluginID for the mentioned interface and service provider

Parameters:
aInterface | The interface implemented by the plugin
aProv | The plugin's service provider
aPluginId | The required pluginID. This argument will be empty if no plugin for the given interface and service provider could be found.
void SmfPluginManager::getPlugins | ( | const QString & | aInterface,
 |  | QMap< QString, SmfProvider > & | aMap
 | ) |  |

Method to get the list of the SmfProvider for all the plugins that implement the mentioned Interface

Parameters:
aInterface | The interface for which list of plugins is required
aMap | The map of pluginID and its corresponding SmfProvider. The Map will be empty if no plugins for the given interface could be found.
void SmfPluginManager::responseAvailable | ( | const SmfTransportResult & | aTransportResult,
 |  | QNetworkReply * | aReply,
 |  | QByteArray * | aResponse
 | ) |  |

Method called by Transport Manager when network response is available

Parameters:
aTransportResult | The result of Transport Operation
aReply | The QNetworkReply instance that requested this transaction
aResponse | The network response data, may be NULL for error
SmfServer* SmfPluginManager::server ( ) [inline]

Debugging only

The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfserver/pluginmgr/smfpluginmanager.h
  • smf/smfservermodule/smfserver/pluginmgr/smfpluginmanager.cpp
Generated on Thu Sep 23 15:03:45 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPluginManager Member List

This is the complete list of members for SmfPluginManager, including all inherited members.
cancelRequest(const quint32 &aSessionID) | SmfPluginManager |
createRequest(const quint32 &aSessionID, const QString &aPluginID, const SmfRequestTypeID &aOperation, QByteArray &aInputData) | SmfPluginManager |
createSyncRequest(const QString &aPluginID, const SmfRequestTypeID &aOperation, QByteArray &aInputData, QByteArray &aOutputData) | SmfPluginManager |
getInstance(SmfServer *aServer=NULL) | SmfPluginManager | [static]
getPluginId(const QString &aInterface, const SmfProvider &aProv, QString &aPluginId) | SmfPluginManager |
getPlugins(const QString &aInterface, QMap< QString, SmfProvider > &aMap) | SmfPluginManager |
responseAvailable(const SmfTransportResult &aTransportResult, QNetworkReply *aReply, QByteArray *aResponse) | SmfPluginManager |
server() | SmfPluginManager | [inline]
~SmfPluginManager() | SmfPluginManager |
Generated on Thu Sep 23 15:03:45 2010 for smf by doxygen 1.6.3


smf: SmfPluginManagerUtil Class Reference

SmfPluginManagerUtil Class Reference

#include <smfpluginmanagerutil.h>

List of all members.

Public Member Functions

~SmfPluginManagerUtil ()

Static Public Member Functions

static SmfPluginManagerUtil * | getInstance (QObject *aParent=0)

Friends

class | SmfPluginManager

Detailed Description

The Plugin Manager util class performs all plugin functional specific functionalities

Constructor & Destructor Documentation

SmfPluginManagerUtil::~SmfPluginManagerUtil ( )

Destructor

Member Function Documentation

SmfPluginManagerUtil * SmfPluginManagerUtil::getInstance ( QObject * aParent = 0 ) [static]

Method to get the instance of SmfPluginManagerUtil class

Parameters:
aParent The parent object
Returns:
The instance of SmfPluginManagerUtil class
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfserver/pluginmgr/smfpluginmanagerutil.h
  • smf/smfservermodule/smfserver/pluginmgr/smfpluginmanagerutil.cpp
Generated on Thu Sep 23 15:03:45 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPluginManagerUtil Member List

This is the complete list of members for SmfPluginManagerUtil, including all inherited members.
getInstance(QObject *aParent=0) | SmfPluginManagerUtil | [static]
SmfPluginManager (defined in SmfPluginManagerUtil) | SmfPluginManagerUtil | [friend]
~SmfPluginManagerUtil() | SmfPluginManagerUtil |
Generated on Thu Sep 23 15:03:45 2010 for smf by doxygen 1.6.3


smf: SmfPluginRequestData Struct Reference

SmfPluginRequestData Struct Reference

#include <smfglobal.h>

List of all members.

Public Attributes

SmfRequestTypeID | iRequestType
QNetworkRequest | iNetworkRequest
QBuffer * | iPostData
QNetworkAccessManager::Operation | iHttpOperationType

Detailed Description

The structure used to hold the request created by the plugins

Member Data Documentation

QNetworkAccessManager::Operation SmfPluginRequestData::iHttpOperationType

The type of HTTP transaction, like GET, POST etc

QNetworkRequest SmfPluginRequestData::iNetworkRequest

The QNetworkRequest that has to be filled up by the plugins

QBuffer* SmfPluginRequestData::iPostData

The data to be posted in case of HTTP POST operation

SmfRequestTypeID SmfPluginRequestData::iRequestType

Indicates the type of operation performed, like getting Friends list, upload image etc

The documentation for this struct was generated from the following file:
  • smf/smfservermodule/smfcommon/smfglobal.h
Generated on Thu Sep 23 15:03:45 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPluginRequestData Member List

This is the complete list of members for SmfPluginRequestData, including all inherited members.
iHttpOperationType | SmfPluginRequestData
iNetworkRequest | SmfPluginRequestData
iPostData | SmfPluginRequestData
iRequestType | SmfPluginRequestData
Generated on Thu Sep 23 15:03:45 2010 for smf by doxygen 1.6.3


smf: SmfPluginUtil Class Reference

SmfPluginUtil Class Reference

#include <smfpluginutil.h>

List of all members.

Public Member Functions

SmfPluginUtil ()
~SmfPluginUtil ()
QVariant | parse (QIODevice *io, bool *ok=0)
QVariant | parse (const QByteArray &jsonData, bool *ok=0)
QString | errorString () const
int | errorLine () const
void | getAuthKeys (SmfAuthParams &aKeys, const QString aRegToken, const QDateTime &aValidity, const QString aPluginID)
void | getNonce (QString &aNonceString, const qint64 aLength)
QByteArray | createParameterString (const QString &aRequestUrl, QNetworkAccessManager::Operation aOperation, const QByteArray &aToken, const QByteArray &aTokenSecret, const SmfSignatureMethod aSignatureMethod, const QMultiMap< QByteArray, QByteArray > &aParams, const SmfParsingMode aMode)

Detailed Description

The Plugin util class provides the information required for the plugins from Smf framework

Constructor & Destructor Documentation

SmfPluginUtil::SmfPluginUtil ( )

Constructor

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The Plugin util class provides the information required for the plugins from Smf framework Constructor

SmfPluginUtil::~SmfPluginUtil ( )

Destructor

Member Function Documentation

QByteArray SmfPluginUtil::createParameterString | ( | const QString & | aRequestUrl,
 |  | QNetworkAccessManager::Operation | aOperation,
 |  | const QByteArray & | aToken,
 |  | const QByteArray & | aTokenSecret,
 |  | const SmfSignatureMethod | aSignatureMethod,
 |  | const QMultiMap< QByteArray, QByteArray > & | aParams,
 |  | const SmfParsingMode | aMode
 | ) |  |

Method called by plugins to generate a parameters string required to access Protected Resources using OAuth authorization.

Parameters:
aRequestUrl | The request URL
aOperation | The type of http operation
aToken | The access token
aTokenSecret | The token secret
aSignatureMethod | The signature method to be used
aParams | A map of parameters to its values
aMode | The mode of creation of the request
Returns:
The cretd parameter string
int SmfPluginUtil::errorLine ( ) const

This method returns line number where the last QJson parsing error occurred

Returns:
the line number where the error occurred
QString SmfPluginUtil::errorString ( ) const

This method returns the error message tha ocuured during last parsing

Returns:
a QString object containing the error message of the last parse operation
void SmfPluginUtil::getAuthKeys | ( | SmfAuthParams & | aKeys,
 |  | const QString | aRegToken,
 |  | const QDateTime & | aValidity,
 |  | const QString | aPluginID
 | ) |  |

Method called by plugins to get the OAuth Keys.

Parameters:
aKeys | [out] The OAuth keys
aRegToken | The plugin's registration token
aValidity | The validity of the keys
aPluginID | The ID of the plugin that requests for the OAuth keys
void SmfPluginUtil::getNonce | ( | QString & | aNonceString,
 |  | const qint64 | aLength
 | ) |  |

Method called by plugins to get the Nonce value

Parameters:
aNonceString | [out] The Nonce string
aLength | Lenth of the NONCE tobe generated
QVariant SmfPluginUtil::parse | ( | const QByteArray & | jsonData,
 |  | bool * | ok = 0
 | ) |  |

This is a method provided for convenience.

Parameters:
jsonData | data containing the JSON object representation
ok | if a conversion error occurs, *ok is set to false; otherwise *ok is set to true.
Returns:
a QVariant object generated from the JSON string
See also:
errorString
errorLine
QVariant SmfPluginUtil::parse | ( | QIODevice * | io,
 |  | bool * | ok = 0
 | ) |  |

Read JSON string from the I/O Device and converts it to a QVariant object

Parameters:
io | Input output device
ok | if a conversion error occurs, *ok is set to false; otherwise *ok is set to true.
Returns:
a QVariant object generated from the JSON string
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfpluginutil.h
  • smf/smfservermodule/smfcommon/smfpluginutil.cpp
Generated on Thu Sep 23 15:03:45 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPluginUtil Member List

This is the complete list of members for SmfPluginUtil, including all inherited members.
createParameterString(const QString &aRequestUrl, QNetworkAccessManager::Operation aOperation, const QByteArray &aToken, const QByteArray &aTokenSecret, const SmfSignatureMethod aSignatureMethod, const QMultiMap< QByteArray, QByteArray > &aParams, const SmfParsingMode aMode) | SmfPluginUtil
errorLine() const | SmfPluginUtil
errorString() const | SmfPluginUtil
getAuthKeys(SmfAuthParams &aKeys, const QString aRegToken, const QDateTime &aValidity, const QString aPluginID) | SmfPluginUtil
getNonce(QString &aNonceString, const qint64 aLength) | SmfPluginUtil
parse(QIODevice *io, bool *ok=0) | SmfPluginUtil
parse(const QByteArray &jsonData, bool *ok=0) | SmfPluginUtil
SmfPluginUtil() | SmfPluginUtil
~SmfPluginUtil() | SmfPluginUtil
Generated on Thu Sep 23 15:03:45 2010 for smf by doxygen 1.6.3


smf: SmfPost Class Reference

SmfPost Class Reference
[Common Data Classes]

#include <smfpost.h>

List of all members.

Public Member Functions

SmfPost ()
SmfPost (SmfContact aOwner, QString aTitle, QString aDesc, QImage aImage, QUrl aUrl)
SmfPost (const SmfPost &aOther)
SmfPost & | operator= (const SmfPost &aOther)
~SmfPost ()
SmfContact | owner () const
QString | title () const
QString | description () const
QImage | image () const
QUrl | url () const
QDateTime | postedDateTime () const
QString | id () const
void | setOwner (const SmfContact &aOwner)
void | setTitle (const QString &aTitle)
void | setDescription (const QString &aDesc)
void | setImage (const QImage &aPic)
void | setUrl (QUrl &aUrl)
void | setPostedDateTime (QDateTime &aDate)
void | setId (QString aPostId)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfPost &aPost)
QDataStream & | operator>> (QDataStream &aDataStream, SmfPost &aPost)

Detailed Description

The post class represents an instance of a post to a SN site

Constructor & Destructor Documentation

SmfPost::SmfPost ( )

Constructor with default argument

Parameters:
text Text

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The post class represents an instance of a post to a SN site Constructor with default argument

Parameters:
text Text
SmfPost::SmfPost | ( | SmfContact | aOwner,
 |  | QString | aTitle,
 |  | QString | aDesc,
 |  | QImage | aImage,
 |  | QUrl | aUrl
 | ) |  |

Constructor

Parameters:
aOwner | Owner of the post(who posted this message) of type SmfContact
aText | The post's text
aImage | The post's image
aUrl | The post's url

Constructor

Parameters:
aText | The post's text
aImage | The post's image
aUrl | The post's url
SmfPost::SmfPost ( const SmfPost & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfPost::~SmfPost ( )

Destructor

Member Function Documentation

QString SmfPost::description ( ) const

Method to get the description of the post

Returns:
The post's description
QString SmfPost::id ( ) const

Method to get the id of the post

Returns:
The ID value
QImage SmfPost::image ( ) const

Method to get the image of the post

Returns:
The post's image
SmfPost & SmfPost::operator= ( const SmfPost & aOther )

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
SmfContact SmfPost::owner ( ) const

Returns the owner(who posted this message)

QDateTime SmfPost::postedDateTime ( ) const

Method to get the posted date and time of the post

Returns:
The post's date and time of posting
void SmfPost::setDescription ( const QString & aDesc )

Method to set the description of the post

Parameters:
aDesc The post's new description
void SmfPost::setId ( QString aPostId )

Method to get the id of the post

void SmfPost::setImage ( const QImage & aPic )

Method to set the image of the post

Parameters:
aPic The post's image
void SmfPost::setOwner ( const SmfContact & aOwner )

sets the owner of the post

void SmfPost::setPostedDateTime ( QDateTime & aDate )

Method to set the posted date and time of the post

Parameters:
aDate The post's date and time of posting
void SmfPost::setTitle ( const QString & aTitle )

Method to set the title of the post

Parameters:
aTitle The post's new title
void SmfPost::setUrl ( QUrl & aUrl )

Method to set the url of the post

Parameters:
aUrl The post's url
QString SmfPost::title ( ) const

Method to get the title of the post

Returns:
The post's title
QUrl SmfPost::url ( ) const

Method to get the url of the post

Returns:
The post's url

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfPost & | aPost |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfPost object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aPost | The SmfPost object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfPost & | aPost |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfPost object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aPost | The SmfPost object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfpost.h
  • smf/smfservermodule/smfcommon/smfpost.cpp
Generated on Thu Sep 23 15:03:45 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPost Member List

This is the complete list of members for SmfPost, including all inherited members.
description() const | SmfPost |
id() const | SmfPost |
image() const | SmfPost |
operator<<(QDataStream &aDataStream, const SmfPost &aPost) | SmfPost | [friend]
operator=(const SmfPost &aOther) | SmfPost |
operator>>(QDataStream &aDataStream, SmfPost &aPost) | SmfPost | [friend]
owner() const | SmfPost |
postedDateTime() const | SmfPost |
setDescription(const QString &aDesc) | SmfPost |
setId(QString aPostId) | SmfPost |
setImage(const QImage &aPic) | SmfPost |
setOwner(const SmfContact &aOwner) | SmfPost |
setPostedDateTime(QDateTime &aDate) | SmfPost |
setTitle(const QString &aTitle) | SmfPost |
setUrl(QUrl &aUrl) | SmfPost |
SmfPost() | SmfPost |
SmfPost(SmfContact aOwner, QString aTitle, QString aDesc, QImage aImage, QUrl aUrl) | SmfPost |
SmfPost(const SmfPost &aOther) | SmfPost |
title() const | SmfPost |
url() const | SmfPost |
~SmfPost() | SmfPost |
Generated on Thu Sep 23 15:03:45 2010 for smf by doxygen 1.6.3


smf: SmfPostPrivate Class Reference

SmfPostPrivate Class Reference

#include <smfpost_p.h>

List of all members.

Public Member Functions

SmfPostPrivate ()
SmfPostPrivate (SmfContact aOwner, QString aTitle, QString aDesc, QImage aImage, QUrl aUrl)
SmfPostPrivate (const SmfPostPrivate &aOther)
~SmfPostPrivate ()

Public Attributes

SmfContact | m_owner
QString | m_title
QString | m_desc
QImage | m_image
QUrl | m_url
QDateTime | m_date
QString | m_postId

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfPost class

Constructor & Destructor Documentation

SmfPostPrivate::SmfPostPrivate ( ) [inline]

Constructor

SmfPostPrivate::SmfPostPrivate | ( | SmfContact | aOwner,
 |  | QString | aTitle,
 |  | QString | aDesc,
 |  | QImage | aImage,
 |  | QUrl | aUrl |
 | ) |  |  | [inline]

Constructor

SmfPostPrivate::SmfPostPrivate ( const SmfPostPrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfPostPrivate::~SmfPostPrivate ( ) [inline]

Destructor

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfpost_p.h
Generated on Thu Sep 23 15:03:45 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPostPrivate Member List

This is the complete list of members for SmfPostPrivate, including all inherited members.
m_date (defined in SmfPostPrivate) | SmfPostPrivate |
m_desc (defined in SmfPostPrivate) | SmfPostPrivate |
m_image (defined in SmfPostPrivate) | SmfPostPrivate |
m_owner (defined in SmfPostPrivate) | SmfPostPrivate |
m_postId (defined in SmfPostPrivate) | SmfPostPrivate |
m_title (defined in SmfPostPrivate) | SmfPostPrivate |
m_url (defined in SmfPostPrivate) | SmfPostPrivate |
SmfPostPrivate() | SmfPostPrivate | [inline]
SmfPostPrivate(SmfContact aOwner, QString aTitle, QString aDesc, QImage aImage, QUrl aUrl) | SmfPostPrivate | [inline]
SmfPostPrivate(const SmfPostPrivate &aOther) | SmfPostPrivate | [inline]
~SmfPostPrivate() | SmfPostPrivate | [inline]
Generated on Thu Sep 23 15:03:45 2010 for smf by doxygen 1.6.3


smf: SmfPostProvider Class Reference

SmfPostProvider Class Reference
[Client Classes]

#include <smfpostprovider.h>

List of all members.

Public Slots

SmfError | posts (SmfContact *user=0, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | post (SmfPost &postData, SmfLocation &location)
SmfError | updatePost (SmfPost &postData)
SmfError | postDirected (SmfPost &postData, SmfContact &contact, SmfLocation *location=0)
SmfError | commentOnAPost (SmfPost &aTarget, SmfPost &aComment, SmfLocation *aLocation=NULL)
SmfError | postAppearence (SmfAppearenceInfo appearence, const QString &status)
SmfError | sharePost (SmfPost &postData, SmfContact &contact, bool edited)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()

Signals

void | postsAvailable (SmfPostList *list, SmfError error, SmfResultPage resultPage)
void | postFinished (SmfError success)
void | customDataAvailable (int operationId, QByteArray *customData)

Public Member Functions

SmfPostProvider (SmfProvider *baseProvider)
~SmfPostProvider ()
qint32 | maxCharsInPost () const
qint32 | maxItems () const
QVector< QTextFormat > | supportedFormats () const
bool | supportsAppearence () const

Friends

class | SmfPostProviderPrivate

Detailed Description

Interface to post scrap/tweet like info. Note that branding information for the particular service implementation is available from getProvider() API. See also: SmfProvider::serviceName(), SmfProvider::serviceIcon(), SmfProvider::description()

Interface name for SmfPostProvider is org.symbian.smf.client.contact.posts

Constructor & Destructor Documentation

SmfPostProvider::SmfPostProvider ( SmfProvider * baseProvider )

Constructs SmfPostProvider.

Parameters:
baseProvider The base provider info Seeing as this is a plug-in implementation, these will realistically be generated by SMF factory of some kind

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: SmfPostProvider Constructs SmfPostProvider.

Parameters:
baseProvider The base provider info Seeing as this is a plug-in implementation, these will realistically be generated by SMF factory of some kind
SmfPostProvider::~SmfPostProvider ( )

Destructor

Member Function Documentation

SmfError SmfPostProvider::cancelRequest ( ) [slot]

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
SmfError SmfPostProvider::commentOnAPost | ( | SmfPost & | aTarget,
 |  | SmfPost & | aComment,
 |  | SmfLocation * | aLocation = NULL |
 | ) |  |  | [slot]

Method to post a comment on a post.

Parameters:
aTarget | Post on which comment has to be posted
aComment | comment to be posted
aLocation | location data
Returns:
SmfError. SmfNoError if success, else appropriate error code
void SmfPostProvider::customDataAvailable | ( | int | operationId,
 |  | QByteArray * | customData |
 | ) |  |  | [signal]

Emitted when custom data is available

Parameters:
operationId | Requested operation id
customData | Custom data received, interpretation is not the responsibility of Smf
SmfError SmfPostProvider::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData |
 | ) |  |  | [slot]

Request for a custom operation.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfError. SmfNoError if success, else appropriate error code Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
qint32 SmfPostProvider::maxCharsInPost ( ) const

returns maximum no of chars (unicode) that service provider can post without truncation negative value means no limit

qint32 SmfPostProvider::maxItems ( ) const

returns maximum no of items that can be returned in a single query to getPosts negative value means feature not supported.

SmfError SmfPostProvider::post | ( | SmfPost & | postData,
 |  | SmfLocation & | location |
 | ) |  |  | [slot]

Updates a post to own area, the success of the post can be checked with signal updatePostFinished() signal

Parameters:
postData | data to be posted
location | location data
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfPostProvider::postAppearence | ( | SmfAppearenceInfo | appearence,
 |  | const QString & | status |
 | ) |  |  | [slot]

Posts appearance info of the user.e.g. appear offline, busy, do-not-disturb

Parameters:
appearence user appearance
See also:
SmfPresenceInfo
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfPostProvider::postDirected | ( | SmfPost & | postData,
 |  | SmfContact & | contact,
 |  | SmfLocation * | location = 0 |
 | ) |  |  | [slot]

Updates a post to a particular Smf contact. the success of the post can be checked with signal updatePostFinished() signal.

Parameters:
postData | data to be posted
contact | contact to which the post is to be directed
location | location data
Returns:
SmfError. SmfNoError if success, else appropriate error code
void SmfPostProvider::postFinished ( SmfError success ) [signal]

Emitted when update post is finished.

Parameters:
success the success of the update
SmfError SmfPostProvider::posts | ( | SmfContact * | user = 0,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [slot]

Gets the posts asynchronously. The signal postsAvailable()with SmfPostList is emitted once the post lists are available

Parameters:
user | user's contact in this SP, omit for self contact
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
See also:
postsAvailable()
void SmfPostProvider::postsAvailable | ( | SmfPostList * | list,
 |  | SmfError | error,
 |  | SmfResultPage | resultPage |
 | ) |  |  | [signal]

Emitted when a request to getPosts() is finished Note if number of posts is large, then it can download the list page by page In that case this signal is emitted multiple times.

Parameters:
list | list of posts
error | error string
resultPage | Page number info
SmfError SmfPostProvider::sharePost | ( | SmfPost & | postData,
 |  | SmfContact & | contact,
 |  | bool | edited |
 | ) |  |  | [slot]

Share /a contact's post to user's friends and followers (e.g. retweet in twitter, share on facebook) emits updatePostFinished() signal when done.

Parameters:
postData | data to be posted
contact | contact to which the post belonged
bool | whether user changed items within the post
Returns:
SmfError. SmfNoError if success, else appropriate error code
QVector< QTextFormat > SmfPostProvider::supportedFormats ( ) const

returns all the formatting of posts that this service provider supports. May return 0 items to mean only QString is supported.

bool SmfPostProvider::supportsAppearence ( ) const

returns whether this SP supports Appearence

See also:
SmfAppearenceInfo
SmfError SmfPostProvider::updatePost ( SmfPost & postData ) [slot]

Updates the last post to own area with new data, the success of the post can be checked with signal updatePostFinished() signal

Parameters:
postData | edited/new data to be posted
location | location data
Returns:
SmfError. SmfNoError if success, else appropriate error code
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfpostprovider.h
  • smf/smfservermodule/smfclient/smfpostprovider.cpp
Generated on Thu Sep 23 15:03:46 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPostProvider Member List

This is the complete list of members for SmfPostProvider, including all inherited members.
cancelRequest() | SmfPostProvider | [slot]
commentOnAPost(SmfPost &aTarget, SmfPost &aComment, SmfLocation *aLocation=NULL) | SmfPostProvider | [slot]
customDataAvailable(int operationId, QByteArray *customData) | SmfPostProvider | [signal]
customRequest(const int &operationId, QByteArray *customData) | SmfPostProvider | [slot]
maxCharsInPost() const | SmfPostProvider |
maxItems() const | SmfPostProvider |
post(SmfPost &postData, SmfLocation &location) | SmfPostProvider | [slot]
postAppearence(SmfAppearenceInfo appearence, const QString &status) | SmfPostProvider | [slot]
postDirected(SmfPost &postData, SmfContact &contact, SmfLocation *location=0) | SmfPostProvider | [slot]
postFinished(SmfError success) | SmfPostProvider | [signal]
posts(SmfContact *user=0, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfPostProvider | [slot]
postsAvailable(SmfPostList *list, SmfError error, SmfResultPage resultPage) | SmfPostProvider | [signal]
sharePost(SmfPost &postData, SmfContact &contact, bool edited) | SmfPostProvider | [slot]
SmfPostProvider(SmfProvider *baseProvider) | SmfPostProvider |
SmfPostProviderPrivate (defined in SmfPostProvider) | SmfPostProvider | [friend]
supportedFormats() const | SmfPostProvider |
supportsAppearence() const | SmfPostProvider |
updatePost(SmfPost &postData) | SmfPostProvider | [slot]
~SmfPostProvider() | SmfPostProvider |
Generated on Thu Sep 23 15:03:46 2010 for smf by doxygen 1.6.3


smf: SmfPostProviderPlugin Class Reference

SmfPostProviderPlugin Class Reference
[Plugin Classes]

#include <smfpostproviderplugin.h>

Inherits SmfPluginBase.

Inherited by FBPostProviderPlugin.

List of all members.

Public Member Functions

virtual | ~SmfPostProviderPlugin ()
virtual qint32 | maxCharsInPost () const =0
virtual qint32 | maxItems () const =0
virtual QVector< QTextFormat > | supportedFormats () const =0
virtual bool | supportsAppearence () const =0
virtual SmfPluginError | retrieve (SmfPluginRequestData &aRequest, const SmfContact *aUser=NULL, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0
virtual SmfPluginError | post (SmfPluginRequestData &aRequest, const SmfPost &aPostData, const SmfLocation &aLocation)=0
virtual SmfPluginError | updatePost (SmfPluginRequestData &aRequest, const SmfPost &aPostData)=0
virtual SmfPluginError | postDirected (SmfPluginRequestData &aRequest, const SmfPost &aPostData, const SmfContact &aContact, const SmfLocation *aLocation=NULL)=0
virtual SmfPluginError | commentOnAPost (SmfPluginRequestData &aRequest, const SmfPost &aTarget, const SmfPost &aComment, const SmfLocation *aLocation=NULL)=0
virtual SmfPluginError | postAppearence (SmfPluginRequestData &aRequest, const SmfPresenceInfo &aAppearence, const QString &aStatus)=0
virtual SmfPluginError | sharePost (SmfPluginRequestData &aRequest, const SmfPost &aPostData, const SmfContact &aContact, const bool &aEdited)=0
virtual SmfPluginError | customRequest (SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Interface specification for getting/posting updates to a social site

Interface to get/update the posts to a service provider. This class provides basic functionality to allow applications to obtain list of posts, updates posts or change the presence information to a social networking service.

All of the functionality described here should be implemented by a service specific plug-in.

Constructor & Destructor Documentation

virtual SmfPostProviderPlugin::~SmfPostProviderPlugin ( ) [inline, virtual]

Destructor

Member Function Documentation

virtual SmfPluginError SmfPostProviderPlugin::commentOnAPost | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPost & | aTarget,
 |  | const SmfPost & | aComment,
 |  | const SmfLocation * | aLocation = NULL |
 | ) |  |  | [pure virtual]

Method to post a comment on a post.

Parameters:
aRequest | [out] The request data to be sent to network
aTarget | [in] Post on which comment has to be posted
aComment | [in] comment to be posted
aLocation | [in] location data
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBPostProviderPlugin.

virtual SmfPluginError SmfPostProviderPlugin::customRequest | ( | SmfPluginRequestData & | aRequest,
 |  | const int & | aOperation,
 |  | QByteArray * | aData |
 | ) |  |  | [pure virtual]

Customised method for SmfPostProviderPlugin interface

Parameters:
aRequest | [out] The request data to be sent to network
aOperation | [in] The operation type (should be known between the client interface and the plugin)
aData | [in] The data required to form the request (The type of data should be known between client and the plugin)
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBPostProviderPlugin.

virtual qint32 SmfPostProviderPlugin::maxCharsInPost ( ) const [pure virtual]

Method that returns maximum no of chars (unicode) that service provider can post without truncation. Negative value means no limit

Returns:
Max characters that can be posted without truncation

Implemented in FBPostProviderPlugin.

virtual qint32 SmfPostProviderPlugin::maxItems ( ) const [pure virtual]

Method that returns maximum no of items that can be returned in a single query to getPosts. Negative value means feature not supported.

Returns:
Max items that can be returned in a single query

Implemented in FBPostProviderPlugin.

virtual SmfPluginError SmfPostProviderPlugin::post | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPost & | aPostData,
 |  | const SmfLocation & | aLocation |
 | ) |  |  | [pure virtual]

Method to update a post to own area.

Parameters:
aRequest | [out] The request data to be sent to network
aPostData | [in] The post data to be posted
aLocation | [in] The location
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBPostProviderPlugin.

virtual SmfPluginError SmfPostProviderPlugin::postAppearence | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPresenceInfo & | aAppearence,
 |  | const QString & | aStatus |
 | ) |  |  | [pure virtual]

Method to update the presence information of the user

Parameters:
aRequest | [out] The request data to be sent to network
aAppearence | [in] The appearence information
aStatus | [in] The status string
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBPostProviderPlugin.

virtual SmfPluginError SmfPostProviderPlugin::postDirected | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPost & | aPostData,
 |  | const SmfContact & | aContact,
 |  | const SmfLocation * | aLocation = NULL |
 | ) |  |  | [pure virtual]

Method to update a post to a particular contact

Parameters:
aRequest | [out] The request data to be sent to network
aPostData | [in] The post data to be posted
aContact | [in] The contact where the data has to be posted
aLocation | [in] The location
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBPostProviderPlugin.

virtual SmfPluginError SmfPostProviderPlugin::retrieve | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfContact * | aUser = NULL,
 |  | const int | aPageNum = SMF_FIRST_PAGE,
 |  | const int | aItemsPerPage = SMF_ITEMS_PER_PAGE |
 | ) |  |  | [pure virtual]

Method to get the latest posts

Parameters:
aRequest | [out] The request data to be sent to network
aUser | [in] The user's contact in this SP, omit for self contact
aPageNum | [in] The page to be extracted
aItemsPerPage | [in] Number of items per page
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBPostProviderPlugin.

virtual SmfPluginError SmfPostProviderPlugin::sharePost | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPost & | aPostData,
 |  | const SmfContact & | aContact,
 |  | const bool & | aEdited |
 | ) |  |  | [pure virtual]

Share a contact's post to user's friends and followers (e.g. retweet in twitter, share on facebook)

Parameters:
aRequest | [out] The request data to be sent to network
aPostData | [in] data to be posted
aContact | [in] contact to which the post belonged
aEdited | [in] whether user changed items within the post
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBPostProviderPlugin.

virtual QVector<QTextFormat> SmfPostProviderPlugin::supportedFormats ( ) const [pure virtual]

Method that returns all the formatting of posts that this service provider supports. May return 0 items to mean only QString is supported.

Returns:
Supported formats of posts

Implemented in FBPostProviderPlugin.

virtual bool SmfPostProviderPlugin::supportsAppearence ( ) const [pure virtual]

Method that returns whether this SP supports Appearence

Returns:
Returns true if Appearance is supported, else false.
See also:
SmfAppearenceInfo

Implemented in FBPostProviderPlugin.

virtual SmfPluginError SmfPostProviderPlugin::updatePost | ( | SmfPluginRequestData & | aRequest,
 |  | const SmfPost & | aPostData |
 | ) |  |  | [pure virtual]

Method to update the last post to own area with new data

Parameters:
aRequest | [out] The request data to be sent to network
aPostData | [in] The edited/new data to be posted
Returns:
Appropriate value of the enum SmfPluginError. Plugin error if any, else SmfPluginErrNone for success

Implemented in FBPostProviderPlugin.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfserver/smfplugins/smfpostproviderplugin.h
Generated on Thu Sep 23 15:03:46 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPostProviderPlugin Member List

This is the complete list of members for SmfPostProviderPlugin, including all inherited members.
commentOnAPost(SmfPluginRequestData &aRequest, const SmfPost &aTarget, const SmfPost &aComment, const SmfLocation *aLocation=NULL)=0 | SmfPostProviderPlugin | [pure virtual]
customRequest(SmfPluginRequestData &aRequest, const int &aOperation, QByteArray *aData)=0 | SmfPostProviderPlugin | [pure virtual]
getProviderInfo()=0 | SmfPluginBase | [pure virtual]
initialize()=0 | SmfPluginBase | [pure virtual]
maxCharsInPost() const =0 | SmfPostProviderPlugin | [pure virtual]
maxItems() const =0 | SmfPostProviderPlugin | [pure virtual]
post(SmfPluginRequestData &aRequest, const SmfPost &aPostData, const SmfLocation &aLocation)=0 | SmfPostProviderPlugin | [pure virtual]
postAppearence(SmfPluginRequestData &aRequest, const SmfPresenceInfo &aAppearence, const QString &aStatus)=0 | SmfPostProviderPlugin | [pure virtual]
postDirected(SmfPluginRequestData &aRequest, const SmfPost &aPostData, const SmfContact &aContact, const SmfLocation *aLocation=NULL)=0 | SmfPostProviderPlugin | [pure virtual]
responseAvailable(const SmfRequestTypeID aOperation, const SmfTransportResult &aTransportResult, QByteArray *aReply, QVariant *aResult, SmfPluginRetType &aRetType, SmfResultPage &aPageResult)=0 | SmfPluginBase | [pure virtual]
retrieve(SmfPluginRequestData &aRequest, const SmfContact *aUser=NULL, const int aPageNum=SMF_FIRST_PAGE, const int aItemsPerPage=SMF_ITEMS_PER_PAGE)=0 | SmfPostProviderPlugin | [pure virtual]
sharePost(SmfPluginRequestData &aRequest, const SmfPost &aPostData, const SmfContact &aContact, const bool &aEdited)=0 | SmfPostProviderPlugin | [pure virtual]
supportedFormats() const =0 | SmfPostProviderPlugin | [pure virtual]
supportsAppearence() const =0 | SmfPostProviderPlugin | [pure virtual]
updatePost(SmfPluginRequestData &aRequest, const SmfPost &aPostData)=0 | SmfPostProviderPlugin | [pure virtual]
~SmfPluginBase() | SmfPluginBase | [inline, virtual]
~SmfPostProviderPlugin() | SmfPostProviderPlugin | [inline, virtual]
Generated on Thu Sep 23 15:03:46 2010 for smf by doxygen 1.6.3


smf: SmfPostProviderPrivate Class Reference

SmfPostProviderPrivate Class Reference

#include <smfpostprovider_p.h>

Inherits smfObserver.

List of all members.

Public Member Functions

SmfPostProviderPrivate (SmfPostProvider *postProvider=0)
~SmfPostProviderPrivate ()
qint32 | maxCharsInPost ()
qint32 | maxItems ()
QVector< QTextFormat > | supportedFormats ()
bool | supportsAppearence ()
SmfError | posts (SmfContact *user=0, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE)
SmfError | post (SmfPost &postData, SmfLocation &location)
SmfError | updatePost (SmfPost &postData)
SmfError | postDirected (SmfPost &postData, SmfContact &contact, SmfLocation *location=0)
SmfError | commentOnAPost (SmfPost &aTarget, SmfPost &aComment, SmfLocation *aLocation=NULL)
SmfError | postAppearence (SmfAppearenceInfo appearence, const QString &status)
SmfError | sharePost (SmfPost &postData, SmfContact &contact, bool edited)
SmfError | customRequest (const int &operationId, QByteArray *customData)
SmfError | cancelRequest ()
void | resultsAvailable (QByteArray result, SmfRequestTypeID opcode, SmfError error)

Friends

class | SmfClientQt

Detailed Description

Private Qt wrapper Provided to accomodate diff facilities in diff platforms. Uses Symbian client-server for Symbian QDbus for linux QLocalserver for rest of the platforms Note:- only symbian client-server impl is provided at the moment

Constructor & Destructor Documentation

SmfPostProviderPrivate::SmfPostProviderPrivate ( SmfPostProvider * postProvider = 0 )

Constructor

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private implementation of SmfPostProvider

SmfPostProviderPrivate::~SmfPostProviderPrivate ( )

Destructor

Member Function Documentation

SmfError SmfPostProviderPrivate::cancelRequest ( )

Cancels a request generated due to the call to any API which results into http request. Might return error if no request is currently pending. Please note that there can be only one request pending at any point of time

Returns:
Appropriate SmfError value
SmfError SmfPostProviderPrivate::commentOnAPost | ( | SmfPost & | aTarget,
 |  | SmfPost & | aComment,
 |  | SmfLocation * | aLocation = NULL
 | ) |  |

Method to post a comment on a post.

Parameters:
aTarget | Post on which comment has to be posted
aComment | comment to be posted
aLocation | location data
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfPostProviderPrivate::customRequest | ( | const int & | operationId,
 |  | QByteArray * | customData
 | ) |  |

Request for a custom operation.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfError. SmfNoError if success, else appropriate error code Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data

Request for a custom operation. The signal customDataAvailable() is emitted when the result is available.

Parameters:
operationId | OperationId
customData | Custom data to be sent
Returns:
SmfError. SmfNoError if success, else appropriate error code Note:-Interpretation of operationId and customData is upto the concerned plugin and client application. service provider should provide some serializing-deserializing utilities for these custom data
qint32 SmfPostProviderPrivate::maxCharsInPost ( )

returns maximum no of chars (unicode) that service provider can post without truncation negative value means no limit

qint32 SmfPostProviderPrivate::maxItems ( )

returns maximum no of items that can be returned in a single query to getPosts negative value means feature not supported.

SmfError SmfPostProviderPrivate::post | ( | SmfPost & | postData,
 |  | SmfLocation & | location
 | ) |  |

Updates a post to own area, the success of the post can be checked with signal updatePostFinished() signal

Parameters:
postData | data to be posted
location | location data
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfPostProviderPrivate::postAppearence | ( | SmfAppearenceInfo | appearence,
 |  | const QString & | status
 | ) |  |

Posts appearance info of the user.e.g. appear offline, busy, do-not-disturb

Parameters:
appearence user appearance
See also:
SmfPresenceInfo
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfPostProviderPrivate::postDirected | ( | SmfPost & | postData,
 |  | SmfContact & | contact,
 |  | SmfLocation * | location = 0
 | ) |  |

Updates a post to a particular Smf contact. the success of the post can be checked with signal updatePostFinished() signal.

Parameters:
postData | data to be posted
contact | contact to which the post is to be directed
location | location data
Returns:
SmfError. SmfNoError if success, else appropriate error code
SmfError SmfPostProviderPrivate::posts | ( | SmfContact * | user = 0,
 |  | int | pageNum = SMF_FIRST_PAGE,
 |  | int | perPage = SMF_ITEMS_PER_PAGE
 | ) |  |

Gets the posts asynchronously. The signal postsAvailable()with SmfPostList is emitted once the post lists are available

Parameters:
user | user's contact in this SP, omit for self contact
pageNum | Page number to download, SMF_FIRST_PAGE denotes fresh query.
perPage | Item per page, default is SMF_ITEMS_PER_PAGE
Returns:
SmfError. SmfNoError if success, else appropriate error code
See also:
postsAvailable()
void SmfPostProviderPrivate::resultsAvailable | ( | QByteArray | result,
 |  | SmfRequestTypeID | opcode,
 |  | SmfError | error |
 | ) |  |  | [virtual]

To notify availibility of asynchronous requests.

Parameters:
result | Requested result, before using must check error param.
opcode | Requested opcode, for which the result has arrived.
error | Error

From smfobserver

Implements smfObserver.

SmfError SmfPostProviderPrivate::sharePost | ( | SmfPost & | postData,
 |  | SmfContact & | contact,
 |  | bool | edited
 | ) |  |

Share /a contact's post to user's friends and followers (e.g. retweet in twitter, share on facebook) emits updatePostFinished() signal when done.

Parameters:
postData | data to be posted
contact | contact to which the post belonged
bool | whether user changed items within the post
Returns:
SmfError. SmfNoError if success, else appropriate error code

Share a contact's post to user's friends and followers (e.g. retweet in twitter, share on facebook) emits updatePostFinished() signal when done.

Parameters:
postData | data to be posted
contact | contact to which the post belonged
bool | whether user changed items within the post
Returns:
SmfError. SmfNoError if success, else appropriate error code
QVector< QTextFormat > SmfPostProviderPrivate::supportedFormats ( )

returns all the formatting of posts that this service provider supports. May return 0 items to mean only QString is supported.

bool SmfPostProviderPrivate::supportsAppearence ( )

returns whether this SP supports Appearence

See also:
SmfAppearenceInfo
SmfError SmfPostProviderPrivate::updatePost ( SmfPost & postData )

Updates the last post to own area with new data, the success of the post can be checked with signal updatePostFinished() signal

Parameters:
postData | edited/new data to be posted
location | location data
Returns:
SmfError. SmfNoError if success, else appropriate error code
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfpostprovider_p.h
  • smf/smfservermodule/smfclient/smfpostprovider_p.cpp
Generated on Thu Sep 23 15:03:46 2010 for smf by doxygen 1.6.3


smf: Member List

SmfPostProviderPrivate Member List

This is the complete list of members for SmfPostProviderPrivate, including all inherited members.
cancelRequest() | SmfPostProviderPrivate |
commentOnAPost(SmfPost &aTarget, SmfPost &aComment, SmfLocation *aLocation=NULL) | SmfPostProviderPrivate |
customRequest(const int &operationId, QByteArray *customData) | SmfPostProviderPrivate |
maxCharsInPost() | SmfPostProviderPrivate |
maxItems() | SmfPostProviderPrivate |
post(SmfPost &postData, SmfLocation &location) | SmfPostProviderPrivate |
postAppearence(SmfAppearenceInfo appearence, const QString &status) | SmfPostProviderPrivate |
postDirected(SmfPost &postData, SmfContact &contact, SmfLocation *location=0) | SmfPostProviderPrivate |
posts(SmfContact *user=0, int pageNum=SMF_FIRST_PAGE, int perPage=SMF_ITEMS_PER_PAGE) | SmfPostProviderPrivate |
resultsAvailable(QByteArray result, SmfRequestTypeID opcode, SmfError error) | SmfPostProviderPrivate | [virtual]
sharePost(SmfPost &postData, SmfContact &contact, bool edited) | SmfPostProviderPrivate |
SmfClientQt (defined in SmfPostProviderPrivate) | SmfPostProviderPrivate | [friend]
SmfPostProviderPrivate(SmfPostProvider *postProvider=0) | SmfPostProviderPrivate |
supportedFormats() | SmfPostProviderPrivate |
supportsAppearence() | SmfPostProviderPrivate |
updatePost(SmfPost &postData) | SmfPostProviderPrivate |
~SmfPostProviderPrivate() | SmfPostProviderPrivate |
Generated on Thu Sep 23 15:03:46 2010 for smf by doxygen 1.6.3


smf: SmfProvider Class Reference

SmfProvider Class Reference
[Client Classes]

#include <smfprovider.h>

List of all members.

Public Member Functions

SmfProvider ()
~SmfProvider ()
QString | serviceName () const
QImage | serviceIcon () const
QString | description () const
QUrl | serviceUrl () const
QUrl | applicationUrl () const
QList< QString > | supportedInterfaces () const
QStringList | supportedLanguages () const
void | setServiceName (QString &name)
void | setServiceIcon (QImage &image)
void | setDescription (QString &desc)
void | setServiceUrl (QUrl &url)
void | setApplicationUrl (QUrl &url)
void | setSupportedInterfaces (QStringList &types)
void | setSupportedLanguages (QStringList &lang)

Friends

QDataStream & | operator<< (QDataStream &, const SmfProvider &)
QDataStream & | operator>> (QDataStream &, SmfProvider &)

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Interface for a base service provider

Interface for a base service provider. Other service provider classes contains implementation of this base class so that each has access to service provider information. All of the functionality described here should be implemented by a service specific plug-in object.

Constructor & Destructor Documentation

SmfProvider::SmfProvider ( )

Constructor

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Interface for a base service provider Constructor

SmfProvider::~SmfProvider ( )

Destructor

Member Function Documentation

QUrl SmfProvider::applicationUrl ( ) const

URL of the application providing this service

Returns:
application url
QString SmfProvider::description ( ) const

Readable service description

Returns:
service description
QImage SmfProvider::serviceIcon ( ) const

Logo of the service

Returns:
logo image of the service
QString SmfProvider::serviceName ( ) const

Localizable name of the service

Returns:
service name
void SmfProvider::setApplicationUrl ( QUrl & url )

Sets URL of the application providing this service

Parameters:
url application url
void SmfProvider::setDescription ( QString & desc )

Sets Readable service description

Parameters:
desc description text
void SmfProvider::setServiceIcon ( QImage & image )

Sets Logo of the service

Parameters:
image service icon
void SmfProvider::setServiceName ( QString & name )

Sets Localizable name of the service

Parameters:
name service name
void SmfProvider::setSupportedInterfaces ( QStringList & types )

Sets list of interfaces that this provider supports

Parameters:
types List of supported interface names
void SmfProvider::setSupportedLanguages ( QStringList & lang )

Sets the list of languages supported by this service provider

Parameters:
lang A QStringList of languages supported by this service provider in 2 letter ISO 639-1 format.
QList< QString > SmfProvider::supportedInterfaces ( ) const

List of interfaces that this provider support

Returns:
List of supported interface names
QStringList SmfProvider::supportedLanguages ( ) const

List of languages supported by this service provider

Returns:
a QStringList of languages supported by this service provider in 2 letter ISO 639-1 format.

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | ,
 |  | const SmfProvider & |  |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfProvider object to the stream and returns a reference to the stream.

Parameters:
out | Stream to be written
base | The SmfProvider object to be externalized
Returns:
reference to the written stream

Method for Externalization. Writes the SmfProvider object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aProvider | The SmfProvider object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | ,
 |  | SmfProvider & |  |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfProvider object from the stream and returns a reference to the stream.

Parameters:
in | Stream to be read
base | The SmfProvider object to be internalized
Returns:
reference to the stream

Method for Internalization. Reads a SmfProvider object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aProvider | The SmfProvider object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfprovider.h
  • smf/smfservermodule/smfcommon/smfprovider.cpp
Generated on Thu Sep 23 15:03:46 2010 for smf by doxygen 1.6.3


smf: Member List

SmfProvider Member List

This is the complete list of members for SmfProvider, including all inherited members.
applicationUrl() const | SmfProvider |
description() const | SmfProvider |
operator<<(QDataStream &, const SmfProvider &) | SmfProvider | [friend]
operator>>(QDataStream &, SmfProvider &) | SmfProvider | [friend]
serviceIcon() const | SmfProvider |
serviceName() const | SmfProvider |
serviceUrl() const (defined in SmfProvider) | SmfProvider |
setApplicationUrl(QUrl &url) | SmfProvider |
setDescription(QString &desc) | SmfProvider |
setServiceIcon(QImage &image) | SmfProvider |
setServiceName(QString &name) | SmfProvider |
setServiceUrl(QUrl &url) (defined in SmfProvider) | SmfProvider |
setSupportedInterfaces(QStringList &types) | SmfProvider |
setSupportedLanguages(QStringList &lang) | SmfProvider |
SmfProvider() | SmfProvider |
supportedInterfaces() const | SmfProvider |
supportedLanguages() const | SmfProvider |
~SmfProvider() | SmfProvider |
Generated on Thu Sep 23 15:03:46 2010 for smf by doxygen 1.6.3


smf: SmfProviderBase Class Reference

SmfProviderBase Class Reference
[Plugin Classes]

#include <smfproviderbase.h>

Inherited by FBActivityProviderBase, FBContactProviderBase, FBProviderBase, FlickrProviderBase, FlickrProviderBase, LastFmMusicSearchProviderBase, LastFmMusicServiceProviderBase, LastFmPlaylistServiceProviderBase, MusicProviderBase, MusicProviderBase, and SampleProviderBase.

List of all members.

Public Member Functions

virtual | ~SmfProviderBase ()
virtual QString | serviceName () const =0
virtual QImage | serviceIcon () const =0
virtual QString | description () const =0
virtual QUrl | serviceUrl () const =0
virtual QUrl | applicationUrl () const =0
virtual QImage | applicationIcon () const =0
virtual QList< QString > | supportedInterfaces () const =0
virtual QStringList | supportedLanguages () const =0
virtual QString | pluginId () const =0
virtual QString | authenticationApp (QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const =0
virtual QString | smfRegistrationId () const =0

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The Provider Base class is the class that has to be contained as a member in all Plug-in Interfaces.

The Provider Base class is the class that has to be contained as a member in all Plug-in Interfaces.

All of plug-ins should contain this class as a member and should also contain a public method to get instance of this class.

Constructor & Destructor Documentation

virtual SmfProviderBase::~SmfProviderBase ( ) [inline, virtual]

Destructor

Member Function Documentation

virtual QImage SmfProviderBase::applicationIcon ( ) const [pure virtual]

Method to get the Icon of the application

Returns:
The Icon of the application

Implemented in FBActivityProviderBase, FBContactProviderBase, FBProviderBase, FlickrProviderBase, FlickrProviderBase, MusicProviderBase, LastFmMusicSearchProviderBase, LastFmMusicServiceProviderBase, LastFmPlaylistServiceProviderBase, MusicProviderBase, and SampleProviderBase.

virtual QUrl SmfProviderBase::applicationUrl ( ) const [pure virtual]

Method to get the URL of the Application providing this service

Returns:
The URL of the Application providing this service

Implemented in FBActivityProviderBase, FBContactProviderBase, FBProviderBase, FlickrProviderBase, FlickrProviderBase, MusicProviderBase, LastFmMusicSearchProviderBase, LastFmMusicServiceProviderBase, LastFmPlaylistServiceProviderBase, MusicProviderBase, and SampleProviderBase.

virtual QString SmfProviderBase::authenticationApp | ( | QString & | aProgram,
 |  | QStringList & | aArguments,
 |  | QIODevice::OpenModeFlag | aMode = QIODevice::ReadWrite |
 | ) |  |  | const [pure virtual]

Method to get the ID of the authentication application for this service

Parameters:
aProgram | The authentication application name
aArguments | List of arguments required for authentication app
aMode | Strting mode for authentication application
Returns:
The ID of the authentication application

Implemented in FBActivityProviderBase, FBContactProviderBase, FBProviderBase, FlickrProviderBase, FlickrProviderBase, MusicProviderBase, LastFmMusicSearchProviderBase, LastFmMusicServiceProviderBase, LastFmPlaylistServiceProviderBase, MusicProviderBase, and SampleProviderBase.

virtual QString SmfProviderBase::description ( ) const [pure virtual]

Method to get the Readable service description

Returns:
The Readable service description

Implemented in FBActivityProviderBase, FBContactProviderBase, FBProviderBase, FlickrProviderBase, FlickrProviderBase, MusicProviderBase, LastFmMusicSearchProviderBase, LastFmMusicServiceProviderBase, LastFmPlaylistServiceProviderBase, MusicProviderBase, and SampleProviderBase.

virtual QString SmfProviderBase::pluginId ( ) const [pure virtual]

Method to get the Plugin specific ID

Returns:
The Plugin specific ID

Implemented in FBActivityProviderBase, FBContactProviderBase, FBProviderBase, FlickrProviderBase, FlickrProviderBase, MusicProviderBase, LastFmMusicSearchProviderBase, LastFmMusicServiceProviderBase, LastFmPlaylistServiceProviderBase, MusicProviderBase, and SampleProviderBase.

virtual QImage SmfProviderBase::serviceIcon ( ) const [pure virtual]

Method to get the Logo of the service

Returns:
The Logo of the service

Implemented in FBActivityProviderBase, FBContactProviderBase, FBProviderBase, FlickrProviderBase, FlickrProviderBase, MusicProviderBase, LastFmMusicSearchProviderBase, LastFmMusicServiceProviderBase, LastFmPlaylistServiceProviderBase, MusicProviderBase, and SampleProviderBase.

virtual QString SmfProviderBase::serviceName ( ) const [pure virtual]

Method to get the Localisable name of the service.

Returns:
The Localisable name of the service.

Implemented in FBActivityProviderBase, FBContactProviderBase, FBProviderBase, FlickrProviderBase, FlickrProviderBase, MusicProviderBase, LastFmMusicSearchProviderBase, LastFmMusicServiceProviderBase, LastFmPlaylistServiceProviderBase, MusicProviderBase, and SampleProviderBase.

virtual QUrl SmfProviderBase::serviceUrl ( ) const [pure virtual]

Method to get the Website of the service

Returns:
The Website of the service

Implemented in FBActivityProviderBase, FBContactProviderBase, FBProviderBase, FlickrProviderBase, FlickrProviderBase, MusicProviderBase, LastFmMusicSearchProviderBase, LastFmMusicServiceProviderBase, LastFmPlaylistServiceProviderBase, MusicProviderBase, and SampleProviderBase.

virtual QString SmfProviderBase::smfRegistrationId ( ) const [pure virtual]

Method to get the unique registration ID provided by the Smf for authorised plugins

Returns:
The unique registration ID/token provided by the Smf for authorised plugins

Implemented in FBActivityProviderBase, FBContactProviderBase, FBProviderBase, FlickrProviderBase, FlickrProviderBase, MusicProviderBase, LastFmMusicSearchProviderBase, LastFmMusicServiceProviderBase, LastFmPlaylistServiceProviderBase, MusicProviderBase, and SampleProviderBase.

virtual QList<QString> SmfProviderBase::supportedInterfaces ( ) const [pure virtual]

Method to get the list of interfaces that this provider support

Returns:
List of supported Interafces

Implemented in FBActivityProviderBase, FBContactProviderBase, FBProviderBase, FlickrProviderBase, FlickrProviderBase, MusicProviderBase, LastFmMusicSearchProviderBase, LastFmMusicServiceProviderBase, LastFmPlaylistServiceProviderBase, and MusicProviderBase.

virtual QStringList SmfProviderBase::supportedLanguages ( ) const [pure virtual]

Method to get the list of languages supported by this service provider

Returns:
a QStringList of languages supported by this service provider in 2 letter ISO 639-1 format.

Implemented in FBActivityProviderBase, FBContactProviderBase, FBProviderBase, FlickrProviderBase, FlickrProviderBase, MusicProviderBase, LastFmMusicSearchProviderBase, LastFmMusicServiceProviderBase, LastFmPlaylistServiceProviderBase, and MusicProviderBase.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfserver/smfplugins/smfproviderbase.h
Generated on Thu Sep 23 15:03:46 2010 for smf by doxygen 1.6.3


smf: Member List

SmfProviderBase Member List

This is the complete list of members for SmfProviderBase, including all inherited members.
applicationIcon() const =0 | SmfProviderBase | [pure virtual]
applicationUrl() const =0 | SmfProviderBase | [pure virtual]
authenticationApp(QString &aProgram, QStringList &aArguments, QIODevice::OpenModeFlag aMode=QIODevice::ReadWrite) const =0 | SmfProviderBase | [pure virtual]
description() const =0 | SmfProviderBase | [pure virtual]
pluginId() const =0 | SmfProviderBase | [pure virtual]
serviceIcon() const =0 | SmfProviderBase | [pure virtual]
serviceName() const =0 | SmfProviderBase | [pure virtual]
serviceUrl() const =0 | SmfProviderBase | [pure virtual]
smfRegistrationId() const =0 | SmfProviderBase | [pure virtual]
supportedInterfaces() const =0 | SmfProviderBase | [pure virtual]
supportedLanguages() const =0 | SmfProviderBase | [pure virtual]
~SmfProviderBase() | SmfProviderBase | [inline, virtual]
Generated on Thu Sep 23 15:03:46 2010 for smf by doxygen 1.6.3


smf: SmfRelationItem Class Reference

SmfRelationItem Class Reference
[Client Classes]

#include <smfrelationmgr.h>

Inherits SmfContact.

List of all members.

Public Member Functions

SmfRelationItem ()
SmfProvider | getProvider () const
void | setProvider (SmfProvider &provider)
SmfContact | getContact () const
void | setContact (SmfContact &contact)
quint32 | getIndex () const
void | setIndex (quint32 index)

Detailed Description

One record of a contact in a relation. Index specifies their position in the relationship.

Constructor & Destructor Documentation

SmfRelationItem::SmfRelationItem ( )

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Interface spefication for managing associations between various social contacts

The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfrelationmgr.h
  • smf/smfservermodule/smfclient/smfrelationmgr.cpp
Generated on Thu Sep 23 15:03:46 2010 for smf by doxygen 1.6.3


smf: Member List

SmfRelationItem Member List

This is the complete list of members for SmfRelationItem, including all inherited members.
convert(QContact &aContact) const | SmfContact | [slot]
getContact() const (defined in SmfRelationItem) | SmfRelationItem |
getIndex() const (defined in SmfRelationItem) | SmfRelationItem |
getProvider() const (defined in SmfRelationItem) | SmfRelationItem |
operator=(const SmfContact &aOther) | SmfContact |
setContact(SmfContact &contact) (defined in SmfRelationItem) | SmfRelationItem |
setIndex(quint32 index) (defined in SmfRelationItem) | SmfRelationItem |
setProvider(SmfProvider &provider) (defined in SmfRelationItem) | SmfRelationItem |
setValue(const QString &aSubType, QVariant &value) | SmfContact | [slot]
SmfContact(QObject *aParent=0) | SmfContact |
SmfContact(const SmfContact &aOther) | SmfContact |
SmfRelationItem() | SmfRelationItem |
subTypes() const | SmfContact | [slot]
value(const QString &aSubType) const | SmfContact | [slot]
~SmfContact() | SmfContact |
Generated on Thu Sep 23 15:03:47 2010 for smf by doxygen 1.6.3


smf: SmfRelationMgr Class Reference

SmfRelationMgr Class Reference

#include <smfrelationmgr.h>

List of all members.

Public Slots

SmfRelationId | create (SmfProvider *provider=NULL, SmfContact *contact=NULL)
SmfError | associate (SmfRelationId &phoneId, const SmfContact *contact, SmfProvider *provider)
SmfError | remove (SmfRelationId &relation, const SmfContact *contact)
SmfRelationItem * | searchById (const SmfRelationId &relation)
SmfRelationId | searchByContact (SmfContact contact)
uint | count (SmfRelationId relation)
SmfRelationItem * | get (SmfRelationId &relation, quint32 index)
QList< SmfRelationItem > | getAll (SmfRelationId &relation)
QList< SmfRelationId > | getAllRelations ()
SmfError | Delete (SmfRelationId &relation)

Public Member Functions

SmfRelationMgr (QObject *parent=0)

Detailed Description

All remote profiles (e.g. facebook, twitter, flicker) for a particular person (or entity) constitutes a relation. Relation Manager stores these relations in persistent memory.

Relations and Items can be visualized in rows and columns. Each row is identified by a RelationId. Each column is identified by index of that Item in the relation Each Items holds necessary information for SmfProvider and SmfContact. In the diagram below C1, C2... could be local or remote contacts, which means that C1, C2 .. could be contacts from device-resident phonebook. For example, for contact C1, items at index 1,2,3.. in this relationship denotes C1's id in Facebook, Twitter, flickr,... .

Relation Item Relation Item Relation Item Relation Item Relation Item Index1 index2 index3 index4 index5 _______________________________________________________________________ | | | | | | RelationId 1 | C1 | Remote | Remote | Remote | Remote | | | Contact | Contact | Contact | Contact | ------------------------------------------------------------------------------------------------------------------ | | | | | | RelationId 2 | C2 | Remote | Remote | | | | | Contact | Contact | | | ----------------------------------------------------------------------------------------------------------------- | | | | | | RelationId 3 | C3 | Remote | | | | | | Contact | | | | ----------------------------------------------------------------------------------------------------------------- | | | | | | RelationId 4 | C4 | Remote | Remote | | | | | Contact | Contact | | | ----------------------------------------------------------------------------------------------------------------- | | | | | | RelationId 5 | C5 | Remote | | | | | | Contact | | | | -----------------------------------------------------------------------------------------------------------------

Items can be added (associated) to a given relation. So this is one-to-many relationship. Typically no items be present in more than one relation.

All functions are synchronous at this moment.

Member Function Documentation

SmfError SmfRelationMgr::associate | ( | SmfRelationId & | phoneId,
 |  | const SmfContact * | contact,
 |  | SmfProvider * | provider |
 | ) |  |  | [slot]

assign contact to a relation

uint SmfRelationMgr::count ( SmfRelationId relation ) [slot]

returns number of contacts in a relation

SmfRelationId SmfRelationMgr::create | ( | SmfProvider * | provider = NULL,
 |  | SmfContact * | contact = NULL |
 | ) |  |  | [slot]

create a new relation. The contact provided is the first contact in this relation. Please note that contact should have valid Guid QtMobility::QContactGuid (used by Smf to store the unique id of user from facebook, etc.) and valid Url QtMobility::QContactUrl

If the contact is already stored with ContactManager (e.g. contact exists in phonebook), then it would have QtMobility::QContactId properly filled with managerUri and localId. These two field would also be stored in SmfRelationMgr (for easily identifying the SmfContacts).

After successful creation, a relationId would be returned. More and more SmfContacts can be added to this relation using this RelationId

SmfError SmfRelationMgr::Delete ( SmfRelationId & relation ) [slot]

delete a particular relation

SmfRelationItem * SmfRelationMgr::get | ( | SmfRelationId & | relation,
 |  | quint32 | index |
 | ) |  |  | [slot]

contacts and their provider

QList< SmfRelationItem > SmfRelationMgr::getAll ( SmfRelationId & relation ) [slot]

list of contacts and their provider

QList< SmfRelationId > SmfRelationMgr::getAllRelations ( ) [slot]

list of all relations

SmfError SmfRelationMgr::remove | ( | SmfRelationId & | relation,
 |  | const SmfContact * | contact |
 | ) |  |  | [slot]

remove contact from a relation

SmfRelationId SmfRelationMgr::searchByContact ( SmfContact contact ) [slot]

returns relation Id for a given contacts if exists, NULL otherwise

SmfRelationItem * SmfRelationMgr::searchById ( const SmfRelationId & relation ) [slot]

returns first relation item in the relation when exists, NULL otherwise

The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfrelationmgr.h
  • smf/smfservermodule/smfclient/smfrelationmgr.cpp
Generated on Thu Sep 23 15:03:47 2010 for smf by doxygen 1.6.3


smf: Member List

SmfRelationMgr Member List

This is the complete list of members for SmfRelationMgr, including all inherited members.
associate(SmfRelationId &phoneId, const SmfContact *contact, SmfProvider *provider) | SmfRelationMgr | [slot]
count(SmfRelationId relation) | SmfRelationMgr | [slot]
create(SmfProvider *provider=NULL, SmfContact *contact=NULL) | SmfRelationMgr | [slot]
Delete(SmfRelationId &relation) | SmfRelationMgr | [slot]
get(SmfRelationId &relation, quint32 index) | SmfRelationMgr | [slot]
getAll(SmfRelationId &relation) | SmfRelationMgr | [slot]
getAllRelations() | SmfRelationMgr | [slot]
remove(SmfRelationId &relation, const SmfContact *contact) | SmfRelationMgr | [slot]
searchByContact(SmfContact contact) | SmfRelationMgr | [slot]
searchById(const SmfRelationId &relation) | SmfRelationMgr | [slot]
SmfRelationMgr(QObject *parent=0) (defined in SmfRelationMgr) | SmfRelationMgr |
~SmfRelationMgr() (defined in SmfRelationMgr) | SmfRelationMgr |
Generated on Thu Sep 23 15:03:47 2010 for smf by doxygen 1.6.3


smf: SmfRelationMgrPrivate Class Reference

SmfRelationMgrPrivate Class Reference

List of all members.

Public Member Functions

SmfRelationMgrPrivate (SmfRelationMgr *relnMngr)
SmfRelationId | create (SmfProvider *provider=NULL, SmfContact *contact=NULL)
SmfError | associate (SmfRelationId &relation, const SmfContact *contact, SmfProvider *provider)
SmfError | remove (SmfRelationId &relation, const SmfContact *contact)
SmfRelationItem * | searchById (const SmfRelationId &relation)
SmfRelationId | searchByContact (SmfContact contact)
uint | count (SmfRelationId relation)
SmfRelationItem * | get (SmfRelationId &relation, quint32 index)
QList< SmfRelationItem > | getAll (SmfRelationId &relation)
QList< SmfRelationId > | getAllRelations ()
SmfError | Delete (SmfRelationId &relation)

Friends

class | SmfClientQt

Constructor & Destructor Documentation

SmfRelationMgrPrivate::SmfRelationMgrPrivate ( SmfRelationMgr * relnMngr )

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private Implementation of Relation Manager

Member Function Documentation

SmfError SmfRelationMgrPrivate::associate | ( | SmfRelationId & | relation,
 |  | const SmfContact * | contact,
 |  | SmfProvider * | provider
 | ) |  |

assign contact to a relation

uint SmfRelationMgrPrivate::count ( SmfRelationId relation )

returns number of contacts in a relation

SmfRelationId SmfRelationMgrPrivate::create | ( | SmfProvider * | provider = NULL,
 |  | SmfContact * | contact = NULL
 | ) |  |

create a relation with first contact (id optional)

SmfError SmfRelationMgrPrivate::Delete ( SmfRelationId & relation )

delete a particular relation

SmfRelationItem * SmfRelationMgrPrivate::get | ( | SmfRelationId & | relation,
 |  | quint32 | index
 | ) |  |

contacts and their provider

QList< SmfRelationItem > SmfRelationMgrPrivate::getAll ( SmfRelationId & relation )

list of contacts and their provider

QList< SmfRelationId > SmfRelationMgrPrivate::getAllRelations ( )

list of all relations

SmfError SmfRelationMgrPrivate::remove | ( | SmfRelationId & | relation,
 |  | const SmfContact * | contact
 | ) |  |

remove contact from a relation

SmfRelationId SmfRelationMgrPrivate::searchByContact ( SmfContact contact )

returns relation Id for a given contacts if exists, NULL otherwise

SmfRelationItem * SmfRelationMgrPrivate::searchById ( const SmfRelationId & relation )

returns first relation item in the relation when exists, NULL otherwise

The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfclient/smfrelationmgr_p.h
  • smf/smfservermodule/smfclient/smfrelationmgr_p.cpp
Generated on Thu Sep 23 15:03:47 2010 for smf by doxygen 1.6.3


smf: Member List

SmfRelationMgrPrivate Member List

This is the complete list of members for SmfRelationMgrPrivate, including all inherited members.
associate(SmfRelationId &relation, const SmfContact *contact, SmfProvider *provider) | SmfRelationMgrPrivate |
count(SmfRelationId relation) | SmfRelationMgrPrivate |
create(SmfProvider *provider=NULL, SmfContact *contact=NULL) | SmfRelationMgrPrivate |
Delete(SmfRelationId &relation) | SmfRelationMgrPrivate |
get(SmfRelationId &relation, quint32 index) | SmfRelationMgrPrivate |
getAll(SmfRelationId &relation) | SmfRelationMgrPrivate |
getAllRelations() | SmfRelationMgrPrivate |
remove(SmfRelationId &relation, const SmfContact *contact) | SmfRelationMgrPrivate |
searchByContact(SmfContact contact) | SmfRelationMgrPrivate |
searchById(const SmfRelationId &relation) | SmfRelationMgrPrivate |
SmfClientQt (defined in SmfRelationMgrPrivate) | SmfRelationMgrPrivate | [friend]
SmfRelationMgrPrivate(SmfRelationMgr *relnMngr) | SmfRelationMgrPrivate |
~SmfRelationMgrPrivate() (defined in SmfRelationMgrPrivate) | SmfRelationMgrPrivate |
Generated on Thu Sep 23 15:03:47 2010 for smf by doxygen 1.6.3


smf: SmfResultPage Struct Reference

SmfResultPage Struct Reference

#include <smfglobal.h>

List of all members.

Public Attributes

uint | iTotalItems
uint | iItemsPerPage
uint | iTotalPages
uint | iPageNum

Detailed Description

The structure used to hold the request created by the plugins

Member Data Documentation

uint SmfResultPage::iItemsPerPage

The number of items per page

uint SmfResultPage::iPageNum

The current fetched page number

uint SmfResultPage::iTotalItems

The total number of items

uint SmfResultPage::iTotalPages

The total number of pages

The documentation for this struct was generated from the following file:
  • smf/smfservermodule/smfcommon/smfglobal.h
Generated on Thu Sep 23 15:03:47 2010 for smf by doxygen 1.6.3


smf: Member List

SmfResultPage Member List

This is the complete list of members for SmfResultPage, including all inherited members.
iItemsPerPage | SmfResultPage
iPageNum | SmfResultPage
iTotalItems | SmfResultPage
iTotalPages | SmfResultPage
Generated on Thu Sep 23 15:03:47 2010 for smf by doxygen 1.6.3


smf: SmfServer Class Reference

SmfServer Class Reference

#include <smfserver.h>

List of all members.

Public Slots

void | clientAuthorizationFinished (bool success, SmfClientAuthID authID)
void | resultsAvailable (int requestID, QByteArray *parsedData, SmfError error)
void | dataStoreUpdateAvailable (QByteArray *respData)
void | authenticationKeysExpired (NotificationType type, SmfPluginID id)

Public Member Functions

SmfServer (QObject *parent=0)
bool | startServer ()
void | getPlugins (const SmfInterfaceID &interfaceID, QMap< SmfPluginID, SmfProvider > &pluginIDMap)
SmfPluginID | getPlugin (const SmfInterfaceID &interfaceID, SmfProvider provider)
void | getAuthorizedPlugins (QList< SmfPluginID > &list, QList< SmfPluginID > &authList)
QStringList | getAuthenticatedPluginList (QString RegistrationToken)
SmfError | sendToPluginManager (int requestID, SmfPluginID pluginID, SmfInterfaceID interfaceID, SmfRequestTypeID requestTypeID, QByteArray dataForPlugin=QByteArray())
SmfError | sendToPluginManager (SmfPluginID pluginID, SmfInterfaceID interfaceID, SmfRequestTypeID requestTypeID, QByteArray dataForPlugin, QByteArray &outputData)
SmfError | sendToDSM (QByteArray qtdataForDSM, SmfRequestTypeID opcode, QByteArray &qtdataFromDSM)

Detailed Description

SmfServer manages the client requests and delegates them to the appropriate SMF component, service the clients synchronously or asynchronously

Constructor & Destructor Documentation

SmfServer::SmfServer ( QObject * parent = 0 )

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: SMF Server component which handles the client requests and delegates them properly to the appropriate component

Member Function Documentation

void SmfServer::authenticationKeysExpired | ( | NotificationType | type,
 |  | SmfPluginID | id |
 | ) |  |  | [slot]

Server calls this method when it receives message from the CM that authentication keys for the pluginID has expired

This is called when CMclient notifies client expiry.

Parameters:
type | notification type, set of enums for future expansion
id | Plugin Id for which the authentication has expired
void SmfServer::clientAuthorizationFinished | ( | bool | success,
 |  | SmfClientAuthID | authID |
 | ) |  |  | [slot]

This slot is called when Credential Manager is done with the autherizing the client for the first time. See isClientAuthorized() and authorizeClient(). success specifies the success of the authorization, authID is the authentication ID in case its not same as SID of the client.

This slot is invoked when CM finishes the authorization of the client.

Parameters:
authID As it contains the session ptr, sever directly invokes the session's API to notify success
void SmfServer::dataStoreUpdateAvailable ( QByteArray * respData ) [inline, slot]

This slot is called when the data store updates are available as a result of "runSavedRequest()". Note:- The "10.4.1.11 updateDatastore" can be merged with this

QStringList SmfServer::getAuthenticatedPluginList ( QString RegistrationToken )

Request CM API to get the list of authenticated plugins

See also:
SmfCredMgrClient::authenticatedPluginList()
void SmfServer::getAuthorizedPlugins | ( | QList< SmfPluginID > & | list,
 |  | QList< SmfPluginID > & | authList
 | ) |  |

Requests the Credential Manager to filter out non-authorized plugin IDs from the list and get authorized plugins into authList.

This API is called by the private impl to get a list of authorized plugins from CM

Parameters:
list | List of plugins to be filtered
authList | List of authorised plugins filled by CM this is returned to the private impl It calls CMclient to get the list synchronously TODO:- session should store this for future ref?
SmfPluginID SmfServer::getPlugin | ( | const SmfInterfaceID & | interfaceID,
 |  | SmfProvider | provider
 | ) |  |

Same as above, except this is used for rest of the requests where we need a particular plugin

void SmfServer::getPlugins | ( | const SmfInterfaceID & | interfaceID,
 |  | QMap< SmfPluginID, SmfProvider > & | pluginIDMap
 | ) |  |

Requests Plugin Manager to get a list of plugin IDs who implement the interface interfaceID. This is used for SmfClient::GetServices () where we need a list of plugins

This API is called by the private impl when client is authorized

Parameters:
interfaceID | Interface id, provided by the private impl (it gets it from client)
pluginIDMap | Map of plugins who implement this interface and corresponding provider, this is returned to the private impl It calls PM to get the list. Note:- PM may return SmfProviderBase which is superset of SmfProvider. TODO:- session should store this map for future ref?
void SmfServer::resultsAvailable | ( | int | requestID,
 |  | QByteArray * | parsedData,
 |  | SmfError | error |
 | ) |  |  | [slot]

This slot is called as a result of trigger from Plugin manager when the parsed data is available.

Parameters:
requestID | The request ID for which result is available
parsedData | Serialized data

This API is called by PM once its done with request and parsing

Parameters:
requestID | The request id which is completed
parsedData | Serialized data(as per request type) filled by PM
error | Error occured TODO:- should use smf wide global errors instead
SmfError SmfServer::sendToDSM | ( | QByteArray | qtdataForDSM,
 |  | SmfRequestTypeID | opcode,
 |  | QByteArray & | qtdataFromDSM
 | ) |  |

Delegates the request to DSM and receives data synshronously.

Parameters:
qtdataForDSM | Data to be passed to DSM
opcode | Opcode
qtdataFromDSM | Data received from DSM
Returns:
Error value returned from DSM
SmfError SmfServer::sendToPluginManager | ( | SmfPluginID | pluginID,
 |  | SmfInterfaceID | interfaceID,
 |  | SmfRequestTypeID | requestTypeID,
 |  | QByteArray | dataForPlugin,
 |  | QByteArray & | outputData
 | ) |  |

Request the Plugin manager to get the data.

Parameters:
requestID | Corresponds to a client's session
pluginID | Plugin for which the request is intended
interfaceID | Interface name
dataForPlugin | Data to be sent for this request
SmfError SmfServer::sendToPluginManager | ( | int | requestID,
 |  | SmfPluginID | pluginID,
 |  | SmfInterfaceID | interfaceID,
 |  | SmfRequestTypeID | requestTypeID,
 |  | QByteArray | dataForPlugin = QByteArray()
 | ) |  |

Request the Plugin manager to get the data.

Parameters:
requestID | Corresponds to a client's session
pluginID | Plugin for which the request is intended
interfaceID | Interface name
dataForPlugin | Data to be sent for this request
bool SmfServer::startServer ( )

Does the following,- First it'll check whether server is already running, if already running it'll simply return else it'll start the server exe and initialize all other SMF components returns whether server is started successfully or not

The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfserver/server/smfserver.h
  • smf/smfservermodule/smfserver/server/smfserver.cpp
Generated on Thu Sep 23 15:03:47 2010 for smf by doxygen 1.6.3


smf: Member List

SmfServer Member List

This is the complete list of members for SmfServer, including all inherited members.
authenticationKeysExpired(NotificationType type, SmfPluginID id) | SmfServer | [slot]
clientAuthorizationFinished(bool success, SmfClientAuthID authID) | SmfServer | [slot]
dataStoreUpdateAvailable(QByteArray *respData) | SmfServer | [inline, slot]
getAuthenticatedPluginList(QString RegistrationToken) | SmfServer |
getAuthorizedPlugins(QList< SmfPluginID > &list, QList< SmfPluginID > &authList) | SmfServer |
getPlugin(const SmfInterfaceID &interfaceID, SmfProvider provider) | SmfServer |
getPlugins(const SmfInterfaceID &interfaceID, QMap< SmfPluginID, SmfProvider > &pluginIDMap) | SmfServer |
resultsAvailable(int requestID, QByteArray *parsedData, SmfError error) | SmfServer | [slot]
sendToDSM(QByteArray qtdataForDSM, SmfRequestTypeID opcode, QByteArray &qtdataFromDSM) | SmfServer |
sendToPluginManager(int requestID, SmfPluginID pluginID, SmfInterfaceID interfaceID, SmfRequestTypeID requestTypeID, QByteArray dataForPlugin=QByteArray()) | SmfServer |
sendToPluginManager(SmfPluginID pluginID, SmfInterfaceID interfaceID, SmfRequestTypeID requestTypeID, QByteArray dataForPlugin, QByteArray &outputData) | SmfServer |
SmfServer(QObject *parent=0) | SmfServer |
startServer() | SmfServer |
~SmfServer() (defined in SmfServer) | SmfServer |
Generated on Thu Sep 23 15:03:47 2010 for smf by doxygen 1.6.3


smf: SmfServerQt Class Reference

SmfServerQt Class Reference

List of all members.

Public Member Functions

SmfServerQt (SmfServer *wrapper)
SmfServer * | wrapper () const
bool | start ()
int | sessionListCount () const
void | clientAuthorizationFinished (bool success)
int | findAndServiceclient (int requestID, QByteArray *parsedData, SmfError error)
bool | start ()
int | sessionListCount () const

Constructor & Destructor Documentation

SmfServerQt::SmfServerQt ( SmfServer * wrapper )

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan Description: SMF Server implementation for platforms other than Symbian. Uses QLocalServer-QLocalSocket classes

Member Function Documentation

void SmfServerQt::clientAuthorizationFinished ( bool success )

Called by the SmfServer when client authorization finishes.

Parameters:
success success of the authorization
int SmfServerQt::sessionListCount ( ) const

Return the number of open sessions

bool SmfServerQt::start ( )

Start the server listening for connections.

The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfserver/server/smfserverqt_p.h
  • smf/smfservermodule/smfserver/server/smfserverqt.cpp
Generated on Thu Sep 23 15:03:47 2010 for smf by doxygen 1.6.3


smf: Member List

SmfServerQt Member List

This is the complete list of members for SmfServerQt, including all inherited members.
clientAuthorizationFinished(bool success) | SmfServerQt |
findAndServiceclient(int requestID, QByteArray *parsedData, SmfError error) (defined in SmfServerQt) | SmfServerQt |
sessionListCount() const | SmfServerQt |
sessionListCount() const (defined in SmfServerQt) | SmfServerQt | [inline]
SmfServerQt(SmfServer *wrapper) | SmfServerQt |
start() | SmfServerQt |
start() (defined in SmfServerQt) | SmfServerQt | [inline]
wrapper() const (defined in SmfServerQt) | SmfServerQt | [inline]
~SmfServerQt() (defined in SmfServerQt) | SmfServerQt |
~SmfServerQt() (defined in SmfServerQt) | SmfServerQt | [inline]
Generated on Thu Sep 23 15:03:47 2010 for smf by doxygen 1.6.3


smf: SmfServerQtSession Class Reference

SmfServerQtSession Class Reference

List of all members.

Public Slots

void | readDataFromClient ()
void | socketError (QLocalSocket::LocalSocketError error)

Public Member Functions

SmfServerQtSession (QLocalSocket *clientConnection, SmfServerQt *server)
void | clientAuthorizationFinished (bool success)

Constructor & Destructor Documentation

SmfServerQtSession::SmfServerQtSession | ( | QLocalSocket * | clientConnection,
 |  | SmfServerQt * | server
 | ) |  |

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Session implementation for Qt desktop builds

The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfserver/server/smfserverqtsession.h
  • smf/smfservermodule/smfserver/server/smfserverqtsession.cpp
Generated on Thu Sep 23 15:03:47 2010 for smf by doxygen 1.6.3


smf: Member List

SmfServerQtSession Member List

This is the complete list of members for SmfServerQtSession, including all inherited members.
clientAuthorizationFinished(bool success) (defined in SmfServerQtSession) | SmfServerQtSession |
readDataFromClient() (defined in SmfServerQtSession) | SmfServerQtSession | [slot]
SmfServerQtSession(QLocalSocket *clientConnection, SmfServerQt *server) | SmfServerQtSession |
socketError(QLocalSocket::LocalSocketError error) (defined in SmfServerQtSession) | SmfServerQtSession | [slot]
~SmfServerQtSession() (defined in SmfServerQtSession) | SmfServerQtSession |
Generated on Thu Sep 23 15:03:47 2010 for smf by doxygen 1.6.3


smf: SmfServerSymbian Class Reference

SmfServerSymbian Class Reference

#include <smfserversymbian_p.h>

List of all members.

Public Member Functions

CSession2 * | NewSessionL (const TVersion &aVersion, const RMessage2 &aMessage) const
SmfServer * wrapper ()
TInt | addToSessionMap (SmfServerSymbianSession *aSession, const RMessage2 &aMsg)
TInt | removeFromSessionMap (SmfServerSymbianSession *aSession, RMessage2 &aMsg)
SmfServerSymbianSession * | findSession (TInt id)
TInt | findAndServiceclient (TInt requestID, QByteArray *parsedData, SmfError error)

Static Public Member Functions

static SmfServerSymbian * | NewL (CActive::TPriority aActiveObjectPriority, SmfServer *aWrapper)

Friends

class | SmfServerSymbianSession

Detailed Description

Our server class - an active object - and therefore derived ultimately from CActive. It accepts requests from client threads and forwards them to the client session to be dealt with. It also handles the creation of the server-side client session.

Member Function Documentation

TInt SmfServerSymbian::addToSessionMap | ( | SmfServerSymbianSession * | aSession,
 |  | const RMessage2 & | aMsg
 | ) |  |

Adds session info to the currently active session map iMap. This map is used to retreive the corresponding session to be serviced. The keys for this map is sent alongwith the request to other components

Parameters:
aSession | Session to be added
aMsg | Currently redundant
TInt SmfServerSymbian::findAndServiceclient | ( | TInt | requestID,
 |  | QByteArray * | parsedData,
 |  | SmfError | error
 | ) |  |

Finds the given session and services it with the data.

Parameters:
requestID | Session ID
parsedData | Parsed and serialized data to be sent to client.
error | Error code
SmfServerSymbianSession * SmfServerSymbian::findSession ( TInt id )

Returns a symbian session for the given key from the iMap.

Parameters:
id Session ID in the SmfServer Session map
SmfServerSymbian * SmfServerSymbian::NewL | ( | CActive::TPriority | aActiveObjectPriority,
 |  | SmfServer * | aWrapper |
 | ) |  |  | [static]

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: SMF Server private implementation for Symbian

TInt SmfServerSymbian::removeFromSessionMap | ( | SmfServerSymbianSession * | aSession,
 |  | RMessage2 & | aMsg
 | ) |  |

Removes the session from the active list of session map

Parameters:
aSession | Session to be removed.
aMsg | Currently redundant
SmfServer * SmfServerSymbian::wrapper ( )

Returns SmfServer

The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfserver/server/smfserversymbian_p.h
  • smf/smfservermodule/smfserver/server/smfserversymbian.cpp
Generated on Thu Sep 23 15:03:48 2010 for smf by doxygen 1.6.3


smf: Member List

SmfServerSymbian Member List

This is the complete list of members for SmfServerSymbian, including all inherited members.
addToSessionMap(SmfServerSymbianSession *aSession, const RMessage2 &aMsg) | SmfServerSymbian |
findAndServiceclient(TInt requestID, QByteArray *parsedData, SmfError error) | SmfServerSymbian |
findSession(TInt id) | SmfServerSymbian |
NewL(CActive::TPriority aActiveObjectPriority, SmfServer *aWrapper) | SmfServerSymbian | [static]
NewSessionL(const TVersion &aVersion, const RMessage2 &aMessage) const (defined in SmfServerSymbian) | SmfServerSymbian |
removeFromSessionMap(SmfServerSymbianSession *aSession, RMessage2 &aMsg) | SmfServerSymbian |
SmfServerSymbianSession (defined in SmfServerSymbian) | SmfServerSymbian | [friend]
wrapper() | SmfServerSymbian |
~SmfServerSymbian() (defined in SmfServerSymbian) | SmfServerSymbian |
Generated on Thu Sep 23 15:03:48 2010 for smf by doxygen 1.6.3


smf: SmfServerSymbianSession Class Reference

SmfServerSymbianSession Class Reference

#include <smfserversymbian_p.h>

List of all members.

Public Member Functions

SmfServerSymbianSession (SmfServerSymbian *aServer)
void | ServiceL (const RMessage2 &aMessage)
void | resultsAvailable (QByteArray *parsedData, SmfError error)
void | clientAuthorizationFinished (bool success)

Protected Member Functions

void | PanicClient (const RMessage2 &aMessage, TInt aPanic) const
void | HandleClientMessageL (const RMessage2 &aMessage)

Detailed Description

This class represents a session with the Smf server. Functions are provided to respond appropriately to client messages.

Constructor & Destructor Documentation

SmfServerSymbianSession::SmfServerSymbianSession ( SmfServerSymbian * aServer )

Creates a session.

Parameters:
aServer The server handle

Member Function Documentation

void SmfServerSymbianSession::clientAuthorizationFinished ( bool success )

Called by the SmfServer when client authorization finishes.

Parameters:
success success of the authorization
void SmfServerSymbianSession::HandleClientMessageL ( const RMessage2 & aMessage ) [protected]

Called by ServiceL() It tests the function code and then delegates to the appropriate function.

Note:- Only ESmfGetService needs to be taken care separately as it doesn't involve createrequest for PM See SmfRequestTypeID for list of opcodes

Two cases,- 1.for ESmfGetServices we donno the provider info 2. for rest of the cases, we know the provider info so it seems PM needs to provide two overloaded getPlugins API But for every client intf instanciation we would execute the same things twice. TODO:- to be changed after GetServices returns SmfProvider+pluginID

void SmfServerSymbianSession::resultsAvailable | ( | QByteArray * | parsedData,
 |  | SmfError | error
 | ) |  |

Called by the SmfServerSymbian when results are available

Parameters:
parsedData | Parsed serialized data
error | Smf Error code
void SmfServerSymbianSession::ServiceL ( const RMessage2 & aMessage )

From CSession2

The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfserver/server/smfserversymbian_p.h
  • smf/smfservermodule/smfserver/server/smfserversymbian.cpp
Generated on Thu Sep 23 15:03:48 2010 for smf by doxygen 1.6.3


smf: Member List

SmfServerSymbianSession Member List

This is the complete list of members for SmfServerSymbianSession, including all inherited members.
clientAuthorizationFinished(bool success) | SmfServerSymbianSession |
HandleClientMessageL(const RMessage2 &aMessage) | SmfServerSymbianSession | [protected]
PanicClient(const RMessage2 &aMessage, TInt aPanic) const (defined in SmfServerSymbianSession) | SmfServerSymbianSession | [protected]
resultsAvailable(QByteArray *parsedData, SmfError error) | SmfServerSymbianSession |
ServiceL(const RMessage2 &aMessage) | SmfServerSymbianSession |
SmfServerSymbianSession(SmfServerSymbian *aServer) | SmfServerSymbianSession |
~SmfServerSymbianSession() (defined in SmfServerSymbianSession) | SmfServerSymbianSession |
Generated on Thu Sep 23 15:03:48 2010 for smf by doxygen 1.6.3


smf: SMFSettings Class Reference

SMFSettings Class Reference

#include <SMFSettings.h>

List of all members.

Public Slots

void | SaveSettings ()
void | ClearData ()

Public Member Functions

SMFSettings ()
void | SetPluginDetails (QString aPluginName, QString aPluginStatus)
void | SetAuthExpirationValue (QString aVal)
void | SetMaxDataTransferLimit (QString aVal)
void | SetRoamingStatusforDataTransfer (QString aStatus)
void | SetUploadFileType (QString aFileType)
QStringList | GetPluginDetails () const
QString | GetAuthExpirationValue () const
QString | GetMaxDataTransferLimit () const
QString | GetRoamingStatusforDataTransfer () const
QString | GetUploadFileType () const

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "{License}" which accompanies this distribution, and is available at the URL "{LicenseUrl}".

Initial Contributors: Narasimhulu Kavadapu, Sasken Communication Technologies Ltd - Initial contribution

Contributors:

Description: Settings UI class of SMF

Constructor & Destructor Documentation

SMFSettings::SMFSettings ( )

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "{License}" which accompanies this distribution, and is available at the URL "{LicenseUrl}".

Initial Contributors: Narasimhulu Kavadapu, Sasken Communication Technologies Ltd - Initial contribution

Contributors:

Description: Settings UI class of SMF

The documentation for this class was generated from the following files:
  • smf/smfsettingsui/SMFSettings.h
  • smf/smfsettingsui/SMFSettings.cpp
Generated on Thu Sep 23 15:03:48 2010 for smf by doxygen 1.6.3


smf: Member List

SMFSettings Member List

This is the complete list of members for SMFSettings, including all inherited members.
ClearData() (defined in SMFSettings) | SMFSettings | [slot]
GetAuthExpirationValue() const (defined in SMFSettings) | SMFSettings |
GetMaxDataTransferLimit() const (defined in SMFSettings) | SMFSettings |
GetPluginDetails() const (defined in SMFSettings) | SMFSettings |
GetRoamingStatusforDataTransfer() const (defined in SMFSettings) | SMFSettings |
GetUploadFileType() const (defined in SMFSettings) | SMFSettings |
SaveSettings() (defined in SMFSettings) | SMFSettings | [slot]
SetAuthExpirationValue(QString aVal) (defined in SMFSettings) | SMFSettings |
SetMaxDataTransferLimit(QString aVal) (defined in SMFSettings) | SMFSettings |
SetPluginDetails(QString aPluginName, QString aPluginStatus) (defined in SMFSettings) | SMFSettings |
SetRoamingStatusforDataTransfer(QString aStatus) (defined in SMFSettings) | SMFSettings |
SetUploadFileType(QString aFileType) (defined in SMFSettings) | SMFSettings |
SMFSettings() | SMFSettings |
~SMFSettings() (defined in SMFSettings) | SMFSettings |
Generated on Thu Sep 23 15:03:48 2010 for smf by doxygen 1.6.3


smf: SmfSettingsHandler Class Reference

SmfSettingsHandler Class Reference

List of all members.

Public Slots

void | SetPluginDetails (QString &aPluginName, QString &aPluginStatus)
void | SetAuthExpirationValue (QString &aVal)
void | SetMaxDataTransferLimit (QString &aVal)
void | SetRoamingStatusforDataTransfer (QString &aStatus)
void | SetUploadFileType (QString &aFileType)
void | GetPluginDetails (QMap< QString, QString > &aDetails) const
QString | GetAuthExpirationValue () const
QString | GetMaxDataTransferLimit () const
QString | GetRoamingStatusforDataTransfer () const
QString | GetUploadFileType () const

Public Member Functions

SmfSettingsHandler (QObject *parent=0)

Constructor & Destructor Documentation

SmfSettingsHandler::SmfSettingsHandler ( QObject * parent = 0 )

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Reads/Writes settings key in a platform independent way

The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfserver/server/smfsettingshandler.h
  • smf/smfservermodule/smfserver/server/smfsettingshandler.cpp
Generated on Thu Sep 23 15:03:48 2010 for smf by doxygen 1.6.3


smf: Member List

SmfSettingsHandler Member List

This is the complete list of members for SmfSettingsHandler, including all inherited members.
GetAuthExpirationValue() const (defined in SmfSettingsHandler) | SmfSettingsHandler | [slot]
GetMaxDataTransferLimit() const (defined in SmfSettingsHandler) | SmfSettingsHandler | [slot]
GetPluginDetails(QMap< QString, QString > &aDetails) const (defined in SmfSettingsHandler) | SmfSettingsHandler | [slot]
GetRoamingStatusforDataTransfer() const (defined in SmfSettingsHandler) | SmfSettingsHandler | [slot]
GetUploadFileType() const (defined in SmfSettingsHandler) | SmfSettingsHandler | [slot]
SetAuthExpirationValue(QString &aVal) (defined in SmfSettingsHandler) | SmfSettingsHandler | [slot]
SetMaxDataTransferLimit(QString &aVal) (defined in SmfSettingsHandler) | SmfSettingsHandler | [slot]
SetPluginDetails(QString &aPluginName, QString &aPluginStatus) (defined in SmfSettingsHandler) | SmfSettingsHandler | [slot]
SetRoamingStatusforDataTransfer(QString &aStatus) (defined in SmfSettingsHandler) | SmfSettingsHandler | [slot]
SetUploadFileType(QString &aFileType) (defined in SmfSettingsHandler) | SmfSettingsHandler | [slot]
SmfSettingsHandler(QObject *parent=0) | SmfSettingsHandler |
~SmfSettingsHandler() (defined in SmfSettingsHandler) | SmfSettingsHandler |
Generated on Thu Sep 23 15:03:48 2010 for smf by doxygen 1.6.3


smf: SmfSettingsRepositoryQt Class Reference

SmfSettingsRepositoryQt Class Reference

#include <smfsettingshandler_qt.h>

List of all members.

Public Member Functions

~SmfSettingsRepositoryQt ()
SmfSettingsRepositoryQt (QObject *parent=0)
void | SetPluginDetails (QString &aPluginName, QString &aPluginStatus)
void | SetAuthExpirationValue (QString &aVal)
void | SetMaxDataTransferLimit (QString &aVal)
void | SetRoamingStatusforDataTransfer (QString &aStatus)
void | SetUploadFileType (QString &aFileType)
void | GetPluginDetails (QMap< QString, QString > &aDetails) const
QString | GetAuthExpirationValue () const
QString | GetMaxDataTransferLimit () const
QString | GetRoamingStatusforDataTransfer () const
QString | GetUploadFileType () const

Detailed Description

An instance Platform Independent Settings class to set/get setting values to/from symbian repository.

Constructor & Destructor Documentation

SmfSettingsRepositoryQt::~SmfSettingsRepositoryQt ( )

~SmfSettingsRepositoryQt

Destroy the object and release all memory objects

SmfSettingsRepositoryQt::SmfSettingsRepositoryQt ( QObject * parent = 0 )

SmfSettingsRepositoryQt

Construct the Settings Object

The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfserver/server/smfsettingshandler_qt.h
  • smf/smfservermodule/smfserver/server/smfsettingshandler_qt.cpp
Generated on Thu Sep 23 15:03:48 2010 for smf by doxygen 1.6.3


smf: Member List

SmfSettingsRepositoryQt Member List

This is the complete list of members for SmfSettingsRepositoryQt, including all inherited members.
GetAuthExpirationValue() const (defined in SmfSettingsRepositoryQt) | SmfSettingsRepositoryQt
GetMaxDataTransferLimit() const (defined in SmfSettingsRepositoryQt) | SmfSettingsRepositoryQt
GetPluginDetails(QMap< QString, QString > &aDetails) const (defined in SmfSettingsRepositoryQt) | SmfSettingsRepositoryQt
GetRoamingStatusforDataTransfer() const (defined in SmfSettingsRepositoryQt) | SmfSettingsRepositoryQt
GetUploadFileType() const (defined in SmfSettingsRepositoryQt) | SmfSettingsRepositoryQt
SetAuthExpirationValue(QString &aVal) (defined in SmfSettingsRepositoryQt) | SmfSettingsRepositoryQt
SetMaxDataTransferLimit(QString &aVal) (defined in SmfSettingsRepositoryQt) | SmfSettingsRepositoryQt
SetPluginDetails(QString &aPluginName, QString &aPluginStatus) (defined in SmfSettingsRepositoryQt) | SmfSettingsRepositoryQt
SetRoamingStatusforDataTransfer(QString &aStatus) (defined in SmfSettingsRepositoryQt) | SmfSettingsRepositoryQt
SetUploadFileType(QString &aFileType) (defined in SmfSettingsRepositoryQt) | SmfSettingsRepositoryQt
SmfSettingsRepositoryQt(QObject *parent=0) | SmfSettingsRepositoryQt
~SmfSettingsRepositoryQt() | SmfSettingsRepositoryQt
Generated on Thu Sep 23 15:03:48 2010 for smf by doxygen 1.6.3


smf: SMFSocialNetworkingSite Class Reference

SMFSocialNetworkingSite Class Reference

This class represents a social networking site. More...

#include <smfSns.h>

List of all members.

Public Slots

void | setSnsName (const QString &name)
Setter method for name of the social networking site.
void | setSnsURL (const QString &url)
Setter method for the URL of the social networking site.

Public Member Functions

SMFSocialNetworkingSite (const QString &name="", const QString &url="", QObject *parent=0)
Constructor for SMFSocialNetworkingSite class.
int | snsID () const
Returns the ID for the social networking site the object corresponds to.
const QString & | snsName () const
Gets the name of the social networking site.
const QString & | snsURL () const
Gets the URL of the social networking site.
~SMFSocialNetworkingSite ()
Destructor for SMFSocialNetworkingSite class.

Friends

class | DataStoreManager

Detailed Description

This class represents a social networking site.

See also:
SMFSocialProfile

Constructor & Destructor Documentation

SMFSocialNetworkingSite::SMFSocialNetworkingSite | ( | const QString & | name = "",
 |  | const QString & | url = "",
 |  | QObject * | parent = 0
 | ) |  |

Constructor for SMFSocialNetworkingSite class.

Parameters:
name | Name of the Social Networking site
url | URL of the Social Networking Site
parent | Parent of the class. Default 0.

Member Function Documentation

void SMFSocialNetworkingSite::setSnsName ( const QString & name ) [slot]

Setter method for name of the social networking site.

Parameters:
name reference to the name object
See also:
snsName()
void SMFSocialNetworkingSite::setSnsURL ( const QString & url ) [slot]

Setter method for the URL of the social networking site.

Parameters:
url const reference to the URL object
See also:
snsURL()
int SMFSocialNetworkingSite::snsID ( ) const

Returns the ID for the social networking site the object corresponds to.

Returns:
Integer ID for the social networking site the object represents.
const QString & SMFSocialNetworkingSite::snsName ( ) const

Gets the name of the social networking site.

Returns:
A const reference to the name of the social networking site
See also:
setSnsName()
const QString & SMFSocialNetworkingSite::snsURL ( ) const

Gets the URL of the social networking site.

Returns:
A const reference to the URL of the social networking site
See also:
setSnsURL()
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfserver/datastoremgr/smfSns.h
  • smf/smfservermodule/smfserver/datastoremgr/smfSns.cpp
Generated on Thu Sep 23 15:03:48 2010 for smf by doxygen 1.6.3


smf: Member List

SMFSocialNetworkingSite Member List

This is the complete list of members for SMFSocialNetworkingSite, including all inherited members.
DataStoreManager (defined in SMFSocialNetworkingSite) | SMFSocialNetworkingSite | [friend]
setSnsName(const QString &name) | SMFSocialNetworkingSite | [slot]
setSnsURL(const QString &url) | SMFSocialNetworkingSite | [slot]
SMFSocialNetworkingSite(const QString &name="", const QString &url="", QObject *parent=0) | SMFSocialNetworkingSite |
snsID() const | SMFSocialNetworkingSite |
snsName() const | SMFSocialNetworkingSite |
snsURL() const | SMFSocialNetworkingSite |
~SMFSocialNetworkingSite() | SMFSocialNetworkingSite |
Generated on Thu Sep 23 15:03:48 2010 for smf by doxygen 1.6.3


smf: SMFSocialProfile Class Reference

SMFSocialProfile Class Reference

This class represents a user's public profile on a social networking site. More...

#include <smfSocialProfile.h>

List of all members.

Public Slots

void | setAssociatedSns (const SMFSocialNetworkingSite &site)
Sets the social networking site associated to this ID. This function and the related function setAssociatedSnsID() do the same job of associating a social networking site to this profile. Either one of these can be called to create an association. There is no requirement to call both separately.
void | setAssociatedSnsID (int sns_id)
Sets the social networking site associated to this ID. This function and the related function setAssociatedSns() do the same job of associating a social networking site to this profile. Either one of these can be called to create an association. There is no requirement to call both separately.
void | setProfileURL (const QString &profile_url)
Sets the profile URL for the social profile.
void | setScreenAlias (const QString &screen_alias)
Sets the screen alias for the social profile.

Public Member Functions

SMFSocialProfile (const SMFSocialNetworkingSite &site, const QString &profile_url="", const QString &screen_alias="", QObject *parent=0)
Constructor for the class SMFSocialProfile.
SMFSocialProfile (int sns_id=-1, int user_id=-1, const QString &profile_url="", const QString &screen_alias="", QObject *parent=0)
Constructor for the class SMFSocialProfile.
SMFSocialProfile (const SMFSocialProfile &other)
~SMFSocialProfile ()
Destructor for the class SMFSocialProfile.
int | associatedUserID () const
Gets the ID of the User Profile associated with this profile.
int | associatedSnsID () const
Gets the ID of the Social Networking Site associated with this profile.
int | profileID () const
Gets the profile ID of the social profile.
const QString & | profileURL () const
Gets profile URL of the social profile.
const QString & | screenAlias () const
Gets the screen alias of the social profile.

Friends

class | DataStoreManager

Detailed Description

This class represents a user's public profile on a social networking site.

A social profile represents the information about the user/contact profiles on various social networking sites. Every profile on a social networking site gets a social profile. A single social profile can be tied to one social networking site and one user profile.

See also:
SMFUserProfile , SMFSocialNetworkingSite

Constructor & Destructor Documentation

SMFSocialProfile::SMFSocialProfile | ( | const SMFSocialNetworkingSite & | site,
 |  | const QString & | profile_url = "",
 |  | const QString & | screen_alias = "",
 |  | QObject * | parent = 0
 | ) |  |

Constructor for the class SMFSocialProfile.

Parameters:
site | A constant reference to the SMFSocialNetworkingSite profile associated with this profile.
user_profile | A constant reference to the SMFUserProfile object associated with this profile.
parent | Reference to the parent object.
SMFSocialProfile::SMFSocialProfile | ( | int | sns_id = -1,
 |  | int | user_id = -1,
 |  | const QString & | profile_url = "",
 |  | const QString & | screen_alias = "",
 |  | QObject * | parent = 0
 | ) |  |

Constructor for the class SMFSocialProfile.

Parameters:
sns_id | Integer id of the SMFSocialNetworkingSite profile associated with this profile.
user_id | Integer id of the SMFUserProfile associated with this profile.
parent | Reference to the parent object.

Member Function Documentation

int SMFSocialProfile::associatedSnsID ( ) const

Gets the ID of the Social Networking Site associated with this profile.

Returns:
Integer ID of the Social Networking Site associated with this profile.
See also:
setAssociatedSnsID()
setAssociatedSns()
int SMFSocialProfile::associatedUserID ( ) const

Gets the ID of the User Profile associated with this profile.

Returns:
Integer ID identifying the User Profile associated with this profile.
See also:
setAssociatedUserID()
setAssociatedUserProfile()
int SMFSocialProfile::profileID ( ) const

Gets the profile ID of the social profile.

Returns:
Returns an Integer ID of this profile.
const QString & SMFSocialProfile::profileURL ( ) const

Gets profile URL of the social profile.

Returns:
Returns a QString containing the profile URL of this social profile. An empty string is returned if the value is not present.
See also:
setProfileURL()
const QString & SMFSocialProfile::screenAlias ( ) const

Gets the screen alias of the social profile.

Returns:
Returns a QString containing the screen alias of this social profile. An empty string is returned if the value is not present.
See also:
setScreenAlias()
void SMFSocialProfile::setAssociatedSns ( const SMFSocialNetworkingSite & site ) [slot]

Sets the social networking site associated to this ID. This function and the related function setAssociatedSnsID() do the same job of associating a social networking site to this profile. Either one of these can be called to create an association. There is no requirement to call both separately.

Parameters:
site Constant reference to the SMFSocialNetworkingSite to be associated.
See also:
setAssociatedSnsID()
associatedSnsID()
void SMFSocialProfile::setAssociatedSnsID ( int sns_id ) [slot]

Sets the social networking site associated to this ID. This function and the related function setAssociatedSns() do the same job of associating a social networking site to this profile. Either one of these can be called to create an association. There is no requirement to call both separately.

Parameters:
id Integer ID of the Social Networking site to be associated.
See also:
setAssociatedSns()
associatedSnsID()
void SMFSocialProfile::setProfileURL ( const QString & profile_url ) [slot]

Sets the profile URL for the social profile.

Parameters:
profile_url Constant reference to the profile URL string.
See also:
profileURL()
void SMFSocialProfile::setScreenAlias ( const QString & screen_alias ) [slot]

Sets the screen alias for the social profile.

Parameters:
screen_alias Constant reference to the screen alias string.
See also:
screenAlias()
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfserver/datastoremgr/smfSocialProfile.h
  • smf/smfservermodule/smfserver/datastoremgr/smfSocialProfile.cpp
Generated on Thu Sep 23 15:03:48 2010 for smf by doxygen 1.6.3


smf: Member List

SMFSocialProfile Member List

This is the complete list of members for SMFSocialProfile, including all inherited members.
associatedSnsID() const | SMFSocialProfile |
associatedUserID() const | SMFSocialProfile |
DataStoreManager (defined in SMFSocialProfile) | SMFSocialProfile | [friend]
profileID() const | SMFSocialProfile |
profileURL() const | SMFSocialProfile |
screenAlias() const | SMFSocialProfile |
setAssociatedSns(const SMFSocialNetworkingSite &site) | SMFSocialProfile | [slot]
setAssociatedSnsID(int sns_id) | SMFSocialProfile | [slot]
setProfileURL(const QString &profile_url) | SMFSocialProfile | [slot]
setScreenAlias(const QString &screen_alias) | SMFSocialProfile | [slot]
SMFSocialProfile(const SMFSocialNetworkingSite &site, const QString &profile_url="", const QString &screen_alias="", QObject *parent=0) | SMFSocialProfile |
SMFSocialProfile(int sns_id=-1, int user_id=-1, const QString &profile_url="", const QString &screen_alias="", QObject *parent=0) | SMFSocialProfile |
SMFSocialProfile(const SMFSocialProfile &other) (defined in SMFSocialProfile) | SMFSocialProfile |
~SMFSocialProfile() | SMFSocialProfile |
Generated on Thu Sep 23 15:03:49 2010 for smf by doxygen 1.6.3


smf: SmfSubtitle Class Reference

SmfSubtitle Class Reference
[Common Data Classes]

#include <smfsubtitle.h>

List of all members.

Public Member Functions

SmfSubtitle ()
SmfSubtitle (const SmfSubtitle &aOther)
SmfSubtitle & | operator= (const SmfSubtitle &aOther)
~SmfSubtitle ()
QByteArray | subtitle () const
QUrl | subtitleUrl () const
QString | language () const
double | frameRate () const
double | duration () const
QDateTime | releaseYear () const
QString | id () const
void | setSubtitle (const QByteArray &aSubtitle)
void | setSubtitleUrl (const QUrl &aSubtitleUrl)
void | setLanguage (const QString &aLang)
void | setFrameRate (const double &aFramerate)
void | setDuration (const double &aDuration)
void | setReleaseYear (const QDateTime &aRelYear)
void | setId (const QString &aId)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfSubtitle &aSubtitle)
QDataStream & | operator>> (QDataStream &aDataStream, SmfSubtitle &aSubtitle)

Detailed Description

The subtitle class represents information about a track's subtitle

Constructor & Destructor Documentation

SmfSubtitle::SmfSubtitle ( )

Constructor with default argument

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The subtitle class represents information about a track's subtitle Constructor with default argument

SmfSubtitle::SmfSubtitle ( const SmfSubtitle & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfSubtitle::~SmfSubtitle ( )

Destructor

Member Function Documentation

double SmfSubtitle::duration ( ) const

Method to get the duration

Returns:
the duration
double SmfSubtitle::frameRate ( ) const

Method to get the frame rate

Returns:
the frame rate
QString SmfSubtitle::id ( ) const

Method to get the id of the subtitle

Returns:
The ID value
QString SmfSubtitle::language ( ) const

Method to get the language

Returns:
The language
SmfSubtitle & SmfSubtitle::operator= ( const SmfSubtitle & aOther )

Overloaded = operator

Parameters:
aOther The reference object

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
QDateTime SmfSubtitle::releaseYear ( ) const

Method to get the release year

Returns:
The release year
void SmfSubtitle::setDuration ( const double & aDuration )

Method to set the duration

Parameters:
aDuration the duration
void SmfSubtitle::setFrameRate ( const double & aFramerate )

Method to set the frame rate

Parameters:
aFramerate the frame rate
void SmfSubtitle::setId ( const QString & aId )

Method to set the id of the subtitle

Parameters:
aId The ID value
void SmfSubtitle::setLanguage ( const QString & aLang )

Method to set the language

Parameters:
aLang The language
void SmfSubtitle::setReleaseYear ( const QDateTime & aRelYear )

Method to set the release year

Parameters:
aRelYear The release year
void SmfSubtitle::setSubtitle ( const QByteArray & aSubtitle )

Method to set the subtitle as a bytearray

Parameters:
aSubtitle The subtitle content
void SmfSubtitle::setSubtitleUrl ( const QUrl & aSubtitleUrl )

Method to set the subtitle url

Parameters:
aSubtitleUrl The subtitle url

Method to set the subtitle as a bytearray

Parameters:
aSubtitle The subtitle content
QByteArray SmfSubtitle::subtitle ( ) const

Method to get the subtitle as a bytearray

Returns:
The subtitle content
QUrl SmfSubtitle::subtitleUrl ( ) const

Method to get the Url to the subtitle

Returns:
the subtitle url

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfSubtitle & | aSubtitle |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfSubtitle object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aSubtitle | The SmfSubtitle object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfSubtitle & | aSubtitle |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfSubtitle object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aSubtitle | The SmfSubtitle object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfsubtitle.h
  • smf/smfservermodule/smfcommon/smfsubtitle.cpp
Generated on Thu Sep 23 15:03:49 2010 for smf by doxygen 1.6.3


smf: Member List

SmfSubtitle Member List

This is the complete list of members for SmfSubtitle, including all inherited members.
duration() const | SmfSubtitle |
frameRate() const | SmfSubtitle |
id() const | SmfSubtitle |
language() const | SmfSubtitle |
operator<<(QDataStream &aDataStream, const SmfSubtitle &aSubtitle) | SmfSubtitle | [friend]
operator=(const SmfSubtitle &aOther) | SmfSubtitle |
operator>>(QDataStream &aDataStream, SmfSubtitle &aSubtitle) | SmfSubtitle | [friend]
releaseYear() const | SmfSubtitle |
setDuration(const double &aDuration) | SmfSubtitle |
setFrameRate(const double &aFramerate) | SmfSubtitle |
setId(const QString &aId) | SmfSubtitle |
setLanguage(const QString &aLang) | SmfSubtitle |
setReleaseYear(const QDateTime &aRelYear) | SmfSubtitle |
setSubtitle(const QByteArray &aSubtitle) | SmfSubtitle |
setSubtitleUrl(const QUrl &aSubtitleUrl) | SmfSubtitle |
SmfSubtitle() | SmfSubtitle |
SmfSubtitle(const SmfSubtitle &aOther) | SmfSubtitle |
subtitle() const | SmfSubtitle |
subtitleUrl() const | SmfSubtitle |
~SmfSubtitle() | SmfSubtitle |
Generated on Thu Sep 23 15:03:49 2010 for smf by doxygen 1.6.3


smf: SmfSubtitlePrivate Class Reference

SmfSubtitlePrivate Class Reference

#include <smfsubtitle_p.h>

List of all members.

Public Member Functions

SmfSubtitlePrivate ()
SmfSubtitlePrivate (const SmfSubtitlePrivate &aOther)
~SmfSubtitlePrivate ()

Public Attributes

QByteArray | m_subtitle
QString | m_language
double | m_frameRate
double | m_duration
QDateTime | m_releaseYr
QString | m_subtitleId
QUrl | m_subtitleUrl

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfSubtitle class

Constructor & Destructor Documentation

SmfSubtitlePrivate::SmfSubtitlePrivate ( ) [inline]

Constructor

SmfSubtitlePrivate::SmfSubtitlePrivate ( const SmfSubtitlePrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfSubtitlePrivate::~SmfSubtitlePrivate ( ) [inline]

Destructor

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfsubtitle_p.h
Generated on Thu Sep 23 15:03:49 2010 for smf by doxygen 1.6.3


smf: Member List

SmfSubtitlePrivate Member List

This is the complete list of members for SmfSubtitlePrivate, including all inherited members.
m_duration (defined in SmfSubtitlePrivate) | SmfSubtitlePrivate |
m_frameRate (defined in SmfSubtitlePrivate) | SmfSubtitlePrivate |
m_language (defined in SmfSubtitlePrivate) | SmfSubtitlePrivate |
m_releaseYr (defined in SmfSubtitlePrivate) | SmfSubtitlePrivate |
m_subtitle (defined in SmfSubtitlePrivate) | SmfSubtitlePrivate |
m_subtitleId (defined in SmfSubtitlePrivate) | SmfSubtitlePrivate |
m_subtitleUrl (defined in SmfSubtitlePrivate) | SmfSubtitlePrivate |
SmfSubtitlePrivate() | SmfSubtitlePrivate | [inline]
SmfSubtitlePrivate(const SmfSubtitlePrivate &aOther) | SmfSubtitlePrivate | [inline]
~SmfSubtitlePrivate() | SmfSubtitlePrivate | [inline]
Generated on Thu Sep 23 15:03:49 2010 for smf by doxygen 1.6.3


smf: SmfTrackInfo Class Reference

SmfTrackInfo Class Reference
[Common Data Classes]

#include <smftrackinfo.h>

List of all members.

Public Member Functions

SmfTrackInfo ()
SmfTrackInfo (const SmfTrackInfo &aOther)
SmfTrackInfo & | operator= (const SmfTrackInfo &aOther)
~SmfTrackInfo ()
QString | title () const
SmfAlbum | album () const
SmfArtists | artists () const
QString | genre () const
QStringList | tags () const
QDateTime | year () const
SmfMusicRating | rating () const
QList< SmfComment > | comments () const
QTime | duration () const
QString | id () const
void | setTitle (const QString &aTitle)
void | setAlbum (const SmfAlbum &aAlbum)
void | setArtists (const SmfArtists &aArtists)
void | setGenre (const QString &aGenre)
void | setTags (const QStringList &aTags)
void | setYear (const QDateTime &aYear)
void | setRating (const SmfMusicRating &aRating)
void | setComment (const QList< SmfComment > &aComments)
void | setDuration (const QTime &aDuration)
void | setId (const QString &aId)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfTrackInfo &aTrackInfo)
QDataStream & | operator>> (QDataStream &aDataStream, SmfTrackInfo &aTrackInfo)

Detailed Description

The track info class represents information about a music track

Constructor & Destructor Documentation

SmfTrackInfo::SmfTrackInfo ( )

Constructor with default argument

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The track info class represents information about a music track Constructor with default argument

SmfTrackInfo::SmfTrackInfo ( const SmfTrackInfo & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfTrackInfo::~SmfTrackInfo ( )

Destructor

Member Function Documentation

SmfAlbum SmfTrackInfo::album ( ) const

Method to get the track album

Returns:
The album of the track
SmfArtists SmfTrackInfo::artists ( ) const

Method to get the track's artists

Returns:
The artists of the track
QList< SmfComment > SmfTrackInfo::comments ( ) const

Method to get the comments on the track

Returns:
The comments on the track
QTime SmfTrackInfo::duration ( ) const

Method to get the track's duration

Returns:
The duration of the track
QString SmfTrackInfo::genre ( ) const

Method to get the genre of the track

Returns:
The genre of the track
QString SmfTrackInfo::id ( ) const

Method to get the id of the track

Returns:
The ID value
SmfTrackInfo & SmfTrackInfo::operator= ( const SmfTrackInfo & aOther )

Overloaded = operator

Parameters:
aOther The reference object

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
SmfMusicRating SmfTrackInfo::rating ( ) const

Method to get the track's rating

Returns:
The rating of the track
void SmfTrackInfo::setAlbum ( const SmfAlbum & aAlbum )

Method to set the track album

Parameters:
aAlbum The new album of the track
void SmfTrackInfo::setArtists ( const SmfArtists & aArtists )

Method to set the track's artists

Parameters:
aArtists The new artists of the track
void SmfTrackInfo::setComment ( const QList< SmfComment > & aComments )

Method to set the comments on the track

Parameters:
aComment The new comment of the track
void SmfTrackInfo::setDuration ( const QTime & aDuration )

Method to set the duration of the track

Parameters:
aDuration The new duration of the track
void SmfTrackInfo::setGenre ( const QString & aGenre )

Method to set the genre of the track

Parameters:
aGenre The new genre of the track
void SmfTrackInfo::setId ( const QString & aId )

Method to set the id of the track

Parameters:
aId The ID value
void SmfTrackInfo::setRating ( const SmfMusicRating & aRating )

Method to set the track's rating

Parameters:
aRating The new rating of the track
void SmfTrackInfo::setTags ( const QStringList & aTags )

Method to set the track's tag

Parameters:
aTag The tag of the track
void SmfTrackInfo::setTitle ( const QString & aTitle )

Method to set the track title

Parameters:
aTitle The new title of the track
void SmfTrackInfo::setYear ( const QDateTime & aYear )

Method to set the release year of the track

Parameters:
aYear The new release year of the track
QStringList SmfTrackInfo::tags ( ) const

Method to get the track's tag

Returns:
The tag of the track
QString SmfTrackInfo::title ( ) const

Method to get the track title

Returns:
The title of the track
QDateTime SmfTrackInfo::year ( ) const

Method to get the release year of the track

Returns:
The release year of the track

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfTrackInfo & | aTrackInfo |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfTrackInfo object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aTrackInfo | The SmfTrackInfo object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfTrackInfo & | aTrackInfo |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfTrackInfo object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aTrackInfo | The SmfTrackInfo object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smftrackinfo.h
  • smf/smfservermodule/smfcommon/smftrackinfo.cpp
Generated on Thu Sep 23 15:03:49 2010 for smf by doxygen 1.6.3


smf: Member List

SmfTrackInfo Member List

This is the complete list of members for SmfTrackInfo, including all inherited members.
album() const | SmfTrackInfo |
artists() const | SmfTrackInfo |
comments() const | SmfTrackInfo |
duration() const | SmfTrackInfo |
genre() const | SmfTrackInfo |
id() const | SmfTrackInfo |
operator<<(QDataStream &aDataStream, const SmfTrackInfo &aTrackInfo) | SmfTrackInfo | [friend]
operator=(const SmfTrackInfo &aOther) | SmfTrackInfo |
operator>>(QDataStream &aDataStream, SmfTrackInfo &aTrackInfo) | SmfTrackInfo | [friend]
rating() const | SmfTrackInfo |
setAlbum(const SmfAlbum &aAlbum) | SmfTrackInfo |
setArtists(const SmfArtists &aArtists) | SmfTrackInfo |
setComment(const QList< SmfComment > &aComments) | SmfTrackInfo |
setDuration(const QTime &aDuration) | SmfTrackInfo |
setGenre(const QString &aGenre) | SmfTrackInfo |
setId(const QString &aId) | SmfTrackInfo |
setRating(const SmfMusicRating &aRating) | SmfTrackInfo |
setTags(const QStringList &aTags) | SmfTrackInfo |
setTitle(const QString &aTitle) | SmfTrackInfo |
setYear(const QDateTime &aYear) | SmfTrackInfo |
SmfTrackInfo() | SmfTrackInfo |
SmfTrackInfo(const SmfTrackInfo &aOther) | SmfTrackInfo |
tags() const | SmfTrackInfo |
title() const | SmfTrackInfo |
year() const | SmfTrackInfo |
~SmfTrackInfo() | SmfTrackInfo |
Generated on Thu Sep 23 15:03:49 2010 for smf by doxygen 1.6.3


smf: SmfTrackInfoPrivate Class Reference

SmfTrackInfoPrivate Class Reference

#include <smftrackinfo_p.h>

List of all members.

Public Member Functions

SmfTrackInfoPrivate ()
SmfTrackInfoPrivate (const SmfTrackInfoPrivate &aOther)
~SmfTrackInfoPrivate ()

Public Attributes

QString | m_trackId
QString | m_title
SmfAlbum | m_album
SmfArtists | m_artists
QString | m_genre
QStringList | m_tags
QDateTime | m_year
SmfMusicRating | m_rating
QList< SmfComment > | m_comments
QTime | m_duration

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfTrackInfo class

Constructor & Destructor Documentation

SmfTrackInfoPrivate::SmfTrackInfoPrivate ( ) [inline]

Constructor

SmfTrackInfoPrivate::SmfTrackInfoPrivate ( const SmfTrackInfoPrivate & aOther ) [inline]

Copy Constructor

Parameters:
aOther The reference object to be copy constructed
SmfTrackInfoPrivate::~SmfTrackInfoPrivate ( ) [inline]

Destructor

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smftrackinfo_p.h
Generated on Thu Sep 23 15:03:49 2010 for smf by doxygen 1.6.3


smf: Member List

SmfTrackInfoPrivate Member List

This is the complete list of members for SmfTrackInfoPrivate, including all inherited members.
m_album (defined in SmfTrackInfoPrivate) | SmfTrackInfoPrivate |
m_artists (defined in SmfTrackInfoPrivate) | SmfTrackInfoPrivate |
m_comments (defined in SmfTrackInfoPrivate) | SmfTrackInfoPrivate |
m_duration (defined in SmfTrackInfoPrivate) | SmfTrackInfoPrivate |
m_genre (defined in SmfTrackInfoPrivate) | SmfTrackInfoPrivate |
m_rating (defined in SmfTrackInfoPrivate) | SmfTrackInfoPrivate |
m_tags (defined in SmfTrackInfoPrivate) | SmfTrackInfoPrivate |
m_title (defined in SmfTrackInfoPrivate) | SmfTrackInfoPrivate |
m_trackId (defined in SmfTrackInfoPrivate) | SmfTrackInfoPrivate |
m_year (defined in SmfTrackInfoPrivate) | SmfTrackInfoPrivate |
SmfTrackInfoPrivate() | SmfTrackInfoPrivate | [inline]
SmfTrackInfoPrivate(const SmfTrackInfoPrivate &aOther) | SmfTrackInfoPrivate | [inline]
~SmfTrackInfoPrivate() | SmfTrackInfoPrivate | [inline]
Generated on Thu Sep 23 15:03:49 2010 for smf by doxygen 1.6.3


smf: SmfTransportManager Class Reference

SmfTransportManager Class Reference

#include <smftransportmanager.h>

List of all members.

Public Slots

SmfTransportInitializeResult | initializeTransport ()
void | configurationAdded (const QNetworkConfiguration &aConfig)
void | configurationChanged (const QNetworkConfiguration &aConfig)
void | configurationRemoved (const QNetworkConfiguration &aConfig)

Public Member Functions

~SmfTransportManager ()

Static Public Member Functions

static SmfTransportManager * | getInstance ()

Detailed Description

The Transport Manager class initializes the transport component of Smf framework

Note: This class has dependencies on QtMobility project

Constructor & Destructor Documentation

SmfTransportManager::~SmfTransportManager ( )

Destructor

Member Function Documentation

void SmfTransportManager::configurationAdded ( const QNetworkConfiguration & aConfig ) [slot]

This slot is called whenever a new network configuration is added to the system.

Parameters:
aConfig The new configuration
void SmfTransportManager::configurationChanged ( const QNetworkConfiguration & aConfig ) [slot]

This slot is called when the state of the aConfig changes.

Parameters:
aConfig The changed configuration
void SmfTransportManager::configurationRemoved ( const QNetworkConfiguration & aConfig ) [slot]

This slot is called when a configuration is about to be removed from the system. The removed configuration is invalid but retains name and identifier.

Parameters:
aConfig The to be removed configuration
SmfTransportManager * SmfTransportManager::getInstance ( ) [static]

Method to get the instance of SmfTransportManager class

Returns:
The instance of SmfTransportManager class
SmfTransportInitializeResult SmfTransportManager::initializeTransport ( ) [slot]

Method to initialize the transport component before executing a web query

Returns:
SmfTransportInitializeResult
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfserver/transportmgr/smftransportmanager.h
  • smf/smfservermodule/smfserver/transportmgr/smftransportmanager.cpp
Generated on Thu Sep 23 15:03:49 2010 for smf by doxygen 1.6.3


smf: Member List

SmfTransportManager Member List

This is the complete list of members for SmfTransportManager, including all inherited members.
configurationAdded(const QNetworkConfiguration &aConfig) | SmfTransportManager | [slot]
configurationChanged(const QNetworkConfiguration &aConfig) | SmfTransportManager | [slot]
configurationRemoved(const QNetworkConfiguration &aConfig) | SmfTransportManager | [slot]
getInstance() | SmfTransportManager | [static]
initializeTransport() | SmfTransportManager | [slot]
~SmfTransportManager() | SmfTransportManager |
Generated on Thu Sep 23 15:03:49 2010 for smf by doxygen 1.6.3


smf: SmfTransportManagerUtil Class Reference

SmfTransportManagerUtil Class Reference

#include <smftransportmanagerutil.h>

List of all members.

Public Slots

void | configurationAdded (const SmfTransportResult &aResult)
void | configurationChanged (const SmfTransportResult &aResult)
void | configurationRemoved (const SmfTransportResult &aResult)

Public Member Functions

~SmfTransportManagerUtil ()
QNetworkReply * | get (QNetworkRequest &aRequest, const QList< QUrl > &aUrlList, bool &aSOPCompliant)
QNetworkReply * | post (QNetworkRequest &aRequest, const QByteArray &aPostData, const QList< QUrl > &aUrlList, bool &aSOPCompliant)
QNetworkReply * | head (QNetworkRequest &aRequest, const QList< QUrl > &aUrlList, bool &aSOPCompliant)
QNetworkReply * | put (QNetworkRequest &aRequest, const QByteArray &aPostData, const QList< QUrl > &aUrlList, bool &aSOPCompliant)
QNetworkReply * | deleteResource (QNetworkRequest &aRequest, const QList< QUrl > &aUrlList, bool &aSOPCompliant)
bool | cancelRequest (QNetworkReply *aCancelReply)

Static Public Member Functions

static SmfTransportManagerUtil * | getInstance ()

Detailed Description

The Transport Manager Utility class provides the http/https transaction methods for the smf framework

Constructor & Destructor Documentation

SmfTransportManagerUtil::~SmfTransportManagerUtil ( )

Destructor

Member Function Documentation

bool SmfTransportManagerUtil::cancelRequest ( QNetworkReply * aCancelReply )

Method that cancels the service request by cancelling the current http transaction.

Parameters:
aCancelReply The QNetworkReply instance whose transaction has to be cancelled
Returns:
Returns true for success, else false
QNetworkReply * SmfTransportManagerUtil::deleteResource | ( | QNetworkRequest & | aRequest,
 |  | const QList< QUrl > & | aUrlList,
 |  | bool & | aSOPCompliant
 | ) |  |

Method that does a http DELETE request. Returns the unique QNetworkReply instance for this transaction to the plugin manager to trace the proper response.

Parameters:
aRequest | The request formed by the plugin
aUrlList | The list of accessible Urls for this plugin
aSOPCompliant | [out] Output parameter indicating Same Origin Policy Compliance. Contains true if the request complies to the policy, else false. If it is false, the network request will not performed
Returns:
The unique QNetworkReply instance for this transaction
QNetworkReply * SmfTransportManagerUtil::get | ( | QNetworkRequest & | aRequest,
 |  | const QList< QUrl > & | aUrlList,
 |  | bool & | aSOPCompliant
 | ) |  |

Method that does a http GET request. Returns the unique QNetworkReply instance for this transaction to the plugin manager to trace the proper response.

Parameters:
aRequest | The request formed by the plugin
aUrlList | The list of accessible Urls for this plugin
aSOPCompliant | [out] Output parameter indicating Same Origin Policy Compliance. Contains true if the request complies to the policy, else false. If it is false, the network request will not performed
Returns:
The unique QNetworkReply instance for this transaction
SmfTransportManagerUtil * SmfTransportManagerUtil::getInstance ( ) [static]

Method to get the instance of SmfTransportManagerUtil class

Returns:
The instance of SmfTransportManagerUtil class

Method to get the instance of SmfTransportManagerUtil class

Returns:
The instance of SmfTransportManager class
QNetworkReply * SmfTransportManagerUtil::head | ( | QNetworkRequest & | aRequest,
 |  | const QList< QUrl > & | aUrlList,
 |  | bool & | aSOPCompliant
 | ) |  |

Method that does a http HEAD request. Returns the unique QNetworkReply instance for this transaction to the plugin manager to trace the proper response.

Parameters:
aRequest | The request formed by the plugin
aUrlList | The list of accessible Urls for this plugin
aSOPCompliant | [out] Output parameter indicating Same Origin Policy Compliance. Contains true if the request complies to the policy, else false. If it is false, the network request will not performed
Returns:
The unique QNetworkReply instance for this transaction
QNetworkReply * SmfTransportManagerUtil::post | ( | QNetworkRequest & | aRequest,
 |  | const QByteArray & | aPostData,
 |  | const QList< QUrl > & | aUrlList,
 |  | bool & | aSOPCompliant
 | ) |  |

Method that does a http POST request. Returns the unique QNetworkReply instance for this transaction to the plugin manager to trace the proper response.

Parameters:
aRequest | The request formed by the plugin
aPostData | The data to be posted via http POST request
aUrlList | The list of accessible Urls for this plugin
aSOPCompliant | [out] Output parameter indicating Same Origin Policy Compliance. Contains true if the request complies to the policy, else false. If it is false, the network request will not performed
Returns:
The unique QNetworkReply instance for this transaction
QNetworkReply * SmfTransportManagerUtil::put | ( | QNetworkRequest & | aRequest,
 |  | const QByteArray & | aPostData,
 |  | const QList< QUrl > & | aUrlList,
 |  | bool & | aSOPCompliant
 | ) |  |

Method that does a http PUT request. Returns the unique QNetworkReply instance for this transaction to the plugin manager to trace the proper response.

Parameters:
aRequest | The request formed by the plugin
aPostData | The data to be posted via http PUT request
aUrlList | The list of accessible Urls for this plugin
aSOPCompliant | [out] Output parameter indicating Same Origin Policy Compliance. Contains true if the request complies to the policy, else false. If it is false, the network request will not performed
Returns:
The unique QNetworkReply instance for this transaction
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfserver/transportmgr/smftransportmanagerutil.h
  • smf/smfservermodule/smfserver/transportmgr/smftransportmanagerutil.cpp
Generated on Thu Sep 23 15:03:50 2010 for smf by doxygen 1.6.3


smf: Member List

SmfTransportManagerUtil Member List

This is the complete list of members for SmfTransportManagerUtil, including all inherited members.
cancelRequest(QNetworkReply *aCancelReply) | SmfTransportManagerUtil |
configurationAdded(const SmfTransportResult &aResult) (defined in SmfTransportManagerUtil) | SmfTransportManagerUtil | [slot]
configurationChanged(const SmfTransportResult &aResult) (defined in SmfTransportManagerUtil) | SmfTransportManagerUtil | [slot]
configurationRemoved(const SmfTransportResult &aResult) (defined in SmfTransportManagerUtil) | SmfTransportManagerUtil | [slot]
deleteResource(QNetworkRequest &aRequest, const QList< QUrl > &aUrlList, bool &aSOPCompliant) | SmfTransportManagerUtil |
get(QNetworkRequest &aRequest, const QList< QUrl > &aUrlList, bool &aSOPCompliant) | SmfTransportManagerUtil |
getInstance() | SmfTransportManagerUtil | [static]
head(QNetworkRequest &aRequest, const QList< QUrl > &aUrlList, bool &aSOPCompliant) | SmfTransportManagerUtil |
post(QNetworkRequest &aRequest, const QByteArray &aPostData, const QList< QUrl > &aUrlList, bool &aSOPCompliant) | SmfTransportManagerUtil |
put(QNetworkRequest &aRequest, const QByteArray &aPostData, const QList< QUrl > &aUrlList, bool &aSOPCompliant) | SmfTransportManagerUtil |
~SmfTransportManagerUtil() | SmfTransportManagerUtil |
Generated on Thu Sep 23 15:03:50 2010 for smf by doxygen 1.6.3


smf: SmfUrl Class Reference

SmfUrl Class Reference
[Common Data Classes]

#include <smfurl.h>

List of all members.

Public Member Functions

SmfUrl ()
SmfUrl (const SmfUrl &aOther)
SmfUrl & | operator= (const SmfUrl &aOther)
~SmfUrl ()
QUrl | href () const
QString | rel () const
QString | type () const
QString | hreflang () const
QString | title () const
QString | length () const
QString | id () const
void | setHref (const QUrl &aData)
void | setRel (const QString &aData)
void | setType (const QString &aData)
void | setHhreflang (const QString &aData)
void | setTitle (const QString &aData)
void | setLength (const QString &aData)
void | setId (const QString &aId)

Friends

QDataStream & | operator<< (QDataStream &aDataStream, const SmfUrl &aUrl)
QDataStream & | operator>> (QDataStream &aDataStream, SmfUrl &aUrl)

Detailed Description

The SmfUrl class represents an URL. This class has been constructed based on the link element of the The Atom Syndication Format (refer http://tools.ietf.org/html/rfc4287) For detailed description about atom link relations, refer "http://www.iana.org/assignments/link-relations/link-relations.xhtml"

Constructor & Destructor Documentation

SmfUrl::SmfUrl ( )

Constructor with default argument

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: The SmfUrl class represents an URL. This class has been constructed based on the link element of the The Atom Syndication Format (refer http://tools.ietf.org/html/rfc4287) For detailed description about atom link relations, refer "http://www.iana.org/assignments/link-relations/link-relations.xhtml" Constructor with default argument

SmfUrl::SmfUrl ( const SmfUrl & aOther )

Copy Constructor

Parameters:
aOther The reference object
SmfUrl::~SmfUrl ( )

Destructor

Member Function Documentation

QUrl SmfUrl::href ( ) const

Method to get the href attribute of the link

Returns:
The href attribute of the link
QString SmfUrl::hreflang ( ) const

Method to get the hreflang attribute of the link

Returns:
The hreflang attribute of the link
QString SmfUrl::id ( ) const

Method to get the id of the URL

Returns:
The ID of the URL
QString SmfUrl::length ( ) const

Method to get the length attribute of the link

Returns:
The length attribute of the link
SmfUrl & SmfUrl::operator= ( const SmfUrl & aOther )

Overloaded = operator

Parameters:
aOther The reference object

Overloaded = operator

Parameters:
aOther The reference object
Returns:
The target reference value
QString SmfUrl::rel ( ) const

Method to get the rel attribute of the link

Returns:
The rel attribute of the link
void SmfUrl::setHhreflang ( const QString & aData )

Method to set the hreflang attribute of the link

Parameters:
aData The hreflang attribute of the link
void SmfUrl::setHref ( const QUrl & aData )

Method to set the href attribute of the link

Parameters:
aData The href attribute of the link
void SmfUrl::setId ( const QString & aId )

Method to set the id of the URL

Parameters:
aId The ID of the URL
void SmfUrl::setLength ( const QString & aData )

Method to set the length attribute of the link

Parameters:
aData The length attribute of the link
void SmfUrl::setRel ( const QString & aData )

Method to set the rel attribute of the link

Parameters:
aData The rel attribute of the link
void SmfUrl::setTitle ( const QString & aData )

Method to set the title attribute of the link

Parameters:
aData The title attribute of the link
void SmfUrl::setType ( const QString & aData )

Method to set the type attribute of the link

Parameters:
aData The type attribute of the link
QString SmfUrl::title ( ) const

Method to get the title attribute of the link

Returns:
The title attribute of the link
QString SmfUrl::type ( ) const

Method to get the type attribute of the link

Returns:
The type attribute of the link

Friends And Related Function Documentation

QDataStream& operator<< | ( | QDataStream & | aDataStream,
 |  | const SmfUrl & | aUrl |
 | ) |  |  | [friend]

Method for Externalization. Writes the SmfUrl object to the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be written
aUrl | The SmfUrl object to be externalized
Returns:
reference to the written stream
QDataStream& operator>> | ( | QDataStream & | aDataStream,
 |  | SmfUrl & | aUrl |
 | ) |  |  | [friend]

Method for Internalization. Reads a SmfUrl object from the stream and returns a reference to the stream.

Parameters:
aDataStream | Stream to be read
aUrl | The SmfUrl object to be internalized
Returns:
reference to the stream
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfcommon/smfurl.h
  • smf/smfservermodule/smfcommon/smfurl.cpp
Generated on Thu Sep 23 15:03:50 2010 for smf by doxygen 1.6.3


smf: Member List

SmfUrl Member List

This is the complete list of members for SmfUrl, including all inherited members.
href() const | SmfUrl |
hreflang() const | SmfUrl |
id() const | SmfUrl |
length() const | SmfUrl |
operator<<(QDataStream &aDataStream, const SmfUrl &aUrl) | SmfUrl | [friend]
operator=(const SmfUrl &aOther) | SmfUrl |
operator>>(QDataStream &aDataStream, SmfUrl &aUrl) | SmfUrl | [friend]
rel() const | SmfUrl |
setHhreflang(const QString &aData) | SmfUrl |
setHref(const QUrl &aData) | SmfUrl |
setId(const QString &aId) | SmfUrl |
setLength(const QString &aData) | SmfUrl |
setRel(const QString &aData) | SmfUrl |
setTitle(const QString &aData) | SmfUrl |
setType(const QString &aData) | SmfUrl |
SmfUrl() | SmfUrl |
SmfUrl(const SmfUrl &aOther) | SmfUrl |
title() const | SmfUrl |
type() const | SmfUrl |
~SmfUrl() | SmfUrl |
Generated on Thu Sep 23 15:03:50 2010 for smf by doxygen 1.6.3


smf: SmfUrlPrivate Class Reference

SmfUrlPrivate Class Reference

#include <smfurl_p.h>

List of all members.

Public Member Functions

SmfUrlPrivate ()
SmfUrlPrivate (const SmfUrlPrivate &aOther)
~SmfUrlPrivate ()

Public Attributes

QUrl | m_href
QString | m_rel
QString | m_type
QString | m_hreflang
QString | m_title
QString | m_length
QString | m_id

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Chandradeep Gandhi, Sasken Communication Technologies Ltd - Initial contribution

Contributors: Manasij Roy, Nalina Hariharan

Description: Private class implemented for implicit sharing of SmfUrl class

Constructor & Destructor Documentation

SmfUrlPrivate::SmfUrlPrivate ( ) [inline]

Constructor

SmfUrlPrivate::SmfUrlPrivate ( const SmfUrlPrivate & aOther ) [inline]

Copy Consturctor

Parameters:
aOther The reference object to be copy constructed
SmfUrlPrivate::~SmfUrlPrivate ( ) [inline]

Destructor

Member Data Documentation

QUrl SmfUrlPrivate::m_href

Data members

The documentation for this class was generated from the following file:
  • smf/smfservermodule/smfcommon/smfurl_p.h
Generated on Thu Sep 23 15:03:50 2010 for smf by doxygen 1.6.3


smf: Member List

SmfUrlPrivate Member List

This is the complete list of members for SmfUrlPrivate, including all inherited members.
m_href | SmfUrlPrivate |
m_hreflang (defined in SmfUrlPrivate) | SmfUrlPrivate |
m_id (defined in SmfUrlPrivate) | SmfUrlPrivate |
m_length (defined in SmfUrlPrivate) | SmfUrlPrivate |
m_rel (defined in SmfUrlPrivate) | SmfUrlPrivate |
m_title (defined in SmfUrlPrivate) | SmfUrlPrivate |
m_type (defined in SmfUrlPrivate) | SmfUrlPrivate |
SmfUrlPrivate() | SmfUrlPrivate | [inline]
SmfUrlPrivate(const SmfUrlPrivate &aOther) | SmfUrlPrivate | [inline]
~SmfUrlPrivate() | SmfUrlPrivate | [inline]
Generated on Thu Sep 23 15:03:50 2010 for smf by doxygen 1.6.3


smf: SMFUserProfile Class Reference

SMFUserProfile Class Reference

This class represents a user's profile. More...

#include <smfUserProfile.h>

List of all members.

Public Slots

void | setName (const QString &name)
Sets the name of user/person whom this profile identifies.
void | setContactID (const QString &contact_id)
Sets the contact ID of the user/person whom this profile identifies.

Public Member Functions

SMFUserProfile (const QString &name="", const QString &contact_id="", QObject *parent=0)
Constructor for the class SMFUserProfile.
~SMFUserProfile ()
Destructor for the class SMFUserProfile.
int | userID () const
Gets the user ID of this profile.
const QString & | name () const
Gets the name of user/person whom this profile identifies.
const QString & | contactID () const
Gets the contact ID of the user/person whom this profile identifies.

Friends

class | DataStoreManager

Detailed Description

This class represents a user's profile.

A user is a contact stored in the handset. This profile is created for contacts in the handset and is related to the social profiles. A single user profile can be associated with multiple social profiles in the database.

See also:
SMFSocialProfile

Constructor & Destructor Documentation

SMFUserProfile::SMFUserProfile | ( | const QString & | name = "",
 |  | const QString & | contact_id = "",
 |  | QObject * | parent = 0
 | ) |  |

Constructor for the class SMFUserProfile.

Parameters:
name | Reference to the name of the user/person whom this profile identifies.
contact_id | Reference to the contact ID of the user/person whom this profile identifies.
parent | Pointer to a parent object.

Member Function Documentation

const QString & SMFUserProfile::contactID ( ) const

Gets the contact ID of the user/person whom this profile identifies.

Returns:
A const reference to the contact ID of the user/person whom this profile identifies.
See also:
setContactID()
const QString & SMFUserProfile::name ( ) const

Gets the name of user/person whom this profile identifies.

Returns:
A const reference to the name of the user/person whom this profile identifies.
See also:
setName()
void SMFUserProfile::setContactID ( const QString & contact_id ) [slot]

Sets the contact ID of the user/person whom this profile identifies.

Parameters:
contact_id A const reference to the contact ID of the user/person whom this profile identifies.
See also:
contactID()
void SMFUserProfile::setName ( const QString & name ) [slot]

Sets the name of user/person whom this profile identifies.

Parameters:
name A const reference to the name of the social networking site
See also:
name()
int SMFUserProfile::userID ( ) const

Gets the user ID of this profile.

Returns:
Integer User ID of this profile. -1 if not assigned a user id yet.
The documentation for this class was generated from the following files:
  • smf/smfservermodule/smfserver/datastoremgr/smfUserProfile.h
  • smf/smfservermodule/smfserver/datastoremgr/smfUserProfile.cpp
Generated on Thu Sep 23 15:03:50 2010 for smf by doxygen 1.6.3


smf: Member List

SMFUserProfile Member List

This is the complete list of members for SMFUserProfile, including all inherited members.
contactID() const | SMFUserProfile |
DataStoreManager (defined in SMFUserProfile) | SMFUserProfile | [friend]
name() const | SMFUserProfile |
setContactID(const QString &contact_id) | SMFUserProfile | [slot]
setName(const QString &name) | SMFUserProfile | [slot]
SMFUserProfile(const QString &name="", const QString &contact_id="", QObject *parent=0) | SMFUserProfile |
userID() const | SMFUserProfile |
~SMFUserProfile() | SMFUserProfile |
Generated on Thu Sep 23 15:03:50 2010 for smf by doxygen 1.6.3


smf: SmfWaitingPluginInfoStruc Struct Reference

SmfWaitingPluginInfoStruc Struct Reference

#include <smfpluginmanager.h>

List of all members.

Public Attributes

quint32 | iSessionID
QString | iPluginId
SmfPluginBase * iInstance
SmfRequestTypeID | iOperation
QByteArray | iInputData

Detailed Description

Structure that holds information about a plugin that is awaiting a response from Transport Manager

Member Data Documentation

QByteArray SmfWaitingPluginInfoStruc::iInputData

The input data for this request (if request need to be send again)

SmfPluginBase* SmfWaitingPluginInfoStruc::iInstance

The instance of the loaded plugin

SmfRequestTypeID SmfWaitingPluginInfoStruc::iOperation

The type of operation requested by the plugin

See also:
smfglobal.h
QString SmfWaitingPluginInfoStruc::iPluginId

The plugin Id who creates this request

quint32 SmfWaitingPluginInfoStruc::iSessionID

The server session ID for this request

The documentation for this struct was generated from the following file:
  • smf/smfservermodule/smfserver/pluginmgr/smfpluginmanager.h
Generated on Thu Sep 23 15:03:50 2010 for smf by doxygen 1.6.3


smf: Member List

SmfWaitingPluginInfoStruc Member List

This is the complete list of members for SmfWaitingPluginInfoStruc, including all inherited members.
iInputData | SmfWaitingPluginInfoStruc
iInstance | SmfWaitingPluginInfoStruc
iOperation | SmfWaitingPluginInfoStruc
iPluginId | SmfWaitingPluginInfoStruc
iSessionID | SmfWaitingPluginInfoStruc
Generated on Thu Sep 23 15:03:50 2010 for smf by doxygen 1.6.3


smf: yy::stack< T, S > Class Template Reference

yy::stack

yy::stack< T, S > Class Template Reference

List of all members.

Public Types

typedef S::reverse_iterator | iterator
typedef S::const_reverse_iterator | const_iterator

Public Member Functions

stack (unsigned int n)
T & | operator[] (unsigned int i)
const T & | operator[] (unsigned int i) const
void | push (const T &t)
void | pop (unsigned int n=1)
unsigned int | height () const
const_iterator | begin () const
const_iterator | end () const

template<class T, class S = std::deque<T>>
class yy::stack< T, S >

The documentation for this class was generated from the following file:
  • smf/smfservermodule/util/qjson/src/stack.hh
Generated on Thu Sep 23 15:03:54 2010 for smf by doxygen 1.6.3


smf: Member List

yy::stack< T, S > Member List

This is the complete list of members for yy::stack< T, S >, including all inherited members.
begin() const (defined in yy::stack< T, S >) | yy::stack< T, S > | [inline]
const_iterator typedef (defined in yy::stack< T, S >) | yy::stack< T, S > |
end() const (defined in yy::stack< T, S >) | yy::stack< T, S > | [inline]
height() const (defined in yy::stack< T, S >) | yy::stack< T, S > | [inline]
iterator typedef (defined in yy::stack< T, S >) | yy::stack< T, S > |
operator[](unsigned int i) (defined in yy::stack< T, S >) | yy::stack< T, S > | [inline]
operator[](unsigned int i) const (defined in yy::stack< T, S >) | yy::stack< T, S > | [inline]
pop(unsigned int n=1) (defined in yy::stack< T, S >) | yy::stack< T, S > | [inline]
push(const T &t) (defined in yy::stack< T, S >) | yy::stack< T, S > | [inline]
stack() (defined in yy::stack< T, S >) | yy::stack< T, S > | [inline]
stack(unsigned int n) (defined in yy::stack< T, S >) | yy::stack< T, S > | [inline]
Generated on Thu Sep 23 15:03:54 2010 for smf by doxygen 1.6.3


smf: TestParser Class Reference

TestParser Class Reference

List of all members.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/util/qjson/tests/testparser.cpp
Generated on Thu Sep 23 15:03:50 2010 for smf by doxygen 1.6.3


smf: Member List

TestParser Member List

This is the complete list of members for TestParser, including all inherited members.
Generated on Thu Sep 23 15:03:50 2010 for smf by doxygen 1.6.3


smf: TestQObjectHelper Class Reference

TestQObjectHelper Class Reference

List of all members.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/util/qjson/tests/testqobjecthelper.cpp
Generated on Thu Sep 23 15:03:50 2010 for smf by doxygen 1.6.3


smf: Member List

TestQObjectHelper Member List

This is the complete list of members for TestQObjectHelper, including all inherited members.
Generated on Thu Sep 23 15:03:50 2010 for smf by doxygen 1.6.3


smf: TestScreen Class Reference

TestScreen Class Reference

List of all members.

Public Slots

void | friendsButtonClicked ()
void | postsButtonClicked ()
void | showGroups (SmfGroupList *grps, SmfError, SmfResultPage)
void | showFriends (SmfContactList *frnds, SmfError, SmfResultPage)
void | showPosts (SmfPostList *postlist, SmfError error, SmfResultPage resultPage)

Public Member Functions

TestScreen (QWidget *parent=0)
void | writeLog (QString log) const
The documentation for this class was generated from the following files:
  • example/smfclientapp/testscreen.h
  • example/smfclientapp/testscreen.cpp
Generated on Thu Sep 23 15:03:50 2010 for smf by doxygen 1.6.3


smf: Member List

TestScreen Member List

This is the complete list of members for TestScreen, including all inherited members.
friendsButtonClicked() (defined in TestScreen) | TestScreen | [slot]
postsButtonClicked() (defined in TestScreen) | TestScreen | [slot]
showFriends(SmfContactList *frnds, SmfError, SmfResultPage) (defined in TestScreen) | TestScreen | [slot]
showGroups(SmfGroupList *grps, SmfError, SmfResultPage) (defined in TestScreen) | TestScreen | [slot]
showPosts(SmfPostList *postlist, SmfError error, SmfResultPage resultPage) (defined in TestScreen) | TestScreen | [slot]
TestScreen(QWidget *parent=0) (defined in TestScreen) | TestScreen |
writeLog(QString log) const (defined in TestScreen) | TestScreen |
~TestScreen() (defined in TestScreen) | TestScreen |
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: TestSerializer Class Reference

TestSerializer Class Reference

List of all members.

The documentation for this class was generated from the following file:
  • smf/smfservermodule/util/qjson/tests/testserializer.cpp
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Member List

TestSerializer Member List

This is the complete list of members for TestSerializer, including all inherited members.
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: yy::json_parser::token Struct Reference

yy::json_parser::token

yy::json_parser::token Struct Reference

Tokens. More...

#include <json_parser.hh>

List of all members.

Public Types

enum yytokentype {
END = 0, CURLY_BRACKET_OPEN = 1, CURLY_BRACKET_CLOSE = 2, SQUARE_BRACKET_OPEN = 3,
SQUARE_BRACKET_CLOSE = 4, COLON = 5, COMMA = 6, MINUS = 7,
DOT = 8, DIGIT = 9, E = 10, TRUE_VAL = 11,
FALSE_VAL = 12, NULL_VAL = 13, QUOTMARKOPEN = 14, QUOTMARKCLOSE = 15,
STRING = 16
}

Detailed Description

Tokens.

The documentation for this struct was generated from the following file:
  • smf/smfservermodule/util/qjson/src/json_parser.hh
Generated on Thu Sep 23 15:03:54 2010 for smf by doxygen 1.6.3


smf: Member List

yy::json_parser::token Member List

This is the complete list of members for yy::json_parser::token, including all inherited members.
COLON enum value (defined in yy::json_parser::token) | yy::json_parser::token
COMMA enum value (defined in yy::json_parser::token) | yy::json_parser::token
CURLY_BRACKET_CLOSE enum value (defined in yy::json_parser::token) | yy::json_parser::token
CURLY_BRACKET_OPEN enum value (defined in yy::json_parser::token) | yy::json_parser::token
DIGIT enum value (defined in yy::json_parser::token) | yy::json_parser::token
DOT enum value (defined in yy::json_parser::token) | yy::json_parser::token
E enum value (defined in yy::json_parser::token) | yy::json_parser::token
END enum value (defined in yy::json_parser::token) | yy::json_parser::token
FALSE_VAL enum value (defined in yy::json_parser::token) | yy::json_parser::token
MINUS enum value (defined in yy::json_parser::token) | yy::json_parser::token
NULL_VAL enum value (defined in yy::json_parser::token) | yy::json_parser::token
QUOTMARKCLOSE enum value (defined in yy::json_parser::token) | yy::json_parser::token
QUOTMARKOPEN enum value (defined in yy::json_parser::token) | yy::json_parser::token
SQUARE_BRACKET_CLOSE enum value (defined in yy::json_parser::token) | yy::json_parser::token
SQUARE_BRACKET_OPEN enum value (defined in yy::json_parser::token) | yy::json_parser::token
STRING enum value (defined in yy::json_parser::token) | yy::json_parser::token
TRUE_VAL enum value (defined in yy::json_parser::token) | yy::json_parser::token
yytokentype enum name (defined in yy::json_parser::token) | yy::json_parser::token
Generated on Thu Sep 23 15:03:54 2010 for smf by doxygen 1.6.3


smf: ToolBar Class Reference

ToolBar Class Reference

List of all members.

Public Slots

void | exitApp ()
void | homeView ()
void | msg ()
void | call ()
void | authApp_Fb ()
void | authApp_Flkr ()

Public Member Functions

void | GetToolBar (QMainWindow *Mainwindow, QStringList aListOfActions)
void | launchFB ()
void | launchFlickr ()

Public Attributes

QMenu * | menu
The documentation for this class was generated from the following files:
  • example/DemoGUI/ToolBar.h
  • example/DemoGUI/ToolBar.cpp
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Member List

ToolBar Member List

This is the complete list of members for ToolBar, including all inherited members.
authApp_Fb() (defined in ToolBar) | ToolBar | [slot]
authApp_Flkr() (defined in ToolBar) | ToolBar | [slot]
call() (defined in ToolBar) | ToolBar | [slot]
exitApp() (defined in ToolBar) | ToolBar | [slot]
GetToolBar(QMainWindow *Mainwindow, QStringList aListOfActions) (defined in ToolBar) | ToolBar |
homeView() (defined in ToolBar) | ToolBar | [slot]
launchFB() (defined in ToolBar) | ToolBar |
launchFlickr() (defined in ToolBar) | ToolBar |
menu (defined in ToolBar) | ToolBar |
msg() (defined in ToolBar) | ToolBar | [slot]
ToolBar() (defined in ToolBar) | ToolBar |
~ToolBar() (defined in ToolBar) | ToolBar |
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: TSmfAuthToken Class Reference

TSmfAuthToken Class Reference

#include <smfcredmgrclientdatastruct.h>

List of all members.

Public Member Functions

TSmfAuthToken ()
void | ExternalizeL (RWriteStream &aStream)
void | InternalizeL (RReadStream &aStream)

Public Attributes

HBufC * | iKey
HBufC * | iSecret

Detailed Description

This class provide details and to serialize Authentication Key And Secret

Constructor & Destructor Documentation

TSmfAuthToken::TSmfAuthToken ( ) [inline]

Constructor

Member Function Documentation

void TSmfAuthToken::ExternalizeL ( RWriteStream & aStream )

Method to externalize the member variables

Parameters:
aStream The Write Stream to be filled.

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Pritam Roy Biswas, Sasken Communication Technologies Ltd - Initial contribution

Description: This source file gives different data classes to be used by Smf Credential Manager Client and Server for data transfer. Method to externalize the member variables

Parameters:
aStream The Write Stream to be filled.
void TSmfAuthToken::InternalizeL ( RReadStream & aStream )

Method to internalize the member variables

Parameters:
aStream the stream to read from

Method to internalize the member variables

Parameters:
aStream The source stream to read from

Member Data Documentation

HBufC* TSmfAuthToken::iKey

Buffer to hold the key

HBufC* TSmfAuthToken::iSecret

Buffer to hold the secret

The documentation for this class was generated from the following files:
  • smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrclientdatastruct.h
  • smf/smfcredentialmgr/smfcredmgrcommon/src/smfcredmgrclientdatastruct.cpp
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Member List

TSmfAuthToken Member List

This is the complete list of members for TSmfAuthToken, including all inherited members.
ExternalizeL(RWriteStream &aStream) | TSmfAuthToken |
iKey | TSmfAuthToken |
InternalizeL(RReadStream &aStream) | TSmfAuthToken |
iSecret | TSmfAuthToken |
TSmfAuthToken() | TSmfAuthToken | [inline]
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Ui_AuthAppClass Class Reference

Ui_AuthAppClass Class Reference

Inherited by Ui::AuthAppClass, and Ui::AuthAppClass.

List of all members.

Public Member Functions

void | setupUi (QMainWindow *AuthAppClass)
void | retranslateUi (QMainWindow *AuthAppClass)
void | setupUi (QMainWindow *AuthAppClass)
void | retranslateUi (QMainWindow *AuthAppClass)

Public Attributes

QWidget * | centralWidget
QVBoxLayout * | verticalLayout
QPushButton * | buttonForget
QPushButton * | pushButton
QSpacerItem * | verticalSpacer
The documentation for this class was generated from the following files:
  • example/AuthApp/ui_AuthApp.h
  • example/FlickrAuthApp/ui_AuthApp.h
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Member List

Ui_AuthAppClass Member List

This is the complete list of members for Ui_AuthAppClass, including all inherited members.
buttonForget (defined in Ui_AuthAppClass) | Ui_AuthAppClass |
centralWidget (defined in Ui_AuthAppClass) | Ui_AuthAppClass |
pushButton (defined in Ui_AuthAppClass) | Ui_AuthAppClass |
retranslateUi(QMainWindow *AuthAppClass) (defined in Ui_AuthAppClass) | Ui_AuthAppClass | [inline]
retranslateUi(QMainWindow *AuthAppClass) (defined in Ui_AuthAppClass) | Ui_AuthAppClass | [inline]
setupUi(QMainWindow *AuthAppClass) (defined in Ui_AuthAppClass) | Ui_AuthAppClass | [inline]
setupUi(QMainWindow *AuthAppClass) (defined in Ui_AuthAppClass) | Ui_AuthAppClass | [inline]
verticalLayout (defined in Ui_AuthAppClass) | Ui_AuthAppClass |
verticalSpacer (defined in Ui_AuthAppClass) | Ui_AuthAppClass |
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Ui_DisplayWidgetClass Class Reference

Ui_DisplayWidgetClass Class Reference

Inherited by Ui::DisplayWidgetClass.

List of all members.

Public Member Functions

void | setupUi (QWidget *DisplayWidgetClass)
void | retranslateUi (QWidget *DisplayWidgetClass)

Public Attributes

QWidget * | verticalLayoutWidget
QVBoxLayout * | verticalLayout
QLabel * | label
QComboBox * | comboBox_intf
QPushButton * | pushButton_intf
QLabel * | label_2
QComboBox * | comboBox__SP
QPushButton * | pushButton_SP
QLabel * | label_3
QComboBox * | comboBox_service
QPushButton * | pushButton_service
QListWidget * | listWidget
QScrollBar * | verticalScrollBar_list
The documentation for this class was generated from the following file:
  • example/smfclientapp/ui_displaywidget.h
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Member List

Ui_DisplayWidgetClass Member List

This is the complete list of members for Ui_DisplayWidgetClass, including all inherited members.
comboBox__SP (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
comboBox_intf (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
comboBox_service (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
label (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
label_2 (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
label_3 (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
listWidget (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
pushButton_intf (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
pushButton_service (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
pushButton_SP (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
retranslateUi(QWidget *DisplayWidgetClass) (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass | [inline]
setupUi(QWidget *DisplayWidgetClass) (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass | [inline]
verticalLayout (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
verticalLayoutWidget (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
verticalScrollBar_list (defined in Ui_DisplayWidgetClass) | Ui_DisplayWidgetClass |
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Ui_MainWindow Class Reference

Ui_MainWindow Class Reference

Inherited by Ui::MainWindow.

List of all members.

Public Member Functions

void | setupUi (QMainWindow *MainWindow)
void | retranslateUi (QMainWindow *MainWindow)

Public Attributes

QWidget * | centralWidget
QTextEdit * | textEdit
QMenuBar * | menuBar
QToolBar * | mainToolBar
QStatusBar * | statusBar
The documentation for this class was generated from the following file:
  • example/DemoGUI/ui_mainwindow.h
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Member List

Ui_MainWindow Member List

This is the complete list of members for Ui_MainWindow, including all inherited members.
centralWidget (defined in Ui_MainWindow) | Ui_MainWindow |
mainToolBar (defined in Ui_MainWindow) | Ui_MainWindow |
menuBar (defined in Ui_MainWindow) | Ui_MainWindow |
retranslateUi(QMainWindow *MainWindow) (defined in Ui_MainWindow) | Ui_MainWindow | [inline]
setupUi(QMainWindow *MainWindow) (defined in Ui_MainWindow) | Ui_MainWindow | [inline]
statusBar (defined in Ui_MainWindow) | Ui_MainWindow |
textEdit (defined in Ui_MainWindow) | Ui_MainWindow |
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Ui_PostTestUiClass Class Reference

Ui_PostTestUiClass Class Reference

Inherited by Ui::PostTestUiClass.

List of all members.

Public Member Functions

void | setupUi (QWidget *PostTestUiClass)
void | retranslateUi (QWidget *PostTestUiClass)

Public Attributes

QWidget * | verticalLayoutWidget
QVBoxLayout * | verticalLayout
QGridLayout * | gridLayout
QComboBox * | comboBox
QListWidget * | listWidget
The documentation for this class was generated from the following file:
  • example/smfclientapp/ui_posttestui.h
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Member List

Ui_PostTestUiClass Member List

This is the complete list of members for Ui_PostTestUiClass, including all inherited members.
comboBox (defined in Ui_PostTestUiClass) | Ui_PostTestUiClass |
gridLayout (defined in Ui_PostTestUiClass) | Ui_PostTestUiClass |
listWidget (defined in Ui_PostTestUiClass) | Ui_PostTestUiClass |
retranslateUi(QWidget *PostTestUiClass) (defined in Ui_PostTestUiClass) | Ui_PostTestUiClass | [inline]
setupUi(QWidget *PostTestUiClass) (defined in Ui_PostTestUiClass) | Ui_PostTestUiClass | [inline]
verticalLayout (defined in Ui_PostTestUiClass) | Ui_PostTestUiClass |
verticalLayoutWidget (defined in Ui_PostTestUiClass) | Ui_PostTestUiClass |
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Ui_progressbarClass Class Reference

Ui_progressbarClass Class Reference

Inherited by Ui::progressbarClass, and Ui::progressbarClass.

List of all members.

Public Member Functions

void | setupUi (QWidget *progressbarClass)
void | retranslateUi (QWidget *progressbarClass)
void | setupUi (QWidget *progressbarClass)
void | retranslateUi (QWidget *progressbarClass)

Public Attributes

QVBoxLayout * | verticalLayout
QLabel * | label
QProgressBar * | progressBar
The documentation for this class was generated from the following files:
  • example/AuthApp/ui_progressbar.h
  • example/FlickrAuthApp/ui_progressbar.h
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Member List

Ui_progressbarClass Member List

This is the complete list of members for Ui_progressbarClass, including all inherited members.
label (defined in Ui_progressbarClass) | Ui_progressbarClass |
progressBar (defined in Ui_progressbarClass) | Ui_progressbarClass |
retranslateUi(QWidget *progressbarClass) (defined in Ui_progressbarClass) | Ui_progressbarClass | [inline]
retranslateUi(QWidget *progressbarClass) (defined in Ui_progressbarClass) | Ui_progressbarClass | [inline]
setupUi(QWidget *progressbarClass) (defined in Ui_progressbarClass) | Ui_progressbarClass | [inline]
setupUi(QWidget *progressbarClass) (defined in Ui_progressbarClass) | Ui_progressbarClass | [inline]
verticalLayout (defined in Ui_progressbarClass) | Ui_progressbarClass |
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Ui_SmfClientApp Class Reference

Ui_SmfClientApp Class Reference

Inherited by Ui::SmfClientApp.

List of all members.

Public Member Functions

void | setupUi (QWidget *SmfClientApp)
void | retranslateUi (QWidget *SmfClientApp)

Public Attributes

QListWidget * | listWidget
QComboBox * | comboBox
QPushButton * | pushButton
QLabel * | label
QPushButton * | pushButton_2
The documentation for this class was generated from the following file:
  • example/smfclientapp/ui_smfclientapp.h
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Member List

Ui_SmfClientApp Member List

This is the complete list of members for Ui_SmfClientApp, including all inherited members.
comboBox (defined in Ui_SmfClientApp) | Ui_SmfClientApp |
label (defined in Ui_SmfClientApp) | Ui_SmfClientApp |
listWidget (defined in Ui_SmfClientApp) | Ui_SmfClientApp |
pushButton (defined in Ui_SmfClientApp) | Ui_SmfClientApp |
pushButton_2 (defined in Ui_SmfClientApp) | Ui_SmfClientApp |
retranslateUi(QWidget *SmfClientApp) (defined in Ui_SmfClientApp) | Ui_SmfClientApp | [inline]
setupUi(QWidget *SmfClientApp) (defined in Ui_SmfClientApp) | Ui_SmfClientApp | [inline]
Generated on Thu Sep 23 15:03:51 2010 for smf by doxygen 1.6.3


smf: Hierarchical Index

Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • AuthApp
  • CPFIndSettings
  • CSessionStruct
  • CSmfClientSymbian
  • CSmfCredMgrClientSymbian
  • CSmfCredMgrDb
  • CSmfCredMgrDbUser
  • CSmfCredMgrServer
  • CSmfCredMgrServerSession
  • CSmfFetchAuthTokenSet
  • CSmfKeyStoreManager
  • CSmfPluginIDListParams
  • CSmfPluginIDUpdate
  • CSmfRsaKeyParameters
  • CSmfSignParameters
  • CSmfStoreAuthParams
  • CSmfURLListParams
  • CustomListWidget
  • DataStoreManager
  • DisplayWidget
  • DSMContactPckg
  • FBDialog
    • FBLoginDialog
    • FBLoginDialog
  • FBError
  • FBRequest
  • FBSession
  • FBXMLHandler
  • FriendView
  • GridView
  • HomeView
  • ImageDownload
  • yy::json_parser
  • JSonScanner
  • yy::location
  • MainWindow
  • MyApplication
  • MyAppView
  • QJson::Parser
  • QJson::ParserPrivate
  • QJson::ParserRunnable
  • Person
  • yy::position
  • PostTestUi
  • QJson::ParserRunnable::Private
  • QJson::SerializerRunnable::Private
  • progressbar
  • QJson::QObjectHelper
  • QJson::QObjectHelper::QObjectHelperPrivate
  • RSmfClientSymbianSession
  • RSmfCredMgrClientSession
  • ScreenSize
  • QJson::Serializer
  • QJson::Serializer::SerializerPrivate
  • QJson::SerializerRunnable
  • yy::slice< T, S >
  • SmfActivityEntry
  • SmfActivityEntryPrivate
  • SmfActivityFetcher
  • SmfActivityObject
  • SmfActivityObjectPrivate
  • SmfAlbum
  • SmfAlbumPrivate
  • SmfArtists
  • SmfArtistsPrivate
  • SmfClient
  • SmfClientApp
  • SmfClientAuthID
  • SmfClientQt
  • SmfComment
  • SmfCommentPrivate
  • SmfContact
    • SmfRelationItem
  • SmfContactFetcher
  • SmfContactPrivate
  • SmfCredMgrClient
  • SmfEvent
  • SmfEventPrivate
  • SmfEventsFetcher
  • SmfGallery
  • SmfGroup
  • SmfGroupPrivate
  • SmfLocation
  • SmfLocationPrivate
  • SmfLyrics
  • SmfLyricsPrivate
  • SmfLyricsService
  • SmfMusicFingerPrint
  • SmfMusicFingerPrintPrivate
  • SmfMusicProfile
  • SmfMusicProfilePrivate
  • SmfMusicRating
  • SmfMusicRatingPrivate
  • SmfMusicSearch
  • SmfMusicService
  • smfObserver
    • SmfActivityFetcherPrivate
    • SmfClientPrivate
    • SmfContactFetcherPrivate
    • SmfEventsFetcherPrivate
    • SmfGalleryPrivate
    • SmfLyricsServicePrivate
    • SmfMusicSearchPrivate
    • SmfMusicServicePrivate
    • SmfPlaylistServicePrivate
    • SmfPostProviderPrivate
  • SmfPicture
  • SmfPictureAlbum
  • SmfPictureAlbumPrivate
  • SmfPicturePrivate
  • SmfPlaylist
  • SmfPlaylistPrivate
  • SmfPlaylistService
  • SmfPluginBase
    • SmfActivityFetcherPlugin
      • FBActivityFetcherPlugin
    • SmfContactFetcherPlugin
      • FBContactFetcherPlugin
      • FlickrContactFetcherPlugin
    • SmfEventsFetcherPlugin
      • MusicEventPlugin
    • SmfGalleryPlugin
      • FlickrGalleryPlugin
      • SamplePlugin
    • SmfLyricsServicePlugin
      • MusicLyricsPlugin
    • SmfMusicSearchPlugin
      • LastFmMusicSearchPlugin
    • SmfMusicServicePlugin
      • LastFmMusicServicePlugin
    • SmfPlaylistServicePlugin
      • LastFmPlaylistServicePlugin
    • SmfPostProviderPlugin
      • FBPostProviderPlugin
  • SmfPluginDataUsage
  • SmfPluginManager
  • SmfPluginManagerUtil
  • SmfPluginRequestData
  • SmfPluginUtil
  • SmfPost
  • SmfPostPrivate
  • SmfPostProvider
  • SmfProvider
  • SmfProviderBase
    • FBActivityProviderBase
    • FBContactProviderBase
    • FBProviderBase
    • FlickrProviderBase
    • FlickrProviderBase
    • LastFmMusicSearchProviderBase
    • LastFmMusicServiceProviderBase
    • LastFmPlaylistServiceProviderBase
    • MusicProviderBase
    • MusicProviderBase
    • SampleProviderBase
  • SmfRelationMgr
  • SmfRelationMgrPrivate
  • SmfResultPage
  • SmfServer
  • SmfServerQt
  • SmfServerQtSession
  • SmfServerSymbian
  • SmfServerSymbianSession
  • SMFSettings
  • SmfSettingsHandler
  • SmfSettingsRepositoryQt
  • SMFSocialNetworkingSite
  • SMFSocialProfile
  • SmfSubtitle
  • SmfSubtitlePrivate
  • SmfTrackInfo
  • SmfTrackInfoPrivate
  • SmfTransportManager
  • SmfTransportManagerUtil
  • SmfUrl
  • SmfUrlPrivate
  • SMFUserProfile
  • SmfWaitingPluginInfoStruc
  • yy::stack< T, S >
  • TestParser
  • TestQObjectHelper
  • TestScreen
  • TestSerializer
  • yy::json_parser::token
  • ToolBar
  • TSmfAuthToken
  • Ui_AuthAppClass
    • Ui::AuthAppClass
    • Ui::AuthAppClass
  • Ui_DisplayWidgetClass
    • Ui::DisplayWidgetClass
  • Ui_MainWindow
    • Ui::MainWindow
  • Ui_PostTestUiClass
    • Ui::PostTestUiClass
  • Ui_progressbarClass
    • Ui::progressbarClass
    • Ui::progressbarClass
  • Ui_SmfClientApp
    • Ui::SmfClientApp
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • actionName() : SmfActivityEntry
  • activities() : SmfActivityEntry
  • addComment() : SmfPictureAlbum , SmfPicture
  • addKeywords() : SmfPictureAlbum
  • addTags() : SmfPicture
  • addToPlaylist() : SmfPlaylistService , SmfPlaylistServicePrivate , SmfPlaylistServicePlugin , LastFmPlaylistServicePlugin
  • addToSessionMap() : SmfServerSymbian
  • album() : SmfTrackInfo
  • albums() : SmfGalleryPlugin , FlickrGalleryPlugin , SmfGallery , SmfGalleryPrivate
  • albumsAvailable() : SmfGallery
  • apiKey() : FBSession
  • apiSecret() : FBSession
  • apiSecureURL() : FBSession
  • apiURL() : FBSession
  • applicationIcon() : LastFmMusicServiceProviderBase , LastFmPlaylistServiceProviderBase , MusicProviderBase , SampleProviderBase , SmfProviderBase , FBActivityProviderBase , FBContactProviderBase , FBProviderBase , FlickrProviderBase , MusicProviderBase , LastFmMusicSearchProviderBase
  • applicationUrl() : FBActivityProviderBase , FBContactProviderBase , SampleProviderBase , FBProviderBase , FlickrProviderBase , MusicProviderBase , LastFmMusicSearchProviderBase , LastFmMusicServiceProviderBase , LastFmPlaylistServiceProviderBase , MusicProviderBase , SmfProvider , SmfProviderBase
  • artists() : SmfAlbum , SmfTrackInfo , SmfEvent
  • associate() : DataStoreManager , SmfRelationMgr , SmfRelationMgrPrivate
  • associatedSnsID() : SMFSocialProfile
  • associatedUserID() : SMFSocialProfile
  • attendees() : SmfEventsFetcherPlugin , SmfEventsFetcher , MusicEventPlugin , SmfEventsFetcherPrivate
  • attendeesAvailable() : SmfEventsFetcher
  • attribution() : SmfPlaylist
  • AuthApp() : AuthApp
  • AuthDataSet() : SmfCredMgrClient
  • AuthDataSetL() : CSmfCredMgrClientSymbian
  • AuthenticatedPluginList() : SmfCredMgrClient
  • authenticatedPluginListL() : CSmfCredMgrClientSymbian
  • authenticationApp() : FBContactProviderBase , LastFmPlaylistServiceProviderBase , LastFmMusicServiceProviderBase , FBActivityProviderBase , FBProviderBase , FlickrProviderBase , LastFmMusicSearchProviderBase , SmfProviderBase , MusicProviderBase , SampleProviderBase , MusicProviderBase , FlickrProviderBase
  • authenticationKeysExpired() : SmfServer
  • author() : SmfPlaylist , SmfActivityEntry
  • AuthParamsTableInsert() : CSmfCredMgrDbUser
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- j -

  • json_parser() : yy::json_parser
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • Key() : CSmfSignParameters
  • KeyData() : CSmfRsaKeyParameters
  • KeyName() : CSmfRsaKeyParameters
  • keywords() : SmfPictureAlbum
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • language() : SmfLyrics , SmfSubtitle
  • length() : SmfUrl
  • license() : SmfPlaylist
  • line : yy::position
  • lines()
: yy::location
, yy::position
  • link() : SmfActivityObject
  • load() : FBDialog , FBLoginDialog , FBDialog , FBLoginDialog
  • loadURL() : FBDialog
  • location() : SmfPlaylist , yy::location , SmfAlbum
  • location_type : yy::json_parser
  • logout() : FBSession
  • lyrics() : SmfLyricsService , MusicLyricsPlugin , SmfLyricsServicePrivate , SmfLyrics , SmfLyricsServicePlugin
  • lyricsAvailable() : SmfLyricsService
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • m_href : SmfUrlPrivate
  • m_id : SmfActivityEntryPrivate , SmfActivityObjectPrivate
  • m_title : SmfPictureAlbumPrivate
  • m_version : SmfPlaylistPrivate
  • maxCharsInPost() : SmfPostProviderPrivate , SmfPostProviderPlugin , FBPostProviderPlugin , SmfPostProvider
  • maxItems() : FBPostProviderPlugin , SmfPostProvider , SmfPostProviderPrivate , SmfPostProviderPlugin
  • maxRating() : SmfMusicRating
  • members() : SmfGroup
  • Message() : CSmfSignParameters
  • metadata() : SmfPlaylist
  • minRating() : SmfMusicRating
  • musicFingerPrint() : SmfMusicFingerPrint
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • name() : SmfAlbum , SmfGroup , SMFUserProfile , SmfLocation
  • names() : SmfArtists
  • NewL() : CSmfSignParameters , CSmfClientSymbian , SmfServerSymbian , CSmfRsaKeyParameters , CSmfKeyStoreManager , CSmfCredMgrServerSession , CSmfCredMgrServer , CSmfCredMgrDb , CSmfCredMgrClientSymbian , CSmfCredMgrDbUser , CSmfSignParameters
  • NewLC() : CSmfCredMgrServer , CSmfKeyStoreManager , CSmfCredMgrServerSession , CSmfClientSymbian , CSmfCredMgrDb , CSmfCredMgrDbUser
  • NewSessionL() : CSmfCredMgrServer
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • objData() : SmfActivityObject
  • operator<< : SmfActivityObject , SmfAlbum , SmfEvent , SmfPictureAlbum , SmfPlaylist , SmfGroup , SmfPost , SmfProvider , SmfArtists , SmfLocation , SmfSubtitle , SmfTrackInfo , SmfLyrics , SmfUrl , SmfActivityEntry , SmfComment , SmfMusicFingerPrint , SmfMusicProfile , SmfContact , SmfMusicRating , SmfPicture
  • operator=() : SmfMusicFingerPrint , SmfMusicProfile , SmfMusicRating , SmfPicture , SmfPictureAlbum , SmfPlaylist , SmfPost , SmfSubtitle , SmfTrackInfo , SmfUrl , SmfActivityObject , SmfAlbum , SmfLyrics , SmfArtists , SmfComment , SmfContact , SmfEvent , SmfGroup , SmfLocation
  • operator>> : SmfLocation , SmfMusicProfile , SmfMusicRating , SmfPictureAlbum , SmfUrl , SmfPlaylist , SmfPicture , SmfActivityEntry , SmfProvider , SmfActivityObject , SmfContact , SmfComment , SmfAlbum , SmfLyrics , SmfMusicFingerPrint , SmfPost , SmfSubtitle , SmfGroup , SmfArtists , SmfTrackInfo , SmfEvent
  • owner() : SmfPost , SmfPicture
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- z -

  • zipCode() : SmfLocation
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- ~ -

  • ~CPFIndSettings() : CPFIndSettings
  • ~CSmfClientSymbian() : CSmfClientSymbian
  • ~CSmfCredMgrClientSymbian() : CSmfCredMgrClientSymbian
  • ~CSmfCredMgrDb() : CSmfCredMgrDb
  • ~CSmfCredMgrDbUser() : CSmfCredMgrDbUser
  • ~CSmfCredMgrServer() : CSmfCredMgrServer
  • ~CSmfCredMgrServerSession() : CSmfCredMgrServerSession
  • ~CSmfFetchAuthTokenSet() : CSmfFetchAuthTokenSet
  • ~CSmfKeyStoreManager() : CSmfKeyStoreManager
  • ~CSmfPluginIDListParams() : CSmfPluginIDListParams
  • ~CSmfRsaKeyParameters() : CSmfRsaKeyParameters
  • ~CSmfSignParameters() : CSmfSignParameters
  • ~CSmfStoreAuthParams() : CSmfStoreAuthParams
  • ~CSmfURLListParams() : CSmfURLListParams
  • ~DataStoreManager() : DataStoreManager
  • ~FBActivityFetcherPlugin() : FBActivityFetcherPlugin
  • ~FBActivityProviderBase() : FBActivityProviderBase
  • ~FBContactFetcherPlugin() : FBContactFetcherPlugin
  • ~FBContactProviderBase() : FBContactProviderBase
  • ~FBPostProviderPlugin() : FBPostProviderPlugin
  • ~FBProviderBase() : FBProviderBase
  • ~FBSession() : FBSession
  • ~FlickrContactFetcherPlugin() : FlickrContactFetcherPlugin
  • ~FlickrGalleryPlugin() : FlickrGalleryPlugin
  • ~FlickrProviderBase() : FlickrProviderBase
  • ~LastFmMusicSearchPlugin() : LastFmMusicSearchPlugin
  • ~LastFmMusicSearchProviderBase() : LastFmMusicSearchProviderBase
  • ~LastFmMusicServicePlugin() : LastFmMusicServicePlugin
  • ~LastFmMusicServiceProviderBase() : LastFmMusicServiceProviderBase
  • ~LastFmPlaylistServicePlugin() : LastFmPlaylistServicePlugin
  • ~LastFmPlaylistServiceProviderBase() : LastFmPlaylistServiceProviderBase
  • ~MusicEventPlugin() : MusicEventPlugin
  • ~MusicLyricsPlugin() : MusicLyricsPlugin
  • ~MusicProviderBase() : MusicProviderBase
  • ~SamplePlugin() : SamplePlugin
  • ~SampleProviderBase() : SampleProviderBase
  • ~SmfActivityFetcher() : SmfActivityFetcher
  • ~SmfActivityFetcherPlugin() : SmfActivityFetcherPlugin
  • ~SmfActivityFetcherPrivate() : SmfActivityFetcherPrivate
  • ~SmfActivityObject() : SmfActivityObject
  • ~SmfAlbum() : SmfAlbum
  • ~SmfAlbumPrivate() : SmfAlbumPrivate
  • ~SmfArtists() : SmfArtists
  • ~SmfArtistsPrivate() : SmfArtistsPrivate
  • ~SmfClient() : SmfClient
  • ~SmfClientPrivate() : SmfClientPrivate
  • ~SmfComment() : SmfComment
  • ~SmfCommentPrivate() : SmfCommentPrivate
  • ~SmfContact() : SmfContact
  • ~SmfContactFetcher() : SmfContactFetcher
  • ~SmfContactFetcherPlugin() : SmfContactFetcherPlugin
  • ~SmfContactFetcherPrivate() : SmfContactFetcherPrivate
  • ~SmfContactPrivate() : SmfContactPrivate
  • ~SmfCredMgrClient() : SmfCredMgrClient
  • ~SmfEvent() : SmfEvent
  • ~SmfEventPrivate() : SmfEventPrivate
  • ~SmfEventsFetcher() : SmfEventsFetcher
  • ~SmfEventsFetcherPlugin() : SmfEventsFetcherPlugin
  • ~SmfEventsFetcherPrivate() : SmfEventsFetcherPrivate
  • ~SmfGallery() : SmfGallery
  • ~SmfGalleryPlugin() : SmfGalleryPlugin
  • ~SmfGalleryPrivate() : SmfGalleryPrivate
  • ~SmfGroup() : SmfGroup
  • ~SmfGroupPrivate() : SmfGroupPrivate
  • ~SmfLocation() : SmfLocation
  • ~SmfLocationPrivate() : SmfLocationPrivate
  • ~SmfLyrics() : SmfLyrics
  • ~SmfLyricsPrivate() : SmfLyricsPrivate
  • ~SmfLyricsService() : SmfLyricsService
  • ~SmfLyricsServicePlugin() : SmfLyricsServicePlugin
  • ~SmfLyricsServicePrivate() : SmfLyricsServicePrivate
  • ~SmfMusicFingerPrint() : SmfMusicFingerPrint
  • ~SmfMusicFingerPrintPrivate() : SmfMusicFingerPrintPrivate
  • ~SmfMusicProfile() : SmfMusicProfile
  • ~SmfMusicProfilePrivate() : SmfMusicProfilePrivate
  • ~SmfMusicRating() : SmfMusicRating
  • ~SmfMusicRatingPrivate() : SmfMusicRatingPrivate
  • ~SmfMusicSearch() : SmfMusicSearch
  • ~SmfMusicSearchPlugin() : SmfMusicSearchPlugin
  • ~SmfMusicSearchPrivate() : SmfMusicSearchPrivate
  • ~SmfMusicService() : SmfMusicService
  • ~SmfMusicServicePlugin() : SmfMusicServicePlugin
  • ~SmfMusicServicePrivate() : SmfMusicServicePrivate
  • ~SmfPicture() : SmfPicture
  • ~SmfPictureAlbum() : SmfPictureAlbum
  • ~SmfPictureAlbumPrivate() : SmfPictureAlbumPrivate
  • ~SmfPicturePrivate() : SmfPicturePrivate
  • ~SmfPlaylist() : SmfPlaylist
  • ~SmfPlaylistPrivate() : SmfPlaylistPrivate
  • ~SmfPlaylistService() : SmfPlaylistService
  • ~SmfPlaylistServicePlugin() : SmfPlaylistServicePlugin
  • ~SmfPlaylistServicePrivate() : SmfPlaylistServicePrivate
  • ~SmfPluginBase() : SmfPluginBase
  • ~SmfPluginManager() : SmfPluginManager
  • ~SmfPluginManagerUtil() : SmfPluginManagerUtil
  • ~SmfPluginUtil() : SmfPluginUtil
  • ~SmfPost() : SmfPost
  • ~SmfPostPrivate() : SmfPostPrivate
  • ~SmfPostProvider() : SmfPostProvider
  • ~SmfPostProviderPlugin() : SmfPostProviderPlugin
  • ~SmfPostProviderPrivate() : SmfPostProviderPrivate
  • ~SmfProvider() : SmfProvider
  • ~SmfProviderBase() : SmfProviderBase
  • ~SmfSettingsRepositoryQt() : SmfSettingsRepositoryQt
  • ~SMFSocialNetworkingSite() : SMFSocialNetworkingSite
  • ~SMFSocialProfile() : SMFSocialProfile
  • ~SmfSubtitle() : SmfSubtitle
  • ~SmfSubtitlePrivate() : SmfSubtitlePrivate
  • ~SmfTrackInfo() : SmfTrackInfo
  • ~SmfTrackInfoPrivate() : SmfTrackInfoPrivate
  • ~SmfTransportManager() : SmfTransportManager
  • ~SmfTransportManagerUtil() : SmfTransportManagerUtil
  • ~SmfUrl() : SmfUrl
  • ~SmfUrlPrivate() : SmfUrlPrivate
  • ~SMFUserProfile() : SMFUserProfile
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • begin : yy::location
  • beginSession() : FBSession
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • call() : FBRequest
  • callWithDataParams() : FBRequest
  • cancel() : FBRequest
  • cancelLogin() : FBSession
  • cancelRequest() : SmfActivityFetcher , SmfMusicService , SmfMusicSearch , SmfActivityFetcherPrivate , SmfPlaylistService , SmfLyricsService , SmfContactFetcher , SmfMusicServicePrivate , SmfMusicSearchPrivate , SmfContactFetcherPrivate , SmfPlaylistServicePrivate , SmfLyricsServicePrivate , SmfEventsFetcher , SmfPostProvider , SmfPostProviderPrivate , SmfEventsFetcherPrivate , SmfPluginManager , SmfTransportManagerUtil , SmfGallery
  • CancelRequest() : SmfClientQt , CSmfClientSymbian
  • cancelRequest() : SmfGalleryPrivate
  • caption() : SmfActivityObject
  • ChangePluginIDList() : SmfCredMgrClient
  • changePluginIDListL() : CSmfCredMgrClientSymbian
  • CheckPluginAuthentication() : SmfCredMgrClient
  • city() : SmfLocation
  • clientAuthorizationFinished() : SmfServer , SmfServerQt , SmfServerSymbianSession
  • Close() : RSmfCredMgrClientSession
  • column : yy::position
  • columns()
: yy::location
, yy::position
  • commentOnAPost() : FBPostProviderPlugin , SmfPostProvider , SmfPostProviderPrivate , SmfPostProviderPlugin
  • comments() : SmfPicture , SmfPictureAlbum , SmfPlaylist , SmfTrackInfo
  • configurationAdded() : SmfTransportManager
  • configurationChanged() : SmfTransportManager
  • configurationRemoved() : SmfTransportManager
  • connectToServer() : RSmfCredMgrClientSession , RSmfClientSymbianSession
  • constructField() : FlickrGalleryPlugin
  • contactID() : SMFUserProfile
  • content() : SmfActivityObject
  • convert() : SmfContact
  • count() : SmfRelationMgr , SmfRelationMgrPrivate , DataStoreManager
  • country() : SmfLocation
  • CPFIndSettings() : CPFIndSettings
  • create() : SmfRelationMgr , SmfRelationMgrPrivate
  • createParameterString() : SmfPluginUtil
  • createRequest() : SmfPluginManager
  • createSyncRequest() : SmfPluginManager
  • creationDate() : SmfPlaylist
  • customDataAvailable() : SmfActivityFetcher , SmfEventsFetcher , SmfGallery , SmfMusicService , SmfPlaylistService , SmfLyricsService , SmfPostProvider , SmfContactFetcher , SmfMusicSearch
  • customRequest() : SmfMusicServicePrivate , SmfMusicServicePlugin , FBContactFetcherPlugin , LastFmMusicServicePlugin , SmfGalleryPrivate , SmfMusicSearch , MusicEventPlugin , SmfContactFetcherPrivate , SmfActivityFetcher , MusicLyricsPlugin , LastFmPlaylistServicePlugin , SmfPostProvider , FBActivityFetcherPlugin , LastFmMusicSearchPlugin , SmfEventsFetcher , FlickrGalleryPlugin , SmfContactFetcherPlugin , FBPostProviderPlugin , SmfPlaylistService , SmfMusicSearchPrivate , SmfPostProviderPrivate , SmfGalleryPlugin , SmfEventsFetcherPrivate , SmfContactFetcher , SmfActivityFetcherPrivate , SmfPostProviderPlugin , SmfMusicSearchPlugin , SmfPlaylistServicePrivate , SmfActivityFetcherPlugin , FlickrContactFetcherPlugin , SmfMusicService , SmfLyricsServicePlugin , SmfEventsFetcherPlugin , SmfPlaylistServicePlugin , SmfLyricsServicePrivate , SmfGallery , SmfLyricsService
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • dataStoreUpdateAvailable() : SmfServer
  • debug_level() : yy::json_parser
  • debug_level_type : yy::json_parser
  • debug_stream() : yy::json_parser
  • Delete() : SmfRelationMgr , SmfRelationMgrPrivate
  • deleteRelation() : DataStoreManager
  • deleteResource() : SmfTransportManagerUtil
  • DeleteRSAKey() : SmfCredMgrClient
  • deleteRSAKey() : CSmfCredMgrClientSymbian
  • description() : FlickrProviderBase , MusicProviderBase , LastFmMusicSearchProviderBase , LastFmMusicServiceProviderBase , LastFmPlaylistServiceProviderBase , MusicProviderBase , FBActivityProviderBase , SamplePlugin , SampleProviderBase , FBContactProviderBase , SmfGallery , SmfGalleryPrivate , FBProviderBase , SmfPicture , SmfPictureAlbum , FlickrProviderBase , SmfPost , SmfProvider , FlickrGalleryPlugin , SmfGalleryPlugin , SmfProviderBase
  • details() : SmfActivityEntry
  • dialogDidCancel() : FBDialog
  • dialogDidFailWithError() : FBDialog
  • dialogDidSucceed() : FBDialog
  • dialogWillAppear() : FBDialog
  • dialogWillDisappear() : FBLoginDialog , FBDialog
  • dismissWithError() : FBDialog
  • dismissWithSuccess() : FBDialog
  • displayFriends() : MyApplication
  • displayGallery() : MyApplication
  • DisplayWidget() : DisplayWidget
  • DoCancel() : CSmfClientSymbian , CSmfCredMgrClientSymbian
  • downloadFlag() : SmfPicture
  • duration() : SmfTrackInfo , SmfEvent , SmfSubtitle
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • end : yy::location
  • EndDate() : CSmfRsaKeyParameters
  • errorLine() : QJson::Parser , SmfPluginUtil
  • errorString() : SmfClient , SmfPluginUtil , QJson::Parser
  • eventDateTime() : SmfEvent
  • events() : MusicEventPlugin , SmfEventsFetcher , SmfEventsFetcherPrivate , SmfEventsFetcherPlugin
  • eventsAvailable() : SmfEventsFetcher
  • eventsUpdated() : SmfEventsFetcher
  • extension() : SmfPlaylist
  • ExternalizeL() : CSmfStoreAuthParams , CSmfRsaKeyParameters , CSmfPluginIDUpdate , CSmfURLListParams , CSmfPluginIDListParams , CSmfFetchAuthTokenSet , TSmfAuthToken , CSmfSignParameters
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • favorites() : SmfMusicProfile
  • FBDialog() : FBDialog
  • FBRequest() : FBRequest
  • FBSession() : FBSession
  • FBXMLHandler() : FBXMLHandler
  • fetchKeys() : MusicEventPlugin
  • fetchPluginListL() : CSmfCredMgrDbUser
  • filename : yy::position
  • filtered() : FBActivityFetcherPlugin , SmfActivityFetcher , SmfActivityFetcherPrivate , SmfActivityFetcherPlugin
  • findAndServiceclient() : SmfServerSymbian
  • findSession() : SmfServerSymbian
  • followers() : FBContactFetcherPlugin , FlickrContactFetcherPlugin , SmfContactFetcher , SmfContactFetcherPrivate , SmfContactFetcherPlugin
  • followersListAvailable() : SmfContactFetcher
  • frameRate() : SmfSubtitle
  • friends() : SmfContactFetcherPlugin , SmfContactFetcher , FlickrContactFetcherPlugin , FBContactFetcherPlugin , SmfContactFetcherPrivate
  • friendsActivities() : FBActivityFetcherPlugin , SmfActivityFetcher , SmfActivityFetcherPrivate , SmfActivityFetcherPlugin
  • friendsListAvailable() : SmfContactFetcher
  • frobKey() : FBSession
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GenerateNONCE() : SmfCredMgrClient
  • generateNONCE() : CSmfCredMgrClientSymbian
  • genre() : SmfTrackInfo
  • geoPositionInfo() : SmfLocation
  • get() : SmfTransportManagerUtil , SmfRelationMgr , SmfRelationMgrPrivate , DataStoreManager
  • getAll() : SmfRelationMgr , SmfRelationMgrPrivate , DataStoreManager
  • getAllRelations() : SmfRelationMgr , SmfRelationMgrPrivate , DataStoreManager
  • getAuthenticatedPluginList() : SmfServer
  • getAuthKeys() : SmfPluginUtil
  • getAuthorizedPlugins() : SmfServer
  • getContact() : DataStoreManager
  • getData() : RSmfClientSymbianSession
  • getDataStoreManager() : DataStoreManager
  • getDataUsage() : SampleProviderBase
  • getErrorText() : DataStoreManager
  • getInstance() : SmfPluginManager , SmfPluginManagerUtil , SmfTransportManager , SmfTransportManagerUtil
  • getMusic() : MyApplication
  • getNonce() : SmfPluginUtil
  • getPlugin() : SmfServer
  • getPluginId() : SmfPluginManager
  • getPlugins() : SmfServer , SmfPluginManager
  • getProviderInfo() : FBActivityFetcherPlugin , SmfPluginBase , MusicLyricsPlugin , FBContactFetcherPlugin , LastFmMusicSearchPlugin , FlickrContactFetcherPlugin , MusicEventPlugin , FlickrGalleryPlugin , LastFmMusicServicePlugin , FBPostProviderPlugin , LastFmPlaylistServicePlugin , SamplePlugin
  • GetServices() : SmfClient , SmfClientPrivate
  • getSessionProxy() : FBSession
  • getState() : DataStoreManager
  • groupListAvailable() : SmfContactFetcher
  • groups() : FlickrContactFetcherPlugin , SmfContactFetcherPrivate , SmfContactFetcherPlugin , SmfContactFetcher , FBContactFetcherPlugin
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • HandleClientMessageL() : SmfServerSymbianSession
  • HandleMessageL() : CSmfKeyStoreManager
  • head() : SmfTransportManagerUtil
  • href() : SmfUrl
  • hreflang() : SmfUrl
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • iAppName : SmfPluginDataUsage
  • iAuthAppID : CSmfStoreAuthParams
  • iAuthTokenArray : CSmfStoreAuthParams , CSmfFetchAuthTokenSet
  • iBytesReceived : SmfPluginDataUsage
  • iBytesSent : SmfPluginDataUsage
  • id() : SmfActivityEntry , SmfMusicFingerPrint , SmfMusicProfile , SmfAlbum , SmfPicture , SmfPictureAlbum , SmfArtists , SmfPlaylist , SmfPost , SmfComment , SmfSubtitle , SmfTrackInfo , SmfEvent , SmfUrl , SmfGroup , SmfActivityObject , SmfLocation , SmfLyrics
  • iHttpOperationType : SmfPluginRequestData
  • iInputData : SmfWaitingPluginInfoStruc
  • iInstance : SmfWaitingPluginInfoStruc
  • iInterfaceName : SmfPluginDataUsage
  • iItemsPerPage : SmfResultPage
  • iKey : TSmfAuthToken
  • image() : SmfPlaylist , SmfPost , SmfArtists
  • imageUrl() : SmfAlbum
  • iNetworkRequest : SmfPluginRequestData
  • iNewPluginID : CSmfPluginIDUpdate
  • info() : SmfPlaylist
  • initialize() : MusicLyricsPlugin , FBActivityFetcherPlugin , FBContactFetcherPlugin , FBPostProviderPlugin , FlickrContactFetcherPlugin , FlickrGalleryPlugin , MusicEventPlugin , LastFmMusicSearchPlugin , LastFmMusicServicePlugin , LastFmPlaylistServicePlugin , SmfPluginBase , yy::location , yy::position
  • initializeTransport() : SmfTransportManager
  • InternalizeL() : TSmfAuthToken , CSmfFetchAuthTokenSet , CSmfURLListParams , CSmfPluginIDListParams , CSmfStoreAuthParams , CSmfPluginIDUpdate
  • iOldPluginID : CSmfPluginIDUpdate
  • iOperation : SmfWaitingPluginInfoStruc
  • iPageNum : SmfResultPage
  • iPluginID : CSmfURLListParams
  • iPluginId : SmfWaitingPluginInfoStruc
  • iPluginIDList : CSmfStoreAuthParams
  • iPluginList : CSmfPluginIDListParams
  • iPostData : SmfPluginRequestData
  • iRegistrationToken : CSmfStoreAuthParams , CSmfFetchAuthTokenSet , CSmfPluginIDListParams
  • iRequestType : SmfPluginRequestData
  • isConnected() : FBSession
  • isDownloaded : SmfPicturePrivate
  • iSecret : TSmfAuthToken
  • iServiceProviderName : SmfPluginDataUsage
  • iSession : FBDialog
  • iSessionID : SmfWaitingPluginInfoStruc
  • isPluginAuthenticatedL() : CSmfCredMgrClientSymbian
  • itemsCount() : SmfAlbum
  • iTotalItems : SmfResultPage
  • iTotalPages : SmfResultPage
  • iURLList : CSmfStoreAuthParams , CSmfURLListParams
  • iValidity : CSmfFetchAuthTokenSet , CSmfStoreAuthParams
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • parse() : SmfPluginUtil , QJson::Parser , yy::json_parser
  • ParserRunnable() : QJson::ParserRunnable
  • parsingFinished()
: QJson::SerializerRunnable
, QJson::ParserRunnable
  • picture() : SmfPicture
  • pictureCount() : SmfPictureAlbum
  • pictures() : FlickrGalleryPlugin , SamplePlugin , SmfGallery , SmfGalleryPrivate , SmfGalleryPlugin
  • picturesAvailable() : SmfGallery
  • playlists() : LastFmPlaylistServicePlugin , SmfPlaylistService , SmfPlaylistServicePrivate , SmfPlaylistServicePlugin
  • playlistsListAvailable() : SmfPlaylistService
  • playlistsOf() : LastFmPlaylistServicePlugin , SmfPlaylistService , SmfPlaylistServicePrivate , SmfPlaylistServicePlugin
  • playListTitle() : SmfPlaylist
  • playlistUpdated() : SmfPlaylistService
  • pluginId() : FlickrProviderBase , MusicProviderBase , LastFmMusicSearchProviderBase , LastFmMusicServiceProviderBase , LastFmPlaylistServiceProviderBase , MusicProviderBase , SampleProviderBase , SmfProviderBase , FBActivityProviderBase , FBContactProviderBase , FBProviderBase , FlickrProviderBase
  • pluginIDEnabled : CSmfStoreAuthParams , CSmfPluginIDUpdate
  • PluginIDTableInsert() : CSmfCredMgrDbUser
  • position() : yy::position
  • post() : FBRequest , FBPostProviderPlugin , FBRequest , SmfPostProvider , SmfPostProviderPrivate , SmfPostProviderPlugin , SmfTransportManagerUtil
  • postAppearence() : FBPostProviderPlugin , SmfPostProvider , SmfPostProviderPrivate , SmfPostProviderPlugin
  • postComment() : FlickrGalleryPlugin , SmfGalleryPlugin , SamplePlugin , SmfGallery , SmfGalleryPrivate
  • postComments() : SmfMusicServicePlugin , SmfMusicServicePrivate , LastFmMusicServicePlugin , SmfMusicService
  • postCurrentPlaying() : LastFmMusicServicePlugin , SmfMusicService , SmfMusicServicePrivate , SmfMusicServicePlugin
  • postCurrentPlayingPlaylist() : SmfPlaylistService , LastFmPlaylistServicePlugin , SmfPlaylistServicePlugin , SmfPlaylistServicePrivate
  • postDirected() : FBPostProviderPlugin , SmfPostProviderPrivate , SmfPostProviderPlugin , SmfPostProvider
  • postedDate() : SmfPicture , SmfPictureAlbum
  • postedDateTime() : SmfPost
  • postEvents() : MusicEventPlugin , SmfEventsFetcherPrivate , SmfEventsFetcherPlugin , SmfEventsFetcher
  • postfinished() : SmfMusicService
  • postFinished() : SmfPostProvider
  • postRating() : SmfMusicService , LastFmMusicServicePlugin , SmfMusicServicePlugin , SmfMusicServicePrivate
  • posts() : SmfPostProviderPrivate , SmfPostProvider
  • postsAvailable() : SmfPostProvider
  • postUpdate() : MyApplication
  • profileID() : SMFSocialProfile
  • profileURL() : SMFSocialProfile
  • put() : SmfTransportManagerUtil
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • qobject2qvariant() : QJson::QObjectHelper
  • qvariant2qobject() : QJson::QObjectHelper
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • rating() : SmfMusicRating , SmfTrackInfo
  • readAuthAppIdInPluginIdTable() : CSmfCredMgrDbUser
  • readAuthAppIdInRegTokenTable() : CSmfCredMgrDbUser
  • readAuthTokensL() : CSmfCredMgrDbUser
  • readFlagInPluginIdTable() : CSmfCredMgrDbUser
  • readPluginIdL() : CSmfCredMgrDbUser
  • readRegistrationTokenL() : CSmfCredMgrDbUser
  • readUrlL() : CSmfCredMgrDbUser
  • readValidity() : CSmfCredMgrDbUser
  • recentTracks() : SmfMusicProfile
  • recommendations() : LastFmMusicSearchPlugin , SmfMusicSearch , SmfMusicSearchPrivate , SmfMusicSearchPlugin
  • RegTokenValidityTableInsert() : CSmfCredMgrDbUser
  • rel() : SmfUrl
  • releaseYear() : SmfLyrics , SmfSubtitle
  • remove() : SmfRelationMgr , SmfRelationMgrPrivate , DataStoreManager
  • removeFromSessionMap() : SmfServerSymbian
  • request() : FBRequest
  • RequestAsyncService() : RSmfCredMgrClientSession
  • requestDidLoad() : FBRequest
  • requestFailedWithNetworkError() : FBRequest
  • requestLoading() : FBRequest
  • RequestService() : RSmfCredMgrClientSession
  • requestWasCancelled() : FBRequest
  • requestWithSession() : FBRequest
  • responseAvailable() : FBPostProviderPlugin , LastFmMusicSearchPlugin , FBActivityFetcherPlugin , FBContactFetcherPlugin , FlickrContactFetcherPlugin , FlickrGalleryPlugin , MusicEventPlugin , LastFmMusicServicePlugin , LastFmPlaylistServicePlugin , MusicLyricsPlugin , SmfPluginManager , SmfPluginBase , SamplePlugin
  • resultsAvailable() : SmfPlaylistServicePrivate , SmfEventsFetcherPrivate , SmfServerSymbianSession , SmfActivityFetcherPrivate , SmfMusicSearchPrivate , SmfPostProviderPrivate , SmfGalleryPrivate , smfObserver , SmfActivityFetcher , SmfContactFetcherPrivate , SmfMusicServicePrivate , SmfServer , SmfLyricsServicePrivate , SmfClientPrivate
  • resume() : FBSession
  • retrieve() : SmfPostProviderPlugin , FBPostProviderPlugin
  • RSmfClientSymbianSession() : RSmfClientSymbianSession
  • RSmfCredMgrClientSession() : RSmfCredMgrClientSession
  • RunError() : CSmfClientSymbian
  • RunL() : CSmfCredMgrClientSymbian , CSmfClientSymbian
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • SamplePlugin() : SamplePlugin
  • SampleProviderBase() : SampleProviderBase
  • SaveFrobKey() : FBSession
  • Savetoken() : FBSession
  • screenAlias() : SMFSocialProfile
  • search() : FlickrContactFetcherPlugin , SmfContactFetcher , SmfContactFetcherPrivate , SmfContactFetcherPlugin , FBContactFetcherPlugin
  • searchAlbum() : LastFmMusicServicePlugin , SmfMusicService , SmfMusicServicePrivate , SmfMusicServicePlugin
  • searchAlbumInfoAvailable() : SmfMusicService
  • searchArtist() : LastFmMusicServicePlugin , SmfMusicService , SmfMusicServicePrivate , SmfMusicServicePlugin
  • searchArtistInfoAvailable() : SmfMusicService
  • searchByContact() : SmfRelationMgr , SmfRelationMgrPrivate , DataStoreManager
  • searchById() : SmfRelationMgr , SmfRelationMgrPrivate , DataStoreManager
  • searchContactFinished() : SmfContactFetcher
  • searchEvents() : SmfMusicServicePlugin , LastFmMusicServicePlugin , SmfMusicService , SmfMusicServicePrivate
  • searchEventsInfoAvailable() : SmfMusicService
  • searchInGroup() : FBContactFetcherPlugin , FlickrContactFetcherPlugin , SmfContactFetcher , SmfContactFetcherPrivate , SmfContactFetcherPlugin
  • searchInGroupFinished() : SmfContactFetcher
  • searchNear() : FBContactFetcherPlugin , FlickrContactFetcherPlugin , SmfContactFetcher , SmfContactFetcherPrivate , SmfContactFetcherPlugin
  • searchNearFinished() : SmfContactFetcher
  • searchUser() : LastFmMusicServicePlugin , SmfMusicService , SmfMusicServicePrivate , SmfMusicServicePlugin
  • searchUserInfoAvailable() : SmfMusicService
  • searchVenue() : LastFmMusicServicePlugin , SmfMusicService , SmfMusicServicePrivate , SmfMusicServicePlugin
  • searchVenueInfoAvailable() : SmfMusicService
  • secondaryId() : SmfAlbum
  • selfActivities() : FBActivityFetcherPlugin , SmfActivityFetcher , SmfActivityFetcherPrivate , SmfActivityFetcherPlugin
  • semantic_type : yy::json_parser
  • send() : FBSession
  • sendAsyncRequest() : RSmfClientSymbianSession
  • sendDSMSyncRequest() : CSmfClientSymbian , RSmfClientSymbianSession
  • sendDummyRequest() : SmfClientQt
  • sendRequest() : SmfClientQt , CSmfClientSymbian , RSmfClientSymbianSession
  • sendSyncRequest() : CSmfClientSymbian , RSmfClientSymbianSession
  • sendToDSM() : SmfServer
  • sendToPluginManager() : SmfServer
  • serialize() : QJson::Serializer
  • SerializerRunnable() : QJson::SerializerRunnable
  • server() : SmfPluginManager
  • serviceIcon() : FBActivityProviderBase , FBContactProviderBase , FBProviderBase , FlickrProviderBase , MusicProviderBase , LastFmMusicSearchProviderBase , LastFmMusicServiceProviderBase , LastFmPlaylistServiceProviderBase , MusicProviderBase , SampleProviderBase , SmfProvider , SmfProviderBase
  • ServiceL() : CSmfCredMgrServerSession , SmfServerSymbianSession
  • serviceName() : FBActivityProviderBase , FBContactProviderBase , FBProviderBase , FlickrProviderBase , MusicProviderBase , LastFmMusicSearchProviderBase , LastFmMusicServiceProviderBase , LastFmPlaylistServiceProviderBase , MusicProviderBase , SampleProviderBase , SmfProvider , SmfProviderBase
  • serviceUrl() : FBActivityProviderBase , FBContactProviderBase , FBProviderBase , FlickrProviderBase , MusicProviderBase , LastFmMusicSearchProviderBase , LastFmMusicServiceProviderBase , LastFmPlaylistServiceProviderBase , MusicProviderBase , SampleProviderBase , SmfProviderBase
  • session() : FBSession
  • sessionDidLogin() : FBSession
  • sessionDidLogout() : FBSession
  • sessionDidNotLogin() : FBSession
  • sessionForApplication() : FBSession
  • sessionKey() : FBSession
  • sessionListCount() : SmfServerQt
  • sessionSecret() : FBSession
  • sessionWillLogout() : FBSession
  • set_debug_level() : yy::json_parser
  • set_debug_stream() : yy::json_parser
  • setActionName() : SmfActivityEntry
  • setActivities() : SmfActivityEntry
  • setAlbum() : SmfTrackInfo
  • setApplicationUrl() : SmfProvider
  • setArtists() : SmfAlbum , SmfEvent , SmfTrackInfo
  • setAssociatedSns() : SMFSocialProfile
  • setAssociatedSnsID() : SMFSocialProfile
  • setAttribution() : SmfPlaylist
  • setAuthor() : SmfActivityEntry , SmfPlaylist
  • setCaption() : SmfActivityObject
  • setCity() : SmfLocation
  • setComment() : SmfTrackInfo
  • setComments() : SmfPlaylist
  • setContactID() : SMFUserProfile
  • setContent() : SmfActivityObject
  • setCountry() : SmfLocation
  • setCreationDate() : SmfPlaylist
  • setDescription() : SmfPicture , SmfPictureAlbum , SmfPost , SmfProvider
  • setDetails() : SmfActivityEntry
  • setDuration() : SmfEvent , SmfSubtitle , SmfTrackInfo
  • setEventDateTime() : SmfEvent
  • setExtension() : SmfPlaylist
  • setFavorites() : SmfMusicProfile
  • setFrameRate() : SmfSubtitle
  • setGenre() : SmfTrackInfo
  • setGeoPositionInfo() : SmfLocation
  • setHhreflang() : SmfUrl
  • setHref() : SmfUrl
  • setId() : SmfActivityObject , SmfActivityEntry , SmfAlbum , SmfArtists , SmfComment , SmfEvent , SmfGroup , SmfLocation , SmfLyrics , SmfMusicFingerPrint , SmfMusicProfile , SmfPicture , SmfPictureAlbum , SmfPlaylist , SmfPost , SmfSubtitle , SmfTrackInfo , SmfUrl
  • setImage() : SmfArtists , SmfPlaylist , SmfPost
  • setImageUrl() : SmfAlbum
  • setInfo() : SmfPlaylist
  • setItemsCount() : SmfAlbum
  • setJsonObject() : QJson::SerializerRunnable
  • setLanguage() : SmfLyrics , SmfSubtitle
  • setLength() : SmfUrl
  • setLicense() : SmfPlaylist
  • setLink() : SmfActivityObject
  • setLocation() : SmfAlbum , SmfPlaylist
  • setLyrics() : SmfLyrics
  • setMaxRating() : SmfMusicRating
  • setMembers() : SmfGroup
  • setMetadata() : SmfPlaylist
  • setMinRating() : SmfMusicRating
  • setMusicFingerPrint() : SmfMusicFingerPrint
  • setName() : SmfAlbum , SmfGroup , SmfLocation , SMFUserProfile
  • setNames() : SmfArtists
  • setObjData() : SmfActivityObject
  • setOwner() : SmfPicture , SmfPost
  • setPicture() : SmfPicture
  • setPictureCount() : SmfPictureAlbum
  • setPlayListTitle() : SmfPlaylist
  • setPostedDate() : SmfPicture , SmfPictureAlbum
  • setPostedDateTime() : SmfPost
  • setProfileURL() : SMFSocialProfile
  • setRating() : SmfMusicRating , SmfTrackInfo
  • setRecentTracks() : SmfMusicProfile
  • setRel() : SmfUrl
  • setReleaseYear() : SmfLyrics , SmfSubtitle
  • setScreenAlias() : SMFSocialProfile
  • setSecondaryId() : SmfAlbum
  • setServiceIcon() : SmfProvider
  • setServiceName() : SmfProvider
  • setSession() : FBSession
  • setSnsName() : SMFSocialNetworkingSite
  • setSnsURL() : SMFSocialNetworkingSite
  • setStreet() : SmfLocation
  • setSubtitle() : SmfSubtitle
  • setSubtitleUrl() : SmfSubtitle
  • setSupportedInterfaces() : SmfProvider
  • setSupportedLanguages() : SmfProvider
  • setTags() : SmfArtists , SmfTrackInfo
  • setTargetObj() : SmfActivityEntry
  • setText() : SmfComment
  • setThumbnail() : SmfActivityObject , SmfPictureAlbum
  • setTicketUrl() : SmfEvent
  • setTime() : SmfActivityObject
  • setTimeStamp() : SmfComment
  • setTitle() : SmfActivityEntry , SmfEvent , SmfPicture , SmfPictureAlbum , SmfPost , SmfTrackInfo , SmfUrl
  • setTrackList() : SmfPlaylist
  • setType() : SmfActivityObject , SmfAlbum , SmfUrl
  • setUrl() : SmfArtists , SmfLocation , SmfPicture , SmfPost , SmfPictureAlbum
  • setUserEvents() : SmfMusicProfile
  • setValue() : SmfContact
  • setVenue() : SmfEvent
  • setVersion() : SmfPlaylist
  • setVisibility() : SmfPicture , SmfPictureAlbum
  • setYear() : SmfTrackInfo
  • setZipCode() : SmfLocation
  • sharePost() : FBPostProviderPlugin , SmfPostProvider , SmfPostProviderPlugin , SmfPostProviderPrivate
  • show() : FBDialog
  • SignMessage() : SmfCredMgrClient
  • signMessageL() : CSmfCredMgrClientSymbian
  • SmfActivityFetcher() : SmfActivityFetcher
  • SmfActivityFetcherPrivate() : SmfActivityFetcherPrivate
  • SmfActivityObject() : SmfActivityObject
  • SmfAlbum() : SmfAlbum
  • SmfAlbumPrivate() : SmfAlbumPrivate
  • SmfArtists() : SmfArtists
  • SmfArtistsPrivate() : SmfArtistsPrivate
  • SmfClient() : SmfClient
  • SmfClientPrivate() : SmfClientPrivate
  • SmfClientQt() : SmfClientQt
  • SmfComment() : SmfComment
  • SmfCommentPrivate() : SmfCommentPrivate
  • SmfContact() : SmfContact
  • SmfContactFetcher() : SmfContactFetcher
  • SmfContactFetcherPrivate() : SmfContactFetcherPrivate
  • SmfContactPrivate() : SmfContactPrivate
  • SmfCredMgrClient() : SmfCredMgrClient
  • SmfEvent() : SmfEvent
  • SmfEventPrivate() : SmfEventPrivate
  • SmfEventsFetcher() : SmfEventsFetcher
  • SmfEventsFetcherPrivate() : SmfEventsFetcherPrivate
  • SmfGallery() : SmfGallery
  • SmfGalleryPrivate() : SmfGalleryPrivate
  • SmfGroup() : SmfGroup
  • SmfGroupPrivate() : SmfGroupPrivate
  • SmfLocation() : SmfLocation
  • SmfLocationPrivate() : SmfLocationPrivate
  • SmfLyrics() : SmfLyrics
  • SmfLyricsPrivate() : SmfLyricsPrivate
  • SmfLyricsService() : SmfLyricsService
  • SmfLyricsServicePrivate() : SmfLyricsServicePrivate
  • SmfMusicFingerPrint() : SmfMusicFingerPrint
  • SmfMusicFingerPrintPrivate() : SmfMusicFingerPrintPrivate
  • SmfMusicProfile() : SmfMusicProfile
  • SmfMusicProfilePrivate() : SmfMusicProfilePrivate
  • SmfMusicRating() : SmfMusicRating
  • SmfMusicRatingPrivate() : SmfMusicRatingPrivate
  • SmfMusicSearch() : SmfMusicSearch
  • SmfMusicSearchPrivate() : SmfMusicSearchPrivate
  • SmfMusicService() : SmfMusicService
  • SmfMusicServicePrivate() : SmfMusicServicePrivate
  • SmfPicture() : SmfPicture
  • SmfPictureAlbum() : SmfPictureAlbum
  • SmfPictureAlbumPrivate() : SmfPictureAlbumPrivate
  • SmfPicturePrivate() : SmfPicturePrivate
  • SmfPlaylist() : SmfPlaylist
  • SmfPlaylistPrivate() : SmfPlaylistPrivate
  • SmfPlaylistService() : SmfPlaylistService
  • SmfPlaylistServicePrivate() : SmfPlaylistServicePrivate
  • SmfPluginUtil() : SmfPluginUtil
  • SmfPost() : SmfPost
  • SmfPostPrivate() : SmfPostPrivate
  • SmfPostProvider() : SmfPostProvider
  • SmfPostProviderPrivate() : SmfPostProviderPrivate
  • SmfProvider() : SmfProvider
  • smfRegistrationId() : FlickrProviderBase , FBActivityProviderBase , LastFmMusicSearchProviderBase , LastFmPlaylistServiceProviderBase , SmfProviderBase , FBContactProviderBase , SampleProviderBase , MusicProviderBase , LastFmMusicServiceProviderBase , FlickrProviderBase , FBProviderBase , MusicProviderBase
  • SmfRelationItem() : SmfRelationItem
  • SmfRelationMgrPrivate() : SmfRelationMgrPrivate
  • SmfServer() : SmfServer
  • SmfServerQt() : SmfServerQt
  • SmfServerQtSession() : SmfServerQtSession
  • SmfServerSymbianSession() : SmfServerSymbianSession
  • SMFSettings() : SMFSettings
  • SmfSettingsHandler() : SmfSettingsHandler
  • SmfSettingsRepositoryQt() : SmfSettingsRepositoryQt
  • SMFSocialNetworkingSite() : SMFSocialNetworkingSite
  • SMFSocialProfile() : SMFSocialProfile
  • SmfSubtitle() : SmfSubtitle
  • SmfSubtitlePrivate() : SmfSubtitlePrivate
  • SmfTrackInfo() : SmfTrackInfo
  • SmfTrackInfoPrivate() : SmfTrackInfoPrivate
  • SmfUrl() : SmfUrl
  • SmfUrlPrivate() : SmfUrlPrivate
  • SMFUserProfile() : SMFUserProfile
  • snsID() : SMFSocialNetworkingSite
  • snsName() : SMFSocialNetworkingSite
  • snsURL() : SMFSocialNetworkingSite
  • start() : SmfServerQt
  • StartDate() : CSmfRsaKeyParameters
  • startServer() : SmfServer
  • step() : yy::location
  • StoreAuthData() : SmfCredMgrClient
  • storeAuthDataL() : CSmfCredMgrClientSymbian
  • StoreRSAKeys() : SmfCredMgrClient
  • storeRSAKeysL() : CSmfCredMgrClientSymbian
  • stores() : SmfMusicSearchPlugin , LastFmMusicSearchPlugin , SmfMusicSearch , SmfMusicSearchPrivate
  • storeSearchAvailable() : SmfMusicSearch
  • street() : SmfLocation
  • subtitle() : SmfSubtitle
  • subtitleAvailable() : SmfLyricsService
  • subtitles() : MusicLyricsPlugin , SmfLyricsServicePlugin , SmfLyricsService , SmfLyricsServicePrivate
  • subtitleUrl() : SmfSubtitle
  • subTypes() : SmfContact
  • supportedFormats() : SmfPostProvider , SmfPostProviderPlugin , SmfPostProviderPrivate , FBPostProviderPlugin
  • supportedInterfaces() : FlickrProviderBase , FBActivityProviderBase , MusicProviderBase , LastFmMusicServiceProviderBase , SmfProvider , LastFmMusicSearchProviderBase , FBProviderBase , SmfProviderBase , FBContactProviderBase , MusicProviderBase , LastFmPlaylistServiceProviderBase , FlickrProviderBase
  • supportedLanguages() : SmfProviderBase , FBContactProviderBase , SmfProvider , FlickrProviderBase , MusicProviderBase , FBProviderBase , LastFmMusicSearchProviderBase , LastFmMusicServiceProviderBase , FlickrProviderBase , MusicProviderBase , LastFmPlaylistServiceProviderBase , FBActivityProviderBase
  • supportsAppearence() : SmfPostProviderPrivate , FBPostProviderPlugin , SmfPostProviderPlugin , SmfPostProvider
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • tags() : SmfArtists , SmfPicture , SmfTrackInfo
  • targetObj() : SmfActivityEntry
  • text() : SmfComment
  • thumbnail() : SmfActivityObject , SmfPictureAlbum
  • ticketUrl() : SmfEvent
  • time() : SmfActivityObject
  • timeStamp() : FBRequest , SmfComment
  • title() : SmfPictureAlbum , SmfPost , SmfTrackInfo , SmfUrl , SmfActivityEntry , SmfEvent , SmfPicture
  • token_type : yy::json_parser
  • trackInfo() : LastFmMusicSearchPlugin , SmfMusicSearch , SmfMusicSearchPrivate , SmfMusicSearchPlugin
  • trackList() : SmfPlaylist
  • trackSearchAvailable() : SmfMusicSearch
  • tracksOfAlbum() : SmfMusicSearchPrivate , SmfMusicSearchPlugin , SmfMusicSearch , LastFmMusicSearchPlugin
  • tracksOfArtist() : SmfMusicSearch , SmfMusicSearchPlugin , SmfMusicSearchPrivate , LastFmMusicSearchPlugin
  • tracksSimilar() : LastFmMusicSearchPlugin , SmfMusicSearchPlugin , SmfMusicSearch , SmfMusicSearchPrivate
  • TSmfAuthToken() : TSmfAuthToken
  • type() : SmfActivityObject , SmfAlbum , SmfUrl
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • updatePlugin() : CSmfCredMgrDbUser
  • updatePost() : FBPostProviderPlugin , SmfPostProviderPrivate , SmfPostProviderPlugin , SmfPostProvider
  • upload() : SamplePlugin , SmfGallery , FlickrGalleryPlugin , SmfGalleryPrivate , FlickrGalleryPlugin , SmfGalleryPlugin
  • uploaded() : MyApplication
  • uploadFinished() : SmfGallery
  • uploadPicture() : MyApplication
  • url() : SmfArtists , SmfLocation , SmfPicture , SmfPictureAlbum , SmfPost
  • URLList() : SmfCredMgrClient
  • URLListL() : CSmfCredMgrClientSymbian
  • URLTableInsert() : CSmfCredMgrDbUser
  • userEvents() : SmfMusicProfile
  • userID() : SMFUserProfile
  • userMusicInfo() : SmfMusicService , SmfMusicServicePrivate , SmfMusicServicePlugin , LastFmMusicServicePlugin
  • userMusicInfoAvailable() : SmfMusicService
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • value() : SmfContact
  • venue() : SmfEvent
  • venues() : SmfEventsFetcher , SmfEventsFetcherPrivate , MusicEventPlugin , SmfEventsFetcherPlugin
  • venuesAvailable() : SmfEventsFetcher
  • version() : SmfPlaylist
  • Version() : RSmfClientSymbianSession , RSmfCredMgrClientSession
  • visibility() : SmfPictureAlbum , SmfPicture
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • wrapper() : SmfServerSymbian
  • writeLog() : MusicLyricsPlugin , MusicEventPlugin
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~
Here is a list of all documented class members with links to the class documentation for each member:

- y -

  • year() : SmfTrackInfo
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- a -

  • actionName() : SmfActivityEntry
  • activities() : SmfActivityEntry
  • addComment() : SmfPictureAlbum , SmfPicture
  • addKeywords() : SmfPictureAlbum
  • addTags() : SmfPicture
  • addToPlaylist() : SmfPlaylistService , SmfPlaylistServicePrivate , SmfPlaylistServicePlugin , LastFmPlaylistServicePlugin
  • addToSessionMap() : SmfServerSymbian
  • album() : SmfTrackInfo
  • albums() : SmfGalleryPlugin , FlickrGalleryPlugin , SmfGallery , SmfGalleryPrivate
  • albumsAvailable() : SmfGallery
  • apiKey() : FBSession
  • apiSecret() : FBSession
  • apiSecureURL() : FBSession
  • apiURL() : FBSession
  • applicationIcon() : LastFmMusicServiceProviderBase , LastFmPlaylistServiceProviderBase , MusicProviderBase , SampleProviderBase , SmfProviderBase , FBActivityProviderBase , FBContactProviderBase , FBProviderBase , FlickrProviderBase , MusicProviderBase , LastFmMusicSearchProviderBase
  • applicationUrl() : FBActivityProviderBase , FBContactProviderBase , SampleProviderBase , FBProviderBase , FlickrProviderBase , MusicProviderBase , LastFmMusicSearchProviderBase , LastFmMusicServiceProviderBase , LastFmPlaylistServiceProviderBase , MusicProviderBase , SmfProvider , SmfProviderBase
  • artists() : SmfAlbum , SmfTrackInfo , SmfEvent
  • associate() : DataStoreManager , SmfRelationMgr , SmfRelationMgrPrivate
  • associatedSnsID() : SMFSocialProfile
  • associatedUserID() : SMFSocialProfile
  • attendees() : SmfEventsFetcherPlugin , SmfEventsFetcher , MusicEventPlugin , SmfEventsFetcherPrivate
  • attendeesAvailable() : SmfEventsFetcher
  • attribution() : SmfPlaylist
  • AuthApp() : AuthApp
  • AuthDataSet() : SmfCredMgrClient
  • AuthDataSetL() : CSmfCredMgrClientSymbian
  • AuthenticatedPluginList() : SmfCredMgrClient
  • authenticatedPluginListL() : CSmfCredMgrClientSymbian
  • authenticationApp() : FBContactProviderBase , LastFmPlaylistServiceProviderBase , LastFmMusicServiceProviderBase , FBActivityProviderBase , FBProviderBase , FlickrProviderBase , LastFmMusicSearchProviderBase , SmfProviderBase , MusicProviderBase , SampleProviderBase , MusicProviderBase , FlickrProviderBase
  • authenticationKeysExpired() : SmfServer
  • author() : SmfPlaylist , SmfActivityEntry
  • AuthParamsTableInsert() : CSmfCredMgrDbUser
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- j -

  • json_parser() : yy::json_parser
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- k -

  • Key() : CSmfSignParameters
  • KeyData() : CSmfRsaKeyParameters
  • KeyName() : CSmfRsaKeyParameters
  • keywords() : SmfPictureAlbum
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- l -

  • language() : SmfLyrics , SmfSubtitle
  • length() : SmfUrl
  • license() : SmfPlaylist
  • lines()
: yy::location
, yy::position
  • link() : SmfActivityObject
  • load() : FBDialog , FBLoginDialog , FBDialog , FBLoginDialog
  • loadURL() : FBDialog
  • location() : SmfPlaylist , yy::location , SmfAlbum
  • logout() : FBSession
  • lyrics() : MusicLyricsPlugin , SmfLyricsServicePlugin , SmfLyrics , SmfLyricsServicePrivate , SmfLyricsService
  • lyricsAvailable() : SmfLyricsService
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- m -

  • maxCharsInPost() : FBPostProviderPlugin , SmfPostProvider , SmfPostProviderPlugin , SmfPostProviderPrivate
  • maxItems() : SmfPostProviderPlugin , FBPostProviderPlugin , SmfPostProvider , SmfPostProviderPrivate
  • maxRating() : SmfMusicRating
  • members() : SmfGroup
  • Message() : CSmfSignParameters
  • metadata() : SmfPlaylist
  • minRating() : SmfMusicRating
  • musicFingerPrint() : SmfMusicFingerPrint
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- n -

  • name() : SmfAlbum , SmfGroup , SMFUserProfile , SmfLocation
  • names() : SmfArtists
  • NewL() : CSmfSignParameters , CSmfClientSymbian , SmfServerSymbian , CSmfRsaKeyParameters , CSmfKeyStoreManager , CSmfCredMgrServerSession , CSmfCredMgrServer , CSmfCredMgrDb , CSmfCredMgrClientSymbian , CSmfCredMgrDbUser , CSmfSignParameters
  • NewLC() : CSmfCredMgrServer , CSmfKeyStoreManager , CSmfCredMgrServerSession , CSmfClientSymbian , CSmfCredMgrDb , CSmfCredMgrDbUser
  • NewSessionL() : CSmfCredMgrServer
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- o -

  • objData() : SmfActivityObject
  • operator=() : SmfActivityObject , SmfArtists , SmfUrl , SmfTrackInfo , SmfSubtitle , SmfGroup , SmfPlaylist , SmfPictureAlbum , SmfPicture , SmfMusicRating , SmfMusicProfile , SmfMusicFingerPrint , SmfLyrics , SmfPost , SmfLocation , SmfEvent , SmfContact , SmfComment , SmfAlbum
  • owner() : SmfPost , SmfPicture
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- z -

  • zipCode() : SmfLocation
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- ~ -

  • ~CPFIndSettings() : CPFIndSettings
  • ~CSmfClientSymbian() : CSmfClientSymbian
  • ~CSmfCredMgrClientSymbian() : CSmfCredMgrClientSymbian
  • ~CSmfCredMgrDb() : CSmfCredMgrDb
  • ~CSmfCredMgrDbUser() : CSmfCredMgrDbUser
  • ~CSmfCredMgrServer() : CSmfCredMgrServer
  • ~CSmfCredMgrServerSession() : CSmfCredMgrServerSession
  • ~CSmfFetchAuthTokenSet() : CSmfFetchAuthTokenSet
  • ~CSmfKeyStoreManager() : CSmfKeyStoreManager
  • ~CSmfPluginIDListParams() : CSmfPluginIDListParams
  • ~CSmfRsaKeyParameters() : CSmfRsaKeyParameters
  • ~CSmfSignParameters() : CSmfSignParameters
  • ~CSmfStoreAuthParams() : CSmfStoreAuthParams
  • ~CSmfURLListParams() : CSmfURLListParams
  • ~DataStoreManager() : DataStoreManager
  • ~FBActivityFetcherPlugin() : FBActivityFetcherPlugin
  • ~FBActivityProviderBase() : FBActivityProviderBase
  • ~FBContactFetcherPlugin() : FBContactFetcherPlugin
  • ~FBContactProviderBase() : FBContactProviderBase
  • ~FBPostProviderPlugin() : FBPostProviderPlugin
  • ~FBProviderBase() : FBProviderBase
  • ~FBSession() : FBSession
  • ~FlickrContactFetcherPlugin() : FlickrContactFetcherPlugin
  • ~FlickrGalleryPlugin() : FlickrGalleryPlugin
  • ~FlickrProviderBase() : FlickrProviderBase
  • ~LastFmMusicSearchPlugin() : LastFmMusicSearchPlugin
  • ~LastFmMusicSearchProviderBase() : LastFmMusicSearchProviderBase
  • ~LastFmMusicServicePlugin() : LastFmMusicServicePlugin
  • ~LastFmMusicServiceProviderBase() : LastFmMusicServiceProviderBase
  • ~LastFmPlaylistServicePlugin() : LastFmPlaylistServicePlugin
  • ~LastFmPlaylistServiceProviderBase() : LastFmPlaylistServiceProviderBase
  • ~MusicEventPlugin() : MusicEventPlugin
  • ~MusicLyricsPlugin() : MusicLyricsPlugin
  • ~MusicProviderBase() : MusicProviderBase
  • ~SamplePlugin() : SamplePlugin
  • ~SampleProviderBase() : SampleProviderBase
  • ~SmfActivityFetcher() : SmfActivityFetcher
  • ~SmfActivityFetcherPlugin() : SmfActivityFetcherPlugin
  • ~SmfActivityFetcherPrivate() : SmfActivityFetcherPrivate
  • ~SmfActivityObject() : SmfActivityObject
  • ~SmfAlbum() : SmfAlbum
  • ~SmfAlbumPrivate() : SmfAlbumPrivate
  • ~SmfArtists() : SmfArtists
  • ~SmfArtistsPrivate() : SmfArtistsPrivate
  • ~SmfClient() : SmfClient
  • ~SmfClientPrivate() : SmfClientPrivate
  • ~SmfComment() : SmfComment
  • ~SmfCommentPrivate() : SmfCommentPrivate
  • ~SmfContact() : SmfContact
  • ~SmfContactFetcher() : SmfContactFetcher
  • ~SmfContactFetcherPlugin() : SmfContactFetcherPlugin
  • ~SmfContactFetcherPrivate() : SmfContactFetcherPrivate
  • ~SmfContactPrivate() : SmfContactPrivate
  • ~SmfCredMgrClient() : SmfCredMgrClient
  • ~SmfEvent() : SmfEvent
  • ~SmfEventPrivate() : SmfEventPrivate
  • ~SmfEventsFetcher() : SmfEventsFetcher
  • ~SmfEventsFetcherPlugin() : SmfEventsFetcherPlugin
  • ~SmfEventsFetcherPrivate() : SmfEventsFetcherPrivate
  • ~SmfGallery() : SmfGallery
  • ~SmfGalleryPlugin() : SmfGalleryPlugin
  • ~SmfGalleryPrivate() : SmfGalleryPrivate
  • ~SmfGroup() : SmfGroup
  • ~SmfGroupPrivate() : SmfGroupPrivate
  • ~SmfLocation() : SmfLocation
  • ~SmfLocationPrivate() : SmfLocationPrivate
  • ~SmfLyrics() : SmfLyrics
  • ~SmfLyricsPrivate() : SmfLyricsPrivate
  • ~SmfLyricsService() : SmfLyricsService
  • ~SmfLyricsServicePlugin() : SmfLyricsServicePlugin
  • ~SmfLyricsServicePrivate() : SmfLyricsServicePrivate
  • ~SmfMusicFingerPrint() : SmfMusicFingerPrint
  • ~SmfMusicFingerPrintPrivate() : SmfMusicFingerPrintPrivate
  • ~SmfMusicProfile() : SmfMusicProfile
  • ~SmfMusicProfilePrivate() : SmfMusicProfilePrivate
  • ~SmfMusicRating() : SmfMusicRating
  • ~SmfMusicRatingPrivate() : SmfMusicRatingPrivate
  • ~SmfMusicSearch() : SmfMusicSearch
  • ~SmfMusicSearchPlugin() : SmfMusicSearchPlugin
  • ~SmfMusicSearchPrivate() : SmfMusicSearchPrivate
  • ~SmfMusicService() : SmfMusicService
  • ~SmfMusicServicePlugin() : SmfMusicServicePlugin
  • ~SmfMusicServicePrivate() : SmfMusicServicePrivate
  • ~SmfPicture() : SmfPicture
  • ~SmfPictureAlbum() : SmfPictureAlbum
  • ~SmfPictureAlbumPrivate() : SmfPictureAlbumPrivate
  • ~SmfPicturePrivate() : SmfPicturePrivate
  • ~SmfPlaylist() : SmfPlaylist
  • ~SmfPlaylistPrivate() : SmfPlaylistPrivate
  • ~SmfPlaylistService() : SmfPlaylistService
  • ~SmfPlaylistServicePlugin() : SmfPlaylistServicePlugin
  • ~SmfPlaylistServicePrivate() : SmfPlaylistServicePrivate
  • ~SmfPluginBase() : SmfPluginBase
  • ~SmfPluginManager() : SmfPluginManager
  • ~SmfPluginManagerUtil() : SmfPluginManagerUtil
  • ~SmfPluginUtil() : SmfPluginUtil
  • ~SmfPost() : SmfPost
  • ~SmfPostPrivate() : SmfPostPrivate
  • ~SmfPostProvider() : SmfPostProvider
  • ~SmfPostProviderPlugin() : SmfPostProviderPlugin
  • ~SmfPostProviderPrivate() : SmfPostProviderPrivate
  • ~SmfProvider() : SmfProvider
  • ~SmfProviderBase() : SmfProviderBase
  • ~SmfSettingsRepositoryQt() : SmfSettingsRepositoryQt
  • ~SMFSocialNetworkingSite() : SMFSocialNetworkingSite
  • ~SMFSocialProfile() : SMFSocialProfile
  • ~SmfSubtitle() : SmfSubtitle
  • ~SmfSubtitlePrivate() : SmfSubtitlePrivate
  • ~SmfTrackInfo() : SmfTrackInfo
  • ~SmfTrackInfoPrivate() : SmfTrackInfoPrivate
  • ~SmfTransportManager() : SmfTransportManager
  • ~SmfTransportManagerUtil() : SmfTransportManagerUtil
  • ~SmfUrl() : SmfUrl
  • ~SmfUrlPrivate() : SmfUrlPrivate
  • ~SMFUserProfile() : SMFUserProfile
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- b -

  • beginSession() : FBSession
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- c -

  • call() : FBRequest
  • callWithDataParams() : FBRequest
  • cancel() : FBRequest
  • cancelLogin() : FBSession
  • cancelRequest() : SmfActivityFetcher , SmfMusicService , SmfMusicSearch , SmfActivityFetcherPrivate , SmfPlaylistService , SmfLyricsService , SmfContactFetcher , SmfMusicServicePrivate , SmfMusicSearchPrivate , SmfContactFetcherPrivate , SmfPlaylistServicePrivate , SmfLyricsServicePrivate , SmfEventsFetcher , SmfPostProvider , SmfPostProviderPrivate , SmfEventsFetcherPrivate , SmfPluginManager , SmfTransportManagerUtil , SmfGallery
  • CancelRequest() : SmfClientQt , CSmfClientSymbian
  • cancelRequest() : SmfGalleryPrivate
  • caption() : SmfActivityObject
  • ChangePluginIDList() : SmfCredMgrClient
  • changePluginIDListL() : CSmfCredMgrClientSymbian
  • CheckPluginAuthentication() : SmfCredMgrClient
  • city() : SmfLocation
  • clientAuthorizationFinished() : SmfServer , SmfServerQt , SmfServerSymbianSession
  • Close() : RSmfCredMgrClientSession
  • columns()
: yy::location
, yy::position
  • commentOnAPost() : FBPostProviderPlugin , SmfPostProvider , SmfPostProviderPrivate , SmfPostProviderPlugin
  • comments() : SmfPicture , SmfPictureAlbum , SmfPlaylist , SmfTrackInfo
  • configurationAdded() : SmfTransportManager
  • configurationChanged() : SmfTransportManager
  • configurationRemoved() : SmfTransportManager
  • connectToServer() : RSmfCredMgrClientSession , RSmfClientSymbianSession
  • constructField() : FlickrGalleryPlugin
  • contactID() : SMFUserProfile
  • content() : SmfActivityObject
  • convert() : SmfContact
  • count() : SmfRelationMgr , SmfRelationMgrPrivate , DataStoreManager
  • country() : SmfLocation
  • CPFIndSettings() : CPFIndSettings
  • create() : SmfRelationMgrPrivate , SmfRelationMgr
  • createParameterString() : SmfPluginUtil
  • createRequest() : SmfPluginManager
  • createSyncRequest() : SmfPluginManager
  • creationDate() : SmfPlaylist
  • customDataAvailable() : SmfActivityFetcher , SmfContactFetcher , SmfGallery , SmfMusicService , SmfMusicSearch , SmfLyricsService , SmfPostProvider , SmfPlaylistService , SmfEventsFetcher
  • customRequest() : SmfLyricsService , FlickrGalleryPlugin , FBContactFetcherPlugin , SmfGalleryPlugin , LastFmMusicServicePlugin , LastFmMusicSearchPlugin , MusicEventPlugin , SmfContactFetcher , SmfContactFetcherPrivate , SmfActivityFetcherPrivate , LastFmPlaylistServicePlugin , SmfPostProviderPlugin , SmfEventsFetcherPlugin , SmfMusicSearchPlugin , SmfEventsFetcher , SmfContactFetcherPlugin , SmfPostProviderPrivate , SmfActivityFetcherPlugin , SmfPlaylistService , SmfMusicSearchPrivate , SmfMusicServicePrivate , SmfMusicService , SmfEventsFetcherPrivate , SmfLyricsServicePlugin , MusicLyricsPlugin , SmfActivityFetcher , FBActivityFetcherPlugin , SmfPlaylistServicePrivate , SmfMusicSearch , FBPostProviderPlugin , SmfMusicServicePlugin , SmfPostProvider , SmfGallery , SmfPlaylistServicePlugin , SmfLyricsServicePrivate , SmfGalleryPrivate , FlickrContactFetcherPlugin
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- d -

  • dataStoreUpdateAvailable() : SmfServer
  • debug_level() : yy::json_parser
  • debug_stream() : yy::json_parser
  • Delete() : SmfRelationMgr , SmfRelationMgrPrivate
  • deleteRelation() : DataStoreManager
  • deleteResource() : SmfTransportManagerUtil
  • DeleteRSAKey() : SmfCredMgrClient
  • deleteRSAKey() : CSmfCredMgrClientSymbian
  • description() : MusicProviderBase , LastFmMusicSearchProviderBase , LastFmMusicServiceProviderBase , LastFmPlaylistServiceProviderBase , FBActivityProviderBase , MusicProviderBase , SamplePlugin , FBContactProviderBase , SampleProviderBase , SmfGallery , FBProviderBase , SmfGalleryPrivate , SmfPicture , FlickrProviderBase , SmfPictureAlbum , SmfPost , FlickrGalleryPlugin , SmfProvider , SmfGalleryPlugin , FlickrProviderBase , SmfProviderBase
  • details() : SmfActivityEntry
  • dialogDidCancel() : FBDialog
  • dialogDidFailWithError() : FBDialog
  • dialogDidSucceed() : FBDialog
  • dialogWillAppear() : FBDialog
  • dialogWillDisappear() : FBLoginDialog , FBDialog
  • dismissWithError() : FBDialog
  • dismissWithSuccess() : FBDialog
  • displayFriends() : MyApplication
  • displayGallery() : MyApplication
  • DisplayWidget() : DisplayWidget
  • DoCancel() : CSmfClientSymbian , CSmfCredMgrClientSymbian
  • downloadFlag() : SmfPicture
  • duration() : SmfEvent , SmfTrackInfo , SmfSubtitle
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- e -

  • EndDate() : CSmfRsaKeyParameters
  • errorLine() : SmfPluginUtil , QJson::Parser
  • errorString() : SmfClient , SmfPluginUtil , QJson::Parser
  • eventDateTime() : SmfEvent
  • events() : MusicEventPlugin , SmfEventsFetcher , SmfEventsFetcherPrivate , SmfEventsFetcherPlugin
  • eventsAvailable() : SmfEventsFetcher
  • eventsUpdated() : SmfEventsFetcher
  • extension() : SmfPlaylist
  • ExternalizeL() : CSmfStoreAuthParams , CSmfRsaKeyParameters , TSmfAuthToken , CSmfSignParameters , CSmfPluginIDListParams , CSmfFetchAuthTokenSet , CSmfPluginIDUpdate , CSmfURLListParams
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- f -

  • favorites() : SmfMusicProfile
  • FBDialog() : FBDialog
  • FBRequest() : FBRequest
  • FBSession() : FBSession
  • FBXMLHandler() : FBXMLHandler
  • fetchKeys() : MusicEventPlugin
  • fetchPluginListL() : CSmfCredMgrDbUser
  • filtered() : FBActivityFetcherPlugin , SmfActivityFetcher , SmfActivityFetcherPrivate , SmfActivityFetcherPlugin
  • findAndServiceclient() : SmfServerSymbian
  • findSession() : SmfServerSymbian
  • followers() : FBContactFetcherPlugin , FlickrContactFetcherPlugin , SmfContactFetcher , SmfContactFetcherPrivate , SmfContactFetcherPlugin
  • followersListAvailable() : SmfContactFetcher
  • frameRate() : SmfSubtitle
  • friends() : FlickrContactFetcherPlugin , SmfContactFetcherPrivate , SmfContactFetcher , FBContactFetcherPlugin , SmfContactFetcherPlugin
  • friendsActivities() : FBActivityFetcherPlugin , SmfActivityFetcherPlugin , SmfActivityFetcher , SmfActivityFetcherPrivate
  • friendsListAvailable() : SmfContactFetcher
  • frobKey() : FBSession
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- g -

  • GenerateNONCE() : SmfCredMgrClient
  • generateNONCE() : CSmfCredMgrClientSymbian
  • genre() : SmfTrackInfo
  • geoPositionInfo() : SmfLocation
  • get() : SmfTransportManagerUtil , SmfRelationMgr , SmfRelationMgrPrivate , DataStoreManager
  • getAll() : SmfRelationMgr , SmfRelationMgrPrivate , DataStoreManager
  • getAllRelations() : SmfRelationMgr , SmfRelationMgrPrivate , DataStoreManager
  • getAuthenticatedPluginList() : SmfServer
  • getAuthKeys() : SmfPluginUtil
  • getAuthorizedPlugins() : SmfServer
  • getContact() : DataStoreManager
  • getData() : RSmfClientSymbianSession
  • getDataStoreManager() : DataStoreManager
  • getDataUsage() : SampleProviderBase
  • getErrorText() : DataStoreManager
  • getInstance() : SmfPluginManager , SmfPluginManagerUtil , SmfTransportManager , SmfTransportManagerUtil
  • getMusic() : MyApplication
  • getNonce() : SmfPluginUtil
  • getPlugin() : SmfServer
  • getPluginId() : SmfPluginManager
  • getPlugins() : SmfServer , SmfPluginManager
  • getProviderInfo() : FBActivityFetcherPlugin , SmfPluginBase , MusicLyricsPlugin , FBContactFetcherPlugin , LastFmMusicSearchPlugin , FlickrContactFetcherPlugin , MusicEventPlugin , FlickrGalleryPlugin , LastFmMusicServicePlugin , FBPostProviderPlugin , LastFmPlaylistServicePlugin , SamplePlugin
  • GetServices() : SmfClient , SmfClientPrivate
  • getSessionProxy() : FBSession
  • getState() : DataStoreManager
  • groupListAvailable() : SmfContactFetcher
  • groups() : FlickrContactFetcherPlugin , SmfContactFetcherPrivate , SmfContactFetcherPlugin , SmfContactFetcher , FBContactFetcherPlugin
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- h -

  • HandleClientMessageL() : SmfServerSymbianSession
  • HandleMessageL() : CSmfKeyStoreManager
  • head() : SmfTransportManagerUtil
  • href() : SmfUrl
  • hreflang() : SmfUrl
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- i -

  • id() : SmfActivityObject , SmfActivityEntry , SmfArtists , SmfLocation , SmfSubtitle , SmfTrackInfo , SmfLyrics , SmfUrl , SmfComment , SmfMusicFingerPrint , SmfMusicProfile , SmfAlbum , SmfEvent , SmfPicture , SmfPictureAlbum , SmfGroup , SmfPlaylist , SmfPost
  • image() : SmfArtists , SmfPlaylist , SmfPost
  • imageUrl() : SmfAlbum
  • info() : SmfPlaylist
  • initialize() : LastFmPlaylistServicePlugin , MusicLyricsPlugin , SmfPluginBase , yy::position , FBPostProviderPlugin , MusicEventPlugin , FlickrContactFetcherPlugin , FBActivityFetcherPlugin , FBContactFetcherPlugin , LastFmMusicSearchPlugin , FlickrGalleryPlugin , yy::location , LastFmMusicServicePlugin
  • initializeTransport() : SmfTransportManager
  • InternalizeL() : TSmfAuthToken , CSmfFetchAuthTokenSet , CSmfURLListParams , CSmfPluginIDListParams , CSmfStoreAuthParams , CSmfPluginIDUpdate
  • isConnected() : FBSession
  • isPluginAuthenticatedL() : CSmfCredMgrClientSymbian
  • itemsCount() : SmfAlbum
Generated on Thu Sep 23 15:03:19 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- p -

  • parse() : SmfPluginUtil , QJson::Parser , yy::json_parser
  • ParserRunnable() : QJson::ParserRunnable
  • parsingFinished()
: QJson::SerializerRunnable
, QJson::ParserRunnable
  • picture() : SmfPicture
  • pictureCount() : SmfPictureAlbum
  • pictures() : FlickrGalleryPlugin , SamplePlugin , SmfGallery , SmfGalleryPrivate , SmfGalleryPlugin
  • picturesAvailable() : SmfGallery
  • playlists() : LastFmPlaylistServicePlugin , SmfPlaylistService , SmfPlaylistServicePrivate , SmfPlaylistServicePlugin
  • playlistsListAvailable() : SmfPlaylistService
  • playlistsOf() : LastFmPlaylistServicePlugin , SmfPlaylistService , SmfPlaylistServicePrivate , SmfPlaylistServicePlugin
  • playListTitle() : SmfPlaylist
  • playlistUpdated() : SmfPlaylistService
  • pluginId() : FlickrProviderBase , MusicProviderBase , LastFmMusicSearchProviderBase , LastFmMusicServiceProviderBase , LastFmPlaylistServiceProviderBase , MusicProviderBase , SampleProviderBase , SmfProviderBase , FBActivityProviderBase , FBContactProviderBase , FBProviderBase , FlickrProviderBase
  • PluginIDTableInsert() : CSmfCredMgrDbUser
  • position() : yy::position
  • post() : FBRequest , FBPostProviderPlugin , FBRequest , SmfPostProvider , SmfPostProviderPrivate , SmfPostProviderPlugin , SmfTransportManagerUtil
  • postAppearence() : FBPostProviderPlugin , SmfPostProvider , SmfPostProviderPrivate , SmfPostProviderPlugin
  • postComment() : SmfGallery , FlickrGalleryPlugin , SamplePlugin , SmfGalleryPrivate , SmfGalleryPlugin
  • postComments() : SmfMusicServicePlugin , LastFmMusicServicePlugin , SmfMusicServicePrivate , SmfMusicService
  • postCurrentPlaying() : SmfMusicServicePrivate , SmfMusicServicePlugin , LastFmMusicServicePlugin , SmfMusicService
  • postCurrentPlayingPlaylist() : LastFmPlaylistServicePlugin , SmfPlaylistService , SmfPlaylistServicePrivate , SmfPlaylistServicePlugin
  • postDirected() : SmfPostProviderPrivate , SmfPostProviderPlugin , SmfPostProvider , FBPostProviderPlugin
  • postedDate() : SmfPicture , SmfPictureAlbum
  • postedDateTime() : SmfPost
  • postEvents() : MusicEventPlugin , SmfEventsFetcherPlugin , SmfEventsFetcher , SmfEventsFetcherPrivate
  • postFinished() : SmfPostProvider
  • postfinished() : SmfMusicService
  • postRating() : SmfMusicService , LastFmMusicServicePlugin , SmfMusicServicePrivate , SmfMusicServicePlugin
  • posts() : SmfPostProvider , SmfPostProviderPrivate
  • postsAvailable() : SmfPostProvider
  • postUpdate() : MyApplication
  • profileID() : SMFSocialProfile
  • profileURL() : SMFSocialProfile
  • put() : SmfTransportManagerUtil
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- q -

  • qobject2qvariant() : QJson::QObjectHelper
  • qvariant2qobject() : QJson::QObjectHelper
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- r -

  • rating() : SmfMusicRating , SmfTrackInfo
  • readAuthAppIdInPluginIdTable() : CSmfCredMgrDbUser
  • readAuthAppIdInRegTokenTable() : CSmfCredMgrDbUser
  • readAuthTokensL() : CSmfCredMgrDbUser
  • readFlagInPluginIdTable() : CSmfCredMgrDbUser
  • readPluginIdL() : CSmfCredMgrDbUser
  • readRegistrationTokenL() : CSmfCredMgrDbUser
  • readUrlL() : CSmfCredMgrDbUser
  • readValidity() : CSmfCredMgrDbUser
  • recentTracks() : SmfMusicProfile
  • recommendations() : LastFmMusicSearchPlugin , SmfMusicSearch , SmfMusicSearchPrivate , SmfMusicSearchPlugin
  • RegTokenValidityTableInsert() : CSmfCredMgrDbUser
  • rel() : SmfUrl
  • releaseYear() : SmfLyrics , SmfSubtitle
  • remove() : SmfRelationMgr , SmfRelationMgrPrivate , DataStoreManager
  • removeFromSessionMap() : SmfServerSymbian
  • request() : FBRequest
  • RequestAsyncService() : RSmfCredMgrClientSession
  • requestDidLoad() : FBRequest
  • requestFailedWithNetworkError() : FBRequest
  • requestLoading() : FBRequest
  • RequestService() : RSmfCredMgrClientSession
  • requestWasCancelled() : FBRequest
  • requestWithSession() : FBRequest
  • responseAvailable() : FBPostProviderPlugin , LastFmMusicSearchPlugin , FBActivityFetcherPlugin , FBContactFetcherPlugin , FlickrContactFetcherPlugin , FlickrGalleryPlugin , MusicEventPlugin , LastFmMusicServicePlugin , LastFmPlaylistServicePlugin , MusicLyricsPlugin , SmfPluginManager , SmfPluginBase , SamplePlugin
  • resultsAvailable() : SmfPlaylistServicePrivate , SmfEventsFetcherPrivate , SmfServerSymbianSession , SmfActivityFetcherPrivate , SmfMusicSearchPrivate , SmfPostProviderPrivate , SmfGalleryPrivate , smfObserver , SmfActivityFetcher , SmfContactFetcherPrivate , SmfMusicServicePrivate , SmfServer , SmfLyricsServicePrivate , SmfClientPrivate
  • resume() : FBSession
  • retrieve() : SmfPostProviderPlugin , FBPostProviderPlugin
  • RSmfClientSymbianSession() : RSmfClientSymbianSession
  • RSmfCredMgrClientSession() : RSmfCredMgrClientSession
  • RunError() : CSmfClientSymbian
  • RunL() : CSmfCredMgrClientSymbian , CSmfClientSymbian
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- s -

  • SamplePlugin() : SamplePlugin
  • SampleProviderBase() : SampleProviderBase
  • SaveFrobKey() : FBSession
  • Savetoken() : FBSession
  • screenAlias() : SMFSocialProfile
  • search() : FlickrContactFetcherPlugin , SmfContactFetcher , SmfContactFetcherPrivate , SmfContactFetcherPlugin , FBContactFetcherPlugin
  • searchAlbum() : LastFmMusicServicePlugin , SmfMusicService , SmfMusicServicePrivate , SmfMusicServicePlugin
  • searchAlbumInfoAvailable() : SmfMusicService
  • searchArtist() : LastFmMusicServicePlugin , SmfMusicService , SmfMusicServicePrivate , SmfMusicServicePlugin
  • searchArtistInfoAvailable() : SmfMusicService
  • searchByContact() : SmfRelationMgr , SmfRelationMgrPrivate , DataStoreManager
  • searchById() : SmfRelationMgr , SmfRelationMgrPrivate , DataStoreManager
  • searchContactFinished() : SmfContactFetcher
  • searchEvents() : SmfMusicServicePlugin , LastFmMusicServicePlugin , SmfMusicService , SmfMusicServicePrivate
  • searchEventsInfoAvailable() : SmfMusicService
  • searchInGroup() : FBContactFetcherPlugin , FlickrContactFetcherPlugin , SmfContactFetcher , SmfContactFetcherPrivate , SmfContactFetcherPlugin
  • searchInGroupFinished() : SmfContactFetcher
  • searchNear() : FBContactFetcherPlugin , FlickrContactFetcherPlugin , SmfContactFetcher , SmfContactFetcherPrivate , SmfContactFetcherPlugin
  • searchNearFinished() : SmfContactFetcher
  • searchUser() : LastFmMusicServicePlugin , SmfMusicService , SmfMusicServicePrivate , SmfMusicServicePlugin
  • searchUserInfoAvailable() : SmfMusicService
  • searchVenue() : LastFmMusicServicePlugin , SmfMusicService , SmfMusicServicePrivate , SmfMusicServicePlugin
  • searchVenueInfoAvailable() : SmfMusicService
  • secondaryId() : SmfAlbum
  • selfActivities() : FBActivityFetcherPlugin , SmfActivityFetcher , SmfActivityFetcherPrivate , SmfActivityFetcherPlugin
  • send() : FBSession
  • sendAsyncRequest() : RSmfClientSymbianSession
  • sendDSMSyncRequest() : CSmfClientSymbian , RSmfClientSymbianSession
  • sendDummyRequest() : SmfClientQt
  • sendRequest() : SmfClientQt , CSmfClientSymbian , RSmfClientSymbianSession
  • sendSyncRequest() : CSmfClientSymbian , RSmfClientSymbianSession
  • sendToDSM() : SmfServer
  • sendToPluginManager() : SmfServer
  • serialize() : QJson::Serializer
  • SerializerRunnable() : QJson::SerializerRunnable
  • server() : SmfPluginManager
  • serviceIcon() : FBActivityProviderBase , FBContactProviderBase , FBProviderBase , FlickrProviderBase , MusicProviderBase , LastFmMusicSearchProviderBase , LastFmMusicServiceProviderBase , LastFmPlaylistServiceProviderBase , MusicProviderBase , SampleProviderBase , SmfProvider , SmfProviderBase
  • ServiceL() : CSmfCredMgrServerSession , SmfServerSymbianSession
  • serviceName() : FBActivityProviderBase , FBContactProviderBase , FBProviderBase , FlickrProviderBase , MusicProviderBase , LastFmMusicSearchProviderBase , LastFmMusicServiceProviderBase , LastFmPlaylistServiceProviderBase , MusicProviderBase , SampleProviderBase , SmfProvider , SmfProviderBase
  • serviceUrl() : FBActivityProviderBase , FBContactProviderBase , FBProviderBase , FlickrProviderBase , MusicProviderBase , LastFmMusicSearchProviderBase , LastFmMusicServiceProviderBase , LastFmPlaylistServiceProviderBase , MusicProviderBase , SampleProviderBase , SmfProviderBase
  • session() : FBSession
  • sessionDidLogin() : FBSession
  • sessionDidLogout() : FBSession
  • sessionDidNotLogin() : FBSession
  • sessionForApplication() : FBSession
  • sessionKey() : FBSession
  • sessionListCount() : SmfServerQt
  • sessionSecret() : FBSession
  • sessionWillLogout() : FBSession
  • set_debug_level() : yy::json_parser
  • set_debug_stream() : yy::json_parser
  • setActionName() : SmfActivityEntry
  • setActivities() : SmfActivityEntry
  • setAlbum() : SmfTrackInfo
  • setApplicationUrl() : SmfProvider
  • setArtists() : SmfAlbum , SmfEvent , SmfTrackInfo
  • setAssociatedSns() : SMFSocialProfile
  • setAssociatedSnsID() : SMFSocialProfile
  • setAttribution() : SmfPlaylist
  • setAuthor() : SmfActivityEntry , SmfPlaylist
  • setCaption() : SmfActivityObject
  • setCity() : SmfLocation
  • setComment() : SmfTrackInfo
  • setComments() : SmfPlaylist
  • setContactID() : SMFUserProfile
  • setContent() : SmfActivityObject
  • setCountry() : SmfLocation
  • setCreationDate() : SmfPlaylist
  • setDescription() : SmfPicture , SmfPictureAlbum , SmfPost , SmfProvider
  • setDetails() : SmfActivityEntry
  • setDuration() : SmfEvent , SmfSubtitle , SmfTrackInfo
  • setEventDateTime() : SmfEvent
  • setExtension() : SmfPlaylist
  • setFavorites() : SmfMusicProfile
  • setFrameRate() : SmfSubtitle
  • setGenre() : SmfTrackInfo
  • setGeoPositionInfo() : SmfLocation
  • setHhreflang() : SmfUrl
  • setHref() : SmfUrl
  • setId() : SmfActivityObject , SmfActivityEntry , SmfAlbum , SmfArtists , SmfComment , SmfEvent , SmfGroup , SmfLocation , SmfLyrics , SmfMusicFingerPrint , SmfMusicProfile , SmfPicture , SmfPictureAlbum , SmfPlaylist , SmfPost , SmfSubtitle , SmfTrackInfo , SmfUrl
  • setImage() : SmfArtists , SmfPlaylist , SmfPost
  • setImageUrl() : SmfAlbum
  • setInfo() : SmfPlaylist
  • setItemsCount() : SmfAlbum
  • setJsonObject() : QJson::SerializerRunnable
  • setLanguage() : SmfLyrics , SmfSubtitle
  • setLength() : SmfUrl
  • setLicense() : SmfPlaylist
  • setLink() : SmfActivityObject
  • setLocation() : SmfAlbum , SmfPlaylist
  • setLyrics() : SmfLyrics
  • setMaxRating() : SmfMusicRating
  • setMembers() : SmfGroup
  • setMetadata() : SmfPlaylist
  • setMinRating() : SmfMusicRating
  • setMusicFingerPrint() : SmfMusicFingerPrint
  • setName() : SmfAlbum , SmfGroup , SmfLocation , SMFUserProfile
  • setNames() : SmfArtists
  • setObjData() : SmfActivityObject
  • setOwner() : SmfPicture , SmfPost
  • setPicture() : SmfPicture
  • setPictureCount() : SmfPictureAlbum
  • setPlayListTitle() : SmfPlaylist
  • setPostedDate() : SmfPicture , SmfPictureAlbum
  • setPostedDateTime() : SmfPost
  • setProfileURL() : SMFSocialProfile
  • setRating() : SmfMusicRating , SmfTrackInfo
  • setRecentTracks() : SmfMusicProfile
  • setRel() : SmfUrl
  • setReleaseYear() : SmfLyrics , SmfSubtitle
  • setScreenAlias() : SMFSocialProfile
  • setSecondaryId() : SmfAlbum
  • setServiceIcon() : SmfProvider
  • setServiceName() : SmfProvider
  • setSession() : FBSession
  • setSnsName() : SMFSocialNetworkingSite
  • setSnsURL() : SMFSocialNetworkingSite
  • setStreet() : SmfLocation
  • setSubtitle() : SmfSubtitle
  • setSubtitleUrl() : SmfSubtitle
  • setSupportedInterfaces() : SmfProvider
  • setSupportedLanguages() : SmfProvider
  • setTags() : SmfArtists , SmfTrackInfo
  • setTargetObj() : SmfActivityEntry
  • setText() : SmfComment
  • setThumbnail() : SmfActivityObject , SmfPictureAlbum
  • setTicketUrl() : SmfEvent
  • setTime() : SmfActivityObject
  • setTimeStamp() : SmfComment
  • setTitle() : SmfActivityEntry , SmfEvent , SmfPicture , SmfPictureAlbum , SmfPost , SmfTrackInfo , SmfUrl
  • setTrackList() : SmfPlaylist
  • setType() : SmfActivityObject , SmfAlbum , SmfUrl
  • setUrl() : SmfLocation , SmfPicture , SmfPictureAlbum , SmfPost , SmfArtists
  • setUserEvents() : SmfMusicProfile
  • setValue() : SmfContact
  • setVenue() : SmfEvent
  • setVersion() : SmfPlaylist
  • setVisibility() : SmfPicture , SmfPictureAlbum
  • setYear() : SmfTrackInfo
  • setZipCode() : SmfLocation
  • sharePost() : SmfPostProviderPlugin , FBPostProviderPlugin , SmfPostProvider , SmfPostProviderPrivate
  • show() : FBDialog
  • SignMessage() : SmfCredMgrClient
  • signMessageL() : CSmfCredMgrClientSymbian
  • SmfActivityFetcher() : SmfActivityFetcher
  • SmfActivityFetcherPrivate() : SmfActivityFetcherPrivate
  • SmfActivityObject() : SmfActivityObject
  • SmfAlbum() : SmfAlbum
  • SmfAlbumPrivate() : SmfAlbumPrivate
  • SmfArtists() : SmfArtists
  • SmfArtistsPrivate() : SmfArtistsPrivate
  • SmfClient() : SmfClient
  • SmfClientPrivate() : SmfClientPrivate
  • SmfClientQt() : SmfClientQt
  • SmfComment() : SmfComment
  • SmfCommentPrivate() : SmfCommentPrivate
  • SmfContact() : SmfContact
  • SmfContactFetcher() : SmfContactFetcher
  • SmfContactFetcherPrivate() : SmfContactFetcherPrivate
  • SmfContactPrivate() : SmfContactPrivate
  • SmfCredMgrClient() : SmfCredMgrClient
  • SmfEvent() : SmfEvent
  • SmfEventPrivate() : SmfEventPrivate
  • SmfEventsFetcher() : SmfEventsFetcher
  • SmfEventsFetcherPrivate() : SmfEventsFetcherPrivate
  • SmfGallery() : SmfGallery
  • SmfGalleryPrivate() : SmfGalleryPrivate
  • SmfGroup() : SmfGroup
  • SmfGroupPrivate() : SmfGroupPrivate
  • SmfLocation() : SmfLocation
  • SmfLocationPrivate() : SmfLocationPrivate
  • SmfLyrics() : SmfLyrics
  • SmfLyricsPrivate() : SmfLyricsPrivate
  • SmfLyricsService() : SmfLyricsService
  • SmfLyricsServicePrivate() : SmfLyricsServicePrivate
  • SmfMusicFingerPrint() : SmfMusicFingerPrint
  • SmfMusicFingerPrintPrivate() : SmfMusicFingerPrintPrivate
  • SmfMusicProfile() : SmfMusicProfile
  • SmfMusicProfilePrivate() : SmfMusicProfilePrivate
  • SmfMusicRating() : SmfMusicRating
  • SmfMusicRatingPrivate() : SmfMusicRatingPrivate
  • SmfMusicSearch() : SmfMusicSearch
  • SmfMusicSearchPrivate() : SmfMusicSearchPrivate
  • SmfMusicService() : SmfMusicService
  • SmfMusicServicePrivate() : SmfMusicServicePrivate
  • SmfPicture() : SmfPicture
  • SmfPictureAlbum() : SmfPictureAlbum
  • SmfPictureAlbumPrivate() : SmfPictureAlbumPrivate
  • SmfPicturePrivate() : SmfPicturePrivate
  • SmfPlaylist() : SmfPlaylist
  • SmfPlaylistPrivate() : SmfPlaylistPrivate
  • SmfPlaylistService() : SmfPlaylistService
  • SmfPlaylistServicePrivate() : SmfPlaylistServicePrivate
  • SmfPluginUtil() : SmfPluginUtil
  • SmfPost() : SmfPost
  • SmfPostPrivate() : SmfPostPrivate
  • SmfPostProvider() : SmfPostProvider
  • SmfPostProviderPrivate() : SmfPostProviderPrivate
  • SmfProvider() : SmfProvider
  • smfRegistrationId() : FBActivityProviderBase , MusicProviderBase , LastFmMusicServiceProviderBase , SmfProviderBase , SampleProviderBase , FBContactProviderBase , FlickrProviderBase , MusicProviderBase , LastFmMusicSearchProviderBase , FlickrProviderBase , LastFmPlaylistServiceProviderBase , FBProviderBase
  • SmfRelationItem() : SmfRelationItem
  • SmfRelationMgrPrivate() : SmfRelationMgrPrivate
  • SmfServer() : SmfServer
  • SmfServerQt() : SmfServerQt
  • SmfServerQtSession() : SmfServerQtSession
  • SmfServerSymbianSession() : SmfServerSymbianSession
  • SMFSettings() : SMFSettings
  • SmfSettingsHandler() : SmfSettingsHandler
  • SmfSettingsRepositoryQt() : SmfSettingsRepositoryQt
  • SMFSocialNetworkingSite() : SMFSocialNetworkingSite
  • SMFSocialProfile() : SMFSocialProfile
  • SmfSubtitle() : SmfSubtitle
  • SmfSubtitlePrivate() : SmfSubtitlePrivate
  • SmfTrackInfo() : SmfTrackInfo
  • SmfTrackInfoPrivate() : SmfTrackInfoPrivate
  • SmfUrl() : SmfUrl
  • SmfUrlPrivate() : SmfUrlPrivate
  • SMFUserProfile() : SMFUserProfile
  • snsID() : SMFSocialNetworkingSite
  • snsName() : SMFSocialNetworkingSite
  • snsURL() : SMFSocialNetworkingSite
  • start() : SmfServerQt
  • StartDate() : CSmfRsaKeyParameters
  • startServer() : SmfServer
  • step() : yy::location
  • StoreAuthData() : SmfCredMgrClient
  • storeAuthDataL() : CSmfCredMgrClientSymbian
  • StoreRSAKeys() : SmfCredMgrClient
  • storeRSAKeysL() : CSmfCredMgrClientSymbian
  • stores() : LastFmMusicSearchPlugin , SmfMusicSearchPlugin , SmfMusicSearch , SmfMusicSearchPrivate
  • storeSearchAvailable() : SmfMusicSearch
  • street() : SmfLocation
  • subtitle() : SmfSubtitle
  • subtitleAvailable() : SmfLyricsService
  • subtitles() : SmfLyricsService , SmfLyricsServicePrivate , SmfLyricsServicePlugin , MusicLyricsPlugin
  • subtitleUrl() : SmfSubtitle
  • subTypes() : SmfContact
  • supportedFormats() : SmfPostProviderPrivate , SmfPostProvider , FBPostProviderPlugin , SmfPostProviderPlugin
  • supportedInterfaces() : LastFmMusicSearchProviderBase , LastFmPlaylistServiceProviderBase , FBActivityProviderBase , FBContactProviderBase , LastFmMusicServiceProviderBase , SmfProvider , MusicProviderBase , FlickrProviderBase , FBProviderBase , SmfProviderBase , MusicProviderBase
  • supportedLanguages() : MusicProviderBase , LastFmMusicSearchProviderBase , SmfProviderBase , LastFmMusicServiceProviderBase , FlickrProviderBase , FBActivityProviderBase , FBContactProviderBase , LastFmPlaylistServiceProviderBase , FBProviderBase , SmfProvider , FlickrProviderBase
  • supportsAppearence() : FBPostProviderPlugin , SmfPostProviderPlugin , SmfPostProviderPrivate , SmfPostProvider
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- t -

  • tags() : SmfArtists , SmfPicture , SmfTrackInfo
  • targetObj() : SmfActivityEntry
  • text() : SmfComment
  • thumbnail() : SmfActivityObject , SmfPictureAlbum
  • ticketUrl() : SmfEvent
  • time() : SmfActivityObject
  • timeStamp() : FBRequest , SmfComment
  • title() : SmfPictureAlbum , SmfPost , SmfTrackInfo , SmfUrl , SmfActivityEntry , SmfEvent , SmfPicture
  • trackInfo() : SmfMusicSearchPlugin , LastFmMusicSearchPlugin , SmfMusicSearch , SmfMusicSearchPrivate
  • trackList() : SmfPlaylist
  • trackSearchAvailable() : SmfMusicSearch
  • tracksOfAlbum() : SmfMusicSearchPlugin , SmfMusicSearch , LastFmMusicSearchPlugin , SmfMusicSearchPrivate
  • tracksOfArtist() : SmfMusicSearchPrivate , LastFmMusicSearchPlugin , SmfMusicSearchPlugin , SmfMusicSearch
  • tracksSimilar() : SmfMusicSearchPlugin , SmfMusicSearch , LastFmMusicSearchPlugin , SmfMusicSearchPrivate
  • TSmfAuthToken() : TSmfAuthToken
  • type() : SmfUrl , SmfActivityObject , SmfAlbum
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- u -

  • updatePlugin() : CSmfCredMgrDbUser
  • updatePost() : FBPostProviderPlugin , SmfPostProviderPrivate , SmfPostProviderPlugin , SmfPostProvider
  • upload() : SamplePlugin , SmfGallery , FlickrGalleryPlugin , SmfGalleryPrivate , FlickrGalleryPlugin , SmfGalleryPlugin
  • uploaded() : MyApplication
  • uploadFinished() : SmfGallery
  • uploadPicture() : MyApplication
  • url() : SmfArtists , SmfLocation , SmfPicture , SmfPictureAlbum , SmfPost
  • URLList() : SmfCredMgrClient
  • URLListL() : CSmfCredMgrClientSymbian
  • URLTableInsert() : CSmfCredMgrDbUser
  • userEvents() : SmfMusicProfile
  • userID() : SMFUserProfile
  • userMusicInfo() : SmfMusicService , SmfMusicServicePrivate , SmfMusicServicePlugin , LastFmMusicServicePlugin
  • userMusicInfoAvailable() : SmfMusicService
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- v -

  • value() : SmfContact
  • venue() : SmfEvent
  • venues() : SmfEventsFetcher , SmfEventsFetcherPrivate , MusicEventPlugin , SmfEventsFetcherPlugin
  • venuesAvailable() : SmfEventsFetcher
  • version() : SmfPlaylist
  • Version() : RSmfClientSymbianSession , RSmfCredMgrClientSession
  • visibility() : SmfPictureAlbum , SmfPicture
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- w -

  • wrapper() : SmfServerSymbian
  • writeLog() : MusicLyricsPlugin , MusicEventPlugin
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • y
  • z
  • ~

- y -

  • year() : SmfTrackInfo
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Related Functions

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • o

- o -

  • operator<< : SmfActivityObject , SmfActivityEntry , SmfArtists , SmfGroup , SmfPlaylist , SmfPost , SmfLocation , SmfProvider , SmfSubtitle , SmfComment , SmfLyrics , SmfTrackInfo , SmfUrl , SmfMusicFingerPrint , SmfAlbum , SmfContact , SmfMusicProfile , SmfMusicRating , SmfEvent , SmfPicture , SmfPictureAlbum
  • operator>> : SmfActivityObject , SmfMusicRating , SmfPicture , SmfPost , SmfProvider , SmfTrackInfo , SmfUrl , SmfArtists , SmfComment , SmfEvent , SmfGroup , SmfMusicFingerPrint , SmfMusicProfile , SmfPlaylist , SmfSubtitle , SmfAlbum , SmfContact , SmfLyrics , SmfPictureAlbum , SmfActivityEntry , SmfLocation
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Typedefs

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • debug_level_type : yy::json_parser
  • location_type : yy::json_parser
  • semantic_type : yy::json_parser
  • token_type : yy::json_parser
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Class Members - Variables

  • All
  • Functions
  • Variables
  • Typedefs
  • Related Functions
  • b
  • c
  • e
  • f
  • i
  • l
  • m
  • p

- b -

  • begin : yy::location

- c -

  • column : yy::position

- e -

  • end : yy::location

- f -

  • filename : yy::position

- i -

  • iAppName : SmfPluginDataUsage
  • iAuthAppID : CSmfStoreAuthParams
  • iAuthTokenArray : CSmfStoreAuthParams , CSmfFetchAuthTokenSet
  • iBytesReceived : SmfPluginDataUsage
  • iBytesSent : SmfPluginDataUsage
  • iHttpOperationType : SmfPluginRequestData
  • iInputData : SmfWaitingPluginInfoStruc
  • iInstance : SmfWaitingPluginInfoStruc
  • iInterfaceName : SmfPluginDataUsage
  • iItemsPerPage : SmfResultPage
  • iKey : TSmfAuthToken
  • iNetworkRequest : SmfPluginRequestData
  • iNewPluginID : CSmfPluginIDUpdate
  • iOldPluginID : CSmfPluginIDUpdate
  • iOperation : SmfWaitingPluginInfoStruc
  • iPageNum : SmfResultPage
  • iPluginID : CSmfURLListParams
  • iPluginId : SmfWaitingPluginInfoStruc
  • iPluginIDList : CSmfStoreAuthParams
  • iPluginList : CSmfPluginIDListParams
  • iPostData : SmfPluginRequestData
  • iRegistrationToken : CSmfFetchAuthTokenSet , CSmfPluginIDListParams , CSmfStoreAuthParams
  • iRequestType : SmfPluginRequestData
  • isDownloaded : SmfPicturePrivate
  • iSecret : TSmfAuthToken
  • iServiceProviderName : SmfPluginDataUsage
  • iSession : FBDialog
  • iSessionID : SmfWaitingPluginInfoStruc
  • iTotalItems : SmfResultPage
  • iTotalPages : SmfResultPage
  • iURLList : CSmfStoreAuthParams , CSmfURLListParams
  • iValidity : CSmfStoreAuthParams , CSmfFetchAuthTokenSet

- l -

  • line : yy::position

- m -

  • m_href : SmfUrlPrivate
  • m_id : SmfActivityEntryPrivate , SmfActivityObjectPrivate
  • m_title : SmfPictureAlbumPrivate
  • m_version : SmfPlaylistPrivate

- p -

  • pluginIDEnabled : CSmfStoreAuthParams , CSmfPluginIDUpdate
Generated on Thu Sep 23 15:03:20 2010 for smf by doxygen 1.6.3


smf: Namespace Index

  • Namespace List
  • Namespace Members

Namespace List

Here is a list of all documented namespaces with brief descriptions:
smfcredmgrclientutil
SmfUtils
Generated on Thu Sep 23 15:03:52 2010 for smf by doxygen 1.6.3


smf: smfcredmgrclientutil Namespace Reference

  • Namespace List
  • Namespace Members

smfcredmgrclientutil Namespace Reference

Functions

RPointerArray< HBufC > | convertToSymbianURLList (QList< QUrl > URLList)
RPointerArray< HBufC > | convertToSymbianPluginList (QStringList PluginList)
void | convertToQStringList (RPointerArray< HBufC > aPluginList, QStringList &ListInQt)
void | convertToQUrlList (RPointerArray< HBufC > aURLList, QList< QUrl > &List)
void | RArrayToSmfAuthParams (RArray< TSmfAuthToken > aArray, SmfAuthParams &Params)
void | SmfAuthParamstoRArray (SmfAuthParams Params, RArray< TSmfAuthToken > &aArray)

Detailed Description

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Pritam Roy Biswas, Sasken Communication Technologies Ltd - Initial contribution

Description: Header file for the utility to handle conversion between symbian and Qt in Credential Manager.

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Pritam Roy Biswas, Sasken Communication Technologies Ltd - Initial contribution

Description: Header file for the utility to handle conversion between symbian and Qt in Credential Manager. Utility to handle conversion between symbian and Qt in Credential Manager.

Function Documentation

void smfcredmgrclientutil::convertToQStringList | ( | RPointerArray< HBufC > | aPluginList,
 |  | QStringList & | ListInQt
 | ) |  |

Conversion method

Parameters:
aPluginList | List in RPointerArray<HBufC>
ListInQt | List in QStringList
void smfcredmgrclientutil::convertToQUrlList | ( | RPointerArray< HBufC > | aURLList,
 |  | QList< QUrl > & | List
 | ) |  |

Conversion method

Parameters:
aURLList | List in RPointerArray<HBufC>
List | List in QStringList
RPointerArray< HBufC > smfcredmgrclientutil::convertToSymbianPluginList ( QStringList PluginList )

Method to convert QStringList type to RPointerArray<HBufC>

Parameters:
PluginList The QStringList to be converted
Returns:
The Converted plugin list in RPointerArray<HBufC>
RPointerArray< HBufC > smfcredmgrclientutil::convertToSymbianURLList ( QList< QUrl > URLList )

Method to convert QList<QUrl> type to RPointerArray<HBufC> type

Parameters:
URLList List of URL in Qt
Returns:
the symbian list of thype RPointerArray<HBufC>
void smfcredmgrclientutil::RArrayToSmfAuthParams | ( | RArray< TSmfAuthToken > | aArray,
 |  | SmfAuthParams & | Params
 | ) |  |

Conversion Method

Parameters:
aArray | Array in RArray<TSmfAuthToken>
Params | Array in SmfAuthParams
void smfcredmgrclientutil::SmfAuthParamstoRArray | ( | SmfAuthParams | Params,
 |  | RArray< TSmfAuthToken > & | aArray
 | ) |  |

Conversion Method

Parameters:
aArray | Array in RArray<TSmfAuthToken>
Params | Array in SmfAuthParams
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: SmfUtils Namespace Reference

  • Namespace List
  • Namespace Members

SmfUtils Namespace Reference

Functions

void | ExternalizeDesL (const TDesC8 &aDes, RWriteStream &aStream)
TInt | InternalizeDesL (RBuf8 &aDes, RReadStream &aStream)
void | ExternalizeDesL (const TDesC16 &aDes, RWriteStream &aStream)
HBufC16 * | InternalizeDesL (RReadStream &aStream)
TInt | InternalizeDesL (RBuf16 &aDes, RReadStream &aStream)
void | ExternalizeInt64L (const TInt64 &aInt, RWriteStream &aStream)
void | InternalizeInt64L (TInt64 &aInt, RReadStream &aStream)

Detailed Description

Utility to serialize data

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "Eclipse Public License v1.0" which accompanies this distribution, and is available at the URL "http://www.eclipse.org/legal/epl-v10.html"

Initial Contributors: Lasse Laasonen, Sasken Communication Technologies Ltd - Initial contribution

Description: This source contains utility routines used by server and client

Function Documentation

void SmfUtils::ExternalizeDesL | ( | const TDesC16 & | aDes,
 |  | RWriteStream & | aStream
 | ) |  |

Method to externalize

Parameters:
aDes | descriptor to be externalized
aStream | The Write Stream to be filled.
void SmfUtils::ExternalizeDesL | ( | const TDesC8 & | aDes,
 |  | RWriteStream & | aStream
 | ) |  |

Method to externalize

Parameters:
aDes | descriptor to be externalized
aStream | The Write Stream to be filled.
void SmfUtils::ExternalizeInt64L | ( | const TInt64 & | aInt,
 |  | RWriteStream & | aStream
 | ) |  |

Method to externalize

Parameters:
aInt | integer to be externalized
aStream | The Write Stream to be filled.
HBufC16 * SmfUtils::InternalizeDesL ( RReadStream & aStream )

Method to internalize

Parameters:
aStream the stream to read from.
TInt SmfUtils::InternalizeDesL | ( | RBuf8 & | aDes,
 |  | RReadStream & | aStream
 | ) |  |

Method to internalize

Parameters:
aDes | descriptor to be internalized
aStream | the stream to read from.
void SmfUtils::InternalizeInt64L | ( | TInt64 & | aInt,
 |  | RReadStream & | aStream
 | ) |  |

Method to internalize

Parameters:
aInt | integer to be internalized
aStream | the stream to read from.
Generated on Thu Sep 23 15:03:53 2010 for smf by doxygen 1.6.3


smf: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
Here is a list of all documented namespace members with links to the namespaces they belong to:
  • convertToQStringList() : smfcredmgrclientutil
  • convertToQUrlList() : smfcredmgrclientutil
  • convertToSymbianPluginList() : smfcredmgrclientutil
  • convertToSymbianURLList() : smfcredmgrclientutil
  • ExternalizeDesL() : SmfUtils
  • ExternalizeInt64L() : SmfUtils
  • InternalizeDesL() : SmfUtils
  • InternalizeInt64L() : SmfUtils
  • RArrayToSmfAuthParams() : smfcredmgrclientutil
  • SmfAuthParamstoRArray() : smfcredmgrclientutil
Generated on Thu Sep 23 15:03:54 2010 for smf by doxygen 1.6.3


smf: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • convertToQStringList() : smfcredmgrclientutil
  • convertToQUrlList() : smfcredmgrclientutil
  • convertToSymbianPluginList() : smfcredmgrclientutil
  • convertToSymbianURLList() : smfcredmgrclientutil
  • ExternalizeDesL() : SmfUtils
  • ExternalizeInt64L() : SmfUtils
  • InternalizeDesL() : SmfUtils
  • InternalizeInt64L() : SmfUtils
  • RArrayToSmfAuthParams() : smfcredmgrclientutil
  • SmfAuthParamstoRArray() : smfcredmgrclientutil
Generated on Thu Sep 23 15:03:54 2010 for smf by doxygen 1.6.3


smf: File Index

  • File List

File List

Here is a list of all documented files with brief descriptions:
example/sampleplugin.h [code] |
example/AuthApp/AuthApp.h [code] |
example/AuthApp/progressbar.h [code] |
example/AuthApp/ui_AuthApp.h [code] |
example/AuthApp/ui_progressbar.h [code] |
example/AuthApp/inc/authAppConstants.h [code] |
example/AuthApp/inc/baseDialog.h [code] |
example/AuthApp/inc/errorCodes.h [code] |
example/AuthApp/inc/keys.h [code] |
example/AuthApp/inc/loginDialog.h [code] |
example/AuthApp/inc/requestSP.h [code] |
example/AuthApp/inc/sessionSP.h [code] |
example/AuthApp/inc/xmlParser.h [code] |
example/DemoGUI/CustomListWidget.h [code] |
example/DemoGUI/FriendView.h [code] |
example/DemoGUI/GridView.h [code] |
example/DemoGUI/HomeView.h [code] |
example/DemoGUI/ImageDownload.h [code] |
example/DemoGUI/mainwindow.h [code] |
example/DemoGUI/ScreenSize.h [code] |
example/DemoGUI/ToolBar.h [code] |
example/DemoGUI/ui_mainwindow.h [code] |
example/DemoGUI/WidgetConstants.h [code] |
example/fbactivityfetcherplugin/fbactivityfetcherplugin.h [code] |
example/fbcontactfetcherplugin/fbcontactfetcherplugin.h [code] |
example/fbpostproviderplugin/fbpostproviderplugin.h [code] |
example/FlickrAuthApp/AuthApp.h [code] |
example/FlickrAuthApp/progressbar.h [code] |
example/FlickrAuthApp/ui_AuthApp.h [code] |
example/FlickrAuthApp/ui_progressbar.h [code] |
example/FlickrAuthApp/inc/authAppConstants.h [code] |
example/FlickrAuthApp/inc/baseDialog.h [code] |
example/FlickrAuthApp/inc/errorCodes.h [code] |
example/FlickrAuthApp/inc/keys.h [code] |
example/FlickrAuthApp/inc/loginDialog.h [code] |
example/FlickrAuthApp/inc/requestSP.h [code] |
example/FlickrAuthApp/inc/sessionSP.h [code] |
example/FlickrAuthApp/inc/xmlParser.h [code] |
example/flickrcontactfetcherplugin/flickrcontactfetcherplugin.h [code] |
example/flickrgalleryplugin/flickrgalleryplugin.h [code] |
example/lastfmmusiceventplugin/lastfmmusiceventplugin.h [code] |
example/lastfmmusicsearchplugin/lastfmmusicsearchplugin.h [code] |
example/lastfmmusicserviceplugin/lastfmmusicserviceplugin.h [code] |
example/lastfmplaylistserviceplugin/lastfmplaylistserviceplugin.h [code] |
example/MusicLyricsPlugin/MusicLyricsPlugin.h [code] |
example/smfclientapp/displaywidget.h [code] |
example/smfclientapp/posttestui.h [code] |
example/smfclientapp/smfclientapp.h [code] |
example/smfclientapp/testscreen.h [code] |
example/smfclientapp/ui_displaywidget.h [code] |
example/smfclientapp/ui_posttestui.h [code] |
example/smfclientapp/ui_smfclientapp.h [code] |
smf/smfdes.h [code] |
smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclient.h [code] |
smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclient_p.h [code] |
smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclientsession.h [code] |
smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclientutil.h [code] |
smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrclientdatastruct.h [code] |
smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrclientglobal.h [code] |
smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrcommon.h [code] |
smf/smfcredentialmgr/smfcredmgrcommon/inc/smfutils.h [code] |
smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrdb.h [code] |
smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrdbuser.h [code] |
smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrserver.h [code] |
smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrserversession.h [code] |
smf/smfcredentialmgr/smfcredmgrserver/inc/smfkeystoremanager.h [code] |
smf/smfservermodule/smfclient/smfactivityfetcher.h [code] |
smf/smfservermodule/smfclient/smfactivityfetcher_p.h [code] |
smf/smfservermodule/smfclient/smfclient.h [code] |
smf/smfservermodule/smfclient/smfclient_p.h [code] |
smf/smfservermodule/smfclient/smfclientqt.h [code] |
smf/smfservermodule/smfclient/smfclientsymbian.h [code] |
smf/smfservermodule/smfclient/smfclientsymbiansession.h [code] |
smf/smfservermodule/smfclient/smfcontactfetcher.h [code] |
smf/smfservermodule/smfclient/smfcontactfetcher_p.h [code] |
smf/smfservermodule/smfclient/smfeventsfetcher.h [code] |
smf/smfservermodule/smfclient/smfeventsfetcher_p.h [code] |
smf/smfservermodule/smfclient/smfgallery.h [code] |
smf/smfservermodule/smfclient/smfgallery_p.h [code] |
smf/smfservermodule/smfclient/smfmusic.h [code] |
smf/smfservermodule/smfclient/smfmusic_p.h [code] |
smf/smfservermodule/smfclient/smfpostprovider.h [code] |
smf/smfservermodule/smfclient/smfpostprovider_p.h [code] |
smf/smfservermodule/smfclient/smfrelationmgr.h [code] |
smf/smfservermodule/smfclient/smfrelationmgr_p.h [code] |
smf/smfservermodule/smfcommon/smfactions.h [code] |
smf/smfservermodule/smfcommon/smfactions_p.h [code] |
smf/smfservermodule/smfcommon/smfalbum.h [code] |
smf/smfservermodule/smfcommon/smfalbum_p.h [code] |
smf/smfservermodule/smfcommon/smfartists.h [code] |
smf/smfservermodule/smfcommon/smfartists_p.h [code] |
smf/smfservermodule/smfcommon/smfclientglobal.h [code] |
smf/smfservermodule/smfcommon/smfcomment.h [code] |
smf/smfservermodule/smfcommon/smfcomment_p.h [code] |
smf/smfservermodule/smfcommon/smfcontact.h [code] |
smf/smfservermodule/smfcommon/smfcontact_p.h [code] |
smf/smfservermodule/smfcommon/smfevent.h [code] |
smf/smfservermodule/smfcommon/smfevent_p.h [code] |
smf/smfservermodule/smfcommon/smfglobal.h [code] |
smf/smfservermodule/smfcommon/smfgroup.h [code] |
smf/smfservermodule/smfcommon/smfgroup_p.h [code] |
smf/smfservermodule/smfcommon/smflocation.h [code] |
smf/smfservermodule/smfcommon/smflocation_p.h [code] |
smf/smfservermodule/smfcommon/smflyrics.h [code] |
smf/smfservermodule/smfcommon/smflyrics_p.h [code] |
smf/smfservermodule/smfcommon/smfmusicfingerprint.h [code] |
smf/smfservermodule/smfcommon/smfmusicfingerprint_p.h [code] |
smf/smfservermodule/smfcommon/smfmusicprofile.h [code] |
smf/smfservermodule/smfcommon/smfmusicprofile_p.h [code] |
smf/smfservermodule/smfcommon/smfmusicrating.h [code] |
smf/smfservermodule/smfcommon/smfmusicrating_p.h [code] |
smf/smfservermodule/smfcommon/smfobserver.h [code] |
smf/smfservermodule/smfcommon/smfpicture.h [code] |
smf/smfservermodule/smfcommon/smfpicture_p.h [code] |
smf/smfservermodule/smfcommon/smfpicturealbum.h [code] |
smf/smfservermodule/smfcommon/smfpicturealbum_p.h [code] |
smf/smfservermodule/smfcommon/smfplaylist.h [code] |
smf/smfservermodule/smfcommon/smfplaylist_p.h [code] |
smf/smfservermodule/smfcommon/smfpluginutil.h [code] |
smf/smfservermodule/smfcommon/smfpost.h [code] |
smf/smfservermodule/smfcommon/smfpost_p.h [code] |
smf/smfservermodule/smfcommon/smfprovider.h [code] |
smf/smfservermodule/smfcommon/smfsubtitle.h [code] |
smf/smfservermodule/smfcommon/smfsubtitle_p.h [code] |
smf/smfservermodule/smfcommon/smftrackinfo.h [code] |
smf/smfservermodule/smfcommon/smftrackinfo_p.h [code] |
smf/smfservermodule/smfcommon/smfurl.h [code] |
smf/smfservermodule/smfcommon/smfurl_p.h [code] |
smf/smfservermodule/smfserver/smfserverglobal.h [code] |
smf/smfservermodule/smfserver/datastoremgr/dsm.h [code] |
smf/smfservermodule/smfserver/datastoremgr/smfSns.cpp | File containing implementation for SMFSocialNetworkingSite class
smf/smfservermodule/smfserver/datastoremgr/smfSns.h [code] | File containing class description for SMFSocialNetworkingSite class
smf/smfservermodule/smfserver/datastoremgr/smfSocialProfile.cpp | File containing implementation for SMFSocialProfile class
smf/smfservermodule/smfserver/datastoremgr/smfSocialProfile.h [code] | File containing class description for SMFSocialProfile class
smf/smfservermodule/smfserver/datastoremgr/smfUserProfile.cpp | File containing implementation for SMFUserProfile class
smf/smfservermodule/smfserver/datastoremgr/smfUserProfile.h [code] | File containing class description for SMFUserProfile class
smf/smfservermodule/smfserver/pluginmgr/smfpluginmanager.h [code] |
smf/smfservermodule/smfserver/pluginmgr/smfpluginmanagerutil.h [code] |
smf/smfservermodule/smfserver/server/smfserver.h [code] |
smf/smfservermodule/smfserver/server/smfserverqt_p.h [code] |
smf/smfservermodule/smfserver/server/smfserverqtsession.h [code] |
smf/smfservermodule/smfserver/server/smfserversymbian_p.h [code] |
smf/smfservermodule/smfserver/server/smfsettingshandler.h [code] |
smf/smfservermodule/smfserver/server/smfsettingshandler_qt.h [code] |
smf/smfservermodule/smfserver/server/smfsettingshandler_symbian.h [code] |
smf/smfservermodule/smfserver/smfplugins/smfactivityfetcherplugin.h [code] |
smf/smfservermodule/smfserver/smfplugins/smfcontactfetcherplugin.h [code] |
smf/smfservermodule/smfserver/smfplugins/smfeventsfetcherplugin.h [code] |
smf/smfservermodule/smfserver/smfplugins/smfgalleryplugin.h [code] |
smf/smfservermodule/smfserver/smfplugins/smflyricsserviceplugin.h [code] |
smf/smfservermodule/smfserver/smfplugins/smfmusicsearchplugin.h [code] |
smf/smfservermodule/smfserver/smfplugins/smfmusicserviceplugin.h [code] |
smf/smfservermodule/smfserver/smfplugins/smfplaylistserviceplugin.h [code] |
smf/smfservermodule/smfserver/smfplugins/smfpluginbase.h [code] |
smf/smfservermodule/smfserver/smfplugins/smfpostproviderplugin.h [code] |
smf/smfservermodule/smfserver/smfplugins/smfproviderbase.h [code] |
smf/smfservermodule/smfserver/transportmgr/smftransportmanager.h [code] |
smf/smfservermodule/smfserver/transportmgr/smftransportmanagerutil.h [code] |
smf/smfservermodule/util/qjson/src/json_parser.hh [code] |
smf/smfservermodule/util/qjson/src/json_scanner.h [code] |
smf/smfservermodule/util/qjson/src/location.hh [code] |
smf/smfservermodule/util/qjson/src/parser.h [code] |
smf/smfservermodule/util/qjson/src/parser_p.h [code] |
smf/smfservermodule/util/qjson/src/parserrunnable.h [code] |
smf/smfservermodule/util/qjson/src/position.hh [code] |
smf/smfservermodule/util/qjson/src/qjson_debug.h [code] |
smf/smfservermodule/util/qjson/src/qjson_export.h [code] |
smf/smfservermodule/util/qjson/src/qobjecthelper.h [code] |
smf/smfservermodule/util/qjson/src/serializer.h [code] |
smf/smfservermodule/util/qjson/src/serializerrunnable.h [code] |
smf/smfservermodule/util/qjson/src/stack.hh [code] |
smf/smfservermodule/util/qjson/tests/person.h [code] |
smf/smfsettingsui/PlatfromIndependentSettings.h [code] |
smf/smfsettingsui/SettingsConstants.h [code] |
smf/smfsettingsui/SettingsRepository.h [code] |
smf/smfsettingsui/SMFSettings.h [code] |
Generated on Thu Sep 23 15:03:54 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/datastoremgr/smfSns.cpp File Reference

  • File List

smf/smfservermodule/smfserver/datastoremgr/smfSns.cpp File Reference

File containing implementation for SMFSocialNetworkingSite class. More...

#include "smfSns.h"
#include <QObject>
#include <QString>

Detailed Description

File containing implementation for SMFSocialNetworkingSite class.

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "{License}" which accompanies this distribution, and is available at the URL "{LicenseUrl}".

Author:
Jaspinder Singh, Sasken Communication Technologies Ltd - Initial contribution
Version:
0.1
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/datastoremgr/smfSns.h File Reference

  • File List

smf/smfservermodule/smfserver/datastoremgr/smfSns.h File Reference

File containing class description for SMFSocialNetworkingSite class. More...

#include <QObject>
#include <QString>

Go to the source code of this file.

Classes

class SMFSocialNetworkingSite
This class represents a social networking site. More...

Detailed Description

File containing class description for SMFSocialNetworkingSite class.

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "{License}" which accompanies this distribution, and is available at the URL "{LicenseUrl}".

Author:
Jaspinder Singh, Sasken Communication Technologies Ltd - Initial contribution
Version:
0.1
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/datastoremgr/smfSns.h Source File

  • File List

smf/smfservermodule/smfserver/datastoremgr/smfSns.h

Go to the documentation of this file.
00001
00018 #ifndef SMFSOCIALNETWORKINGSITE_H
00019 #define SMFSOCIALNETWORKINGSITE_H
00020
00021 #include <QObject>
00022 #include <QString>
00023
00024 class DataStoreManager; //Forward Declaration
00025
00027
00032 class SMFSocialNetworkingSite : public QObject
00033 {
00034         Q_OBJECT
00035
00036     friend class DataStoreManager;
00037
00038         public:
00039         SMFSocialNetworkingSite(const QString& name="", const QString& url="", QObject* parent = 0);
00040         int snsID() const;
00041                 const QString& snsName() const;
00042                 const QString& snsURL() const;
00043                 ~SMFSocialNetworkingSite();
00044
00045         public slots:
00046                 void setSnsName(const QString& name);
00047                 void setSnsURL(const QString& url);
00048
00049         private:
00050                 int m_sns_id;                   // m_sns_id gets generated. It is never set through a setter method. Hence, no public setter for ID.
00051                                                 // It gets generated when the social networking site is stored in the database.
00052                 QString m_sns_name;
00053                 QString m_sns_url;
00054
00055         private slots:
00056                 void setSnsID(int id);          //private setter method for ID. Might be required.
00057 };
00058
00059 #endif
Generated on Thu Sep 23 15:03:14 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/datastoremgr/smfSocialProfile.cpp File Reference

  • File List

smf/smfservermodule/smfserver/datastoremgr/smfSocialProfile.cpp File Reference

File containing implementation for SMFSocialProfile class. More...

#include "smfSocialProfile.h"
#include <QObject>
#include <QString>
#include "smfSns.h"

Detailed Description

File containing implementation for SMFSocialProfile class.

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "{License}" which accompanies this distribution, and is available at the URL "{LicenseUrl}".

Author:
Jaspinder Singh, Sasken Communication Technologies Ltd - Initial contribution
Version:
0.1
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/datastoremgr/smfSocialProfile.h File Reference

  • File List

smf/smfservermodule/smfserver/datastoremgr/smfSocialProfile.h File Reference

File containing class description for SMFSocialProfile class. More...

#include <QObject>
#include <QString>
#include "smfSns.h"
#include "smfUserProfile.h"

Go to the source code of this file.

Classes

class SMFSocialProfile
This class represents a user's public profile on a social networking site. More...

Detailed Description

File containing class description for SMFSocialProfile class.

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "{License}" which accompanies this distribution, and is available at the URL "{LicenseUrl}".

Author:
Jaspinder Singh, Sasken Communication Technologies Ltd - Initial contribution
Version:
0.1
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/datastoremgr/smfSocialProfile.h Source File

  • File List

smf/smfservermodule/smfserver/datastoremgr/smfSocialProfile.h

Go to the documentation of this file.
00001
00018 #ifndef SMFSOCIALPROFILE_H
00019 #define SMFSOCIALPROFILE_H
00020
00021 #include <QObject>
00022 #include <QString>
00023
00024 #include "smfSns.h"
00025 #include "smfUserProfile.h"
00026
00027 class DataStoreManager; //Forward Declaration
00028
00030
00038 class SMFSocialProfile: public QObject
00039 {
00040         Q_OBJECT
00041
00042     friend class DataStoreManager;
00043
00044         public:
00045         SMFSocialProfile(const SMFSocialNetworkingSite& site, const QString& profile_url = "", const QString& screen_alias = "", QObject* parent = 0);
00046         SMFSocialProfile(int sns_id = -1, int user_id = -1, const QString& profile_url = "", const QString& screen_alias = "", QObject* parent = 0);
00047         SMFSocialProfile (const SMFSocialProfile& other);
00048                 ~SMFSocialProfile();
00049                 int associatedUserID() const;
00050                 int associatedSnsID() const;
00051                 int profileID() const;
00052                 const QString& profileURL() const;
00053                 const QString& screenAlias() const;
00054
00055         public slots:
00056                 void setAssociatedSns(const SMFSocialNetworkingSite& site);
00057                 void setAssociatedSnsID(int sns_id);
00058                 void setProfileURL(const QString& profile_url);
00059                 void setScreenAlias(const QString& screen_alias);
00060
00061         private:
00062                 int m_social_profile_id;
00063                 int m_user_id;
00064                 int m_sns_id;
00065                 QString m_profile_url;
00066                 QString m_screen_alias;
00067
00068         private slots:
00069                 void setProfileID(int id);
00070         void setAssociatedUserID(int user_id);
00071         void setAssociatedUserProfile(const SMFUserProfile& user_profile);
00072 };
00073
00074 #endif
Generated on Thu Sep 23 15:03:14 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/datastoremgr/smfUserProfile.cpp File Reference

  • File List

smf/smfservermodule/smfserver/datastoremgr/smfUserProfile.cpp File Reference

File containing implementation for SMFUserProfile class. More...

#include "smfUserProfile.h"

Detailed Description

File containing implementation for SMFUserProfile class.

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "{License}" which accompanies this distribution, and is available at the URL "{LicenseUrl}".

Author:
Jaspinder Singh, Sasken Communication Technologies Ltd - Initial contribution
Version:
0.1
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/datastoremgr/smfUserProfile.h File Reference

  • File List

smf/smfservermodule/smfserver/datastoremgr/smfUserProfile.h File Reference

File containing class description for SMFUserProfile class. More...

#include <QObject>
#include <QString>

Go to the source code of this file.

Classes

class SMFUserProfile
This class represents a user's profile. More...

Detailed Description

File containing class description for SMFUserProfile class.

Copyright (c) 2010 Sasken Communication Technologies Ltd. All rights reserved. This component and the accompanying materials are made available under the terms of the "{License}" which accompanies this distribution, and is available at the URL "{LicenseUrl}".

Author:
Jaspinder Singh, Sasken Communication Technologies Ltd - Initial contribution
Version:
0.1
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/datastoremgr/smfUserProfile.h Source File

  • File List

smf/smfservermodule/smfserver/datastoremgr/smfUserProfile.h

Go to the documentation of this file.
00001
00017 #ifndef SMFUSERPROFILE_H
00018 #define SMFUSERPROFILE_H
00019
00020 #include <QObject>
00021 #include <QString>
00022
00023 class DataStoreManager; //Forward Declaration
00024
00026
00033 class SMFUserProfile : public QObject
00034 {
00035         Q_OBJECT
00036
00037     friend class DataStoreManager;
00038
00039         public:
00040         SMFUserProfile(const QString& name = "", const QString& contact_id = "", QObject* parent = 0);
00041                 ~SMFUserProfile();
00042                 int userID() const;
00043                 const QString& name() const;
00044                 const QString& contactID() const;
00045
00046         public slots:
00047                 void setName(const QString& name);
00048                 void setContactID(const QString& contact_id);
00049
00050         private:
00051                 int m_user_id;
00052         QString m_name;
00053         QString m_contact_id;
00054
00055         private slots:
00056                 void setUserID(int id);
00057 };
00058
00059 #endif
Generated on Thu Sep 23 15:03:14 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/src/location.hh File Reference

  • File List

smf/smfservermodule/util/qjson/src/location.hh File Reference

#include <iostream>
#include <string>
#include "position.hh"

Go to the source code of this file.

Classes

class | yy::location
Abstract a location. More...

Functions

const location | yy::operator+ (const location &begin, const location &end)
Join two location objects to create a location.
const location | yy::operator+ (const location &begin, unsigned int width)
Add two location objects.
location & | yy::operator+= (location &res, unsigned int width)
Add and assign a location.
std::ostream & | yy::operator<< (std::ostream &ostr, const location &loc)
Intercept output stream redirection.

Detailed Description

Define the yy::location class.

Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/src/location.hh Source File

  • File List

smf/smfservermodule/util/qjson/src/location.hh

Go to the documentation of this file.
00001 /* A Bison parser, made by GNU Bison 2.3.  */
00002
00003 /* Locations for Bison parsers in C++
00004
00005    Copyright (C) 2002, 2003, 2004, 2005, 2006 Free Software Foundation, Inc.
00006
00007    This program is free software; you can redistribute it and/or modify
00008    it under the terms of the GNU General Public License as published by
00009    the Free Software Foundation; either version 2, or (at your option)
00010    any later version.
00011
00012    This program is distributed in the hope that it will be useful,
00013    but WITHOUT ANY WARRANTY; without even the implied warranty of
00014    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00015    GNU General Public License for more details.
00016
00017    You should have received a copy of the GNU General Public License
00018    along with this program; if not, write to the Free Software
00019    Foundation, Inc., 51 Franklin Street, Fifth Floor,
00020    Boston, MA 02110-1301, USA.  */
00021
00022 /* As a special exception, you may create a larger work that contains
00023    part or all of the Bison parser skeleton and distribute that work
00024    under terms of your choice, so long as that work isn't itself a
00025    parser generator using the skeleton or a modified version thereof
00026    as a parser skeleton.  Alternatively, if you modify or redistribute
00027    the parser skeleton itself, you may (at your option) remove this
00028    special exception, which will cause the skeleton and the resulting
00029    Bison output files to be licensed under the GNU General Public
00030    License without this special exception.
00031
00032    This special exception was added by the Free Software Foundation in
00033    version 2.2 of Bison.  */
00034
00040 #ifndef BISON_LOCATION_HH
00041 # define BISON_LOCATION_HH
00042
00043 # include <iostream>
00044 # include <string>
00045 # include "position.hh"
00046
00047 namespace yy
00048 {
00049
00051   class location
00052   {
00053   public:
00054
00056     location ()
00057       : begin (), end ()
00058     {
00059     }
00060
00061
00063     inline void initialize (std::string* fn)
00064     {
00065       begin.initialize (fn);
00066       end = begin;
00067     }
00068
00071   public:
00073     inline void step ()
00074     {
00075       begin = end;
00076     }
00077
00079     inline void columns (unsigned int count = 1)
00080     {
00081       end += count;
00082     }
00083
00085     inline void lines (unsigned int count = 1)
00086     {
00087       end.lines (count);
00088     }
00092   public:
00094     position begin;
00096     position end;
00097   };
00098
00100   inline const location operator+ (const location& begin, const location& end)
00101   {
00102     location res = begin;
00103     res.end = end.end;
00104     return res;
00105   }
00106
00108   inline const location operator+ (const location& begin, unsigned int width)
00109   {
00110     location res = begin;
00111     res.columns (width);
00112     return res;
00113   }
00114
00116   inline location& operator+= (location& res, unsigned int width)
00117   {
00118     res.columns (width);
00119     return res;
00120   }
00121
00128   inline std::ostream& operator<< (std::ostream& ostr, const location& loc)
00129   {
00130     position last = loc.end - 1;
00131     ostr << loc.begin;
00132     if (last.filename
00133         && (!loc.begin.filename
00134             || *loc.begin.filename != *last.filename))
00135       ostr << '-' << last;
00136     else if (loc.begin.line != last.line)
00137       ostr << '-' << last.line  << '.' << last.column;
00138     else if (loc.begin.column != last.column)
00139       ostr << '-' << last.column;
00140     return ostr;
00141   }
00142
00143 }
00144
00145 #endif // not BISON_LOCATION_HH
Generated on Thu Sep 23 15:03:16 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/src/position.hh File Reference

  • File List

smf/smfservermodule/util/qjson/src/position.hh File Reference

#include <iostream>
#include <string>

Go to the source code of this file.

Classes

class | yy::position
Abstract a position. More...

Functions

const position & | yy::operator+= (position &res, const int width)
Add and assign a position.
const position | yy::operator+ (const position &begin, const int width)
Add two position objects.
const position & | yy::operator-= (position &res, const int width)
Add and assign a position.
const position | yy::operator- (const position &begin, const int width)
Add two position objects.
std::ostream & | yy::operator<< (std::ostream &ostr, const position &pos)
Intercept output stream redirection.

Detailed Description

Define the yy::position class.

Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/src/position.hh Source File

  • File List

smf/smfservermodule/util/qjson/src/position.hh

Go to the documentation of this file.
00001 /* A Bison parser, made by GNU Bison 2.3.  */
00002
00003 /* Positions for Bison parsers in C++
00004
00005    Copyright (C) 2002, 2003, 2004, 2005, 2006 Free Software Foundation, Inc.
00006
00007    This program is free software; you can redistribute it and/or modify
00008    it under the terms of the GNU General Public License as published by
00009    the Free Software Foundation; either version 2, or (at your option)
00010    any later version.
00011
00012    This program is distributed in the hope that it will be useful,
00013    but WITHOUT ANY WARRANTY; without even the implied warranty of
00014    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00015    GNU General Public License for more details.
00016
00017    You should have received a copy of the GNU General Public License
00018    along with this program; if not, write to the Free Software
00019    Foundation, Inc., 51 Franklin Street, Fifth Floor,
00020    Boston, MA 02110-1301, USA.  */
00021
00022 /* As a special exception, you may create a larger work that contains
00023    part or all of the Bison parser skeleton and distribute that work
00024    under terms of your choice, so long as that work isn't itself a
00025    parser generator using the skeleton or a modified version thereof
00026    as a parser skeleton.  Alternatively, if you modify or redistribute
00027    the parser skeleton itself, you may (at your option) remove this
00028    special exception, which will cause the skeleton and the resulting
00029    Bison output files to be licensed under the GNU General Public
00030    License without this special exception.
00031
00032    This special exception was added by the Free Software Foundation in
00033    version 2.2 of Bison.  */
00034
00040 #ifndef BISON_POSITION_HH
00041 # define BISON_POSITION_HH
00042
00043 # include <iostream>
00044 # include <string>
00045
00046 namespace yy
00047 {
00049   class position
00050   {
00051   public:
00052
00054     position ()
00055       : filename (0), line (1), column (0)
00056     {
00057     }
00058
00059
00061     inline void initialize (std::string* fn)
00062     {
00063       filename = fn;
00064       line = 1;
00065       column = 0;
00066     }
00067
00070   public:
00072     inline void lines (int count = 1)
00073     {
00074       column = 0;
00075       line += count;
00076     }
00077
00079     inline void columns (int count = 1)
00080     {
00081       int leftmost = 0;
00082       int current  = column;
00083       if (leftmost <= current + count)
00084         column += count;
00085       else
00086         column = 0;
00087     }
00090   public:
00092     std::string* filename;
00094     unsigned int line;
00096     unsigned int column;
00097   };
00098
00100   inline const position&
00101   operator+= (position& res, const int width)
00102   {
00103     res.columns (width);
00104     return res;
00105   }
00106
00108   inline const position
00109   operator+ (const position& begin, const int width)
00110   {
00111     position res = begin;
00112     return res += width;
00113   }
00114
00116   inline const position&
00117   operator-= (position& res, const int width)
00118   {
00119     return res += -width;
00120   }
00121
00123   inline const position
00124   operator- (const position& begin, const int width)
00125   {
00126     return begin + -width;
00127   }
00128
00133   inline std::ostream&
00134   operator<< (std::ostream& ostr, const position& pos)
00135   {
00136     if (pos.filename)
00137       ostr << *pos.filename << ':';
00138     return ostr << pos.line << '.' << pos.column;
00139   }
00140
00141 }
00142 #endif // not BISON_POSITION_HH
Generated on Thu Sep 23 15:03:16 2010 for smf by doxygen 1.6.3


smf: example/AuthApp/AuthApp.h Source File

  • File List

example/AuthApp/AuthApp.h

00001
00018 #ifndef AUTHAPP_H
00019 #define AUTHAPP_H
00020
00021 #include <QtGui/QMainWindow>
00022 #include "ui_AuthApp.h"
00023 #include "errorCodes.h"
00024 #include "loginDialog.h"
00025 #include "sessionSP.h"
00026
00027 class AuthApp : public QMainWindow
00028 {
00029     Q_OBJECT
00030
00031 public:
00032         AuthApp(QWidget *parent = 0);
00033     ~AuthApp();
00034 private:
00035         void CheckforLogin();
00036 private slots:
00037     void on_buttonForget_clicked();
00038     void on_pushButton_clicked();
00039
00040     void sessionDidLogin(QString sessionkey);
00041     void sessionDidLogout();
00042
00043     void requestFailedWithFacebookError ( const FBError& aError );
00044
00045 protected:
00046     void changeEvent(QEvent *e);
00047
00048 private:
00049     FBSession*      iFBSession;
00050     FBLoginDialog*  iLoginDialog;
00051     Ui::AuthAppClass *ui;
00052 };
00053
00054 #endif // AUTHAPP_H
Generated on Thu Sep 23 15:03:07 2010 for smf by doxygen 1.6.3


smf: example/AuthApp/inc/authAppConstants.h Source File

  • File List

example/AuthApp/inc/authAppConstants.h

00001
00018 #ifndef FBCONNECTGLOBAL_H
00019 #define FBCONNECTGLOBAL_H
00020
00021 #include <QtGlobal>
00022 #include <QHash>
00023 #include <QString>
00024
00025 typedef QHash<QString,QString> Dictionary;
00026 typedef QHashIterator<QString, QString> DictionaryIterator;
00027
00028
00029
00030 #endif // FBCONNECTGLOBAL_H
Generated on Thu Sep 23 15:03:07 2010 for smf by doxygen 1.6.3


smf: example/AuthApp/inc/baseDialog.h Source File

  • File List

example/AuthApp/inc/baseDialog.h

00001
00018 #ifndef FB_DIALOG_H_
00019 #define FB_DIALOH_H_
00020
00021 #include <QDialog>
00022 #include <QWebView>
00023 #include <qprogressbar.h>
00024 #include <qboxlayout.h>
00025 #include "authAppConstants.h"
00026
00027 // FORWARD DECLARATIONS
00028 class FBSession;
00029 class FBError;
00030 class QNetworkReply;
00031
00032 const QString KSuccessurl = "http://www.facebook.com/connect/login_success.html";
00036 class FBDialog : public QWidget
00037 {
00038     Q_OBJECT
00039
00040 protected:
00041
00045     FBSession*  iSession;
00046     QWebView*   iWebView;
00047     QString     iLoadingUrl;
00048     bool        iIgnorePageLoadCompleteEvent;
00049     QProgressBar* progressbar;
00050     QVBoxLayout* layout;
00051
00052 signals:
00053
00057     void dialogDidSucceed ();
00058
00062     void dialogDidCancel();
00063
00067     void dialogDidFailWithError ( const FBError& error );
00068
00069
00070
00071 private slots:
00072     void cancel();
00073
00074     /* slots for signals from QWebView.page() */
00075     void linkClicked ( const QUrl & url );
00076     void loadStarted ();
00077     void loadProgress(int progress);
00078     void loadFinished ( bool ok );
00079
00080     //Network Error Slots
00081     void slotAuthenticationRequired( QNetworkReply* reply, QAuthenticator* authenticator );
00082     void slotsslErrors( QNetworkReply* reply, const QList<QSslError>& errors  );
00083     void slotproxyAuthenticationRequired( const QNetworkProxy& proxy, QAuthenticator* authenticator  );
00084
00085 public:
00086
00087         void proxysettings();
00091     FBDialog(FBSession* aSession);
00092     FBDialog();
00093
00099     void show();
00100
00105     virtual void load ();
00106
00110     void loadURL(const QString& aUrl, QNetworkAccessManager::Operation aMethod, const QHash<QString, QString>& aGetParams,
00111                  const QHash<QString, QString>&  aPostParams);
00112
00113
00114     void dismiss(bool aAnimated);
00115
00119     void dismissWithSuccess (bool aSuccess, bool aAnimated);
00120
00124     void dismissWithError (const FBError& aError, bool aAnimated);
00125
00129     virtual void dialogWillAppear();
00130
00134     virtual void dialogWillDisappear();
00135
00141     virtual void dialogDidSucceed(const QUrl& aUrl);
00142
00143     QString title() const;
00144     void setTitle ( const QString& aTitle );
00145
00146     virtual void GetSessionKey(const QUrl& aUrl);
00147     virtual void FetchKeyFromUrl(const QUrl& aUrl);
00148 private:
00149     void createControls();
00150
00151     QString generateURL( const QString& aUrl, const QHash<QString, QString>& aParams) const;
00152     QByteArray generatePostBody (const QHash<QString, QString>& aParams) const;
00153
00154     void postDismissCleanup();
00155
00156
00157  };
00158 #endif
Generated on Thu Sep 23 15:03:07 2010 for smf by doxygen 1.6.3


smf: example/AuthApp/inc/errorCodes.h Source File

  • File List

example/AuthApp/inc/errorCodes.h

00001
00018 #ifndef FBERROR_H_
00019 #define FBERROR_H_
00020
00021
00022 #include "authAppConstants.h"
00023
00025 // Error codes
00026 /* defined by this proj*/
00027 #define FBRESPONSE_PARSE_ERROR 13  /* the xml parser was unable to parse the response returned by the server */
00028
00029 /* defined and returned by facebook */
00030 #define FBAPI_EC_SUCCESS 0
00031 #define FBAPI_EC_UNKNOWN 1
00032 #define FBAPI_EC_SERVICE 2
00033 #define FBAPI_EC_METHOD 3
00034 #define FBAPI_EC_TOO_MANY_CALLS 4
00035 #define FBAPI_EC_BAD_IP 5
00036 #define FBAPI_EC_HOST_API 6
00037 #define FBAPI_EC_HOST_UP 7
00038 #define FBAPI_EC_SECURE 8
00039 #define FBAPI_EC_RATE 9
00040 #define FBAPI_EC_PERMISSION_DENIED 10
00041 #define FBAPI_EC_DEPRECATED 11
00042 #define FBAPI_EC_VERSION 12
00043
00044 #define FBAPI_EC_PARAM 100
00045 #define FBAPI_EC_PARAM_FBAPI_KEY 101
00046 #define FBAPI_EC_PARAM_SESSION_KEY 102
00047 #define FBAPI_EC_PARAM_CALL_ID 103
00048 #define FBAPI_EC_PARAM_SIGNATURE 104
00049 #define FBAPI_EC_PARAM_TOO_MANY 105
00050 #define FBAPI_EC_PARAM_USER_ID 110
00051 #define FBAPI_EC_PARAM_USER_FIELD 111
00052 #define FBAPI_EC_PARAM_SOCIAL_FIELD 112
00053 #define FBAPI_EC_PARAM_EMAIL 113
00054 #define FBAPI_EC_PARAM_ALBUM_ID 120
00055 #define FBAPI_EC_PARAM_PHOTO_ID 121
00056 #define FBAPI_EC_PARAM_FEED_PRIORITY 130
00057 #define FBAPI_EC_PARAM_CATEGORY 140
00058 #define FBAPI_EC_PARAM_SUBCATEGORY 141
00059 #define FBAPI_EC_PARAM_TITLE 142
00060 #define FBAPI_EC_PARAM_DESCRIPTION 143
00061 #define FBAPI_EC_PARAM_BAD_JSON 144
00062 #define FBAPI_EC_PARAM_BAD_EID 150
00063 #define FBAPI_EC_PARAM_UNKNOWN_CITY 151
00064 #define FBAPI_EC_PARAM_BAD_PAGE_TYPE 152
00065
00066 #define FBAPI_EC_PERMISSION 200
00067 #define FBAPI_EC_PERMISSION_USER 210
00068 #define FBAPI_EC_PERMISSION_ALBUM 220
00069 #define FBAPI_EC_PERMISSION_PHOTO 221
00070 #define FBAPI_EC_PERMISSION_MESSAGE 230
00071 #define FBAPI_EC_PERMISSION_MARKUP_OTHER_USER 240
00072 #define FBAPI_EC_PERMISSION_STATUS_UPDATE 250
00073 #define FBAPI_EC_PERMISSION_PHOTO_UPLOAD 260
00074 #define FBAPI_EC_PERMISSION_SMS 270
00075 #define FBAPI_EC_PERMISSION_CREATE_LISTING 280
00076 #define FBAPI_EC_PERMISSION_EVENT 290
00077 #define FBAPI_EC_PERMISSION_LARGE_FBML_TEMPLATE 291
00078 #define FBAPI_EC_PERMISSION_LIVEMESSAGE 292
00079 #define FBAPI_EC_PERMISSION_RSVP_EVENT 299
00080
00081 #define FBAPI_EC_EDIT 300
00082 #define FBAPI_EC_EDIT_USER_DATA 310
00083 #define FBAPI_EC_EDIT_PHOTO 320
00084 #define FBAPI_EC_EDIT_ALBUM_SIZE 321
00085 #define FBAPI_EC_EDIT_PHOTO_TAG_SUBJECT 322
00086 #define FBAPI_EC_EDIT_PHOTO_TAG_PHOTO 323
00087 #define FBAPI_EC_EDIT_PHOTO_FILE 324
00088 #define FBAPI_EC_EDIT_PHOTO_PENDING_LIMIT 325
00089 #define FBAPI_EC_EDIT_PHOTO_TAG_LIMIT 326
00090 #define FBAPI_EC_EDIT_ALBUM_REORDER_PHOTO_NOT_IN_ALBUM 327
00091 #define FBAPI_EC_EDIT_ALBUM_REORDER_TOO_FEW_PHOTOS 328
00092 #define FBAPI_EC_MALFORMED_MARKUP 329
00093 #define FBAPI_EC_EDIT_MARKUP 330
00094 #define FBAPI_EC_EDIT_FEED_TOO_MANY_USER_CALLS 340
00095 #define FBAPI_EC_EDIT_FEED_TOO_MANY_USER_ACTION_CALLS 341
00096 #define FBAPI_EC_EDIT_FEED_TITLE_LINK 342
00097 #define FBAPI_EC_EDIT_FEED_TITLE_LENGTH 343
00098 #define FBAPI_EC_EDIT_FEED_TITLE_NAME 344
00099 #define FBAPI_EC_EDIT_FEED_TITLE_BLANK 345
00100 #define FBAPI_EC_EDIT_FEED_BODY_LENGTH 346
00101 #define FBAPI_EC_EDIT_FEED_PHOTO_SRC 347
00102 #define FBAPI_EC_EDIT_FEED_PHOTO_LINK 348
00103 #define FBAPI_EC_EDIT_VIDEO_SIZE 350
00104 #define FBAPI_EC_EDIT_VIDEO_INVALID_FILE 351
00105 #define FBAPI_EC_EDIT_VIDEO_INVALID_TYPE 352
00106 #define FBAPI_EC_EDIT_FEED_TITLE_ARRAY 360
00107 #define FBAPI_EC_EDIT_FEED_TITLE_PARAMS 361
00108 #define FBAPI_EC_EDIT_FEED_BODY_ARRAY 362
00109 #define FBAPI_EC_EDIT_FEED_BODY_PARAMS 363
00110 #define FBAPI_EC_EDIT_FEED_PHOTO 364
00111 #define FBAPI_EC_EDIT_FEED_TEMPLATE 365
00112 #define FBAPI_EC_EDIT_FEED_TARGET 366
00113 #define FBAPI_EC_USERS_CREATE_INVALID_EMAIL 370
00114 #define FBAPI_EC_USERS_CREATE_EXISTING_EMAIL 371
00115 #define FBAPI_EC_USERS_CREATE_BIRTHDAY 372
00116 #define FBAPI_EC_USERS_CREATE_PASSWORD 373
00117 #define FBAPI_EC_USERS_REGISTER_INVALID_CREDENTIAL 374
00118 #define FBAPI_EC_USERS_REGISTER_CONF_FAILURE 375
00119 #define FBAPI_EC_USERS_REGISTER_EXISTING 376
00120 #define FBAPI_EC_USERS_REGISTER_DEFAULT_ERROR 377
00121 #define FBAPI_EC_USERS_REGISTER_PASSWORD_BLANK 378
00122 #define FBAPI_EC_USERS_REGISTER_PASSWORD_INVALID_CHARS 379
00123 #define FBAPI_EC_USERS_REGISTER_PASSWORD_SHORT 380
00124 #define FBAPI_EC_USERS_REGISTER_PASSWORD_WEAK 381
00125 #define FBAPI_EC_USERS_REGISTER_USERNAME_ERROR 382
00126 #define FBAPI_EC_USERS_REGISTER_MISSING_INPUT 383
00127 #define FBAPI_EC_USERS_REGISTER_INCOMPLETE_BDAY 384
00128 #define FBAPI_EC_USERS_REGISTER_INVALID_EMAIL 385
00129 #define FBAPI_EC_USERS_REGISTER_EMAIL_DISABLED 386
00130 #define FBAPI_EC_USERS_REGISTER_ADD_USER_FAILED 387
00131 #define FBAPI_EC_USERS_REGISTER_NO_GENDER 388
00132
00133 #define FBAPI_EC_AUTH_EMAIL 400
00134 #define FBAPI_EC_AUTH_LOGIN 401
00135 #define FBAPI_EC_AUTH_SIG 402
00136 #define FBAPI_EC_AUTH_TIME 403
00137
00138 #define FBAPI_EC_SESSION_METHOD 451
00139 #define FBAPI_EC_SESSION_REQUIRED 453
00140 #define FBAPI_EC_SESSION_REQUIRED_FOR_SECRET 454
00141 #define FBAPI_EC_SESSION_CANNOT_USE_SESSION_SECRET 455
00142
00143 #define FBAPI_EC_MESG_BANNED 500
00144 #define FBAPI_EC_MESG_NO_BODY 501
00145 #define FBAPI_EC_MESG_TOO_LONG 502
00146 #define FBAPI_EC_MESG_RATE 503
00147 #define FBAPI_EC_MESG_INVALID_THREAD 504
00148 #define FBAPI_EC_MESG_INVALID_RECIP 505
00149 #define FBAPI_EC_POKE_INVALID_RECIP 510
00150 #define FBAPI_EC_POKE_OUTSTANDING 511
00151 #define FBAPI_EC_POKE_RATE 512
00152
00153 #define FQL_EC_UNKNOWN_ERROR 600
00154 #define FQL_EC_PARSER_ERROR 601
00155 #define FQL_EC_UNKNOWN_FIELD 602
00156 #define FQL_EC_UNKNOWN_TABLE 603
00157 #define FQL_EC_NO_INDEX 604
00158 #define FQL_EC_UNKNOWN_FUNCTION 605
00159 #define FQL_EC_INVALID_PARAM 606
00160 #define FQL_EC_INVALID_FIELD 607
00161 #define FQL_EC_INVALID_SESSION 608
00162
00163 #define FBAPI_EC_REF_SET_FAILED 700
00164 #define FBAPI_EC_FB_APP_UNKNOWN_ERROR 750
00165 #define FBAPI_EC_FB_APP_FETCH_FAILED 751
00166 #define FBAPI_EC_FB_APP_NO_DATA 752
00167 #define FBAPI_EC_FB_APP_NO_PERMISSIONS 753
00168 #define FBAPI_EC_FB_APP_TAG_MISSING 754
00169
00170 #define FBAPI_EC_DATA_UNKNOWN_ERROR 800
00171 #define FBAPI_EC_DATA_INVALID_OPERATION 801
00172 #define FBAPI_EC_DATA_QUOTA_EXCEEDED 802
00173 #define FBAPI_EC_DATA_OBJECT_NOT_FOUND 803
00174 #define FBAPI_EC_DATA_OBJECT_ALREADY_EXISTS 804
00175 #define FBAPI_EC_DATA_DATABASE_ERROR 805
00176 #define FBAPI_EC_DATA_CREATE_TEMPLATE_ERROR 806
00177 #define FBAPI_EC_DATA_TEMPLATE_EXISTS_ERROR 807
00178 #define FBAPI_EC_DATA_TEMPLATE_HANDLE_TOO_LONG 808
00179 #define FBAPI_EC_DATA_TEMPLATE_HANDLE_ALREADY_IN_USE 809
00180 #define FBAPI_EC_DATA_TOO_MANY_TEMPLATE_BUNDLES 810
00181 #define FBAPI_EC_DATA_MALFORMED_ACTION_LINK 811
00182 #define FBAPI_EC_DATA_TEMPLATE_USES_RESERVED_TOKEN 812
00183
00184 #define FBAPI_EC_NO_SUCH_APP 900
00185 #define FBAPI_BATCH_TOO_MANY_ITEMS 950
00186 #define FBAPI_EC_BATCH_ALREADY_STARTED 951
00187 #define FBAPI_EC_BATCH_NOT_STARTED 952
00188 #define FBAPI_EC_BATCH_METHOD_NOT_ALLOWED_IN_BATCH_MODE 953
00189
00190 #define FBAPI_EC_EVENT_INVALID_TIME 1000
00191 #define FBAPI_EC_INFO_NO_INFORMATION 1050
00192 #define FBAPI_EC_INFO_SET_FAILED 1051
00193
00194 #define FBAPI_EC_LIVEMESSAGE_SEND_FAILED 1100
00195 #define FBAPI_EC_LIVEMESSAGE_EVENT_NAME_TOO_LONG 1101
00196 #define FBAPI_EC_LIVEMESSAGE_MESSAGE_TOO_LONG 1102
00197
00198 #define FBAPI_EC_PAGES_CREATE 1201
00199
00201
00203 class FBError
00204 {
00205
00206 public:
00207     FBError(quint8 aErrorCode) : iErrorCode (aErrorCode) {}
00208     FBError() : iErrorCode(0) {}
00209
00210     inline quint8 code() const { return iErrorCode; }
00211     inline void setCode( quint8 aErrorCode ) { iErrorCode = aErrorCode; }
00212
00213     inline QString description() const { return iErrorDescription; }
00214     inline void setDescription( const QString& aErrorDescription ) { iErrorDescription = aErrorDescription; }
00215
00216 private:
00217     quint8 iErrorCode;
00218     QString iErrorDescription;
00219 };
00220
00221 #endif // FBERROR_H_
Generated on Thu Sep 23 15:03:07 2010 for smf by doxygen 1.6.3


smf: example/AuthApp/inc/keys.h Source File

  • File List

example/AuthApp/inc/keys.h

00001 /*
00002  * keys.h
00003  *
00004  *  Created on: Jul 16, 2010
00005  *      Author: satishkk
00006  */
00007
00008 #ifndef KEYS_H_
00009 #define KEYS_H_
00010
00011 static const QString kApiKey = "077fd6b8881f39c2dc23207323cca439";
00012 static const QString kApiSecret = "cb13436999afde9338ecd8b0bfb82508";
00013 static const QString kAppId = "118421274862377";
00014
00015 #endif /* KEYS_H_ */
Generated on Thu Sep 23 15:03:07 2010 for smf by doxygen 1.6.3


smf: example/AuthApp/inc/loginDialog.h Source File

  • File List

example/AuthApp/inc/loginDialog.h

00001
00019 #ifndef FB_LOGIN_DIALOG_H_
00020 #define FB_LOGIN_DIALOG_H_
00021
00022 #include "baseDialog.h"
00023 #include "requestSP.h"
00024 #include <QNetworkReply>
00025
00026 // FORWARD DECLARATIONS
00027 class FBRequest;
00028
00029 class FBLoginDialog : public FBDialog
00030 {
00031     Q_OBJECT
00032
00033 private:
00034     FBRequest* iGetSessionRequest;
00035
00036 private slots:
00037     /* slots for handling signals from FBRequest iGetSessionRequest */
00038     void requestDidLoad (const QVariant& aResult);
00039
00040     void requestFailedWithFacebookError ( const FBError& aError );
00041     void requestFailedWithNetworkError( QNetworkReply::NetworkError code );
00042
00043 public:
00044     FBLoginDialog(FBSession* aSession);
00045     FBLoginDialog();
00046
00047     void load();
00048
00049 protected:
00050     virtual void dialogWillDisappear();
00051     void GetSessionKey(const QUrl& aUrl);
00052     void FetchKeyFromUrl(const QUrl& aUrl);
00053 private:
00054     void connectToGetSession(const QString& aToken);
00055     void loadLoginPage();
00056
00057  };
00058 #endif
Generated on Thu Sep 23 15:03:07 2010 for smf by doxygen 1.6.3


smf: example/AuthApp/inc/requestSP.h Source File

  • File List

example/AuthApp/inc/requestSP.h

00001
00017 #ifndef FBREQUEST_H
00018 #define FBREQUEST_H
00019
00020 #include <QObject>
00021 #include <QString>
00022 #include <QDateTime>
00023 #include <QHttp>
00024 #include <QHash>
00025 #include <QNetworkAccessManager>
00026 #include <QNetworkReply>
00027 #include "progressbar.h"
00028 #include "authAppConstants.h"
00029 #include "xmlParser.h"
00030
00031 // FORWARD DECLARATIONS
00032 class FBSession;
00033 class FBError;
00034
00036 class  FBRequest : public QObject
00037 {
00038     Q_OBJECT
00039
00040 private:
00041
00042     /* pointer to the session that owns this request */
00043     FBSession*  iSession;
00044
00048     QString iUrl;
00049
00053     QString iMethod;
00054
00058     void*   iUserInfo;
00059
00066     Dictionary  iParams;
00067
00074     QByteArray  iDataParam;
00075
00079     bool        iDataParamPicture;
00080
00084     QDateTime   iTimestamp;
00085     QHttp       iConnection;
00086     QByteArray  iResponseText;
00087
00088     QNetworkAccessManager iNetworkAccessManager;
00089     progressbar* pbar;
00090
00091 signals: /* the signals ommitted by FBRequest */
00092
00096     void requestLoading();
00097
00101     //todo: void requestDidReceiveResponse (FBRequest* aRequest, NSURLResponse* aResponse);
00102
00106     void requestFailedWithNetworkError( QNetworkReply::NetworkError code );
00107     void requestFailedWithFacebookError ( const FBError& aError );
00108
00115     void requestDidLoad ( const QVariant& aResult);
00116
00120     void requestWasCancelled ();
00121
00122
00123 private slots:
00124     void networkReplyError ( QNetworkReply::NetworkError code );
00125     void networkReplyFinished ();
00126
00127 public: /* class functions */
00131     static FBRequest* request();
00132
00136     static FBRequest* requestWithSession (FBSession* aSession);
00137
00138 public: /* instance functions */
00139
00143     FBRequest (FBSession* aSession);
00144
00150     void call (const QString& aMethod, const Dictionary& aParams);
00151
00157     void callWithDataParams (const QString& aMethod, const Dictionary& aParams, const QByteArray& aDataParam, bool aDataParamPicture);
00158
00164     void post( const QString& aUrl, const Dictionary& aParams);
00165
00169     void cancel();
00170
00174     const QDateTime& timeStamp() const;
00175
00176     void connect();
00177
00178 private:
00182     static QString md5(const QString&);
00183
00187     bool isSpecialMethod() const;
00188
00192     QString urlForMethod (const QString& aMethod) const;
00193
00197     QString generateGetURL() const;
00198
00199     QString generateCallId() const;
00200     QString generateSig();
00201
00202     void generatePostBody(QByteArray& body);
00203
00208     void handleResponseData( const QByteArray& aResponseData );
00209
00215     QVariant parseXMLResponse ( const QByteArray& aResponseData, FBError& aError);
00216
00217 };
00218
00219 #endif // FBREQUEST_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/AuthApp/inc/sessionSP.h Source File

  • File List

example/AuthApp/inc/sessionSP.h

00001
00018 #ifndef FBSESSION_H
00019 #define FBSESSION_H
00020
00021 #include <QObject>
00022 #include <QList>
00023 #include <QString>
00024 #include <QSettings>
00025 #include <QDateTime>
00026 #include "smfcredmgrclient.h"
00027 #include "authAppConstants.h"
00028
00029 // FORWARD DECLARATIONS
00030 class FBRequest;
00031
00032 const QString KFacebokkKeysFileName = "c://Data//FacebookKeys.txt";
00033
00035
00047 class FBSession : public QObject
00048 {
00049     Q_OBJECT
00050
00051 private:
00055     QList<FBRequest*>           iRequestQueue;
00056
00060     QString iApiKey;
00061
00065     QString iApiSecret;
00066
00072     QString iGetSessionProxy;
00073
00077     QString iSessionKey;
00078
00082     QString iSessionSecret;
00083
00087     QDateTime iExpirationDate;
00088
00089
00094     QDateTime   iLastRequestTime;
00095     int         iRequestBurstCount;
00096
00097
00101     QSettings   iSettings;
00105     SmfCredMgrClient* m_Client;
00109     QString iCMRegToken;
00110
00111 signals: /* the signals ommitted by FBSession */
00112
00117     void sessionDidLogin (QString SessionKey);
00118
00122     void sessionDidNotLogin ();
00123
00128     void sessionWillLogout ();
00129
00133     void sessionDidLogout ();
00134
00135 private slots:
00139     void requestTimerReady();
00140
00141 public: /* class functions */
00142
00146     static FBSession* session();
00147
00154     static void setSession(FBSession* aSession);
00155
00161     static FBSession* sessionForApplication ( const QString& aKey, const QString& aSecret, const QString& aSessionProxy);
00162
00163 public: /* instance functions */
00164
00171     FBSession( const QString& aKey, const QString& aSecret, const QString& aSessionProxy );
00172
00176     ~FBSession();
00177
00181     void beginSession ( const QString& aSessionKey, const QString& aSessionSecret, const QDateTime& aExpires );
00182
00186      bool resume();
00187
00191     void cancelLogin();
00192
00196     void logout();
00197
00201     void send (FBRequest* aRequest);
00202
00206     const QString& apiURL() const;
00207
00211     const QString& apiSecureURL() const;
00212
00217     bool isConnected() const;
00218
00222     const QString& apiSecret() const { return iApiSecret; }
00223
00227     const QString& getSessionProxy() const { return iGetSessionProxy; }
00228
00232     const QString& apiKey() const { return iApiKey; }
00233
00237     const QString& sessionSecret() const { return iSessionSecret; }
00238
00242     const QString& sessionKey() const { return iSessionKey; }
00243
00244 private:
00245
00249     void save();
00253     void unsave();
00254
00255     void startFlushTimer();
00256
00260     void enqueueRequest(FBRequest* aRequest);
00261
00266     bool performRequest(FBRequest* aRequest, bool aEnqueue);
00267
00272     void flushRequestQueue();
00273
00274 };
00275
00276 #endif // FBSESSION_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/AuthApp/inc/xmlParser.h Source File

  • File List

example/AuthApp/inc/xmlParser.h

00001
00018 #ifndef FB_XML_HANDLER_H
00019 #define FB_XML_HANDLER_H
00020
00021 #include <QObject>
00022 #include <QString>
00023 #include <QXmlDefaultHandler>
00024 #include <QVariantList>
00025
00026 #include "authAppConstants.h"
00027
00028 // FORWARD DECLARATIONS
00029 class FBRequest;
00030
00032 class FBXMLHandler : public QObject, public QXmlDefaultHandler
00033 {
00034     Q_OBJECT
00035
00036 private:
00037     QVariantList        iStack;
00038     QList<QString>      iNameStack;
00039     QVariant            iRootObject;
00040     QString             iRootName;
00041     QString             iChars;
00042
00043     QString         iParseErrorMessage;
00044     bool            iError;
00045
00046 public: /* class functions */
00047
00048     FBXMLHandler();
00049     ~FBXMLHandler();
00050
00051     inline const QString& rootName() const { return iRootName; }
00052     inline QVariant rootObject() const { return iRootObject; }
00053
00054     inline bool parseError() const { return iError; }
00055
00056 private:
00057     /* methods from QXmlDefaultHandler */
00058     bool startElement( const QString & namespaceURI,
00059                        const QString & localName,
00060                        const QString & qName,
00061                        const QXmlAttributes & atts);
00062     bool characters(const QString& text);
00063     bool endElement( const QString & namespaceURI,
00064                      const QString & localName,
00065                      const QString & qName );
00066
00067     /* methods from QXmlErrorHandler */
00068     bool error(const QXmlParseException& exception);
00069     bool fatalError(const QXmlParseException& exception);
00070
00071     /* private functions*/
00072     const QString& topName() const;
00073     void flushCharacters();
00074     QVariant topObject(bool aCreate);
00075
00076     QVariant topContainer();
00077
00078
00079     void initWhiteSpaceHash();
00080     QHash<QChar, bool> iWhiteSpaceAndNewLineCharSet;
00081
00082 };
00083
00084 #endif // FB_XML_HANDLER_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/AuthApp/progressbar.h Source File

  • File List

example/AuthApp/progressbar.h

00001 #ifndef PROGRESSBAR_H
00002 #define PROGRESSBAR_H
00003
00004 #include <QtGui/QWidget>
00005 #include "ui_progressbar.h"
00006
00007 class progressbar : public QWidget
00008 {
00009     Q_OBJECT
00010
00011 public:
00012     progressbar(QWidget *parent = 0);
00013     ~progressbar();
00014
00015 private:
00016     Ui::progressbarClass ui;
00017 };
00018
00019 #endif // PROGRESSBAR_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/AuthApp/ui_AuthApp.h Source File

  • File List

example/AuthApp/ui_AuthApp.h

00001 /********************************************************************************
00002 ** Form generated from reading UI file 'AuthApp.ui'
00003 **
00004 ** Created: Wed Sep 22 18:28:00 2010
00005 **      by: Qt User Interface Compiler version 4.6.2
00006 **
00007 ** WARNING! All changes made in this file will be lost when recompiling UI file!
00008 ********************************************************************************/
00009
00010 #ifndef UI_AUTHAPP_H
00011 #define UI_AUTHAPP_H
00012
00013 #include <QtCore/QVariant>
00014 #include <QtGui/QAction>
00015 #include <QtGui/QApplication>
00016 #include <QtGui/QButtonGroup>
00017 #include <QtGui/QHeaderView>
00018 #include <QtGui/QMainWindow>
00019 #include <QtGui/QPushButton>
00020 #include <QtGui/QSpacerItem>
00021 #include <QtGui/QVBoxLayout>
00022 #include <QtGui/QWidget>
00023
00024 QT_BEGIN_NAMESPACE
00025
00026 class Ui_AuthAppClass
00027 {
00028 public:
00029     QWidget *centralWidget;
00030     QVBoxLayout *verticalLayout;
00031     QPushButton *buttonForget;
00032     QPushButton *pushButton;
00033     QSpacerItem *verticalSpacer;
00034
00035     void setupUi(QMainWindow *AuthAppClass)
00036     {
00037         if (AuthAppClass->objectName().isEmpty())
00038             AuthAppClass->setObjectName(QString::fromUtf8("AuthAppClass"));
00039         AuthAppClass->resize(275, 310);
00040         centralWidget = new QWidget(AuthAppClass);
00041         centralWidget->setObjectName(QString::fromUtf8("centralWidget"));
00042         verticalLayout = new QVBoxLayout(centralWidget);
00043         verticalLayout->setSpacing(6);
00044         verticalLayout->setContentsMargins(11, 11, 11, 11);
00045         verticalLayout->setObjectName(QString::fromUtf8("verticalLayout"));
00046         buttonForget = new QPushButton(centralWidget);
00047         buttonForget->setObjectName(QString::fromUtf8("buttonForget"));
00048
00049         verticalLayout->addWidget(buttonForget);
00050
00051         pushButton = new QPushButton(centralWidget);
00052         pushButton->setObjectName(QString::fromUtf8("pushButton"));
00053
00054         verticalLayout->addWidget(pushButton);
00055
00056         verticalSpacer = new QSpacerItem(20, 40, QSizePolicy::Minimum, QSizePolicy::Expanding);
00057
00058         verticalLayout->addItem(verticalSpacer);
00059
00060         AuthAppClass->setCentralWidget(centralWidget);
00061
00062         retranslateUi(AuthAppClass);
00063
00064         QMetaObject::connectSlotsByName(AuthAppClass);
00065     } // setupUi
00066
00067     void retranslateUi(QMainWindow *AuthAppClass)
00068     {
00069         AuthAppClass->setWindowTitle(QApplication::translate("AuthAppClass", "MainWindow", 0, QApplication::UnicodeUTF8));
00070         buttonForget->setText(QApplication::translate("AuthAppClass", "Logout", 0, QApplication::UnicodeUTF8));
00071         pushButton->setText(QApplication::translate("AuthAppClass", "Login to facebook", 0, QApplication::UnicodeUTF8));
00072     } // retranslateUi
00073
00074 };
00075
00076 namespace Ui {
00077     class AuthAppClass: public Ui_AuthAppClass {};
00078 } // namespace Ui
00079
00080 QT_END_NAMESPACE
00081
00082 #endif // UI_AUTHAPP_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/AuthApp/ui_progressbar.h Source File

  • File List

example/AuthApp/ui_progressbar.h

00001 /********************************************************************************
00002 ** Form generated from reading UI file 'progressbar.ui'
00003 **
00004 ** Created: Wed Sep 22 18:27:56 2010
00005 **      by: Qt User Interface Compiler version 4.6.2
00006 **
00007 ** WARNING! All changes made in this file will be lost when recompiling UI file!
00008 ********************************************************************************/
00009
00010 #ifndef UI_PROGRESSBAR_H
00011 #define UI_PROGRESSBAR_H
00012
00013 #include <QtCore/QVariant>
00014 #include <QtGui/QAction>
00015 #include <QtGui/QApplication>
00016 #include <QtGui/QButtonGroup>
00017 #include <QtGui/QHeaderView>
00018 #include <QtGui/QLabel>
00019 #include <QtGui/QProgressBar>
00020 #include <QtGui/QVBoxLayout>
00021 #include <QtGui/QWidget>
00022
00023 QT_BEGIN_NAMESPACE
00024
00025 class Ui_progressbarClass
00026 {
00027 public:
00028     QVBoxLayout *verticalLayout;
00029     QLabel *label;
00030     QProgressBar *progressBar;
00031
00032     void setupUi(QWidget *progressbarClass)
00033     {
00034         if (progressbarClass->objectName().isEmpty())
00035             progressbarClass->setObjectName(QString::fromUtf8("progressbarClass"));
00036         verticalLayout = new QVBoxLayout(progressbarClass);
00037         verticalLayout->setSpacing(6);
00038         verticalLayout->setContentsMargins(11, 11, 11, 11);
00039         verticalLayout->setObjectName(QString::fromUtf8("verticalLayout"));
00040         label = new QLabel(progressbarClass);
00041         label->setObjectName(QString::fromUtf8("label"));
00042
00043         verticalLayout->addWidget(label);
00044
00045         progressBar = new QProgressBar(progressbarClass);
00046         progressBar->setObjectName(QString::fromUtf8("progressBar"));
00047         progressBar->setValue(24);
00048
00049         verticalLayout->addWidget(progressBar);
00050
00051
00052         retranslateUi(progressbarClass);
00053
00054         QMetaObject::connectSlotsByName(progressbarClass);
00055     } // setupUi
00056
00057     void retranslateUi(QWidget *progressbarClass)
00058     {
00059         progressbarClass->setWindowTitle(QApplication::translate("progressbarClass", "progressbar", 0, QApplication::UnicodeUTF8));
00060         label->setText(QApplication::translate("progressbarClass", "<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.0//EN\" \"http://www.w3.org/TR/REC-html40/strict.dtd\">\n"
00061 "<html><head><meta name=\"qrichtext\" content=\"1\" /><style type=\"text/css\">\n"
00062 "p, li { white-space: pre-wrap; }\n"
00063 "</style></head><body style=\" font-family:'MS Shell Dlg 2'; font-size:8.25pt; font-weight:400; font-style:normal;\">\n"
00064 "<p style=\" margin-top:0px; margin-bottom:0px; margin-left:0px; margin-right:0px; -qt-block-indent:0; text-indent:0px;\"><span style=\" font-size:10pt;\">Loading,Please wait.....</span></p></body></html>", 0, QApplication::UnicodeUTF8));
00065     } // retranslateUi
00066
00067 };
00068
00069 namespace Ui {
00070     class progressbarClass: public Ui_progressbarClass {};
00071 } // namespace Ui
00072
00073 QT_END_NAMESPACE
00074
00075 #endif // UI_PROGRESSBAR_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/DemoGUI/CustomListWidget.h Source File

  • File List

example/DemoGUI/CustomListWidget.h

00001 #ifndef CUSTOMLISTWIDGET_H
00002 #define CUSTOMLISTWIDGET_H
00003
00004 #include <qlistwidget.h>
00005 #include <smfcontact.h>
00006 #include <smfpost.h>
00007 #include <smfactions.h>
00008 #include "qmainwindow.h"
00009
00010 class CustomListWidget : public QListWidget
00011 {
00012 public:
00013     CustomListWidget();
00014     //QWidget* CreateListwidget(QStrng aIconPath,QString aFirstLine,QString aSecondLine);
00015     QWidget* CreateListwidget(SmfContactList* friendsList);
00016     QWidget* CreateListwidget(SmfPostList *postsList);
00017     QWidget* CreateListwidget(SmfActivityEntryList *activityList);
00018     void AddListItem(QString aIconPath,QString aFirstLine,QString aSecondLine);
00019     void AddListItem(QMainWindow *mainWindow,QStringList aIconPath, QStringList iconName);
00020     ~CustomListWidget();
00021
00022 };
00023
00024
00025 #endif // CUSTOMLISTWIDGET_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/FlickrAuthApp/AuthApp.h Source File

  • File List

example/FlickrAuthApp/AuthApp.h

00001
00018 #ifndef AUTHAPP_H
00019 #define AUTHAPP_H
00020
00021 #include <QtGui/QMainWindow>
00022 #include "ui_AuthApp.h"
00023 #include "errorCodes.h"
00024 #include "loginDialog.h"
00025 #include "sessionSP.h"
00026
00027 class AuthApp : public QMainWindow
00028 {
00029     Q_OBJECT
00030
00031 public:
00032         AuthApp(QWidget *parent = 0);
00033     ~AuthApp();
00034 private:
00035         void CheckforLogin();
00036 private slots:
00037     void on_buttonForget_clicked();
00038     void on_pushButton_clicked();
00039
00040     void sessionDidLogin(QString sessionkey);
00041     void sessionDidLogout();
00042
00043     void requestFailedWithFacebookError ( const FBError& aError );
00044
00045 protected:
00046     void changeEvent(QEvent *e);
00047
00048 private:
00049     FBSession*      iFBSession;
00050     FBLoginDialog*  iLoginDialog;
00051     Ui::AuthAppClass *ui;
00052 };
00053
00054 #endif // AUTHAPP_H
Generated on Thu Sep 23 15:03:07 2010 for smf by doxygen 1.6.3


smf: example/FlickrAuthApp/inc/authAppConstants.h Source File

  • File List

example/FlickrAuthApp/inc/authAppConstants.h

00001
00018 #ifndef FBCONNECTGLOBAL_H
00019 #define FBCONNECTGLOBAL_H
00020
00021 #include <QtGlobal>
00022 #include <QHash>
00023 #include <QString>
00024
00025 typedef QHash<QString,QString> Dictionary;
00026 typedef QHashIterator<QString, QString> DictionaryIterator;
00027
00028
00029
00030 #endif // FBCONNECTGLOBAL_H
Generated on Thu Sep 23 15:03:07 2010 for smf by doxygen 1.6.3


smf: example/FlickrAuthApp/inc/baseDialog.h Source File

  • File List

example/FlickrAuthApp/inc/baseDialog.h

00001
00018 #ifndef FB_DIALOG_H_
00019 #define FB_DIALOH_H_
00020
00021 #include <QDialog>
00022 #include <QWebView>
00023 #include <qprogressbar.h>
00024 #include <qboxlayout.h>
00025 #include "authAppConstants.h"
00026
00027 // FORWARD DECLARATIONS
00028 class FBSession;
00029 class FBError;
00030 class QNetworkReply;
00031
00032 //#define __WINSCW__
00033
00037 class FBDialog : public QWidget
00038 {
00039     Q_OBJECT
00040
00041 protected:
00042
00046     FBSession*  iSession;
00047     QWebView*   iWebView;
00048     QString     iLoadingUrl;
00049     bool        iIgnorePageLoadCompleteEvent;
00050     QProgressBar* progressbar;
00051     QVBoxLayout* layout;
00052
00053 signals:
00054
00058     void dialogDidSucceed ();
00059
00063     void dialogDidCancel();
00064
00068     void dialogDidFailWithError ( const FBError& error );
00069
00070
00071
00072 private slots:
00073     void cancel();
00074
00075     /* slots for signals from QWebView.page() */
00076     void linkClicked ( const QUrl & url );
00077     void loadStarted ();
00078     void loadProgress(int progress);
00079     void loadFinished ( bool ok );
00080     //void urlChanged ( const QUrl & url );
00081     //Network Error Slots
00082     void slotAuthenticationRequired( QNetworkReply* reply, QAuthenticator* authenticator );
00083     void slotsslErrors( QNetworkReply* reply, const QList<QSslError>& errors  );
00084     void slotproxyAuthenticationRequired( const QNetworkProxy& proxy, QAuthenticator* authenticator  );
00085
00086 public:
00087
00088         void proxysettings();
00092     FBDialog(FBSession* aSession);
00093     FBDialog();
00094
00100     void show();
00101
00106     virtual void load ();
00107
00111     void loadURL(const QString& aUrl, QNetworkAccessManager::Operation aMethod, const QHash<QString, QString>& aGetParams,
00112                  const QHash<QString, QString>&  aPostParams);
00113
00114
00115     void dismiss(bool aAnimated);
00116
00120     void dismissWithSuccess (bool aSuccess, bool aAnimated);
00121
00125     void dismissWithError (const FBError& aError);
00126
00130     virtual void dialogWillAppear();
00131
00135     virtual void dialogWillDisappear();
00136
00142     virtual void dialogDidSucceed(const QUrl& aUrl);
00143
00144     QString title() const;
00145     void setTitle ( const QString& aTitle );
00146
00147     virtual void GetSessionKey(const QUrl& aUrl);
00148
00149     virtual void connectToGetFullToken();
00150
00151 private:
00152     void createControls();
00153     QString generateURL( const QString& aUrl, const QHash<QString, QString>& aParams) const;
00154     QByteArray generatePostBody (const QHash<QString, QString>& aParams) const;
00155
00156     void postDismissCleanup();
00157
00158  };
00159 #endif
Generated on Thu Sep 23 15:03:07 2010 for smf by doxygen 1.6.3


smf: example/FlickrAuthApp/inc/errorCodes.h Source File

  • File List

example/FlickrAuthApp/inc/errorCodes.h

00001
00018 #ifndef FBERROR_H_
00019 #define FBERROR_H_
00020
00021
00022 #include "authAppConstants.h"
00023
00025 // Error codes
00026 /* defined by this proj*/
00027 #define FBRESPONSE_PARSE_ERROR 13  /* the xml parser was unable to parse the response returned by the server */
00028
00029 /* defined and returned by facebook */
00030 #define FBAPI_EC_SUCCESS 0
00031 #define FBAPI_EC_UNKNOWN 1
00032 #define FBAPI_EC_SERVICE 2
00033 #define FBAPI_EC_METHOD 3
00034 #define FBAPI_EC_TOO_MANY_CALLS 4
00035 #define FBAPI_EC_BAD_IP 5
00036 #define FBAPI_EC_HOST_API 6
00037 #define FBAPI_EC_HOST_UP 7
00038 #define FBAPI_EC_SECURE 8
00039 #define FBAPI_EC_RATE 9
00040 #define FBAPI_EC_PERMISSION_DENIED 10
00041 #define FBAPI_EC_DEPRECATED 11
00042 #define FBAPI_EC_VERSION 12
00043
00044 #define FBAPI_EC_PARAM 100
00045 #define FBAPI_EC_PARAM_FBAPI_KEY 101
00046 #define FBAPI_EC_PARAM_SESSION_KEY 102
00047 #define FBAPI_EC_PARAM_CALL_ID 103
00048 #define FBAPI_EC_PARAM_SIGNATURE 104
00049 #define FBAPI_EC_PARAM_TOO_MANY 105
00050 #define FBAPI_EC_PARAM_USER_ID 110
00051 #define FBAPI_EC_PARAM_USER_FIELD 111
00052 #define FBAPI_EC_PARAM_SOCIAL_FIELD 112
00053 #define FBAPI_EC_PARAM_EMAIL 113
00054 #define FBAPI_EC_PARAM_ALBUM_ID 120
00055 #define FBAPI_EC_PARAM_PHOTO_ID 121
00056 #define FBAPI_EC_PARAM_FEED_PRIORITY 130
00057 #define FBAPI_EC_PARAM_CATEGORY 140
00058 #define FBAPI_EC_PARAM_SUBCATEGORY 141
00059 #define FBAPI_EC_PARAM_TITLE 142
00060 #define FBAPI_EC_PARAM_DESCRIPTION 143
00061 #define FBAPI_EC_PARAM_BAD_JSON 144
00062 #define FBAPI_EC_PARAM_BAD_EID 150
00063 #define FBAPI_EC_PARAM_UNKNOWN_CITY 151
00064 #define FBAPI_EC_PARAM_BAD_PAGE_TYPE 152
00065
00066 #define FBAPI_EC_PERMISSION 200
00067 #define FBAPI_EC_PERMISSION_USER 210
00068 #define FBAPI_EC_PERMISSION_ALBUM 220
00069 #define FBAPI_EC_PERMISSION_PHOTO 221
00070 #define FBAPI_EC_PERMISSION_MESSAGE 230
00071 #define FBAPI_EC_PERMISSION_MARKUP_OTHER_USER 240
00072 #define FBAPI_EC_PERMISSION_STATUS_UPDATE 250
00073 #define FBAPI_EC_PERMISSION_PHOTO_UPLOAD 260
00074 #define FBAPI_EC_PERMISSION_SMS 270
00075 #define FBAPI_EC_PERMISSION_CREATE_LISTING 280
00076 #define FBAPI_EC_PERMISSION_EVENT 290
00077 #define FBAPI_EC_PERMISSION_LARGE_FBML_TEMPLATE 291
00078 #define FBAPI_EC_PERMISSION_LIVEMESSAGE 292
00079 #define FBAPI_EC_PERMISSION_RSVP_EVENT 299
00080
00081 #define FBAPI_EC_EDIT 300
00082 #define FBAPI_EC_EDIT_USER_DATA 310
00083 #define FBAPI_EC_EDIT_PHOTO 320
00084 #define FBAPI_EC_EDIT_ALBUM_SIZE 321
00085 #define FBAPI_EC_EDIT_PHOTO_TAG_SUBJECT 322
00086 #define FBAPI_EC_EDIT_PHOTO_TAG_PHOTO 323
00087 #define FBAPI_EC_EDIT_PHOTO_FILE 324
00088 #define FBAPI_EC_EDIT_PHOTO_PENDING_LIMIT 325
00089 #define FBAPI_EC_EDIT_PHOTO_TAG_LIMIT 326
00090 #define FBAPI_EC_EDIT_ALBUM_REORDER_PHOTO_NOT_IN_ALBUM 327
00091 #define FBAPI_EC_EDIT_ALBUM_REORDER_TOO_FEW_PHOTOS 328
00092 #define FBAPI_EC_MALFORMED_MARKUP 329
00093 #define FBAPI_EC_EDIT_MARKUP 330
00094 #define FBAPI_EC_EDIT_FEED_TOO_MANY_USER_CALLS 340
00095 #define FBAPI_EC_EDIT_FEED_TOO_MANY_USER_ACTION_CALLS 341
00096 #define FBAPI_EC_EDIT_FEED_TITLE_LINK 342
00097 #define FBAPI_EC_EDIT_FEED_TITLE_LENGTH 343
00098 #define FBAPI_EC_EDIT_FEED_TITLE_NAME 344
00099 #define FBAPI_EC_EDIT_FEED_TITLE_BLANK 345
00100 #define FBAPI_EC_EDIT_FEED_BODY_LENGTH 346
00101 #define FBAPI_EC_EDIT_FEED_PHOTO_SRC 347
00102 #define FBAPI_EC_EDIT_FEED_PHOTO_LINK 348
00103 #define FBAPI_EC_EDIT_VIDEO_SIZE 350
00104 #define FBAPI_EC_EDIT_VIDEO_INVALID_FILE 351
00105 #define FBAPI_EC_EDIT_VIDEO_INVALID_TYPE 352
00106 #define FBAPI_EC_EDIT_FEED_TITLE_ARRAY 360
00107 #define FBAPI_EC_EDIT_FEED_TITLE_PARAMS 361
00108 #define FBAPI_EC_EDIT_FEED_BODY_ARRAY 362
00109 #define FBAPI_EC_EDIT_FEED_BODY_PARAMS 363
00110 #define FBAPI_EC_EDIT_FEED_PHOTO 364
00111 #define FBAPI_EC_EDIT_FEED_TEMPLATE 365
00112 #define FBAPI_EC_EDIT_FEED_TARGET 366
00113 #define FBAPI_EC_USERS_CREATE_INVALID_EMAIL 370
00114 #define FBAPI_EC_USERS_CREATE_EXISTING_EMAIL 371
00115 #define FBAPI_EC_USERS_CREATE_BIRTHDAY 372
00116 #define FBAPI_EC_USERS_CREATE_PASSWORD 373
00117 #define FBAPI_EC_USERS_REGISTER_INVALID_CREDENTIAL 374
00118 #define FBAPI_EC_USERS_REGISTER_CONF_FAILURE 375
00119 #define FBAPI_EC_USERS_REGISTER_EXISTING 376
00120 #define FBAPI_EC_USERS_REGISTER_DEFAULT_ERROR 377
00121 #define FBAPI_EC_USERS_REGISTER_PASSWORD_BLANK 378
00122 #define FBAPI_EC_USERS_REGISTER_PASSWORD_INVALID_CHARS 379
00123 #define FBAPI_EC_USERS_REGISTER_PASSWORD_SHORT 380
00124 #define FBAPI_EC_USERS_REGISTER_PASSWORD_WEAK 381
00125 #define FBAPI_EC_USERS_REGISTER_USERNAME_ERROR 382
00126 #define FBAPI_EC_USERS_REGISTER_MISSING_INPUT 383
00127 #define FBAPI_EC_USERS_REGISTER_INCOMPLETE_BDAY 384
00128 #define FBAPI_EC_USERS_REGISTER_INVALID_EMAIL 385
00129 #define FBAPI_EC_USERS_REGISTER_EMAIL_DISABLED 386
00130 #define FBAPI_EC_USERS_REGISTER_ADD_USER_FAILED 387
00131 #define FBAPI_EC_USERS_REGISTER_NO_GENDER 388
00132
00133 #define FBAPI_EC_AUTH_EMAIL 400
00134 #define FBAPI_EC_AUTH_LOGIN 401
00135 #define FBAPI_EC_AUTH_SIG 402
00136 #define FBAPI_EC_AUTH_TIME 403
00137
00138 #define FBAPI_EC_SESSION_METHOD 451
00139 #define FBAPI_EC_SESSION_REQUIRED 453
00140 #define FBAPI_EC_SESSION_REQUIRED_FOR_SECRET 454
00141 #define FBAPI_EC_SESSION_CANNOT_USE_SESSION_SECRET 455
00142
00143 #define FBAPI_EC_MESG_BANNED 500
00144 #define FBAPI_EC_MESG_NO_BODY 501
00145 #define FBAPI_EC_MESG_TOO_LONG 502
00146 #define FBAPI_EC_MESG_RATE 503
00147 #define FBAPI_EC_MESG_INVALID_THREAD 504
00148 #define FBAPI_EC_MESG_INVALID_RECIP 505
00149 #define FBAPI_EC_POKE_INVALID_RECIP 510
00150 #define FBAPI_EC_POKE_OUTSTANDING 511
00151 #define FBAPI_EC_POKE_RATE 512
00152
00153 #define FQL_EC_UNKNOWN_ERROR 600
00154 #define FQL_EC_PARSER_ERROR 601
00155 #define FQL_EC_UNKNOWN_FIELD 602
00156 #define FQL_EC_UNKNOWN_TABLE 603
00157 #define FQL_EC_NO_INDEX 604
00158 #define FQL_EC_UNKNOWN_FUNCTION 605
00159 #define FQL_EC_INVALID_PARAM 606
00160 #define FQL_EC_INVALID_FIELD 607
00161 #define FQL_EC_INVALID_SESSION 608
00162
00163 #define FBAPI_EC_REF_SET_FAILED 700
00164 #define FBAPI_EC_FB_APP_UNKNOWN_ERROR 750
00165 #define FBAPI_EC_FB_APP_FETCH_FAILED 751
00166 #define FBAPI_EC_FB_APP_NO_DATA 752
00167 #define FBAPI_EC_FB_APP_NO_PERMISSIONS 753
00168 #define FBAPI_EC_FB_APP_TAG_MISSING 754
00169
00170 #define FBAPI_EC_DATA_UNKNOWN_ERROR 800
00171 #define FBAPI_EC_DATA_INVALID_OPERATION 801
00172 #define FBAPI_EC_DATA_QUOTA_EXCEEDED 802
00173 #define FBAPI_EC_DATA_OBJECT_NOT_FOUND 803
00174 #define FBAPI_EC_DATA_OBJECT_ALREADY_EXISTS 804
00175 #define FBAPI_EC_DATA_DATABASE_ERROR 805
00176 #define FBAPI_EC_DATA_CREATE_TEMPLATE_ERROR 806
00177 #define FBAPI_EC_DATA_TEMPLATE_EXISTS_ERROR 807
00178 #define FBAPI_EC_DATA_TEMPLATE_HANDLE_TOO_LONG 808
00179 #define FBAPI_EC_DATA_TEMPLATE_HANDLE_ALREADY_IN_USE 809
00180 #define FBAPI_EC_DATA_TOO_MANY_TEMPLATE_BUNDLES 810
00181 #define FBAPI_EC_DATA_MALFORMED_ACTION_LINK 811
00182 #define FBAPI_EC_DATA_TEMPLATE_USES_RESERVED_TOKEN 812
00183
00184 #define FBAPI_EC_NO_SUCH_APP 900
00185 #define FBAPI_BATCH_TOO_MANY_ITEMS 950
00186 #define FBAPI_EC_BATCH_ALREADY_STARTED 951
00187 #define FBAPI_EC_BATCH_NOT_STARTED 952
00188 #define FBAPI_EC_BATCH_METHOD_NOT_ALLOWED_IN_BATCH_MODE 953
00189
00190 #define FBAPI_EC_EVENT_INVALID_TIME 1000
00191 #define FBAPI_EC_INFO_NO_INFORMATION 1050
00192 #define FBAPI_EC_INFO_SET_FAILED 1051
00193
00194 #define FBAPI_EC_LIVEMESSAGE_SEND_FAILED 1100
00195 #define FBAPI_EC_LIVEMESSAGE_EVENT_NAME_TOO_LONG 1101
00196 #define FBAPI_EC_LIVEMESSAGE_MESSAGE_TOO_LONG 1102
00197
00198 #define FBAPI_EC_PAGES_CREATE 1201
00199
00201
00203 class FBError
00204 {
00205
00206 public:
00207     FBError(quint8 aErrorCode) : iErrorCode (aErrorCode) {}
00208     FBError() : iErrorCode(0) {}
00209
00210     inline quint8 code() const { return iErrorCode; }
00211     inline void setCode( quint8 aErrorCode ) { iErrorCode = aErrorCode; }
00212
00213     inline QString description() const { return iErrorDescription; }
00214     inline void setDescription( const QString& aErrorDescription ) { iErrorDescription = aErrorDescription; }
00215
00216 private:
00217     quint8 iErrorCode;
00218     QString iErrorDescription;
00219 };
00220
00221 #endif // FBERROR_H_
Generated on Thu Sep 23 15:03:07 2010 for smf by doxygen 1.6.3


smf: example/FlickrAuthApp/inc/keys.h Source File

  • File List

example/FlickrAuthApp/inc/keys.h

00001 /*
00002  * keys.h
00003  *
00004  *  Created on: Jul 16, 2010
00005  *      Author: satishkk
00006  */
00007
00008 #ifndef KEYS_H_
00009 #define KEYS_H_
00010
00011 static const QString kApiKey = "2835574777f7421bc0d058f5a1ad5a56";
00012 static const QString kApiSecret = "f902dad777efa173";
00013
00014 #endif /* KEYS_H_ */
Generated on Thu Sep 23 15:03:07 2010 for smf by doxygen 1.6.3


smf: example/FlickrAuthApp/inc/loginDialog.h Source File

  • File List

example/FlickrAuthApp/inc/loginDialog.h

00001
00019 #ifndef FB_LOGIN_DIALOG_H_
00020 #define FB_LOGIN_DIALOG_H_
00021
00022 #include "baseDialog.h"
00023 #include "requestSP.h"
00024 #include <QNetworkReply>
00025
00026 // FORWARD DECLARATIONS
00027 class FBRequest;
00028
00029 class FBLoginDialog : public FBDialog
00030 {
00031     Q_OBJECT
00032
00033 private:
00034     FBRequest* iGetSessionRequest;
00035
00036 private slots:
00037     /* slots for handling signals from FBRequest iGetSessionRequest */
00038     void requestDidLoad (const QVariant& aResult);
00039
00040     void requestFailedWithFlickrError ( const FBError& aError );
00041     void requestFailedWithNetworkError( QNetworkReply::NetworkError code );
00042
00043 public:
00044     FBLoginDialog(FBSession* aSession);
00045     FBLoginDialog();
00046     void connecttoGetFrob();
00047     void load();
00048
00049 private:
00050     void connectToGetFullToken();
00051
00052     void loadLoginPage();
00053
00054  };
00055 #endif
Generated on Thu Sep 23 15:03:07 2010 for smf by doxygen 1.6.3


smf: example/FlickrAuthApp/inc/requestSP.h Source File

  • File List

example/FlickrAuthApp/inc/requestSP.h

00001
00017 #ifndef FBREQUEST_H
00018 #define FBREQUEST_H
00019
00020 #include <QObject>
00021 #include <QString>
00022 #include <QDateTime>
00023 #include <QHttp>
00024 #include <QHash>
00025 #include <QNetworkAccessManager>
00026 #include <QNetworkReply>
00027 #include "progressbar.h"
00028 #include "authAppConstants.h"
00029 #include "xmlParser.h"
00030
00031 // FORWARD DECLARATIONS
00032 class FBSession;
00033 class FBError;
00034
00036 class  FBRequest : public QObject
00037 {
00038     Q_OBJECT
00039
00040 private:
00041
00042     /* pointer to the session that owns this request */
00043     FBSession*  iSession;
00044
00048     QString iUrl;
00049
00053     QString iMethod;
00054
00058     void*   iUserInfo;
00059
00066     Dictionary  iParams;
00067
00074     QByteArray  iDataParam;
00075
00079     bool        iDataParamPicture;
00080
00084     QDateTime   iTimestamp;
00085     QHttp       iConnection;
00086     QByteArray  iResponseText;
00087
00088     QNetworkAccessManager iNetworkAccessManager;
00089     progressbar* pbar;
00090
00091 signals: /* the signals ommitted by FBRequest */
00092
00096     void requestLoading();
00097
00101     void requestFailedWithNetworkError( QNetworkReply::NetworkError code );
00102     void requestFailedWithFlickrError ( const FBError& aError );
00103
00110     void requestDidLoad ( const QVariant& aResult);
00111
00112
00113
00114 private slots:
00115     void networkReplyError ( QNetworkReply::NetworkError code );
00116     void networkReplyFinished ();
00117
00118 public: /* class functions */
00122     static FBRequest* request();
00123
00127     static FBRequest* requestWithSession (FBSession* aSession);
00128
00129 public: /* instance functions */
00130
00134     FBRequest (FBSession* aSession);
00135
00141     void call (const QString& aMethod, const Dictionary& aParams);
00142
00143     void callforToken ();
00144
00150     void callWithDataParams (const QString& aMethod, const Dictionary& aParams, const QByteArray& aDataParam, bool aDataParamPicture);
00151
00157     void post( const QString& aUrl, const Dictionary& aParams);
00158
00162     void cancel();
00163
00167     const QDateTime& timeStamp() const;
00168
00169     void connect();
00170
00171     QString generateSig(Dictionary Params);
00172
00173     void proxysettings();
00174
00175 private:
00179     static QString md5(const QString&);
00180
00184     bool isSpecialMethod() const;
00185
00189     QString urlForMethod (const QString& aMethod) const;
00190
00194     QString generateGetURL() const;
00195
00196     QString generateCallId() const;
00197
00198
00199     void generatePostBody(QByteArray& body);
00200
00205     void handleResponseData( const QByteArray& aResponseData );
00206
00212     QVariant parseXMLResponse ( const QByteArray& aResponseData, FBError& aError);
00213
00214 };
00215
00216 #endif // FBREQUEST_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/FlickrAuthApp/inc/sessionSP.h Source File

  • File List

example/FlickrAuthApp/inc/sessionSP.h

00001
00018 #ifndef FBSESSION_H
00019 #define FBSESSION_H
00020
00021 #include <QObject>
00022 #include <QList>
00023 #include <QString>
00024 #include <QSettings>
00025 #include <QDateTime>
00026 #include "smfcredmgrclient.h"
00027 #include "authAppConstants.h"
00028
00029 // FORWARD DECLARATIONS
00030 class FBRequest;
00031
00032 const QString KFacebokkKeysFileName = "c://Data//FacebookKeys.txt";
00033
00035
00047 class FBSession : public QObject
00048 {
00049     Q_OBJECT
00050
00051 private:
00055     QString iApiKey;
00056
00060     QString iApiSecret;
00061
00065         QString iFrobKey;
00066
00070         QString iToken;
00071
00075     QSettings   iSettings;
00079     SmfCredMgrClient* m_Client;
00083     QString iCMRegToken;
00084
00085 signals: /* the signals ommitted by FBSession */
00086
00091     void sessionDidLogin (QString SessionKey);
00092
00096     void sessionDidNotLogin ();
00097
00102     void sessionWillLogout ();
00103
00107     void sessionDidLogout ();
00108
00109 public: /* class functions */
00110
00114     static FBSession* session();
00115
00122     static void setSession(FBSession* aSession);
00123
00129     static FBSession* sessionForApplication ( const QString& aKey, const QString& aSecret, const QString& aSessionProxy);
00130
00131 public: /* instance functions */
00132
00139     FBSession( const QString& aKey, const QString& aSecret, const QString& aSessionProxy );
00140
00144     ~FBSession();
00145
00149     void SaveFrobKey ( const QString& aFrob);
00150
00154         void Savetoken (const QString& token );
00155
00159      bool resume();
00160
00164     void logout();
00165
00169     void send (FBRequest* aRequest);
00170
00174     const QString& apiURL() const;
00178     const QString& apiSecret() const { return iApiSecret; }
00179
00183     const QString& apiKey() const { return iApiKey; }
00184
00188         const QString& frobKey() const { return iFrobKey; }
00189
00190 private:
00191
00195     void save();
00199     void unsave();
00204     bool performRequest(FBRequest* aRequest, bool aEnqueue);
00205
00206
00207 };
00208
00209 #endif // FBSESSION_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/FlickrAuthApp/inc/xmlParser.h Source File

  • File List

example/FlickrAuthApp/inc/xmlParser.h

00001
00018 #ifndef FB_XML_HANDLER_H
00019 #define FB_XML_HANDLER_H
00020
00021 #include <QObject>
00022 #include <QString>
00023 #include <QXmlDefaultHandler>
00024 #include <QVariantList>
00025
00026 #include "authAppConstants.h"
00027
00028 // FORWARD DECLARATIONS
00029 class FBRequest;
00030
00032 class FBXMLHandler : public QObject, public QXmlDefaultHandler
00033 {
00034     Q_OBJECT
00035
00036 private:
00037     QVariantList        iStack;
00038     QList<QString>      iNameStack;
00039     QVariant            iRootObject;
00040     QString             iRootName;
00041     QString             iChars;
00042
00043     QString         iParseErrorMessage;
00044     bool            iError;
00045
00046 public: /* class functions */
00047
00048     FBXMLHandler();
00049     ~FBXMLHandler();
00050
00051     inline const QString& rootName() const { return iRootName; }
00052     inline QVariant rootObject() const { return iRootObject; }
00053
00054     inline bool parseError() const { return iError; }
00055
00056 private:
00057     /* methods from QXmlDefaultHandler */
00058     bool startElement( const QString & namespaceURI,
00059                        const QString & localName,
00060                        const QString & qName,
00061                        const QXmlAttributes & atts);
00062     bool characters(const QString& text);
00063     bool endElement( const QString & namespaceURI,
00064                      const QString & localName,
00065                      const QString & qName );
00066
00067     /* methods from QXmlErrorHandler */
00068     bool error(const QXmlParseException& exception);
00069     bool fatalError(const QXmlParseException& exception);
00070
00071     /* private functions*/
00072     const QString& topName() const;
00073     void flushCharacters();
00074     QVariant topObject(bool aCreate);
00075
00076     QVariant topContainer();
00077
00078
00079     void initWhiteSpaceHash();
00080     QHash<QChar, bool> iWhiteSpaceAndNewLineCharSet;
00081
00082 };
00083
00084 #endif // FB_XML_HANDLER_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/FlickrAuthApp/progressbar.h Source File

  • File List

example/FlickrAuthApp/progressbar.h

00001 #ifndef PROGRESSBAR_H
00002 #define PROGRESSBAR_H
00003
00004 #include <QtGui/QWidget>
00005 #include "ui_progressbar.h"
00006
00007 class progressbar : public QWidget
00008 {
00009     Q_OBJECT
00010
00011 public:
00012     progressbar(QWidget *parent = 0);
00013     ~progressbar();
00014
00015 private:
00016     Ui::progressbarClass ui;
00017 };
00018
00019 #endif // PROGRESSBAR_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/FlickrAuthApp/ui_AuthApp.h Source File

  • File List

example/FlickrAuthApp/ui_AuthApp.h

00001 /********************************************************************************
00002 ** Form generated from reading UI file 'AuthApp.ui'
00003 **
00004 ** Created: Wed Sep 22 18:28:06 2010
00005 **      by: Qt User Interface Compiler version 4.6.2
00006 **
00007 ** WARNING! All changes made in this file will be lost when recompiling UI file!
00008 ********************************************************************************/
00009
00010 #ifndef UI_AUTHAPP_H
00011 #define UI_AUTHAPP_H
00012
00013 #include <QtCore/QVariant>
00014 #include <QtGui/QAction>
00015 #include <QtGui/QApplication>
00016 #include <QtGui/QButtonGroup>
00017 #include <QtGui/QHeaderView>
00018 #include <QtGui/QMainWindow>
00019 #include <QtGui/QPushButton>
00020 #include <QtGui/QSpacerItem>
00021 #include <QtGui/QVBoxLayout>
00022 #include <QtGui/QWidget>
00023
00024 QT_BEGIN_NAMESPACE
00025
00026 class Ui_AuthAppClass
00027 {
00028 public:
00029     QWidget *centralWidget;
00030     QVBoxLayout *verticalLayout;
00031     QPushButton *buttonForget;
00032     QPushButton *pushButton;
00033     QSpacerItem *verticalSpacer;
00034
00035     void setupUi(QMainWindow *AuthAppClass)
00036     {
00037         if (AuthAppClass->objectName().isEmpty())
00038             AuthAppClass->setObjectName(QString::fromUtf8("AuthAppClass"));
00039         AuthAppClass->resize(275, 310);
00040         centralWidget = new QWidget(AuthAppClass);
00041         centralWidget->setObjectName(QString::fromUtf8("centralWidget"));
00042         verticalLayout = new QVBoxLayout(centralWidget);
00043         verticalLayout->setSpacing(6);
00044         verticalLayout->setContentsMargins(11, 11, 11, 11);
00045         verticalLayout->setObjectName(QString::fromUtf8("verticalLayout"));
00046         buttonForget = new QPushButton(centralWidget);
00047         buttonForget->setObjectName(QString::fromUtf8("buttonForget"));
00048
00049         verticalLayout->addWidget(buttonForget);
00050
00051         pushButton = new QPushButton(centralWidget);
00052         pushButton->setObjectName(QString::fromUtf8("pushButton"));
00053
00054         verticalLayout->addWidget(pushButton);
00055
00056         verticalSpacer = new QSpacerItem(20, 40, QSizePolicy::Minimum, QSizePolicy::Expanding);
00057
00058         verticalLayout->addItem(verticalSpacer);
00059
00060         AuthAppClass->setCentralWidget(centralWidget);
00061
00062         retranslateUi(AuthAppClass);
00063
00064         QMetaObject::connectSlotsByName(AuthAppClass);
00065     } // setupUi
00066
00067     void retranslateUi(QMainWindow *AuthAppClass)
00068     {
00069         AuthAppClass->setWindowTitle(QApplication::translate("AuthAppClass", "MainWindow", 0, QApplication::UnicodeUTF8));
00070         buttonForget->setText(QApplication::translate("AuthAppClass", "Logout", 0, QApplication::UnicodeUTF8));
00071         pushButton->setText(QApplication::translate("AuthAppClass", "Login to Flickr", 0, QApplication::UnicodeUTF8));
00072     } // retranslateUi
00073
00074 };
00075
00076 namespace Ui {
00077     class AuthAppClass: public Ui_AuthAppClass {};
00078 } // namespace Ui
00079
00080 QT_END_NAMESPACE
00081
00082 #endif // UI_AUTHAPP_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/FlickrAuthApp/ui_progressbar.h Source File

  • File List

example/FlickrAuthApp/ui_progressbar.h

00001 /********************************************************************************
00002 ** Form generated from reading UI file 'progressbar.ui'
00003 **
00004 ** Created: Wed Sep 22 18:28:02 2010
00005 **      by: Qt User Interface Compiler version 4.6.2
00006 **
00007 ** WARNING! All changes made in this file will be lost when recompiling UI file!
00008 ********************************************************************************/
00009
00010 #ifndef UI_PROGRESSBAR_H
00011 #define UI_PROGRESSBAR_H
00012
00013 #include <QtCore/QVariant>
00014 #include <QtGui/QAction>
00015 #include <QtGui/QApplication>
00016 #include <QtGui/QButtonGroup>
00017 #include <QtGui/QHeaderView>
00018 #include <QtGui/QLabel>
00019 #include <QtGui/QProgressBar>
00020 #include <QtGui/QVBoxLayout>
00021 #include <QtGui/QWidget>
00022
00023 QT_BEGIN_NAMESPACE
00024
00025 class Ui_progressbarClass
00026 {
00027 public:
00028     QVBoxLayout *verticalLayout;
00029     QLabel *label;
00030     QProgressBar *progressBar;
00031
00032     void setupUi(QWidget *progressbarClass)
00033     {
00034         if (progressbarClass->objectName().isEmpty())
00035             progressbarClass->setObjectName(QString::fromUtf8("progressbarClass"));
00036         verticalLayout = new QVBoxLayout(progressbarClass);
00037         verticalLayout->setSpacing(6);
00038         verticalLayout->setContentsMargins(11, 11, 11, 11);
00039         verticalLayout->setObjectName(QString::fromUtf8("verticalLayout"));
00040         label = new QLabel(progressbarClass);
00041         label->setObjectName(QString::fromUtf8("label"));
00042
00043         verticalLayout->addWidget(label);
00044
00045         progressBar = new QProgressBar(progressbarClass);
00046         progressBar->setObjectName(QString::fromUtf8("progressBar"));
00047         progressBar->setValue(24);
00048
00049         verticalLayout->addWidget(progressBar);
00050
00051
00052         retranslateUi(progressbarClass);
00053
00054         QMetaObject::connectSlotsByName(progressbarClass);
00055     } // setupUi
00056
00057     void retranslateUi(QWidget *progressbarClass)
00058     {
00059         progressbarClass->setWindowTitle(QApplication::translate("progressbarClass", "progressbar", 0, QApplication::UnicodeUTF8));
00060         label->setText(QApplication::translate("progressbarClass", "<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.0//EN\" \"http://www.w3.org/TR/REC-html40/strict.dtd\">\n"
00061 "<html><head><meta name=\"qrichtext\" content=\"1\" /><style type=\"text/css\">\n"
00062 "p, li { white-space: pre-wrap; }\n"
00063 "</style></head><body style=\" font-family:'MS Shell Dlg 2'; font-size:8.25pt; font-weight:400; font-style:normal;\">\n"
00064 "<p style=\" margin-top:0px; margin-bottom:0px; margin-left:0px; margin-right:0px; -qt-block-indent:0; text-indent:0px;\"><span style=\" font-size:10pt;\">Loading,Please wait.....</span></p></body></html>", 0, QApplication::UnicodeUTF8));
00065     } // retranslateUi
00066
00067 };
00068
00069 namespace Ui {
00070     class progressbarClass: public Ui_progressbarClass {};
00071 } // namespace Ui
00072
00073 QT_END_NAMESPACE
00074
00075 #endif // UI_PROGRESSBAR_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/DemoGUI/FriendView.h Source File

  • File List

example/DemoGUI/FriendView.h

00001 #ifndef FRIENDVIEW_H
00002 #define FRIENDVIEW_H
00003
00004 #include <qmainwindow.h>
00005 #include <WidgetConstants.h>
00006 #include "customListwidget.h"
00007 #include "GridView.h"
00008 #include <qtablewidget.h>
00009
00010
00011 class FriendView : public QMainWindow
00012 {
00013     Q_OBJECT
00014 public:
00015     FriendView(QString aHeadName);
00016     void SetupUI();
00017     ~FriendView();
00018 private:
00019     QString iHeadName;
00020 private slots:
00021     void Navigated2OtherTab(int tabIndex);
00022 private:
00023     QMainWindow *iMainwindow;
00024     QTabWidget* TabWidget;
00025     GridView* AlbumView;
00026     CustomListWidget* iPostsListWidget;
00027 };
00028
00029 #endif // FRIENDVIEW_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/DemoGUI/GridView.h Source File

  • File List

example/DemoGUI/GridView.h

00001 #ifndef GRIDVIEW_H
00002 #define GRIDVIEW_H
00003
00005
00006 #include <qwidget.h>
00007 #include "WidgetConstants.h"
00008 #include<qpushbutton.h>
00009
00010 class GridView : public QWidget
00011 {
00012 Q_OBJECT
00013
00014 public:
00015     GridView();
00016     void CreateGridView(QStringList aIconPath, QStringList names);
00017     ~GridView();
00018
00019 };
00020
00021
00022 #endif // GRIDVIEW_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/DemoGUI/HomeView.h Source File

  • File List

example/DemoGUI/HomeView.h

00001 #ifndef HOMEVIEW_H
00002 #define HOMEVIEW_H
00003
00004 #include <qmainwindow.h>
00005 #include <WidgetConstants.h>
00006 //#include <smfglobal.h>
00007 #include <smfcontact.h>
00008 #include <smfpost.h>
00009 #include <smfpicturealbum.h>
00010 #include <smfactions.h>
00011 #include <smfpicture.h>
00012 #include <smfcontactfetcher.h>
00013 #include <smfpostprovider.h>
00014 #include <smfgallery.h>
00015 #include <smfactivityfetcher.h>
00016 #include "ImageDownload.h"
00017 #include "ToolBar.h"
00018 #include <qmenu.h>
00019
00020 class CustomListWidget;
00021 class GridView;
00022
00023 class HomeView : public QObject
00024 {
00025         Q_OBJECT
00026 public:
00027     HomeView(QString aHeadName);
00028     ~HomeView();
00029     void SetupUI(QMainWindow *Mainwindow);
00030     void populateFriendsWidget();
00031     void populatePostsWidget();
00032     void populateActivitiesWidget();
00033     void populatePhotosGridView();
00034
00035 private:
00036     void getFriends();
00037     void getPosts();
00038     void downloadImages(const SmfItemIdentifier &identifier, const QMap<QString, QUrl> urlMap);
00039     void getAlbums();
00040     void getActivities();
00041     void getPhotos();
00042
00043 private slots:
00044     void friendsAvailable(SmfContactList* friendsList, SmfError , SmfResultPage );
00045     void postsAvailable(SmfPostList* postsList, SmfError , SmfResultPage );
00046     void albumsAvailable(SmfPictureAlbumList* albums, SmfError error, SmfResultPage resultPage);
00047     void activitiesAvailable(SmfActivityEntryList* postsList, SmfError , SmfResultPage );
00048     void picturesAvailable(SmfPictureList* albums, SmfError error, SmfResultPage resultPage);
00049     void Navigated2OtherTab(int index);
00050
00051 private:
00052     QString iHeadName;
00053     ToolBar* ToolBarwidget;
00054     QMainWindow *m_mainWindow;
00055     QTabWidget *TabWidget;
00056     CustomListWidget *iFrndsListWidget;
00057     CustomListWidget *iPostsListWidget;
00058     CustomListWidget *iActivityListWidget;
00059     CustomListWidget *iAlbumWidget;
00060     GridView *AlbumView;
00061     ImageDownload m_downloader;
00062
00063     SmfContactFetcher *m_contactFetcher;
00064     SmfPostProvider *m_postProvider;
00065     SmfGallery *m_gallery;
00066     SmfActivityFetcher *m_activityFetcher;
00067     SmfContactList *m_friendsList;
00068     SmfPostList *m_postsList;
00069     SmfPictureAlbumList *m_albumsList;
00070     SmfActivityEntryList *m_activitiesList;
00071     SmfPictureList *m_picList;
00072
00073 };
00074
00075 #endif // HOMEVIEW_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/DemoGUI/ImageDownload.h Source File

  • File List

example/DemoGUI/ImageDownload.h

00001 /****************************************************************************
00002 **
00003 ** Trolltech hereby grants a license to use the Qt/Eclipse Integration
00004 ** plug-in (the software contained herein), in binary form, solely for the
00005 ** purpose of creating code to be used with Trolltech's Qt software.
00006 **
00007 ** Qt Designer is licensed under the terms of the GNU General Public
00008 ** License versions 2.0 and 3.0 ("GPL License"). Trolltech offers users the
00009 ** right to use certain no GPL licensed software under the terms of its GPL
00010 ** Exception version 1.2 (http://trolltech.com/products/qt/gplexception).
00011 **
00012 ** THIS SOFTWARE IS PROVIDED BY TROLLTECH AND ITS CONTRIBUTORS (IF ANY) "AS
00013 ** IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
00014 ** TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
00015 ** PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER
00016 ** OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00017 ** EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00018 ** PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00019 ** PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
00020 ** LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
00021 ** NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
00022 ** SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE."
00023 **
00024 ** Since we now have the GPL exception I think that the "special exception
00025 ** is no longer needed. The license text proposed above (other than the
00026 ** special exception portion of it) is the BSD license and we have added
00027 ** the BSD license as a permissible license under the exception.
00028 **
00029 ****************************************************************************/
00030
00031 #ifndef IMAGEDOWNLOAD_H_
00032 #define IMAGEDOWNLOAD_H_
00033
00034 #include <QNetworkReply>
00035 #include <QList>
00036 #include <QNetworkAccessManager>
00037 #include <qhash.h>
00038
00039 class HomeView;
00040
00041 extern bool downloading;
00042
00043 enum SmfItemIdentifier
00044         {
00045         SmfFriendsFetch = 0,
00046         SmfPostsFetch,
00047         SmfAlbumsFetch,
00048         SmfPhotosFetch,
00049         SmfActivityFetch
00050         };
00051
00052 class ImageDownload : public QObject
00053 {
00054     Q_OBJECT
00055 public:
00056     ImageDownload(QObject *parent = 0);
00057     ~ImageDownload();
00058     void downloadImage(HomeView *homeView, QString name, QUrl url, const SmfItemIdentifier &identifier);
00059
00060 public slots:
00061     void networkReplyFinished ( QNetworkReply *aNetworkReply );
00062
00063 private:
00064     SmfItemIdentifier m_identifier;
00065     QNetworkAccessManager *manager;
00066     HomeView *m_homeView;
00067     QString m_name;
00068     QHash<QString, QNetworkReply*> m_nameReplyHash;
00069 };
00070
00071 #endif /* IMAGEDOWNLOAD_H_ */
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: example/MusicLyricsPlugin/MusicLyricsPlugin.h Source File

  • File List

example/MusicLyricsPlugin/MusicLyricsPlugin.h

00001 /*
00002  * MusicLyricsPlugin.h
00003  *
00004  *  Created on: Aug 18, 2010
00005  *      Author: sanpra
00006  */
00007
00008
00009
00010 #ifndef MUSICLYRICSPLUGIN_H_
00011 #define MUSICLYRICSPLUGIN_H_
00012
00013 // Include files
00014 #include "smflyricsserviceplugin.h"
00015 #include "smfpluginutil.h"
00016
00017 #include <parser.h>
00018
00019 // Forward declarations
00020 class MusicProviderBase;
00021 class QVariant;
00022 class QNetworkReply;
00023
00024 // Class declaration
00025 class MusicLyricsPlugin : public QObject, public SmfLyricsServicePlugin
00026 {
00027         Q_OBJECT
00028         Q_INTERFACES( SmfLyricsServicePlugin SmfPluginBase )
00029
00030 public:
00031         virtual ~MusicLyricsPlugin();
00032
00033 public: // From SmfMusicEventsPlugin
00034
00043                  SmfPluginError lyrics( SmfPluginRequestData &aRequest,
00044                                 const SmfTrackInfo &aTrack,
00045                                 const int aPageNum = SMF_FIRST_PAGE,
00046                                 const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) ;
00047
00057                  SmfPluginError subtitles( SmfPluginRequestData &aRequest,
00058                                 const SmfTrackInfo &aTrack,
00059                                 const SmfSubtitleSearchFilter &aFilter = SubtitleAll,
00060                                 const int aPageNum = SMF_FIRST_PAGE,
00061                                 const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) ;
00071                 SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00072                                 const int &aOperation, QByteArray *aData );
00073
00074 public: // From SmfPluginBase
00081              void initialize(/*SmfPluginUtil *aUtil*/);
00082
00087             SmfProviderBase* getProviderInfo( );
00088
00103         /*      SmfPluginError responseAvailable(
00104                         const SmfTransportResult &aTransportResult,
00105                         QNetworkReply *aReply,
00106                         QVariant* aResult,
00107                         SmfPluginRetType &aRetType,
00108                         SmfResultPage &aPageResult );*/
00109         SmfPluginError responseAvailable(
00110                         const SmfRequestTypeID aOperation,
00111                         const SmfTransportResult &aTransportResult,
00112                         QByteArray *aResponse,
00113                         QVariant* aResult,
00114                         SmfPluginRetType &aRetType,
00115                         SmfResultPage &aPageResult );
00116
00117              void writeLog(QString log) const;
00118
00119
00120 private:
00121
00122       QString generateSignature(const QString aBaseString);
00123
00124
00125 private slots:
00126
00127
00128
00129 private:
00141            SmfPluginError createRequest( SmfPluginRequestData &aRequest,const QNetworkAccessManager::Operation aOperation,
00142                         const SmfSignatureMethod aSignatureMethod,
00143                         QMultiMap<QByteArray, QByteArray> &aParams,
00144                         const SmfParsingMode aMode,
00145                         QBuffer *aPostData );
00146
00147 private:
00148            MusicProviderBase *m_provider;
00149            SmfPluginUtil *m_util;
00150 };
00151
00152 // Class declaration
00153 class MusicProviderBase : public QObject, public SmfProviderBase
00154         {
00155          Q_OBJECT
00156          Q_INTERFACES( SmfProviderBase )
00157
00158 public:
00159         virtual ~MusicProviderBase( );
00160
00165         QString serviceName( ) const;
00166
00171         QImage serviceIcon( ) const;
00172
00177         QString description( ) const;
00178
00183         QUrl serviceUrl( ) const;
00184
00189         QUrl applicationUrl( ) const;
00190
00195         QImage applicationIcon( ) const;
00196
00201         QList<QString> supportedInterfaces( ) const;
00202
00208         QStringList supportedLanguages( ) const;
00209
00214         QString pluginId( ) const;
00215
00224         QString authenticationApp( QString &aProgram, QStringList & aArguments,
00225                         QIODevice::OpenModeFlag aMode = QIODevice::ReadWrite ) const;
00226
00233         QString smfRegistrationId( ) const;
00234
00235 private:
00236         friend class MusicLyricsPlugin;
00237         void initialize();
00238         QString m_serviceName;
00239         QImage m_serviceIcon;
00240         QString m_description;
00241         QUrl m_serviceUrl;
00242         QUrl m_applicationUrl;
00243         QImage m_applicationIcon;
00244         QStringList m_serviceType;
00245         QStringList m_supportedLanguages;
00246         QString m_pluginId;
00247         QString m_authAppId;
00248         QString m_smfRegToken;
00249         };
00250
00251
00252
00253 #endif /* MUSICLYRICSPLUGIN_H_ */
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfsettingsui/PlatfromIndependentSettings.h Source File

  • File List

smf/smfsettingsui/PlatfromIndependentSettings.h

00001
00017 #include "SettingsConstants.h"
00018
00019 #ifndef __FOR_SYMBIAN_CR_USAGE__
00020
00021 #ifndef PLATFROMINDEPENDENTSETTINGS_H_
00022 #define PLATFROMINDEPENDENTSETTINGS_H_
00023
00024 #include <qsettings.h>
00025 #include <qstringlist.h>
00032 class CPFIndSettings : public QObject
00033     {
00034 public:
00035
00036
00042      ~CPFIndSettings();
00043
00050             CPFIndSettings();
00051         /*
00052          * Method to set the PluginDetails to QSettings
00053          * Parm - @aPluginName,Name of the plugin
00054          * Param - @aPluginStatus,holds the Plgugin Status.
00055          */
00056         void SetPluginDetails(QString& aPluginName,QString& aPluginStatus);
00057         /*
00058          * Method to set the Auth Expiry Value to QSettings
00059          * Param - @aVal,Auth Expiry Value
00060          */
00061         void SetAuthExpirationValue(QString& aVal);
00062         /*
00063          * Method to set the Max. Data Transfer Limit to QSettings
00064          * Param - @aVal,Max. Data Transfer Limit Value
00065          */
00066         void SetMaxDataTransferLimit(QString& aVal);
00067         /*
00068          * Method to set the Roaming Status for Data Transfer to QSettings
00069          * Param - @aStatus,Rpaming Status value for Data Transfer
00070          */
00071         void SetRoamingStatusforDataTransfer(QString& aStatus);
00072         /*
00073          * Method to set the Upload File Type to QSettings
00074          * Param - @aStatus,Upload File Type Value
00075          */
00076         void SetUploadFileType(QString& aFileType);
00077         /*
00078          * Method to Get the PluginDetails from QSettings
00079          */
00080         QStringList GetPluginDetails() const;
00081         /*
00082          * Method to Get the Auth Expiry Value from QSettings
00083          */
00084         QString GetAuthExpirationValue() const;
00085         /*
00086          * Method to Get the Max. Data Transfer Limit from QSettings
00087          */
00088         QString GetMaxDataTransferLimit() const;
00089         /*
00090          * Method to Get the Roaming Status for Data Transfer from QSettings
00091          */
00092         QString GetRoamingStatusforDataTransfer() const;
00093         /*
00094          * Method to Get the Upload File Type from QSettings
00095          */
00096         QString GetUploadFileType() const;
00097
00098 private:
00102     QSettings*  iSettings;
00103
00104     };
00105
00106 #endif /* PLATFROMINDEPENDENTSETTINGS_H_ */
00107
00108 #endif
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: smf/smfsettingsui/SMFSettings.h Source File

  • File List

smf/smfsettingsui/SMFSettings.h

00001
00018 #ifndef SMFSETTINGS_H
00019 #define SMFSETTINGS_H
00020
00021 //#include <QtGui/QWidget>
00022 #include <qmainwindow.h>
00023 #include "ui_SMFSettings.h"     //for SMFSettingsClass
00024 #include "SettingsRepository.h"
00025 #include "PlatfromIndependentSettings.h"
00026 #include "qlist.h"              //for QList
00027 #include "qstring.h"    //for QString
00028 #include "SettingsConstants.h"
00029
00030 /*
00031  * SMFSettings UI Class
00032  */
00033 class SMFSettings : public /*QWidget*/  QMainWindow
00034 {
00035     Q_OBJECT
00036
00037 public:
00038         /*
00039          * Constructor
00040          */
00041         SMFSettings(/*QWidget *parent = 0*/);
00042         /*
00043          * Destructor
00044          */
00045     ~SMFSettings();
00046
00047 public slots:
00048         /*
00049          * slot written to set/Save the User input/settings to xml.
00050          */
00051     void SaveSettings();
00052         /*
00053          * slot written to Reset the UI settings.
00054          */
00055         void ClearData();
00056 private:
00057         /*
00058          * Method to get the default/initial settings from xml.
00059          */
00060         void GetDefaultSettings();
00061
00062         //void createActions();
00063         void createMenuActions();
00064
00065 //Set & Get Methods
00066 public:
00067         /*
00068          * Method to set the PluginDetails to UI
00069          * Param - @aPluginStatus,holds the Plgugin Status.
00070          */
00071         void SetPluginDetails(QString aPluginName,QString aPluginStatus);
00072         /*
00073          * Method to set the Auth Expiry Value to UI
00074          * Param - @aVal,Auth Expiry Value
00075          */
00076         void SetAuthExpirationValue(QString aVal);
00077         /*
00078          * Method to set the Max. Data Transfer Limit to UI
00079          * Param - @aVal,Max. Data Transfer Limit Value
00080          */
00081         void SetMaxDataTransferLimit(QString aVal);
00082         /*
00083          * Method to set the Roaming Status for Data Transfer to UI
00084          * Param - @aStatus,Rpaming Status value for Data Transfer
00085          */
00086         void SetRoamingStatusforDataTransfer(QString aStatus);
00087         /*
00088          * Method to set the Upload File Type to UI
00089          * Param - @aStatus,Upload File Type Value
00090          */
00091         void SetUploadFileType(QString aFileType);
00092         /*
00093          * Method to Get the PluginDetails from UI
00094          */
00095         QStringList GetPluginDetails() const;
00096         /*
00097          * Method to Get the Auth Expiry Value from UI
00098          */
00099         QString GetAuthExpirationValue() const;
00100         /*
00101          * Method to Get the Max. Data Transfer Limit from UI
00102          */
00103         QString GetMaxDataTransferLimit() const;
00104         /*
00105          * Method to Get the Roaming Status for Data Transfer from UI
00106          */
00107         QString GetRoamingStatusforDataTransfer() const;
00108         /*
00109          * Method to Get the Upload File Type from UI
00110          */
00111         QString GetUploadFileType() const;
00112
00113 private:
00114         /*
00115          * pointer to Settings UI class.
00116          */
00117     Ui::SMFSettingsClass *ui;
00118
00119         #ifdef __FOR_SYMBIAN_CR_USAGE__
00120                 CSettingsRepository* iSettingsRepository;
00121         #else
00122                 CPFIndSettings* iSettingsRepository;
00123         #endif
00124
00125
00126 };
00127
00128 #endif // SMFSETTINGS_H
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: example/DemoGUI/ScreenSize.h Source File

  • File List

example/DemoGUI/ScreenSize.h

00001 #ifndef SCREENSIZE_H
00002 #define SCREENSIZE_H
00003
00004 #include <qobject.h>
00005 #include <qrect.h>
00006 #include <qapplication.h>
00007 #include <qdesktopwidget.h>
00008
00009 class ScreenSize : public QObject
00010 {
00011 public:
00012     inline static QRect GetScreenRect()
00013     {
00014         return   QApplication::desktop()->screenGeometry();
00015     }
00016 };
00017
00018 #endif // SCREENSIZE_H
Generated on Thu Sep 23 15:03:09 2010 for smf by doxygen 1.6.3


smf: smf/smfsettingsui/SettingsConstants.h Source File

  • File List

smf/smfsettingsui/SettingsConstants.h

00001 /*
00002  * SettingsInternalCRKeys.h
00003  *
00004  *  Created on: Mar 30, 2010
00005  *      Author: kavadapu
00006  */
00007
00008 #ifndef SETTINGSCONSTANTS_H_
00009 #define SETTINGSCONSTANTS_H_
00010
00011 //#define __FOR_SYMBIAN_CR_USAGE__
00012
00013 #ifdef __FOR_SYMBIAN_CR_USAGE__
00014         #include <e32base.h>
00015         //UID of the Setting Application
00016         static const TUid KCRUidSettings = { 0xE6313AF5 };
00017         //Settings Key value to set/identify the Plugin Name
00018         const TUint32 KSettingsUIPluginNameKey = 0x01;
00019         //Settings Key value to set/identify the Plugin Status
00020         const TUint32 KSettingsUIPluginStausKey = 0x02;
00021         //Settings Key value used to set/identify the Authentication Expiry Limit
00022         const TUint32 KSettingsUIAuthExpLimitKey = 0x03;
00023         //Settings key value used to set/identify the Max. Data Transfer Limit value
00024         const TUint32 KSettingsUIMaxDataTransferLimitKey = 0x04;
00025         //Settings key value used to set/identify the Roaming status Value.
00026         const TUint32 KSettingsUIRoamingStatusKey = 0x05;
00027         //Settings key value used to set/identify the Upload file type value.
00028         const TUint32 KSettingsUIUploadFileTypeKey = 0x06;
00029 #else
00030         #include "qsettings.h"
00031
00032         //Settings Key value to set/identify the Plugin Name
00033         const QString KSettingsUIPluginNameKey = "PluginName";
00034         //Settings Key value to set/identify the Plugin Status
00035         const QString KSettingsUIPluginStausKey = "PluginStatus";
00036         //Settings Key value used to set/identify the Authentication Expiry Limit
00037         const QString KSettingsUIAuthExpLimitKey = "AuthExpLmt";
00038         //Settings key value used to set/identify the Max. Data Transfer Limit value
00039         const QString KSettingsUIMaxDataTransferLimitKey = "MaxDataTrLmt";
00040         //Settings key value used to set/identify the Roaming status Value.
00041         const QString KSettingsUIRoamingStatusKey = "RoamingStatus";
00042         //Settings key value used to set/identify the Upload file type value.
00043         const QString KSettingsUIUploadFileTypeKey = "UploadFileType";
00044 #endif
00045
00046 #endif /* SETTINGSCONSTANTS_H_ */
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: smf/smfsettingsui/SettingsRepository.h Source File

  • File List

smf/smfsettingsui/SettingsRepository.h

00001
00018 #include "SettingsConstants.h"
00019
00020 #ifdef __FOR_SYMBIAN_CR_USAGE__
00021
00022 #ifndef SETTINGSREPOSITORY_H_
00023 #define SETTINGSREPOSITORY_H_
00024
00025 const TInt KMaxSettingValue = 50;
00026
00027 #include <centralrepository.h>
00028 //#include <BADESCA.H>
00035 class CSettingsRepository : public CBase
00036     {
00037 public:
00038
00045     static CSettingsRepository* NewL();
00046
00053     static CSettingsRepository* NewLC();
00054
00055
00061      ~CSettingsRepository();
00062
00063
00064 public:
00065
00066
00073             CSettingsRepository();
00074         /*
00075          * Method to set the PluginDetails to Symbian Repository
00076          * Parm - @aPluginName,Name of the plugin
00077          * Param - @aPluginStatus,holds the Plgugin Status.
00078          */
00079         void SetPluginDetails(TDesC& aPluginName,TDesC& aPluginStatus);
00080         /*
00081          * Method to set the Auth Expiry Value to Repository
00082          * Param - @aVal,Auth Expiry Value
00083          */
00084         void SetAuthExpirationValue(TDesC& aVal);
00085         /*
00086          * Method to set the Max. Data Transfer Limit to Repository
00087          * Param - @aVal,Max. Data Transfer Limit Value
00088          */
00089         void SetMaxDataTransferLimit(TDesC& aVal);
00090         /*
00091          * Method to set the Roaming Status for Data Transfer to Repository
00092          * Param - @aStatus,Rpaming Status value for Data Transfer
00093          */
00094         void SetRoamingStatusforDataTransfer(TDesC& aStatus);
00095         /*
00096          * Method to set the Upload File Type to Repository
00097          * Param - @aStatus,Upload File Type Value
00098          */
00099         void SetUploadFileType(TDesC& aFileType);
00100         /*
00101          * Method to Get the PluginDetails from Repository
00102          */
00103         RArray<TBuf<KMaxSettingValue> >& GetPluginDetails() const;
00104         /*
00105          * Method to Get the Auth Expiry Value from Repository
00106          */
00107         TDesC& GetAuthExpirationValue() const;
00108         /*
00109          * Method to Get the Max. Data Transfer Limit from Repository
00110          */
00111         TDesC& GetMaxDataTransferLimit() const;
00112         /*
00113          * Method to Get the Roaming Status for Data Transfer from Repository
00114          */
00115         TDesC& GetRoamingStatusforDataTransfer() const;
00116         /*
00117          * Method to Get the Upload File Type from Repository
00118          */
00119         TDesC& GetUploadFileType() const;
00120
00121 private:
00122
00128     void ConstructL();
00129
00133    CRepository*  iRepository;
00134
00135     };
00136
00137
00138 #endif /* SETTINGSREPOSITORY_H_ */
00139
00140 #endif
Generated on Thu Sep 23 15:03:17 2010 for smf by doxygen 1.6.3


smf: example/DemoGUI/ToolBar.h Source File

  • File List

example/DemoGUI/ToolBar.h

00001 #ifndef TOOLBAR_H
00002 #define TOOLBAR_H
00003
00004 #include <qobject.h>
00005 #include <qmainwindow.h>
00006 #include <qboxlayout.h>
00007 #include <qtoolbar.h>
00008 #include <qtoolbutton.h>
00009 #include <qsignalmapper.h>
00010 #include "WidgetConstants.h"
00011 #include <qmenu.h>
00012
00013 //FaceBook AuthApp UID
00014 const TUint32 KFBUid3 = { 0xEFE2FD23 };
00015 const TUint32 KFlickUid3 = { 0xE1D8C7D7 };
00016
00017 class ToolBar : public QObject
00018 {
00019     Q_OBJECT
00020 public:
00021     ToolBar();
00022     void GetToolBar(QMainWindow *Mainwindow,QStringList aListOfActions);
00023     void launchFB();
00024     void launchFlickr();
00025     ~ToolBar();
00026 public slots:
00027     //void post();
00028     //void reply();
00029     void exitApp();
00030     void homeView();
00031     void msg();
00032     void call();
00033     void authApp_Fb();
00034     void authApp_Flkr();
00035 private:
00036      QMainWindow *iMainWindow;
00037      QSignalMapper *signal;
00038 public:
00039         QMenu* menu;
00040         //QAction *newAction1;
00041         //QAction *newAction2;
00042 };
00043
00044 #endif // TOOLBAR_H
Generated on Thu Sep 23 15:03:09 2010 for smf by doxygen 1.6.3


smf: example/DemoGUI/WidgetConstants.h Source File

  • File List

example/DemoGUI/WidgetConstants.h

00001 #ifndef WIDGETCONSTANTS_H
00002 #define WIDGETCONSTANTS_H
00003
00004 //For Home Screen
00005 const int KHeadNameHeight = 40;
00006 const int KWidgetGapFactor = 5;
00007 const int ToolbarIconHeight = 50;
00008
00009
00010 #endif // WIDGETCONSTANTS_H
Generated on Thu Sep 23 15:03:09 2010 for smf by doxygen 1.6.3


smf: Alphabetical List

Class Index

A | C | D | F | G | H | I | J | L | M | P | Q | R | S | T | U
A
G
RSmfCredMgrClientSession SmfGroup SmfProvider
AuthApp GridView
S
SmfGroupPrivate SmfProviderBase
AuthAppClass (Ui)
H
SamplePlugin SmfLocation SmfRelationItem
C
HomeView SampleProviderBase SmfLocationPrivate SmfRelationMgr
CPFIndSettings
I
ScreenSize SmfLyrics SmfRelationMgrPrivate
CSessionStruct | ImageDownload | Serializer (QJson) | SmfLyricsPrivate | SmfResultPage
CSmfClientSymbian
J
Serializer::SerializerPrivate SmfLyricsService SmfServer
CSmfCredMgrClientSymbian | json_parser (yy) | SerializerRunnable (QJson) | SmfLyricsServicePlugin | SmfServerQt
CSmfCredMgrDb | JSonScanner | slice (yy) | SmfLyricsServicePrivate | SmfServerQtSession
CSmfCredMgrDbUser
L
SmfActivityEntry SmfMusicFingerPrint SmfServerSymbian
CSmfCredMgrServer LastFmMusicSearchPlugin SmfActivityEntryPrivate SmfMusicFingerPrintPrivate SmfServerSymbianSession
CSmfCredMgrServerSession LastFmMusicSearchProviderBase SmfActivityFetcher SmfMusicProfile SMFSettings
CSmfFetchAuthTokenSet LastFmMusicServicePlugin SmfActivityFetcherPlugin SmfMusicProfilePrivate SmfSettingsHandler
CSmfKeyStoreManager LastFmMusicServiceProviderBase SmfActivityFetcherPrivate SmfMusicRating SmfSettingsRepositoryQt
CSmfPluginIDListParams LastFmPlaylistServicePlugin SmfActivityObject SmfMusicRatingPrivate SMFSocialNetworkingSite
CSmfPluginIDUpdate LastFmPlaylistServiceProviderBase SmfActivityObjectPrivate SmfMusicSearch SMFSocialProfile
CSmfRsaKeyParameters | location (yy) | SmfAlbum | SmfMusicSearchPlugin | SmfSubtitle
CSmfSignParameters
M
SmfAlbumPrivate SmfMusicSearchPrivate SmfSubtitlePrivate
CSmfStoreAuthParams | MainWindow (Ui) | SmfArtists | SmfMusicService | SmfTrackInfo
CSmfURLListParams MainWindow SmfArtistsPrivate SmfMusicServicePlugin SmfTrackInfoPrivate
CustomListWidget MusicEventPlugin SmfClient SmfMusicServicePrivate SmfTransportManager
D
MusicLyricsPlugin SmfClientApp (Ui) smfObserver SmfTransportManagerUtil
DataStoreManager MusicProviderBase SmfClientApp SmfPicture SmfUrl
DisplayWidget MyApplication SmfClientAuthID SmfPictureAlbum SmfUrlPrivate
DisplayWidgetClass (Ui) | MyAppView | SmfClientPrivate | SmfPictureAlbumPrivate | SMFUserProfile
DSMContactPckg
P
SmfClientQt SmfPicturePrivate SmfWaitingPluginInfoStruc
F
Parser (QJson) SmfComment SmfPlaylist stack (yy)
FBActivityFetcherPlugin ParserPrivate (QJson) SmfCommentPrivate SmfPlaylistPrivate
T
FBActivityProviderBase | ParserRunnable (QJson) | SmfContact | SmfPlaylistService | TestParser
FBContactFetcherPlugin Person SmfContactFetcher SmfPlaylistServicePlugin TestQObjectHelper
FBContactProviderBase | position (yy) | SmfContactFetcherPlugin | SmfPlaylistServicePrivate | TestScreen
FBDialog PostTestUi SmfContactFetcherPrivate SmfPluginBase TestSerializer
FBError | PostTestUiClass (Ui) | SmfContactPrivate | SmfPluginDataUsage | json_parser::token (yy)
FBLoginDialog SerializerRunnable::Private SmfCredMgrClient SmfPluginManager ToolBar
FBPostProviderPlugin | ParserRunnable::Private (QJson) | SmfEvent | SmfPluginManagerUtil | TSmfAuthToken
FBProviderBase progressbar SmfEventPrivate SmfPluginRequestData
U
FBRequest | progressbarClass (Ui) | SmfEventsFetcher | SmfPluginUtil | Ui_AuthAppClass
FBSession
Q
SmfEventsFetcherPlugin SmfPost Ui_DisplayWidgetClass
FBXMLHandler | QObjectHelper (QJson) | SmfEventsFetcherPrivate | SmfPostPrivate | Ui_MainWindow
FlickrContactFetcherPlugin QObjectHelper::QObjectHelperPrivate SmfGallery SmfPostProvider Ui_PostTestUiClass
FlickrGalleryPlugin
R
SmfGalleryPlugin SmfPostProviderPlugin Ui_progressbarClass
FlickrProviderBase RSmfClientSymbianSession SmfGalleryPrivate SmfPostProviderPrivate Ui_SmfClientApp
FriendView
A | C | D | F | G | H | I | J | L | M | P | Q | R | S | T | U
Generated on Thu Sep 23 15:03:18 2010 for smf by doxygen 1.6.3


smf: example/smfclientapp/displaywidget.h Source File

  • File List

example/smfclientapp/displaywidget.h

00001
00016 #ifndef DISPLAYWIDGET_H
00017 #define DISPLAYWIDGET_H
00018
00019 #include <QtGui/QWidget>
00020 #include "ui_displaywidget.h"
00021 #include "smfclient.h"
00022 #include <QFile>
00023 #include <QMessageBox>
00024 #include <QTextStream>
00025 #include <smfcontactfetcher.h>
00026 #include <smfpostprovider.h>
00027 #include <QSplashScreen>
00028 class DisplayWidget : public QWidget
00029 {
00030     Q_OBJECT
00031
00032 public:
00033     DisplayWidget(QWidget *parent = 0);
00034     ~DisplayWidget();
00035          //debugging
00036          void writeLog(QString log) const;
00037 public slots:
00038         //void friendsButtonClicked();
00039         //void postsButtonClicked();
00040         // void showGroups(SmfGroupList* grps, SmfError , SmfResultPage);
00041          void showFriends(SmfContactList* frnds, SmfError , SmfResultPage);
00042          void showPosts(SmfPostList* postlist, SmfError error, SmfResultPage resultPage);
00043          //void getData(int index);
00044          void interfaceSelected();
00045          void serviceProviderSelected();
00046          void serviceSelected();
00047 private:
00048    SmfProvider* m_provider;
00049    SmfContactFetcher* m_contactFetcher;
00050    SmfPostProvider* m_postProvider;
00051    QList<SmfProvider>* providerList;
00052    QPixmap pixmap;
00053    QSplashScreen splash;
00054     Ui::DisplayWidgetClass ui;
00055 };
00056
00057 #endif // DISPLAYWIDGET_H
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/datastoremgr/dsm.h Source File

  • File List

smf/smfservermodule/smfserver/datastoremgr/dsm.h

00001
00017  /*      DataStoreManager table description
00018          --------------------------------------------
00019
00020          contact (contactId INTEGER PRIMARY KEY AUTOINCREMENT,
00021                           userId TEXT,
00022                           contactUrl TEXT,
00023                           localId TEXT,
00024                           managerUri TEXT,
00025                           snsName TEXT,
00026                           snsDesc TEXT,
00027                           snsUrl TEXT),
00028                           presenceState INTEGER,
00029                           presenceText TEXT,
00030                           StatusText TEXT,
00031                           timeStamp INTEGER");
00032
00033 --------------------------------------------********-------------------------------------------------
00034                 relation table constitue of relationId, contactId and contactIndex fields.
00035
00036                 relation (relationId INTEGER ,
00037                                   contactId INTEGER,
00038                                   contactIndex INTEGER);
00039
00040                 if more than one contactId exist for a relation,
00041                 contactIndex will be assigned in incremental order to the contactId's (0, 1, 2, 3........).
00042
00043         Eg.
00044                 Row     |       relationId | contactId | contactIndex
00045                 -----------------------------------------------
00046                 R1      |       1000       |  1234     |    0
00047                 R2      |       1000       |  1235     |    1
00048                 R3      |       1001       |  4567     |    0
00049                 R4      |       1000       |  1236     |    2
00050
00051
00052                 On deletion Row2: Deleting Relation Contact
00053                 Row     |       relationId | contactId | contactIndex
00054                 -----------------------------------------------
00055                 R1      |       1000       |  1234     |    0
00056                 R2      |       1001       |  4567     |    0
00057                 R3      |       1000       |  1236     |    1
00058
00059
00060 */
00061
00062 #ifndef DATASTOREMANAGER_H
00063 #define DATASTOREMANAGER_H
00064
00065 #define socialProfileBaseID 1000
00066
00067 #include <QString>
00068 #include <QObject>
00069 #include <QtSql>
00070
00071 #include "smfprovider.h"
00072 #include "smfcontact.h"
00073 #include "smfrelationmgr.h"
00074 #include "smfglobal.h"
00075
00076 enum DataStoreManagerState{READY, BUSY, CLOSED, ERROR};
00077
00078 struct DSMContactPckg
00079 {
00080 public:
00081          QString userId;
00082          QString contactUrl;
00083          QString localId;
00084          QString managerUri;
00085          QString snsName;
00086          QString snsDesc;
00087          QString snsUrl;
00088          QString presenceState;
00089          QString presenceText;
00090          QString statusText;
00091          Int64 timeStamp;
00092          int contactIndex;
00093          int relationId;
00094 };
00095
00096 class DataStoreManager : public QObject
00097 {
00098         Q_OBJECT
00099
00100         public:
00101
00102                 static DataStoreManager* getDataStoreManager();
00103                 ~DataStoreManager();
00104                 DataStoreManagerState getState() const;
00105                 QString getErrorText() const;
00106
00107         public slots:
00108         SmfRelationId create(SmfProvider *aProvider=NULL, SmfContact *aContact=NULL);
00109
00111                 SmfError associate( SmfRelationId aRelation,
00112                                                         const SmfContact* aContact,
00113                                                         SmfProvider* aProvider);
00114
00116                 SmfError remove(SmfRelationId aRelation,
00117                                                 const SmfContact* aConact);
00118
00120                 SmfRelationItem* searchById(const SmfRelationId aRelation);
00121
00123                 SmfRelationId searchByContact( SmfContact aContact);
00124
00126                 QList<SmfRelationItem> getAll(SmfRelationId aRelation);
00127
00129                 SmfRelationItem* getContact(SmfRelationId aRelation, quint32 aIndex);
00130
00132                 SmfError deleteRelation(SmfRelationId aRelation);
00133
00135                 QList<SmfRelationId> getAllRelations();
00136
00138                 uint count(SmfRelationId aRelation);
00139
00141                 DSMContactPckg* get(SmfRelationId aRelation, quint32 aIndex);
00142
00143
00144         private:
00145                 int openDB();
00146                 int executeQuery(QSqlQuery&);
00147                 DataStoreManager(const QString& dbName, QObject* parent = 0);
00148                 bool InitializeDataBase();      // Initialization code to be called once while lazy construction of the instance
00149
00150         private:
00151         /*create and initialize a SmfRelationItem*/
00152                 void createRelationItem(QSqlQuery & aQry, int aIndex);
00153
00154                 enum{
00155                         ENewRelation = -1
00156                 };
00157         /*------------------Operation on Contact Table-------------------*/
00159         int addContactToTable( const QString &localId,
00160                                                                         const QString &managerUri,
00161                                                                         const QString &snsName,
00162                                                                         const QString &snsDesc,
00163                                                                         const QString &snsUrl);
00164
00165         int addContactToTable( const QString &userId,
00166                                                                         const QString &contactUrl,
00167                                                                         const QString &localId,
00168                                                                         const QString &managerUri,
00169                                                                         const QString &snsName,
00170                                                                         const QString &snsDesc,
00171                                                                         const QString &snsUrl,
00172                                                                         const QString &presenceState,
00173                                                                         const QString &presenceText,
00174                                                                         const QString &statusText,
00175                                                                         const Int64 timeStamp
00176                                                                         );
00177
00178
00179
00181         SmfError removeContactFromTable(const int aContactId);
00182
00184         SmfRelationItem* searchContact(const int aContactId);
00185
00187         TBool contactIfExist( const int aContactId);
00188
00189
00190         /*------------------Operation on Relation Table-------------------*/
00192         int addRelationToTable(const int aContactId, int aRelationId = ENewRelation);
00193
00195         SmfError deleteRelationFromTable(const int aRelationId);
00196
00198                 SmfError deleteContactFromTable(const int aRelationId, const int aContactId);
00199
00201         QList<int> searchContactIdList(const int aRelationId);
00202
00204         int searchContactId(const int aRelationId, const int aIndex);
00205
00207         int searchRelationId(const int aContactId);
00208
00210         int findMaxIndexValue(const int aRelationId );
00211
00213         int findMaxRelationId();
00214
00218         void manageContactIndex(const int aRelationId, const int aContactIndex );
00219
00221         uint count(const int aRelationId);
00222
00224         TBool relationIfExist( const int aRelationId);
00225
00226         private:
00227
00228         static DataStoreManager* dsmInstance;           // Unique Instance for DSM (Singleton Implementation)
00229         static const QString dbName;
00230         int dsmInstanceCount;                                           // Track references to the DSM
00231         static DataStoreManagerState state;                     // Current state of DSM
00232         QString lastMsg;                                                        // Last message/error generated by the database.
00233         QSqlDatabase db;
00234         SmfRelationItem * iSmsfRelationItem;
00235         DSMContactPckg  *iDSMContactPckgItem;
00236
00237 };
00238
00239 #endif
Generated on Thu Sep 23 15:03:14 2010 for smf by doxygen 1.6.3


smf: example/fbactivityfetcherplugin/fbactivityfetcherplugin.h Source File

  • File List

example/fbactivityfetcherplugin/fbactivityfetcherplugin.h

00001
00020 #ifndef _FBACTIVITYFETCHERPLUGIN_H
00021 #define _FBACTIVITYFETCHERPLUGIN_H
00022
00023 // Include files
00024 #include <QDateTime>
00025 #include <smfactivityfetcherplugin.h>
00026
00027 // Forward declarations
00028 class FBActivityProviderBase;
00029 class QVariant;
00030
00035 class FBActivityFetcherPlugin : public QObject, public SmfActivityFetcherPlugin
00036         {
00037         Q_OBJECT
00038         Q_INTERFACES( SmfActivityFetcherPlugin SmfPluginBase )
00039
00040 public:
00044         virtual ~FBActivityFetcherPlugin( );
00045
00046 public: // From SmfActivityFetcherPlugin interface
00047
00055         SmfPluginError selfActivities( SmfPluginRequestData &aRequest,
00056                         const int aPageNum = SMF_FIRST_PAGE,
00057                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00058
00067         SmfPluginError friendsActivities( SmfPluginRequestData &aRequest,
00068                         const SmfContact &aContact,
00069                         const int aPageNum = SMF_FIRST_PAGE,
00070                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00071
00080         SmfPluginError filtered( SmfPluginRequestData &aRequest,
00081                         QList<SmfActivityObjectType> &aFilters,
00082                         const int aPageNum = SMF_FIRST_PAGE,
00083                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00084
00094         SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00095                         const int &aOperation, QByteArray *aData );
00096
00097 public: // From SmfPluginBase interface
00102         void initialize( );
00103
00108         SmfProviderBase* getProviderInfo( );
00109
00126         SmfPluginError responseAvailable(
00127                         const SmfRequestTypeID aOperation,
00128                         const SmfTransportResult &aTransportResult,
00129                         QByteArray *aResponse,
00130                         QVariant* aResult,
00131                         SmfPluginRetType &aRetType,
00132                         SmfResultPage &aPageResult );
00133
00134 private:
00140         QString generateSignature(const QString aBaseString);
00141
00147         SmfPluginError getFacebookUserId( SmfPluginRequestData &aRequest );
00148
00156         SmfPluginError getSelfActivities(  SmfPluginRequestData &aRequest,
00157                         const int aPageNum = SMF_FIRST_PAGE,
00158                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00159
00166         SmfActivityVerb convertActivityverb( const QString& verbStr );
00167
00174         SmfActivityObjectType convertActivityObjectType( const QString& verbStr );
00175
00184         void fetchKeys( QString &aApiKey,
00185                         QString &aApiSecret,
00186                         QString &aSessionKey,
00187                         QString &aSessionSecret,
00188                         QString &aAppId);
00189
00190 private:
00191         FBActivityProviderBase *m_provider;
00192         };
00193
00194
00195
00199 class FBActivityProviderBase : public QObject, public SmfProviderBase
00200         {
00201         Q_OBJECT
00202         Q_INTERFACES( SmfProviderBase )
00203
00204 public:
00208         virtual ~FBActivityProviderBase( );
00209
00214         QString serviceName( ) const;
00215
00220         QImage serviceIcon( ) const;
00221
00226         QString description( ) const;
00227
00232         QUrl serviceUrl( ) const;
00233
00238         QUrl applicationUrl( ) const;
00239
00244         QImage applicationIcon( ) const;
00245
00250         QList<QString> supportedInterfaces( ) const;
00251
00257         QStringList supportedLanguages( ) const;
00258
00263         QString pluginId( ) const;
00264
00273         QString authenticationApp( QString &aProgram, QStringList & aArguments,
00274                         QIODevice::OpenModeFlag aMode = QIODevice::ReadWrite ) const;
00275
00282         QString smfRegistrationId( ) const;
00283
00284 private:
00289         void initialize();
00290
00291 private:
00292         friend class FBActivityFetcherPlugin;
00293         QString m_serviceName;
00294         QImage m_serviceIcon;
00295         QString m_description;
00296         QUrl m_serviceUrl;
00297         QUrl m_applicationUrl;
00298         QImage m_applicationIcon;
00299         QString m_pluginId;
00300         QString m_authAppId;
00301         QString m_smfRegToken;
00302         QList<QString> m_supportedInterfaces;
00303         QStringList m_supportedLangs;
00304         QDateTime m_validity;
00305         };
00306
00307 #endif /*_FBACTIVITYFETCHERPLUGIN_H*/
Generated on Thu Sep 23 15:03:09 2010 for smf by doxygen 1.6.3


smf: example/fbcontactfetcherplugin/fbcontactfetcherplugin.h Source File

  • File List

example/fbcontactfetcherplugin/fbcontactfetcherplugin.h

00001
00020 #ifndef _FBCONTACTFETCHERPLUGIN_H
00021 #define _FBCONTACTFETCHERPLUGIN_H
00022
00023 // Include files
00024 #include <QDateTime>
00025 #include <smfcontactfetcherplugin.h>
00026
00027 // Forward declarations
00028 class FBContactProviderBase;
00029 class QVariant;
00030
00031
00036 class FBContactFetcherPlugin : public QObject, public SmfContactFetcherPlugin
00037         {
00038         Q_OBJECT
00039         Q_INTERFACES( SmfContactFetcherPlugin SmfPluginBase )
00040
00041 public:
00045         virtual ~FBContactFetcherPlugin( );
00046
00047 public: // From SmfContactFetcherPlugin interface
00048
00056         SmfPluginError friends( SmfPluginRequestData &aRequest,
00057                         const int aPageNum = SMF_FIRST_PAGE,
00058                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00059
00067         SmfPluginError followers( SmfPluginRequestData &aRequest,
00068                         const int aPageNum = SMF_FIRST_PAGE,
00069                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00070
00079         SmfPluginError search( SmfPluginRequestData &aRequest,
00080                         const SmfContact &aContact,
00081                         const int aPageNum = SMF_FIRST_PAGE,
00082                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00083
00094         SmfPluginError searchNear( SmfPluginRequestData &aRequest,
00095                         const SmfLocation &aLocation,
00096                         const SmfLocationSearchBoundary &aProximity,
00097                         const int aPageNum = SMF_FIRST_PAGE,
00098                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00099
00107         SmfPluginError groups( SmfPluginRequestData &aRequest,
00108                         const int aPageNum = SMF_FIRST_PAGE,
00109                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00110
00120         SmfPluginError searchInGroup( SmfPluginRequestData &aRequest,
00121                         const SmfGroup &aGroup,
00122                         SmfContact *aContact = NULL,
00123                         const int aPageNum = SMF_FIRST_PAGE,
00124                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00125
00135         SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00136                         const int &aOperation, QByteArray *aData );
00137
00138 public: // From SmfPluginBase interface
00143         void initialize( );
00144
00149         SmfProviderBase* getProviderInfo( );
00150
00168         SmfPluginError responseAvailable(
00169                         const SmfRequestTypeID aOperation,
00170                         const SmfTransportResult &aTransportResult,
00171                         QByteArray *aResponse,
00172                         QVariant* aResult,
00173                         SmfPluginRetType &aRetType,
00174                         SmfResultPage &aPageResult );
00175
00176 private:
00182         QString generateSignature(const QString aBaseString);
00183
00191         SmfPluginError getFriendsUids( SmfPluginRequestData &aRequest,
00192                         const int aPageNum,
00193                         const int aItemsPerPage );
00194
00202         SmfPluginError getFriendsDetails( SmfPluginRequestData &aRequest,
00203                         const int aPageNum,
00204                         const int aItemsPerPage );
00205
00213         void fetchKeys( QString &aApiKey,
00214                         QString &aApiSecret,
00215                         QString &aSessionKey,
00216                         QString &aSessionSecret );
00217
00218 private:
00219         FBContactProviderBase *m_provider;
00220         };
00221
00222
00223
00227 class FBContactProviderBase : public QObject, public SmfProviderBase
00228         {
00229         Q_OBJECT
00230         Q_INTERFACES( SmfProviderBase )
00231
00232 public:
00236         virtual ~FBContactProviderBase( );
00237
00242         QString serviceName( ) const;
00243
00248         QImage serviceIcon( ) const;
00249
00254         QString description( ) const;
00255
00260         QUrl serviceUrl( ) const;
00261
00266         QUrl applicationUrl( ) const;
00267
00272         QImage applicationIcon( ) const;
00273
00278         QList<QString> supportedInterfaces( ) const;
00279
00285         QStringList supportedLanguages( ) const;
00286
00291         QString pluginId( ) const;
00292
00301         QString authenticationApp( QString &aProgram, QStringList & aArguments,
00302                         QIODevice::OpenModeFlag aMode = QIODevice::ReadWrite ) const;
00303
00310         QString smfRegistrationId( ) const;
00311
00312 private:
00317         void initialize();
00318
00319 private:
00320         friend class FBContactFetcherPlugin;
00321         QString m_serviceName;
00322         QImage m_serviceIcon;
00323         QString m_description;
00324         QUrl m_serviceUrl;
00325         QUrl m_applicationUrl;
00326         QImage m_applicationIcon;
00327         QString m_pluginId;
00328         QString m_authAppId;
00329         QString m_smfRegToken;
00330         QList<QString> m_supportedInterfaces;
00331         QStringList m_supportedLangs;
00332         QDateTime m_validity;
00333         };
00334
00335 #endif /*_FBCONTACTFETCHERPLUGIN_H*/
Generated on Thu Sep 23 15:03:09 2010 for smf by doxygen 1.6.3


smf: example/fbpostproviderplugin/fbpostproviderplugin.h Source File

  • File List

example/fbpostproviderplugin/fbpostproviderplugin.h

00001
00020 #ifndef _FBPOSTPROVIDERPLUGIN_H
00021 #define _FBPOSTPROVIDERPLUGIN_H
00022
00023 // Include files
00024 #include <QDateTime>
00025 #include <smfpostproviderplugin.h>
00026
00027 // Forward declarations
00028 class FBProviderBase;
00029 class QVariant;
00030
00031
00036 class FBPostProviderPlugin : public QObject, public SmfPostProviderPlugin
00037 {
00038         Q_OBJECT
00039         Q_INTERFACES( SmfPostProviderPlugin SmfPluginBase )
00040
00041 public:
00045         virtual ~FBPostProviderPlugin( );
00046
00047 public: // From SmfPostProviderPlugin interface
00048
00055         qint32 maxCharsInPost( ) const;
00056
00063         qint32 maxItems( ) const;
00064
00071         QVector<QTextFormat> supportedFormats ( ) const;
00072
00078         bool supportsAppearence ( ) const;
00079
00088         SmfPluginError retrieve( SmfPluginRequestData &aRequest,
00089                         const SmfContact *aUser=0,
00090                         const int aPageNum = SMF_FIRST_PAGE,
00091                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00092
00093
00101         SmfPluginError post( SmfPluginRequestData &aRequest,
00102                         const SmfPost &aPostData,
00103                         const SmfLocation &aLocation );
00104
00111         SmfPluginError updatePost( SmfPluginRequestData &aRequest,
00112                         const SmfPost &aPostData );
00113
00122         SmfPluginError postDirected( SmfPluginRequestData &aRequest,
00123                         const SmfPost &aPostData,
00124                         const SmfContact &aContact,
00125                         const SmfLocation *aLocation = NULL );
00126
00127
00135         SmfPluginError commentOnAPost(SmfPluginRequestData &aRequest,
00136                         const SmfPost &aTarget,
00137                         const SmfPost &aComment,
00138                         const SmfLocation *aLocation = NULL);
00139
00147         SmfPluginError postAppearence( SmfPluginRequestData &aRequest,
00148                         const SmfPresenceInfo &aAppearence,
00149                         const QString &aStatus );
00150
00160         SmfPluginError sharePost( SmfPluginRequestData &aRequest,
00161                         const SmfPost &aPostData,
00162                         const SmfContact &aContact,
00163                         const bool &aEdited);
00164
00174         SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00175                         const int &aOperation, QByteArray *aData );
00176
00177 public: // From SmfPluginBase interface
00182         void initialize( );
00183
00188         SmfProviderBase* getProviderInfo( );
00189
00207         SmfPluginError responseAvailable(
00208                         const SmfRequestTypeID aOperation,
00209                         const SmfTransportResult &aTransportResult,
00210                         QByteArray *aResponse,
00211                         QVariant* aResult,
00212                         SmfPluginRetType &aRetType,
00213                         SmfResultPage &aPageResult );
00214
00215 private:
00221         QString generateSignature( const QString aBaseString );
00222
00228         SmfPluginError getFacebookUserId( SmfPluginRequestData &aRequest );
00229
00238         SmfPluginError getPosts( SmfPluginRequestData &aRequest,
00239                         const SmfContact *aUser,
00240                         const int aPageNum ,
00241                         const int aItemsPerPage );
00242
00250         void fetchKeys( QString &aApiKey,
00251                         QString &aApiSecret,
00252                         QString &aSessionKey,
00253                         QString &aSessionSecret );
00254
00255 private:
00256         FBProviderBase *m_provider;
00257 };
00258
00259
00263 class FBProviderBase : public QObject, public SmfProviderBase
00264         {
00265         Q_OBJECT
00266         Q_INTERFACES( SmfProviderBase )
00267
00268 public:
00272         virtual ~FBProviderBase( );
00273
00278         QString serviceName( ) const;
00279
00284         QImage serviceIcon( ) const;
00285
00290         QString description( ) const;
00291
00296         QUrl serviceUrl( ) const;
00297
00302         QUrl applicationUrl( ) const;
00303
00308         QImage applicationIcon( ) const;
00309
00314         QList<QString> supportedInterfaces( ) const;
00315
00321         QStringList supportedLanguages( ) const;
00322
00327         QString pluginId( ) const;
00328
00337         QString authenticationApp( QString &aProgram, QStringList & aArguments,
00338                         QIODevice::OpenModeFlag aMode = QIODevice::ReadWrite ) const;
00339
00346         QString smfRegistrationId( ) const;
00347
00348 private:
00353         void initialize();
00354
00355 private:
00356         friend class FBPostProviderPlugin;
00357         QString m_serviceName;
00358         QImage m_serviceIcon;
00359         QString m_description;
00360         QUrl m_serviceUrl;
00361         QUrl m_applicationUrl;
00362         QImage m_applicationIcon;
00363         QString m_pluginId;
00364         QString m_authAppId;
00365         QString m_smfRegToken;
00366         QList<QString> m_supportedInterfaces;
00367         QStringList m_supportedLangs;
00368         QDateTime m_validity;
00369         };
00370
00371 #endif /*_FBPOSTPROVIDERPLUGIN_H*/
Generated on Thu Sep 23 15:03:09 2010 for smf by doxygen 1.6.3


smf: example/flickrcontactfetcherplugin/flickrcontactfetcherplugin.h Source File

  • File List

example/flickrcontactfetcherplugin/flickrcontactfetcherplugin.h

00001
00020 #ifndef _FLICKRCONTACTFETCHERPLUGIN_H
00021 #define _FLICKRCONTACTFETCHERPLUGIN_H
00022
00023 // Include files
00024 #include <QDateTime>
00025 #include <smfcontactfetcherplugin.h>
00026
00027 // Forward declarations
00028 class FlickrProviderBase;
00029 class QVariant;
00030
00031
00035 class FlickrContactFetcherPlugin : public QObject, public SmfContactFetcherPlugin
00036         {
00037         Q_OBJECT
00038         Q_INTERFACES( SmfContactFetcherPlugin SmfPluginBase )
00039
00040 public:
00044         virtual ~FlickrContactFetcherPlugin( );
00045
00046 public: // From SmfContactFetcherPlugin interface
00047
00055         SmfPluginError friends( SmfPluginRequestData &aRequest,
00056                         const int aPageNum = SMF_FIRST_PAGE,
00057                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00058
00066         SmfPluginError followers( SmfPluginRequestData &aRequest,
00067                         const int aPageNum = SMF_FIRST_PAGE,
00068                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00069
00078         SmfPluginError search( SmfPluginRequestData &aRequest,
00079                         const SmfContact &aContact,
00080                         const int aPageNum = SMF_FIRST_PAGE,
00081                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00082
00093         SmfPluginError searchNear( SmfPluginRequestData &aRequest,
00094                         const SmfLocation &aLocation,
00095                         const SmfLocationSearchBoundary &aProximity,
00096                         const int aPageNum = SMF_FIRST_PAGE,
00097                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00098
00106         SmfPluginError groups( SmfPluginRequestData &aRequest,
00107                         const int aPageNum = SMF_FIRST_PAGE,
00108                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00109
00119         SmfPluginError searchInGroup( SmfPluginRequestData &aRequest,
00120                         const SmfGroup &aGroup,
00121                         SmfContact *aContact = NULL,
00122                         const int aPageNum = SMF_FIRST_PAGE,
00123                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00124
00134         SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00135                         const int &aOperation, QByteArray *aData );
00136
00137 public: // From SmfPluginBase interface
00142         void initialize( );
00143
00148         SmfProviderBase* getProviderInfo( );
00149
00167         SmfPluginError responseAvailable(
00168                         const SmfRequestTypeID aOperation,
00169                         const SmfTransportResult &aTransportResult,
00170                         QByteArray *aResponse,
00171                         QVariant* aResult,
00172                         SmfPluginRetType &aRetType,
00173                         SmfResultPage &aPageResult );
00174
00175 private:
00181         QString generateSignature( const QString aBaseString );
00182
00189         void fetchKeys( QString &aApiKey,
00190                         QString &aApiSecret,
00191                         QString &aAuthToken );
00192
00193 private:
00194         FlickrProviderBase *m_provider;
00195         };
00196
00197
00201 class FlickrProviderBase : public QObject, public SmfProviderBase
00202         {
00203         Q_OBJECT
00204         Q_INTERFACES( SmfProviderBase )
00205
00206 public:
00210         virtual ~FlickrProviderBase( );
00211
00216         QString serviceName( ) const;
00217
00222         QImage serviceIcon( ) const;
00223
00228         QString description( ) const;
00229
00234         QUrl serviceUrl( ) const;
00235
00240         QUrl applicationUrl( ) const;
00241
00246         QImage applicationIcon( ) const;
00247
00252         QList<QString> supportedInterfaces( ) const;
00253
00259         QStringList supportedLanguages( ) const;
00260
00265         QString pluginId( ) const;
00266
00275         QString authenticationApp( QString &aProgram, QStringList & aArguments,
00276                         QIODevice::OpenModeFlag aMode = QIODevice::ReadWrite ) const;
00277
00284         QString smfRegistrationId( ) const;
00285
00286 private:
00291         void initialize();
00292
00293 private:
00294         friend class FlickrContactFetcherPlugin;
00295         QString m_serviceName;
00296         QImage m_serviceIcon;
00297         QString m_description;
00298         QUrl m_serviceUrl;
00299         QUrl m_applicationUrl;
00300         QImage m_applicationIcon;
00301         QString m_pluginId;
00302         QString m_authAppId;
00303         QString m_smfRegToken;
00304         QList<QString> m_supportedInterfaces;
00305         QStringList m_supportedLangs;
00306         QDateTime m_validity;
00307         };
00308
00309 #endif /*_FLICKRCONTACTFETCHERPLUGIN_H*/
Generated on Thu Sep 23 15:03:09 2010 for smf by doxygen 1.6.3


smf: example/flickrgalleryplugin/flickrgalleryplugin.h Source File

  • File List

example/flickrgalleryplugin/flickrgalleryplugin.h

00001
00020 #ifndef FLICKRGALLERYPLUGIN_H_
00021 #define FLICKRGALLERYPLUGIN_H_
00022
00023 // Include files
00024 #include <QDateTime>
00025 #include <smfgalleryplugin.h>
00026 #include <smfcontact.h>
00027
00028 // Forward declarations
00029 class FlickrProviderBase;
00030 class QVariant;
00031
00032
00037 class FlickrGalleryPlugin : public QObject, public SmfGalleryPlugin
00038 {
00039         Q_OBJECT
00040         Q_INTERFACES( SmfGalleryPlugin SmfPluginBase )
00041
00042 public:
00046         virtual ~FlickrGalleryPlugin();
00047
00048 public: // From FlickrGalleryPlugin
00049
00059         SmfPluginError albums( SmfPluginRequestData &aRequest,
00060                         const QStringList &aNames,
00061                         const SmfContact *aUser,
00062                         const int aPageNum = SMF_FIRST_PAGE,
00063                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00064
00073         SmfPluginError pictures( SmfPluginRequestData &aRequest,
00074                         const SmfPictureAlbumList &aAlbums,
00075                         const int aPageNum = SMF_FIRST_PAGE,
00076                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00077
00084         SmfPluginError description( SmfPluginRequestData &aRequest,
00085                         const SmfPicture &aImage );
00086
00094         SmfPluginError upload( SmfPluginRequestData &aRequest,
00095                         const SmfPicture &aImage,
00096                         const SmfPictureAlbum* aAlbum = NULL );
00097
00098
00106         SmfPluginError upload( SmfPluginRequestData &aRequest,
00107                         const QList<SmfPicture> &aImages,
00108                         const SmfPictureAlbum* aAlbum = NULL );
00109
00117         SmfPluginError postComment( SmfPluginRequestData &aRequest,
00118                          const SmfPicture &aImage,
00119                          const SmfComment &aComment );
00120
00121
00131         SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00132                         const int &aOperation,
00133                         QByteArray *aData );
00134
00135 public: // From SmfPluginBase
00140         void initialize( );
00141
00146         SmfProviderBase* getProviderInfo( );
00147
00166         SmfPluginError responseAvailable(
00167                         const SmfRequestTypeID aOperation,
00168                         const SmfTransportResult &aTransportResult,
00169                         QByteArray *aResponse,
00170                         QVariant* aResult,
00171                         SmfPluginRetType &aRetType,
00172                         SmfResultPage &aPageResult );
00173
00182         QByteArray constructField( const QString &aName,
00183                         const QString &aContent,
00184                         const QByteArray &aBoundary,
00185                         const QString &aFilename = QString() );
00186
00187 private:
00193         QString generateSignature( const QString aBaseString );
00194
00201         void fetchKeys( QString &aApiKey,
00202                         QString &aApiSecret,
00203                         QString &aAuthToken );
00204
00205 private:
00206         FlickrProviderBase *m_provider;
00207
00208         };
00209
00213 class FlickrProviderBase : public QObject, public SmfProviderBase
00214         {
00215         Q_OBJECT
00216         Q_INTERFACES( SmfProviderBase )
00217
00218 public:
00219         virtual ~FlickrProviderBase( );
00220
00225         QString serviceName( ) const;
00226
00231         QImage serviceIcon( ) const;
00232
00237         QString description( ) const;
00238
00243         QUrl serviceUrl( ) const;
00244
00249         QUrl applicationUrl( ) const;
00250
00255         QImage applicationIcon( ) const;
00256
00261         QList<QString> supportedInterfaces( ) const;
00262
00268         QStringList supportedLanguages( ) const;
00269
00274         QString pluginId( ) const;
00275
00284         QString authenticationApp( QString &aProgram, QStringList & aArguments,
00285                         QIODevice::OpenModeFlag aMode = QIODevice::ReadWrite ) const;
00286
00293         QString smfRegistrationId( ) const;
00294
00295 private:
00296         friend class FlickrGalleryPlugin;
00297         void initialize();
00298         QString m_serviceName;
00299         QImage m_serviceIcon;
00300         QString m_description;
00301         QUrl m_serviceUrl;
00302         QUrl m_applicationUrl;
00303         QImage m_applicationIcon;
00304         QString m_pluginId;
00305         QString m_authAppId;
00306         QString m_smfRegToken;
00307         QList<QString> m_supportedInterfaces;
00308         QStringList m_supportedLangs;
00309         QDateTime m_validity;
00310         };
00311
00312
00313 #endif /* FLICKRGALLERYPLUGIN_H_ */
Generated on Thu Sep 23 15:03:09 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/src/json_parser.hh Source File

  • File List

smf/smfservermodule/util/qjson/src/json_parser.hh

00001 /* A Bison parser, made by GNU Bison 2.3.  */
00002
00003 /* Skeleton interface for Bison LALR(1) parsers in C++
00004
00005    Copyright (C) 2002, 2003, 2004, 2005, 2006 Free Software Foundation, Inc.
00006
00007    This program is free software; you can redistribute it and/or modify
00008    it under the terms of the GNU General Public License as published by
00009    the Free Software Foundation; either version 2, or (at your option)
00010    any later version.
00011
00012    This program is distributed in the hope that it will be useful,
00013    but WITHOUT ANY WARRANTY; without even the implied warranty of
00014    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00015    GNU General Public License for more details.
00016
00017    You should have received a copy of the GNU General Public License
00018    along with this program; if not, write to the Free Software
00019    Foundation, Inc., 51 Franklin Street, Fifth Floor,
00020    Boston, MA 02110-1301, USA.  */
00021
00022 /* As a special exception, you may create a larger work that contains
00023    part or all of the Bison parser skeleton and distribute that work
00024    under terms of your choice, so long as that work isn't itself a
00025    parser generator using the skeleton or a modified version thereof
00026    as a parser skeleton.  Alternatively, if you modify or redistribute
00027    the parser skeleton itself, you may (at your option) remove this
00028    special exception, which will cause the skeleton and the resulting
00029    Bison output files to be licensed under the GNU General Public
00030    License without this special exception.
00031
00032    This special exception was added by the Free Software Foundation in
00033    version 2.2 of Bison.  */
00034
00035 /* C++ LALR(1) parser skeleton written by Akim Demaille.  */
00036
00037 #ifndef PARSER_HEADER_H
00038 # define PARSER_HEADER_H
00039
00040 #include <string>
00041 #include <iostream>
00042 #include "stack.hh"
00043
00044 namespace yy
00045 {
00046   class position;
00047   class location;
00048 }
00049
00050 /* First part of user declarations.  */
00051 #line 25 "json_parser.yy"
00052
00053   #include "parser_p.h"
00054   #include "json_scanner.h"
00055   #include "qjson_debug.h"
00056
00057   #include <QtCore/QByteArray>
00058   #include <QtCore/QMap>
00059   #include <QtCore/QString>
00060   #include <QtCore/QVariant>
00061
00062   class JSonScanner;
00063
00064   namespace QJson {
00065     class Parser;
00066   }
00067
00068   #define YYERROR_VERBOSE 1
00069
00070
00071 /* Line 303 of lalr1.cc.  */
00072 #line 73 "json_parser.hh"
00073
00074 #include "location.hh"
00075
00076 /* Enabling traces.  */
00077 #ifndef YYDEBUG
00078 # define YYDEBUG 1
00079 #endif
00080
00081 /* Enabling verbose error messages.  */
00082 #ifdef YYERROR_VERBOSE
00083 # undef YYERROR_VERBOSE
00084 # define YYERROR_VERBOSE 1
00085 #else
00086 # define YYERROR_VERBOSE 1
00087 #endif
00088
00089 /* Enabling the token table.  */
00090 #ifndef YYTOKEN_TABLE
00091 # define YYTOKEN_TABLE 0
00092 #endif
00093
00094 /* YYLLOC_DEFAULT -- Set CURRENT to span from RHS[1] to RHS[N].
00095    If N is 0, then set CURRENT to the empty location which ends
00096    the previous symbol: RHS[0] (always defined).  */
00097
00098 #ifndef YYLLOC_DEFAULT
00099 # define YYLLOC_DEFAULT(Current, Rhs, N)                \
00100 do {                                                    \
00101   if (N)                                                \
00102     {                                                   \
00103       (Current).begin = (Rhs)[1].begin;                 \
00104       (Current).end   = (Rhs)[N].end;                   \
00105     }                                                   \
00106   else                                                  \
00107     {                                                   \
00108       (Current).begin = (Current).end = (Rhs)[0].end;   \
00109     }                                                   \
00110 } while (false)
00111 #endif
00112
00113 namespace yy
00114 {
00115
00117   class json_parser
00118   {
00119   public:
00121 #ifndef YYSTYPE
00122     typedef int semantic_type;
00123 #else
00124     typedef YYSTYPE semantic_type;
00125 #endif
00126
00127     typedef location location_type;
00129     struct token
00130     {
00131       /* Tokens.  */
00132    enum yytokentype {
00133      END = 0,
00134      CURLY_BRACKET_OPEN = 1,
00135      CURLY_BRACKET_CLOSE = 2,
00136      SQUARE_BRACKET_OPEN = 3,
00137      SQUARE_BRACKET_CLOSE = 4,
00138      COLON = 5,
00139      COMMA = 6,
00140      MINUS = 7,
00141      DOT = 8,
00142      DIGIT = 9,
00143      E = 10,
00144      TRUE_VAL = 11,
00145      FALSE_VAL = 12,
00146      NULL_VAL = 13,
00147      QUOTMARKOPEN = 14,
00148      QUOTMARKCLOSE = 15,
00149      STRING = 16
00150    };
00151
00152     };
00154     typedef token::yytokentype token_type;
00155
00157     json_parser (QJson::ParserPrivate* driver_yyarg);
00158     virtual ~json_parser ();
00159
00162     virtual int parse ();
00163
00165     std::ostream& debug_stream () const;
00167     void set_debug_stream (std::ostream &);
00168
00170     typedef int debug_level_type;
00172     debug_level_type debug_level () const;
00174     void set_debug_level (debug_level_type l);
00175
00176   private:
00180     virtual void error (const location_type& loc, const std::string& msg);
00181
00185     virtual std::string yysyntax_error_ (int yystate, int tok);
00186
00187 #if YYDEBUG
00188
00189
00190
00191
00192     virtual void yy_symbol_value_print_ (int yytype,
00193                                          const semantic_type* yyvaluep,
00194                                          const location_type* yylocationp);
00199     virtual void yy_symbol_print_ (int yytype,
00200                                    const semantic_type* yyvaluep,
00201                                    const location_type* yylocationp);
00202 #endif /* ! YYDEBUG */
00203
00204
00206     typedef int state_type;
00208     typedef stack<state_type>    state_stack_type;
00210     typedef stack<semantic_type> semantic_stack_type;
00212     typedef stack<location_type> location_stack_type;
00213
00215     state_stack_type yystate_stack_;
00217     semantic_stack_type yysemantic_stack_;
00219     location_stack_type yylocation_stack_;
00220
00222     typedef unsigned char token_number_type;
00223     /* Tables.  */
00225     static const signed char yypact_[];
00226     static const signed char yypact_ninf_;
00227
00231     static const unsigned char yydefact_[];
00232
00233     static const signed char yypgoto_[];
00234     static const signed char yydefgoto_[];
00235
00241     static const unsigned char yytable_[];
00242     static const signed char yytable_ninf_;
00243
00244     static const unsigned char yycheck_[];
00245
00247     static const unsigned char yystos_[];
00248
00250     static const unsigned char yyr1_[];
00252     static const unsigned char yyr2_[];
00253
00254 #if YYDEBUG || YYERROR_VERBOSE || YYTOKEN_TABLE
00255
00256     static const char* const yytname_[];
00257 #endif
00258
00259 #if YYERROR_VERBOSE
00260
00261     virtual std::string yytnamerr_ (const char *n);
00262 #endif
00263
00264 #if YYDEBUG
00265
00266     typedef signed char rhs_number_type;
00268     static const rhs_number_type yyrhs_[];
00270     static const unsigned char yyprhs_[];
00272     static const unsigned char yyrline_[];
00274     static const unsigned short int yytoken_number_[];
00276     virtual void yy_reduce_print_ (int r);
00278     virtual void yystack_print_ ();
00279 #endif
00280
00282     token_number_type yytranslate_ (int t);
00283
00289     inline void yydestruct_ (const char* yymsg,
00290                              int yytype,
00291                              semantic_type* yyvaluep,
00292                              location_type* yylocationp);
00293
00295     inline void yypop_ (unsigned int n = 1);
00296
00297     /* Constants.  */
00298     static const int yyeof_;
00299     /* LAST_ -- Last index in TABLE_.  */
00300     static const int yylast_;
00301     static const int yynnts_;
00302     static const int yyempty_;
00303     static const int yyfinal_;
00304     static const int yyterror_;
00305     static const int yyerrcode_;
00306     static const int yyntokens_;
00307     static const unsigned int yyuser_token_number_max_;
00308     static const token_number_type yyundef_token_;
00309
00310     /* Debugging.  */
00311     int yydebug_;
00312     std::ostream* yycdebug_;
00313
00314
00315     /* User arguments.  */
00316     QJson::ParserPrivate* driver;
00317   };
00318 }
00319
00320
00321 #endif /* ! defined PARSER_HEADER_H */
Generated on Thu Sep 23 15:03:16 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/src/json_scanner.h Source File

  • File List

smf/smfservermodule/util/qjson/src/json_scanner.h

00001 /* This file is part of QJson
00002  *
00003  * Copyright (C) 2008 Flavio Castelli <flavio.castelli@gmail.com>
00004  *
00005  * This library is free software; you can redistribute it and/or
00006  * modify it under the terms of the GNU Library General Public
00007  * License as published by the Free Software Foundation; either
00008  * version 2 of the License, or (at your option) any later version.
00009  *
00010  * This library is distributed in the hope that it will be useful,
00011  * but WITHOUT ANY WARRANTY; without even the implied warranty of
00012  * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00013  * Library General Public License for more details.
00014  *
00015  * You should have received a copy of the GNU Library General Public License
00016  * along with this library; see the file COPYING.LIB.  If not, write to
00017  * the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
00018  * Boston, MA 02110-1301, USA.
00019  */
00020
00021 #ifndef _JSON_SCANNER
00022 #define _JSON_SCANNER
00023
00024 #include <fstream>
00025 #include <string>
00026
00027 #include <QtCore/QIODevice>
00028 #include <QtCore/QVariant>
00029
00030 #define YYSTYPE QVariant
00031
00032 #include "parser_p.h"
00033
00034 namespace yy {
00035   class location;
00036   int yylex(YYSTYPE *yylval, yy::location *yylloc, QJson::ParserPrivate* driver);
00037 }
00038
00039 class JSonScanner
00040 {
00041     public:
00042         explicit JSonScanner(QIODevice* io);
00043         int yylex(YYSTYPE* yylval, yy::location *yylloc);
00044
00045     protected:
00046         bool m_quotmarkClosed;
00047         unsigned int m_quotmarkCount;
00048         QIODevice* m_io;
00049 };
00050
00051 #endif
00052
Generated on Thu Sep 23 15:03:16 2010 for smf by doxygen 1.6.3


smf: example/lastfmmusiceventplugin/lastfmmusiceventplugin.h Source File

  • File List

example/lastfmmusiceventplugin/lastfmmusiceventplugin.h

00001 /*
00002  * lastfmmusiceventplugin.h
00003  *
00004  *  Created on: Jun 21, 2010
00005  *      Author: ankitg
00006  */
00007
00008 #ifndef LASTFMMUSICEVENTPLUGIN_H_
00009 #define LASTFMMUSICEVENTPLUGIN_H_
00010
00011 // Include files
00012 #include "smfeventsfetcherplugin.h"
00013 #include "smfpluginutil.h"
00014
00015 #include <parser.h>
00016
00017 // Forward declarations
00018 class MusicProviderBase;
00019 class QVariant;
00020 class QNetworkReply;
00021
00022 // Class declaration
00023 class MusicEventPlugin : public QObject, public SmfEventsFetcherPlugin
00024 {
00025         Q_OBJECT
00026         Q_INTERFACES( SmfEventsFetcherPlugin SmfPluginBase )
00027
00028 public:
00029         virtual ~MusicEventPlugin();
00030
00031 public: // From SmfMusicEventsPlugin
00032
00041                 /*SmfPluginError events( SmfPluginRequestData &aRequest,
00042                                 const QGeoPositionInfo &aLocation,
00043                                 const int aPageNum = SMF_FIRST_PAGE,
00044                                 const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00045                 */
00046
00055         void  fetchKeys( QString &aApiKey,
00056                         QString &aApiSecret,
00057                         QString &aSessionKey,
00058                         QString &aSessionSecret );
00059                 SmfPluginError venues( SmfPluginRequestData &aRequest,
00060                                 const SmfLocation &aLocation,
00061                                 const int aPageNum = SMF_FIRST_PAGE,
00062                                 const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00063
00072                 SmfPluginError events( SmfPluginRequestData &aRequest,
00073                                 const SmfLocation &aVenue,
00074                                 const int aPageNum = SMF_FIRST_PAGE,
00075                                 const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00076
00083                 SmfPluginError postEvents( SmfPluginRequestData &aRequest,
00084                                 const QList<SmfEvent> &aEventList );
00085
00086
00087                 /*** Method to get the list of attendees for a musical event
00088                                                  * @param aRequest [out] The request data to be sent to network
00089                                                  * @param aEvent The event for which attendees should be fetched
00090                                                  * @param aPageNum The page to be extracted
00091                                                  * @param aItemsPerPage Number of items per page
00092                                                  * @return SmfPluginError Plugin error if any, else SmfPluginErrNone
00093                                                  */
00094                 SmfPluginError attendees( SmfPluginRequestData &aRequest,
00095                                 const SmfEvent &aEvent,
00096                                 const int aPageNum = SMF_FIRST_PAGE,
00097                                 const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00098
00108                 SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00109                                 const int &aOperation, QByteArray *aData );
00110
00111
00112
00113
00114 public: // From SmfPluginBase
00121              void initialize(/*SmfPluginUtil *aUtil*/);
00122
00127             SmfProviderBase* getProviderInfo( );
00128
00143         /*      SmfPluginError responseAvailable(
00144                         const SmfTransportResult &aTransportResult,
00145                         QNetworkReply *aReply,
00146                         QVariant* aResult,
00147                         SmfPluginRetType &aRetType,
00148                         SmfResultPage &aPageResult );*/
00149         SmfPluginError responseAvailable(
00150                         const SmfRequestTypeID aOperation,
00151                         const SmfTransportResult &aTransportResult,
00152                         QByteArray *aResponse,
00153                         QVariant* aResult,
00154                         SmfPluginRetType &aRetType,
00155                         SmfResultPage &aPageResult );
00156
00157              void writeLog(QString log) const;
00158
00159
00160 private:
00161
00162       QString generateSignature(const QString aBaseString);
00163
00164
00165 private slots:
00166
00167
00168
00169 private:
00181            SmfPluginError createRequest( SmfPluginRequestData &aRequest,
00182                         const QNetworkAccessManager::Operation aOperation,
00183                         const SmfSignatureMethod aSignatureMethod,
00184                         QMultiMap<QByteArray, QByteArray> &aParams,
00185                         const SmfParsingMode aMode,
00186                         QBuffer *aPostData );
00187
00188 private:
00189            MusicProviderBase *m_provider;
00190            SmfPluginUtil *m_util;
00191 };
00192
00193 // Class declaration
00194 class MusicProviderBase : public QObject, public SmfProviderBase
00195         {
00196          Q_OBJECT
00197          Q_INTERFACES( SmfProviderBase )
00198
00199 public:
00200         virtual ~MusicProviderBase( );
00201
00206         QString serviceName( ) const;
00207
00212         QImage serviceIcon( ) const;
00213
00218         QString description( ) const;
00219
00224         QUrl serviceUrl( ) const;
00225
00230         QUrl applicationUrl( ) const;
00231
00236         QImage applicationIcon( ) const;
00237
00242         QList<QString> supportedInterfaces( ) const;
00243
00249         QStringList supportedLanguages( ) const;
00250
00255         QString pluginId( ) const;
00256
00265         QString authenticationApp( QString &aProgram, QStringList & aArguments,
00266                         QIODevice::OpenModeFlag aMode = QIODevice::ReadWrite ) const;
00267
00274         QString smfRegistrationId( ) const;
00275
00276 private:
00277         friend class MusicEventPlugin;
00278         void initialize();
00279         QString m_serviceName;
00280         QImage m_serviceIcon;
00281         QString m_description;
00282         QUrl m_serviceUrl;
00283         QUrl m_applicationUrl;
00284         QImage m_applicationIcon;
00285         QStringList m_serviceType;
00286         QStringList m_supportedLanguages;
00287         QString m_pluginId;
00288         QString m_authAppId;
00289         QString m_smfRegToken;
00290         QDateTime m_validity;
00291         };
00292 #endif /* LASTFMMUSICEVENTPLUGIN_H_ */
Generated on Thu Sep 23 15:03:09 2010 for smf by doxygen 1.6.3


smf: example/lastfmmusicsearchplugin/lastfmmusicsearchplugin.h Source File

  • File List

example/lastfmmusicsearchplugin/lastfmmusicsearchplugin.h

00001
00020 #ifndef _LASTFMMUSICSEARCHPLUGIN_H
00021 #define _LASTFMMUSICSEARCHPLUGIN_H
00022
00023 // Include files
00024 #include <smfmusicsearchplugin.h>
00025
00026 // Class declaration
00027 class LastFmMusicSearchProviderBase;
00028 class QVariant;
00029
00033 class LastFmMusicSearchPlugin : public QObject, public SmfMusicSearchPlugin
00034         {
00035         Q_OBJECT
00036         Q_INTERFACES( SmfMusicSearchPlugin SmfPluginBase )
00037
00038 public:
00042         virtual ~LastFmMusicSearchPlugin ( );
00043
00044 public: // From SmfMusicSearchPlugin interface
00054         SmfPluginError recommendations( SmfPluginRequestData &aRequest,
00055                         const SmfTrackInfo &aTrack,
00056                         const int aPageNum = SMF_FIRST_PAGE,
00057                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00058
00068         SmfPluginError tracksSimilar( SmfPluginRequestData &aRequest,
00069                         const SmfTrackInfo &aTrack,
00070                         const int aPageNum = SMF_FIRST_PAGE,
00071                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00072
00081         SmfPluginError tracksOfAlbum( SmfPluginRequestData &aRequest,
00082                         const SmfAlbum &aAlbum,
00083                         const int aPageNum = SMF_FIRST_PAGE,
00084                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00085
00094         SmfPluginError tracksOfArtist( SmfPluginRequestData &aRequest,
00095                         const SmfArtists &aArtist,
00096                         const int aPageNum = SMF_FIRST_PAGE,
00097                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00098
00108         SmfPluginError trackInfo( SmfPluginRequestData &aRequest,
00109                         const SmfMusicFingerPrint &aSignature,
00110                         const int aPageNum = SMF_FIRST_PAGE,
00111                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00112
00121         SmfPluginError stores( SmfPluginRequestData &aRequest,
00122                         const SmfTrackInfo &aTrack,
00123                         const int aPageNum = SMF_FIRST_PAGE,
00124                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00125
00135         SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00136                         const int &aOperation, QByteArray *aData );
00137
00138 public: // From SmfPluginBase interface
00143         void initialize( );
00144
00149         SmfProviderBase* getProviderInfo( );
00150
00168         SmfPluginError responseAvailable(
00169                         const SmfRequestTypeID aOperation,
00170                         const SmfTransportResult &aTransportResult,
00171                         QByteArray *aResponse,
00172                         QVariant* aResult,
00173                         SmfPluginRetType &aRetType,
00174                         SmfResultPage &aPageResult );
00175
00176 private:
00182         QString generateSignature(const QString aBaseString);
00183
00191         void fetchKeys( QString &aApiKey,
00192                         QString &aApiSecret,
00193                         QString &aToken );
00194
00201         SmfPluginError getAlbumId( SmfPluginRequestData &aRequest,
00202                         const SmfAlbum &aAlbum );
00209         SmfPluginError getTracksOfAlbum( SmfPluginRequestData &aRequest,
00210                         const SmfAlbum &aAlbum );
00211
00216         QString currentCountryName() const;
00217
00218 private: // Data
00219         LastFmMusicSearchProviderBase *m_provider;
00220         };
00221
00222
00223
00227 class LastFmMusicSearchProviderBase : public QObject, public SmfProviderBase
00228         {
00229         Q_OBJECT
00230         Q_INTERFACES( SmfProviderBase )
00231
00232 public:
00236         virtual ~LastFmMusicSearchProviderBase( );
00237
00242         QString serviceName( ) const;
00243
00248         QImage serviceIcon( ) const;
00249
00254         QString description( ) const;
00255
00260         QUrl serviceUrl( ) const;
00261
00266         QUrl applicationUrl( ) const;
00267
00272         QImage applicationIcon( ) const;
00273
00278         QList<QString> supportedInterfaces( ) const;
00279
00285         QStringList supportedLanguages( ) const;
00286
00291         QString pluginId( ) const;
00292
00301         QString authenticationApp( QString &aProgram, QStringList & aArguments,
00302                         QIODevice::OpenModeFlag aMode = QIODevice::ReadWrite ) const;
00303
00310         QString smfRegistrationId( ) const;
00311
00312 private:
00317         void initialize();
00318
00319 private:
00320         friend class LastFmMusicSearchPlugin;
00321         QString m_serviceName;
00322         QImage m_serviceIcon;
00323         QString m_description;
00324         QUrl m_serviceUrl;
00325         QUrl m_applicationUrl;
00326         QImage m_applicationIcon;
00327         QString m_pluginId;
00328         QString m_authAppId;
00329         QString m_smfRegToken;
00330         QList<QString> m_supportedInterfaces;
00331         QStringList m_supportedLangs;
00332         QDateTime m_validity;
00333         };
00334
00335 #endif //_LASTFMMUSICSEARCHPLUGIN_H
Generated on Thu Sep 23 15:03:09 2010 for smf by doxygen 1.6.3


smf: example/lastfmmusicserviceplugin/lastfmmusicserviceplugin.h Source File

  • File List

example/lastfmmusicserviceplugin/lastfmmusicserviceplugin.h

00001
00020 #ifndef _LASTFMMUSICSERVICEPLUGIN_H
00021 #define _LASTFMMUSICSERVICEPLUGIN_H
00022
00023 // Include files
00024 #include <smfmusicserviceplugin.h>
00025
00026 // Class declaration
00027 class LastFmMusicServiceProviderBase;
00028 class QVariant;
00029
00033 class LastFmMusicServicePlugin : public QObject, public SmfMusicServicePlugin
00034         {
00035         Q_OBJECT
00036         Q_INTERFACES( SmfMusicServicePlugin SmfPluginBase )
00037
00038 public:
00042         virtual ~LastFmMusicServicePlugin ( );
00043
00044 public: // From SmfMusicServicePlugin interface
00051         SmfPluginError userMusicInfo( SmfPluginRequestData &aRequest );
00052
00063         SmfPluginError searchArtist( SmfPluginRequestData &aRequest,
00064                         const SmfArtists &aArtist,
00065                         const int aPageNum = SMF_FIRST_PAGE,
00066                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00067
00078         SmfPluginError searchAlbum( SmfPluginRequestData &aRequest,
00079                         const SmfAlbum &aAlbum,
00080                         const int aPageNum = SMF_FIRST_PAGE,
00081                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00082
00093         SmfPluginError searchEvents( SmfPluginRequestData &aRequest,
00094                         const SmfEvent &aEvent,
00095                         const int aPageNum = SMF_FIRST_PAGE,
00096                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00097
00108         SmfPluginError searchVenue( SmfPluginRequestData &aRequest,
00109                         const SmfLocation &aVenue,
00110                         const int aPageNum = SMF_FIRST_PAGE,
00111                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00112
00123         SmfPluginError searchUser( SmfPluginRequestData &aRequest,
00124                         const SmfLocation &aPlace,
00125                         const int aPageNum = SMF_FIRST_PAGE,
00126                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00127
00135         SmfPluginError postCurrentPlaying(
00136                         SmfPluginRequestData &aRequest,
00137                         const SmfTrackInfo &aTrack );
00138
00147         SmfPluginError postRating(
00148                         SmfPluginRequestData &aRequest,
00149                         const SmfTrackInfo &aTrack,
00150                         const SmfMusicRating &aRating );
00151
00160         SmfPluginError postComments(
00161                         SmfPluginRequestData &aRequest,
00162                         const SmfTrackInfo &aTrack,
00163                         const SmfComment &aComment );
00164
00175         SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00176                         const int &aOperation, QByteArray *aData );
00177
00178
00179 public: // From SmfPluginBase interface
00184         void initialize( );
00185
00190         SmfProviderBase* getProviderInfo( );
00191
00214         SmfPluginError responseAvailable(
00215                         const SmfRequestTypeID aOperation,
00216                         const SmfTransportResult &aTransportResult,
00217                         QByteArray *aResponse,
00218                         QVariant* aResult,
00219                         SmfPluginRetType &aRetType,
00220                         SmfResultPage &aPageResult );
00221
00222 private:
00228         QString generateSignature(const QString aBaseString);
00229
00238         void fetchKeys( QString &aApiKey,
00239                         QString &aApiSecret,
00240                         QString &aToken,
00241                         QString &aName );
00242
00243 private: // Data
00244         LastFmMusicServiceProviderBase *m_provider;
00245         };
00246
00247
00248
00252 class LastFmMusicServiceProviderBase : public QObject, public SmfProviderBase
00253         {
00254         Q_OBJECT
00255         Q_INTERFACES( SmfProviderBase )
00256
00257 public:
00261         virtual ~LastFmMusicServiceProviderBase( );
00262
00267         QString serviceName( ) const;
00268
00273         QImage serviceIcon( ) const;
00274
00279         QString description( ) const;
00280
00285         QUrl serviceUrl( ) const;
00286
00291         QUrl applicationUrl( ) const;
00292
00297         QImage applicationIcon( ) const;
00298
00303         QList<QString> supportedInterfaces( ) const;
00304
00310         QStringList supportedLanguages( ) const;
00311
00316         QString pluginId( ) const;
00317
00326         QString authenticationApp( QString &aProgram, QStringList & aArguments,
00327                         QIODevice::OpenModeFlag aMode = QIODevice::ReadWrite ) const;
00328
00335         QString smfRegistrationId( ) const;
00336
00337 private:
00342         void initialize();
00343
00344 private:
00345         friend class LastFmMusicServicePlugin;
00346         QString m_serviceName;
00347         QImage m_serviceIcon;
00348         QString m_description;
00349         QUrl m_serviceUrl;
00350         QUrl m_applicationUrl;
00351         QImage m_applicationIcon;
00352         QString m_pluginId;
00353         QString m_authAppId;
00354         QString m_smfRegToken;
00355         QList<QString> m_supportedInterfaces;
00356         QStringList m_supportedLangs;
00357         QDateTime m_validity;
00358         };
00359
00360 #endif //_LASTFMMUSICSERVICEPLUGIN_H
Generated on Thu Sep 23 15:03:09 2010 for smf by doxygen 1.6.3


smf: example/lastfmplaylistserviceplugin/lastfmplaylistserviceplugin.h Source File

  • File List

example/lastfmplaylistserviceplugin/lastfmplaylistserviceplugin.h

00001
00021 #ifndef _LASTFMPLAYLISTSERVICEPLUGIN_H_
00022 #define _LASTFMPLAYLISTSERVICEPLUGIN_H_
00023
00024 //Include files
00025 #include <smfplaylistserviceplugin.h>
00026
00027 // Forward declarations
00028 class LastFmPlaylistServiceProviderBase;
00029 class QVariant;
00030
00031 // Class declaration
00032 class LastFmPlaylistServicePlugin : public QObject, public SmfPlaylistServicePlugin
00033 {
00034         Q_OBJECT
00035         Q_INTERFACES( SmfPlaylistServicePlugin SmfPluginBase )
00036
00037 public:
00041         virtual ~LastFmPlaylistServicePlugin ( );
00042
00043 public: // From SmfPlaylistServicePlugin
00052         SmfPluginError playlists( SmfPluginRequestData &aRequest,
00053                         const int aPageNum = SMF_FIRST_PAGE,
00054                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00055
00065         SmfPluginError playlistsOf( SmfPluginRequestData &aRequest,
00066                         const SmfContact &aUser,
00067                         const int aPageNum = SMF_FIRST_PAGE,
00068                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00069
00078         SmfPluginError addToPlaylist( SmfPluginRequestData &aRequest,
00079                         const SmfPlaylist &aPlaylist,
00080                         const QList<SmfTrackInfo> &aTracks );
00081
00089         SmfPluginError postCurrentPlayingPlaylist(
00090                         SmfPluginRequestData &aRequest,
00091                         const SmfPlaylist &aPlaylist );
00092
00103         SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00104                         const int &aOperation, QByteArray *aData );
00105
00106 public: // From SmfPluginBase interface
00111         void initialize( );
00112
00117         SmfProviderBase* getProviderInfo( );
00118
00141         SmfPluginError responseAvailable(
00142                         const SmfRequestTypeID aOperation,
00143                         const SmfTransportResult &aTransportResult,
00144                         QByteArray *aResponse,
00145                         QVariant* aResult,
00146                         SmfPluginRetType &aRetType,
00147                         SmfResultPage &aPageResult );
00148
00149 private:
00155         QString generateSignature( const QString aBaseString );
00156
00165         void fetchKeys( QString &aApiKey,
00166                         QString &aApiSecret,
00167                         QString &aToken,
00168                         QString &aName );
00169
00170 private:
00171         LastFmPlaylistServiceProviderBase *m_provider;
00172         };
00173
00177 class LastFmPlaylistServiceProviderBase : public QObject, public SmfProviderBase
00178         {
00179         Q_OBJECT
00180         Q_INTERFACES( SmfProviderBase )
00181
00182 public:
00186         virtual ~LastFmPlaylistServiceProviderBase( );
00187
00192         QString serviceName( ) const;
00193
00198         QImage serviceIcon( ) const;
00199
00204         QString description( ) const;
00205
00210         QUrl serviceUrl( ) const;
00211
00216         QUrl applicationUrl( ) const;
00217
00222         QImage applicationIcon( ) const;
00223
00228         QList<QString> supportedInterfaces( ) const;
00229
00235         QStringList supportedLanguages( ) const;
00236
00241         QString pluginId( ) const;
00242
00251         QString authenticationApp( QString &aProgram, QStringList & aArguments,
00252                         QIODevice::OpenModeFlag aMode = QIODevice::ReadWrite ) const;
00253
00260         QString smfRegistrationId( ) const;
00261
00262 private:
00267         void initialize();
00268
00269 private:
00270         friend class LastFmPlaylistServicePlugin;
00271         QString m_serviceName;
00272         QImage m_serviceIcon;
00273         QString m_description;
00274         QUrl m_serviceUrl;
00275         QUrl m_applicationUrl;
00276         QImage m_applicationIcon;
00277         QString m_pluginId;
00278         QString m_authAppId;
00279         QString m_smfRegToken;
00280         QList<QString> m_supportedInterfaces;
00281         QStringList m_supportedLangs;
00282         QDateTime m_validity;
00283         };
00284
00285 #endif /* _LASTFMPLAYLISTSERVICEPLUGIN_H_ */
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: example/DemoGUI/mainwindow.h Source File

  • File List

example/DemoGUI/mainwindow.h

00001 #ifndef MAINWINDOW_H
00002 #define MAINWINDOW_H
00003
00004 #include <QMainWindow>
00005 #include "HomeView.h"
00006
00007 namespace Ui {
00008     class MainWindow;
00009 }
00010
00011 class MainWindow : public QMainWindow {
00012     Q_OBJECT
00013 public:
00014     MainWindow(QWidget *parent = 0);
00015     ~MainWindow();
00016
00017 protected:
00018     void changeEvent(QEvent *e);
00019
00020 private:
00021     Ui::MainWindow *ui;
00022     HomeView* Ptr2HomeView;
00023 };
00024
00025 #endif // MAINWINDOW_H
Generated on Thu Sep 23 15:03:08 2010 for smf by doxygen 1.6.3


smf: Page Index

Related Pages

Here is a list of all related documentation pages:
  • Todo List
Generated on Thu Sep 23 15:03:07 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/src/parser.h Source File

  • File List

smf/smfservermodule/util/qjson/src/parser.h

00001 /* This file is part of QJson
00002  *
00003  * Copyright (C) 2008 Flavio Castelli <flavio.castelli@gmail.com>
00004  *
00005  * This library is free software; you can redistribute it and/or
00006  * modify it under the terms of the GNU Library General Public
00007  * License as published by the Free Software Foundation; either
00008  * version 2 of the License, or (at your option) any later version.
00009  *
00010  * This library is distributed in the hope that it will be useful,
00011  * but WITHOUT ANY WARRANTY; without even the implied warranty of
00012  * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00013  * Library General Public License for more details.
00014  *
00015  * You should have received a copy of the GNU Library General Public License
00016  * along with this library; see the file COPYING.LIB.  If not, write to
00017  * the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
00018  * Boston, MA 02110-1301, USA.
00019  */
00020
00021 #ifndef QJSON_PARSER_H
00022 #define QJSON_PARSER_H
00023
00024 #include "qjson_export.h"
00025
00026 class QIODevice;
00027 class QVariant;
00028
00029 namespace QJson {
00030
00031   class ParserPrivate;
00032
00036   class QJSON_EXPORT Parser
00037   {
00038     public:
00039       Parser();
00040       ~Parser();
00041
00048       QVariant parse(QIODevice* io, bool* ok = 0);
00049
00058       QVariant parse(const QByteArray& jsonData, bool* ok = 0);
00059
00065       QString errorString() const;
00066
00072       int errorLine() const;
00073
00074     private:
00075       Q_DISABLE_COPY(Parser)
00076       ParserPrivate* const d;
00077   };
00078 }
00079
00080 #endif // QJSON_PARSER_H
Generated on Thu Sep 23 15:03:16 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/src/parser_p.h Source File

  • File List

smf/smfservermodule/util/qjson/src/parser_p.h

00001 /* This file is part of QJson
00002  *
00003  * Copyright (C) 2008 Flavio Castelli <flavio.castelli@gmail.com>
00004  * Copyright (C) 2009 Michael Leupold <lemma@confuego.org>
00005  *
00006  * This library is free software; you can redistribute it and/or
00007  * modify it under the terms of the GNU Library General Public
00008  * License as published by the Free Software Foundation; either
00009  * version 2 of the License, or (at your option) any later version.
00010  *
00011  * This library is distributed in the hope that it will be useful,
00012  * but WITHOUT ANY WARRANTY; without even the implied warranty of
00013  * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00014  * Library General Public License for more details.
00015  *
00016  * You should have received a copy of the GNU Library General Public License
00017  * along with this library; see the file COPYING.LIB.  If not, write to
00018  * the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
00019  * Boston, MA 02110-1301, USA.
00020  */
00021
00022 #ifndef QJSON_PARSER_P_H
00023 #define QJSON_PARSER_P_H
00024
00025 #include "parser.h"
00026
00027 #include <QtCore/QString>
00028 #include <QtCore/QVariant>
00029
00030 class JSonScanner;
00031
00032 namespace yy {
00033   class json_parser;
00034 }
00035
00036 namespace QJson {
00037
00038   class ParserPrivate
00039   {
00040     public:
00041       ParserPrivate();
00042       ~ParserPrivate();
00043
00044       void setError(QString errorMsg, int line);
00045
00046       JSonScanner* m_scanner;
00047       bool m_negate;
00048       bool m_error;
00049       int m_errorLine;
00050       QString m_errorMsg;
00051       QVariant m_result;
00052   };
00053 }
00054
00055 #endif // QJSON_PARSER_H
Generated on Thu Sep 23 15:03:16 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/src/parserrunnable.h Source File

  • File List

smf/smfservermodule/util/qjson/src/parserrunnable.h

00001 /* This file is part of qjson
00002   *
00003   * Copyright (C) 2009 Flavio Castelli <flavio@castelli.name>
00004   *
00005   * This library is free software; you can redistribute it and/or
00006   * modify it under the terms of the GNU Library General Public
00007   * License as published by the Free Software Foundation; either
00008   * version 2 of the License, or (at your option) any later version.
00009   *
00010   * This library is distributed in the hope that it will be useful,
00011   * but WITHOUT ANY WARRANTY; without even the implied warranty of
00012   * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00013   * Library General Public License for more details.
00014   *
00015   * You should have received a copy of the GNU Library General Public License
00016   * along with this library; see the file COPYING.LIB.  If not, write to
00017   * the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
00018   * Boston, MA 02110-1301, USA.
00019   */
00020
00021 #ifndef PARSERRUNNABLE_H
00022 #define PARSERRUNNABLE_H
00023
00024 #include "qjson_export.h"
00025
00026 #include <QtCore/QObject>
00027 #include <QtCore/QRunnable>
00028
00029 class QVariant;
00030
00031 namespace QJson {
00035   class QJSON_EXPORT ParserRunnable  : public QObject, public QRunnable
00036   {
00037     Q_OBJECT
00038     public:
00044       explicit ParserRunnable(QObject* parent = 0);
00045       ~ParserRunnable();
00046
00047       void setData( const QByteArray& data );
00048
00049       void run();
00050
00051     Q_SIGNALS:
00058       void parsingFinished(const QVariant& json, bool ok, const QString& error_msg);
00059
00060     private:
00061       Q_DISABLE_COPY(ParserRunnable)
00062       class Private;
00063       Private* const d;
00064   };
00065 }
00066
00067 #endif // PARSERRUNNABLE_H
Generated on Thu Sep 23 15:03:16 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/tests/person.h Source File

  • File List

smf/smfservermodule/util/qjson/tests/person.h

00001 /* This file is part of qjson
00002   *
00003   * Copyright (C) 2009 Till Adam <adam@kde.org>
00004   *
00005   * This library is free software; you can redistribute it and/or
00006   * modify it under the terms of the GNU Library General Public
00007   * License as published by the Free Software Foundation; either
00008   * version 2 of the License, or (at your option) any later version.
00009   *
00010   * This library is distributed in the hope that it will be useful,
00011   * but WITHOUT ANY WARRANTY; without even the implied warranty of
00012   * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00013   * Library General Public License for more details.
00014   *
00015   * You should have received a copy of the GNU Library General Public License
00016   * along with this library; see the file COPYING.LIB.  If not, write to
00017   * the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
00018   * Boston, MA 02110-1301, USA.
00019   */
00020
00021 #ifndef PERSON_H
00022 #define PERSON_H
00023
00024 #include <QtCore/QDate>
00025 #include <QtCore/QObject>
00026
00027 class Person : public QObject
00028 {
00029   Q_OBJECT
00030
00031   Q_PROPERTY(QString name READ name WRITE setName)
00032   Q_PROPERTY(int phoneNumber READ phoneNumber WRITE setPhoneNumber)
00033   Q_PROPERTY(Gender gender READ gender WRITE setGender)
00034   Q_PROPERTY(QDate dob READ dob WRITE setDob)
00035   Q_ENUMS(Gender)
00036
00037  public:
00038     Person(QObject* parent = 0);
00039     ~Person();
00040
00041     QString name() const;
00042     void setName(const QString& name);
00043
00044     int phoneNumber() const;
00045     void setPhoneNumber(const int  phoneNumber);
00046
00047     enum Gender {Male, Female};
00048     void setGender(Gender gender);
00049     Gender gender() const;
00050
00051     QDate dob() const;
00052     void setDob(const QDate& dob);
00053
00054   private:
00055     QString m_name;
00056     int m_phoneNumber;
00057     Gender m_gender;
00058     QDate m_dob;
00059 };
00060
00061 #endif
Generated on Thu Sep 23 15:03:16 2010 for smf by doxygen 1.6.3


smf: example/smfclientapp/posttestui.h Source File

  • File List

example/smfclientapp/posttestui.h

00001 #ifndef POSTTESTUI_H
00002 #define POSTTESTUI_H
00003
00004 #include <QtGui/QWidget>
00005 #include "ui_posttestui.h"
00006
00007 class PostTestUi : public QWidget
00008 {
00009     Q_OBJECT
00010
00011 public:
00012     PostTestUi(QWidget *parent = 0);
00013     ~PostTestUi();
00014
00015 private:
00016     Ui::PostTestUiClass ui;
00017 };
00018
00019 #endif // POSTTESTUI_H
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/src/qjson_debug.h Source File

  • File List

smf/smfservermodule/util/qjson/src/qjson_debug.h

00001 /* This file is part of qjson
00002   *
00003   * Copyright (C) 2009 Michael Leupold <lemma@confuego.org>
00004   *
00005   * This library is free software; you can redistribute it and/or
00006   * modify it under the terms of the GNU Library General Public
00007   * License as published by the Free Software Foundation; either
00008   * version 2 of the License, or (at your option) any later version.
00009   *
00010   * This library is distributed in the hope that it will be useful,
00011   * but WITHOUT ANY WARRANTY; without even the implied warranty of
00012   * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00013   * Library General Public License for more details.
00014   *
00015   * You should have received a copy of the GNU Library General Public License
00016   * along with this library; see the file COPYING.LIB.  If not, write to
00017   * the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
00018   * Boston, MA 02110-1301, USA.
00019   */
00020
00021 #ifndef QJSON_DEBUG_H
00022 #define QJSON_DEBUG_H
00023
00024 #include <QtCore/QDebug>
00025
00026 // define qjsonDebug()
00027 #ifdef QJSON_VERBOSE_DEBUG_OUTPUT
00028   inline QDebug qjsonDebug() { return QDebug(QtDebugMsg); }
00029 #else
00030   inline QNoDebug qjsonDebug() { return QNoDebug(); }
00031 #endif
00032
00033 #endif
Generated on Thu Sep 23 15:03:16 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/src/qjson_export.h Source File

  • File List

smf/smfservermodule/util/qjson/src/qjson_export.h

00001 /*  This file is part of the KDE project
00002     Copyright (C) 2009 Pino Toscano <pino@kde.org>
00003
00004     This library is free software; you can redistribute it and/or
00005     modify it under the terms of the GNU Library General Public
00006     License as published by the Free Software Foundation; either
00007     version 2 of the License, or (at your option) any later version.
00008
00009     This library is distributed in the hope that it will be useful,
00010     but WITHOUT ANY WARRANTY; without even the implied warranty of
00011     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00012     Library General Public License for more details.
00013
00014     You should have received a copy of the GNU Library General Public License
00015     along with this library; see the file COPYING.LIB.  If not, write to
00016     the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
00017     Boston, MA 02110-1301, USA.
00018 */
00019
00020 #ifndef QJSON_EXPORT_H
00021 #define QJSON_EXPORT_H
00022
00023 #include <QtCore/qglobal.h>
00024
00025 #ifndef QJSON_EXPORT
00026 # if defined(QJSON_MAKEDLL)
00027    /* We are building this library */
00028 #  define QJSON_EXPORT Q_DECL_EXPORT
00029 # else
00030    /* We are using this library */
00031 #  define QJSON_EXPORT Q_DECL_IMPORT
00032 # endif
00033 #endif
00034
00035 #endif
Generated on Thu Sep 23 15:03:16 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/src/qobjecthelper.h Source File

  • File List

smf/smfservermodule/util/qjson/src/qobjecthelper.h

00001 /* This file is part of qjson
00002   *
00003   * Copyright (C) 2009 Flavio Castelli <flavio@castelli.name>
00004   *
00005   * This library is free software; you can redistribute it and/or
00006   * modify it under the terms of the GNU Library General Public
00007   * License as published by the Free Software Foundation; either
00008   * version 2 of the License, or (at your option) any later version.
00009   *
00010   * This library is distributed in the hope that it will be useful,
00011   * but WITHOUT ANY WARRANTY; without even the implied warranty of
00012   * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00013   * Library General Public License for more details.
00014   *
00015   * You should have received a copy of the GNU Library General Public License
00016   * along with this library; see the file COPYING.LIB.  If not, write to
00017   * the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
00018   * Boston, MA 02110-1301, USA.
00019   */
00020
00021 #ifndef QOBJECTHELPER_H
00022 #define QOBJECTHELPER_H
00023
00024 #include "qjson_export.h"
00025
00026 #include <QtCore/QLatin1String>
00027 #include <QtCore/QStringList>
00028 #include <QtCore/QVariantMap>
00029
00030 class QObject;
00031
00032 namespace QJson {
00115   class QJSON_EXPORT QObjectHelper {
00116     public:
00117       QObjectHelper();
00118       ~QObjectHelper();
00119
00126     static QVariantMap qobject2qvariant( const QObject* object,
00127                                   const QStringList& ignoredProperties = QStringList(QString(QLatin1String("objectName"))));
00128
00134     static void qvariant2qobject(const QVariantMap& variant, QObject* object);
00135
00136     private:
00137       Q_DISABLE_COPY(QObjectHelper)
00138       class QObjectHelperPrivate;
00139       QObjectHelperPrivate* const d;
00140   };
00141 }
00142
00143 #endif // QOBJECTHELPER_H
Generated on Thu Sep 23 15:03:16 2010 for smf by doxygen 1.6.3


smf: example/sampleplugin.h Source File

  • File List

example/sampleplugin.h

00001 #ifndef _SAMPLEPLUGIN_H
00002 #define _SAMPLEPLUGIN_H
00003
00004 // Include files
00005 #include <QVariant>
00006 #include <qplugin.h>
00007
00008 #include "smfglobal.h"
00009 #include "smfpicture.h"
00010 #include "smfcomment.h"
00011 #include "smfpluginbase.h"
00012 #include "smfproviderbase.h"
00013 #include "smfgalleryplugin.h"
00014 #include "smfpluginutil.h"
00015
00016
00017 // Forward declarations
00018 class SampleProviderBase;
00019
00020
00021 // Class declaration
00022 class SamplePlugin : public SmfGalleryPlugin
00023 {
00024         Q_OBJECT
00025         Q_INTERFACES( SmfGalleryPlugin )
00026
00027 public:
00035         SamplePlugin( SmfPluginUtil *aUtil );
00036
00040         ~SamplePlugin( );
00041
00042 public: // From SmfGalleryPlugin
00043
00051         SmfPluginError pictures( SmfPluginRequestData &aRequest,
00052                         const int aPageNum = SMF_FIRST_PAGE,
00053                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE );
00054
00061         SmfPluginError description( SmfPluginRequestData &aRequest,
00062                         const SmfPicture &aImage );
00063
00070         SmfPluginError upload( SmfPluginRequestData &aRequest,
00071                         const SmfPicture &aImage );
00072
00079         SmfPluginError upload( SmfPluginRequestData &aRequest,
00080                         const QList<SmfPicture> &aImages );
00081
00089         SmfPluginError postComment( SmfPluginRequestData &aRequest,
00090                         const SmfPicture &aImage,
00091                         const SmfComment &aComment );
00092
00093 public: // From SmfPluginBase
00098         SmfProviderBase* getProviderInfo( );
00099
00114         SmfPluginError responseAvailable(
00115                         const SmfTransportResult &aTransportResult,
00116                         QNetworkReply *aReply,
00117                         QVariant* aResult,
00118                         SmfPluginRetType &aRetType,
00119                         SmfResultPage &aPageResult );
00120
00121 private:
00133         SmfPluginError createRequest( SmfPluginRequestData &aRequest,
00134                         const QNetworkAccessManager::Operation aOperation,
00135                         const SmfSignatureMethod aSignatureMethod,
00136                         QMultiMap<QByteArray, QByteArray> &aParams,
00137                         const SmfParsingMode aMode,
00138                         QBuffer *aPostData );
00142         QString retrievePrivateRegToken();
00143 private:
00144         SampleProviderBase *m_provider;
00145         SmfPluginUtil *m_util;
00146 };
00147
00148
00149 // Class declaration
00150 class SampleProviderBase : public SmfProviderBase
00151         {
00152         Q_OBJECT
00153
00154 public:
00159         SampleProviderBase( QObject* aParent = 0 );
00160
00165         SampleProviderBase( const SampleProviderBase &aOther );
00166
00170         ~SampleProviderBase( );
00171
00176         QString serviceName( ) const;
00177
00182         QImage serviceIcon( ) const;
00183
00188         QString description( ) const;
00189
00194         QUrl serviceUrl( ) const;
00195
00200         QUrl applicationUrl( ) const;
00201
00206         QImage applicationIcon( ) const;
00207
00212         QString pluginId( ) const;
00213
00222         QString authenticationApp( QString &aProgram, QStringList & aArguments,
00223                         QIODevice::OpenModeFlag aMode = QIODevice::ReadWrite ) const;
00224
00231         QString smfRegistrationId( ) const;
00232
00237         SmfPluginDataUsage getDataUsage( ) const;
00238
00239 private:
00250         bool updateDataUsage( const uint &aBytesSent, const uint &aBytesReceived );
00251
00252         friend class SamplePlugin;
00253
00254 private:
00255         QString m_serviceName;
00256         QImage m_serviceIcon;
00257         QString m_description;
00258         QUrl m_serviceUrl;
00259         QUrl m_applicationUrl;
00260         QImage m_applicationIcon;
00261         QString m_pluginId;
00262         QString m_authAppId;
00263         QString m_smfRegToken;
00264         SmfPluginDataUsage m_dataUsage;
00265         };
00266
00267 #endif /*_SAMPLEPLUGIN_H*/
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/src/serializer.h Source File

  • File List

smf/smfservermodule/util/qjson/src/serializer.h

00001 /* This file is part of qjson
00002   *
00003   * Copyright (C) 2009 Till Adam <adam@kde.org>
00004   *
00005   * This library is free software; you can redistribute it and/or
00006   * modify it under the terms of the GNU Library General Public
00007   * License as published by the Free Software Foundation; either
00008   * version 2 of the License, or (at your option) any later version.
00009   *
00010   * This library is distributed in the hope that it will be useful,
00011   * but WITHOUT ANY WARRANTY; without even the implied warranty of
00012   * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00013   * Library General Public License for more details.
00014   *
00015   * You should have received a copy of the GNU Library General Public License
00016   * along with this library; see the file COPYING.LIB.  If not, write to
00017   * the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
00018   * Boston, MA 02110-1301, USA.
00019   */
00020
00021 #ifndef QJSON_SERIALIZER_H
00022 #define QJSON_SERIALIZER_H
00023
00024 #include "qjson_export.h"
00025
00026 class QIODevice;
00027 class QString;
00028 class QVariant;
00029
00030 namespace QJson {
00037   class QJSON_EXPORT Serializer {
00038   public:
00039     Serializer();
00040     ~Serializer();
00041
00050     void serialize( const QVariant& variant, QIODevice* out, bool* ok = 0 );
00051
00062     QByteArray serialize( const QVariant& variant );
00063
00064   private:
00065     Q_DISABLE_COPY(Serializer)
00066     class SerializerPrivate;
00067     SerializerPrivate* const d;
00068   };
00069 }
00070
00071 #endif // QJSON_SERIALIZER_H
Generated on Thu Sep 23 15:03:16 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/src/serializerrunnable.h Source File

  • File List

smf/smfservermodule/util/qjson/src/serializerrunnable.h

00001 /* This file is part of qjson
00002  *
00003  * Copyright (C) 2009 Frank Osterfeld <osterfeld@kde.org>
00004  *
00005  * This library is free software; you can redistribute it and/or
00006  * modify it under the terms of the GNU Library General Public
00007  * License as published by the Free Software Foundation; either
00008  * version 2 of the License, or (at your option) any later version.
00009  *
00010  * This library is distributed in the hope that it will be useful,
00011  * but WITHOUT ANY WARRANTY; without even the implied warranty of
00012  * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
00013  * Library General Public License for more details.
00014  *
00015  * You should have received a copy of the GNU Library General Public License
00016  * along with this library; see the file COPYING.LIB.  If not, write to
00017  * the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
00018  * Boston, MA 02110-1301, USA.
00019  */
00020
00021 #ifndef SERIALIZERRUNNABLE_H
00022 #define SERIALIZERRUNNABLE_H
00023
00024 #include "qjson_export.h"
00025
00026 #include <QtCore/QObject>
00027 #include <QtCore/QRunnable>
00028
00029 class QByteArray;
00030 class QString;
00031 class QVariant;
00032
00033 namespace QJson {
00037   class QJSON_EXPORT SerializerRunnable  : public QObject, public QRunnable
00038   {
00039     Q_OBJECT
00040     public:
00046       explicit SerializerRunnable(QObject* parent = 0);
00047       ~SerializerRunnable();
00048
00054       void setJsonObject( const QVariant& json );
00055
00056       /* reimp */ void run();
00057
00058     Q_SIGNALS:
00065       void parsingFinished(const QByteArray& serialized, bool ok, const QString& error_msg);
00066
00067     private:
00068       Q_DISABLE_COPY(SerializerRunnable)
00069       class Private;
00070       Private* const d;
00071   };
00072 }
00073
00074 #endif // SERIALIZERRUNNABLE_H
Generated on Thu Sep 23 15:03:16 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfactions.h Source File

  • File List

smf/smfservermodule/smfcommon/smfactions.h

00001
00019 #ifndef SMFACTIONS_H_
00020 #define SMFACTIONS_H_
00021
00022 #include <QList>
00023 #include <QImage>
00024 #include <QDateTime>
00025 #include <QStringList>
00026 #include <QUrl>
00027 #include <qdatastream.h>
00028 #include <QSharedData>
00029 #include <QMetaType>
00030
00031 #include "smfclientglobal.h"
00032 #include "smfpost.h"
00033 #include "smfcontact.h"
00034
00038 const int MaxSmfActivityEntrySize = 5000;
00039
00044 enum SmfActivityVerb
00045         {
00046         SmfActivityMarkAsFavorite,
00047         SmfActivityStartFollowing,
00048         SmfActivityMarkLiked,
00049         SmfActivityMakeFriend,
00050         SmfActivityJoin,
00051         SmfActivityPlay,
00052         SmfActivityPost,
00053         SmfActivitySave,
00054         SmfActivityShare,
00055         SmfActivityTag,
00056         SmfActivityUpdate
00057         };
00058
00063 enum SmfActivityObjectType
00064         {
00065         SmfActivityObjTypeArticle,
00066         SmfActivityObjTypeAudio,
00067         SmfActivityObjTypeBookmark,
00068         SmfActivityObjTypeComment,
00069         SmfActivityObjTypeFile,
00070         SmfActivityObjTypeFolder,
00071         SmfActivityObjTypeGroup,
00072         SmfActivityObjTypeList,
00073         SmfActivityObjTypeNote,
00074         SmfActivityObjTypePerson,
00075         SmfActivityObjTypePhoto,
00076         SmfActivityObjTypePhotoAlbum,
00077         SmfActivityObjTypePlace,
00078         SmfActivityObjTypePlaylist,
00079         SmfActivityObjTypeProduct,
00080         SmfActivityObjTypeReview,
00081         SmfActivityObjTypeService,
00082         SmfActivityObjTypeStatus,
00083         SmfActivityObjTypeVideo,
00084         SmfActivityObjTypeMusic,
00085         SmfActivityObjTypeEvent,
00086         SmfActivityObjTypeAdvanced
00087         };
00088
00089 enum SmfActivityFor
00090         {
00091                 SmfActivitySelf,
00092                 SmfActivityFriend,
00093                 SmfActivityOthers
00094         };
00095
00096 class SmfActivityObjectPrivate;
00097 //class SmfActivityEntryPrivate;
00098
00103 class SMFCOMMON_EXPORT SmfActivityObject
00104         {
00105 public:
00109         SmfActivityObject();
00110
00114         SmfActivityObject(const SmfActivityObject& aOther);
00115
00121         SmfActivityObject& operator=( const SmfActivityObject &aOther );
00122
00126         ~SmfActivityObject();
00127
00131         QString id() const;
00132
00136         QImage thumbnail() const;
00137
00141         QString caption() const;
00142
00146         SmfActivityObjectType type( ) const;
00147
00151         QVariant objData() const;
00152
00156         QString link() const;
00157
00161         QDateTime time() const;
00162
00166         QString content() const;
00167
00172         void setId(const QString& aId);
00173
00178         void setThumbnail(const QImage& aIcon);
00179
00184         void setCaption(const QString& aCap);
00185
00190         void setType(const SmfActivityObjectType& aObjType);
00191
00197         void setObjData( const QVariant& aData);
00198
00203         void setLink( const QString& aLink);
00204
00209         void setTime( const QDateTime& aTime);
00210
00215         void setContent( const QString& aText) ;
00216
00217 private:
00218         QSharedDataPointer<SmfActivityObjectPrivate> d;
00219
00220         friend QDataStream& operator >> ( QDataStream &aOut, SmfActivityObject& aData);
00221         friend QDataStream& operator << ( QDataStream &aIn, const SmfActivityObject& aData);
00222         };
00223
00224 SMFCOMMON_EXPORT QDataStream& operator >> ( QDataStream &aOut, SmfActivityObject& aData);
00225 SMFCOMMON_EXPORT QDataStream& operator << ( QDataStream &aIn, const SmfActivityObject& aData);
00226
00227 typedef QList<SmfActivityObject> SmfActivityObjectList;
00228
00229 // Make the class SmfActivityObject known to QMetaType, so that as to register it.
00230 Q_DECLARE_METATYPE(SmfActivityObject)
00231 Q_DECLARE_METATYPE(QList<SmfActivityObject>)
00232
00233
00234 class SmfActivityEntryPrivate: public QSharedData
00235         {
00236 public:
00237         SmfActivityEntryPrivate( ) {
00238                 m_id.clear();
00239         }
00240
00241         SmfActivityEntryPrivate( const SmfActivityEntryPrivate& aOther ) :
00242                 QSharedData (aOther),
00243                 m_id (aOther.m_id),
00244                 m_title (aOther.m_title),
00245                 m_details (aOther.m_details),
00246                 m_author (aOther.m_author),
00247                 m_actionName (aOther.m_actionName),
00248                 m_activities (aOther.m_activities),
00249                 m_targetObj (aOther.m_targetObj)  { }
00250
00251         ~SmfActivityEntryPrivate( ) { }
00252
00256         QString m_id;
00257         SmfPost m_title;
00258         SmfPost m_details;
00259         SmfContact m_author;
00260         SmfActivityVerb m_actionName;
00261         QList<SmfActivityObject> m_activities;
00262         SmfActivityObject m_targetObj;
00263         };
00264
00269 class SMFCOMMON_EXPORT SmfActivityEntry
00270         {
00271
00272 public:
00273
00274         SmfActivityEntry();
00275         SmfActivityEntry(const SmfActivityEntry& aOther);
00276         ~SmfActivityEntry();
00277
00281         QString id() const;
00285         SmfPost title() const;
00286
00290         SmfPost details() const;
00291
00296         SmfContact author() const;
00297
00301         SmfActivityVerb actionName() const;
00302
00307         QList<SmfActivityObject> activities() const;
00308
00313         SmfActivityObject targetObj() const;
00314
00319         bool setId( const QString& aId);
00320
00325         bool setTitle(const SmfPost& aTitle);
00326
00331         bool setDetails(const SmfPost& aDetails);
00332
00338         bool setAuthor(const SmfContact& aContact);
00339
00344         void setActionName(SmfActivityVerb  aVerb);
00345
00350         bool setActivities(QList<SmfActivityObject>& aList);
00351
00357         bool setTargetObj(const SmfActivityObject& aTarget);
00358
00359 private:
00360         QSharedDataPointer<SmfActivityEntryPrivate> d;
00361
00362         friend QDataStream& operator >> ( QDataStream &aOut, SmfActivityEntry& aData);
00363         friend QDataStream& operator << ( QDataStream &aIn, const SmfActivityEntry& aData);
00364         };
00365
00366 SMFCOMMON_EXPORT QDataStream& operator >> ( QDataStream &aOut, SmfActivityEntry& aData);
00367 SMFCOMMON_EXPORT QDataStream& operator << ( QDataStream &aIn, const SmfActivityEntry& aData);
00368
00369 typedef QList<SmfActivityEntry> SmfActivityEntryList;
00370
00371 // Make the class SmfActivityEntry known to QMetaType, so that as to register it.
00372 Q_DECLARE_METATYPE(SmfActivityEntry)
00373 Q_DECLARE_METATYPE(QList<SmfActivityEntry>)
00374
00375 #endif /* SMFACTIONS_H_ */
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfactions_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfactions_p.h

00001
00019 #ifndef SMFACTIONS_P_H_
00020 #define SMFACTIONS_P_H_
00021
00022 #include <QDateTime>
00023 #include <QSharedData>
00024 #include <QVariant>
00025 #include <QImage>
00026 #include <QDateTime>
00027 #include <QStringList>
00028 #include <QUrl>
00029 #include <qdatastream.h>
00030 #include <QSharedData>
00031 #include <QMetaType>
00032
00033 #include "smfactions.h"
00034 #include "smfpost.h"
00035 #include "smfcontact.h"
00036
00037 class SmfActivityObjectPrivate: public QSharedData
00038         {
00039 public:
00040         SmfActivityObjectPrivate( ) {
00041                 m_id.clear();
00042                 m_caption.clear();
00043                 m_link.clear();
00044                 m_content.clear();
00045         }
00046
00047         SmfActivityObjectPrivate( const SmfActivityObjectPrivate& aOther ) :
00048                 QSharedData (aOther),
00049                 m_id (aOther.m_id),
00050                 m_thumbnail (aOther.m_thumbnail),
00051                 m_caption (aOther.m_caption),
00052                 m_type (aOther.m_type),
00053                 m_objData (aOther.m_objData),
00054                 m_link (aOther.m_link),
00055                 m_time (aOther.m_time),
00056                 m_content (aOther.m_content) { }
00057
00058         ~SmfActivityObjectPrivate( ) {}
00059
00063         QString m_id;
00064         QImage m_thumbnail;
00065         QString m_caption;
00066         SmfActivityObjectType m_type;
00067         QVariant m_objData;
00068         QString m_link;
00069         QDateTime m_time;
00070         QString m_content;
00071         };
00072
00073
00074
00075 #endif /* SMFACTIONS_P_H_ */
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfactivityfetcher.h Source File

  • File List

smf/smfservermodule/smfclient/smfactivityfetcher.h

00001
00020 #ifndef SMFACTIVITYFETCHER_H_
00021 #define SMFACTIVITYFETCHER_H_
00022
00023 #include <QList>
00024 #include <smfglobal.h>
00025 #include <smfactions.h>
00026
00027 // Forward declaration
00028 class SmfActivityFetcherPrivate;
00029 class SmfProvider;
00030 class SmfContact;
00031
00032
00037 class SMFCLIENT_EXPORT SmfActivityFetcher : public QObject
00038         {
00039         Q_OBJECT
00040
00041 public:
00046         SmfActivityFetcher(SmfProvider* baseprovider = 0);
00047
00051         ~SmfActivityFetcher();
00052
00053 public slots:
00058         SmfError selfActivities(int pageNum = SMF_FIRST_PAGE,int perPage = SMF_ITEMS_PER_PAGE);
00059
00064         SmfError friendsActivities(const SmfContact& aFriend, int pageNum = SMF_FIRST_PAGE,
00065                         int perPage = SMF_ITEMS_PER_PAGE);
00066
00071         SmfError filtered(QList<SmfActivityObjectType> filters, int pageNum = SMF_FIRST_PAGE,
00072                         int perPage = SMF_ITEMS_PER_PAGE);
00073
00084         SmfError customRequest ( const int& operationId, QByteArray* customData );
00085
00092         SmfError cancelRequest ();
00093
00094 signals:
00098         void resultsAvailable(SmfActivityEntryList* entries, SmfError error, SmfResultPage resultPage);
00099
00103         void customDataAvailable( const int& operationId, QByteArray* customData );
00104
00105 private:
00109         SmfProvider* getProvider() const;
00110
00111 // Friend Class
00112         friend class SmfActivityFetcherPrivate;
00113
00114 private:
00115         SmfActivityFetcherPrivate* m_private;
00116         SmfProvider* m_baseProvider;
00117
00118         };
00119
00120 SMF_SERVICE_NAME(SmfActivityFetcher, "org.symbian.smf.client.activity.fetcher\0.2")
00121
00122 #endif /* SMFACTIVITYFETCHER_H_ */
Generated on Thu Sep 23 15:03:11 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfactivityfetcher_p.h Source File

  • File List

smf/smfservermodule/smfclient/smfactivityfetcher_p.h

00001
00020 #ifndef SMFACTIVITYFETCHER_P_H_
00021 #define SMFACTIVITYFETCHER_P_H_
00022
00023 #include <QList>
00024 #include <smfglobal.h>
00025 #include <smfactions.h>
00026 #include <smfobserver.h>
00027
00028 class SmfActivityFetcher;
00029 class SmfProvider;
00030 class SmfContact;
00031 #ifdef Q_OS_SYMBIAN
00032         class CSmfClientSymbian;
00033 #else
00034         class SmfClientQt;
00035 #endif
00036
00037
00038 class SmfActivityFetcherPrivate : public smfObserver
00039         {
00040         Q_OBJECT
00041
00042 public:
00046         SmfActivityFetcherPrivate(SmfActivityFetcher* activityFetcher);
00047
00051         ~SmfActivityFetcherPrivate();
00052
00057         SmfError selfActivities(int pageNum, int perPage);
00058
00063         SmfError friendsActivities(const SmfContact& aFriend, int pageNum, int perPage);
00064
00069         SmfError filtered(QList<SmfActivityObjectType> filters, int pageNum, int perPage);
00070
00081         SmfError customRequest ( const int& operationId, QByteArray* customData );
00082
00089         SmfError cancelRequest ();
00090
00091 public: //From smfObserver
00098         void resultsAvailable(QByteArray result,SmfRequestTypeID opcode, SmfError error);
00099
00100 private:
00101           SmfActivityFetcher* m_activityFetcher;
00102 #ifdef Q_OS_SYMBIAN
00103           CSmfClientSymbian* m_SmfClientPrivate;
00104           friend class CSmfClientSymbian;
00105 #else
00106           SmfClientQt* m_SmfClientPrivate;
00107           friend class SmfClientQt;
00108 #endif
00109           quint8 m_argFlag;
00110           //serialized byte array of provider+other info to be sent to the server
00111           //The order:- SmfProvider then params in order of their appearance in fn
00112           QByteArray m_serializedDataToServer;
00113
00114         };
00115
00116 #endif /* SMFACTIVITYFETCHER_P_H_ */
Generated on Thu Sep 23 15:03:11 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/smfplugins/smfactivityfetcherplugin.h Source File

  • File List

smf/smfservermodule/smfserver/smfplugins/smfactivityfetcherplugin.h

00001
00019 #ifndef SMFACTIVITYFETCHERPLUGIN_H_
00020 #define SMFACTIVITYFETCHERPLUGIN_H_
00021
00022 #include <smfpluginbase.h>
00023 #include <smfactions.h>
00024
00025 // Forward declaration
00026 class SmfContact;
00027
00038 class SmfActivityFetcherPlugin : public SmfPluginBase
00039         {
00040 public:
00044         virtual ~SmfActivityFetcherPlugin( ) {}
00045
00054         virtual SmfPluginError selfActivities( SmfPluginRequestData &aRequest,
00055                         const int aPageNum = SMF_FIRST_PAGE,
00056                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00057
00067         virtual SmfPluginError friendsActivities( SmfPluginRequestData &aRequest,
00068                         const SmfContact &aContact,
00069                         const int aPageNum = SMF_FIRST_PAGE,
00070                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00071
00081         virtual SmfPluginError filtered( SmfPluginRequestData &aRequest,
00082                         QList<SmfActivityObjectType> &aFilters,
00083                         const int aPageNum = SMF_FIRST_PAGE,
00084                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00085
00096         virtual SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00097                         const int &aOperation, QByteArray *aData ) = 0;
00098
00099         };
00100
00101 Q_DECLARE_INTERFACE( SmfActivityFetcherPlugin, "org.symbian.smf.plugin.activity.fetcher/v0.2" );
00102
00103 #endif /* SMFACTIVITYFETCHERPLUGIN_H_ */
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfalbum.h Source File

  • File List

smf/smfservermodule/smfcommon/smfalbum.h

00001
00019 #ifndef SMFALBUM_H_
00020 #define SMFALBUM_H_
00021
00022 #include <QImage>
00023 #include <qdatastream.h>
00024 #include <QSharedData>
00025 #include <QMetaType>
00026 #include <smfclientglobal.h>
00027
00028 class SmfAlbumPrivate;
00029 class SmfArtists;
00030 class SmfLocation;
00031
00032
00033 // Enums
00034 enum SmfAlbumMediaType
00035         {
00036         SmfAlbumUnspecified,
00037         SmfAlbumMusic,
00038         SmfAlbumVideo,
00039         SmfAlbumMixed
00040         };
00041
00046 class SMFCOMMON_EXPORT SmfAlbum
00047         {
00048 public:
00052         SmfAlbum( );
00053
00058         SmfAlbum( const SmfAlbum &aOther );
00059
00065         SmfAlbum& operator=( const SmfAlbum &aOther );
00066
00070         ~SmfAlbum( );
00071
00076         QString name( ) const;
00077
00082         QUrl imageUrl( ) const;
00083
00088         SmfArtists artists( ) const;
00089
00094         SmfLocation location( ) const;
00095
00100         int itemsCount( ) const;
00101
00106         SmfAlbumMediaType type( ) const;
00107
00112         QString id( ) const;
00113
00118         QString secondaryId( ) const;
00119
00120
00125         void setName( const QString &aName );
00126
00131         void setImageUrl( const QUrl &aUrl );
00132
00137         void setArtists( const SmfArtists &aArtists );
00138
00143         void setLocation(const SmfLocation &aLoc );
00144
00149         void setItemsCount( const int aCount );
00150
00155         void setType(SmfAlbumMediaType aType);
00156
00161         void setId( const QString &aId );
00162
00167         void setSecondaryId( const QString &aSecondaryID );
00168
00169
00170 private:
00171         QSharedDataPointer<SmfAlbumPrivate> d;
00172
00173         friend QDataStream &operator<<( QDataStream &aDataStream,
00174                         const SmfAlbum &aAlbum );
00175
00176         friend QDataStream &operator>>( QDataStream &aDataStream,
00177                         SmfAlbum &aAlbum );
00178
00179         };
00180
00181
00189 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00190                 const SmfAlbum &aAlbum );
00191
00199 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00200                 SmfAlbum &aAlbum);
00201
00202 typedef QList<SmfAlbum> SmfAlbumList;
00203
00204 // Make the class SmfAlbum known to QMetaType, so that as to register it.
00205 Q_DECLARE_METATYPE(SmfAlbum)
00206 Q_DECLARE_METATYPE(QList<SmfAlbum>)
00207
00208 #endif /* SMFALBUM_H_ */
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfalbum_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfalbum_p.h

00001
00020 #ifndef SMFALBUM_P_H_
00021 #define SMFALBUM_P_H_
00022
00023 #include <smfalbum.h>
00024 #include <smfartists.h>
00025 #include <smflocation.h>
00026 #include <QStringList>
00027 #include <QSharedData>
00028
00029 class SmfAlbumPrivate : public QSharedData
00030 {
00031 public:
00035         SmfAlbumPrivate( ) {
00036                 m_name.clear();
00037                 m_imageUrl.clear();
00038                 m_itemCount = 0;
00039                 m_type = SmfAlbumUnspecified;
00040                 m_albumId.clear();
00041                 m_secondaryId.clear();
00042         }
00043
00048         SmfAlbumPrivate( const SmfAlbumPrivate &aOther ) :
00049                 QSharedData ( aOther ),
00050                 m_name ( aOther.m_name ),
00051                 m_imageUrl ( aOther.m_imageUrl ),
00052                 m_artists ( aOther.m_artists ),
00053                 m_location ( aOther.m_location ),
00054                 m_itemCount ( aOther.m_itemCount ),
00055                 m_type ( aOther.m_type ),
00056                 m_albumId ( aOther.m_albumId ),
00057                 m_secondaryId ( aOther.m_secondaryId ) { }
00058
00062         ~SmfAlbumPrivate( )
00063                 {
00064                 }
00065
00066         QString m_name;                 // album name
00067         QUrl m_imageUrl;                // album's image url
00068         SmfArtists m_artists;   // album's artists
00069         SmfLocation m_location; // album's location
00070         int m_itemCount;                // count of items in the album
00071         SmfAlbumMediaType m_type;// type of media in the album
00072         QString m_albumId;              // album Id
00073         QString m_secondaryId;  // the secondary id of the album, e.g.-
00074                                                         //-musicbrainz id of the album for a music album
00075
00076 };
00077
00078 #endif /* SMFALBUM_P_H_ */
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfartists.h Source File

  • File List

smf/smfservermodule/smfcommon/smfartists.h

00001
00020 #ifndef SMFARTISTS_H_
00021 #define SMFARTISTS_H_
00022
00023 #include <QImage>
00024 #include <QUrl>
00025 #include <qdatastream.h>
00026 #include <QSharedData>
00027 #include <smfclientglobal.h>
00028 #include <QMetaType>
00029
00030 class SmfArtistsPrivate;
00031
00036 class SMFCOMMON_EXPORT SmfArtists
00037         {
00038 public:
00042         SmfArtists( );
00043
00048         SmfArtists( const SmfArtists &aOther );
00049
00054         SmfArtists& operator=( const SmfArtists &aOther );
00055
00059         ~SmfArtists( );
00060
00065         QStringList names( ) const;
00066
00071         QImage image( ) const;
00072
00077         QUrl url( ) const;
00078
00083         QStringList tags( ) const;
00084
00089         QString id( ) const;
00090
00095         void setNames( const QStringList &aList );
00096
00101         void setImage( const QImage &aImage );
00102
00107         void setUrl( const QUrl &aUrl );
00108
00113         void setTags( const QStringList &aTags );
00114
00119         void setId( const QString &aId );
00120
00121 private:
00122         QSharedDataPointer<SmfArtistsPrivate> d;
00123
00124         friend QDataStream &operator<<( QDataStream &aDataStream,
00125                         const SmfArtists &aArtists );
00126
00127         friend QDataStream &operator>>( QDataStream &aDataStream,
00128                         SmfArtists &aArtists );
00129
00130         };
00131
00132
00140 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00141                 const SmfArtists &aArtists );
00142
00150 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00151                 SmfArtists &aArtists);
00152
00153 typedef QList<SmfArtists> SmfArtistsList;
00154
00155 // Make the class SmfArtists known to QMetaType, so that as to register it.
00156 Q_DECLARE_METATYPE(SmfArtists)
00157 Q_DECLARE_METATYPE(QList<SmfArtists>)
00158
00159 #endif /* SMFARTISTS_H_ */
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfartists_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfartists_p.h

00001
00020 #ifndef SMFARTISTS_P_H_
00021 #define SMFARTISTS_P_H_
00022
00023 #include <QImage>
00024 #include <QUrl>
00025 #include <QStringList>
00026 #include <QSharedData>
00027
00028 class SmfArtistsPrivate : public QSharedData
00029 {
00030 public:
00034         SmfArtistsPrivate( ) {
00035                 m_names.clear();
00036                 m_url.clear();
00037                 m_tags.clear();
00038                 m_id.clear();
00039         }
00040
00045         SmfArtistsPrivate( const SmfArtistsPrivate &aOther ) :
00046                 QSharedData ( aOther ),
00047                 m_names ( aOther.m_names ),
00048                 m_image ( aOther.m_image ),
00049                 m_url ( aOther.m_url ),
00050                 m_tags ( aOther.m_tags ),
00051                 m_id ( aOther.m_id ) { }
00052
00056         ~SmfArtistsPrivate( )
00057                 {
00058                 }
00059
00060         QStringList     m_names;        // artist names
00061         QImage          m_image;        // image
00062         QUrl            m_url;          // url
00063         QStringList m_tags;             // tags
00064         QString         m_id;           // id
00065 };
00066
00067
00068 #endif /* SMFARTISTS_P_H_ */
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfclient.h Source File

  • File List

smf/smfservermodule/smfclient/smfclient.h

00001
00022 #ifndef SMFCLIENT_H
00023 #define SMFCLIENT_H
00024
00025 #include <QObject>
00026
00027 #include "smfclientglobal.h"
00028 #include "smfglobal.h"
00029
00030 //Forward declarations
00031 class SmfProvider;
00032 class SmfClientPrivate;
00033
00042 class  SMFCLIENT_EXPORT SmfClient
00043         {
00044 public:
00048         SmfClient();
00049
00053         ~SmfClient();
00054
00061         QList<SmfProvider>* GetServices(const QString& serviceName);
00062
00063         // ToDo :- More overloaded APIs will be provided later
00064         //QList<SmfProvider>* GetServices(const QString& serviceName, const QString& providerName);
00065         //QList<SmfProvider>* GetServices(const QString& serviceName, const SmfProvider& provider);
00066
00072         QString errorString ( const SmfError &aErrorCode ) const;
00073
00074 private:
00078         SmfClientPrivate* m_private;
00079
00083         QList<SmfProvider>* m_providerList;
00084
00085         };
00086
00087 #endif // SMFCLIENT_H
Generated on Thu Sep 23 15:03:11 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfclient_p.h Source File

  • File List

smf/smfservermodule/smfclient/smfclient_p.h

00001
00018 #ifndef SMFCLIENT_P_H_
00019 #define SMFCLIENT_P_H_
00020
00021 #include <QObject>
00022 #include <QDateTime>
00023 #include <QStringList>
00024
00025 #include "smfclient.h"
00026 #include "smfclientglobal.h"
00027 #include "smfglobal.h"
00028 #include "smfprovider.h"
00029 #include "smfobserver.h"
00030 #ifdef Q_OS_SYMBIAN
00031         #include "smfclientsymbian.h"
00032 #else
00033         #include "smfclientqt.h"
00034 #endif
00035
00036
00045 class SmfClientPrivate : public smfObserver
00046 {
00047         Q_OBJECT
00048
00049 public:
00050
00055         SmfClientPrivate(SmfClient* client = 0);
00056
00060         ~SmfClientPrivate(){};
00061
00062 public:
00066         QList<SmfProvider>* GetServices(const QString serviceName);
00067
00076         void resultsAvailable(QByteArray result,SmfRequestTypeID opcode,SmfError error);
00077
00078 private:
00079         SmfClient* m_client;
00080         QList<SmfProvider>* m_baseProvider;
00081         QByteArray m_providerSerialized;        // serialized byte array of provider
00082
00083 #ifdef Q_OS_SYMBIAN
00084         CSmfClientSymbian* m_SmfClientPrivate;
00085         friend class CSmfClientSymbian;
00086 #else
00087         SmfClientQt* m_SmfClientPrivate;
00088         friend class SmfClientQt;
00089 #endif
00090
00091         };
00092
00093 #endif /* SMFCLIENT_P_H_ */
Generated on Thu Sep 23 15:03:11 2010 for smf by doxygen 1.6.3


smf: example/smfclientapp/smfclientapp.h Source File

  • File List

example/smfclientapp/smfclientapp.h

00001 /****************************************************************************
00002 **
00003 ** Trolltech hereby grants a license to use the Qt/Eclipse Integration
00004 ** plug-in (the software contained herein), in binary form, solely for the
00005 ** purpose of creating code to be used with Trolltech's Qt software.
00006 **
00007 ** Qt Designer is licensed under the terms of the GNU General Public
00008 ** License versions 2.0 and 3.0 ("GPL License"). Trolltech offers users the
00009 ** right to use certain no GPL licensed software under the terms of its GPL
00010 ** Exception version 1.2 (http://trolltech.com/products/qt/gplexception).
00011 **
00012 ** THIS SOFTWARE IS PROVIDED BY TROLLTECH AND ITS CONTRIBUTORS (IF ANY) "AS
00013 ** IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
00014 ** TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
00015 ** PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER
00016 ** OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
00017 ** EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
00018 ** PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
00019 ** PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
00020 ** LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
00021 ** NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
00022 ** SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE."
00023 **
00024 ** Since we now have the GPL exception I think that the "special exception
00025 ** is no longer needed. The license text proposed above (other than the
00026 ** special exception portion of it) is the BSD license and we have added
00027 ** the BSD license as a permissible license under the exception.
00028 **
00029 ****************************************************************************/
00030
00031 #ifndef SMFCLIENTAPP_H
00032 #define SMFCLIENTAPP_H
00033
00034 #include <QtGui/QWidget>
00035 #include "ui_SmfClientApp.h"
00036
00037 class SmfClientApp : public QWidget
00038 {
00039     Q_OBJECT
00040
00041 public:
00042         SmfClientApp(QWidget *parent = 0);
00043     ~SmfClientApp();
00044
00045 private:
00046     Ui::SmfClientApp ui;
00047 };
00048
00049 #endif // SMFCLIENTAPP_H
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfclientglobal.h Source File

  • File List

smf/smfservermodule/smfcommon/smfclientglobal.h

00001
00020 #ifndef SMFCLIENTGLOBAL_H_
00021 #define SMFCLIENTGLOBAL_H_
00022
00023 #include <QtCore/QtGlobal>
00024 #include <QString>
00025
00026 #ifdef Q_OS_SYMBIAN
00027         _LIT(KSmfServerName,"smfserver");
00028         _LIT(KSmfServerSemaphoreName,"smfserverSemaphore");
00029         _LIT(KSmfServerFilename,"smfserver");
00030 #else
00031         const QString KSmfServerName("smfserver");
00032         const QString KSmfServerSemaphoreName("smfserverSemaphore");
00033         const QString KSmfServerFilename("smfserver");
00034 #endif
00035
00036
00037  #ifdef SMFCLIENT_LIB_EXPORT
00038          #define SMFCLIENT_EXPORT Q_DECL_EXPORT
00039  #else
00040          #define SMFCLIENT_EXPORT Q_DECL_IMPORT
00041  #endif
00042
00043 #ifdef SMFCOMMON_LIB_EXPORT
00044          #define SMFCOMMON_EXPORT Q_DECL_EXPORT
00045 #else
00046          #define SMFCOMMON_EXPORT Q_DECL_IMPORT
00047 #endif
00048
00049
00053 #define SMF_GETSERVICES(INTERFACE,INTERFACESTRING)
00054
00055 #endif /* SMFCLIENTDEFS_H_ */
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfclientqt.h Source File

  • File List

smf/smfservermodule/smfclient/smfclientqt.h

00001
00016 #ifndef SMFCLIENTQT_H
00017 #define SMFCLIENTQT_H
00018
00019 #include <QObject>
00020 #include <QByteArray>
00021 #include <QString>
00022 #include <QLocalSocket>
00023
00024 #include "smfglobal.h"
00025
00026 class SmfClientQt : public QObject
00027         {
00028 Q_OBJECT
00029
00030 public:
00031     explicit SmfClientQt(QObject *parent = 0);
00032
00033     ~SmfClientQt();
00034
00035 public:
00042     int sendRequest(QByteArray& aSerializedData,
00043                 QString aInterfaceName,
00044                 SmfRequestTypeID requestType);
00045
00050     QByteArray sendRequest(QString aInterfaceName,
00051                 SmfRequestTypeID requestType);
00052
00056     int sendDummyRequest(QByteArray* provider,QString aInterfaceName,
00057                 SmfRequestTypeID requestType);
00058
00063     void CancelRequest();
00064
00065 private slots:
00066     void connectionEstablished();
00067     void readIncomingData();
00068     void handleError(QLocalSocket::LocalSocketError error);
00069
00070 private:
00071     QLocalSocket *m_serverConnection;
00072         };
00073
00074 #endif // SMFCLIENTQT_H
Generated on Thu Sep 23 15:03:11 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfclientsymbian.h Source File

  • File List

smf/smfservermodule/smfclient/smfclientsymbian.h

00001
00020 #ifndef SMFCLIENTSYMBIAN_H_
00021 #define SMFCLIENTSYMBIAN_H_
00022
00023 #include <e32base.h>
00024 #include <e32cmn.h>
00025 #include <QStringList>
00026 #include <smfglobal.h>
00027 #include <smfobserver.h>
00028 #include <smfprovider.h>
00029
00030 #include "smfclientsymbiansession.h"
00031
00035 class CSmfClientSymbian : public CActive
00036 {
00037
00038 public: // Constructors and destructors
00043         static CSmfClientSymbian* NewL(smfObserver* aObserver=NULL);
00044
00049         static CSmfClientSymbian* NewLC(smfObserver* aObserver);
00050
00055         virtual ~CSmfClientSymbian();
00056
00057 public:
00067         QByteArray sendRequest(QString aInterfaceName, SmfRequestTypeID requestType,
00068         TInt aMaxAllocation, QByteArray& aSerializedData);
00069
00079         QByteArray sendSyncRequest ( QString aInterfaceName,
00080                         SmfRequestTypeID requestType, TInt maxSize,
00081                         QByteArray &aSerializedData );
00082
00091         QByteArray sendDSMSyncRequest ( SmfRequestTypeID requestType,
00092                         QByteArray& aSerializedData, SmfError& aErr, TInt maxSize = 10 );
00093
00103         TInt sendRequest( QByteArray& aSerializedData, QString aInterfaceName,
00104                         SmfRequestTypeID requestType, TInt aMaxAllocation );
00105
00110         void CancelRequest() ;
00111
00112 protected: // Functions from the base class CActive
00118         void RunL();
00119
00124         void DoCancel();
00125
00129         TInt RunError(TInt aError);
00130
00131 private: // Constructors
00136         CSmfClientSymbian(smfObserver* aObserver);
00137
00143         void ConstructL();
00144
00145 private: // Data
00149         RSmfClientSymbianSession iSession;
00150
00154         smfObserver* iObserver;
00155
00156         //Interface name, to be passed to the server
00157         TBuf<128> iInterfaceName;
00158         QString iInterfaceNameQt;
00159         //Data ptr
00160         TPtr iDataPtr;
00161         //Bytearray
00162         QByteArray* iBytearray;
00163         HBufC* iBuffer;
00164         TInt iMaxMessageSize;
00165
00166         };
00167
00168 #endif /* SMFCLIENTSYMBIAN_H_ */
Generated on Thu Sep 23 15:03:11 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfclientsymbiansession.h Source File

  • File List

smf/smfservermodule/smfclient/smfclientsymbiansession.h

00001
00016 #ifndef SMFCLIENTSYMBIANSESSION_H_
00017 #define SMFCLIENTSYMBIANSESSION_H_
00018
00019 #include <e32cmn.h>
00020 #include <QByteArray>
00021 #include <QString>
00022 #include <QVariant>
00023 #include <QList>
00024 #include <smfglobal.h>
00025
00029 class RSmfClientSymbianSession : public RSessionBase
00030 {
00031 public:
00035         RSmfClientSymbianSession();
00036
00041     TInt connectToServer();
00042
00046     TVersion Version() const{return TVersion(0,0,1);};
00047
00048     void Close(){};
00049
00050         bool isConnected();
00051
00052         bool connected;
00053
00058     TInt sendRequest(SmfRequestTypeID requestType);
00059
00063         TPtr8 sendSyncRequest(QByteArray& aSerializedData,
00064                         QString aInterfaceName,
00065                         SmfRequestTypeID aRequestType,
00066                         TInt maxSize);
00067
00071         TPtr8 sendDSMSyncRequest(SmfRequestTypeID aRequestType,
00072                         QByteArray& aSerializedData,
00073                         SmfError& aErr, TInt maxSize = 0 );
00074
00078         TPtr8 sendSyncRequest( QString aInterfaceName,
00079                         SmfRequestTypeID aRequestType,
00080                         TInt maxSize, QByteArray& aSerializedData );
00081
00091         void sendAsyncRequest(QByteArray& aSerializedData,
00092                         QString aInterfaceName, SmfRequestTypeID aRequestType,
00093                         TRequestStatus& aStatus, TInt aMaxAllocation);
00094
00098     TPtr8 getData()
00099                 {
00100                  return iDataPtr8;
00101                 }
00102
00103     TInt getLastRequest()
00104         {
00105         return iLastRequest;
00106         }
00107         TPtr8 iDataPtr8;
00108         TPtr iDataPtr16;
00109 private:
00113         QByteArray iBaseProvider;
00114     TBuf8<525> iProviderSymbian;
00115     TBuf<125> iInterfaceSymbian;
00116     TBuf8<125> iInterfaceSymbian8;
00117     QString iInterfaceName;
00118     HBufC* iIntfNameBuffer;
00119     HBufC* iBuffer16;
00120     TPtr iPtrProvider;
00121         TPtr8 iPtrProvider8;
00122         QByteArray iInterfaceNamebyte;
00123         TBuf<100> iDSMErr;
00124         HBufC8* iProviderBuf8;
00125     TPtr iIntfNamePtr;
00126         TPtr8 iIntfNamePtr8;
00127         HBufC8* iIntfNameBuffer8;
00128         HBufC8* iBuffer8;
00129         HBufC8* iXtraInfoBuf8;
00130     TPtr iPtrToXtraInfo;
00131     TPtr8 iPtrToXtraInfo8;
00132         HBufC8* iSlot0Buffer8;
00133         TPtr8 iPtr8ToSlot0;
00134         TInt iMaxMessageSize;
00135         TInt iMaxSize;
00139         TInt iLastRequest;
00140
00141 private:
00142         QList<QVariant*> result;
00143
00144         };
00145
00146 #endif /* SMFCLIENTSYMBIANSESSION_H_ */
Generated on Thu Sep 23 15:03:11 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfcomment.h Source File

  • File List

smf/smfservermodule/smfcommon/smfcomment.h

00001
00020 #ifndef SMFCOMMENT_H_
00021 #define SMFCOMMENT_H_
00022
00023 #include <QDateTime>
00024 #include <qdatastream.h>
00025 #include <QSharedData>
00026 #include "smfclientglobal.h"
00027 #include <QMetaType>
00028
00029 class SmfCommentPrivate;
00030
00035 class SMFCOMMON_EXPORT SmfComment
00036         {
00037 public:
00041         SmfComment( );
00042
00047         SmfComment( const SmfComment &aOther );
00048
00054         SmfComment& operator=(const SmfComment &aOther);
00055
00059         ~SmfComment( );
00060
00065         QString text( ) const;
00066
00071         QDateTime timeStamp( ) const;
00072
00077         QString id( ) const;
00078
00083         void setText( const QString &aText );
00084
00089         void setTimeStamp( const QDateTime &aDateTime );
00090
00095         void setId( const QString &aId );
00096
00097 private:
00098         QSharedDataPointer<SmfCommentPrivate> d;
00099
00100         friend QDataStream &operator<<( QDataStream &aDataStream,
00101                         const SmfComment &aComment );
00102
00103         friend QDataStream &operator>>( QDataStream &aDataStream,
00104                         SmfComment &aComment );
00105
00106         };
00107
00108
00116 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00117                 const SmfComment &aComment );
00118
00126 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00127                 SmfComment &aComment);
00128
00129
00130 // Make the class SmfComment known to QMetaType, so that as to register it.
00131 Q_DECLARE_METATYPE(SmfComment)
00132 Q_DECLARE_METATYPE(QList<SmfComment>)
00133
00134 #endif /* SMFCOMMENT_H_ */
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfcomment_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfcomment_p.h

00001
00020 #ifndef SMFCOMMENT_P_H_
00021 #define SMFCOMMENT_P_H_
00022
00023 #include <QDateTime>
00024 #include <QSharedData>
00025
00026 class SmfCommentPrivate : public QSharedData
00027 {
00028 public:
00032         SmfCommentPrivate( ) { m_text.clear(); m_commentId.clear(); }
00033
00038         SmfCommentPrivate( const SmfCommentPrivate &aOther ) :
00039                 QSharedData ( aOther ),
00040                 m_text ( aOther.m_text ),
00041                 m_timeStamp ( aOther.m_timeStamp ),
00042                 m_commentId ( aOther.m_commentId )      { }
00043
00047         ~SmfCommentPrivate( )
00048                 {
00049                 }
00050
00051         QString m_text;                 // comment text
00052         QDateTime m_timeStamp;  // comment time stamp
00053         QString m_commentId;    // comment Id
00054
00055 };
00056
00057 #endif /* SMFCOMMENT_P_H_ */
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfcontact.h Source File

  • File List

smf/smfservermodule/smfcommon/smfcontact.h

00001
00021 #ifndef SMFCONTACT_H_
00022 #define SMFCONTACT_H_
00023
00024 #include <qtcontacts.h>
00025 #include <qdatastream.h>
00026 #include <QSharedData>
00027 #include <QVariant>
00028
00029 #include "smfclientglobal.h"
00030
00031
00032 using namespace QtMobility;
00033
00034 /* forward declaration*/
00035 class SmfContactPrivate;
00036
00040 const int MaxSmfContactSize = 1000;
00041
00048 class  SMFCOMMON_EXPORT SmfContact
00049         {
00050 public:
00055         SmfContact( QObject *aParent = 0 );
00056
00061         SmfContact( const SmfContact &aOther );
00062
00068         SmfContact& operator=( const SmfContact &aOther );
00069
00073         ~SmfContact( );
00074
00075 public slots:
00101         QStringList subTypes( ) const;
00102
00109         void convert( QContact &aContact ) const;
00110
00117         QVariant value( const QString& aSubType ) const;
00118
00124         void setValue(const QString& aSubType,QVariant& value);
00125
00126 private:
00127         QSharedDataPointer<SmfContactPrivate> d;
00128
00129         friend QDataStream &operator<<( QDataStream &aDataStream,
00130                         const SmfContact &aContact );
00131
00132         friend QDataStream &operator>>( QDataStream &aDataStream,
00133                         SmfContact &aContact );
00134
00135         };
00136
00137
00145 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00146                 const SmfContact &aContact );
00147
00155 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00156                 SmfContact &aContact );
00157
00158
00159 typedef QList<SmfContact> SmfContactList;
00160
00161
00165 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00166         const QContactAddress &aAddress );
00167
00168 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00169                 QContactAddress &aAddress );
00170
00171 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00172         const QContactAnniversary &aAnniversary );
00173
00174 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00175                 QContactAnniversary &aAnniversary );
00176
00177 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00178         const QContactAvatar &aAvatar );
00179
00180 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00181                 QContactAvatar &aAvatar );
00182
00183 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00184         const QContactBirthday &aBirthday );
00185
00186 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00187                 QContactBirthday &aBirthday );
00188
00189 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00190         const QContactEmailAddress &aEMail );
00191
00192 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00193                 QContactEmailAddress &aEMail );
00194
00195 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00196         const QContactGender &aGender );
00197
00198 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00199                 QContactGender &aGender );
00200
00201 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00202         const QContactGeoLocation &aGeolocation );
00203
00204 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00205                 QContactGeoLocation &aGeolocation );
00206
00207 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00208         const QContactGuid &aGuid );
00209
00210 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00211                 QContactGuid &aGuid );
00212
00213 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00214         const QContactId &aContactId );
00215
00216 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00217                 QContactId &aContactId );
00218
00219 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00220         const QContactName &aName );
00221
00222 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00223                 QContactName &aName );
00224
00225 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00226         const QContactNickname &aNickname );
00227
00228 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00229                 QContactNickname &aNickname );
00230
00231 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00232         const QContactNote &aNote );
00233
00234 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00235                 QContactNote &aNote );
00236
00237 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00238         const QContactOnlineAccount &aOnlineAccount );
00239
00240 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00241                 QContactOnlineAccount &aOnlineAccount );
00242
00243 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00244         const QContactOrganization &aOrganization );
00245
00246 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00247                 QContactOrganization &aOrganization );
00248
00249 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00250         const QContactPhoneNumber &aPhoneNumber );
00251
00252 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00253                 QContactPhoneNumber &aPhoneNumber );
00254
00255 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00256         const QContactPresence &aPresence );
00257
00258 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00259                 QContactPresence &aPresence );
00260
00261 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00262         const QContactThumbnail &aThumbnail );
00263
00264 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00265                 QContactThumbnail &aThumbnail );
00266
00267 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00268         const QContactTimestamp &aTimestamp );
00269
00270 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00271                 QContactTimestamp &aTimestamp );
00272
00273 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00274         const QContactType &aType );
00275
00276 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00277                 QContactType &aType );
00278
00279 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00280         const QContactUrl &aUrl );
00281
00282 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00283                 QContactUrl &aUrl );
00284
00285
00286 // Make the class SmfContact known to QMetaType, so that as to register it.
00287 Q_DECLARE_METATYPE(SmfContact)
00288 Q_DECLARE_METATYPE(QList<SmfContact>)
00289
00290 //make qt mobility related classes known to moc
00291 Q_DECLARE_METATYPE(QContactAddress)
00292 Q_DECLARE_METATYPE(QContactAnniversary)
00293 Q_DECLARE_METATYPE(QContactAvatar)
00294 Q_DECLARE_METATYPE(QContactBirthday)
00295 Q_DECLARE_METATYPE(QContactId)
00296 Q_DECLARE_METATYPE(QContactEmailAddress)
00297 Q_DECLARE_METATYPE(QContactGender)
00298 Q_DECLARE_METATYPE(QContactGeoLocation)
00299 Q_DECLARE_METATYPE(QContactGuid)
00300 Q_DECLARE_METATYPE(QContactName)
00301 Q_DECLARE_METATYPE(QContactNickname)
00302 Q_DECLARE_METATYPE(QContactNote)
00303 Q_DECLARE_METATYPE(QContactOnlineAccount)
00304 Q_DECLARE_METATYPE(QContactOrganization)
00305 Q_DECLARE_METATYPE(QContactPhoneNumber)
00306 Q_DECLARE_METATYPE(QContactPresence)
00307 Q_DECLARE_METATYPE(QContactThumbnail)
00308 Q_DECLARE_METATYPE(QContactTimestamp)
00309 Q_DECLARE_METATYPE(QContactType)
00310 Q_DECLARE_METATYPE(QContactUrl)
00311
00312 #endif /* SMFCONTACT_H_ */
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfcontact_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfcontact_p.h

00001
00020 #ifndef SMFCONTACT_P_H_
00021 #define SMFCONTACT_P_H_
00022
00023 #include <QSharedData>
00024
00025 using namespace QtMobility;
00026
00027 class SmfContactPrivate : public QSharedData
00028 {
00029 public:
00033         SmfContactPrivate( ) { m_details.clear(); }
00034
00039         SmfContactPrivate( const SmfContactPrivate &aOther ) :
00040                 QSharedData ( aOther ),
00041                 m_details ( aOther.m_details )  { }
00042
00046         ~SmfContactPrivate( ){};
00047
00048         QVariantMap     m_details;// contact details
00049
00050 };
00051
00052 #endif /* SMFCONTACT_P_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfcontactfetcher.h Source File

  • File List

smf/smfservermodule/smfclient/smfcontactfetcher.h

00001
00020 #ifndef SMFCONTACTHETCHER_H
00021 #define SMFCONTACTHETCHER_H
00022
00023 #include <QObject>
00024 #include <smfglobal.h>
00025 #include <smfcontact.h>
00026 #include <smflocation.h>
00027 #include <smfgroup.h>
00028
00029 // Forward declaration
00030 class SmfProvider; //base-class for service provider
00031 class SmfContactFetcherPrivate;//implementation
00032
00047 class  SMFCLIENT_EXPORT SmfContactFetcher : public QObject
00048         {
00049         Q_OBJECT
00050
00051 public:
00058         SmfContactFetcher( SmfProvider* baseProvider );
00059
00067         SmfContactFetcher( SmfProvider* baseProvider, SmfContact* contact );
00068
00072         ~SmfContactFetcher();
00073
00074 public:
00084         SmfError friends ( int pageNum = SMF_FIRST_PAGE, int perPage = SMF_ITEMS_PER_PAGE );
00085
00096         SmfError followers ( int pageNum = SMF_FIRST_PAGE, int perPage = SMF_ITEMS_PER_PAGE );
00097
00109         SmfError search ( SmfContact* contact, int pageNum = SMF_FIRST_PAGE,
00110                                         int perPage = SMF_ITEMS_PER_PAGE );
00111
00124         SmfError searchNear ( SmfLocation* location,
00125                                         SmfLocationSearchBoundary proximity,
00126                                         int pageNum = SMF_FIRST_PAGE,
00127                                         int perPage = SMF_ITEMS_PER_PAGE);
00128
00139         SmfError groups ( int pageNum = SMF_FIRST_PAGE, int perPage = SMF_ITEMS_PER_PAGE );
00140
00152         SmfError searchInGroup ( SmfGroup group,
00153                                                 SmfContact* contact = NULL,
00154                                                 int pageNum = SMF_FIRST_PAGE,
00155                                                 int perPage = SMF_ITEMS_PER_PAGE );
00156
00167         SmfError customRequest ( const int& operationId, QByteArray* customData );
00168
00175         SmfError cancelRequest ();
00176
00177 signals:
00178
00188         void friendsListAvailable ( SmfContactList* list,
00189                         SmfError error, SmfResultPage resultPage );
00190
00200         void followersListAvailable ( SmfContactList* list,
00201                         SmfError error, SmfResultPage resultPage );
00202
00211         void searchContactFinished ( SmfContactList* list,
00212                         SmfError error, SmfResultPage resultPage );
00213
00222         void searchNearFinished(SmfContactList* list,SmfError error, SmfResultPage resultPage);
00223
00233         void groupListAvailable ( SmfGroupList* list,
00234                         SmfError error, SmfResultPage resultPage );
00235
00244         void searchInGroupFinished(SmfContactList* list,SmfError error, SmfResultPage resultPage);
00245
00252         void customDataAvailable ( int operationId, QByteArray* customData );
00253
00254 private:
00258         SmfProvider* getProvider() const;
00259
00260 // Friend Class declaration
00261         //so that private impl can directly call emit
00262         friend class SmfContactFetcherPrivate;
00263
00264 private:
00265         SmfProvider* m_baseProvider;
00266         SmfContact* m_frndContact;                              //used for searching
00267         SmfContactFetcherPrivate* m_private;    //private impl wrapper
00268
00269         };
00270
00271 SMF_SERVICE_NAME(SmfContactFetcher, "org.symbian.smf.client.contact.fetcher\0.2")
00272
00273 #endif // SMFCONTACTHETCHER_H
Generated on Thu Sep 23 15:03:11 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfcontactfetcher_p.h Source File

  • File List

smf/smfservermodule/smfclient/smfcontactfetcher_p.h

00001
00020 #ifndef SMFCLIENTPRIVATE_H_
00021 #define SMFCLIENTPRIVATE_H_
00022
00023 #include <smfprovider.h>
00024 #include <smfclientglobal.h>
00025 #include <smfglobal.h>
00026 #include <smfobserver.h>
00027 #include <smflocation.h>
00028 #include <smfgroup.h>
00029
00030 // Forward Declaration
00031 class SmfProvider;
00032 class SmfContact;
00033 class SmfContactFetcher;
00034 #ifdef Q_OS_SYMBIAN
00035         class CSmfClientSymbian;
00036 #else
00037         class SmfClientQt;
00038 #endif
00039
00040
00049 class SmfContactFetcherPrivate : public smfObserver
00050         {
00051         Q_OBJECT
00052
00053 public:
00058         SmfContactFetcherPrivate ( SmfContactFetcher* contactFetcher = 0 );
00059
00063         ~SmfContactFetcherPrivate();
00064         //Note we need to expose the methods later through some macro
00065
00066 public:
00076         SmfError friends ( int pageNum = SMF_FIRST_PAGE, int perPage = SMF_ITEMS_PER_PAGE );
00077
00088         SmfError followers ( int pageNum = SMF_FIRST_PAGE, int perPage = SMF_ITEMS_PER_PAGE );
00089
00101         SmfError search ( SmfContact* contact, int pageNum = SMF_FIRST_PAGE,
00102                                         int perPage = SMF_ITEMS_PER_PAGE );
00103
00116         SmfError searchNear ( SmfLocation* location,
00117                                         SmfLocationSearchBoundary proximity,
00118                                         int pageNum = SMF_FIRST_PAGE,
00119                                         int perPage = SMF_ITEMS_PER_PAGE);
00120
00131         SmfError groups ( int pageNum = SMF_FIRST_PAGE, int perPage = SMF_ITEMS_PER_PAGE );
00132
00144         SmfError searchInGroup ( SmfGroup group,
00145                                                 SmfContact* contact = NULL,
00146                                                 int pageNum = SMF_FIRST_PAGE,
00147                                                 int perPage = SMF_ITEMS_PER_PAGE );
00148
00159         SmfError customRequest ( const int& operationId, QByteArray* customData );
00160
00167         SmfError cancelRequest ();
00168
00169 public: //from smfobserver
00176         void resultsAvailable ( QByteArray result,
00177                         SmfRequestTypeID opcode, SmfError error );
00178
00179 private:
00180         SmfContactFetcher* m_contactFetcher;
00181         QByteArray m_dataSerialized;    //serialized byte array of provider and data
00182         //QByteArray m_xtraInfoSerialized;      //serialized xtra info, order of serialization follows order of param
00183         quint8 m_argFlag;
00184 #ifdef Q_OS_SYMBIAN
00185         CSmfClientSymbian* m_SmfClientPrivate;
00186         friend class CSmfClientSymbian;
00187 #else
00188         SmfClientQt* m_SmfClientPrivate;
00189         friend class SmfClientQt;
00190 #endif
00191
00192         };
00193
00194 QDataStream &operator<<( QDataStream &aDataStream, const SmfError &err );
00195 QDataStream &operator>>( QDataStream &aDataStream, SmfError &err );
00196
00197 #endif /* SMFCLIENTPRIVATE_H_ */
Generated on Thu Sep 23 15:03:11 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/smfplugins/smfcontactfetcherplugin.h Source File

  • File List

smf/smfservermodule/smfserver/smfplugins/smfcontactfetcherplugin.h

00001
00020 #ifndef SMFCONTACTFETCHERPLUGIN_H_
00021 #define SMFCONTACTFETCHERPLUGIN_H_
00022
00023 #include <smfpluginbase.h>
00024 #include <smfcontact.h>
00025 #include <smfgroup.h>
00026 #include <smflocation.h>
00027
00028
00038 class SmfContactFetcherPlugin : public SmfPluginBase
00039         {
00040 public:
00044         virtual ~SmfContactFetcherPlugin( ) {}
00045
00054         virtual SmfPluginError friends( SmfPluginRequestData &aRequest,
00055                         const int aPageNum = SMF_FIRST_PAGE,
00056                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00057
00066         virtual SmfPluginError followers( SmfPluginRequestData &aRequest,
00067                         const int aPageNum = SMF_FIRST_PAGE,
00068                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00069
00079         virtual SmfPluginError search( SmfPluginRequestData &aRequest,
00080                         const SmfContact &aContact,
00081                         const int aPageNum = SMF_FIRST_PAGE,
00082                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00083
00095         virtual SmfPluginError searchNear( SmfPluginRequestData &aRequest,
00096                         const SmfLocation &aLocation,
00097                         const SmfLocationSearchBoundary &aProximity,
00098                         const int aPageNum = SMF_FIRST_PAGE,
00099                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00100
00109         virtual SmfPluginError groups( SmfPluginRequestData &aRequest,
00110                         const int aPageNum = SMF_FIRST_PAGE,
00111                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00112
00124         virtual SmfPluginError searchInGroup( SmfPluginRequestData &aRequest,
00125                         const SmfGroup &aGroup,
00126                         SmfContact *aContact = NULL,
00127                         const int aPageNum = SMF_FIRST_PAGE,
00128                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00129
00140         virtual SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00141                         const int &aOperation, QByteArray *aData ) = 0;
00142         };
00143
00144 Q_DECLARE_INTERFACE( SmfContactFetcherPlugin, "org.symbian.smf.plugin.contact.fetcher/v0.2" );
00145
00146 #endif /* SMFCONTACTFETCHERPLUGIN_H_ */
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclient.h Source File

  • File List

smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclient.h

00001
00017 #ifndef SMFCREDMGRCLIENT_H_
00018 #define SMFCREDMGRCLIENT_H_
00019
00020 #include <QObject>
00021 #include <QUrl>
00022 #include <QDateTime>
00023 #include <QStringList>
00024
00025 #ifdef Q_OS_SYMBIAN
00026 #include <smfcredmgrcommon.h>
00027 #include <smfcredmgrclientglobal.h>
00028 #endif
00029 //Private implementation for different platforms
00030 #ifdef Q_OS_SYMBIAN
00031 class CSmfCredMgrClientSymbian;
00032 class RSmfCredMgrClientSession;
00033 #else
00034 class SmfCredMgrClientStub;
00035 class SmfCredMgrClientStubSession;
00036 #endif
00037
00042 class SmfCredMgrClient_EXPORT SmfCredMgrClient : public QObject
00043         {
00044         //Q_OBJECT -- todo used when signal and slots implemented
00045 public:
00046
00050         SmfCredMgrClient(QObject* parent = 0);
00051
00055         ~SmfCredMgrClient();
00056
00057 public:
00058
00064         bool CheckPluginAuthentication(QString PluginID) const;
00065
00074         bool AuthDataSet(QString RegToken,QDateTime Validity, SmfAuthParams& AuthDataSet) const;
00075
00081         QList<QUrl> URLList(QString PluginID) const;
00082
00088         QStringList AuthenticatedPluginList(QString RegistrationToken) const;
00089
00095         QString GenerateNONCE(const qint64 Length);
00096
00104         void ChangePluginIDList(QString NewPluginID,bool Flag, QString OldPluginID);
00116         QString StoreAuthData(SmfAuthParams Set,
00117                         QDateTime Validity, QList<QUrl> URLList, QStringList PluginList,
00118                         QString AuthAppId, bool Flag);
00119
00127         QString StoreRSAKeys(const QString KeyLabel,
00128                         const QString Keydata, const QDateTime Validity);
00129
00141         SMFCredMgrErrorCode SignMessage(QString Message,
00142                         QString Key, QString& Signature, SmfSignatureMethod AlgorithmUsed);
00147         void DeleteRSAKey(QString KeyLabel);
00148
00149 private:
00153 #ifdef Q_OS_SYMBIAN
00154         CSmfCredMgrClientSymbian* m_SmfClientPrivate;
00155         //friend class CSmfCredMgrClientSymbian;
00156 #endif
00157
00158         };
00159
00160 #endif /* SMFCREDMGRCLIENT_H_ */
00161
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclient_p.h Source File

  • File List

smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclient_p.h

00001
00018 #ifndef __SMFCREDMGRCLIENT_P_H__
00019 #define __SMFCREDMGRCLIENT_P_H__
00020
00021 //  Include Files
00022 #ifdef Q_OS_SYMBIAN
00023 #include <e32base.h>
00024 #include <e32std.h>
00025 #include <e32cmn.h>
00026 #include <s32strm.h>
00027 #include <S32MEM.H>
00028 #include <e32des16.h>
00029 #endif
00030 #include <QUrl>
00031 #include <QDateTime>
00032 #include <private/qcore_symbian_p.h>
00033 #include <QtCore/qglobal.h>
00034 #include <qstring.h>
00035 #include <QStringList>
00036 #include <qbytearray.h>
00037 #include <qlist.h>
00038
00039 #ifdef Q_OS_SYMBIAN
00040 #include "smfcredmgrcommon.h"  //client-server common header.
00041 #include "smfcredmgrclientsession.h"
00042 #include "smfcredmgrclientglobal.h"
00043 #else
00044 #endif
00045
00046 const TInt KMinBufSize = 128;
00047 const TInt KMaxBufSize = 512;
00048
00049 //forward declarations
00050 class SmfCredMgrClient;
00051
00056 class CSmfCredMgrClientSymbian : public CActive
00057         {
00058 public:
00063         static CSmfCredMgrClientSymbian* NewL(SmfCredMgrClient* aPublicImpl);
00064         static CSmfCredMgrClientSymbian* NewLC(SmfCredMgrClient* aPublicImpl);
00065
00069         ~CSmfCredMgrClientSymbian();
00070
00082         QString storeAuthDataL(SmfAuthParams Set, QDateTime Validity,
00083                         QList<QUrl> URLList, QStringList PluginList, QString AuthAppAID,
00084                         bool Flag);
00085
00091         TBool isPluginAuthenticatedL(QString PluginID);
00092
00098         void authenticatedPluginListL(QString RegistrationToken, QStringList& List);
00099
00105         void URLListL(QString PluginID, QList<QUrl>& List);
00106
00112         QString generateNONCE(const qint64 Length);
00113
00121         void changePluginIDListL(const QString NewPluginID, const bool Flag,
00122                         const QString OldPluginID);
00123
00131         TBool AuthDataSetL(QString RegToken, QDateTime Validity,
00132                         SmfAuthParams& AuthTokenSet);
00133
00141         QString storeRSAKeysL(const QString KeyLabel, const QString keydata,
00142                         const QDateTime Validity);
00154         SMFCredMgrErrorCode signMessageL(QString Message, QString Key,
00155                         QString& Signature, SmfSignatureMethod AlgorithmUsed);
00160         void deleteRSAKey(QString KeyLabel);
00161
00162 protected:
00163         // Functions from base classes
00164
00170         void RunL();
00171
00176         void DoCancel();
00177
00178 private:
00183         CSmfCredMgrClientSymbian(SmfCredMgrClient* aPublicImpl);
00184
00188         void ConstructL();
00189
00190 private:
00194         RSmfCredMgrClientSession iSession;
00198         SmfCredMgrClient* iPublicImpl;
00199
00200         };
00201
00202 #endif  // __SMFCREDMGRCLIENT_P_H__
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrclientdatastruct.h Source File

  • File List

smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrclientdatastruct.h

00001
00018 #ifndef CSMFCREDMGRCLIENTDATASTRUCT_H_
00019 #define CSMFCREDMGRCLIENTDATASTRUCT_H_
00020
00021 // System includes
00022 #include <e32cmn.h>
00023 #include <S32MEM.H>
00024 #include <s32strm.h>
00025
00026 #include "smfcredmgrcommon.h"
00027
00031 const TInt KMaxAuthTokenLength = 256;
00032
00036 const TInt KMaxPluginIDLength = 256;
00037
00041 const TInt KMaxRegistrationTokenLength = 50;
00042
00046 const TInt KMaxURLStringLength = 256;
00047
00051 const TInt KMaxAuthIdLength = 256;
00052
00056 const TInt KMaxSignedMsgLength = 256;
00057
00058
00062 class TSmfAuthToken
00063         {
00064 public:
00068         inline TSmfAuthToken() :
00069                 iKey(NULL), iSecret(NULL)
00070                 {
00071                 }
00072
00077         void ExternalizeL(RWriteStream& aStream);
00078
00083         void InternalizeL(RReadStream& aStream);
00084
00088         HBufC* iKey;
00089
00093         HBufC* iSecret;
00094         };
00095
00096
00100 class CSmfFetchAuthTokenSet : public CBase
00101         {
00102 public:
00106         ~CSmfFetchAuthTokenSet()
00107                 {
00108                 iAuthTokenArray.Reset();
00109                 delete iRegistrationToken;
00110                 }
00111
00116         void ExternalizeL(RWriteStream& aStream);
00117
00122         void InternalizeL(const RBuf8& aSource);
00123
00127         HBufC* iRegistrationToken;
00128
00132         TUint32 iValidity;
00133
00137         RArray<TSmfAuthToken> iAuthTokenArray;
00138         };
00139
00140
00144 class CSmfURLListParams : public CBase
00145         {
00146 public:
00150         ~CSmfURLListParams()
00151                 {
00152                 iURLList.ResetAndDestroy();
00153                 delete iPluginID;
00154                 }
00155
00160         void ExternalizeL(RWriteStream& aStream);
00161
00166         void InternalizeL(const TDesC8& aSource);
00167
00171         RPointerArray<HBufC> iURLList;
00172
00176         HBufC* iPluginID;
00177         };
00178
00179
00183 class CSmfPluginIDListParams : public CBase
00184         {
00185 public:
00189         ~CSmfPluginIDListParams()
00190                 {
00191                 iPluginList.ResetAndDestroy();
00192                 delete iRegistrationToken;
00193                 }
00194
00199         void ExternalizeL(RWriteStream& aStream);
00200
00205         void InternalizeL(const RBuf8& aSource);
00206
00210         RPointerArray<HBufC> iPluginList;
00211
00215         HBufC* iRegistrationToken;
00216         };
00217
00221 class CSmfStoreAuthParams : public CBase
00222         {
00223 public:
00227         ~CSmfStoreAuthParams()
00228                 {
00229                 iAuthTokenArray.Reset();
00230                 iURLList.ResetAndDestroy();
00231                 iPluginIDList.ResetAndDestroy();
00232                 delete iRegistrationToken;
00233                 delete iAuthAppID;
00234                 }
00235
00240         void ExternalizeL(RWriteStream& aStream);
00241
00246         void InternalizeL(const RBuf8& aSource);
00247
00251         RArray<TSmfAuthToken> iAuthTokenArray;
00252
00256         RPointerArray<HBufC> iPluginIDList;
00257
00261         RPointerArray<HBufC> iURLList;
00262
00266         HBufC* iRegistrationToken;
00267
00271         HBufC* iAuthAppID;
00272
00276         TBool pluginIDEnabled;
00277
00281         TUint32 iValidity;
00282         };
00283
00288 class CSmfPluginIDUpdate : public CBase
00289         {
00290 public:
00291         ~CSmfPluginIDUpdate()
00292                 {
00293                 delete iNewPluginID;
00294                 delete iOldPluginID;
00295                 }
00296
00301         void ExternalizeL(RWriteStream& aStream);
00302
00307         void InternalizeL(const RBuf8& aSource);
00308
00312         HBufC* iNewPluginID;
00313
00317         HBufC* iOldPluginID;
00318
00322         TBool pluginIDEnabled;
00323         };
00324
00328 class CSmfSignParameters : public CBase
00329 {
00330 public:
00337         static CSmfSignParameters* NewL( const TDesC8& aMessage, const TDesC8& aKey );
00338
00344         static CSmfSignParameters* NewL( const TDesC8& aData );
00345
00349         ~CSmfSignParameters();
00350
00355         void ExternalizeL( RWriteStream& aStream ) const;
00356
00361         const TDesC8& Key() const;
00362
00367         const TDesC8& Message() const;
00368
00369 private:
00373         CSmfSignParameters();
00374
00380         void ConstructL( const TDesC8& aMessage, const TDesC8& aKey );
00381
00386         void ConstructL( const TDesC8& aData );
00387
00388 private:
00392         RBuf8 iMessage;
00393
00397         RBuf8 iKey;
00398 };
00399
00403 class CSmfRsaKeyParameters : public CBase
00404         {
00405 public:
00414         static CSmfRsaKeyParameters* NewL( const TDesC& aKeyName,
00415                         const TTime& startDate,
00416                         const TTime& endDate,
00417                         const TDesC8& aKeyData );
00418
00424         static CSmfRsaKeyParameters* NewL( const TDesC8& aData );
00425
00429         ~CSmfRsaKeyParameters();
00430
00435         void ExternalizeL( RWriteStream& aStream ) const;
00436
00441         const TDesC& KeyName() const;
00442
00447         const TDesC8& KeyData() const;
00448
00453         const TTime& StartDate() const;
00454
00459         const TTime& EndDate() const;
00460
00461 private:
00469         void ConstructL( const TDesC& aKeyName,
00470                         const TTime& startDate,
00471                         const TTime& endDate,
00472                         const TDesC8& aKeyData );
00473
00478         void ConstructL( const TDesC8& aData );
00479
00480 private:
00484         RBuf iKeyName;
00485
00489         RBuf8 iKeyData;
00490
00494         TTime iStartDate;
00495
00499         TTime iEndDate;
00500         };
00501
00502 #endif /* CSMFCREDMGRCLIENTDATASTRUCT_H_ */
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrclientglobal.h Source File

  • File List

smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrclientglobal.h

00001
00018 #ifndef SMFCREDMGRCLIENTGLOBAL_H
00019 #define SMFCREDMGRCLIENTGLOBAL_H
00020
00021 #include <QtCore/qglobal.h>
00022 #include <QByteArray>
00023 #include <QMap>
00024
00025 typedef QMap<QByteArray, QByteArray> SmfAuthParams;
00026
00027 #if defined(SMFCREDMGRCLIENT_LIBRARY)
00028 #define SmfCredMgrClient_EXPORT Q_DECL_EXPORT
00029 #else
00030 #define SmfCredMgrClient_EXPORT Q_DECL_IMPORT
00031 #endif
00032
00037 enum SMFCredMgrErrorCode
00038         {
00042         SmfErrNone = 200,
00043
00047         SmfErrUnAutherised,
00048
00052         SmfErrBadParameter,
00053
00057         SmfErrUnKnown
00058         };
00059
00060 #endif // SMFCREDMGRCLIENTGLOBAL_H
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclientsession.h Source File

  • File List

smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclientsession.h

00001
00017 #ifndef RSMFCREDMGRCLIENTSESSION_H_
00018 #define RSMFCREDMGRCLIENTSESSION_H_
00019
00020 #ifdef Q_OS_SYMBIAN
00021 #include <smfcredmgrcommon.h>
00022 #include <e32std.h>
00023 #include <e32std.h>
00024 #include <e32cmn.h>
00025 #endif
00026
00031 class RSmfCredMgrClientSession : public RSessionBase
00032         {
00033 public:
00037         RSmfCredMgrClientSession();
00038
00042         TInt connectToServer();
00043
00047         TVersion Version() const;
00048
00052         void Close();
00053
00058         void RequestAsyncService(TCredentialServerRequestID aRequestType,
00059                         TRequestStatus& aStatus);
00060
00064         void RequestService(TCredentialServerRequestID aRequestType,
00065                         const TIpcArgs &aArgs);
00066
00067         };
00068
00069 #endif /* RSMFCREDMGRCLIENTSESSION_H_ */
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclientutil.h Source File

  • File List

smf/smfcredentialmgr/smfcredmgrclient/smfcredmgrclientutil.h

00001
00017 #ifndef SMFQTSYMBIANCONVERSIONUTILS_H_
00018 #define SMFQTSYMBIANCONVERSIONUTILS_H_
00019
00020 #include <QObject>
00021 #include <QUrl>
00022 #include <QDateTime>
00023 #include <private/qcore_symbian_p.h>
00024 #include <QtCore/qglobal.h>
00025 #include <qstring.h>
00026 #include <QStringList>
00027 #include <qbytearray.h>
00028 #include <qlist.h>
00029 #include <QDebug>
00030
00031
00032
00033 #ifdef Q_OS_SYMBIAN
00034 #include <e32base.h>
00035 #include <e32std.h>
00036 #include <e32cmn.h>
00037 #include <s32strm.h>
00038 #include <S32MEM.H>
00039 #include <e32des16.h>
00040 #include <smfcredmgrclientdatastruct.h>
00041 #include <smfcredmgrclientglobal.h>
00042 #endif
00043
00046 namespace smfcredmgrclientutil
00047         {
00048
00054         RPointerArray<HBufC> convertToSymbianURLList(QList<QUrl> URLList);
00055
00061         RPointerArray<HBufC> convertToSymbianPluginList(QStringList PluginList);
00062
00068         void convertToQStringList(RPointerArray<HBufC> aPluginList,
00069                         QStringList &ListInQt);
00070
00076         void convertToQUrlList(RPointerArray<HBufC> aURLList, QList<QUrl> &List);
00077
00083         void RArrayToSmfAuthParams(RArray<TSmfAuthToken> aArray,
00084                         SmfAuthParams& Params);
00085
00091         void SmfAuthParamstoRArray(SmfAuthParams Params,
00092                         RArray<TSmfAuthToken>& aArray);
00093
00094         }
00095
00096 #endif /* SMFQTSYMBIANCONVERSIONUTILS_H_ */
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrcommon.h Source File

  • File List

smf/smfcredentialmgr/smfcredmgrcommon/inc/smfcredmgrcommon.h

00001
00056 #ifndef COMMON_H_
00057 #define COMMON_H_
00058
00059 #include <e32base.h>
00060 #include <e32debug.h>
00061
00065 _LIT(KCredMgrServerName,"smfcredmgrserver");
00066 _LIT(KCredMgrServerSemaphoreName, "smfcredmgrserversemaphore" );
00067 _LIT(KCredMgrServerFilename, "smfcredmgrserver" );
00068
00069 const TUint KDefaultMessageSlots = 10;
00073 const TUint KSecureServMajorVersionNumber = 1;
00074 const TUint KSecureServMinorVersionNumber = 0;
00075 const TUint KSecureServBuildVersionNumber = 0;
00076
00081 enum SmfSignatureMethod
00082         {
00086         ESmfNoSigningMethod = 0,
00087
00091         ESMFRSAProtocol,
00092
00096         ESMFHMACProtocol,
00097
00101         ESMFPlainText,
00102
00106         ESMFSHA256Protocol
00107         };
00108
00112 enum TCredentialServerRequestID
00113         {
00117         ECheckPluginAuthentication = 1,
00118
00122         EStoreAuthData,
00123
00127         ESendAuthDataSet,
00128
00132         ESendPluginIDList,
00133
00137         ESendURLList,
00138
00142         EUpdatePluginIDList,
00143
00147         ESmfStoreRSAKey,
00148
00152         ESmfRSASignMessage,
00153
00157         ESmfHMACSHA1SignMessage,
00158
00162         ESmfDeleteKeys
00163         };
00164
00165 #endif /* COMMON_H_ */
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrdb.h Source File

  • File List

smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrdb.h

00001
00021 #ifndef SMFCREDMGRDB_H_
00022 #define SMFCREDMGRDB_H_
00023
00024 #include <sqldb.h>
00025 #include <e32base.h>
00026 #include <f32file.h>
00027
00028 //the private folder of the app
00029 _LIT(KSmfCredMgrDbPrivateDir, "C:\\private\\EF0FFBD7\\");
00030 _LIT(KSmfCredMgrDbFileName, "[EF0FFBD7]CREDMGRDB.db");
00031
00032 //Create Database Table Queries
00033 _LIT8(KCreatePluginIDTable,"CREATE TABLE PluginIDTable(PluginId TEXT, AuthAppId TEXT, IsEnabled INT, PRIMARY KEY(PluginId, AuthAppId))");
00034 _LIT8(KCreateURLTable,"CREATE TABLE URLTable(AuthAppId TEXT, URL TEXT, PRIMARY KEY(AuthAppId, URL))");
00035 _LIT8(KCreateRegTokenValidityTable,"CREATE TABLE RegTokenValidityTable(RegistrationToken TEXT PRIMARY KEY, AuthAppId TEXT UNIQUE, Validity BIGINT)");
00036 _LIT8(KCreateAuthParamsTable,"CREATE TABLE AuthParamsTable(AuthAppId TEXT, AuthKey TEXT, AuthSecret TEXT, PRIMARY KEY(AuthAppId, AuthKey))");
00037
00038
00043 class CSmfCredMgrDb : public CBase
00044         {
00045 public:
00050         static CSmfCredMgrDb* NewL();
00051
00056         static CSmfCredMgrDb* NewLC();
00057
00061         ~CSmfCredMgrDb();
00062
00063 private:
00067         CSmfCredMgrDb();
00068
00072         void ConstructL();
00073
00080         TInt CreateDbFile(const TFileName &aFileName);
00081
00086         void CompleteDBCreationL(const TFileName &aFileName);
00087
00093         TInt PluginIDTableCreate();
00094
00100         TInt URLTableCreate();
00101
00107         TInt RegTokenValidityTableCreate();
00108
00114         TInt AuthParamsTableCreate();
00115
00122         TInt DeleteDbFile(const TFileName &aFileName);
00123
00124 private:
00125         RFs iFileSession;
00126         TFileName iDbFilePathName;
00127         RSqlDatabase iDataBase;
00128         };
00129
00130 #endif /* SMFCREDMGRDB_H_ */
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrdbuser.h Source File

  • File List

smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrdbuser.h

00001
00021 #ifndef SMFCREDMGRDBUSER_H_
00022 #define SMFCREDMGRDBUSER_H_
00023
00024 #include <sqldb.h>
00025 #include <e32base.h>
00026 #include <f32file.h>
00027
00028 #include "smfcredmgrserversession.h"
00029
00030 //DB COMMANDS
00031 _LIT(KBegin , "BEGIN");
00032 _LIT(KCommit, "COMMIT");
00033 _LIT(KRollback, "ROLLBACK");
00034
00035 //INSERTION
00036 _LIT(KSmfPluginIDTableInsert, "INSERT OR REPLACE INTO PluginIDTable(PluginId, AuthAppId, IsEnabled) VALUES(:Val1, :Val2, :Val3)");
00037 _LIT(KSmfURLTableInsert, "INSERT OR REPLACE INTO URLTable(AuthAppId, URL) VALUES(:Val1, :Val2)");
00038 _LIT(KSmfRegTokenValidityTableInsert, "INSERT OR REPLACE INTO RegTokenValidityTable(RegistrationToken, AuthAppId, Validity) VALUES(:Val1, :Val2, :Val3)");
00039 _LIT(KSmfAuthParamsTableInsert, "INSERT OR REPLACE INTO AuthParamsTable(AuthAppId, AuthKey, AuthSecret) VALUES(:Val1, :Val2, :Val3)");
00040
00041 //READ
00042 _LIT(KSmfDbReadValidity, "SELECT Validity FROM RegTokenValidityTable WHERE AuthAppId = :iID");
00043 _LIT(KSmfDbReadRegistrationToken, "SELECT RegistrationToken FROM RegTokenValidityTable WHERE AuthAppId = :iID");
00044 _LIT(KSmfDbReadAuthTokens, "SELECT AuthKey, AuthSecret FROM AuthParamsTable WHERE AuthAppId = :iID");
00045 _LIT(KSmfDbReadPluginID, "SELECT PluginId, IsEnabled FROM PluginIDTable WHERE AuthAppId = :iID");
00046 _LIT(KSmfDbReadURL, "SELECT URL FROM URLTable WHERE AuthAppId = :iID");
00047 _LIT(KSmfDbReadAuthAppIdInPluginTable, "SELECT AuthAppId FROM PluginIDTable WHERE PluginId = :iID");
00048 _LIT(KSmfDbReadFlagInPluginTable, "SELECT IsEnabled FROM PluginIDTable WHERE PluginId = :iID");
00049 _LIT(KSmfDbReadAuthAppIdInRegTokenTable, "SELECT AuthAppId, Validity FROM RegTokenValidityTable WHERE RegistrationToken = :iID");
00050
00051 //UPDATE
00052 _LIT( KUpdatePluginID, "UPDATE PluginIDTable SET PluginId =:iText, IsEnabled =:iFlag WHERE PluginId = :iID");
00053
00057 class CSmfCredMgrDbUser : public CBase
00058         {
00059 public:
00065         static CSmfCredMgrDbUser* NewL(CSmfCredMgrServerSession* aSession);
00066
00073         static CSmfCredMgrDbUser* NewLC(CSmfCredMgrServerSession* aSession);
00074
00078         ~CSmfCredMgrDbUser();
00079
00080 public:
00090         TInt PluginIDTableInsert(const TDesC& aPluginID,
00091                         const TDesC& aAuthAppId,
00092                         TBool aEnableFlag);
00093
00101         TInt URLTableInsert(const TDesC& aAuthAppId, const TDesC& aURL);
00102
00111         TInt RegTokenValidityTableInsert(const TDesC& aRegToken,
00112                         const TDesC& aAuthAppId, const TUint aValidity);
00113
00122         TInt AuthParamsTableInsert(const TDesC& aAuthAppId, const TDesC& aKey,
00123                         const TDesC& aSecret);
00124
00130         void fetchPluginListL(const TDesC& aRegToken, RPointerArray<HBufC>& aArray);
00131
00137         void readAuthTokensL(const TDesC& aAuthAppId, RArray<TSmfAuthToken>& aArray);
00138
00144         void readUrlL(const TDesC& aAuthAppId, RPointerArray<HBufC>& aArray);
00145
00151         void readValidity(const TDesC& aAuthAppId, TInt64& aValidity);
00152
00158         void readRegistrationTokenL(const TDesC& aAuthAppId, TDesC& aRegToken);
00159
00166         void readAuthAppIdInRegTokenTable(const TDesC& aRegToken, TDes& aAuthAppId);
00167
00173         void readAuthAppIdInPluginIdTable(const TDesC& aPluginID, TDes& aAuthAppId);
00174
00180         void readFlagInPluginIdTable(const TDesC& aPluginID, TInt& aFlag);
00181
00190         TInt updatePlugin(const TDesC& aPluginID, const TBool& aFlag,
00191                         const TDesC& aOldPluginID);
00192
00199         void readPluginIdL(const TDesC& aAuthAppId, RPointerArray<HBufC>& aArray);
00200
00201 private:
00206         CSmfCredMgrDbUser(CSmfCredMgrServerSession* aSession);
00207
00211         void ConstructL();
00212
00213 private:
00214         //data
00215         RFs iFileSession;
00216         TFileName iDbFilePathName;
00217         RSqlDatabase iDataBase;
00218         CSmfCredMgrServerSession* iSession;
00219         };
00220
00221 #endif /* SMFCREDMGRDBUSER_H_ */
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrserver.h Source File

  • File List

smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrserver.h

00001
00019 #ifndef __SMFCREDMGRSERVER_H__
00020 #define __SMFCREDMGRSERVER_H__
00021
00022 //  Include Files
00023 #include <e32base.h>
00024
00025 // Forward declaration
00026 class CSmfCredMgrDb;
00027
00028 //  Function Prototypes
00029 GLDEF_C TInt E32Main();
00030
00031 // ----------------------------------------------------------------------------------------
00032 // Server's policy
00033 // ----------------------------------------------------------------------------------------
00034 static const TUint rangeCount = 1;
00035
00036 static const TInt ranges[rangeCount] =
00037         {
00038         0
00039         };
00040
00041 static const TUint8 elementsIndex[rangeCount] =
00042         {
00043         CPolicyServer::EAlwaysPass
00044         };
00045
00046 static const CPolicyServer::TPolicy policy =
00047         {
00048         CPolicyServer::EAlwaysPass, //specifies all connect attempts should pass
00049                         rangeCount,
00050                         ranges,
00051                         elementsIndex,
00052                         NULL
00053         };
00054
00059 class CSmfCredMgrServer : public CPolicyServer
00060         {
00061 public:
00066         static CSmfCredMgrServer * NewL();
00067
00072         static CSmfCredMgrServer* NewLC();
00073
00077         ~CSmfCredMgrServer();
00078
00085         CSession2* NewSessionL(const TVersion& aVersion, const RMessage2& aMessage) const;
00086
00087 private:
00091         CSmfCredMgrServer();
00092
00096         void ConstructL();
00097
00098 private:
00099         CSmfCredMgrDb* iDbCreator;
00100         };
00101
00102 #endif  // __SMFCREDMGRSERVER_H__
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrserversession.h Source File

  • File List

smf/smfcredentialmgr/smfcredmgrserver/inc/smfcredmgrserversession.h

00001
00019 #ifndef SMFCREDMGRSERVERSESSION_H_
00020 #define SMFCREDMGRSERVERSESSION_H_
00021
00022 #include <e32base.h>
00023
00024 #include "smfcredmgrserver.h"
00025 #include "smfcredmgrclientdatastruct.h"
00026 #include "smfkeystoremanager.h"
00027
00031 class CSmfCredMgrDbUser;
00032
00036 const TInt KMaxBufSize = 512;
00037
00042 class CSmfCredMgrServerSession : public CSession2
00043         {
00044 public:
00050         static CSmfCredMgrServerSession* NewL(CSmfCredMgrServer& aServer);
00051
00057         static CSmfCredMgrServerSession* NewLC(CSmfCredMgrServer& aServer);
00058
00062         ~CSmfCredMgrServerSession();
00063
00064 public: // from CSession2
00070         virtual void ServiceL(const RMessage2& aMessage);
00071
00072 private:
00077         CSmfCredMgrServerSession(CSmfCredMgrServer& aServer);
00078
00082         void ConstructL();
00083
00088         void storeInDb(CSmfStoreAuthParams* aParams);
00089
00094         void fetchPluginIDsL(CSmfPluginIDListParams* aParams);
00095
00100         void fetchUrlL(CSmfURLListParams* aArg);
00101
00106         void getTokenArrayL(CSmfFetchAuthTokenSet* aParams);
00107
00108 private:  // Data
00109         CSmfCredMgrServer& iServer;
00110         CSmfCredMgrDbUser* iDbUser;
00111         CSmfKeyStoreManager* iKeyStore;
00112         CSmfFetchAuthTokenSet* iFetchAuthTokenSetParams;
00113
00114         };
00115
00116 #endif /* SMFCREDMGRSERVERSESSION_H_ */
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfdes.h Source File

  • File List

smf/smfdes.h

00001
Generated on Thu Sep 23 15:03:11 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfevent.h Source File

  • File List

smf/smfservermodule/smfcommon/smfevent.h

00001
00020 #ifndef SMFEVENT_H_
00021 #define SMFEVENT_H_
00022
00023 #include "smflocation.h"
00024 #include "smfartists.h"
00025 #include <QStringList>
00026 #include <QDatastream>
00027 #include <QSharedData>
00028 #include "smfclientglobal.h"
00029 #include <QMetaType>
00030
00031 class SmfEventPrivate;
00032
00037 class SMFCOMMON_EXPORT SmfEvent
00038         {
00039 public:
00043         SmfEvent( );
00044
00049         SmfEvent( const SmfEvent &aOther );
00050
00056         SmfEvent& operator=( const SmfEvent &aOther );
00057
00061         ~SmfEvent( );
00062
00067         QString title( ) const;
00068
00073         QDateTime eventDateTime( ) const;
00074
00079         QTime duration( ) const;
00080
00085         SmfArtists artists( ) const;
00086
00091         SmfLocation venue( ) const;
00092
00097         QUrl ticketUrl( ) const;
00098
00103         QString id( ) const;
00104
00109         void setTitle( const QString &aName );
00110
00116         void setEventDateTime( const QDateTime &aDateTime );
00117
00123         void setDuration( const QTime &aDuration );
00124
00129         void setArtists( const SmfArtists &aArtists );
00130
00135         void setVenue( const SmfLocation &aVenue );
00136
00141         void setTicketUrl( const QUrl &aUrl );
00142
00147         void setId( const QString &aId );
00148
00149 private:
00150         QSharedDataPointer<SmfEventPrivate> d;
00151
00152         friend QDataStream &operator<<( QDataStream &aDataStream,
00153                         const SmfEvent &aEvent );
00154
00155         friend QDataStream &operator>>( QDataStream &aDataStream,
00156                         SmfEvent &aEvent );
00157
00158         };
00159
00160
00168 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00169                 const SmfEvent &aEvent );
00170
00178 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00179                 SmfEvent &aEvent);
00180
00181
00182 typedef QList<SmfEvent> SmfEventList;
00183
00184 // Make the class SmfEvent known to QMetaType, so that as to register it.
00185 Q_DECLARE_METATYPE(SmfEvent)
00186 Q_DECLARE_METATYPE(QList<SmfEvent>)
00187
00188
00189 #endif /* SMFEVENT_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfevent_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfevent_p.h

00001
00020 #ifndef SMFEVENT_P_H_
00021 #define SMFEVENT_P_H_
00022
00023
00024 #include <smflocation.h>
00025 #include <smfartists.h>
00026 #include <QStringList>
00027 #include <QSharedData>
00028
00029 class SmfEventPrivate : public QSharedData
00030 {
00031 public:
00035         SmfEventPrivate( ) {
00036                 m_name.clear();
00037                 m_url.clear();
00038                 m_eventId.clear();
00039
00040         }
00041
00046         SmfEventPrivate( const SmfEventPrivate &aOther ) :
00047                 QSharedData ( aOther ),
00048                 m_name ( aOther.m_name ),
00049                 m_dateTime ( aOther.m_dateTime ),
00050                 m_duration ( aOther.m_duration ),
00051                 m_artists ( aOther.m_artists ),
00052                 m_venue ( aOther.m_venue ),
00053                 m_url ( aOther.m_url ),
00054                 m_eventId ( aOther.m_eventId )  { }
00055
00059         ~SmfEventPrivate( )
00060                 {
00061                 }
00062
00063         QString         m_name;         // event name
00064         QDateTime       m_dateTime;     // event date and time
00065         QTime           m_duration;     // event duration
00066         SmfArtists      m_artists;      // event artist names
00067         SmfLocation     m_venue;        // event venue
00068         QUrl            m_url;          // ticket url
00069         QString         m_eventId;      // event Id
00070
00071 };
00072
00073 #endif /* SMFEVENT_P_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfeventsfetcher.h Source File

  • File List

smf/smfservermodule/smfclient/smfeventsfetcher.h

00001
00020 #ifndef SMFEVENTSFETCHER_H_
00021 #define SMFEVENTSFETCHER_H_
00022
00023 #include <smfglobal.h>
00024 #include <smfevent.h>
00025 #include <smflocation.h>
00026 #include <smfprovider.h>
00027 #include <smfcontact.h>
00028
00029 class SmfEventsFetcherPrivate;
00030
00031 using namespace QtMobility;
00032
00037 class SMFCLIENT_EXPORT SmfEventsFetcher : public QObject
00038         {
00039         Q_OBJECT
00040
00041 public:
00047         SmfEventsFetcher ( SmfProvider* baseProvider = 0 );
00048
00052         ~SmfEventsFetcher ( );
00053
00054 public:
00064         SmfError events ( SmfLocation venue, int pageNum = SMF_FIRST_PAGE,
00065                         int perPage = SMF_ITEMS_PER_PAGE);
00066
00076         SmfError venues ( SmfLocation location, int pageNum = SMF_FIRST_PAGE,
00077                         int perPage = SMF_ITEMS_PER_PAGE);
00078
00079
00088         SmfError attendees(SmfEvent event, int pageNum = SMF_FIRST_PAGE,
00089                         int perPage = SMF_ITEMS_PER_PAGE);
00090
00091 public slots:
00098         SmfError postEvents ( SmfEventList events );
00099
00110         SmfError customRequest ( const int& operationId, QByteArray* customData );
00111
00118         SmfError cancelRequest ();
00119
00120 signals:
00128         void eventsAvailable ( SmfEventList* list,
00129                         SmfError error, SmfResultPage resultPage );
00130
00138         void venuesAvailable ( SmfLocationList* list,
00139                         SmfError error, SmfResultPage resultPage );
00140
00148         void attendeesAvailable ( SmfContactList* list,
00149                         SmfError error, SmfResultPage resultPage );
00150
00155         void eventsUpdated ( SmfError success );
00156
00162         void customDataAvailable( const int& operationId, QByteArray* customData );
00163
00164 private:
00168         SmfProvider* getProvider() const;
00169
00170 private:
00171         SmfProvider* m_baseProvider;
00172         SmfEventsFetcherPrivate* m_private;
00173         friend class SmfEventsFetcherPrivate;
00174
00175         };
00176
00177 SMF_SERVICE_NAME(SmfEventsFetcher, "org.symbian.smf.client.events.fetcher\0.2")
00178
00179
00180 #endif /* SMFEVENTSFETCHER_H_ */
Generated on Thu Sep 23 15:03:11 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfeventsfetcher_p.h Source File

  • File List

smf/smfservermodule/smfclient/smfeventsfetcher_p.h

00001
00020 #ifndef SMFEVENTSFETCHER_P_H_
00021 #define SMFEVENTSFETCHER_P_H_
00022
00023 #include <smfglobal.h>
00024 #include <smfobserver.h>
00025 #include <smfevent.h>
00026 #include <smflocation.h>
00027 #include <smfprovider.h>
00028
00029 class SmfEventsFetcher;
00030
00031 #ifdef Q_OS_SYMBIAN
00032         class CSmfClientSymbian;
00033 #else
00034         class SmfClientQt;
00035 #endif
00036
00037 class SmfEventsFetcherPrivate : public smfObserver
00038         {
00039         Q_OBJECT
00040
00041 public:
00045         SmfEventsFetcherPrivate(SmfEventsFetcher* aEventFetcher);
00046
00050         ~SmfEventsFetcherPrivate();
00051
00052 public:
00062         SmfError events ( SmfLocation venue, int pageNum = SMF_FIRST_PAGE,
00063                         int perPage = SMF_ITEMS_PER_PAGE);
00064
00074         SmfError venues ( SmfLocation location, int pageNum = SMF_FIRST_PAGE,
00075                         int perPage = SMF_ITEMS_PER_PAGE);
00076
00077
00086         SmfError attendees(SmfEvent event, int pageNum = SMF_FIRST_PAGE,
00087                         int perPage = SMF_ITEMS_PER_PAGE);
00088
00095         SmfError postEvents ( SmfEventList events );
00096
00107         SmfError customRequest ( const int& operationId, QByteArray* customData );
00108
00115         SmfError cancelRequest ();
00116
00117 public: //From smfObserver
00124         void resultsAvailable(QByteArray result,SmfRequestTypeID opcode, SmfError error);
00125
00126 private:
00127         SmfEventsFetcher* m_eventFetcher;
00128         //serialized byte array of provider+other info to be sent to the server
00129         //The order:- SmfProvider then params in order of their appearance in fn
00130         QByteArray m_serializedDataToServer;
00131 #ifdef Q_OS_SYMBIAN
00132         CSmfClientSymbian* m_SmfClientPrivate;
00133         friend class CSmfClientSymbian;
00134 #else
00135         SmfClientQt* m_SmfClientPrivate;
00136         friend class SmfClientQt;
00137 #endif
00138         quint8 m_argFlag;
00139
00140         };
00141
00142 #endif /* SMFEVENTSFETCHER_P_H_ */
Generated on Thu Sep 23 15:03:11 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/smfplugins/smfeventsfetcherplugin.h Source File

  • File List

smf/smfservermodule/smfserver/smfplugins/smfeventsfetcherplugin.h

00001
00022 #ifndef SMFEVENTSFETCHERPLUGIN_H_
00023 #define SMFEVENTSFETCHERPLUGIN_H_
00024
00025 #include <smfpluginbase.h>
00026 #include <smfevent.h>
00027 #include <smflocation.h>
00028 #include <smfcontact.h>
00029
00030 using namespace QtMobility;
00031
00041 class SmfEventsFetcherPlugin : public SmfPluginBase
00042         {
00043 public:
00044
00048         virtual ~SmfEventsFetcherPlugin( ) {}
00049
00059         virtual SmfPluginError events( SmfPluginRequestData &aRequest,
00060                         const SmfLocation &aLocation,
00061                         const int aPageNum = SMF_FIRST_PAGE,
00062                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00063
00073         virtual SmfPluginError venues( SmfPluginRequestData &aRequest,
00074                         const SmfLocation &aLocation,
00075                         const int aPageNum = SMF_FIRST_PAGE,
00076                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00077
00087         virtual SmfPluginError attendees( SmfPluginRequestData &aRequest,
00088                         const SmfEvent &aEvent,
00089                         const int aPageNum = SMF_FIRST_PAGE,
00090                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00098         virtual SmfPluginError postEvents( SmfPluginRequestData &aRequest,
00099                         const QList<SmfEvent> &aEventList ) = 0;
00100
00111         virtual SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00112                         const int &aOperation, QByteArray *aData ) = 0;
00113
00114         };
00115
00116 Q_DECLARE_INTERFACE( SmfEventsFetcherPlugin, "org.symbian.smf.plugin.events.fetcher/v0.2" );
00117
00118 #endif /* SMFEVENTSFETCHERPLUGIN_H_ */
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfgallery.h Source File

  • File List

smf/smfservermodule/smfclient/smfgallery.h

00001
00020 #ifndef SMFGALLERY_H
00021 #define SMFGALLERY_H
00022
00023 #include <QObject>
00024 #include <smfglobal.h>
00025 #include <smfclientglobal.h>
00026 #include <smfpicture.h>
00027 #include <smfpicturealbum.h>
00028
00029 class SmfGalleryPrivate;
00030 class SmfProvider;
00031 class SmfContact;
00032 class SmfComment;
00033
00048 class SMFCLIENT_EXPORT SmfGallery : public QObject
00049         {
00050         Q_OBJECT
00051
00052 public:
00057         SmfGallery(SmfProvider* baseprovider);
00058
00062         ~SmfGallery();
00063
00064 public slots:
00076         SmfError albums ( QStringList names, SmfContact* user,
00077                                         int pageNum = SMF_FIRST_PAGE,
00078                                         int perPage = SMF_ITEMS_PER_PAGE );
00079
00090         SmfError pictures ( SmfPictureAlbumList &albums,
00091                                         int pageNum = SMF_FIRST_PAGE,
00092                                         int perPage = SMF_ITEMS_PER_PAGE );
00093
00098         SmfError description ( SmfPicture& picture );
00099
00100 public slots:
00108         SmfError upload ( SmfPicture* image, SmfPictureAlbum* album = NULL );
00109
00117         SmfError upload ( SmfPictureList* images, SmfPictureAlbum* album = NULL );
00118
00126         SmfError postComment ( SmfPicture image, SmfComment comment );
00127
00137         SmfError customRequest ( const int& operationId, QByteArray* customData );
00138
00145         SmfError cancelRequest ();
00146
00147 signals:
00154         void albumsAvailable ( SmfPictureAlbumList* albums,
00155                         SmfError error, SmfResultPage resultPage );
00156
00166         void picturesAvailable ( SmfPictureList* pics,
00167                         SmfError error, SmfResultPage resultPage );
00168
00169         void descriptionAvailable( QString desc, SmfError error );
00170
00175         void uploadFinished ( QList<SmfError> error );
00176
00182         void customDataAvailable ( int operationId, QByteArray* customData );
00183
00184 private:
00188         SmfProvider* getProvider() const;
00189
00190 // Friend Class
00191         //friend so that it can directly emit SmfPostProvider's signal
00192         friend class SmfGalleryPrivate;
00193
00194 private:
00195         SmfProvider* m_baseProvider;
00196         SmfGalleryPrivate* m_private;   //private impl wrapper
00197
00198         };
00199
00200 SMF_SERVICE_NAME(SmfGallery, "org.symbian.smf.client.gallery\0.2")
00201
00202 #endif // SMFGALLERY_H
00203
Generated on Thu Sep 23 15:03:11 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfgallery_p.h Source File

  • File List

smf/smfservermodule/smfclient/smfgallery_p.h

00001
00020 #ifndef SMFGALLERY_P_H
00021 #define SMFGALLERY_P_H
00022
00023 #include <smfclientglobal.h>
00024 #include <smfglobal.h>
00025 #include <smfobserver.h>
00026 #include <smfpicture.h>
00027 #include <smfpicturealbum.h>
00028
00029 // Forward Declarations
00030 class SmfProvider;
00031 class SmfGallery;
00032 class SmfContact;
00033 class SmfComment;
00034 #ifdef Q_OS_SYMBIAN
00035         class CSmfClientSymbian;
00036 #else
00037         class SmfClientQt;
00038 #endif
00039
00040
00049 class SmfGalleryPrivate : public smfObserver
00050         {
00051         Q_OBJECT
00052
00053 public:
00057         SmfGalleryPrivate(SmfGallery* gallery = 0);
00058
00062         ~SmfGalleryPrivate();
00063
00075         SmfError albums ( QStringList names, SmfContact* user,
00076                                         int pageNum = SMF_FIRST_PAGE,
00077                                         int perPage = SMF_ITEMS_PER_PAGE );
00078
00089         SmfError pictures ( SmfPictureAlbumList &albums,
00090                                         int pageNum = SMF_FIRST_PAGE,
00091                                         int perPage = SMF_ITEMS_PER_PAGE );
00092
00097         SmfError description ( SmfPicture& picture );
00098
00106         SmfError upload ( SmfPicture* image, SmfPictureAlbum* album = NULL );
00107
00115         SmfError upload ( SmfPictureList* images, SmfPictureAlbum* album = NULL );
00116
00124         SmfError postComment ( SmfPicture image, SmfComment comment );
00125
00135         SmfError customRequest ( const int& operationId, QByteArray* customData );
00136
00143         SmfError cancelRequest ();
00144
00145 public:// from smfobserver
00152         void resultsAvailable(QByteArray result,SmfRequestTypeID opcode,SmfError error);
00153
00154 private:
00155         SmfGallery* m_gallery;
00156         QByteArray m_serializedDataToServer;//serialized byte array of provider+other info to be sent to the server
00157         quint8 m_argFlag;
00158 #ifdef Q_OS_SYMBIAN
00159         CSmfClientSymbian* m_SmfClientPrivate;
00160         friend class CSmfClientSymbian;
00161 #else
00162         SmfClientQt* m_SmfClientPrivate;
00163         friend class SmfClientQt;
00164 #endif
00165
00166         };
00167
00168 #endif // SMFGALLERY_P_H
Generated on Thu Sep 23 15:03:11 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/smfplugins/smfgalleryplugin.h Source File

  • File List

smf/smfservermodule/smfserver/smfplugins/smfgalleryplugin.h

00001
00020 #ifndef SMFGALLERYPLUGIN_H_
00021 #define SMFGALLERYPLUGIN_H_
00022
00023 #include <smfpluginbase.h>
00024 #include <smfpicture.h>
00025 #include <smfcomment.h>
00026 #include <smfpicturealbum.h>
00027 #include <smfcontact.h>
00028
00057 class SmfGalleryPlugin : public SmfPluginBase
00058         {
00059 public:
00063         virtual ~SmfGalleryPlugin( ) {}
00064
00076         virtual SmfPluginError albums( SmfPluginRequestData &aRequest,
00077                         const QStringList &aNames,
00078                         const SmfContact *aUser,
00079                         const int aPageNum = SMF_FIRST_PAGE,
00080                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00081
00091         virtual SmfPluginError pictures( SmfPluginRequestData &aRequest,
00092                         const SmfPictureAlbumList &aAlbums,
00093                         const int aPageNum = SMF_FIRST_PAGE,
00094                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00095
00103         virtual SmfPluginError description( SmfPluginRequestData &aRequest,
00104                         const SmfPicture &aImage ) = 0;
00105
00114         virtual SmfPluginError upload( SmfPluginRequestData &aRequest,
00115                         const SmfPicture &aImage,
00116                         const SmfPictureAlbum* aAlbum = NULL ) = 0;
00117
00126         virtual SmfPluginError upload( SmfPluginRequestData &aRequest,
00127                         const QList<SmfPicture> &aImages,
00128                         const SmfPictureAlbum* aAlbum = NULL ) = 0;
00129
00139         virtual SmfPluginError postComment( SmfPluginRequestData &aRequest,
00140                         const SmfPicture &aImage,
00141                         const SmfComment &aComment ) = 0;
00142
00153         virtual SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00154                         const int &aOperation, QByteArray *aData ) = 0;
00155
00156         };
00157
00158 Q_DECLARE_INTERFACE( SmfGalleryPlugin, "org.symbian.smf.plugin.gallery/v0.2" );
00159
00160 #endif /* SMFGALLERYPLUGIN_H_ */
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfglobal.h Source File

  • File List

smf/smfservermodule/smfcommon/smfglobal.h

00001
00021 #ifndef SMFGLOBAL_H
00022 #define SMFGLOBAL_H
00023
00024 #include <qglobal.h>
00025 #include <QBuffer>
00026 #include <QNetworkRequest>
00027 #include <QNetworkAccessManager>
00028
00029 #ifdef Q_OS_SYMBIAN
00030 class SmfServerSymbianSession;
00031 #else
00032 class SmfServerQtSession;
00033 #endif
00034
00038 #define SMF_SERVICE_NAME(INTERFACE,INTERFACENAME)
00039
00043 const int SMF_FIRST_PAGE = 0;
00044
00048 const int SMF_ITEMS_PER_PAGE = 10;
00049
00050
00055 enum SmfPluginError
00056         {
00057         SmfPluginErrNone = 0,
00058         SmfPluginErrTooManyRequest,
00059         SmfPluginErrRequestQuotaExceeded,
00060         SmfPluginErrInvalidRequest,
00061         SmfPluginErrUserNotLoggedIn,
00062         SmfPluginErrAuthenticationExpired,
00063         SmfPluginErrPermissionDenied,
00064         SmfPluginErrInvalidApplication,
00065         SmfPluginErrServiceUnavailable,
00066         SmfPluginErrServiceTemporaryUnavailable,
00067         SmfPluginErrFormatNotSupported,
00068         SmfPluginErrDataSizeExceeded,
00069         SmfPluginErrServiceNotSupported,
00070         SmfPluginErrInvalidArguments,
00071         SmfPluginErrRequestNotCreated,
00072         SmfPluginErrParsingFailed,
00073         SmfPluginErrNetworkError,
00074         SmfPluginErrCancelComplete
00075         };
00076
00077
00081 enum SmfPluginRetType
00082         {
00083         SmfSendRequestAgain = 0,
00084         SmfRequestComplete,
00085         SmfRequestError
00086         };
00087
00088
00092 enum SmfRequestTypeID
00093         {
00094         SmfGetService,
00095         SmfCancelRequest,
00096         SmfContactGetFriends,
00097         SmfContactGetFollowers,
00098         SmfContactSearch,
00099         SmfContactSearchNear,
00100         SmfContactGetGroups,
00101         SmfContactSearchInGroup,
00102         SmfContactCustomRequest,
00103         SmfContactRetrievePosts,
00104         SmfContactPost,
00105         SmfContactUpdatePost,
00106         SmfContactPostDirected,
00107         SmfContactCommentOnAPost,
00108         SmfContactPostAppearence,
00109         SmfContactSharePost,
00110         SmfContactPostCustomRequest,
00111         SmfPostGetMaxCharsInPost,
00112         SmfPostGetMaxItems,
00113         SmfPostGetSupportedFormats,
00114         SmfPostGetAppearanceSupport,
00115         SmfMusicGetLyrics,
00116         SmfMusicGetSubtitle,
00117         SmfMusicLyricsCustomRequest,
00118         SmfMusicGetRecommendations,
00119         SmfMusicGetTracksSimilar,
00120         SmfMusicGetTracksOfAlbum,
00121         SmfMusicGetTracksOfArtist,
00122         SmfMusicGetTrackInfo,
00123         SmfMusicGetStores,
00124         SmfMusicSearchCustomRequest,
00125         SmfMusicGetUserInfo,
00126         SmfMusicSearchArtist,
00127         SmfMusicSearchAlbum,
00128         SmfMusicSearchEvent,
00129         SmfMusicSearchVenue,
00130         SmfMusicSearchUser,
00131         SmfMusicPostCurrentPlaying,
00132         SmfMusicPostRating,
00133         SmfMusicPostComment,
00134         SmfMusicServiceCustomRequest,
00135         SmfMusicGetPlaylists,
00136         SmfMusicGetPlaylistsOfUser,
00137         SmfMusicAddToPlaylist,
00138         SmfMusicPostCurrentPlayingPlaylist,
00139         SmfMusicPlaylistCustomRequest,
00140         SmfPictureGetAlbums,
00141         SmfPictureGetPictures,
00142         SmfPictureDescription,
00143         SmfPictureUpload,
00144         SmfPictureMultiUpload,
00145         SmfPicturePostComment,
00146         SmfPictureCustomRequest,
00147         SmfActivityFriendsActivities,
00148         SmfActivityFiltered,
00149         SmfActivitySelfActivity,
00150         SmfActivityCustomRequest,
00151         SmfEventsGetEvents,
00152         SmfEventsGetVenues,
00153         SmfEventsGetEventAttendees,
00154         SmfEventsPostEvents,
00155         SmfEventsCustomRequest,
00156         SmfRelationCreate,//SmfRelationMngr start
00157         SmfRelationAssociate,
00158         SmfRelationRemove,
00159         SmfRelationSearchById,
00160         SmfRelationSearchByContact,
00161         SmfRelationCount,
00162         SmfRelationGet,
00163         SmfRelationGetAll,
00164         SmfRelationGetAllRelations,
00165         SmfRelationDeleteRelation//SmfRelationMngr end
00166
00167         };
00168
00169
00173 enum SmfTransportResult
00174         {
00175         SmfTransportOpNoError = 0,
00176         SmfTransportOpConnectionRefusedError,
00177         SmfTransportOpRemoteHostClosedError,
00178         SmfTransportOpHostNotFoundError,
00179         SmfTransportOpTimeoutError,
00180         SmfTransportOpOperationCanceledError,
00181         SmfTransportOpSslHandshakeFailedError,
00182         SmfTransportOpProxyConnectionRefusedError,
00183         SmfTransportOpProxyConnectionClosedError,
00184         SmfTransportOpProxyNotFoundError,
00185         SmfTransportOpProxyTimeoutError,
00186         SmfTransportOpProxyAuthenticationRequiredError,
00187         SmfTransportOpContentAccessDenied,
00188         SmfTransportOpContentOperationNotPermittedError,
00189         SmfTransportOpContentNotFoundError,
00190         SmfTransportOpAuthenticationRequiredError,
00191         SmfTransportOpContentReSendError,
00192         SmfTransportOpProtocolUnknownError,
00193         SmfTransportOpProtocolInvalidOperationError,
00194         SmfTransportOpUnknownNetworkError,
00195         SmfTransportOpUnknownProxyError,
00196         SmfTransportOpUnknownContentError,
00197         SmfTransportOpProtocolFailure,
00198         SmfTransportOpUnknownError,
00199         SmfTransportOpIAPChanged,
00200         SmfTransportOpCancelled,
00201         SmfTransportOpUnsupportedContentEncodingFormat,
00202         SmfTransportOpGzipError
00203         };
00204
00205
00209 struct SmfPluginRequestData
00210         {
00215         SmfRequestTypeID iRequestType;
00216
00220         QNetworkRequest iNetworkRequest;
00221
00225         QBuffer *iPostData;
00226
00230         QNetworkAccessManager::Operation iHttpOperationType;
00231
00232         };
00233
00237 struct SmfResultPage
00238         {
00242         uint iTotalItems;
00243
00247         uint iItemsPerPage;
00248
00252         uint iTotalPages;
00253
00257         uint iPageNum;
00258         };
00259
00260
00261 struct SmfClientAuthID
00262         {
00263 #ifdef Q_OS_SYMBIAN
00264         TSecureId pid;
00265         SmfServerSymbianSession* session;
00266 #else
00267         QString pid;
00268         SmfServerQtSession* session;
00269 #endif
00270         };
00271
00275 enum SmfError
00276         {
00277         SmfNoError = 0,
00278         SmfInvalidInterface,                                            //1
00279         SmfNoAuthorizedPlugin,                                          //2
00280         SmfClientAuthFailed,                                            //3
00281         SmfPMPluginNotFound,                                            //4
00282         SmfPMPluginNotLoaded,                                           //5
00283         SmfPMPluginLoadError,                                           //6
00284         SmfPMPluginNotAuthorised,                                       //7
00285         SmfPMPluginRequestCreationFailed,                       //8
00286         SmfPMPluginUnknownPluginService,                        //9
00287         SmfPMPluginUnknownHttpService,                          //10
00288         SmfPMPluginRequestSendingFailed,                        //11
00289         SmfPMPluginSOPCheckFailed,                                      //12
00290         SmfPMPluginSendRequestAgain,                            //13
00291         SmfPluginErrorTooManyRequest,                           //14
00292         SmfPluginErrorRequestQuotaExceeded,                     //15
00293         SmfPluginErrorInvalidRequest,                           //16
00294         SmfPluginErrorUserNotLoggedIn,                          //17
00295         SmfPluginErrorAuthenticationExpired,            //18
00296         SmfPluginErrorPermissionDenied,                         //19
00297         SmfPluginErrorInvalidApplication,                       //20
00298         SmfPluginErrorServiceUnavailable,                       //21
00299         SmfPluginErrorServiceTemporaryUnavailable,      //22
00300         SmfPluginErrorFormatNotSupported,                       //23
00301         SmfPluginErrorDataSizeExceeded ,                        //24
00302         SmfPluginErrorInvalidArguments,                         //25
00303         SmfPluginErrorParsingFailed,                            //26
00304         SmfPluginErrorNetworkError,                                     //27
00305         SmfPluginErrorCancelComplete,                           //28
00306         SmfTMConnectionRefusedError,                            //29
00307         SmfTMRemoteHostClosedError,                                     //30
00308         SmfTMHostNotFoundError,                                         //31
00309         SmfTMTimeoutError,                                                      //32
00310         SmfTMOperationCanceledError,                            //33
00311         SmfTMSslHandshakeFailedError,                           //34
00312         SmfTMProxyConnectionRefusedError,                       //35
00313         SmfTMProxyConnectionClosedError,                        //36
00314         SmfTMProxyNotFoundError,                                        //37
00315         SmfTMProxyTimeoutError,                                         //38
00316         SmfTMProxyAuthenticationRequiredError,          //39
00317         SmfTMContentAccessDenied,                                       //40
00318         SmfTMContentOperationNotPermittedError,         //41
00319         SmfTMContentNotFoundError,                                      //42
00320         SmfTMAuthenticationRequiredError,                       //43
00321         SmfTMContentReSendError,                                        //44
00322         SmfTMProtocolUnknownError,                                      //45
00323         SmfTMProtocolInvalidOperationError,                     //46
00324         SmfTMUnknownNetworkError,                                       //47
00325         SmfTMUnknownProxyError,                                         //48
00326         SmfTMUnknownContentError,                                       //49
00327         SmfTMProtocolFailure,                                           //50
00328         SmfTMUnknownError,                                                      //51
00329         SmfTMIAPChanged,                                                        //52
00330         SmfTMCancelled,                                                         //53
00331         SmfTMUnsupportedContentEncodingFormat,          //54
00332         SmfTMInitNetworkNotAvailable ,                          //55
00333         SmfTMInitRoamingNetworkUsageNotEnabled,         //56
00334         SmfTMGzipMemoryError,                                           //57
00335         SmfTMGzipStreamError,                                           //58
00336         SmfTMGzipDataError,                                                     //59
00337         SmfMemoryAllocationFailure,                                     //60
00338         SmfDbOpeningError,                          //61
00339         SmfDbQueryExecutonError,                                        //61
00340         SmfDbContactNotExist,                                           //63
00341         SmfErrItemNotInRelation,                    //64
00342         SmfErrInvalidRelation,                      //65
00343         SmfUnknownError                                                         //66
00344
00345         };
00346
00347
00351 enum SmfPanic
00352         {
00353         SmfRequestPending               //to allow one outstanding request per session
00354         };
00355
00356 //interface names
00357 const QString contactFetcherInterface("org.symbian.smf.plugin.contact.fetcher\0.2");
00358 const QString postProviderInterface("org.symbian.smf.plugin.contact.posts\0.2");
00359 const QString galleryInterface("org.symbian.smf.plugin.gallery\0.2");
00360 const QString musicServiceInterface("org.symbian.smf.plugin.music.service\0.2");
00361 const QString musicSearchInterface("org.symbian.smf.client.music.search\0.2");
00362 const QString playlistServiceInterface("org.symbian.smf.plugin.music.playlist\0.2");
00363 const QString musicEventServiceInterface("org.symbian.smf.plugin.music.events\0.2");
00364 const QString lyricsServiceInterface("org.symbian.smf.plugin.music.lyrics\0.2");
00365 const QString activityFetcherInterface("org.symbian.smf.plugin.activity.fetcher\0.2");
00366 const QString eventFetcherInterface("org.symbian.smf.plugin.events.fetcher\0.2");
00367
00368 #endif /* SMFGLOBAL_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfgroup.h Source File

  • File List

smf/smfservermodule/smfcommon/smfgroup.h

00001
00020 #ifndef SMFGROUP_H_
00021 #define SMFGROUP_H_
00022
00023 #include <qdatastream.h>
00024 #include <QSharedData>
00025 #include <QMetaType>
00026
00027 #include "smfcontact.h"
00028 #include "smfclientglobal.h"
00029
00030
00034 class SmfGroupPrivate;
00035
00039 const int MaxMemberPerGroup = 1000;
00040
00044 const int MaxSmfGroupSize = MaxSmfContactSize*MaxMemberPerGroup;
00045
00046
00052 class  SMFCOMMON_EXPORT SmfGroup
00053         {
00054 public:
00059         SmfGroup( QList<SmfContact>* list = 0 );
00060
00065         SmfGroup( const SmfGroup &aOther );
00066
00071         SmfGroup& operator=( const SmfGroup &aOther );
00072
00076         ~SmfGroup( );
00077
00078 public slots:
00083         QList<SmfContact> members( ) const;
00084
00089         void setMembers(QList<SmfContact>* mems);
00090
00095         QString name( ) const;
00096
00100         void setName(QString& name);
00101
00106         QString id( ) const;
00107
00111         void setId(QString& id);
00112
00113 private:
00114         QSharedDataPointer<SmfGroupPrivate> d;
00115
00116         friend QDataStream &operator<<( QDataStream &aDataStream,
00117                         const SmfGroup &aGroup );
00118
00119         friend QDataStream &operator>>( QDataStream &aDataStream,
00120                         SmfGroup &aGroup );
00121
00122         };
00123
00124
00132 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00133                 const SmfGroup &aGroup );
00134
00142 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00143                 SmfGroup &aGroup);
00144
00145 typedef QList<SmfGroup> SmfGroupList;
00146
00147 // Make the class SmfGroup known to QMetaType, so that as to register it.
00148 Q_DECLARE_METATYPE(SmfGroup)
00149 Q_DECLARE_METATYPE(QList<SmfGroup>)
00150
00151 #endif /* SMFGROUP_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfgroup_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfgroup_p.h

00001
00020 #ifndef SMFGROUP_P_H_
00021 #define SMFGROUP_P_H_
00022
00023 #include <smfcontact.h>
00024 #include <QSharedData>
00025
00026 class SmfGroupPrivate : public QSharedData
00027 {
00028 public:
00032         SmfGroupPrivate( ) { m_members = NULL; m_groupName.clear(); m_groupId.clear(); }
00033
00038         SmfGroupPrivate( const SmfGroupPrivate &aOther ) :
00039                 QSharedData ( aOther ),
00040                 m_members ( aOther.m_members ),
00041                 m_groupName ( aOther.m_groupName ),
00042                 m_groupId ( aOther.m_groupId )  { }
00043
00047         ~SmfGroupPrivate( ){};
00048
00049         QList<SmfContact> *m_members;   // members in the group
00050         QString m_groupName;
00051         QString m_groupId;
00052         // Other details to be added
00053 };
00054
00055
00056 #endif /* SMFGROUP_P_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfcredentialmgr/smfcredmgrserver/inc/smfkeystoremanager.h Source File

  • File List

smf/smfcredentialmgr/smfcredmgrserver/inc/smfkeystoremanager.h

00001
00016 #ifndef SMFKEYSTOREMANAGER_H_
00017 #define SMFKEYSTOREMANAGER_H_
00018
00019 // Include files
00020 #include <e32base.h>
00021 #include <f32file.h>
00022
00023 #ifdef  SYMBIAN_V3
00024 #include <rmpointerarray.h>
00025 #include <platform/mkeystore.h>
00026 #include <platform/flogger.h>
00027
00028 class CUnifiedKeyStore;
00029 class CCTKeyInfo;
00030 class CRSASignature;
00031 #endif
00032
00033 class CSmfSignParameters;
00034 class CSmfRsaKeyParameters;
00035
00036 class CSmfKeyStoreManager : public CActive
00037         {
00038 public:
00043         static CSmfKeyStoreManager* NewL();
00044
00049         static CSmfKeyStoreManager* NewLC();
00050
00054         ~CSmfKeyStoreManager();
00055
00060         void HandleMessageL( const RMessage2& aMessage );
00061
00062 //      void GenerateKeyL( const RMessage2& aMessage );
00063 //      void StoreRSAKeyL( const RMessage2& aMessage );
00064
00065 private: // from CActive
00069         void RunL();
00070
00074         void DoCancel();
00075
00081         TInt RunError(TInt aError);
00082
00083 private:
00087         CSmfKeyStoreManager();
00088
00092         void ConstructL();
00093
00097         void ContinueMessageHandlingL();
00098
00102         void StoreRSAKeyL();
00103
00107         void RSA_SHA1_SignMessageL();
00108
00112         void HMAC_SHA1_SignMessageL();
00113
00117         void DeleteKeysL();
00118
00122         void SetPassphraseTimeout();
00123
00127         void ReadSignParametersL();
00128
00132         void ReadRsaKeyParametersL();
00133
00134 private:
00135         RFs iFs;
00136
00137         RPointerArray<RMessage2> iMessages;
00138         CSmfSignParameters* iSignParameters;
00139         CSmfRsaKeyParameters* iRsaKeyParameters;
00140 #ifdef  SYMBIAN_V3
00141         CCTKeyInfo*     iImportedKey;
00142         CUnifiedKeyStore* iKeyStore;
00143         RMPointerArray<CCTKeyInfo> iKeys;
00144         MRSASigner* iRSASigner;
00145         CRSASignature* iRSASignature;
00146 #endif
00147
00148         enum {
00149                 EInitializingKeystore,
00150                 ESettingPassphraseTimeout,
00151                 EInitialized,
00152                 EGeneratingKey,
00153                 EImportingKey,
00154                 EGettingKeyList,
00155                 EGettingRSASigner,
00156                 ERSASigningMessage,
00157                 EListingKeys,
00158                 EDeletingKey,
00159                 EKeyDeleted             //state after the key has been deleted
00160         } iState;
00161
00162 };
00163
00164 #endif /* SMFKEYSTOREMANAGER_H_ */
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smflocation.h Source File

  • File List

smf/smfservermodule/smfcommon/smflocation.h

00001
00021 #ifndef SMFLOCATION_H_
00022 #define SMFLOCATION_H_
00023
00024 #include <QUrl>
00025 #include <qgeopositioninfo.h> // Qt mobility class
00026 #include <qdatastream.h>
00027 #include <QSharedData>
00028 #include <smfclientglobal.h>
00029 #include <QMetaType>
00030
00031 // Qt mobility - namespace
00032 using namespace QtMobility;
00033
00034 enum SmfLocationSearchBoundary
00035 {
00036         SearchByStreet = 0x00,
00037         SearchByLocality,
00038         SearchByPostOffice,
00039         SearchByTown,
00040         SearchByRegion,
00041         SearchByState,
00042         SearchByCountry
00043 };
00044
00045 class SmfLocationPrivate;
00046
00053 class SMFCOMMON_EXPORT SmfLocation
00054         {
00055 public:
00059         SmfLocation( );
00060
00065         SmfLocation( const SmfLocation &aOther );
00066
00072         SmfLocation& operator=( const SmfLocation &aOther );
00073
00077         ~SmfLocation( );
00078
00083         QString name( ) const;
00084
00089         QString city( ) const;
00090
00095         QString street( ) const;
00096
00101         QString zipCode( ) const;
00102
00107         QString country( ) const;
00108
00115         QGeoPositionInfo geoPositionInfo( ) const;
00116
00121         QUrl url( ) const;
00122
00127         QString id( ) const;
00128
00133         void setName( const QString &aPlace );
00134
00139         void setCity( const QString &aCity );
00140
00145         void setStreet( const QString &aStreet );
00146
00151         void setZipCode( const QString &aZipCode );
00152
00157         void setCountry( const QString &aCountry );
00158
00165         void setGeoPositionInfo( const QGeoPositionInfo &aGeoPosInfo );
00166
00171         void setUrl( const QUrl &aUrl );
00172
00177         void setId( const QString &aId );
00178
00179 private:
00180         QSharedDataPointer<SmfLocationPrivate> d;
00181
00182         friend QDataStream &operator<<( QDataStream &aDataStream,
00183                         const SmfLocation &aPlace );
00184
00185         friend QDataStream &operator>>( QDataStream &aDataStream,
00186                         SmfLocation &aPlace );
00187
00188         };
00189
00190
00198 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00199                 const SmfLocation &aPlace );
00200
00208 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00209                 SmfLocation &aPlace);
00210
00211 typedef QList<SmfLocation> SmfLocationList;
00212
00213 // Make the class SmfLocation known to QMetaType, so that as to register it.
00214 Q_DECLARE_METATYPE(SmfLocation)
00215 Q_DECLARE_METATYPE(QList<SmfLocation>)
00216
00217 #endif /* SMFLOCATION_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smflocation_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smflocation_p.h

00001
00021 #ifndef SMFLOCATION_P_H_
00022 #define SMFLOCATION_P_H_
00023
00024 #include <QUrl>
00025 #include <qgeopositioninfo.h> // Qt mobility class
00026 #include <QSharedData>
00027
00028 // Qt mobility - namespace
00029 using namespace QtMobility;
00030
00031 class SmfLocationPrivate : public QSharedData
00032 {
00033 public:
00037         SmfLocationPrivate( ) {
00038                 m_name.clear();
00039                 m_city.clear();
00040                 m_street.clear();
00041                 m_zipcode.clear();
00042                 m_country.clear();
00043                 m_url.clear();
00044                 m_placeId.clear(); }
00045
00050         SmfLocationPrivate( const SmfLocationPrivate &aOther ) :
00051                 QSharedData ( aOther ),
00052                 m_name ( aOther.m_name ),
00053                 m_city ( aOther.m_city ),
00054                 m_street ( aOther.m_street ),
00055                 m_zipcode ( aOther.m_zipcode ),
00056                 m_country ( aOther.m_country ),
00057                 m_geo ( aOther.m_geo ),
00058                 m_url ( aOther.m_url ),
00059                 m_placeId ( aOther.m_placeId )  { }
00060
00064         ~SmfLocationPrivate( )
00065                 {
00066                 }
00067
00068         QString m_name;                 // place name
00069         QString m_city;                 // city of place
00070         QString m_street;               // street of place
00071         QString m_zipcode;              // zip code of place
00072         QString m_country;              // country of place
00073         QGeoPositionInfo m_geo; // place geo position information
00074         QUrl m_url;                             // url indicating the place
00075         QString m_placeId;              // place id
00076
00077 };
00078
00079 #endif /* SMFLOCATION_P_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smflyrics.h Source File

  • File List

smf/smfservermodule/smfcommon/smflyrics.h

00001
00020 #ifndef SMFLYRICS_H_
00021 #define SMFLYRICS_H_
00022
00023 #include <qdatastream.h>
00024 #include <QDateTime>
00025 #include <QSharedData>
00026 #include <smfclientglobal.h>
00027 #include <QMetaType>
00028
00029 class SmfLyricsPrivate;
00030
00031 const int SmfMusicLyricsMaxSize = 5000;
00032
00037 class SMFCOMMON_EXPORT SmfLyrics
00038         {
00039 public:
00043         SmfLyrics( );
00044
00049         SmfLyrics( const SmfLyrics &aOther );
00050
00056         SmfLyrics& operator=( const SmfLyrics &aOther );
00057
00061         ~SmfLyrics( );
00062
00067         QByteArray lyrics( ) const;
00068
00073         QString language( ) const;
00074
00079         QDateTime releaseYear( ) const;
00080
00085         QString id( ) const;
00086
00091         void setLyrics( const QByteArray &aLyrics );
00092
00097         void setLanguage( const QString &aLang );
00098
00103         void setReleaseYear( const QDateTime &aRelYear );
00104
00109         void setId( const QString &aId );
00110
00111 private:
00112         QSharedDataPointer<SmfLyricsPrivate> d;
00113
00114         friend QDataStream &operator<<( QDataStream &aDataStream,
00115                         const SmfLyrics &aLyrics );
00116
00117         friend QDataStream &operator>>( QDataStream &aDataStream,
00118                         SmfLyrics &aLyrics );
00119
00120         };
00121
00122
00130 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00131                 const SmfLyrics &aLyrics );
00132
00140 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00141                 SmfLyrics &aLyrics);
00142
00143
00144 typedef QList<SmfLyrics> SmfLyricsList;
00145
00146 // Make the class SmfLyrics known to QMetaType, so that as to register it.
00147 Q_DECLARE_METATYPE(SmfLyrics)
00148 Q_DECLARE_METATYPE(QList<SmfLyrics>)
00149
00150
00151 #endif /* SMFLYRICS_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smflyrics_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smflyrics_p.h

00001
00020 #ifndef SMFLYRICS_P_H_
00021 #define SMFLYRICS_P_H_
00022
00023 #include <QDateTime>
00024 #include <QSharedData>
00025
00026 class SmfLyricsPrivate : public QSharedData
00027 {
00028 public:
00032         SmfLyricsPrivate( ) {
00033                 m_lyrics.clear();
00034                 m_language.clear();
00035                 m_lyricsId.clear();
00036         }
00037
00042         SmfLyricsPrivate( const SmfLyricsPrivate &aOther ) :
00043                 QSharedData ( aOther ),
00044                 m_lyrics ( aOther.m_lyrics ),
00045                 m_language ( aOther.m_language ),
00046                 m_releaseYr ( aOther.m_releaseYr ),
00047                 m_lyricsId ( aOther.m_lyricsId )        { }
00048
00052         ~SmfLyricsPrivate( )
00053                 {
00054                 }
00055
00056         QByteArray m_lyrics;    // lyrics data
00057         QString m_language;             // language
00058         QDateTime m_releaseYr;  // release year
00059         QString m_lyricsId;             // lyrics id
00060
00061 };
00062
00063 #endif /* SMFLYRICS_P_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/smfplugins/smflyricsserviceplugin.h Source File

  • File List

smf/smfservermodule/smfserver/smfplugins/smflyricsserviceplugin.h

00001
00021 #ifndef SMFLYRICSSERVICEPLUGIN_H_
00022 #define SMFLYRICSSERVICEPLUGIN_H_
00023
00024 #include <smfpluginbase.h>
00025 #include <smftrackinfo.h>
00026 #include <QString>
00027 #include <smfsubtitle.h>
00028 #include <smflyrics.h>
00029
00037 class SmfLyricsServicePlugin : public SmfPluginBase
00038         {
00039 public:
00040
00044         virtual ~SmfLyricsServicePlugin( ) {}
00045
00055         virtual SmfPluginError lyrics( SmfPluginRequestData &aRequest,
00056                         const SmfTrackInfo &aTrack,
00057                         const int aPageNum = SMF_FIRST_PAGE,
00058                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00059
00070         virtual SmfPluginError subtitles( SmfPluginRequestData &aRequest,
00071                         const SmfTrackInfo &aTrack,
00072                         const SmfSubtitleSearchFilter &aFilter = SubtitleAll,
00073                         const int aPageNum = SMF_FIRST_PAGE,
00074                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00075
00086         virtual SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00087                         const int &aOperation, QByteArray *aData ) = 0;
00088
00089         };
00090
00091 Q_DECLARE_INTERFACE( SmfLyricsServicePlugin, "org.symbian.smf.plugin.music.lyrics/v0.2" );
00092
00093 #endif /* SMFLYRICSSERVICEPLUGIN_H_ */
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfmusic.h Source File

  • File List

smf/smfservermodule/smfclient/smfmusic.h

00001
00020 #ifndef SMFMUSIC_H
00021 #define SMFMUSIC_H
00022
00023 #include <qcontactgeolocation.h>
00024 #include <smfglobal.h>
00025 #include <smfevent.h>
00026 #include <smfsubtitle.h>
00027 #include <smfmusicprofile.h>
00028 #include <smflyrics.h>
00029 #include <smfplaylist.h>
00030 #include <smftrackinfo.h>
00031 #include <smflocation.h>
00032 #include <smfprovider.h>
00033 #include <smfcontact.h>
00034
00035 class SmfMusicServicePrivate;
00036 class SmfMusicSearchPrivate;
00037 class SmfLyricsServicePrivate;
00038 class SmfPlaylistServicePrivate;
00039 class SmfMusicFingerPrint;
00040 class SmfMusicRating;
00041 class SmfComment;
00042 class SmfContact;
00043
00044 using namespace QtMobility;
00045
00046
00056 class SMFCLIENT_EXPORT SmfMusicService : public QObject
00057         {
00058         Q_OBJECT
00059
00060 public:
00065         SmfMusicService ( SmfProvider* baseProvider = 0 );
00066
00070         ~SmfMusicService ( );
00071
00072 public slots:
00078         SmfError userMusicInfo ( );
00079
00089         SmfError searchArtist ( SmfArtists artist, int pageNum = SMF_FIRST_PAGE,
00090                                                 int perPage = SMF_ITEMS_PER_PAGE );
00091
00101         SmfError searchAlbum ( SmfAlbum album, int pageNum = SMF_FIRST_PAGE,
00102                                                 int perPage = SMF_ITEMS_PER_PAGE );
00103
00113         SmfError searchEvents ( SmfEvent event, int pageNum = SMF_FIRST_PAGE,
00114                                                 int perPage = SMF_ITEMS_PER_PAGE );
00115
00125         SmfError searchVenue ( SmfLocation location, int pageNum = SMF_FIRST_PAGE,
00126                                                 int perPage = SMF_ITEMS_PER_PAGE );
00127
00138         SmfError searchUser ( SmfLocation venue, int pageNum = SMF_FIRST_PAGE,
00139                                                 int perPage = SMF_ITEMS_PER_PAGE);
00140
00147         SmfError postCurrentPlaying ( SmfTrackInfo track);
00148
00156         SmfError postRating ( SmfTrackInfo track, SmfMusicRating rate);
00157
00165         SmfError postComments ( SmfTrackInfo track, SmfComment comment);
00166
00177         SmfError customRequest ( const int& operationId, QByteArray* customData );
00178
00185         SmfError cancelRequest ();
00186
00187
00188 signals:
00194         void userMusicInfoAvailable ( SmfMusicProfile* profile, SmfError error );
00195
00201         void searchUserInfoAvailable ( SmfMusicProfileList* profileList,
00202                         SmfError error, SmfResultPage resultPage );
00203
00209         void searchArtistInfoAvailable (QList<SmfArtists>* artists,
00210                         SmfError error, SmfResultPage resultPage );
00211
00217         void searchAlbumInfoAvailable ( QList<SmfAlbum>* albumList,
00218                         SmfError error, SmfResultPage resultPage );
00219
00225         void searchEventsInfoAvailable ( SmfEventList* eventList,
00226                         SmfError error, SmfResultPage resultPage );
00227
00233         void searchVenueInfoAvailable ( SmfLocationList* venueList,
00234                         SmfError error, SmfResultPage resultPage );
00235
00241         void customDataAvailable( const int& operationId, QByteArray* customData );
00242
00247         void postfinished ( SmfError error );
00248
00249 private:
00253         SmfProvider* getProvider() const;
00254
00255 // Friend Class
00256         friend class SmfMusicServicePrivate;
00257
00258 private:
00259         SmfProvider* m_baseProvider;
00260         SmfMusicServicePrivate* m_private;
00261
00262         };
00263
00264 SMF_SERVICE_NAME(SmfMusicService, "org.symbian.smf.client.music.service\0.2")
00265
00266
00267
00270 class SMFCLIENT_EXPORT SmfMusicSearch : public QObject
00271         {
00272         Q_OBJECT
00273
00274 public:
00278         SmfMusicSearch ( SmfProvider* baseProvider = 0 );
00279
00283         ~SmfMusicSearch();
00284
00285 public:
00297         SmfError recommendations ( SmfTrackInfo track, int pageNum = SMF_FIRST_PAGE,
00298                         int perPage = SMF_ITEMS_PER_PAGE);
00299
00311         SmfError tracksSimilar ( SmfTrackInfo track, int pageNum = SMF_FIRST_PAGE,
00312                         int perPage = SMF_ITEMS_PER_PAGE);
00313
00325         SmfError tracksOfAlbum ( SmfAlbum album, int pageNum = SMF_FIRST_PAGE,
00326                         int perPage = SMF_ITEMS_PER_PAGE);
00327
00339         SmfError tracksOfArtist ( SmfArtists artists, int pageNum = SMF_FIRST_PAGE,
00340                         int perPage = SMF_ITEMS_PER_PAGE);
00341
00351         SmfError trackInfo ( SmfMusicFingerPrint signature, int pageNum = SMF_FIRST_PAGE,
00352                         int perPage = SMF_ITEMS_PER_PAGE);
00353
00362         SmfError stores ( SmfTrackInfo track, int pageNum = SMF_FIRST_PAGE,
00363                         int perPage = SMF_ITEMS_PER_PAGE);
00364
00375         SmfError customRequest ( const int& operationId, QByteArray* customData );
00376
00383         SmfError cancelRequest ();
00384
00385 signals:
00393         void trackSearchAvailable ( SmfTrackInfoList* result,
00394                         SmfError error, SmfResultPage resultPage);
00395
00403         void storeSearchAvailable ( SmfProviderList* result,
00404                         SmfError error, SmfResultPage resultPage );
00405
00411         void customDataAvailable( const int& operationId, QByteArray* customData );
00412
00413 private:
00417         SmfProvider* getProvider() const;
00418
00419 private:
00420         SmfProvider* m_baseProvider;
00421         SmfMusicSearchPrivate* m_private;
00422         friend class SmfMusicSearchPrivate;
00423
00424         };
00425
00426 SMF_SERVICE_NAME(SmfMusicSearch, "org.symbian.smf.client.music.search\0.2")
00427
00428
00429
00444 class SMFCLIENT_EXPORT SmfPlaylistService : public QObject
00445         {
00446         Q_OBJECT
00447
00448 public:
00454         SmfPlaylistService ( SmfProvider* baseProvider = 0 );
00455
00459         ~SmfPlaylistService ( );
00460
00461 public:
00472         SmfError playlists ( int pageNum = SMF_FIRST_PAGE,
00473                         int perPage = SMF_ITEMS_PER_PAGE);
00474
00486         SmfError playlistsOf ( SmfContact* user, int pageNum = SMF_FIRST_PAGE,
00487                         int perPage = SMF_ITEMS_PER_PAGE);
00488
00489 public slots:
00497         SmfError addToPlaylist ( SmfPlaylist plst, SmfTrackInfoList* tracks );
00498
00505         SmfError postCurrentPlayingPlaylist ( SmfPlaylist plst );
00506
00517         SmfError customRequest ( const int& operationId, QByteArray* customData );
00518
00525         SmfError cancelRequest ();
00526
00527 signals:
00535         void playlistsListAvailable ( SmfPlaylistList* plst,
00536                         SmfError error, SmfResultPage resultPage );
00541         void playlistUpdated ( SmfError error );
00542
00548         void customDataAvailable( const int& operationId, QByteArray* customData );
00549
00550 private:
00554         SmfProvider* getProvider() const;
00555
00556 private:
00557         SmfProvider* m_baseProvider;
00558         SmfPlaylistServicePrivate* m_private;
00559         friend class SmfPlaylistServicePrivate;
00560
00561         };
00562
00563 SMF_SERVICE_NAME(SmfPlaylistService, "org.symbian.smf.client.music.playlist\0.2")
00564
00565
00566
00567
00570 class SMFCLIENT_EXPORT SmfLyricsService : public QObject
00571         {
00572         Q_OBJECT
00573
00574 public:
00578         SmfLyricsService ( SmfProvider* baseProvider = 0 );
00579
00583         ~SmfLyricsService ( );
00584
00585 public:
00594         SmfError lyrics ( SmfTrackInfo track, int pageNum = SMF_FIRST_PAGE,
00595                         int perPage = SMF_ITEMS_PER_PAGE);
00596
00607         SmfError subtitles ( SmfTrackInfo track, SmfSubtitleSearchFilter filter,
00608                         int pageNum = SMF_FIRST_PAGE, int perPage = SMF_ITEMS_PER_PAGE);
00609
00620         SmfError customRequest ( const int& operationId, QByteArray* customData );
00621
00628         SmfError cancelRequest ();
00629
00630 signals:
00638         void lyricsAvailable ( SmfLyricsList* list,
00639                         SmfError error, SmfResultPage resultPage );
00640
00648         void subtitleAvailable ( SmfSubtitleList* list,
00649                         SmfError error, SmfResultPage resultPage );
00650
00656         void customDataAvailable( const int& operationId, QByteArray* customData );
00657
00658 private:
00659
00663         SmfProvider* getProvider() const;
00664
00665 private:
00666         SmfProvider* m_baseProvider;
00667         SmfLyricsServicePrivate* m_private;
00668         friend class SmfLyricsServicePrivate;
00669
00670         };
00671
00672 SMF_SERVICE_NAME(SmfLyricsService, "org.symbian.smf.client.music.lyrics\0.2")
00673
00674 #endif // SMFMUSIC_H
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfmusic_p.h Source File

  • File List

smf/smfservermodule/smfclient/smfmusic_p.h

00001
00020 #ifndef SMFMUSICPRIVATE_H_
00021 #define SMFMUSICPRIVATE_H_
00022
00023 #include <qcontactgeolocation.h>
00024 #include <smfglobal.h>
00025 #include <smfobserver.h>
00026 #include <smfevent.h>
00027 #include <smfsubtitle.h>
00028 #include <smfmusicprofile.h>
00029 #include <smflyrics.h>
00030 #include <smfplaylist.h>
00031 #include <smftrackinfo.h>
00032 #include <smflocation.h>
00033 #include <smfprovider.h>
00034 #include <smfartists.h>
00035 #include <smfalbum.h>
00036
00037 #ifdef Q_OS_SYMBIAN
00038         class CSmfClientSymbian;
00039 #else
00040         class SmfClientQt;
00041 #endif
00042 class SmfMusicService;
00043 class SmfMusicSearch;
00044 class SmfPlaylistService;
00045 class SmfLyricsService;
00046 class SmfMusicFingerPrint;
00047 class SmfMusicRating;
00048 class SmfComment;
00049 class SmfContact;
00050
00051
00052 class SmfMusicServicePrivate : public smfObserver
00053         {
00054         Q_OBJECT
00055 public:
00059         SmfMusicServicePrivate(SmfMusicService* aMusicService);
00060
00064         ~SmfMusicServicePrivate();
00065
00071         SmfError userMusicInfo ( );
00072
00082         SmfError searchArtist ( SmfArtists artist, int pageNum = SMF_FIRST_PAGE,
00083                                                 int perPage = SMF_ITEMS_PER_PAGE );
00084
00094         SmfError searchAlbum ( SmfAlbum album, int pageNum = SMF_FIRST_PAGE,
00095                                                 int perPage = SMF_ITEMS_PER_PAGE );
00096
00106         SmfError searchEvents ( SmfEvent event, int pageNum = SMF_FIRST_PAGE,
00107                                                 int perPage = SMF_ITEMS_PER_PAGE );
00108
00118         SmfError searchVenue ( SmfLocation location, int pageNum = SMF_FIRST_PAGE,
00119                                                 int perPage = SMF_ITEMS_PER_PAGE );
00120
00131         SmfError searchUser ( SmfLocation venue, int pageNum = SMF_FIRST_PAGE,
00132                                                 int perPage = SMF_ITEMS_PER_PAGE);
00133
00140         SmfError postCurrentPlaying ( SmfTrackInfo track);
00141
00149         SmfError postRating ( SmfTrackInfo track, SmfMusicRating rate);
00150
00158         SmfError postComments ( SmfTrackInfo track, SmfComment comment);
00159
00170         SmfError customRequest ( const int& operationId, QByteArray* customData );
00171
00178         SmfError cancelRequest ();
00179
00180 public: // from smfObserver
00187         void resultsAvailable(QByteArray result,SmfRequestTypeID opcode, SmfError error);
00188
00189 private:
00190         SmfMusicService* m_musicService;
00191         //serialized byte array of provider+other info to be sent to the server
00192         //The order:- SmfProvider then params in order of their appearance in fn
00193         QByteArray m_serializedDataToServer;
00194 #ifdef Q_OS_SYMBIAN
00195         CSmfClientSymbian* m_SmfClientPrivate;
00196         friend class CSmfClientSymbian;
00197 #else
00198         SmfClientQt* m_SmfClientPrivate;
00199         friend class SmfClientQt;
00200 #endif
00201         quint8 m_argFlag;
00202
00203         };
00204
00205
00206 //SmfMusicSearch
00207 class SmfMusicSearchPrivate : public smfObserver
00208         {
00209         Q_OBJECT
00210 public:
00214         SmfMusicSearchPrivate(SmfMusicSearch* aMusicSearch);
00215
00219         ~SmfMusicSearchPrivate();
00220
00221 public:
00233         SmfError recommendations ( SmfTrackInfo track, int pageNum = SMF_FIRST_PAGE,
00234                         int perPage = SMF_ITEMS_PER_PAGE);
00235
00247         SmfError tracksSimilar ( SmfTrackInfo track, int pageNum = SMF_FIRST_PAGE,
00248                         int perPage = SMF_ITEMS_PER_PAGE);
00249
00261         SmfError tracksOfAlbum ( SmfAlbum album, int pageNum = SMF_FIRST_PAGE,
00262                         int perPage = SMF_ITEMS_PER_PAGE);
00263
00275         SmfError tracksOfArtist ( SmfArtists artists, int pageNum = SMF_FIRST_PAGE,
00276                         int perPage = SMF_ITEMS_PER_PAGE);
00277
00287         SmfError trackInfo ( SmfMusicFingerPrint signature, int pageNum = SMF_FIRST_PAGE,
00288                         int perPage = SMF_ITEMS_PER_PAGE);
00289
00298         SmfError stores ( SmfTrackInfo track, int pageNum = SMF_FIRST_PAGE,
00299                         int perPage = SMF_ITEMS_PER_PAGE);
00300
00311         SmfError customRequest ( const int& operationId, QByteArray* customData );
00312
00319         SmfError cancelRequest ();
00320
00321 public: //From smfObserver
00328         void resultsAvailable(QByteArray result,SmfRequestTypeID opcode, SmfError error);
00329
00330 private:
00331         SmfMusicSearch *m_musicSearch;
00332         //serialized byte array of provider+other info to be sent to the server
00333         //The order:- SmfProvider then params in order of their appearance in fn
00334         QByteArray m_serializedDataToServer;
00335 #ifdef Q_OS_SYMBIAN
00336         CSmfClientSymbian* m_SmfClientPrivate;
00337         friend class CSmfClientSymbian;
00338 #else
00339         SmfClientQt* m_SmfClientPrivate;
00340         friend class SmfClientQt;
00341 #endif
00342         quint8 m_argFlag;
00343
00344         };
00345
00346
00347 class SmfPlaylistServicePrivate : public smfObserver
00348         {
00349         Q_OBJECT
00350
00351 public:
00355         SmfPlaylistServicePrivate(SmfPlaylistService* aPlayLstSrvc);
00356
00360         ~SmfPlaylistServicePrivate();
00361
00362 public:
00373         SmfError playlists ( int pageNum = SMF_FIRST_PAGE,
00374                         int perPage = SMF_ITEMS_PER_PAGE);
00375
00387         SmfError playlistsOf ( SmfContact* user, int pageNum = SMF_FIRST_PAGE,
00388                         int perPage = SMF_ITEMS_PER_PAGE);
00389
00397         SmfError addToPlaylist ( SmfPlaylist plst, SmfTrackInfoList* tracks );
00398
00405         SmfError postCurrentPlayingPlaylist ( SmfPlaylist plst );
00406
00417         SmfError customRequest ( const int& operationId, QByteArray* customData );
00418
00425         SmfError cancelRequest ();
00426
00427 public: //From smfObserver
00434         void resultsAvailable(QByteArray result,SmfRequestTypeID opcode, SmfError error);
00435
00436 private:
00437         SmfPlaylistService* m_playlstSrvc;
00438         //serialized byte array of provider+other info to be sent to the server
00439         //The order:- SmfProvider then params in order of their appearance in fn
00440         QByteArray m_serializedDataToServer;
00441
00442 #ifdef Q_OS_SYMBIAN
00443         CSmfClientSymbian* m_SmfClientPrivate;
00444         friend class CSmfClientSymbian;
00445 #else
00446         SmfClientQt* m_SmfClientPrivate;
00447         friend class SmfClientQt;
00448 #endif
00449         quint8 m_argFlag;
00450
00451         };
00452
00453
00454
00458 class SmfLyricsServicePrivate : public smfObserver
00459         {
00460         Q_OBJECT
00461
00462 public:
00466         SmfLyricsServicePrivate(SmfLyricsService* aLyricsSrvc);
00467
00471         ~SmfLyricsServicePrivate();
00472
00473 public:
00482         SmfError lyrics ( SmfTrackInfo track, int pageNum = SMF_FIRST_PAGE,
00483                         int perPage = SMF_ITEMS_PER_PAGE);
00484
00495         SmfError subtitles ( SmfTrackInfo track, SmfSubtitleSearchFilter filter,
00496                         int pageNum = SMF_FIRST_PAGE, int perPage = SMF_ITEMS_PER_PAGE);
00497
00508         SmfError customRequest ( const int& operationId, QByteArray* customData );
00509
00516         SmfError cancelRequest ();
00517
00518 public: //From smfObserver
00525         void resultsAvailable(QByteArray result,SmfRequestTypeID opcode, SmfError error);
00526
00527 private:
00528         SmfLyricsService *m_lyricsSrvc;
00529         //serialized byte array of provider+other info to be sent to the server
00530         //The order:- SmfProvider then params in order of their appearance in fn
00531         QByteArray m_serializedDataToServer;
00532 #ifdef Q_OS_SYMBIAN
00533         CSmfClientSymbian* m_SmfClientPrivate;
00534         friend class CSmfClientSymbian;
00535 #else
00536         SmfClientQt* m_SmfClientPrivate;
00537         friend class SmfClientQt;
00538 #endif
00539         quint8 m_argFlag;
00540
00541         };
00542
00543 #endif
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfmusicfingerprint.h Source File

  • File List

smf/smfservermodule/smfcommon/smfmusicfingerprint.h

00001
00020 #ifndef SMFMUSICFINGERPRINT_H_
00021 #define SMFMUSICFINGERPRINT_H_
00022
00023 #include <QDataStream>
00024 #include <QSharedData>
00025 #include <QMetaType>
00026
00027 #include "smfclientglobal.h"
00028
00029 class SmfMusicFingerPrintPrivate;
00030
00035 class SMFCOMMON_EXPORT SmfMusicFingerPrint
00036         {
00037 public:
00041         SmfMusicFingerPrint( );
00042
00047         SmfMusicFingerPrint( const SmfMusicFingerPrint &aOther );
00048
00053         SmfMusicFingerPrint& operator=( const SmfMusicFingerPrint &aOther );
00054
00058         ~SmfMusicFingerPrint( );
00059
00064         QByteArray musicFingerPrint ( ) const;
00065
00070         QString id( ) const;
00071
00076         void setMusicFingerPrint ( const QByteArray &aFp);
00077
00082         void setId( const QString &aId );
00083
00084 private:
00085         QSharedDataPointer<SmfMusicFingerPrintPrivate> d;
00086
00087         friend QDataStream &operator<<( QDataStream &aDataStream,
00088                         const SmfMusicFingerPrint &aMFP );
00089
00090         friend QDataStream &operator>>( QDataStream &aDataStream,
00091                         SmfMusicFingerPrint &aMFP );
00092
00093         };
00094
00095
00103 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00104                 const SmfMusicFingerPrint &aMFP );
00105
00113 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00114                 SmfMusicFingerPrint &aMFP);
00115
00116
00117 // Make the class SmfMusicFingerPrint known to QMetaType, so that as to register it.
00118 Q_DECLARE_METATYPE(SmfMusicFingerPrint)
00119 Q_DECLARE_METATYPE(QList<SmfMusicFingerPrint>)
00120
00121 #endif /* SMFMUSICFINGERPRINT_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfmusicfingerprint_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfmusicfingerprint_p.h

00001
00020 #ifndef SMFMUSICFINGERPRINT_P_H_
00021 #define SMFMUSICFINGERPRINT_P_H_
00022
00023 #include <QSharedData>
00024
00025 class SmfMusicFingerPrintPrivate : public QSharedData
00026 {
00027 public:
00031         SmfMusicFingerPrintPrivate( )
00032                 {
00033                 m_id.clear();
00034                 m_fingerPrintData.clear();
00035                 }
00036
00041         SmfMusicFingerPrintPrivate( const SmfMusicFingerPrintPrivate &aOther ) :
00042                 QSharedData ( aOther ),
00043                 m_fingerPrintData ( aOther.m_fingerPrintData ),
00044                 m_id (aOther.m_id) { }
00045
00049         ~SmfMusicFingerPrintPrivate( )
00050                 {
00051                 }
00052
00053         QByteArray m_fingerPrintData;   // Finger print data
00054         QString m_id;           // Finger print id by the service provider
00055
00056 };
00057
00058
00059 #endif /* SMFMUSICFINGERPRINT_P_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfmusicprofile.h Source File

  • File List

smf/smfservermodule/smfcommon/smfmusicprofile.h

00001
00020 #ifndef SMFMUSICPROFILE_H_
00021 #define SMFMUSICPROFILE_H_
00022
00023 #include <qdatastream.h>
00024 #include <QSharedData>
00025 #include <QMetaType>
00026
00027 #include "smftrackinfo.h"
00028 #include "smfevent.h"
00029 #include "smfclientglobal.h"
00030
00031
00032 class SmfMusicProfilePrivate;
00033
00034 /*
00035  * Implementation constants
00036  */
00037 const int SmfMusicProfileMaxSize = 20000;
00038
00043 class SMFCOMMON_EXPORT SmfMusicProfile
00044         {
00045 public:
00049         SmfMusicProfile( );
00050
00055         SmfMusicProfile( const SmfMusicProfile &aOther );
00056
00061         SmfMusicProfile& operator=( const SmfMusicProfile &aOther );
00062
00066         ~SmfMusicProfile( );
00067
00072         QList<SmfTrackInfo> recentTracks( ) const;
00073
00078         QList<SmfTrackInfo> favorites( ) const;
00079
00084         QList<SmfEvent> userEvents( ) const;
00085
00090         QString id( ) const;
00091
00096         void setRecentTracks( const QList<SmfTrackInfo>& aUsage );
00097
00102         void setFavorites( const QList<SmfTrackInfo>& aInterest );
00103
00108         void setUserEvents( const QList<SmfEvent> &aList );
00109
00114         void setId( const QString &aId );
00115
00116 private:
00117         QSharedDataPointer<SmfMusicProfilePrivate> d;
00118
00119         friend QDataStream &operator<<( QDataStream &aDataStream,
00120                         const SmfMusicProfile &aProfile );
00121
00122         friend QDataStream &operator>>( QDataStream &aDataStream,
00123                         SmfMusicProfile &aProfile );
00124
00125         };
00126
00127
00135 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00136                 const SmfMusicProfile &aProfile );
00137
00145 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00146                 SmfMusicProfile &aProfile);
00147
00148 typedef QList<SmfMusicProfile> SmfMusicProfileList;
00149
00150 // Make the class SmfMusicProfile known to QMetaType, so that as to register it.
00151 Q_DECLARE_METATYPE(SmfMusicProfile)
00152 Q_DECLARE_METATYPE(QList<SmfMusicProfile>)
00153
00154 #endif /* SMFMUSICPROFILE_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfmusicprofile_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfmusicprofile_p.h

00001
00020 #ifndef SMFMUSICPROFILE_P_H_
00021 #define SMFMUSICPROFILE_P_H_
00022
00023
00024 #include <smftrackinfo.h>
00025 #include <smfevent.h>
00026 #include <QSharedData>
00027
00028 class SmfMusicProfilePrivate : public QSharedData
00029 {
00030 public:
00034         SmfMusicProfilePrivate( ) {
00035                 m_recent.clear();
00036                 m_favorites.clear();
00037                 m_events.clear();
00038                 m_profileId.clear();
00039         }
00040
00045         SmfMusicProfilePrivate( const SmfMusicProfilePrivate &aOther ) :
00046                 QSharedData ( aOther ),
00047                 m_recent ( aOther.m_recent ),
00048                 m_favorites ( aOther.m_favorites ),
00049                 m_events ( aOther.m_events ),
00050                 m_profileId ( aOther.m_profileId )      { }
00051
00055         ~SmfMusicProfilePrivate( )
00056                 {
00057                 }
00058
00059         QList<SmfTrackInfo> m_recent;   // recently heard tracks
00060         QList<SmfTrackInfo> m_favorites;// favorite tracks
00061         QList<SmfEvent> m_events;               // events list
00062         QString m_profileId;                    // profile Id
00063
00064 };
00065
00066 #endif /* SMFMUSICPROFILE_P_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfmusicrating.h Source File

  • File List

smf/smfservermodule/smfcommon/smfmusicrating.h

00001
00021 #ifndef SMFMUSICRATING_H_
00022 #define SMFMUSICRATING_H_
00023
00024 #include <QSharedData>
00025 #include "smfclientglobal.h"
00026 #include <QMetaType>
00027
00028 class SmfTrackInfo;
00029 class SmfMusicRatingPrivate;
00030
00035 const int SMF_MAX_RATING = 10;
00036 const int SMF_MIN_RATING = 0;
00037
00043 class SMFCOMMON_EXPORT SmfMusicRating
00044         {
00045 public:
00050         SmfMusicRating( SmfTrackInfo *aParent = 0 );
00051
00056         SmfMusicRating( const SmfMusicRating &aOther );
00057
00062         SmfMusicRating& operator=( const SmfMusicRating &aOther );
00063
00067         ~SmfMusicRating( );
00068
00073         int rating( ) const;
00074
00079         int maxRating( ) const;
00080
00085         int minRating( ) const;
00086
00091         void setRating( const int &aRating );
00092
00097         void setMaxRating( const int &aMax );
00098
00103         void setMinRating( const int &aMin );
00104
00105 private:
00106         QSharedDataPointer<SmfMusicRatingPrivate> d;
00107
00108         friend QDataStream &operator<<( QDataStream &aDataStream,
00109                         const SmfMusicRating &aMusicRating );
00110
00111         friend QDataStream &operator>>( QDataStream &aDataStream,
00112                         SmfMusicRating &aMusicRating );
00113
00114         };
00115
00116
00124 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00125                 const SmfMusicRating &aMusicRating );
00126
00134 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00135                 SmfMusicRating &aMusicRating);
00136
00137
00138 // Make the class SmfMusicRating known to QMetaType, so that as to register it.
00139 Q_DECLARE_METATYPE(SmfMusicRating)
00140 Q_DECLARE_METATYPE(QList<SmfMusicRating>)
00141
00142 #endif /* SMFMUSICRATING_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfmusicrating_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfmusicrating_p.h

00001
00020 #ifndef SMFMUSICRATING_P_H_
00021 #define SMFMUSICRATING_P_H_
00022
00023 #include <QSharedData>
00024 #include <smfmusicrating.h>
00025
00026 class SmfMusicRatingPrivate : public QSharedData
00027 {
00028 public:
00032         SmfMusicRatingPrivate( ) {
00033                 m_rating = 0;
00034                 m_max = SMF_MAX_RATING;
00035                 m_min = SMF_MIN_RATING;
00036         }
00037
00042         SmfMusicRatingPrivate( const SmfMusicRatingPrivate &aOther ) :
00043                 QSharedData ( aOther ),
00044                 m_rating ( aOther.m_rating ),
00045                 m_max ( aOther.m_max ),
00046                 m_min ( aOther.m_min )  { }
00047
00051         ~SmfMusicRatingPrivate( )
00052                 {
00053                 }
00054
00055         qint32 m_rating;        // rating
00056         qint32 m_max;           // max rating
00057         qint32 m_min;           // min rating
00058
00059 };
00060
00061 #endif /* SMFMUSICRATING_P_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/smfplugins/smfmusicsearchplugin.h Source File

  • File List

smf/smfservermodule/smfserver/smfplugins/smfmusicsearchplugin.h

00001
00021 #ifndef SMFMUSICSEARCHPLUGIN_H_
00022 #define SMFMUSICSEARCHPLUGIN_H_
00023
00024 #include <smfpluginbase.h>
00025 #include <QList>
00026 #include <smfmusicfingerprint.h>
00027 #include <smftrackinfo.h>
00028 #include <smfalbum.h>
00029 #include <smfartists.h>
00030
00040 class SmfMusicSearchPlugin : public SmfPluginBase
00041         {
00042 public:
00043
00047         virtual ~SmfMusicSearchPlugin( ) {}
00048
00059         virtual SmfPluginError recommendations( SmfPluginRequestData &aRequest,
00060                         const SmfTrackInfo &aTrack,
00061                         const int aPageNum = SMF_FIRST_PAGE,
00062                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00063
00074         virtual SmfPluginError tracksSimilar( SmfPluginRequestData &aRequest,
00075                         const SmfTrackInfo &aTrack,
00076                         const int aPageNum = SMF_FIRST_PAGE,
00077                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00078
00088         virtual SmfPluginError tracksOfAlbum( SmfPluginRequestData &aRequest,
00089                         const SmfAlbum &aAlbum,
00090                         const int aPageNum = SMF_FIRST_PAGE,
00091                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00092
00102         virtual SmfPluginError tracksOfArtist( SmfPluginRequestData &aRequest,
00103                         const SmfArtists &aArtist,
00104                         const int aPageNum = SMF_FIRST_PAGE,
00105                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00106
00117         virtual SmfPluginError trackInfo( SmfPluginRequestData &aRequest,
00118                         const SmfMusicFingerPrint &aSignature,
00119                         const int aPageNum = SMF_FIRST_PAGE,
00120                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00121
00131         virtual SmfPluginError stores( SmfPluginRequestData &aRequest,
00132                         const SmfTrackInfo &aTrack,
00133                         const int aPageNum = SMF_FIRST_PAGE,
00134                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00135
00146         virtual SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00147                         const int &aOperation, QByteArray *aData ) = 0;
00148
00149         };
00150
00151 Q_DECLARE_INTERFACE( SmfMusicSearchPlugin, "org.symbian.smf.plugin.music.search/v0.2" );
00152
00153 #endif /* SMFMUSICSEARCHPLUGIN_H_ */
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/smfplugins/smfmusicserviceplugin.h Source File

  • File List

smf/smfservermodule/smfserver/smfplugins/smfmusicserviceplugin.h

00001
00021 #ifndef SMFMUSICSERVICEPLUGIN_H_
00022 #define SMFMUSICSERVICEPLUGIN_H_
00023
00024 #include <smfpluginbase.h>
00025 #include <smfmusicprofile.h>
00026 #include <smflocation.h>
00027 #include <smftrackinfo.h>
00028 #include <smfmusicrating.h>
00029 #include <smfcomment.h>
00030
00040 class SmfMusicServicePlugin : public SmfPluginBase
00041         {
00042 public:
00043
00047         virtual ~SmfMusicServicePlugin( ) {}
00048
00055         virtual SmfPluginError userMusicInfo( SmfPluginRequestData &aRequest ) = 0;
00056
00067         virtual SmfPluginError searchArtist( SmfPluginRequestData &aRequest,
00068                         const SmfArtists &aArtist,
00069                         const int aPageNum = SMF_FIRST_PAGE,
00070                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00071
00082         virtual SmfPluginError searchAlbum( SmfPluginRequestData &aRequest,
00083                         const SmfAlbum &aAlbum,
00084                         const int aPageNum = SMF_FIRST_PAGE,
00085                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00086
00097         virtual SmfPluginError searchEvents( SmfPluginRequestData &aRequest,
00098                         const SmfEvent &aEvent,
00099                         const int aPageNum = SMF_FIRST_PAGE,
00100                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00101
00112         virtual SmfPluginError searchVenue( SmfPluginRequestData &aRequest,
00113                         const SmfLocation &aVenue,
00114                         const int aPageNum = SMF_FIRST_PAGE,
00115                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00116
00127         virtual SmfPluginError searchUser( SmfPluginRequestData &aRequest,
00128                         const SmfLocation &aPlace,
00129                         const int aPageNum = SMF_FIRST_PAGE,
00130                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00131
00139         virtual SmfPluginError postCurrentPlaying(
00140                         SmfPluginRequestData &aRequest,
00141                         const SmfTrackInfo &aTrack ) = 0;
00142
00151         virtual SmfPluginError postRating(
00152                         SmfPluginRequestData &aRequest,
00153                         const SmfTrackInfo &aTrack,
00154                         const SmfMusicRating &aRating ) = 0;
00155
00164         virtual SmfPluginError postComments(
00165                         SmfPluginRequestData &aRequest,
00166                         const SmfTrackInfo &aTrack,
00167                         const SmfComment &aComment ) = 0;
00168
00179         virtual SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00180                         const int &aOperation, QByteArray *aData ) = 0;
00181
00182         };
00183
00184 Q_DECLARE_INTERFACE( SmfMusicServicePlugin, "org.symbian.smf.plugin.music.service/v0.2" );
00185
00186 #endif /* SMFMUSICSERVICEPLUGIN_H_ */
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfobserver.h Source File

  • File List

smf/smfservermodule/smfcommon/smfobserver.h

00001
00021 #ifndef SMFOBSERVER_H_
00022 #define SMFOBSERVER_H_
00023
00024 #include <QObject>
00025
00026 #include "smfglobal.h"
00027
00028 // Forward declaration
00029 class QByteArray;
00030
00034 class smfObserver : public QObject
00035         {
00036 public:
00043         virtual void resultsAvailable(QByteArray result,SmfRequestTypeID opcode, SmfError error) = 0;
00044         };
00045
00046 #endif
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfpicture.h Source File

  • File List

smf/smfservermodule/smfcommon/smfpicture.h

00001
00020 #ifndef SMFPICTURE_H_
00021 #define SMFPICTURE_H_
00022
00023 #include <QImage>
00024 #include <QDateTime>
00025 #include <QStringList>
00026 #include <QUrl>
00027 #include <qdatastream.h>
00028 #include <QSharedData>
00029 #include <smfclientglobal.h>
00030 #include <QMetaType>
00031 #include <smfcomment.h>
00032
00033 class SmfPicturePrivate;
00037 const int MaxSmfPictureSize = 1000;
00041 enum SmfPictureVisibility
00042         {
00043         SMFVisibilityFriend,
00044         SMFVisibilityPersonal,
00045         SMFVisibilityFamily,
00046         SMFVisibilityGroup,
00047         SMFVisibilityPublic
00048         };
00049
00054 class SMFCOMMON_EXPORT SmfPicture
00055         {
00056 public:
00063         SmfPicture(/*bool aDownloaded = false*/ );
00064
00069         SmfPicture( const SmfPicture &aOther );
00070
00075         SmfPicture( const QImage &aImage );
00076
00082         SmfPicture& operator=(const SmfPicture &aOther);
00083
00087         ~SmfPicture( );
00088
00093         QString owner( ) const;
00094
00099         QString title( ) const;
00100
00105         QString description( ) const;
00106
00111         SmfPictureVisibility visibility( ) const;
00112
00117         QDateTime postedDate( ) const;
00118
00123         QList<SmfComment> comments( ) const;
00124
00129         QStringList tags( ) const;
00130
00135         QUrl url( ) const;
00136
00141         QImage picture( ) const;
00142
00147         QString id( ) const;
00148
00154         bool downloadFlag();
00155
00160         void setOwner( const QString &aOwner );
00161
00166         void setTitle( const QString &aTitle );
00167
00172         void setDescription( const QString &aDescription );
00173
00179         void setVisibility( const SmfPictureVisibility &aVisibility );
00180
00185         void setPostedDate( const QDateTime &aDate );
00186
00191         void addComment( const SmfComment &aComment );
00192
00197         void addTags( const QStringList &aTags );
00198
00203         void setUrl( const QUrl &aUrl );
00204
00209         void setPicture( const QImage &aData );
00210
00215         void setId( const QString &aId );
00216
00217 private:
00218         QSharedDataPointer<SmfPicturePrivate> d;
00219
00220         friend QDataStream& operator<<( QDataStream &aDataStream,
00221                         const SmfPicture &aPic );
00222
00223         friend QDataStream& operator>>( QDataStream &aDataStream,
00224                         SmfPicture &aPic );
00225
00226         };
00227
00228
00236 SMFCOMMON_EXPORT QDataStream& operator<<( QDataStream &aDataStream,
00237                 const SmfPicture &aPic );
00238
00246 SMFCOMMON_EXPORT QDataStream& operator>>( QDataStream &aDataStream,
00247                 SmfPicture &aPic);
00248
00249 typedef QList<SmfPicture> SmfPictureList;
00250
00251 // Make the class SmfPicture known to QMetaType, so that as to register it.
00252 Q_DECLARE_METATYPE(SmfPicture)
00253 Q_DECLARE_METATYPE(QList<SmfPicture>)
00254
00255 #endif /* SMFPICTURE_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfpicture_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfpicture_p.h

00001
00020 #ifndef SMFPICTURE_P_H_
00021 #define SMFPICTURE_P_H_
00022
00023
00024 #include <QDateTime>
00025 #include <QStringList>
00026 #include <QUrl>
00027 #include <QSharedData>
00028 #include <smfclientglobal.h>
00029 #include <smfpicture.h>
00030
00031 class SmfPicturePrivate : public QSharedData
00032 {
00033 public:
00037         SmfPicturePrivate( ) {
00038                 m_photoId.clear();
00039                 m_owner.clear();
00040                 m_title.clear();
00041                 m_description.clear();
00042                 m_comments.clear();
00043                 m_tags.clear();
00044                 m_url.clear();
00045                 isDownloaded = false;
00046         }
00050         SmfPicturePrivate( const QImage &aImage ) {
00051                 m_photoId.clear();
00052                 m_owner.clear();
00053                 m_title.clear();
00054                 m_description.clear();
00055                 m_comments.clear();
00056                 m_tags.clear();
00057                 m_url.clear();
00058                 m_picture = aImage;
00059                 //false by default
00060                 isDownloaded = false;
00061         }
00062
00067         SmfPicturePrivate( const SmfPicturePrivate &aOther ) :
00068                 QSharedData ( aOther ),
00069                 m_photoId ( aOther.m_photoId ),
00070                 m_owner ( aOther.m_owner ),
00071                 m_title ( aOther.m_title ),
00072                 m_description ( aOther.m_description ),
00073                 m_picVisibility ( aOther.m_picVisibility ),
00074                 m_postedOn ( aOther.m_postedOn ),
00075                 m_comments ( aOther.m_comments ),
00076                 m_tags ( aOther.m_tags ),
00077                 m_url ( aOther.m_url ),
00078                 m_picture ( aOther.m_picture ),
00079                 isDownloaded(aOther.isDownloaded)
00080                         {
00081
00082                         }
00083
00087         ~SmfPicturePrivate( )
00088                 {
00089                 }
00090
00091         QString m_photoId;              // unique ID of the picture, service provider specific
00092         QString m_owner;                // owner of the picture
00093         QString m_title;                // picture title
00094         QString m_description;  // description
00095         SmfPictureVisibility m_picVisibility;// picture visibility
00096         QDateTime m_postedOn;   // date posted
00097         QList<SmfComment> m_comments;            // comments
00098         QStringList m_tags;             // tags
00099         QUrl m_url;                             // url
00100         QImage m_picture;               // picture data as bytearray
00107         bool isDownloaded;
00108 };
00109
00110 #endif /* SMFPICTURE_P_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfpicturealbum.h Source File

  • File List

smf/smfservermodule/smfcommon/smfpicturealbum.h

00001
00020 #ifndef SMFPICTUREALBUM_H_
00021 #define SMFPICTUREALBUM_H_
00022
00023 #include <QImage>
00024 #include <QDateTime>
00025 #include <QStringList>
00026 #include <QUrl>
00027 #include <qdatastream.h>
00028 #include <QSharedData>
00029 #include <smfclientglobal.h>
00030 #include <QMetaType>
00031 #include <smfcomment.h>
00032 #include <smfpicture.h>
00033
00034 class SmfPictureAlbumPrivate;
00036 const int MaxSmfPictureAlbumSize = 20000;//20KB
00037
00042 class SMFCOMMON_EXPORT SmfPictureAlbum
00043         {
00044 public:
00048         SmfPictureAlbum( );
00049
00054         SmfPictureAlbum( const SmfPictureAlbum &aOther );
00055
00061         SmfPictureAlbum& operator=(const SmfPictureAlbum &aOther);
00062
00066         ~SmfPictureAlbum( );
00067
00072         QString title( ) const;
00073
00078         QString description( ) const;
00079
00084         SmfPictureVisibility visibility( ) const;
00085
00090         QDateTime postedDate( ) const;
00091
00096         QList<SmfComment> comments( ) const;
00097
00102         QStringList keywords( ) const;
00103
00108         QUrl url( ) const;
00109
00114         QImage thumbnail( ) const;
00115
00120         qint32 pictureCount( ) const;
00121
00126         QString id( ) const;
00127
00132         void setTitle( const QString &aTitle );
00133
00138         void setDescription( const QString &aDescription );
00139
00145         void setVisibility( const SmfPictureVisibility &aVisibility );
00146
00151         void setPostedDate( const QDateTime &aDate );
00152
00157         void addComment( const SmfComment &aComment );
00158
00163         void addKeywords( const QStringList &aWords );
00164
00169         void setUrl( const QUrl &aUrl );
00170
00175         void setThumbnail(const QImage &aImage );
00176
00181          void setPictureCount( const qint32 aCount);
00182
00187         void setId( const QString &aId );
00188
00189 private:
00190         QSharedDataPointer<SmfPictureAlbumPrivate> d;
00191
00192         friend QDataStream& operator<<( QDataStream &aDataStream,
00193                         const SmfPictureAlbum &aAlbm );
00194
00195         friend QDataStream& operator>>( QDataStream &aDataStream,
00196                         SmfPictureAlbum &aAlbm );
00197
00198         };
00199
00200
00208 SMFCOMMON_EXPORT QDataStream& operator<<( QDataStream &aDataStream,
00209                 const SmfPictureAlbum &aAlbm );
00210
00218 SMFCOMMON_EXPORT QDataStream& operator>>( QDataStream &aDataStream,
00219                 SmfPictureAlbum &aAlbm);
00220
00221 typedef QList<SmfPictureAlbum> SmfPictureAlbumList;
00222
00223 // Make the class SmfPictureAlbum known to QMetaType, so that as to register it.
00224 Q_DECLARE_METATYPE(SmfPictureAlbum)
00225 Q_DECLARE_METATYPE(QList<SmfPictureAlbum>)
00226
00227 #endif /* SMFPICTUREALBUM_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfpicturealbum_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfpicturealbum_p.h

00001
00020 #ifndef SMFPICTUREALBUM_P_H_
00021 #define SMFPICTUREALBUM_P_H_
00022
00023
00024 #include <QDateTime>
00025 #include <QStringList>
00026 #include <QUrl>
00027 #include <QSharedData>
00028 #include <smfclientglobal.h>
00029 #include <smfpicturealbum.h>
00030
00031 class SmfPictureAlbumPrivate : public QSharedData
00032 {
00033 public:
00037         SmfPictureAlbumPrivate( ) {
00038                 m_title.clear();                // album title
00039                 m_description.clear();  // description
00040                 m_albumVisibility = SMFVisibilityPublic;// album visibility
00041                 m_comments.clear();              // comments
00042                 m_keywords.clear();             // tags
00043                 m_url.clear();                          // url
00044                 m_picCount=0;   //count of pictures
00045                 m_albumId.clear();              // unique ID of the album, service provider specific
00046         }
00047
00048
00053         SmfPictureAlbumPrivate( const SmfPictureAlbumPrivate &aOther ) :
00054                 QSharedData ( aOther ),
00055                 m_albumId ( aOther.m_albumId),
00056                 m_title ( aOther.m_title ),
00057                 m_description ( aOther.m_description ),
00058                 m_albumVisibility ( aOther.m_albumVisibility ),
00059                 m_postedOn ( aOther.m_postedOn ),
00060                 m_comments ( aOther.m_comments ),
00061                 m_keywords ( aOther.m_keywords ),
00062                 m_url ( aOther.m_url ),
00063                 m_picCount (aOther.m_picCount),
00064                 m_thumbnail ( aOther.m_thumbnail )      { }
00065
00069         ~SmfPictureAlbumPrivate( )
00070                 {
00071                 }
00072
00076         QString m_title;                // album title
00077         QString m_description;  // description
00078         SmfPictureVisibility m_albumVisibility;// album visibility
00079         QDateTime m_postedOn;   // date posted
00080         QList<SmfComment> m_comments;            // comments
00081         QStringList m_keywords;         // tags
00082         QUrl m_url;                             // url
00083         QImage m_thumbnail;             // thumbnail data
00084         quint32  m_picCount;    //count of pictures
00085         QString m_albumId;              // unique ID of the album, service provider specific
00086 };
00087
00088 #endif /* SMFPICTUREALBUM_P_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfplaylist.h Source File

  • File List

smf/smfservermodule/smfcommon/smfplaylist.h

00001
00022 #ifndef SMFPLAYLIST_H_
00023 #define SMFPLAYLIST_H_
00024
00025 #include <qdatastream.h>
00026 #include <QSharedData>
00027 #include <QMetaType>
00028 #include <QVariant>
00029
00030 #include "smfclientglobal.h"
00031 #include "smftrackinfo.h"
00032 #include "smfcomment.h"
00033
00034 class SmfPlaylistPrivate;
00035
00036 const int SmfMusicPlaylistMaxSize = 5000;
00037
00044 class SMFCOMMON_EXPORT SmfPlaylist
00045         {
00046 public:
00050         SmfPlaylist( );
00051
00056         SmfPlaylist( const SmfPlaylist &aOther );
00057
00062         SmfPlaylist& operator=( const SmfPlaylist &aOther );
00063
00067         ~SmfPlaylist( );
00068
00073         QString version( ) const;
00074
00079         QString playListTitle( ) const;
00080
00085         QString author( ) const;
00086
00091         QList<SmfComment> comments( ) const;
00092
00097         QUrl info( ) const;
00098
00103         QUrl location( ) const;
00104
00109         QString id( ) const;
00110
00116         QUrl image( ) const;
00117
00122         QDateTime creationDate( ) const;
00123
00129         QUrl license( ) const;
00130
00136         QList<QUrl> attribution( ) const;
00137
00142         QVariantMap metadata( ) const;
00143
00149         QVariantMap extension( ) const;
00150
00155         QList<SmfTrackInfo> trackList( ) const;
00156
00161         void setVersion( const QString& aVersion );
00162
00167         void setPlayListTitle( const QString &aTitle );
00168
00173         void setAuthor( const QString& aAuthor );
00174
00179         void setComments( const QList<SmfComment>& aComments );
00180
00185         void setInfo( const QUrl& aInfoUrl );
00186
00191         void setLocation( const QUrl& aLocation );
00192
00197         void setId( const QString &aId);
00198
00204         void setImage( const QUrl& aImage );
00205
00210         void setCreationDate( const QDateTime& aDate );
00211
00217         void setLicense( const QUrl& aLicense );
00218
00224         void setAttribution( const QList<QUrl>& aAttribution );
00225
00230         void setMetadata( const QVariantMap& aMetaData );
00231
00237         void setExtension( const QVariantMap& aExtension );
00238
00243         void setTrackList( const QList<SmfTrackInfo> &aList );
00244
00245 private:
00246         QSharedDataPointer<SmfPlaylistPrivate> d;
00247
00248         friend QDataStream &operator<<( QDataStream &aDataStream,
00249                         const SmfPlaylist &aPlaylist );
00250
00251         friend QDataStream &operator>>( QDataStream &aDataStream,
00252                         SmfPlaylist &aPlaylist );
00253
00254         };
00255
00256
00264 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00265                 const SmfPlaylist &aPlaylist );
00266
00274 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00275                 SmfPlaylist &aPlaylist);
00276
00277 typedef QList<SmfPlaylist> SmfPlaylistList;
00278
00279 // Make the class SmfPlaylist known to QMetaType, so that as to register it.
00280 Q_DECLARE_METATYPE(SmfPlaylist)
00281 Q_DECLARE_METATYPE(QList<SmfPlaylist>)
00282
00283 #endif /* SMFPLAYLIST_H_ */
00284
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfplaylist_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfplaylist_p.h

00001
00020 #ifndef SMFPLAYLIST_P_H_
00021 #define SMFPLAYLIST_P_H_
00022
00023 #include <smftrackinfo.h>
00024 #include <QSharedData>
00025
00026 class SmfPlaylistPrivate : public QSharedData
00027 {
00028 public:
00032         SmfPlaylistPrivate( ) {
00033                 m_version.clear();
00034                 m_title.clear();
00035                 m_author.clear();
00036                 m_comments.clear();
00037                 m_info.clear();
00038                 m_location.clear();
00039                 m_playlistId.clear();
00040                 m_image.clear();
00041                 m_license.clear();
00042                 m_attribution.clear();
00043                 m_trackList.clear();
00044         }
00045
00050         SmfPlaylistPrivate( const SmfPlaylistPrivate &aOther ) :
00051                 QSharedData ( aOther ),
00052                 m_version ( aOther.m_version ),
00053                 m_title ( aOther.m_title ),
00054                 m_author ( aOther.m_author ),
00055                 m_comments ( aOther.m_comments ),
00056                 m_info ( aOther.m_info ),
00057                 m_location ( aOther.m_location ),
00058                 m_playlistId ( aOther.m_playlistId ),
00059                 m_image ( aOther.m_image ),
00060                 m_creationDate ( aOther.m_creationDate ),
00061                 m_license ( aOther.m_license ),
00062                 m_attribution ( aOther.m_attribution ),
00063                 m_metadata ( aOther.m_metadata ),
00064                 m_extension ( aOther.m_extension ),
00065                 m_trackList ( aOther.m_trackList ) { }
00066
00070         ~SmfPlaylistPrivate( )
00071                 {
00072                 }
00073
00077         QString m_version;                              // playlist version
00078         QString m_title;                                // playlist title
00079         QString m_author;                               // playlist creator
00080         QList<SmfComment> m_comments;   // comments about the playlist
00081         QUrl m_info;                                    // URI of a web page to find out more about this playlist
00082         QUrl m_location;                                // The Source URI for this playlist
00083         QString m_playlistId;                   // The playlist ID
00084         QUrl m_image;                                   // URI of an image to display in the absence of an
00085                                                                         // image for playlist's tracks
00086         QDateTime m_creationDate;               // creation date of the playlist
00087         QUrl m_license;                                 // URI of a resource that describes the license under
00088                                                                         // which this playlist was released
00089         QList<QUrl> m_attribution;              // An ordered list of URIs. The purpose is to satisfy licenses
00090                                                                         // allowing modification but requiring attribution
00091         QVariantMap m_metadata;                 // The meta element allows metadata fields to be added to XSPF
00092         QVariantMap m_extension;                // The extension element allows non-XSPF XML
00093                                                                         // to be included in XSPF documents
00094         QList<SmfTrackInfo> m_trackList;// list of tracks in the playlist
00095
00096 };
00097
00098 #endif /* SMFPLAYLIST_P_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/smfplugins/smfplaylistserviceplugin.h Source File

  • File List

smf/smfservermodule/smfserver/smfplugins/smfplaylistserviceplugin.h

00001
00021 #ifndef SMFPLAYLISTSERVICEPLUGIN_H_
00022 #define SMFPLAYLISTSERVICEPLUGIN_H_
00023
00024 #include <smfpluginbase.h>
00025 #include <smfplaylist.h>
00026 #include <smfmusicprofile.h>
00027 #include <smftrackinfo.h>
00028 #include <smfcontact.h>
00029
00030
00041 class SmfPlaylistServicePlugin : public SmfPluginBase
00042         {
00043 public:
00047         virtual ~SmfPlaylistServicePlugin( ) {}
00048
00057         virtual SmfPluginError playlists( SmfPluginRequestData &aRequest,
00058                         const int aPageNum = SMF_FIRST_PAGE,
00059                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00060
00070         virtual SmfPluginError playlistsOf( SmfPluginRequestData &aRequest,
00071                         const SmfContact &aUser,
00072                         const int aPageNum = SMF_FIRST_PAGE,
00073                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00074
00083         virtual SmfPluginError addToPlaylist( SmfPluginRequestData &aRequest,
00084                         const SmfPlaylist &aPlaylist,
00085                         const QList<SmfTrackInfo> &aTracks ) = 0;
00086
00094         virtual SmfPluginError postCurrentPlayingPlaylist(
00095                         SmfPluginRequestData &aRequest,
00096                         const SmfPlaylist &aPlaylist ) = 0;
00097
00108         virtual SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00109                         const int &aOperation, QByteArray *aData ) = 0;
00110
00111         };
00112
00113 Q_DECLARE_INTERFACE( SmfPlaylistServicePlugin, "org.symbian.smf.plugin.music.playlist/v0.2" );
00114
00115 #endif /* SMFPLAYLISTSERVICEPLUGIN_H_ */
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/smfplugins/smfpluginbase.h Source File

  • File List

smf/smfservermodule/smfserver/smfplugins/smfpluginbase.h

00001
00020 #ifndef SMFPLUGINBASE_H_
00021 #define SMFPLUGINBASE_H_
00022
00023 #include <smfproviderbase.h>
00024 #include <smfglobal.h>
00025
00026 class SmfPluginUtil;
00027
00032 class SmfPluginBase
00033         {
00034 public:
00038         virtual ~SmfPluginBase( ) {}
00039
00044         virtual void initialize( ) = 0;
00045
00050         virtual SmfProviderBase* getProviderInfo( ) = 0;
00051
00117         virtual SmfPluginError responseAvailable(
00118                         const SmfRequestTypeID aOperation,
00119                         const SmfTransportResult &aTransportResult,
00120                         QByteArray *aReply,
00121                         QVariant* aResult,
00122                         SmfPluginRetType &aRetType,
00123                         SmfResultPage &aPageResult ) = 0;
00124
00125         };
00126
00127 Q_DECLARE_INTERFACE( SmfPluginBase, "org.symbian.smf.plugin.smfpluginbase/v0.2" );
00128
00129 #endif /* SMFPLUGINBASE_H_ */
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/pluginmgr/smfpluginmanager.h Source File

  • File List

smf/smfservermodule/smfserver/pluginmgr/smfpluginmanager.h

00001
00020 #ifndef SMFPLUGINMANAGER_H_
00021 #define SMFPLUGINMANAGER_H_
00022
00023 #include <QtSql>
00024 #include <smfglobal.h>
00025 #include "smfserverglobal.h"
00026 #include "smfserver.h"
00027
00028 // Forward declaration
00029 class SmfPluginManagerUtil;
00030 class SmfTransportManagerUtil;
00031 class QFileSystemWatcher;
00032 class QPluginLoader;
00033 class SmfPluginBase;
00034 class SmfProvider;
00035
00040 struct SmfWaitingPluginInfoStruc
00041         {
00045         quint32 iSessionID;
00049         QString iPluginId;
00050
00054         SmfPluginBase *iInstance;
00055
00060         SmfRequestTypeID iOperation;
00061
00065         QByteArray iInputData;
00066
00067         };
00068
00069
00073 class SmfPluginManager : public QObject
00074         {
00075         Q_OBJECT
00076
00077 public:
00083         static SmfPluginManager* getInstance ( SmfServer *aServer = NULL );
00084
00088         SmfServer* server ( ) { return m_server; }
00089
00093         ~SmfPluginManager ( );
00094
00095 public:
00117         SmfError createRequest ( const quint32& aSessionID,
00118                         const QString& aPluginID,
00119                         const SmfRequestTypeID& aOperation,
00120                         QByteArray& aInputData );
00121
00134         SmfError createSyncRequest ( const QString& aPluginID,
00135                         const SmfRequestTypeID& aOperation,
00136                         QByteArray& aInputData,
00137                         QByteArray& aOutputData );
00138
00146         void responseAvailable ( const SmfTransportResult &aTransportResult,
00147                         QNetworkReply *aReply,
00148                         QByteArray *aResponse );
00149
00157         bool cancelRequest ( const quint32& aSessionID );
00158
00166         void getPlugins ( const QString& aInterface,
00167                         QMap<QString,SmfProvider>& aMap );
00168
00176         void getPluginId ( const QString& aInterface,
00177                         const SmfProvider& aProv, QString& aPluginId );
00178
00179 private:
00184         void initializeFileWatcher ( );
00185
00195         bool initializeSmfPluginDataBase ( );
00196
00207         QObject* load ( const QString &aPluginId,
00208                         SmfError &aLoadResult);
00209
00217         bool unload ( SmfPluginBase *aPlugin );
00218
00227         bool unload ( const QList<SmfPluginBase*> &aPluginList);
00228
00243         void sendRequest ( SmfPluginRequestData &aReqData,
00244                         SmfError &aResult,
00245                         const QList<QUrl> &aUrlList );
00246
00259         bool authorisePlugin( const QString &aPluginId,
00260                         QList<QUrl> &aUrlList );
00261
00269         void serializeResult ( const SmfRequestTypeID &aOperation,
00270                         QVariant* aResult,
00271                         QDataStream &aDataStream );
00272
00273 private slots:
00280         void directoryChanged ( const QString &aPath );
00281
00282 private:
00287         SmfPluginManager ( SmfServer *aServer );
00288
00293         SmfPluginManager ( const SmfPluginManager &aOther );
00294
00295 private:
00299         static SmfPluginManager* m_myInstance;
00300
00305         QHash<SmfPluginBase*, QPluginLoader*> m_pluginLoaderHash;
00306
00311         QFileSystemWatcher *m_fileWatcher;
00312
00317         SmfWaitingPluginInfoStruc *m_tempStruct;
00318
00323         QHash<QNetworkReply*, SmfWaitingPluginInfoStruc*> m_waitingPluginHash;
00324
00328         QHash<QString, QString> m_pluginIdPathHash;
00329
00334         SmfServer *m_server;
00335
00340         SmfTransportManagerUtil *m_transMngrUtil;
00341
00346         SmfPluginManagerUtil *m_util;
00347
00351         QSqlDatabase m_pluginDataBase;
00352
00353         };
00354
00355 #endif /* SMFPLUGINMANAGER_H_ */
Generated on Thu Sep 23 15:03:14 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/pluginmgr/smfpluginmanagerutil.h Source File

  • File List

smf/smfservermodule/smfserver/pluginmgr/smfpluginmanagerutil.h

00001
00021 #ifndef SMFPLUGINMANAGERUTIL_H_
00022 #define SMFPLUGINMANAGERUTIL_H_
00023
00024 #include "smfpluginbase.h"
00025 #include "smfserverglobal.h"
00026
00027 // Forward declaration
00028 class SmfPluginManager;
00029
00034 class SmfPluginManagerUtil : public QObject
00035         {
00036         Q_OBJECT
00037
00038 public:
00044         static SmfPluginManagerUtil* getInstance ( QObject *aParent = 0 );
00045
00049         ~SmfPluginManagerUtil ( );
00050
00051 private:
00056         SmfPluginManagerUtil ( QObject *aParent = 0 );
00057
00058 private:
00076         void createRequest ( QObject* aInstance,
00077                         const SmfRequestTypeID &aOperation,
00078                         QByteArray &aInputData,
00079                         SmfPluginRequestData &aReqData,
00080                         SmfError &aResult,
00081                         QByteArray &aOutputData );
00082
00092         SmfPluginError createActivityFetcherRequest ( QObject *aPlugin,
00093                         const SmfRequestTypeID &aOperation,
00094                         QByteArray &aInputData,
00095                         SmfPluginRequestData &aReqData );
00096
00106         SmfPluginError createContactFetcherRequest ( QObject *aPlugin,
00107                         const SmfRequestTypeID &aOperation,
00108                         QByteArray &aInputData,
00109                         SmfPluginRequestData &aReqData );
00110
00121         SmfPluginError createContactPostRequest ( QObject *aPlugin,
00122                         const SmfRequestTypeID &aOperation,
00123                         QByteArray &aInputData,
00124                         SmfPluginRequestData &aReqData );
00125
00135         SmfPluginError createMusicLyricsRequest ( QObject *aPlugin,
00136                         const SmfRequestTypeID &aOperation,
00137                         QByteArray &aInputData,
00138                         SmfPluginRequestData &aReqData );
00139
00140
00150         SmfPluginError createEventsFetcherRequest ( QObject *aPlugin,
00151                         const SmfRequestTypeID &aOperation,
00152                         QByteArray &aInputData,
00153                         SmfPluginRequestData &aReqData );
00154
00164         SmfPluginError createMusicSearchRequest ( QObject *aPlugin,
00165                         const SmfRequestTypeID &aOperation,
00166                         QByteArray &aInputData,
00167                         SmfPluginRequestData &aReqData );
00168
00169
00180         SmfPluginError createMusicServiceRequest ( QObject *aPlugin,
00181                         const SmfRequestTypeID &aOperation,
00182                         QByteArray &aInputData,
00183                         SmfPluginRequestData &aReqData );
00184
00185
00195         SmfPluginError createMusicPlaylistRequest ( QObject *aPlugin,
00196                         const SmfRequestTypeID &aOperation,
00197                         QByteArray &aInputData,
00198                         SmfPluginRequestData &aReqData );
00199
00209         SmfPluginError createGalleryRequest ( QObject *aPlugin,
00210                         const SmfRequestTypeID &aOperation,
00211                         QByteArray &aInputData,
00212                         SmfPluginRequestData &aReqData );
00213
00223         SmfPluginError createSyncRequest ( QObject *aPlugin,
00224                         const SmfRequestTypeID &aOperation,
00225                         QByteArray &aInputData,
00226                         QByteArray &aOutputData );
00227
00241         SmfError responseAvailable ( SmfPluginBase *aInstance,
00242                         const SmfRequestTypeID &aOperation,
00243                         const SmfTransportResult &aTransportResult,
00244                         QByteArray *aResponse,
00245                         QVariant *aResult,
00246                         SmfPluginRetType &aRetType,
00247                         SmfResultPage &aPageResult );
00248
00256         void serializeResult ( const SmfRequestTypeID &aOperation,
00257                         QVariant* aResult,
00258                         QDataStream &aDataStream );
00259
00265         void convertPluginErrorType( const SmfPluginError &aPluginError,
00266                         SmfError &aSMFError );
00267
00273         void convertNetworkErrorType( const SmfTransportResult &aTMError,
00274                         SmfError &aSMFError );
00275
00276         friend class SmfPluginManager;
00277
00278 private:
00282         static SmfPluginManagerUtil* m_myInstance;
00283
00284         };
00285
00286 #endif /* SMFPLUGINMANAGERUTIL_H_ */
Generated on Thu Sep 23 15:03:14 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfpluginutil.h Source File

  • File List

smf/smfservermodule/smfcommon/smfpluginutil.h

00001
00021 #ifndef SMFPLUGINUTIL_H_
00022 #define SMFPLUGINUTIL_H_
00023
00024 #include <QNetworkAccessManager>
00025 #include <QMap>
00026 #include <QVariant>
00027 #include <parser.h>
00028 #include <smfclientglobal.h>
00029 #include <smfcredmgrclient.h>
00030
00031 enum SmfParsingMode
00032         {
00033         ParseForRequestContent, //Inline query format (foo=bar&bar=baz&baz=foo ...), suitable for POST requests.
00034         ParseForInlineQuery, // Same as ParseForRequestContent, but prepends the string with a question mark -
00035                                                 // suitable for GET requests (appending parameters to the request URL)
00036         ParseForHeaderArguments // HTTP request header format (parameters to be put inside a request header).
00037         };
00038
00043 class SMFCOMMON_EXPORT SmfPluginUtil
00044         {
00045 public:
00049         SmfPluginUtil();
00050
00054         ~SmfPluginUtil ( );
00055
00062     QVariant parse ( QIODevice* io, bool* ok = 0 );
00063
00072     QVariant parse ( const QByteArray& jsonData, bool* ok = 0 );
00073
00078     QString errorString ( ) const;
00079
00084     int errorLine ( ) const;
00085
00094     void getAuthKeys( SmfAuthParams &aKeys,
00095                 const QString aRegToken,
00096                 const QDateTime& aValidity,
00097                 const QString aPluginID );
00098
00104     void getNonce( QString &aNonceString, const qint64 aLength );
00105
00118         QByteArray createParameterString( const QString &aRequestUrl,
00119                         QNetworkAccessManager::Operation aOperation,
00120                         const QByteArray &aToken,
00121                         const QByteArray &aTokenSecret,
00122                         const SmfSignatureMethod aSignatureMethod,
00123                         const QMultiMap<QByteArray, QByteArray> &aParams,
00124                         const SmfParsingMode aMode);
00125
00126 private:
00130         QJson::Parser *m_jsonParser;
00131
00132         };
00133
00134 #endif /* SMFPLUGINUTIL_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfpost.h Source File

  • File List

smf/smfservermodule/smfcommon/smfpost.h

00001
00020 #ifndef SMFPOST_H_
00021 #define SMFPOST_H_
00022
00023 #include <QImage>
00024 #include <QUrl>
00025 #include <qdatastream.h>
00026 #include <QMetaType>
00027 #include <QSharedData>
00028 #include <QTextDocument>
00029 #include <smfclientglobal.h>
00030 #include <smfcontact.h>
00034 class SmfPostPrivate;
00035
00036 const int MaxSmfPostSize=1000;
00040 enum SmfAppearenceInfo
00041         {
00042         EAppearanceNotSupported,
00043         EOnline,
00044         EOffline,
00045         EBusy,
00046         EDoNotDisturb,
00047         EAppearOffline,
00048         EOther
00049         };
00050 //To sort out conflict betwn client and PM, later should be removed
00051 typedef SmfAppearenceInfo SmfPresenceInfo;
00056 class SMFCOMMON_EXPORT SmfPost //: public QTextDocument
00057         {
00058 public:
00063         SmfPost( );
00064
00072         SmfPost(SmfContact aOwner, QString aTitle, QString aDesc, QImage aImage, QUrl aUrl );
00073
00078         SmfPost( const SmfPost &aOther );
00079
00085         SmfPost& operator=( const SmfPost &aOther );
00086
00090         ~SmfPost( );
00091
00095         SmfContact owner() const;
00096
00101         QString title( ) const;
00102
00107         QString description( ) const;
00108
00113         QImage image( ) const;
00114
00119         QUrl url( ) const;
00120
00125         QDateTime postedDateTime() const;
00126
00131         QString id( ) const;
00132
00136         void setOwner(const SmfContact& aOwner);
00137
00142         void setTitle( const QString &aTitle );
00143
00148         void setDescription( const QString &aDesc );
00149
00154         void setImage( const QImage& aPic );
00155
00160         void setUrl( QUrl& aUrl );
00161
00166         void setPostedDateTime( QDateTime &aDate );
00167
00171         void setId(QString aPostId);
00172
00173 private:
00174         QSharedDataPointer<SmfPostPrivate> d;
00175
00176         friend QDataStream &operator<<( QDataStream &aDataStream,
00177                         const SmfPost &aPost );
00178
00179         friend QDataStream &operator>>( QDataStream &aDataStream,
00180                         SmfPost &aPost );
00181
00182         };
00183
00184
00192 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00193                 const SmfPost &aPost );
00194
00202 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00203                 SmfPost &aPost);
00204
00205 typedef QList<SmfPost> SmfPostList;
00206
00207 // Make the class SmfPost known to QMetaType, so that as to register it.
00208 Q_DECLARE_METATYPE(SmfPost)
00209 Q_DECLARE_METATYPE(SmfPostList)
00210
00211 #endif /* SMFPOST_H_ */
Generated on Thu Sep 23 15:03:13 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfpost_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfpost_p.h

00001
00020 #ifndef SMFPOST_P_H_
00021 #define SMFPOST_P_H_
00022
00023 #include <QSharedData>
00024 #include "smfcontact.h"
00025 class SmfPostPrivate : public QSharedData
00026 {
00027 public:
00031         SmfPostPrivate( ) { m_title.clear(); m_desc.clear(); m_url.clear(); m_postId.clear(); }
00032
00036         SmfPostPrivate(SmfContact aOwner, QString aTitle, QString aDesc, QImage aImage, QUrl aUrl )
00037                 {
00038                 m_owner = aOwner;
00039                 m_title = aTitle;
00040                 m_desc = aDesc;
00041                 m_image = aImage;
00042                 m_url = aUrl;
00043                 m_postId.clear();
00044                 }
00045
00050         SmfPostPrivate( const SmfPostPrivate &aOther ) :
00051                 QSharedData ( aOther ),
00052                 m_title ( aOther.m_title ),
00053                 m_desc ( aOther.m_desc ),
00054                 m_image ( aOther.m_image ),
00055                 m_url ( aOther.m_url ),
00056                 m_date ( aOther.m_date ),
00057                 m_postId ( aOther.m_postId )    { }
00058
00062         ~SmfPostPrivate( )
00063                 {
00064                 }
00065
00066         SmfContact m_owner; //owner of the post(who posted this message)
00067         QString m_title;        // title
00068         QString m_desc;         // description
00069         QImage m_image;         // image
00070         QUrl m_url;                     // url
00071         QDateTime m_date;       // posted date
00072         QString m_postId;       // post's unique Id
00073
00074 };
00075
00076 #endif /* SMFPOST_P_H_ */
Generated on Thu Sep 23 15:03:14 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfpostprovider.h Source File

  • File List

smf/smfservermodule/smfclient/smfpostprovider.h

00001
00020 #ifndef SMFPOSTPROVIDER_H
00021 #define SMFPOSTPROVIDER_H
00022
00023 #include <QObject>
00024 #include <qmobilityglobal.h>
00025 #include <qgeopositioninfo.h>
00026 #include <QTextDocument>
00027 #include <smfglobal.h>
00028 #include <smfclientglobal.h>
00029 #include <smfprovider.h>
00030 #include <smfcontact.h>
00031 #include <smflocation.h>
00032 #include <smfpost.h>
00033
00034 class SmfPostProviderPrivate;
00035
00045 class SMFCLIENT_EXPORT SmfPostProvider : public QObject
00046         {
00047         Q_OBJECT
00048
00049 public:
00056         SmfPostProvider(SmfProvider* baseProvider);
00057
00061         ~SmfPostProvider();
00062
00063 public:
00068         qint32 maxCharsInPost() const;
00069
00074         qint32 maxItems() const;
00075
00080         QVector<QTextFormat> supportedFormats () const;
00081
00085         bool supportsAppearence () const;
00086
00087 public slots:
00097         SmfError posts(SmfContact* user = 0,int pageNum=SMF_FIRST_PAGE,int perPage=SMF_ITEMS_PER_PAGE);
00098
00106         SmfError post(SmfPost& postData,SmfLocation& location);
00107
00115         SmfError updatePost(SmfPost& postData);
00116
00125         SmfError postDirected(SmfPost& postData,SmfContact& contact,SmfLocation* location=0);
00126
00134         SmfError commentOnAPost( SmfPost &aTarget, SmfPost &aComment, SmfLocation *aLocation = NULL);
00135
00142         SmfError postAppearence(SmfAppearenceInfo appearence, const QString &status);
00143
00152         SmfError sharePost(SmfPost& postData,SmfContact& contact,bool edited);
00153
00163    SmfError customRequest(const int& operationId,QByteArray* customData);
00164
00171         SmfError cancelRequest ();
00172
00173 signals:
00174
00183         void postsAvailable(SmfPostList* list, SmfError error, SmfResultPage resultPage);
00184
00189         void postFinished(SmfError success);
00190
00196         void customDataAvailable(int operationId, QByteArray* customData);
00197
00198 private:
00202         SmfProvider* getProvider() const;
00203
00204 // Friend Class
00205         //friend so that it can directly emit SmfPostProvider's signal
00206         friend class SmfPostProviderPrivate;
00207
00208 private:
00209         SmfProvider* m_baseProvider;
00210         SmfPostProviderPrivate* m_private;      //private impl wrapper
00211
00212         };
00213
00214 SMF_SERVICE_NAME(SmfPostProvider, "org.symbian.smf.client.contact.posts\0.2")
00215
00216 #endif // SMFPOSTPROVIDER_H
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfpostprovider_p.h Source File

  • File List

smf/smfservermodule/smfclient/smfpostprovider_p.h

00001
00020 #ifndef SMFPOSTPROVIDER_P_H_
00021 #define SMFPOSTPROVIDER_P_H_
00022
00023 #include <QVector>
00024 #include <QTextFormat>
00025 #include <smfclientglobal.h>
00026 #include <smfglobal.h>
00027 #include <smfobserver.h>
00028 #include <smfpost.h>
00029
00030 // Forward declaration
00031 class SmfProvider;
00032 class SmfContact;
00033 class SmfLocation;
00034 class SmfPostProvider;
00035 #ifdef Q_OS_SYMBIAN
00036         class CSmfClientSymbian;
00037 #else
00038         class SmfClientQt;
00039 #endif
00040
00047 const int KSmfPostMaxSize = 1000000;
00048
00049
00058 class SmfPostProviderPrivate: public smfObserver
00059         {
00060         Q_OBJECT
00061
00062 public:
00066         SmfPostProviderPrivate(SmfPostProvider* postProvider=0);
00067
00071         ~SmfPostProviderPrivate();
00072
00073 public:
00078         qint32 maxCharsInPost();
00079
00084         qint32 maxItems();
00085
00090         QVector<QTextFormat> supportedFormats();
00091
00095         bool supportsAppearence();
00096
00106         SmfError posts(SmfContact* user = 0,int pageNum=SMF_FIRST_PAGE,int perPage=SMF_ITEMS_PER_PAGE);
00107
00115         SmfError post(SmfPost& postData,SmfLocation& location) ;
00116
00124         SmfError updatePost(SmfPost& postData);
00125
00134         SmfError postDirected(SmfPost& postData,SmfContact& contact,SmfLocation* location=0);
00135
00143         SmfError commentOnAPost( SmfPost &aTarget, SmfPost &aComment, SmfLocation *aLocation = NULL);
00144
00151         SmfError postAppearence(SmfAppearenceInfo appearence, const QString &status);
00152
00161         SmfError sharePost(SmfPost& postData,SmfContact& contact,bool edited);
00162
00172         SmfError customRequest(const int& operationId,QByteArray* customData);
00173
00180         SmfError cancelRequest ();
00181
00182 public: //From smfobserver
00189         void resultsAvailable(QByteArray result,SmfRequestTypeID opcode,SmfError error);
00190
00191 private:
00192         SmfPostProvider* m_postProvider;
00193         QByteArray m_serializedDataToServer;    //serialized xtra info, order of serialization follows order of param
00194         quint8 m_argFlag;
00195 #ifdef Q_OS_SYMBIAN
00196         CSmfClientSymbian* m_SmfClientPrivate;
00197         friend class CSmfClientSymbian;
00198 #else
00199         SmfClientQt* m_SmfClientPrivate;
00200         friend class SmfClientQt;
00201 #endif
00202         };
00203
00204 #endif /* SMFPOSTPROVIDER_P_H_ */
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/smfplugins/smfpostproviderplugin.h Source File

  • File List

smf/smfservermodule/smfserver/smfplugins/smfpostproviderplugin.h

00001
00021 #ifndef SMFPOSTPROVIDERPLUGIN_H_
00022 #define SMFPOSTPROVIDERPLUGIN_H_
00023
00024 #include <smfpluginbase.h>
00025 #include <smfcontact.h>
00026 #include <smfpost.h>
00027 #include <smflocation.h>
00028
00039 class SmfPostProviderPlugin : public SmfPluginBase
00040         {
00041 public:
00042
00046         virtual ~SmfPostProviderPlugin( ) {}
00047
00054         virtual qint32 maxCharsInPost( ) const = 0;
00055
00062         virtual qint32 maxItems( ) const = 0;
00063
00070         virtual QVector<QTextFormat> supportedFormats ( ) const = 0;
00071
00077         virtual bool supportsAppearence ( ) const = 0;
00078
00088         virtual SmfPluginError retrieve( SmfPluginRequestData &aRequest,
00089                         const SmfContact *aUser = NULL,
00090                         const int aPageNum = SMF_FIRST_PAGE,
00091                         const int aItemsPerPage = SMF_ITEMS_PER_PAGE ) = 0;
00092
00093
00102         virtual SmfPluginError post( SmfPluginRequestData &aRequest,
00103                         const SmfPost &aPostData,
00104                         const SmfLocation &aLocation ) = 0;
00105
00113         virtual SmfPluginError updatePost( SmfPluginRequestData &aRequest,
00114                         const SmfPost &aPostData ) = 0;
00115
00125         virtual SmfPluginError postDirected( SmfPluginRequestData &aRequest,
00126                         const SmfPost &aPostData,
00127                         const SmfContact &aContact,
00128                         const SmfLocation *aLocation = NULL ) = 0;
00129
00130
00140         virtual SmfPluginError commentOnAPost(SmfPluginRequestData &aRequest,
00141                         const SmfPost &aTarget,
00142                         const SmfPost &aComment,
00143                         const SmfLocation *aLocation = NULL) = 0;
00144
00153         virtual SmfPluginError postAppearence( SmfPluginRequestData &aRequest,
00154                         const SmfPresenceInfo &aAppearence,
00155                         const QString &aStatus ) = 0;
00156
00167         virtual SmfPluginError sharePost( SmfPluginRequestData &aRequest,
00168                         const SmfPost &aPostData,
00169                         const SmfContact &aContact,
00170                         const bool &aEdited ) = 0;
00171
00182         virtual SmfPluginError customRequest( SmfPluginRequestData &aRequest,
00183                         const int &aOperation, QByteArray *aData ) = 0;
00184
00185
00186         };
00187
00188 Q_DECLARE_INTERFACE( SmfPostProviderPlugin, "org.symbian.smf.plugin.contact.posts/v0.2" );
00189
00190 #endif /* SMFPOSTPROVIDERPLUGIN_H_ */
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfprovider.h Source File

  • File List

smf/smfservermodule/smfcommon/smfprovider.h

00001
00020 #ifndef SMFPROVIDER_H
00021 #define SMFPROVIDER_H
00022
00023 #include <QObject>
00024 #include <QImage>
00025 #include <QUrl>
00026 #include <QStringList>
00027 #include <QMetaType>
00028
00029 #include "smfclientglobal.h"
00030
00039 class SMFCOMMON_EXPORT SmfProvider
00040         {
00041
00042 public:
00046         SmfProvider();
00050         ~SmfProvider();
00051
00052 public:
00057         QString serviceName() const;
00058
00063         QImage serviceIcon() const;
00064
00069         QString description() const;
00070
00071         /*
00072          * Website of the service
00073          * @return service url
00074          */
00075         QUrl serviceUrl() const;
00076
00081         QUrl applicationUrl() const;
00082
00087         QList<QString> supportedInterfaces() const;
00088
00094         QStringList supportedLanguages() const;
00095
00100         void setServiceName(QString& name);
00101
00106         void setServiceIcon(QImage& image) ;
00107
00112         void setDescription(QString& desc) ;
00113
00114         /*
00115          * Sets Website of the service
00116          * @param name service url
00117          */
00118         void setServiceUrl(QUrl& url) ;
00119
00124         void setApplicationUrl(QUrl& url) ;
00125
00130         void setSupportedInterfaces( QStringList& types);
00131
00137         void setSupportedLanguages( QStringList& lang );
00138
00139 private:
00140         QString m_serviceName;
00141         QImage m_serviceIcon;
00142         QString m_description;
00143         QUrl m_serviceUrl;
00144         QUrl m_appUrl;
00145         QStringList m_serviceTypes;
00146         QStringList m_supportedLanguages;
00147
00148         friend QDataStream &operator<<(QDataStream &, const SmfProvider&);
00149         friend QDataStream &operator>>(QDataStream &, SmfProvider&);
00150         };
00151
00159 SMFCOMMON_EXPORT QDataStream& operator<<(QDataStream &aDataStream,
00160                 const SmfProvider &aProvider);
00161
00169 SMFCOMMON_EXPORT QDataStream& operator>>(QDataStream &aDataStream,
00170                 SmfProvider &aProvider);
00171
00172 typedef QList<SmfProvider> SmfProviderList;
00173
00174 // Make the class SmfProvider known to QMetaType, so that as to register it.
00175 Q_DECLARE_METATYPE(SmfProvider)
00176 Q_DECLARE_METATYPE(QList<SmfProvider>)
00177
00178 #endif // SMFPROVIDER_H
Generated on Thu Sep 23 15:03:14 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/smfplugins/smfproviderbase.h Source File

  • File List

smf/smfservermodule/smfserver/smfplugins/smfproviderbase.h

00001
00021 #ifndef SMFPROVIDERBASE_H_
00022 #define SMFPROVIDERBASE_H_
00023
00024 #include <QImage>
00025 #include <QUrl>
00026 #include <QBuffer>
00027 #include <smfglobal.h>
00028 #include <qdatastream.h>
00029 #include <QSharedData>
00030
00039 class SmfProviderBase
00040         {
00041 public:
00045         virtual ~SmfProviderBase( ) {}
00046
00051         virtual QString serviceName( ) const = 0;
00052
00057         virtual QImage serviceIcon( ) const = 0;
00058
00063         virtual QString description( ) const = 0;
00064
00069         virtual QUrl serviceUrl( ) const = 0;
00070
00075         virtual QUrl applicationUrl( ) const = 0;
00076
00081         virtual QImage applicationIcon( ) const = 0;
00082
00083
00088         virtual QList<QString> supportedInterfaces( ) const = 0;
00089
00095         virtual QStringList supportedLanguages( ) const = 0;
00096
00097
00102         virtual QString pluginId( ) const = 0;
00103
00112         virtual QString authenticationApp( QString &aProgram, QStringList & aArguments,
00113                         QIODevice::OpenModeFlag aMode = QIODevice::ReadWrite ) const = 0;
00114
00121         virtual QString smfRegistrationId( ) const = 0;
00122         };
00123
00124 Q_DECLARE_INTERFACE( SmfProviderBase, "org.symbian.smf.plugin.smfproviderbase/v0.2" );
00125
00126 #endif /* SMFPROVIDERBASE_H_ */
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfrelationmgr.h Source File

  • File List

smf/smfservermodule/smfclient/smfrelationmgr.h

00001
00020 #ifndef SMFRELATIONMGR_H
00021 #define SMFRELATIONMGR_H
00022
00023 #include <smfprovider.h>
00024 #include <smfcontact.h>
00025 #include <smfglobal.h>
00026
00027 // forward declaation
00028 class SmfRelationMgrPrivate;
00029
00030 // implementaion constants
00031 const int maxSmfRelationIdSize = 1000;
00032 const int maxSmfRelationItemSize = 1000;
00033 const int maxRelationItems = 1000;
00034
00035
00036 // persistent Id of a relation.
00037 typedef QString SmfRelationId;
00038
00043 class SMFCLIENT_EXPORT SmfRelationItem : public SmfContact
00044         {
00045 public:
00046         SmfRelationItem();
00047
00048 public:
00049         SmfProvider getProvider() const;
00050         void setProvider(SmfProvider& provider);
00051
00052         SmfContact getContact() const;
00053         void setContact(SmfContact& contact);
00054
00055         quint32 getIndex() const;
00056         void setIndex(quint32 index);
00057
00058 private:
00059         SmfProvider m_provider;
00060         SmfContact  m_contact;
00061         quint32          m_index;
00062         };
00063
00064 SMFCLIENT_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00065         const SmfRelationItem &aRelnItem );
00066
00067 SMFCLIENT_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00068                 SmfRelationItem &aRelnItem);
00069
00070
00113 class SMFCLIENT_EXPORT SmfRelationMgr : public QObject
00114         {
00115         Q_OBJECT
00116 public:
00117         SmfRelationMgr(QObject* parent = 0);
00118         ~SmfRelationMgr();
00119
00120 public slots:
00121
00135         SmfRelationId create(SmfProvider *provider=NULL, SmfContact *contact=NULL);
00136
00138         SmfError associate( SmfRelationId& phoneId,
00139                                                 const SmfContact* contact,
00140                                                 SmfProvider* provider);
00141
00143         SmfError remove(SmfRelationId& relation,
00144                                         const SmfContact* contact);
00145
00147         SmfRelationItem* searchById(const SmfRelationId& relation);
00148
00150         SmfRelationId searchByContact( SmfContact contact);
00151
00153         uint count(SmfRelationId relation);
00154
00156         SmfRelationItem* get(SmfRelationId& relation, quint32 index);
00157
00159         QList<SmfRelationItem> getAll(SmfRelationId& relation);
00160
00162         QList<SmfRelationId> getAllRelations();
00163
00165         SmfError Delete(SmfRelationId& relation);
00166
00167 private:
00168         SmfRelationMgrPrivate* m_private;       //private impl wrapper
00169         };
00170
00171 #endif // SMFRELATIONMGR_H
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfclient/smfrelationmgr_p.h Source File

  • File List

smf/smfservermodule/smfclient/smfrelationmgr_p.h

00001
00020 #ifndef SMFRELATIONMGR_P_H
00021 #define SMFRELATIONMGR_P_H
00022
00023 #include <QStringList>
00024 #include <smfprovider.h>
00025 #include <smfclientglobal.h>
00026 #include <smfglobal.h>
00027 #include <smfobserver.h>
00028
00029 class SmfRelationMgr;
00030 class SmfProvider;
00031 #ifdef Q_OS_SYMBIAN
00032         class CSmfClientSymbian;
00033 #else
00034         class SmfClientQt;
00035 #endif
00036
00037 class SmfRelationMgrPrivate
00038         {
00039 public:
00040         SmfRelationMgrPrivate(SmfRelationMgr* relnMngr);
00041         ~SmfRelationMgrPrivate();
00042
00043 public:
00045         SmfRelationId create(SmfProvider *provider=NULL, SmfContact *contact=NULL);
00046
00048         SmfError associate( SmfRelationId& relation,
00049                                                 const SmfContact* contact,
00050                                                 SmfProvider* provider);
00051
00053         SmfError remove(SmfRelationId& relation,
00054                                         const SmfContact* contact);
00055
00057         SmfRelationItem* searchById(const SmfRelationId& relation);
00058
00060         SmfRelationId searchByContact( SmfContact contact);
00061
00063         uint count(SmfRelationId relation);
00064
00066         SmfRelationItem* get(SmfRelationId& relation, quint32 index);
00067
00069         QList<SmfRelationItem> getAll(SmfRelationId& relation);
00070
00072         QList<SmfRelationId> getAllRelations();
00073
00075         SmfError Delete(SmfRelationId& relation);
00076
00077 private:
00078 #ifdef Q_OS_SYMBIAN
00079         CSmfClientSymbian* m_SmfClientPrivate;
00080         friend class CSmfClientSymbian;
00081 #else
00082         SmfClientQt* m_SmfClientPrivate;
00083         friend class SmfClientQt;
00084 #endif
00085         QByteArray m_dataForDSM;
00086         quint8 m_argFlag;
00087         QByteArray m_dataFromDSM;
00088         };
00089
00090 #endif // SMFRELATIONMGR_P_H
Generated on Thu Sep 23 15:03:12 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/server/smfserver.h Source File

  • File List

smf/smfservermodule/smfserver/server/smfserver.h

00001
00021 #ifndef SMFSERVER_H
00022 #define SMFSERVER_H
00023
00024 #include <QObject>
00025 #include <QMap>
00026 #include <smfglobal.h>
00027 #include <smfcredmgrclientglobal.h>
00028 #ifdef CLIENT_SERVER_TEST
00029         #include <QTimer>
00030         #include <QTextStream>
00031 #endif
00032
00033 #include "smfserverglobal.h"
00034
00035 // Forward declarations(Other components of the SMF)
00036 class SmfTransportManager;
00037 class SmfPluginManager;
00038 class SmfCredMgrClient;
00039 class SmfProvider;
00040 //Private implementation for different platforms
00041 #ifdef Q_OS_SYMBIAN
00042         class SmfServerSymbian;
00043         class SmfServerSymbianSession;
00044 #else
00045         class SmfServerQt;
00046         class SmfServerQtSession;
00047 #endif
00048
00049
00050 //For the time being, need to change later
00051 typedef QString SmfInterfaceID;
00052 //For the time being, need to change later
00053 typedef QString SmfPluginID;
00054 //TODO:- define proper enums after consulting with CM owner
00055 typedef int NotificationType;
00056
00057
00062 class SmfServer : public QObject
00063         {
00064         Q_OBJECT
00065
00066 public:
00067         SmfServer(QObject* parent = 0);
00068         ~SmfServer();
00069
00077         bool startServer();
00078
00079 public:
00085         void getPlugins ( const SmfInterfaceID& interfaceID,
00086                         QMap<SmfPluginID,SmfProvider>& pluginIDMap);
00087
00092         SmfPluginID getPlugin ( const SmfInterfaceID& interfaceID, SmfProvider provider);
00093
00098         void getAuthorizedPlugins ( QList<SmfPluginID>& list, QList<SmfPluginID>& authList );
00099
00104         QStringList getAuthenticatedPluginList ( QString RegistrationToken );
00105
00113         SmfError sendToPluginManager ( int requestID, SmfPluginID pluginID,
00114                         SmfInterfaceID interfaceID, SmfRequestTypeID requestTypeID,
00115                         QByteArray dataForPlugin = QByteArray() );
00116
00124         SmfError sendToPluginManager ( SmfPluginID pluginID,
00125                         SmfInterfaceID interfaceID, SmfRequestTypeID requestTypeID,
00126                         QByteArray dataForPlugin, QByteArray &outputData);
00127
00135         SmfError sendToDSM ( QByteArray qtdataForDSM, SmfRequestTypeID opcode,
00136                         QByteArray& qtdataFromDSM );
00137
00138 public slots:
00145         void clientAuthorizationFinished ( bool success, SmfClientAuthID authID );
00146
00153         void resultsAvailable ( int requestID, QByteArray* parsedData, SmfError error );
00154
00155 #ifdef CLIENT_SERVER_TEST
00156
00160 /*      void serviceClient ( QByteArray* parsedData );*/
00161
00166         void timerExpired ( ) {}
00167
00173         void runSavedRequest ( ) {}
00174 #endif
00175
00180         void dataStoreUpdateAvailable ( QByteArray* respData ){ Q_UNUSED(respData) }
00181
00186         void authenticationKeysExpired ( NotificationType type, SmfPluginID id );
00187
00188 private:
00189         SmfTransportInitializeResult prepareTransport();
00190
00191 private:
00192         //private impl
00193 #ifdef Q_OS_SYMBIAN
00194         SmfServerSymbian* m_SmfServerPrivate;
00195 #else
00196         SmfServerQt* m_SmfServerPrivate;
00197 #endif
00198         //Handles of other SMF components
00199         SmfTransportManager* m_transportManager;
00200         SmfPluginManager* m_pluginManager;
00201         SmfCredMgrClient* m_credentialMngr;
00202         };
00203
00204 #ifdef CLIENT_SERVER_TEST
00205 class dummyPM : public QObject
00206         {
00207                 Q_OBJECT
00208 public:
00209                 dummyPM(SmfServer* server,QObject* parent=0);
00210                 ~dummyPM();
00211                 SmfError createRequest ( const quint32& aSessionID,
00212                                 const QString& aPluginID,
00213                                 const SmfRequestTypeID& aOperation,
00214                                 QByteArray& aInputData );
00215 public slots:
00216         void responseAvailable();
00217 private:
00218                 QTimer* m_timer;
00219                 SmfServer* m_server;
00220         };
00221 #endif
00222
00223 #endif // SMFSERVER_H
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/smfserverglobal.h Source File

  • File List

smf/smfservermodule/smfserver/smfserverglobal.h

00001
00020 #ifndef SMFSERVERGLOBAL_H_
00021 #define SMFSERVERGLOBAL_H_
00022
00023 #include <QString>
00024
00028 enum SmfNetworkStatus
00029         {
00030         SmfNetworkConnectedHome = 0,
00031         SmfNetworkConnectedRoaming,     // value = 1
00032         SmfNetworkStateNotKnown,        // value = 2
00033         SmfNetworkConnected,            // value = 3
00034         SmfNetworkNotConnected          // value = 4
00035         };
00036
00040 enum SmfTransportInitializeResult
00041         {
00042         SmfTransportInitNetworkNotAvailable = 0,
00043         SmfTransportInitRoamingNetworkUsageNotEnabled,  // value = 1
00044         SmfTransportInitNoError                                                 // value = 2
00045         };
00046
00047
00051 struct SmfPluginDataUsage
00052         {
00056         QString iAppName;
00057
00061         QString iInterfaceName;
00062
00066         QString iServiceProviderName;
00067
00071         uint iBytesSent;
00072
00076         uint iBytesReceived;
00077
00078         };
00079
00080 #endif /* SMFSERVERGLOBAL_H_ */
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/server/smfserverqt_p.h Source File

  • File List

smf/smfservermodule/smfserver/server/smfserverqt_p.h

00001
00020 #ifndef SMFSERVERQT_P_H
00021 #define SMFSERVERQT_P_H
00022
00023 #include <QObject>
00024 #include <smfglobal.h>
00025
00026 class SmfServer;
00027 class QLocalServer;
00028 class QLocalSocket;
00029
00030 class SmfServerQt : public QObject
00031         {
00032     Q_OBJECT
00033
00034 public:
00035     SmfServerQt(SmfServer* wrapper);
00036     ~SmfServerQt();
00037
00038     inline SmfServer *wrapper() const;
00039
00040     bool start();
00041     int sessionListCount() const;
00042     void clientAuthorizationFinished(bool success);
00043     int findAndServiceclient(int requestID,QByteArray* parsedData,SmfError error);
00044
00045     ~SmfServerQt() {}
00046     bool start() {return false;}
00047     int sessionListCount() const {return 0;}
00048 private slots:
00049     void newClientConnected();
00050     void removeFromList();
00051
00052 private:
00053     SmfServer *m_generic;
00054     QLocalServer *m_server;
00055     QList<SmfServerQtSession*> m_sessions;
00056 };
00057
00058 inline SmfServer *SmfServerQt::wrapper() const
00059 {
00060     return m_generic;
00061 }
00062
00063 private:
00064     SmfServerQt *iServer;
00065     QLocalSocket *iClientConnection;
00066
00067         };
00068
00069 #endif // SMFSERVERQT_P_H
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/server/smfserverqtsession.h Source File

  • File List

smf/smfservermodule/smfserver/server/smfserverqtsession.h

00001
00019 #ifndef SMFSERVERQTSESSION_H
00020 #define SMFSERVERQTSESSION_H
00021
00022 #include <QObject>
00023 #include <QLocalSocket>
00024
00025 class SmfServerQt;
00026
00027 class SmfServerQtSession : public QObject
00028         {
00029     Q_OBJECT
00030
00031 public:
00032     SmfServerQtSession(QLocalSocket *clientConnection, SmfServerQt *server);
00033     ~SmfServerQtSession();
00034
00035     void clientAuthorizationFinished(bool success);
00036
00037 private:
00038     void handleRequest();
00039     void handleGetService();
00040
00041 public slots:
00042     void readDataFromClient();
00043     void socketError(QLocalSocket::LocalSocketError error);
00044
00045 private:
00046     int m_opCode;
00047     QLocalSocket *m_clientConnection;
00048     SmfServerQt *m_server;
00049         };
00050
00051 #endif // SMFSERVERQTSESSION_H
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/server/smfserversymbian_p.h Source File

  • File List

smf/smfservermodule/smfserver/server/smfserversymbian_p.h

00001
00020 #ifndef SMFSERVERSYMBIAN_H
00021 #define SMFSERVERSYMBIAN_H
00022
00023 #include <QObject>
00024 #include <e32hashtab.h>
00025 #include <e32base.h>
00026 #include <QByteArray>
00027 #include <QString>
00028
00029 #include "smfserver.h"
00030
00031 //Forward declarations
00032 class SmfServerSymbianSession;
00033 class SmfProvider;
00034
00035
00040 struct CSessionStruct
00041         {
00042         SmfServerSymbianSession* iSession;
00043         RMessage2 iMsg;
00044         };
00045
00046
00047 //Policy table---start
00048 //note capabilities are yet to be finalized
00049 //46 services as of 15th apr
00050 const TUint myRangeCount = 1/*7*/;
00051
00052 //Passing everything for the time being
00053 const TInt myRanges[myRangeCount] =
00054         {
00055         0/*, //ERequestPass
00056         1, //ERequestFail
00057         2, //ERequestNotSupported
00058         3, //ERequestDrmService
00059         4, //ERequestUserEnvironmentService
00060         5, //ERequestCustomCheckPass
00061         6  //ERequestCustomCheckFail*/
00062         };
00063
00064
00065 /* bis: each element of this array actually indexes to a particular element of
00066 TPolicyElement. For eg. element 0 of this array maps element 0 of myRanges to
00067 a particular element of TpolicyElement array which is in this case element 0
00068 of TPolicyElement
00069 */
00070 const TUint8 myElementsIndex[myRangeCount] =
00071         {
00072         CPolicyServer::EAlwaysPass, //passing everything for now
00073         };
00074
00075
00076 /* bis: Policies used by the server to check messages from the client
00077 for each message, the server will carry out security check according
00078 to this policy.
00079 */
00080 const CPolicyServer::TPolicyElement myElements[] =
00081         {
00082         {_INIT_SECURITY_POLICY_PASS, CPolicyServer::EFailClient}
00083         };
00084
00085 /* bis: TPolicy used by the server to check messages from the client
00086 for each message. This structure is passed to the server at its creation.
00087 The Symbian client-server architecture will make sure that each client request
00088 passes through the security test as indicated by myPolicy before it is handled
00089 by myPolciyServer */
00090 const CPolicyServer::TPolicy myPolicy =
00091         {
00092         //bis:
00093         //the connection policy (CPolicyServer::EAlwaysPass) should be changed if the
00094         //server wants to check for a particular policy before grating any connection
00095         //to the client. For eg. DRM manager server should only allow clients having DRM
00096         //capability to connect to it. To do so, change CPolicyserver::EAlwaysPass,
00097         //to the index no. of myElements which checks for ECapabilityDRM i.e index 2
00098         //in this case. For EACM server, the server should allow only clients having
00099         //ECapabilityUserEnvironment to connect to it.
00100         CPolicyServer::EAlwaysPass, //specifies all connect attempts should pass
00101         myRangeCount,
00102         myRanges,
00103         myElementsIndex,
00104         myElements,
00105         };
00106 //Policy table---end
00107
00108
00115 class SmfServerSymbian : public CPolicyServer
00116         {
00117 public:
00118         static SmfServerSymbian * NewL(CActive::TPriority aActiveObjectPriority,SmfServer* aWrapper);
00119     ~SmfServerSymbian();
00120     CSession2 * NewSessionL(const TVersion& aVersion, const RMessage2& aMessage) const;
00121
00125     SmfServer* wrapper();
00126
00134     TInt addToSessionMap(SmfServerSymbianSession* aSession,const RMessage2& aMsg);
00135
00141     TInt removeFromSessionMap(SmfServerSymbianSession* aSession,RMessage2& aMsg);
00142
00147     SmfServerSymbianSession* findSession(TInt id);
00148
00155     TInt findAndServiceclient(TInt requestID,QByteArray* parsedData,SmfError error);
00156
00157 private:
00163         SmfServerSymbian(CActive::TPriority aActiveObjectPriority,SmfServer* aWrapper);
00164
00165     void ConstructL();
00166
00167 private:
00168     friend class SmfServerSymbianSession;
00169
00170     SmfServer* iWrapper;
00171
00175     RHashMap<TInt,CSessionStruct> iMap;
00176
00177     TInt iSessionCount;
00178         };
00179
00180
00185 class SmfServerSymbianSession : public CSession2
00186         {
00187 public:
00192         SmfServerSymbianSession(SmfServerSymbian* aServer);
00193     ~SmfServerSymbianSession();
00194
00198     void ServiceL(const RMessage2 & aMessage);
00199
00205         void resultsAvailable(QByteArray* parsedData,SmfError error);
00206
00211         void clientAuthorizationFinished(bool success);
00212
00213 protected:
00214     //TMessageParams ReadMessageAndRetrieveParams (const RMessage2 & aMessage);
00215
00216     void PanicClient(const RMessage2 & aMessage, TInt aPanic) const;
00217
00223     void HandleClientMessageL(const RMessage2 & aMessage);
00224
00225 private:
00226     //Following are for handling specific client requests
00230     void HandleGetService(const RMessage2 & aMessage, const SmfInterfaceID& aInterfaceID);
00231
00235     void HandleSyncServiceL(const RMessage2 & aMessage);
00236
00240     void HandleCommonServiceL(const RMessage2 & aMessage);
00241
00245     void HandleDSMServiceL(const RMessage2 & aMessage);
00246
00250     void HandleCancelRequest(const RMessage2 & aMessage);
00251
00252
00253 private:
00254     SmfServerSymbian* iServer;
00255     RMessage2 iMessage;
00256     TBuf<100> iErrBuf;
00257         //this interface id will be provided by Smf client, will map Smf Client
00258         // interface hierarchy
00259         SmfInterfaceID iInterfaceID;
00260         TPtr iIntfNameSymbian;
00261         TPtr8 iIntfNameSymbian8;
00262
00263         TBuf8<125> iInterfaceNametbuf;
00264         TPtr8 iProviderSymbian8;
00265         TPtr8 iXtraDataPtr8;
00266         HBufC8* iData8ForDSM;
00267         TPtr8 iPtr8DataForDSM;
00268         HBufC8* iData8FromDSM;
00269         TPtr8 iPtr8DataFromDSM;
00270         TBuf<100> iDSMErr;
00271         HBufC8* iProviderBuf8;
00272         HBufC8* iXtraDataBuf8;
00273         HBufC8* iIntfNameBuf8;
00274         QMap<SmfPluginID,SmfProvider> iPluginIDMap;
00275         QList<SmfPluginID> iPluginIDList;
00276         QList<SmfPluginID> iAuthList;
00277
00282         RArray<RMessage2> iRequestList;
00286         TInt iLastRequest;
00287         TPtr8 iPtrToBuf;
00288         TPtr8 iPtrToDataForClient;
00289         HBufC8* iDataForClient;
00290         QByteArray resultData;
00291         QByteArray xtraData;
00292         };
00293
00294 #endif // SMFSERVERSYMBIAN_H
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/server/smfsettingshandler.h Source File

  • File List

smf/smfservermodule/smfserver/server/smfsettingshandler.h

00001
00018 #ifndef SMFSETTINGSHANDLER_H
00019 #define SMFSETTINGSHANDLER_H
00020
00021 #include <QObject>
00022 #include <QStringList>
00023 #include <QMap>
00024 #ifdef __FOR_SYMBIAN_CR_USAGE__
00025 class CSettingsRepository;
00026 #else
00027 class SmfSettingsRepositoryQt;
00028 #endif
00029
00030
00031
00032 class SmfSettingsHandler : public QObject
00033         {
00034         Q_OBJECT
00035 public:
00036         SmfSettingsHandler(QObject* parent=0);
00037         ~SmfSettingsHandler();
00038
00039 public slots:
00040         /*
00041          * Method to set the PluginDetails to Smf repository
00042          * Parm - @aPluginName,Name of the plugin
00043          * Param - @aPluginStatus,holds the Plgugin Status.
00044          */
00045         void SetPluginDetails(QString& aPluginName,QString& aPluginStatus);
00046         /*
00047          * Method to set the Auth Expiry Value to Repository
00048          * Param - @aVal,Auth Expiry Value
00049          */
00050         void SetAuthExpirationValue(QString& aVal);
00051         /*
00052          * Method to set the Max. Data Transfer Limit to Repository
00053          * Param - @aVal,Max. Data Transfer Limit Value
00054          */
00055         void SetMaxDataTransferLimit(QString& aVal);
00056         /*
00057          * Method to set the Roaming Status for Data Transfer to Repository
00058          * Param - @aStatus,Rpaming Status value for Data Transfer
00059          */
00060         void SetRoamingStatusforDataTransfer(QString& aStatus);
00061         /*
00062          * Method to set the Upload File Type to Repository
00063          * Param - @aStatus,Upload File Type Value
00064          */
00065         void SetUploadFileType(QString& aFileType);
00066         /*
00067          * Method to Get the PluginDetails from Repository
00068          */
00069         void GetPluginDetails(QMap<QString,QString>& aDetails ) const;
00070         /*
00071          * Method to Get the Auth Expiry Value from Repository
00072          */
00073         QString GetAuthExpirationValue() const;
00074         /*
00075          * Method to Get the Max. Data Transfer Limit from Repository
00076          */
00077         QString GetMaxDataTransferLimit() const;
00078         /*
00079          * Method to Get the Roaming Status for Data Transfer from Repository
00080          */
00081         QString GetRoamingStatusforDataTransfer() const;
00082         /*
00083          * Method to Get the Upload File Type from Repository
00084          */
00085         QString GetUploadFileType() const;
00086 private:
00087 #ifdef __FOR_SYMBIAN_CR_USAGE__
00088         CSettingsRepository* m_repository;
00089 #else
00090         SmfSettingsRepositoryQt* m_repository;
00091 #endif
00092         };
00093 #endif
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/server/smfsettingshandler_qt.h Source File

  • File List

smf/smfservermodule/smfserver/server/smfsettingshandler_qt.h

00001 /*
00002  * smfsettingshandler_qt.h
00003  *
00004  *  Created on: Jul 8, 2010
00005  *      Author: satishkk
00006  */
00007
00008 #ifndef SMFSETTINGSHANDLER_QT_H_
00009 #define SMFSETTINGSHANDLER_QT_H_
00010
00011 #include <qsettings.h>
00012 #include <qstringlist.h>
00013
00020 class SmfSettingsRepositoryQt : public QObject
00021     {
00022 public:
00023
00024
00030      ~SmfSettingsRepositoryQt();
00031
00038      SmfSettingsRepositoryQt(QObject *parent = 0);
00039         /*
00040          * Method to set the PluginDetails to QSettings
00041          * Parm - @aPluginName,Name of the plugin
00042          * Param - @aPluginStatus,holds the Plgugin Status.
00043          */
00044         void SetPluginDetails(QString& aPluginName,QString& aPluginStatus);
00045         /*
00046          * Method to set the Auth Expiry Value to QSettings
00047          * Param - @aVal,Auth Expiry Value
00048          */
00049         void SetAuthExpirationValue(QString& aVal);
00050         /*
00051          * Method to set the Max. Data Transfer Limit to QSettings
00052          * Param - @aVal,Max. Data Transfer Limit Value
00053          */
00054         void SetMaxDataTransferLimit(QString& aVal);
00055         /*
00056          * Method to set the Roaming Status for Data Transfer to QSettings
00057          * Param - @aStatus,Rpaming Status value for Data Transfer
00058          */
00059         void SetRoamingStatusforDataTransfer(QString& aStatus);
00060         /*
00061          * Method to set the Upload File Type to QSettings
00062          * Param - @aStatus,Upload File Type Value
00063          */
00064         void SetUploadFileType(QString& aFileType);
00065         /*
00066          * Method to Get the PluginDetails from QSettings
00067          */
00068         void GetPluginDetails(QMap<QString,QString>& aDetails) const;
00069         /*
00070          * Method to Get the Auth Expiry Value from QSettings
00071          */
00072         QString GetAuthExpirationValue() const;
00073         /*
00074          * Method to Get the Max. Data Transfer Limit from QSettings
00075          */
00076         QString GetMaxDataTransferLimit() const;
00077         /*
00078          * Method to Get the Roaming Status for Data Transfer from QSettings
00079          */
00080         QString GetRoamingStatusforDataTransfer() const;
00081         /*
00082          * Method to Get the Upload File Type from QSettings
00083          */
00084         QString GetUploadFileType() const;
00085
00086 private:
00090     QSettings*  iSettings;
00091
00092     };
00093
00094 #endif /* SMFSETTINGSHANDLER_QT_H_ */
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/server/smfsettingshandler_symbian.h Source File

  • File List

smf/smfservermodule/smfserver/server/smfsettingshandler_symbian.h

00001
00018 #ifndef SETTINGSREPOSITORY_H_
00019 #define SETTINGSREPOSITORY_H_
00020
00021 #ifdef __FOR_SYMBIAN_CR_USAGE__
00022
00023 const TInt KMaxSettingValue = 50;
00024
00025 #include <centralrepository.h>
00026 #include <QStringList>
00027 #include <QMap>
00028 #include <qsettings.h>
00029 //#include <BADESCA.H>
00036 class CSettingsRepository : public CBase
00037     {
00038 public:
00039
00046     static CSettingsRepository* NewL();
00047
00054     static CSettingsRepository* NewLC();
00055
00056
00062      ~CSettingsRepository();
00063
00064
00065 public:
00066
00067
00074             CSettingsRepository();
00075         /*
00076          * Method to set the PluginDetails to Smf repository
00077          * Parm - @aPluginName,Name of the plugin
00078          * Param - @aPluginStatus,holds the Plgugin Status.
00079          */
00080         void SetPluginDetails(QString& aPluginName,QString& aPluginStatus);
00081         /*
00082          * Method to set the Auth Expiry Value to Repository
00083          * Param - @aVal,Auth Expiry Value
00084          */
00085         void SetAuthExpirationValue(QString& aVal);
00086         /*
00087          * Method to set the Max. Data Transfer Limit to Repository
00088          * Param - @aVal,Max. Data Transfer Limit Value
00089          */
00090         void SetMaxDataTransferLimit(QString& aVal);
00091         /*
00092          * Method to set the Roaming Status for Data Transfer to Repository
00093          * Param - @aStatus,Rpaming Status value for Data Transfer
00094          */
00095         void SetRoamingStatusforDataTransfer(QString& aStatus);
00096         /*
00097          * Method to set the Upload File Type to Repository
00098          * Param - @aStatus,Upload File Type Value
00099          */
00100         void SetUploadFileType(QString& aFileType);
00101         /*
00102          * Method to Get the PluginDetails from Repository
00103          * Key-Plugin name
00104          * Value-Plugin status
00105          */
00106         void GetPluginDetails(QMap<QString,QString>& aDetails);
00107         /*
00108          * Method to Get the Auth Expiry Value from Repository
00109          */
00110         QString GetAuthExpirationValue() const;
00111         /*
00112          * Method to Get the Max. Data Transfer Limit from Repository
00113          */
00114         QString GetMaxDataTransferLimit()const;
00115         /*
00116          * Method to Get the Roaming Status for Data Transfer from Repository
00117          */
00118         QString GetRoamingStatusforDataTransfer() const;
00119         /*
00120          * Method to Get the Upload File Type from Repository
00121          */
00122         QString GetUploadFileType() const;
00123 private:
00124         /*
00125          * Method to set the PluginDetails to Symbian Repository
00126          * Parm - @aPluginName,Name of the plugin
00127          * Param - @aPluginStatus,holds the Plgugin Status.
00128          */
00129         void SetPluginDetails(TDesC& aPluginName,TDesC& aPluginStatus);
00130         /*
00131          * Method to set the Auth Expiry Value to Repository
00132          * Param - @aVal,Auth Expiry Value
00133          */
00134         void SetAuthExpirationValue(TDesC& aVal);
00135         /*
00136          * Method to set the Max. Data Transfer Limit to Repository
00137          * Param - @aVal,Max. Data Transfer Limit Value
00138          */
00139         void SetMaxDataTransferLimit(TDesC& aVal);
00140         /*
00141          * Method to set the Roaming Status for Data Transfer to Repository
00142          * Param - @aStatus,Rpaming Status value for Data Transfer
00143          */
00144         void SetRoamingStatusforDataTransfer(TDesC& aStatus);
00145         /*
00146          * Method to set the Upload File Type to Repository
00147          * Param - @aStatus,Upload File Type Value
00148          */
00149         void SetUploadFileType(TDesC& aFileType);
00150         /*
00151          * Method to Get the PluginDetails from Repository
00152          */
00153         void GetPluginDetailsInternal(TDes& aName , TDes& aDetails) const;
00154         /*
00155          * Method to Get the Auth Expiry Value from Repository
00156          */
00157         void GetAuthExpirationValueInternal(TDes& aExp) const;
00158         /*
00159          * Method to Get the Max. Data Transfer Limit from Repository
00160          */
00161         void GetMaxDataTransferLimitInternal(TDes& aMax) const;
00162         /*
00163          * Method to Get the Roaming Status for Data Transfer from Repository
00164          */
00165         void GetRoamingStatusforDataTransferInternal(TDes& aRoam) const;
00166         /*
00167          * Method to Get the Upload File Type from Repository
00168          */
00169         void GetUploadFileTypeInternal(TDes& aFtype) const;
00170
00171 private:
00172
00178     void ConstructL();
00179
00183    CRepository*  iRepository;
00184
00185     };
00186
00187 #endif
00188
00189 #endif /* SETTINGSREPOSITORY_H_ */
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfsubtitle.h Source File

  • File List

smf/smfservermodule/smfcommon/smfsubtitle.h

00001
00020 #ifndef SMFSUBTITLE_H_
00021 #define SMFSUBTITLE_H_
00022
00023 #include <qdatastream.h>
00024 #include <QDateTime>
00025 #include <QSharedData>
00026 #include "smfclientglobal.h"
00027 #include <QMetaType>
00028
00029 enum SmfSubtitleSearchFilter
00030         {
00031         SubtitleLanguage = 0,
00032         SubtitleFrameRate,              // value = 1
00033         SubtitleDuration,               // value = 2
00034         SubtitleReleaseYear,    // value = 3
00035         SubtitleAll = SubtitleLanguage | SubtitleFrameRate |
00036                         SubtitleDuration | SubtitleReleaseYear
00037         };
00038
00039 class SmfSubtitlePrivate;
00040
00045 class SMFCOMMON_EXPORT SmfSubtitle
00046         {
00047 public:
00051         SmfSubtitle( );
00052
00057         SmfSubtitle( const SmfSubtitle &aOther );
00058
00063         SmfSubtitle& operator=( const SmfSubtitle &aOther );
00064
00068         ~SmfSubtitle( );
00069
00074         QByteArray subtitle( ) const;
00075
00080         QUrl subtitleUrl() const;
00081
00086         QString language( ) const;
00087
00092         double frameRate( ) const;
00093
00098         double duration( ) const;
00099
00104         QDateTime releaseYear( ) const;
00105
00110         QString id( ) const;
00111
00116         void setSubtitle( const QByteArray &aSubtitle );
00117
00123         void setSubtitleUrl( const QUrl &aSubtitleUrl);
00124
00129         void setLanguage( const QString &aLang );
00130
00135         void setFrameRate( const double &aFramerate );
00136
00141         void setDuration( const double &aDuration );
00142
00147         void setReleaseYear( const QDateTime &aRelYear );
00148
00153         void setId( const QString &aId );
00154
00155 private:
00156         QSharedDataPointer<SmfSubtitlePrivate> d;
00157
00158         friend QDataStream &operator<<( QDataStream &aDataStream,
00159                         const SmfSubtitle &aSubtitle );
00160
00161         friend QDataStream &operator>>( QDataStream &aDataStream,
00162                         SmfSubtitle &aSubtitle );
00163
00164         };
00165
00166
00174 SMFCOMMON_EXPORT  QDataStream &operator<<( QDataStream &aDataStream,
00175                 const SmfSubtitle &aSubtitle );
00176
00184 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00185                 SmfSubtitle &aSubtitle);
00186
00187
00188 typedef QList<SmfSubtitle> SmfSubtitleList;
00189
00190 // Make the class SmfSubtitle known to QMetaType, so that as to register it.
00191 Q_DECLARE_METATYPE(SmfSubtitle)
00192 Q_DECLARE_METATYPE(QList<SmfSubtitle>)
00193
00194 #endif /* SMFSUBTITLE_H_ */
Generated on Thu Sep 23 15:03:14 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfsubtitle_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfsubtitle_p.h

00001
00020 #ifndef SMFSUBTITLE_P_H_
00021 #define SMFSUBTITLE_P_H_
00022
00023 #include <QDateTime>
00024 #include <QSharedData>
00025 #include <QUrl>
00026
00027 class SmfSubtitlePrivate : public QSharedData
00028 {
00029 public:
00033         SmfSubtitlePrivate( ) {
00034                 m_language.clear();
00035                 m_frameRate = 0;
00036                 m_duration = 0;
00037                 m_subtitleId.clear();
00038                 m_subtitleUrl.clear();
00039         }
00040
00045         SmfSubtitlePrivate( const SmfSubtitlePrivate &aOther ) :
00046                 QSharedData ( aOther ),
00047                 m_subtitle ( aOther.m_subtitle ),
00048                 m_language ( aOther.m_language ),
00049                 m_frameRate ( aOther.m_frameRate ),
00050                 m_duration ( aOther.m_duration ),
00051                 m_releaseYr ( aOther.m_releaseYr ),
00052                 m_subtitleId ( aOther.m_subtitleId ),
00053                 m_subtitleUrl (aOther.m_subtitleUrl){ }
00054
00058         ~SmfSubtitlePrivate( )
00059                 {
00060                 }
00061
00062         QByteArray m_subtitle;  // subtitle data
00063         QString m_language;             // language
00064         double m_frameRate;             // frame rate
00065         double m_duration;              // duration
00066         QDateTime m_releaseYr;  // release year
00067         QString m_subtitleId;   // subtitle id
00068         QUrl m_subtitleUrl;     // subtitle Url
00069
00070 };
00071
00072 #endif /* SMFSUBTITLE_P_H_ */
Generated on Thu Sep 23 15:03:14 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smftrackinfo.h Source File

  • File List

smf/smfservermodule/smfcommon/smftrackinfo.h

00001
00020 #ifndef SMFTRACKINFO_H_
00021 #define SMFTRACKINFO_H_
00022
00023 #include <QTime>
00024 #include <qdatastream.h>
00025 #include <smfmusicrating.h>
00026 #include <smfartists.h>
00027 #include "smfalbum.h"
00028 #include <smfcomment.h>
00029 #include <QStringList>
00030 #include <QSharedData>
00031 #include <smfclientglobal.h>
00032 #include <QMetaType>
00033
00034 class SmfTrackInfoPrivate;
00035
00036 /*
00037  * Implementation constants
00038  */
00039 const int SmfMusicTracksMaxSize = 2000;
00040
00045 class SMFCOMMON_EXPORT SmfTrackInfo
00046         {
00047 public:
00051         SmfTrackInfo( );
00052
00057         SmfTrackInfo( const SmfTrackInfo &aOther );
00058
00063         SmfTrackInfo& operator=( const SmfTrackInfo &aOther );
00064
00068         ~SmfTrackInfo( );
00069
00074         QString title( ) const;
00075
00080         SmfAlbum album( ) const;
00081
00086         SmfArtists artists( ) const;
00087
00092         QString genre( ) const;
00093
00098         QStringList tags( ) const;
00099
00104         QDateTime year( ) const;
00105
00110         SmfMusicRating rating( ) const;
00111
00116         QList<SmfComment> comments( ) const;
00117
00122         QTime duration( ) const;
00123
00128         QString id( ) const;
00129
00134         void setTitle( const QString &aTitle );
00135
00140         void setAlbum( const SmfAlbum &aAlbum );
00141
00146         void setArtists( const SmfArtists &aArtists );
00147
00152         void setGenre( const QString &aGenre );
00153
00158         void setTags( const QStringList &aTags );
00159
00164         void setYear( const QDateTime &aYear );
00165
00170         void setRating( const SmfMusicRating &aRating );
00171
00176         void setComment( const QList<SmfComment> &aComments );
00177
00182         void setDuration( const QTime &aDuration );
00183
00188         void setId( const QString &aId );
00189
00190 private:
00191         QSharedDataPointer<SmfTrackInfoPrivate> d;
00192
00193         friend QDataStream &operator<<( QDataStream &aDataStream,
00194                         const SmfTrackInfo &aTrackInfo );
00195
00196         friend QDataStream &operator>>( QDataStream &aDataStream,
00197                         SmfTrackInfo &aTrackInfo );
00198
00199         };
00200
00201
00209 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00210                 const SmfTrackInfo &aTrackInfo );
00211
00219 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00220                 SmfTrackInfo &aTrackInfo);
00221
00222
00223 typedef QList<SmfTrackInfo> SmfTrackInfoList;
00224
00225 // Make the class SmfTrackInfo known to QMetaType, so that as to register it.
00226 Q_DECLARE_METATYPE(SmfTrackInfo)
00227 Q_DECLARE_METATYPE(QList<SmfTrackInfo>)
00228
00229 #endif /* SMFTRACKINFO_H_ */
Generated on Thu Sep 23 15:03:14 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smftrackinfo_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smftrackinfo_p.h

00001
00020 #ifndef SMFTRACKINFO_P_H_
00021 #define SMFTRACKINFO_P_H_
00022
00023 #include <QTime>
00024 #include <smfmusicrating.h>
00025 #include <smfcomment.h>
00026 #include <QStringList>
00027 #include <QSharedData>
00028
00029 class SmfTrackInfoPrivate : public QSharedData
00030 {
00031 public:
00035         SmfTrackInfoPrivate( ) : m_rating( )
00036                 {
00037                 m_trackId.clear();
00038                 m_title.clear();
00039                 m_genre.clear();
00040                 m_tags.clear();
00041                 m_comments.clear();
00042         }
00043
00048         SmfTrackInfoPrivate( const SmfTrackInfoPrivate &aOther ) :
00049                 QSharedData ( aOther ),
00050                 m_trackId ( aOther.m_trackId ),
00051                 m_title ( aOther.m_title ),
00052                 m_album ( aOther.m_album ),
00053                 m_artists ( aOther.m_artists ),
00054                 m_genre ( aOther.m_genre ),
00055                 m_tags ( aOther.m_tags ),
00056                 m_year ( aOther.m_year ),
00057                 m_rating ( aOther.m_rating ),
00058                 m_comments ( aOther.m_comments ),
00059                 m_duration ( aOther.m_duration )        { }
00060
00064         ~SmfTrackInfoPrivate( )
00065                 {
00066                 }
00067
00068         QString m_trackId;              // track id
00069         QString m_title;                // title
00070         SmfAlbum m_album;               // album
00071         SmfArtists m_artists;   // artist name
00072         QString m_genre;                // genre information
00073         QStringList m_tags;             // tag information
00074         QDateTime m_year;               // release year
00075         SmfMusicRating m_rating;// rating
00076         QList<SmfComment> m_comments;   // comments
00077         QTime m_duration;               // duration
00078
00079 };
00080
00081 #endif /* SMFTRACKINFO_P_H_ */
Generated on Thu Sep 23 15:03:14 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/transportmgr/smftransportmanager.h Source File

  • File List

smf/smfservermodule/smfserver/transportmgr/smftransportmanager.h

00001
00022 #ifndef SMFTRANSPORTMANAGER_H_
00023 #define SMFTRANSPORTMANAGER_H_
00024
00025 // Include files
00026 #include "smfserverglobal.h"
00027
00028 // Qt mobility classes
00029 #include <qnetworkconfigmanager.h>
00030 #include <qsysteminfo.h>
00031
00032 using namespace QtMobility;
00033
00040 class SmfTransportManager : public QObject
00041         {
00042         Q_OBJECT
00043
00044 public:
00049         static SmfTransportManager* getInstance ( );
00050
00054         ~SmfTransportManager ( );
00055
00056 public slots:
00062         SmfTransportInitializeResult initializeTransport ( );
00063
00064         /*
00065          * This slot is called whenever a new network configuration is added to the system.
00066          * @param aConfig The new configuration
00067          */
00068         void configurationAdded ( const QNetworkConfiguration &aConfig );
00069
00070         /*
00071          * This slot is called when the state of the aConfig changes.
00072          * @param aConfig The changed configuration
00073          */
00074         void configurationChanged ( const QNetworkConfiguration &aConfig );
00075
00076         /*
00077          * This slot is called when a configuration is about to be removed from the system.
00078          * The removed configuration is invalid but retains name and identifier.
00079          * @param aConfig The to be removed configuration
00080          */
00081         void configurationRemoved ( const QNetworkConfiguration &aConfig );
00082
00083 private:
00084         /* Method to get network availability.
00085          * @return True if online, else false.
00086          */
00087         bool getNetworkAvailabilty ( );
00088
00089         /*
00090          * Method that checks if the phone is in home network or in roaming.
00091          * @param aStatus [out] An output parameter indicating the current network
00092          * status as SmfNetworkStatus
00093          */
00094         void getCurrentNetworkStatus ( SmfNetworkStatus &aStatus );
00095
00096 private:
00100         SmfTransportManager ( );
00101
00106         SmfTransportManager ( const SmfTransportManager &aOther );
00107
00108 private:
00112         static SmfTransportManager* m_myInstance;
00113
00114         /*
00115          * Member variable - QNetworkConfigurationManager instance
00116          */
00117         QNetworkConfigurationManager *m_netwConfigMngr;
00118
00119         /*
00120          * Member variable - QSystemNetworkInfo instance
00121          */
00122         QSystemNetworkInfo *m_systemInfo;
00123
00124         };
00125
00126 #endif /* SMFTRANSPORTMANAGER_H_ */
Generated on Thu Sep 23 15:03:15 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfserver/transportmgr/smftransportmanagerutil.h Source File

  • File List

smf/smfservermodule/smfserver/transportmgr/smftransportmanagerutil.h

00001
00021 #ifndef SMFTRANSPORTMANAGERUTIL_H_
00022 #define SMFTRANSPORTMANAGERUTIL_H_
00023
00024 #include <QNetworkReply>
00025 #include <smfglobal.h>
00026 #include <smfserverglobal.h>
00027
00028 // Forward declaration
00029 class QNetworkAccessManager;
00030 class QSettings;
00031
00037 class SmfTransportManagerUtil : public QObject
00038         {
00039         Q_OBJECT
00040
00041 public:
00046         static SmfTransportManagerUtil* getInstance ( );
00047
00051         ~SmfTransportManagerUtil ( );
00052
00053
00054 public:
00066     QNetworkReply* get ( QNetworkRequest &aRequest,
00067                 const QList<QUrl> &aUrlList,
00068                 bool &aSOPCompliant );
00069
00082     QNetworkReply* post ( QNetworkRequest &aRequest,
00083                 const QByteArray& aPostData,
00084                 const QList<QUrl> &aUrlList,
00085                 bool &aSOPCompliant );
00086
00098     QNetworkReply* head ( QNetworkRequest &aRequest,
00099                 const QList<QUrl> &aUrlList,
00100                 bool &aSOPCompliant );
00101
00114     QNetworkReply* put ( QNetworkRequest &aRequest,
00115                 const QByteArray& aPostData,
00116                 const QList<QUrl> &aUrlList,
00117                 bool &aSOPCompliant );
00118
00130     QNetworkReply* deleteResource ( QNetworkRequest &aRequest,
00131                 const QList<QUrl> &aUrlList,
00132                 bool &aSOPCompliant );
00133
00141         bool cancelRequest ( QNetworkReply *aCancelReply );
00142
00143 public slots:
00144         /*
00145          * Method that is called whenever a new network configuration is added to the system.
00146          * @param aResult SmfTransportResult
00147          */
00148         void configurationAdded ( const SmfTransportResult &aResult );
00149
00150         /*
00151          * Method that is called when the state of the network configuration changes.
00152          * @param aResult SmfTransportResult
00153          */
00154         void configurationChanged ( const SmfTransportResult &aResult );
00155
00156         /*
00157          * Method that is called when a configuration is about to be removed from the system.
00158          * The removed configuration is invalid but retains name and identifier.
00159          * @param aResult SmfTransportResult
00160          */
00161         void configurationRemoved ( const SmfTransportResult &aResult );
00162
00163 private slots:
00169         void networkReplyFinished ( QNetworkReply *aNetworkReply );
00170
00175         void networkReplyError ( QNetworkReply::NetworkError aError );
00176
00177 private:
00184         void convertErrorType( const QNetworkReply::NetworkError &aError,
00185                         SmfTransportResult &aResult );
00186
00194         QByteArray* inflateResponse ( QByteArray &aResponse, SmfError& aError );
00195
00203         QByteArray* deflateRequest( QByteArray &aResponse, SmfError& aError );
00204
00205 private:
00209         SmfTransportManagerUtil ( );
00210
00215         SmfTransportManagerUtil ( const SmfTransportManagerUtil &aOther );
00216
00217 private:
00221         static SmfTransportManagerUtil* m_myInstance;
00222
00226         QNetworkAccessManager m_networkAccessManager;
00227
00231         QList<QNetworkReply *> m_activeNetwReplyList;
00232
00237         QSettings *m_settings;
00238         };
00239
00240
00241 #endif /* SMFTRANSPORTMANAGERUTIL_H_ */
Generated on Thu Sep 23 15:03:16 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfurl.h Source File

  • File List

smf/smfservermodule/smfcommon/smfurl.h

00001
00024 #ifndef SMFURL_H_
00025 #define SMFURL_H_
00026
00027 #include <qdatastream.h>
00028 #include <QSharedData>
00029 #include <smfclientglobal.h>
00030 #include <QMetaType>
00031
00032 class SmfUrlPrivate;
00033
00042 class SMFCOMMON_EXPORT SmfUrl
00043         {
00044 public:
00048         SmfUrl( );
00049
00054         SmfUrl( const SmfUrl &aOther );
00055
00060         SmfUrl& operator=( const SmfUrl &aOther );
00061
00065         ~SmfUrl( );
00066
00071         QUrl href( ) const;
00072
00077         QString rel( ) const;
00078
00083         QString type( ) const;
00084
00089         QString hreflang( ) const;
00090
00095         QString title( ) const;
00096
00101         QString length( ) const;
00102
00107         QString id( ) const;
00108
00113         void setHref( const QUrl& aData );
00114
00119         void setRel( const QString &aData );
00120
00125         void setType( const QString &aData );
00126
00131         void setHhreflang( const QString &aData );
00132
00137         void setTitle( const QString &aData );
00138
00143         void setLength( const QString &aData );
00144
00149         void setId( const QString &aId );
00150
00151 private:
00152         QSharedDataPointer<SmfUrlPrivate> d;
00153
00154         friend QDataStream &operator<<( QDataStream &aDataStream,
00155                         const SmfUrl &aUrl );
00156
00157         friend QDataStream &operator>>( QDataStream &aDataStream,
00158                         SmfUrl &aUrl );
00159
00160         };
00161
00162
00170 SMFCOMMON_EXPORT QDataStream &operator<<( QDataStream &aDataStream,
00171                 const SmfUrl &aUrl );
00172
00180 SMFCOMMON_EXPORT QDataStream &operator>>( QDataStream &aDataStream,
00181                 SmfUrl &aUrl);
00182
00183 typedef QList<SmfUrl> SmfUrlList;
00184
00185 // Make the class SmfUrl known to QMetaType, so that as to register it.
00186 Q_DECLARE_METATYPE(SmfUrl)
00187 Q_DECLARE_METATYPE(QList<SmfUrl>)
00188
00189 #endif /* SMFURL_H_ */
00190
Generated on Thu Sep 23 15:03:14 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/smfcommon/smfurl_p.h Source File

  • File List

smf/smfservermodule/smfcommon/smfurl_p.h

00001
00020 #ifndef SMFURL_P_H_
00021 #define SMFURL_P_H_
00022
00023 #include <QSharedData>
00024 #include <QUrl>
00025
00026 class SmfUrlPrivate : public QSharedData
00027         {
00028 public:
00032         SmfUrlPrivate( ) {
00033                 m_id.clear();
00034         }
00035
00040         SmfUrlPrivate( const SmfUrlPrivate &aOther ) :
00041                 QSharedData ( aOther ),
00042                 m_id ( aOther.m_id ) { }
00043
00047         ~SmfUrlPrivate( )
00048                 {
00049                 }
00050
00054         QUrl    m_href;         // The href attribute of an Atom link element, contains the link's IRI
00055         QString m_rel;          // The rel attribute that indicates the link relation type
00056         QString m_type;         // The type attribute. It is a hint about the type of the
00057                                                 // representation that is expected to be returned when the
00058                                                 // value of the href attribute is dereferenced
00059         QString m_hreflang;     // The hreflang attribute describes the language of the resource
00060                                                 // pointed to by the href attribute
00061         QString m_title;        // The title attribute conveys human-readable information about the link
00062         QString m_length;       // The length attribute indicates an advisory length
00063                                                 // of the linked content in octets
00064         QString m_id;           // The url ID
00065
00066         };
00067
00068 #endif /* SMFURL_P_H_ */
Generated on Thu Sep 23 15:03:14 2010 for smf by doxygen 1.6.3


smf: smf/smfcredentialmgr/smfcredmgrcommon/inc/smfutils.h Source File

  • File List

smf/smfcredentialmgr/smfcredmgrcommon/inc/smfutils.h

00001
00016 #ifndef SMFUTILS_H_
00017 #define SMFUTILS_H_
00018
00019 #include <e32base.h>
00020
00021 class RWriteStream;
00022 class RReadStream;
00023
00027 namespace SmfUtils
00028         {
00034         void ExternalizeDesL(const TDesC8& aDes, RWriteStream& aStream);
00035
00041         TInt InternalizeDesL(RBuf8& aDes, RReadStream& aStream);
00042
00048         void ExternalizeDesL(const TDesC16& aDes, RWriteStream& aStream);
00049
00054         HBufC16* InternalizeDesL(RReadStream& aStream);
00055
00056         TInt InternalizeDesL( RBuf16& aDes, RReadStream& aStream );
00062         void ExternalizeInt64L(const TInt64& aInt, RWriteStream& aStream);
00063
00069         void InternalizeInt64L(TInt64& aInt, RReadStream& aStream);
00070         }
00071
00072 #endif /* SMFUTILS_H_ */
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: smf/smfservermodule/util/qjson/src/stack.hh Source File

  • File List

smf/smfservermodule/util/qjson/src/stack.hh

00001 /* A Bison parser, made by GNU Bison 2.3.  */
00002
00003 /* Stack handling for Bison parsers in C++
00004
00005    Copyright (C) 2002, 2003, 2004, 2005, 2006 Free Software Foundation, Inc.
00006
00007    This program is free software; you can redistribute it and/or modify
00008    it under the terms of the GNU General Public License as published by
00009    the Free Software Foundation; either version 2, or (at your option)
00010    any later version.
00011
00012    This program is distributed in the hope that it will be useful,
00013    but WITHOUT ANY WARRANTY; without even the implied warranty of
00014    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
00015    GNU General Public License for more details.
00016
00017    You should have received a copy of the GNU General Public License
00018    along with this program; if not, write to the Free Software
00019    Foundation, Inc., 51 Franklin Street, Fifth Floor,
00020    Boston, MA 02110-1301, USA.  */
00021
00022 /* As a special exception, you may create a larger work that contains
00023    part or all of the Bison parser skeleton and distribute that work
00024    under terms of your choice, so long as that work isn't itself a
00025    parser generator using the skeleton or a modified version thereof
00026    as a parser skeleton.  Alternatively, if you modify or redistribute
00027    the parser skeleton itself, you may (at your option) remove this
00028    special exception, which will cause the skeleton and the resulting
00029    Bison output files to be licensed under the GNU General Public
00030    License without this special exception.
00031
00032    This special exception was added by the Free Software Foundation in
00033    version 2.2 of Bison.  */
00034
00035 #ifndef BISON_STACK_HH
00036 # define BISON_STACK_HH
00037
00038 #include <deque>
00039
00040 namespace yy
00041 {
00042   template <class T, class S = std::deque<T> >
00043   class stack
00044   {
00045   public:
00046
00047     // Hide our reversed order.
00048     typedef typename S::reverse_iterator iterator;
00049     typedef typename S::const_reverse_iterator const_iterator;
00050
00051     stack () : seq_ ()
00052     {
00053     }
00054
00055     stack (unsigned int n) : seq_ (n)
00056     {
00057     }
00058
00059     inline
00060     T&
00061     operator [] (unsigned int i)
00062     {
00063       return seq_[i];
00064     }
00065
00066     inline
00067     const T&
00068     operator [] (unsigned int i) const
00069     {
00070       return seq_[i];
00071     }
00072
00073     inline
00074     void
00075     push (const T& t)
00076     {
00077       seq_.push_front (t);
00078     }
00079
00080     inline
00081     void
00082     pop (unsigned int n = 1)
00083     {
00084       for (; n; --n)
00085         seq_.pop_front ();
00086     }
00087
00088     inline
00089     unsigned int
00090     height () const
00091     {
00092       return seq_.size ();
00093     }
00094
00095     inline const_iterator begin () const { return seq_.rbegin (); }
00096     inline const_iterator end () const { return seq_.rend (); }
00097
00098   private:
00099
00100     S seq_;
00101   };
00102
00104   template <class T, class S = stack<T> >
00105   class slice
00106   {
00107   public:
00108
00109     slice (const S& stack,
00110            unsigned int range) : stack_ (stack),
00111                                  range_ (range)
00112     {
00113     }
00114
00115     inline
00116     const T&
00117     operator [] (unsigned int i) const
00118     {
00119       return stack_[range_ - i];
00120     }
00121
00122   private:
00123
00124     const S& stack_;
00125     unsigned int range_;
00126   };
00127 }
00128
00129 #endif // not BISON_STACK_HH
Generated on Thu Sep 23 15:03:16 2010 for smf by doxygen 1.6.3


smf: example/smfclientapp/testscreen.h Source File

  • File List

example/smfclientapp/testscreen.h

00001 #ifndef TESTSCREEN_H
00002 #define TESTSCREEN_H
00003
00004 #include <QtGui/QWidget>
00005 #include "ui_SmfClientApp.h"
00006 #include <smfcontactfetcher.h>
00007 #include <smfpostprovider.h>
00008 #include <QSplashScreen>
00009 class TestScreen : public QWidget
00010 {
00011     Q_OBJECT
00012
00013 public:
00014     TestScreen(QWidget *parent = 0);
00015     ~TestScreen();
00016          //debugging
00017          void writeLog(QString log) const;
00018 public slots:
00019         void friendsButtonClicked();
00020         void postsButtonClicked();
00021          void showGroups(SmfGroupList* grps, SmfError , SmfResultPage);
00022          void showFriends(SmfContactList* frnds, SmfError , SmfResultPage);
00023          void showPosts(SmfPostList* postlist, SmfError error, SmfResultPage resultPage);
00024 private:
00025          Ui::SmfClientApp ui;
00026     SmfProvider* m_provider;
00027     SmfContactFetcher* m_contactFetcher;
00028     SmfPostProvider* m_postProvider;
00029     QList<SmfProvider>* providerList;
00030     QPixmap pixmap;
00031     QSplashScreen splash;
00032 };
00033
00034 #endif // TESTSCREEN_H
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: example/smfclientapp/ui_displaywidget.h Source File

  • File List

example/smfclientapp/ui_displaywidget.h

00001 /********************************************************************************
00002 ** Form generated from reading UI file 'displaywidget.ui'
00003 **
00004 ** Created: Wed Sep 22 18:28:30 2010
00005 **      by: Qt User Interface Compiler version 4.6.2
00006 **
00007 ** WARNING! All changes made in this file will be lost when recompiling UI file!
00008 ********************************************************************************/
00009
00010 #ifndef UI_DISPLAYWIDGET_H
00011 #define UI_DISPLAYWIDGET_H
00012
00013 #include <QtCore/QVariant>
00014 #include <QtGui/QAction>
00015 #include <QtGui/QApplication>
00016 #include <QtGui/QButtonGroup>
00017 #include <QtGui/QComboBox>
00018 #include <QtGui/QHeaderView>
00019 #include <QtGui/QLabel>
00020 #include <QtGui/QListWidget>
00021 #include <QtGui/QPushButton>
00022 #include <QtGui/QScrollBar>
00023 #include <QtGui/QVBoxLayout>
00024 #include <QtGui/QWidget>
00025
00026 QT_BEGIN_NAMESPACE
00027
00028 class Ui_DisplayWidgetClass
00029 {
00030 public:
00031     QWidget *verticalLayoutWidget;
00032     QVBoxLayout *verticalLayout;
00033     QLabel *label;
00034     QComboBox *comboBox_intf;
00035     QPushButton *pushButton_intf;
00036     QLabel *label_2;
00037     QComboBox *comboBox__SP;
00038     QPushButton *pushButton_SP;
00039     QLabel *label_3;
00040     QComboBox *comboBox_service;
00041     QPushButton *pushButton_service;
00042     QListWidget *listWidget;
00043     QScrollBar *verticalScrollBar_list;
00044
00045     void setupUi(QWidget *DisplayWidgetClass)
00046     {
00047         if (DisplayWidgetClass->objectName().isEmpty())
00048             DisplayWidgetClass->setObjectName(QString::fromUtf8("DisplayWidgetClass"));
00049         DisplayWidgetClass->resize(400, 489);
00050         verticalLayoutWidget = new QWidget(DisplayWidgetClass);
00051         verticalLayoutWidget->setObjectName(QString::fromUtf8("verticalLayoutWidget"));
00052         verticalLayoutWidget->setGeometry(QRect(10, 10, 371, 461));
00053         verticalLayout = new QVBoxLayout(verticalLayoutWidget);
00054         verticalLayout->setSpacing(6);
00055         verticalLayout->setContentsMargins(11, 11, 11, 11);
00056         verticalLayout->setObjectName(QString::fromUtf8("verticalLayout"));
00057         verticalLayout->setContentsMargins(0, 0, 0, 0);
00058         label = new QLabel(verticalLayoutWidget);
00059         label->setObjectName(QString::fromUtf8("label"));
00060
00061         verticalLayout->addWidget(label);
00062
00063         comboBox_intf = new QComboBox(verticalLayoutWidget);
00064         comboBox_intf->setObjectName(QString::fromUtf8("comboBox_intf"));
00065
00066         verticalLayout->addWidget(comboBox_intf);
00067
00068         pushButton_intf = new QPushButton(verticalLayoutWidget);
00069         pushButton_intf->setObjectName(QString::fromUtf8("pushButton_intf"));
00070
00071         verticalLayout->addWidget(pushButton_intf);
00072
00073         label_2 = new QLabel(verticalLayoutWidget);
00074         label_2->setObjectName(QString::fromUtf8("label_2"));
00075
00076         verticalLayout->addWidget(label_2);
00077
00078         comboBox__SP = new QComboBox(verticalLayoutWidget);
00079         comboBox__SP->setObjectName(QString::fromUtf8("comboBox__SP"));
00080
00081         verticalLayout->addWidget(comboBox__SP);
00082
00083         pushButton_SP = new QPushButton(verticalLayoutWidget);
00084         pushButton_SP->setObjectName(QString::fromUtf8("pushButton_SP"));
00085
00086         verticalLayout->addWidget(pushButton_SP);
00087
00088         label_3 = new QLabel(verticalLayoutWidget);
00089         label_3->setObjectName(QString::fromUtf8("label_3"));
00090
00091         verticalLayout->addWidget(label_3);
00092
00093         comboBox_service = new QComboBox(verticalLayoutWidget);
00094         comboBox_service->setObjectName(QString::fromUtf8("comboBox_service"));
00095
00096         verticalLayout->addWidget(comboBox_service);
00097
00098         pushButton_service = new QPushButton(verticalLayoutWidget);
00099         pushButton_service->setObjectName(QString::fromUtf8("pushButton_service"));
00100
00101         verticalLayout->addWidget(pushButton_service);
00102
00103         listWidget = new QListWidget(verticalLayoutWidget);
00104         listWidget->setObjectName(QString::fromUtf8("listWidget"));
00105
00106         verticalLayout->addWidget(listWidget);
00107
00108         verticalScrollBar_list = new QScrollBar(DisplayWidgetClass);
00109         verticalScrollBar_list->setObjectName(QString::fromUtf8("verticalScrollBar_list"));
00110         verticalScrollBar_list->setGeometry(QRect(380, 242, 20, 221));
00111         verticalScrollBar_list->setOrientation(Qt::Vertical);
00112
00113         retranslateUi(DisplayWidgetClass);
00114
00115         QMetaObject::connectSlotsByName(DisplayWidgetClass);
00116     } // setupUi
00117
00118     void retranslateUi(QWidget *DisplayWidgetClass)
00119     {
00120         DisplayWidgetClass->setWindowTitle(QApplication::translate("DisplayWidgetClass", "DisplayWidget", 0, QApplication::UnicodeUTF8));
00121         label->setText(QApplication::translate("DisplayWidgetClass", "Select Interface", 0, QApplication::UnicodeUTF8));
00122         pushButton_intf->setText(QApplication::translate("DisplayWidgetClass", "Ok", 0, QApplication::UnicodeUTF8));
00123         label_2->setText(QApplication::translate("DisplayWidgetClass", "Select Service Provider", 0, QApplication::UnicodeUTF8));
00124         pushButton_SP->setText(QApplication::translate("DisplayWidgetClass", "Ok", 0, QApplication::UnicodeUTF8));
00125         label_3->setText(QApplication::translate("DisplayWidgetClass", "Select Service", 0, QApplication::UnicodeUTF8));
00126         pushButton_service->setText(QApplication::translate("DisplayWidgetClass", "Ok", 0, QApplication::UnicodeUTF8));
00127     } // retranslateUi
00128
00129 };
00130
00131 namespace Ui {
00132     class DisplayWidgetClass: public Ui_DisplayWidgetClass {};
00133 } // namespace Ui
00134
00135 QT_END_NAMESPACE
00136
00137 #endif // UI_DISPLAYWIDGET_H
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: example/DemoGUI/ui_mainwindow.h Source File

  • File List

example/DemoGUI/ui_mainwindow.h

00001 /********************************************************************************
00002 ** Form generated from reading UI file 'mainwindow.ui'
00003 **
00004 ** Created: Wed Sep 22 18:28:37 2010
00005 **      by: Qt User Interface Compiler version 4.6.2
00006 **
00007 ** WARNING! All changes made in this file will be lost when recompiling UI file!
00008 ********************************************************************************/
00009
00010 #ifndef UI_MAINWINDOW_H
00011 #define UI_MAINWINDOW_H
00012
00013 #include <QtCore/QVariant>
00014 #include <QtGui/QAction>
00015 #include <QtGui/QApplication>
00016 #include <QtGui/QButtonGroup>
00017 #include <QtGui/QHeaderView>
00018 #include <QtGui/QMainWindow>
00019 #include <QtGui/QMenuBar>
00020 #include <QtGui/QStatusBar>
00021 #include <QtGui/QTextEdit>
00022 #include <QtGui/QToolBar>
00023 #include <QtGui/QWidget>
00024
00025 QT_BEGIN_NAMESPACE
00026
00027 class Ui_MainWindow
00028 {
00029 public:
00030     QWidget *centralWidget;
00031     QTextEdit *textEdit;
00032     QMenuBar *menuBar;
00033     QToolBar *mainToolBar;
00034     QStatusBar *statusBar;
00035
00036     void setupUi(QMainWindow *MainWindow)
00037     {
00038         if (MainWindow->objectName().isEmpty())
00039             MainWindow->setObjectName(QString::fromUtf8("MainWindow"));
00040         MainWindow->resize(600, 400);
00041         centralWidget = new QWidget(MainWindow);
00042         centralWidget->setObjectName(QString::fromUtf8("centralWidget"));
00043         textEdit = new QTextEdit(centralWidget);
00044         textEdit->setObjectName(QString::fromUtf8("textEdit"));
00045         textEdit->setGeometry(QRect(40, 50, 104, 64));
00046         MainWindow->setCentralWidget(centralWidget);
00047         menuBar = new QMenuBar(MainWindow);
00048         menuBar->setObjectName(QString::fromUtf8("menuBar"));
00049         menuBar->setGeometry(QRect(0, 0, 600, 21));
00050         MainWindow->setMenuBar(menuBar);
00051         mainToolBar = new QToolBar(MainWindow);
00052         mainToolBar->setObjectName(QString::fromUtf8("mainToolBar"));
00053         MainWindow->addToolBar(Qt::TopToolBarArea, mainToolBar);
00054         statusBar = new QStatusBar(MainWindow);
00055         statusBar->setObjectName(QString::fromUtf8("statusBar"));
00056         MainWindow->setStatusBar(statusBar);
00057
00058         retranslateUi(MainWindow);
00059
00060         QMetaObject::connectSlotsByName(MainWindow);
00061     } // setupUi
00062
00063     void retranslateUi(QMainWindow *MainWindow)
00064     {
00065         MainWindow->setWindowTitle(QApplication::translate("MainWindow", "MainWindow", 0, QApplication::UnicodeUTF8));
00066     } // retranslateUi
00067
00068 };
00069
00070 namespace Ui {
00071     class MainWindow: public Ui_MainWindow {};
00072 } // namespace Ui
00073
00074 QT_END_NAMESPACE
00075
00076 #endif // UI_MAINWINDOW_H
Generated on Thu Sep 23 15:03:09 2010 for smf by doxygen 1.6.3


smf: example/smfclientapp/ui_posttestui.h Source File

  • File List

example/smfclientapp/ui_posttestui.h

00001 /********************************************************************************
00002 ** Form generated from reading UI file 'posttestui.ui'
00003 **
00004 ** Created: Wed Sep 22 18:28:30 2010
00005 **      by: Qt User Interface Compiler version 4.6.2
00006 **
00007 ** WARNING! All changes made in this file will be lost when recompiling UI file!
00008 ********************************************************************************/
00009
00010 #ifndef UI_POSTTESTUI_H
00011 #define UI_POSTTESTUI_H
00012
00013 #include <QtCore/QVariant>
00014 #include <QtGui/QAction>
00015 #include <QtGui/QApplication>
00016 #include <QtGui/QButtonGroup>
00017 #include <QtGui/QComboBox>
00018 #include <QtGui/QGridLayout>
00019 #include <QtGui/QHeaderView>
00020 #include <QtGui/QListWidget>
00021 #include <QtGui/QVBoxLayout>
00022 #include <QtGui/QWidget>
00023
00024 QT_BEGIN_NAMESPACE
00025
00026 class Ui_PostTestUiClass
00027 {
00028 public:
00029     QWidget *verticalLayoutWidget;
00030     QVBoxLayout *verticalLayout;
00031     QGridLayout *gridLayout;
00032     QComboBox *comboBox;
00033     QListWidget *listWidget;
00034
00035     void setupUi(QWidget *PostTestUiClass)
00036     {
00037         if (PostTestUiClass->objectName().isEmpty())
00038             PostTestUiClass->setObjectName(QString::fromUtf8("PostTestUiClass"));
00039         PostTestUiClass->resize(400, 300);
00040         verticalLayoutWidget = new QWidget(PostTestUiClass);
00041         verticalLayoutWidget->setObjectName(QString::fromUtf8("verticalLayoutWidget"));
00042         verticalLayoutWidget->setGeometry(QRect(10, 20, 371, 261));
00043         verticalLayout = new QVBoxLayout(verticalLayoutWidget);
00044         verticalLayout->setSpacing(6);
00045         verticalLayout->setContentsMargins(11, 11, 11, 11);
00046         verticalLayout->setObjectName(QString::fromUtf8("verticalLayout"));
00047         verticalLayout->setContentsMargins(0, 0, 0, 0);
00048         gridLayout = new QGridLayout();
00049         gridLayout->setSpacing(6);
00050         gridLayout->setObjectName(QString::fromUtf8("gridLayout"));
00051         comboBox = new QComboBox(verticalLayoutWidget);
00052         comboBox->setObjectName(QString::fromUtf8("comboBox"));
00053
00054         gridLayout->addWidget(comboBox, 1, 0, 1, 1);
00055
00056         listWidget = new QListWidget(verticalLayoutWidget);
00057         listWidget->setObjectName(QString::fromUtf8("listWidget"));
00058
00059         gridLayout->addWidget(listWidget, 2, 0, 1, 1);
00060
00061
00062         verticalLayout->addLayout(gridLayout);
00063
00064
00065         retranslateUi(PostTestUiClass);
00066
00067         QMetaObject::connectSlotsByName(PostTestUiClass);
00068     } // setupUi
00069
00070     void retranslateUi(QWidget *PostTestUiClass)
00071     {
00072         PostTestUiClass->setWindowTitle(QApplication::translate("PostTestUiClass", "PostTestUi", 0, QApplication::UnicodeUTF8));
00073         comboBox->clear();
00074         comboBox->insertItems(0, QStringList()
00075          << QApplication::translate("PostTestUiClass", "Retreive Post", 0, QApplication::UnicodeUTF8)
00076          << QApplication::translate("PostTestUiClass", "Post Scrap", 0, QApplication::UnicodeUTF8)
00077          << QApplication::translate("PostTestUiClass", "Post Scrap directed", 0, QApplication::UnicodeUTF8)
00078         );
00079     } // retranslateUi
00080
00081 };
00082
00083 namespace Ui {
00084     class PostTestUiClass: public Ui_PostTestUiClass {};
00085 } // namespace Ui
00086
00087 QT_END_NAMESPACE
00088
00089 #endif // UI_POSTTESTUI_H
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3


smf: example/smfclientapp/ui_smfclientapp.h Source File

  • File List

example/smfclientapp/ui_smfclientapp.h

00001 /********************************************************************************
00002 ** Form generated from reading UI file 'smfclientapp.ui'
00003 **
00004 ** Created: Wed Sep 22 18:28:33 2010
00005 **      by: Qt User Interface Compiler version 4.6.2
00006 **
00007 ** WARNING! All changes made in this file will be lost when recompiling UI file!
00008 ********************************************************************************/
00009
00010 #ifndef UI_SMFCLIENTAPP_H
00011 #define UI_SMFCLIENTAPP_H
00012
00013 #include <QtCore/QVariant>
00014 #include <QtGui/QAction>
00015 #include <QtGui/QApplication>
00016 #include <QtGui/QButtonGroup>
00017 #include <QtGui/QComboBox>
00018 #include <QtGui/QHeaderView>
00019 #include <QtGui/QLabel>
00020 #include <QtGui/QListWidget>
00021 #include <QtGui/QPushButton>
00022 #include <QtGui/QWidget>
00023
00024 QT_BEGIN_NAMESPACE
00025
00026 class Ui_SmfClientApp
00027 {
00028 public:
00029     QListWidget *listWidget;
00030     QComboBox *comboBox;
00031     QPushButton *pushButton;
00032     QLabel *label;
00033     QPushButton *pushButton_2;
00034
00035     void setupUi(QWidget *SmfClientApp)
00036     {
00037         if (SmfClientApp->objectName().isEmpty())
00038             SmfClientApp->setObjectName(QString::fromUtf8("SmfClientApp"));
00039         SmfClientApp->resize(340, 600);
00040         listWidget = new QListWidget(SmfClientApp);
00041         listWidget->setObjectName(QString::fromUtf8("listWidget"));
00042         listWidget->setGeometry(QRect(20, 230, 256, 271));
00043         comboBox = new QComboBox(SmfClientApp);
00044         comboBox->setObjectName(QString::fromUtf8("comboBox"));
00045         comboBox->setGeometry(QRect(20, 90, 201, 51));
00046         pushButton = new QPushButton(SmfClientApp);
00047         pushButton->setObjectName(QString::fromUtf8("pushButton"));
00048         pushButton->setGeometry(QRect(20, 150, 75, 51));
00049         label = new QLabel(SmfClientApp);
00050         label->setObjectName(QString::fromUtf8("label"));
00051         label->setGeometry(QRect(40, 19, 271, 51));
00052         pushButton_2 = new QPushButton(SmfClientApp);
00053         pushButton_2->setObjectName(QString::fromUtf8("pushButton_2"));
00054         pushButton_2->setGeometry(QRect(110, 150, 75, 51));
00055
00056         retranslateUi(SmfClientApp);
00057
00058         QMetaObject::connectSlotsByName(SmfClientApp);
00059     } // setupUi
00060
00061     void retranslateUi(QWidget *SmfClientApp)
00062     {
00063         SmfClientApp->setWindowTitle(QApplication::translate("SmfClientApp", "SmfClientApp", 0, QApplication::UnicodeUTF8));
00064         pushButton->setText(QApplication::translate("SmfClientApp", "Friends", 0, QApplication::UnicodeUTF8));
00065         label->setText(QApplication::translate("SmfClientApp", "Supported Social Networking Sites", 0, QApplication::UnicodeUTF8));
00066         pushButton_2->setText(QApplication::translate("SmfClientApp", "Posts", 0, QApplication::UnicodeUTF8));
00067     } // retranslateUi
00068
00069 };
00070
00071 namespace Ui {
00072     class SmfClientApp: public Ui_SmfClientApp {};
00073 } // namespace Ui
00074
00075 QT_END_NAMESPACE
00076
00077 #endif // UI_SMFCLIENTAPP_H
Generated on Thu Sep 23 15:03:10 2010 for smf by doxygen 1.6.3